%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Einleitung
Ansicht mit Navigationswerkzeuge

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema

Dokumentation

Stand 01 .01.2020

Dokumentiertes XML-Schema:

MODIFY_CONTENT_IDMP_3_0_0.xsd

Kontakt

DCC e. V.
Dr.-Ing. Olaf Plümer
E-Mail pluemer@vhk-herford.de
Telefon 0 52 21/12 65-37


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Grundstruktur des IDM-Schemas
Ansicht mit Navigationswerkzeuge
Einleitung > Grundstruktur des IDM-Schemas

Die Grundstruktur des IDMP-Schemas

Das Hauptelement T_MODIFY_CONTENT_CATALOG definiert, dass ein neuer, vollständiger Katalogdatenbestand bereitgestellt wird.

Das IDM-Schema ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Child-Elemente (siehe Abbildung 1) von T_MODIFY_CONTENT_CATALOG abgebildet werden.

Abbildung 1 - Child-Elemente von T_MODIFY_CONTENT_CATALOG

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.
Darüber hinaus referenzieren viele Datenbereiche auf den zugehörigen Basiskatalog.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

REF_CATALOG

In REF_CATALOG werden Informationen zum Basiskatalog hinterlegt.

GLOBAL_DEFINITION

Der Datenbereich GLOBAL_DEFINITION ist ein Datenpool für Informationen, die in den anderen Datenbereichen verwendet werden. Hier sind es die Detailinformationen in diesem Datenbestand gespeichert werden.

SERIES

In SERIES werden die veränderten handelsspezifischen Texte, Detailinformationen und Klassifizierungen für die Artikel des Basiskataloges hinterlegt. Dabei werden die Artikel in Produktgruppen wie beispielsweise Sessel oder Zwischenelemente gruppiert.

FEATURE_DEFINITION

In FEATURE_DEFINITION werden handelspezifische Texte und Detailinformationen für Varianteninformationen hinterlegt.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Elemente der Katalogstruktur
Ansicht mit Navigationswerkzeuge

Elemente der Katalogstruktur anlegen

Serieninformationen anlegen

Serien werden in folgendem Element definiert:

T_NEW_CATALOG/SERIES/SERIE

Alle Child-Elemente werden verwendet, um die Eigenschaften der Serien zu beschreiben. Varianten werden Serien über Prüfverfahren (RESTRICTION_REF) zugeordnet.

Varianten anlegen

Beispiel: Anlegen von Varianten

1. Definition der Varianteneigenschaften/ Variantenausprägungen

Die Varianteneigenschaften werden im folgenden Element definiert:

FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

</OPTION_DEFINITION>

In diesem Element werden die Ausprägungen von Farben, Materialien, Formvarianten und Maßen definiert.

2. Erstellen der Varianten

Die Varianten werden in folgendem Element erstellt:

FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_KEY="L"

</OPTION>

<OPTION OPTION_KEY="S"

</OPTION>

</OPTIONS>

</FEATURE>

Variantenarten werden über Variantenartennummern z. B. 1 definiert. Die Variante wird über die Kombination von FEATURE_NO in FEATURE_DEFINITION/FEATURES/FEATURE und OPTION_KEY in FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION eindeutig identifiziert.

Artikelinformationen anlegen

Artikelinformationen werden im folgenden Element angelegt:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Das Element ITEM besitzt eine Vielzahl von Elementen mit denen die Eigenschaften von Artikeln beschrieben werden können. Die Identifizierung eines Artikels erfolgt über das Attribut TYPE_NO.

Hierbei ist jedoch zu beachten, dass ein Artikel in Abhängigkeit der Serie unterschiedliche Eigenschaften haben kann. Demzufolge wird ein Artikel mit seinen Eigenschaften nur eindeutig in Verbindung mit der Serie identifiziert.

Serienspezifische Artikelinformationen

Artikel können in Anhängigkeit der Serie unterschiedliche Eigenschaften haben. Artikel sind einer Serie automatisch zugeordnet, da das Elemente ITEM ein Kind-Element des Elementes SERIE ist.

Varianteninformationen anlegen

Varianteninformationen werden im IDM-Schema wie nachfolgend beschrieben angelegt:

- Anlegen der Ausprägungen für die Varianten

- Zuordnen von Ausprägung und Variantenart

Anlegen der Ausprägungen

Die Ausprägungen für die Varianten werden als Datenpool in dem Element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert.

Abbildung 2 – Das Element OPTION_DEFINITION

Das Element OPTION_DEFINITION enthält Elemente, in denen die jeweiligen Ausprägungen angelegt werden:

MATERIAL | In diesem Element werden die Eigenschaften von Materialien mittels Farben und Texturen definiert. Diese Elemente werden aus Ausführungsvariantenarten referenziert.
OPTION_MEASURE | In diesem Element werden die Werte von Varianten hinterlegt, über die ein Maß angegeben wird (z. B. Sitzhöhe(Variantenart 35).

Beispiel: Ausprägungen für Farben

<OPTION_DEFINITION>

<MATERIAL>

<COLOR COLOR_NO="1">

<RGB_RED>255</RGB_RED>

<RGB_GREEN>0</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="2">

<RGB_RED>133</RGB_RED>

<RGB_GREEN>273</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="3">

<RGB_RED>0</RGB_RED>

<RGB_GREEN>89</RGB_GREEN>

<RGB_BLUE>89</RGB_BLUE>

</COLOR>

</MATERIAL>

</OPTION_DEFINITION>

Die obigen Elemente definieren drei Farben, die über die Nummern (COLOR_NO) 1-3 identifiziert werden.

Zuordnen von Ausprägung und Variantenart

Die beispielartig definierten Farben müssen, um sie nutzen zu können, Variantenarten zugeordnet werden, wodurch Varianten entstehen.

Die Zuordnung von Variantenarten (FEATURE) und Ausprägungen (OPTION) zu Varianten erfolgt im Element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE. Eine Variante wird durch die Kombination von FEATURE und OPTION gebildet und identifiziert. Die nachfolgenden XML-Elemente definieren 2 Fußhöhen (Variantenart 15).

Beispiel: Aufbau der Varianten aus Variantenart und Ausprägungen

<FEATURE FEATURE_NO="15">

<OPTIONS>

<OPTION OPTION_KEY="10">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

<OPTION OPTION_KEY="30">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

</OPTIONS>

<FEATURE_TEXT>

</FEATURE_TEXT>

<HEADER_POS_VARIATION_TYPE>K</HEADER_POS_VARIATION_TYPE>

</FEATURE>

Die Child-Elemente von FEATURE beschreiben die Eigenschaften der Variantenart und die Child-Elemente von OPTION beschreiben die Eigenschaften der Variante. Entsprechend diesem Prinzip, welches grundlegend für alle Elemente im IDM-Schema gilt, wird durch das Element OPTION_TEXT ein Text definiert, der die Variante bezeichnet. Das Element FEATURE_TEXT definiert einen Text, der die Variantenart bezeichnet.

Soll in den Daten eine Variante referenziert werden, muss immer die Kombination aus FEATURE_NO und OPTION_KEY als Referenzierungschlüssel angegeben werden.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Datentypen
Ansicht mit Navigationswerkzeuge
Einleitung > Datentypen

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

In der Version IDMP 2.4 werden folgende Datentypen verwendet:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDMP wird der Datentyp date XML-Schema konform in folgender Weise angewendet: YYYY-MM-DD Y = Jahr, M = Monat, D = Tag
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDMP für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.
anyURI | Der Datentyp wird im IDMP für die Darstellung einer URL verwendet. anyURI stellt einen Uniform Resource Identifier (URI) dar. Der lexikalische Bereich von anyURI ist eine endlich lange Zeichenkette, die einem legalen URI entspricht. Ein anyURI-Wert kann absolut oder relativ sein und darf Fragment-Bezeichner enthalten (z.B. könnte es eine URI-Refenz sein).
language | Der Datentyp wird im IDMP für die Darstellung von gültigen Sprachschlüsseln verwendet. language repräsentiert Bezeichner für natürliche Sprachen, wie sie in Tags for the Identification of Languages definiert werden. Der Wertebereich von language ist die Menge aller Zeichenketten, die einen gültigen Bezeichner einer natürlichen Sprache darstellen. Für ISO-normierte Sprachen besteht das Format i. A. aus einer Zeichenfolge von 2-3 kleinen Buchstaben optional gefolgt von einem Bindestrich und einem Ländercode bestehend aus 2 großen Buchstaben z. B. en-US.

Zusätzlich gibt es einen benutzerdefinierten Datentyp

operator

Der Datentyp wird im IDMP für Regeln genutzt. Mit diesem einfachen selbst definierten Datentyp wird ein Operator für Vergleiche formuliert. Der Vergleichsoperator stellt sich als string der Länge 1 bis 4 dar und kann der folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Die Wertebereiche der obigen Datentypen sind im Allgemeinen für die Elemente im IDMP eingeschränkt. Über "restrictions" bei der Datentypdefinition sind Minimal- und Maximalwerte, zulässige Zeichen (pattern) sowie Wertlisten eingeschränkt.

In der Dokumentation zum XML-Schema des IDMP sind die Wertebereiche durch die Angabe hinter M und P spezifiziert.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Erläuterung zur Dokumentation
Ansicht mit Navigationswerkzeuge
Einleitung > Erläuterung zur Dokumentation

Erläuterungen zur Dokumentation des IDMP

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

Beschreibung:

In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Variantenarten
Ansicht mit Navigationswerkzeuge
Einleitung > Variantenarten

Variantenarten

Folgende Variantenarten wurden definiert:

Varianten_Art | Varianten_Art_Text | Typ | Bemerkung / mögliche Ausprägungen
1 | Bezugsart | A |
2 | Hauptbezugsart | A |
3 | Hauptbezugsfarbe | F |
4 | Absatzbezugsausführung | A |
5 | Absatzbezugsfarbe | F |
6 | Rückenbezugsart | A |
7 | Rückenbezugsfarbe | F |
8 | Rückenbild | A | mit/ohne Kimme, mit/ohne Steppung etc.
9 | Sitzkissenausführung | A |
10 | Sitzkissenfarbe | F |
11 | Zierkissenausführung | A | lose, fest, rund, rechteckig, …
12 | Zierkissenfarbe | F |
13 | Kontrastfadenart / -ausführung | A |
14 | Kontrastfadenfarbe | F |
15 | Fußhöhe | A |
16 | Fußmaterial | A | Metall, Holz, Kunststoff, Buche, …
17 | Fußform | A | Kufe, Rehling, Einzelfuß, Rollen, Gleiter, …
18 | Fußfarbe | F |
19 | Holz- / Chatosenausführung | A |
20 | Holz- / Chatosenfarbe / -beizton | F |
21 | Behangausführung | A |
22 | Behangfarbe | F |
23 | Besatzausführung | A |
24 | Besatzfarbe | F |
25 | Seitentaschenausführung | A |
26 | Seitentaschenfarbe | F |
27 | Kederausführung | A |
28 | Kederfarbe | F |
29 | Drellausführung | A |
30 | Drellfarbe | F |
31 | Reissverschlussausführung | A |
32 | Reissverschlussfarbe | F |
33 | Sitzhärte, - qualität | A | mit /ohne Federkern, …
34 | Antriebsart | A | Schlaufe, manuell, Gasdruckfeder, Motor Netz, Motor Accu, Do
35 | Sitzhöhe | A |
36 | Sitztiefe | A |
37 | Sitzbreite | A |
38 | Rückenhöhe | A |
39 | Rückenkissenhöhe | A |
40 | Rückenkissenausführung | A |
41 | Armlehnen- / Seitenteilanordnung | A | ohne, links, rechts, beidseitig, …
42 | Armlehnen- / Seitenteilausführung | A |
43 | Seitenteilverstellung | A |
44 | Kopfstützenausführung | A | lose, fest, Nackenstütze, …
45 | Kopfstützenfarbe | F |
46 | Vorderblendenausführung | A | bodeneben, bodenfrei
47 | Stoffkombination | K |
48 | Brand- / Flammschutz | A |
49 | Liegeflächenausführung | A |
50 | Liegeflächenfarbe | F |
51 | Länderausführung | A |
52 | Querschläfer | A |
53 | Sitzneigungsverstellung | A |
54 | Sitztiefenverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
55 | Rückenverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
56 | Fußstützenverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
57 | Massagefunktion | A |
58 | Sitzheizung | A |
59 | Lordose | A |
60 | Drehgestell | A |
61 | Aufstehhilfe | A | Mechanisch, Elektromotorisch, Gasdruckfeder, …
62 | Klapptisch | A |
63 | Stecktisch | A |
64 | Ausziehtisch | A |
65 | Getränkehalter | A |
66 | Kopfteil | A | Form 1, Form 2 usw., Kopfteilkürzung gegen Mehrpreis, ohne K
67 | Kopfteilbezug | A |
68 | Tagesdecke | A | kurz, halblang, lang, Haube
69 | Tagesdeckenbezug | A |
70 | Liegefläche | A | 160x200, 180x200, 200x200 usw., Sonderlänge gegen Mehrpreis
71 | Bettkasten | A | Standard, Einlegevorrichtung, Highline usw.
72 | Bettkastenbezug | A |
73 | Lattenrost | A | Standard oder Alternativen gegen Mehrpreis, ggf. Einlegelatten
74 | Matratze | A | Standard oder Alternativen gegen Mehrpreis >> Härtegrad H2,
75 | Griffe (bei Konsolen) | F |
76 | Konsolen | A | Schub mit Kunststoff oder Metallführung
77 | Lampenfarbe und -ausführung | A |
78 | Knopfbezug | F |
79 | Lattenrostverstellung | A | Mechanisch, Elektromotorisch, Gasdruckfeder, mehrfach …
80 | Funktion / Verstellung allgemein | A |
81 | freie Variantenart | F |
82 | freie Variantenart | F |
83 | freie Variantenart | F |
84 | freie Variantenart | F |
85 | freie Variantenart | F |
86 | freie Variantenart | F |
87 | freie Variantenart | F |
88 | freie Variantenart | F |
89 | Anschlusstyp L | P | ID des Anschlussvektors in der SVG: AVL
90 | Anschlusstyp R | P | ID des Anschlussvektors in der SVG: AVR
91 | Anschlusstyp Custom 1 | P | ID des Anschlussvektors in der SVG: AVC01
92 | Anschlusstyp Custom 2 | P | ID des Anschlussvektors in der SVG: AVC02
93 | Anschlusstyp Custom 3 | P | ID des Anschlussvektors in der SVG: AVC03
94 | Anschlusstyp Custom 4 | P | ID des Anschlussvektors in der SVG: AVC04
95 | Planungsbreite | P | Breite des Artikels
96 | Planungstiefe | P | Tiefe des Artikels
97 | Planungshöhe | P | Höhe des Artikels
98 | Antriebsposition | A |
99 | Tischfarbe | F |
100 | Kopfteilverstellung | A |
101 | Relaxfunktion | A |
102 | Vitalfunktion | A |
103 | Stromquelle/Motor | A |
104 | Zubehör | A |
105 | Auflagetisch | A |
106 | Rückenhalter | A |
107 | Steckrücken | A |
108 | Zwischentisch | A |
109 | Zeitschriftenablage | A |
110 | Schwenkfunktion | A |
111 | Leseleuchte | A |
112 | Decoartikel | A |
150 | Anschlusstyp Custom 5 | P | ID des Anschlussvektors in der SVG: AVC05
151 | Anschlusstyp Custom 6 | P | ID des Anschlussvektors in der SVG: AVC06
152 | Anschlusstyp Custom 7 | P | ID des Anschlussvektors in der SVG: AVC07
153 | Anschlusstyp Custom 8 | P | ID des Anschlussvektors in der SVG: AVC08
154 | Anschlusstyp Custom 9 | P | ID des Anschlussvektors in der SVG: AVC09
155 | Anschlusstyp Custom 10 | P | ID des Anschlussvektors in der SVG: AVC10
160 | Anschlusstyp Oben 1 | P | ID des Anschlussvektors in der SVG: AVO1
161 | Anschlusstyp Oben 2 | P | ID des Anschlussvektors in der SVG: AVO2
162 | Anschlusstyp Oben 3 | P | ID des Anschlussvektors in der SVG: AVO3
163 | Anschlusstyp Oben 4 | P | ID des Anschlussvektors in der SVG: AVO4
164 | Anschlusstyp Oben 5 | P | ID des Anschlussvektors in der SVG: AVO5
165 | Anschlusstyp Unten 1 | P | ID des Anschlussvektors in der SVG: AVU1
166 | Anschlusstyp Unten 2 | P | ID des Anschlussvektors in der SVG: AVU2
167 | Anschlusstyp Unten 3 | P | ID des Anschlussvektors in der SVG: AVU3
168 | Anschlusstyp Unten 4 | P | ID des Anschlussvektors in der SVG: AVU4
169 | Anschlusstyp Unten 5 | P | ID des Anschlussvektors in der SVG: AVU5
170 | Anschlusstyp Oben 6 | P | ID des Anschlussvektors in der SVG: AVO6
171 | Anschlusstyp Oben 7 | P | ID des Anschlussvektors in der SVG: AVO7
172 | Anschlusstyp Oben 8 | P | ID des Anschlussvektors in der SVG: AVO8
173 | Anschlusstyp Oben 9 | P | ID des Anschlussvektors in der SVG: AVO9
174 | Anschlusstyp Oben 10 | P | ID des Anschlussvektors in der SVG: AVO10
175 | Anschlusstyp Unten 6 | P | ID des Anschlussvektors in der SVG: AVU6
176 | Anschlusstyp Unten 7 | P | ID des Anschlussvektors in der SVG: AVU7
177 | Anschlusstyp Unten 8 | P | ID des Anschlussvektors in der SVG: AVU8
178 | Anschlusstyp Unten 9 | P | ID des Anschlussvektors in der SVG: AVU9
179 | Anschlusstyp Unten 10 | P | ID des Anschlussvektors in der SVG: AVU10
180 | Anschlusstyp Custom 1N | P | ID des Anschlussvektors in der SVG: AVC01N
181 | Anschlusstyp Custom 2N | P | ID des Anschlussvektors in der SVG: AVC02N
182 | Anschlusstyp Custom 3N | P | ID des Anschlussvektors in der SVG: AVC03N
183 | Anschlusstyp Custom 4N | P | ID des Anschlussvektors in der SVG: AVC04N
184 | Anschlusstyp Custom 5N | P | ID des Anschlussvektors in der SVG: AVC05N
185 | Anschlusstyp Custom 6N | P | ID des Anschlussvektors in der SVG: AVC06N
186 | Anschlusstyp Custom 7N | P | ID des Anschlussvektors in der SVG: AVC07N
187 | Anschlusstyp Custom 8N | P | ID des Anschlussvektors in der SVG: AVC08N
188 | Anschlusstyp Custom 9N | P | ID des Anschlussvektors in der SVG: AVC09N
189 | Anschlusstyp Custom 10N | P | ID des Anschlussvektors in der SVG: AVC10N
190 | Anschlusstyp Custom 1S | P | ID des Anschlussvektors in der SVG: AVC01S
191 | Anschlusstyp Custom 2S | P | ID des Anschlussvektors in der SVG: AVC02S
192 | Anschlusstyp Custom 3S | P | ID des Anschlussvektors in der SVG: AVC03S
193 | Anschlusstyp Custom 4S | P | ID des Anschlussvektors in der SVG: AVC04S
194 | Anschlusstyp Custom 5S | P | ID des Anschlussvektors in der SVG: AVC05S
195 | Anschlusstyp Custom 6S | P | ID des Anschlussvektors in der SVG: AVC06S
196 | Anschlusstyp Custom 7S | P | ID des Anschlussvektors in der SVG: AVC07S
197 | Anschlusstyp Custom 8S | P | ID des Anschlussvektors in der SVG: AVC08S
198 | Anschlusstyp Custom 9S | P | ID des Anschlussvektors in der SVG: AVC09S
199 | Anschlusstyp Custom 10S | P | ID des Anschlussvektors in der SVG: AVC10S
200 | freie Variantenart | F |
201 | freie Variantenart | F |
202 | freie Variantenart | F |
203 | freie Variantenart | F |
204 | freie Variantenart | F |
205 | freie Variantenart | F |
206 | freie Variantenart | F |
207 | freie Variantenart | F |
208 | freie Variantenart | F |
209 | freie Variantenart | F |
210 | freie Variantenart | F |

Ab 200 bis 999 stehen freie Variantenarten zur Verfügung.

Typ: A = Ausführung

F = Farbe

P = Planung


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Typenschlüssel
Ansicht mit Navigationswerkzeuge

Typenschlüssel

Der Typenschlüssel wird in folgendem Element hinterlegt:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE

Folgende Typenschlüssel wurden definiert:

Typ-Nr. | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Sessel / Hochlehnsessel | Floor cupboard
2 | Clubchair | Tal cupboard
3 | TV-Sessel / Ruhe- / Liege- / Relaxsessel | Hanging/wall cupboard
4 | Longchair | Work-top mounted cupboard
5 | Sofa / Canapé | Recess kit
6 | Zwischenelement | Highboard/ Intermediate element
7 | Ecke / Trapezteil | Corner / trapezoidal element
8 | Einzelliege / Recamiere / Ottomane / Cheselon / Chaiselongue | Single daybed / recamiere / otoman / cheselon / chaiselounge
9 | Hocker | Front element
10 | Kissen | Cushions
11 | Couchtisch / Anstelltische / Stecktische ... | Cornice profile
12 | Esstisch | Pelmet
13 | Kombinationen | Top facing
14 | Abschlusselement | End unit/Plinth filler
15 | Bettsofa / Bettcouch / Liegesofa / Schlafelement / Polsterliegen | Plinth board
16 | Sitzbank, Essplatzbank, Dinnersofa, ... | Bench, dining table bench, dining sofa, ...
17 | Stühle | Work-top
18 | Fußbank | Wall end moulding
19 | Kopfstütze | Covering plate
20 | Leuchten | Canopy
21 | Teppiche | Over shelf
22 | Zubehör / Kleinteile | Construction shelf
23 | Polsterbetten / Polsterbett-Systeme | Sofa beds / sofa bed systems/ Chimney
24 | Polsterbettgestelle | Sofa bed frames/ Chimney
25 | Metrage | Metrage
26 | Sonstiges | Miscellaneous/Appliance


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Katalogstruktur
Ansicht mit Navigationswerkzeuge

Katalog- und Elementstruktur

Die Katalogstruktur wird im IDM-Schema durch die folgende Elementhierarchie abgebildet:

Abbildung 1 – Elementhierarchie im IDM-Schema

In dem Element SERIE werden die Eigenschaften einer Serie definiert. Innerhalb der Serie werden Produktgruppen (PRODUCT_GROUPS) definiert, in denen Artikel (ITEMS) mit gleichartigen Variantenarten zusammengefasst sind. Die Artikel sind einer Serie automatisch zugeordnet, da sie Kind-Elemente des Elementes SERIE sind. Über die Elemente DECISIONS werden serienübergreifend, einer Serie, einer Produktgruppe oder einem Artikel Varianten über Regeln zugeordnet. Zusätzlich ist es möglich, den über DECISIONS formulierten Regeln Aktionen (ACTIONS) zuzuordnen.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Aufbauen der Katalogstruktur
Ansicht mit Navigationswerkzeuge

Aufbauen der Katalogstruktur

Varianten Serien zuordnen

Varianten werden allen Serien in folgendem Element zugeordnet:

SERIES/DECISIONS/DECISION_REF

Die Variante wird der Serie zugeordnet, in dem eine Regel referenziert wird, welches die Variante als gültige Kombination definiert in dem Element SERIES/SERIE/DECISIONS/DECISION_REF.

Artikel, Serien und Varianten zuordnen

Artikel-Serien Zuordnung

Artikel werden Serien automatisch zugeordnet, da das Element ITEM ein Kind-Element des Elementes SERIES ist:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Es können Artikelspezifisch Regeln über SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISIONS_REF formuliert werden.

Beispiel: Regel zur Varianten-Zuordnung

Element: FEATURE_DEFINITION/DECISIONS/DECISION

<DECISIONS>
<DECISIONVALIDATION_TYPE="0"DECISION_NO="1">
<DECISION_NAME_TEXT>
<LANGUAGEISO_LANGUAGE_ID="EN">
<TEXT_LINESEQUENCE_NO="1">
<TEXT>item numbers</TEXT>
</TEXT_LINE>
</LANGUAGE>
</DECISION_NAME_TEXT>
<OPTION_COMBINATIONSEQUENCE="1">
<FEATURE_REFFEATURE_NO="1">
<OPTION_REF_OPOPTION_KEY="1"OPERATOR="eq"/>
</FEATURE_REF>
<FEATURE_REFFEATURE_NO="201">
<OPTION_REF_OPOPTION_KEY="0"OPERATOR="eq"/>
</FEATURE_REF>
<FEATURE_REFFEATURE_NO="202">
<OPTION_REF_OPOPTION_KEY="00"OPERATOR="eq"/>
</FEATURE_REF>
<ACTIONS>
<SET_FEATURE_FIXEDFEATURE_NO="204">
<OPTION_REFOPTION_KEY="1000"/>
</SET_FEATURE_FIXED>
</ACTIONS>
</OPTION_COMBINATION>
</DECISION>
</DECISIONS>


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Referenzierung
Ansicht mit Navigationswerkzeuge

Referenzierung von Elementen

Im IDM-Schema werden Beziehungen zwischen Elementen aufgebaut und Informationen an zentraler Stelle definiert und an anderer Stelle mehrfach verwendet. Die Wiederverwendung der Informationen und der Aufbau von Elementbeziehungen erfolgt über Referenzierung. Die im IDM-Schema angewendete Art der Referenzierung wird nachfolgend beschrieben.

Begriffsdefinition

Im IDM-Schema werden für die Referenzierung von Elementen folgende Begriffe verwendet:

Key-Element | Ein XML-Element, welches von anderen Elementen referenziert wird.
Ref-Element | Ein XML-Element, welches andere Elemente referenziert.

Vorgang der Referenzierung

Das Key-Element besitzt Attribute, über die es eindeutig identifiziert wird. Das Ref-Element besitzt minimal die Key-Attribute des Key-Elementes. Zwischen den Elementen wird die Referenz aufgebaut, in dem die Attributwerte des Ref-Elementes denen des Key-Elementes entsprechen.

Beispiel: Referenzierung der Regel serienübergreifend, aus der Serie, der Produktgruppe und dem Artikel

Das nachfolgende Beispiel zeigt, wie von einem Artikel (ITEM) eine Regel (DECISION) referenziert wird. Die XML-Elemente sind nur auszugsweise dargestellt.

Key-Element

T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS

<DECISIONS>

<DECISION DECISION_NO="1"/> … </DECISION>

<DECISION DECISION_NO="2"/> … </DECISION>

<DECISION DECISION_NO="3"/> … </DECISION>

. . .

</DECISIONS>

Ref-Element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS>

<ITEM TYPE_NO="1111">

<DECISIONS>

<DECISION_REF DECISION_NO="1" > … </DECISION_REF>

. . .

</ITEMS>

Beispiel: Referenzierung einer Varianten

Im folgenden Beispiel wird eine Variante aus einem Prüfverfahren heraus referenziert.

Key-Element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="15"> <!-- Fußhöhe -->

<OPTIONS>

<OPTION OPTION_KEY="100"> … </OPTION>

<OPTION OPTION_KEY="120"> … </OPTION>

<OPTION OPTION_KEY="30"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="17"> <!-- Fußform -->

<OPTIONS>

<OPTION OPTION_KEY="F00"> … </OPTION>

<OPTION OPTION_KEY="F3Z"> … </OPTION>

<OPTION OPTION_KEY="F70"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

Die XML-Elemente definieren für die Variantenart 15 (FEATURE) drei Varianten (OPTION) mit den Schlüsseln 100,120,30 sowie für die Variantenart 17 drei Varianten mit den Schlüsseln F00, F3Z, F70. Eine Variante wird identifiziert über die Kombination FEATURE_NO und OPTION_KEY.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Pruefverfahren
Ansicht mit Navigationswerkzeuge

Definition und Zuordnung von Regeln

Die früheren Prüfungen (RESTRICTIONS) werden jetzt vollständig durch Regeln (DECISIONS) ersetzt.

Eine Zuordnung der Regeln/Prüfverfahren zu Serien oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien oder Artikeln referenziert werden.

Regeln, die von Artikeln referenziert werden, haben Vorrang gegenüber den Regeln, die von Serien referenziert werden.

Bei den DECISIONS findet man 3 Typen von Regeln (über die TEST_ID gekennzeichnet).

Abhängig von dem Element TEST_ID können unterschiedliche Regeln formuliert werden.

Ist der Wert von TEST_ID 1, handelt es sich um eine Erstellungsregel (Preparation Rule).

Hierüber können nun Mengen von gültigen Varianten in OPTION_COMBINATION definiert werden. Diese finden Anwendung, wenn man die gültigen Varianten zu einer Variantenart ermitteln möchte. Diese Regeln besitzen keinen Aktionsteil („ACTIONS“) und sie bestimmen eine Menge von Variantenkombinationen, die entweder wahr oder falsch sind. Dabei handelt es sich um eine Tabelle, deren Spaltenüberschriften die Variantenarten (FEATURES) sind und deren Zelleninhalte Werte, Listen, Intervalle, Variantengruppen sind, die durch Mengenoperatoren miteinander verknüpft sind.

Die Bedingungen wurden um Operatoren ergänzt. Hierfür wurde ein extra Datentyp definiert. Dieser kann folgende Werte enthalten:

eq (ist gleich)

ne (ist nicht gleich)

in (ist enthalten in einer Menge)

nin (ist nicht enthalten in der Menge)

gt (größer)

lt (kleiner)

ge (größer gleich)

le (kleiner gleich)

Die einzelnen OPTION_COMBINATIONs sind allerdings als ELSE Zweige zu betrachten. Das heißt, sobald eine Bedingungszeile (OPTION_COMBINATIONS) einen Treffer bekommen hat, werden die anderen nicht mehr durchlaufen.

Ist der Wert von TEST_ID 2, handelt es sich um eine Aktionsregel (Action Rule). Hier können zusätzlich zu den Bedingungen noch Aktionen definiert werden.

Wenn alle Bedingungen innerhalb einer „OPTION_COMBINATION“ erfüllt sind, dann werden alle zugeordneten Aktionen (ACTIONS) ausgeführt, die abhängig von Bedingungen Werte setzen oder auch Variantenarten (FEATURES) ausblenden können. Ist eine OPTION_COMBINATION erfüllt, werden auch hier die anderen Bedingungen nicht mehr durchlaufen.

Aktionen (ACTIONS) sind Anweisungen, die ausgeführt werden, wenn eine Bedingung erfüllt ist. Folgende Aktionen können ausgeführt werden:

  • Das Setzen von Varianten (SET_FEATURE_FIXED) mit folgenden Möglichkeiten:

§ Direkt, wie z.B. Haupstoff = „blau“ (OPTION)

§ das Setzen von Variantenwerten aus einer anderen Variantenart (FEATURE) wie z.B Absatzstoff = Hauptstoff

§ das Rechnen von Varianten (z.B. Sitzhöhe + 5cm).
Diese Funktion steht allerdings nur für Maßvarianten zur Verfügung und geschieht über einen Formelstring, der Parameter und Werte enthalten darf.
Hierzu muss vorher die Variantenart (z.B. Sitzhöhe) einmal mit einem Parameter versehen werden (z.B. „sh“).
Dem Maßparameter (MEASURE_PARAMETER) kann noch eine Einheit (MEASURE_UNIT) mit gegeben werden. In der Formel (FORMULA_STRING) tauchen somit nur die Parameter auf (z.B. Planungsbreite = 2*st + sb, was bedeutet, dass die Planungsbreite sich aus der Sitzbreite + 2 mal der Seitenteilbreite ergibt)

  • Das Setzen von Defaultvarianten (SET_FEATURE_DEFAULT):
    Diese können dann gefüllt werden, wenn noch kein Wert eingegeben wurde. Hier gelten die gleichen Möglichkeiten wie oben.
  • Die Sichtbarkeit von Variantenarten (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) bzw. das Wegschalten von Regeln (DISABLE_DECISION, ENABLE_DECISION):
    So kann z.B. bei Holzfüssen eine eventuell vorhandene Variantenart für einen Beizton eingeblendet werden und bei Auswahl eines Metallfußes eventuell wieder ausgeblendet werden.

Action Rules werden im Konfigurator meistens genutzt, wenn sich ein Optionswert (eine Variante) ändert. So kann z.B. dann, wenn sich die Fußvariante von Edelstahl auf Holz ändert, eine Variantenart für den Beizton angezeigt werden.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Sprachenschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprache
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharisch
AN | Aragonesisch
AR | Arabisch
AS | Assamesisch
AV | Avarisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Belorussisch
BG | Bulgarisch
BH | Bihari
BI | Bislama
BM | Bambara
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CR | Cree
CS | Tschechisch
CU | Alt-Slawisch
CV | Tschuwaschisch
CY | Walisisch
DA | Dänisch
DE | Deutsch
DV | Dhivehi
DZ | Dzongkha
EE | Ewe
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FF | Fulfulde
FI | Finnisch
FJ | Fidschianisch
FO | Färöisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
GV | Manx, Manx-Gälisch
HA | Hausa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HT | Haitianisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiaq
IN | Ehemalig Indonesisch
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut (Eskimosprache)
JA | Japanisch
JV | Javanisch
KA | Georgisch
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KR | Kanuri
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KW | Kornisch
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LG | Luganda
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LU | Kiluba
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Holländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VE | Tshivenda
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu

Nach ISO-Norm werden die Sprachenschlüssel im Allgemeinen mit kleinen Buchstaben geschrieben. Für die IDM-Daten sind große Buchstaben beschlossen.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Länderschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Länderschlüssel

Länderkennzeichen | Ländername(deutsch) | Ländername(englisch)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Typen für Detailinformationen
Ansicht mit Navigationswerkzeuge
Einleitung > Typen für Detailinformationen

Für die Beschreibung der Art der Detailinformation gibt es folgende Info-Typen:

1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Erläuterung zur Dokumentation
Ansicht mit Navigationswerkzeuge


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
MODIFY_CONTENT_IDMP_3_0_0.xsd
Ansicht mit Navigationswerkzeuge
Beschreibung

Diese Dokumentation dient der Beschreibung der Erweiterungsdatei bezüglich handelsspezifischer Texte, Detailinformationen und Klassifizierungen für Polsterkataloge

Elemente
Element | Beschreibung
T_MODIFY_CONTENT_CATALOG | Dieses Element bietet den Einstieg für veränderte Texte und Bezeichnungen, handelsspezifische Medien oder zusätzliche Klassifizierungen bezogen auf einen Katalog im IDMP-Format. Hersteller dieser Daten kann sowohl der Handel als auch die Verbände u. Ä. sein, die für die Artikel und Varianten angepasste Texte, Medien bzw. Klassifizierungen transferieren möchten. Diese Texte und Medien sind nur für den Verkauf relevant, für Bestellungen müssen die Texte und Bezeichnungen des Original-Katalogs im IDMP-Format genutzt werden. Werden an einem Element Medien in dem Datenbestand referenziert, müssen bei der Referenzierung alle relevanten Medien angegeben werden, auch die, die vom Originalkatalog genutzt werden sollen. Das gilt insbesondere auch für Magnetplanerinformationen.
Komplexe Typen
Complex Type | Beschreibung
languagetext | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.
languagetext30 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
languagetext40 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.
languagetext60 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.

© 2020 All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Elementreferenz
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > Elementreferenz


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Einfache Datentypen
Ansicht mit Navigationswerkzeuge

Für die Formulierung bestimmter Bedingungen wurde ein eigener Datentyp operator geschaffen


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
T_MODIFY_CONTENT_CATALOG Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd : T_MODIFY_CONTENT_CATALOG Element
Beschreibung
Dieses Element bietet den Einstieg für veränderte Texte und Bezeichnungen, handelsspezifische Medien oder zusätzliche Klassifizierungen bezogen auf einen Katalog im IDMP-Format. Hersteller dieser Daten kann sowohl der Handel als auch die Verbände u. Ä. sein, die für die Artikel und Varianten angepasste Texte, Medien bzw. Klassifizierungen transferieren möchten. Diese Texte und Medien sind nur für den Verkauf relevant, für Bestellungen müssen die Texte und Bezeichnungen des Original-Katalogs im IDMP-Format genutzt werden. Werden an einem Element Medien in dem Datenbestand referenziert, müssen bei der Referenzierung alle relevanten Medien angegeben werden, auch die, die vom Originalkatalog genutzt werden sollen. Das gilt insbesondere auch für Magnetplanerinformationen.
Namensraum (none)
Diagramm
FEATURE_DEFINITION Element SERIES Element GLOBAL_DEFINITION Element REF_CATALOG Element CATALOG Element Sequence T_MODIFY_CONTENT_CATALOG Element
Overview
T_MODIFY_CONTENT_CATALOG
Dieses Element bietet den Einstieg für veränderte Texte und Bezeichnungen, handelsspezifische Medien oder zusätzliche Klassifizierungen bezogen auf einen Katalog im IDMP-Format. Hersteller dieser Daten kann sowohl der Handel als auch die Verbände u. Ä. sein, die für die Artikel und Varianten angepasste Texte, Medien bzw. Klassifizierungen transferieren möchten. Diese Texte und Medien sind nur für den Verkauf relevant, für Bestellungen müssen die Texte und Bezeichnungen des Original-Katalogs im IDMP-Format genutzt werden. Werden an einem Element Medien in dem Datenbestand referenziert, müssen bei der Referenzierung alle relevanten Medien angegeben werden, auch die, die vom Originalkatalog genutzt werden sollen. Das gilt insbesondere auch für Magnetplanerinformationen.
MAJOR required Restriction of xs:positiveInteger
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION. 		D positiveInteger
P
M [3:3]
MINOR required Restriction of xs:nonNegativeInteger
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:0]
REVISION required Restriction of xs:nonNegativeInteger
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt. D nonNegativeInteger
P
M [0:0]
FORMAT required Restriction of xs:string
In diesem Element wird das Kennzeichen für die Herstellerbranche angegeben. Derzeit sind folgende Branchenkennzeichen definiert:

A = Arbeitsplattenhersteller
B = Badmöbelhersteller
G = Gerätehersteller
K = Küchenmöbelhersteller
O = Büromöbelhersteller
P = Polstermöbelhersteller
S = Sanitärhersteller
W = Wohnmöbelhersteller
Z = Zubehörhersteller 		D string
P [ABGKOPSWZ]
M [1:1]
Sequence
CATALOG
In diesem Element werden administrative Informationen zum Datenbestand hinterlegt.
Sequence
CATALOG_IDENTIFICATION
In diesem Element werden identifizierende Merkmale des Kataloges hinterlegt.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten müssen identisch sein.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
CATALOG_NAME languagetext30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
CATALOG_MERGE_TYPE optional xs:boolean

Dieses Element CATALOG_MERGE_TYPE ist optional und vom Datentyp boolean mit folgenden Werten:

0: entspricht dem Wert, wenn das Element nicht vorhanden ist und bedeutet, dieser Katalog muss nicht Bestandteil eines Multiherstellerkataloges sein.

1: Dieser Katalog ist immer Bestandteil eines Multiherstellerkataloges.

 D boolean
P
M
CATALOG_DATA_VERSION optional Restriction of xs:date
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
CATALOG_INFO optional languagetext Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
CATALOG_ID Restriction of xs:string

Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
CATALOG_VERSION Restriction of xs:positiveInteger
Hier kann der Hersteller des Datenbestandes eine Versions-Nr. für den Katalog vergeben. Wird zu einem Basiskatalog ein neuer Modifizierungsdatenbestand herausgegeben, muss der Wert von CATALOG_VERSION hoch gezählt werden. D positiveInteger
P
M [1:999999999]
FALL_BACK_LANGUAGE Restriction of xs:language
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO- Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
DETAIL_INFOS optional
Dieses Element dient der veränderten Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos bzw. eines speziellen Labels.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
RECEIVER_ID xs:string
Hier wird die ID des Empfängers eingetragen. D string
P
M
REF_CATALOG
Hier wird der Katalog, auf den sich die modifizierten Texte beziehen, über die GLN des Herstellers und die CATALOG_ID des Basiskataloges referenziert.
SUPPLIER_GLN_NO required Restriction of xs:string
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) des Herstellers des Basiskataloges eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch. D string
P [0-9]{13}
M
CATALOG_ID required Restriction of xs:string

Hier wird die eindeutige ID (z.B.GUID) des Herstellers eingeben, um den BasisKatalog eindeutig zu referenziern. Sie muss den gleichen Wert wie die CATALOG_ID unterhalb von CATALOG im Basiskatalog haben.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Sequence
CATALOG_DATA_VERSION Restriction of xs:date
In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf die sich die Zusatzpreise beziehen. D date
P
M
CATALOG_VERSION Restriction of xs:positiveInteger
Hier wird dieVersions-Nr. des Basiskataloges angegeben. D positiveInteger
P
M [1:999999999]
GLOBAL_DEFINITION optional
In diesem Element werden für den Datenbestand gültige Daten (globale Informationen) hinterlegt.
Sequence
DETAIL_INFOS optional
In diesem Element werden für den Datenbestand als globale Informationen die Detail-Informationen (Medien) hinterlegt.
Sequence
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:14]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
SERIES

In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren zugeordneten Elementen wie beispielsweise Produktgruppen oder Artikeln hinterlegt, an denen veränderte Texte, Detailinformationen oder zusätzliche Klassifizierungen hinterlegt werden.

Eine Serie entspricht im Allgemeinen einem Modell.

Sequence
SERIE 1..1000000
In diesem Element wird eine Serie mit ihren entsprechenden Artikeln gespeichert. Einen Serie entspricht einem Modell. Die Angaben der Nummern und Bezeichnungen müssen denen des Basiskataloges entsprechen.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie des Basiskataloges angegeben. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
Dieses Attribut gibt die Möglichkeit, Serien mit einer selbstdefinierten Sortierreihenfolge anzulegen.
Wird für eine Serie eine SEQUENCE_NO angegeben, muss für alle Serien eine SEQUENCE_NO angegeben werden. Sie muss dem Basiskatalog entsprechen. 		D positiveInteger
P
M
Sequence
SERIES_NAME
Dieses Element gibt den Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PRODUCT_GROUPS
In diesem Element werden Produktgruppen gespeichert. Sie müssen denen des Basiskataloges entsprechen. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Polstermöbel mit Armlehne).
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind.
Sequence
ITEMS

In diesem Element werden alle Artikel einer Produktgruppe angegeben, für die die Texte, Detailinformationen oder Klassifizierungen handelspezifisch verändert werden.

Sequence
ITEM 1..∞

In diesem Element werden Artikel entsprechend des Basiskataloges gespeichert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 2).

Pfad 1: SERIES/SERIE/SERIE_NO
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

DETAIL_INFOS optional
In diesem Element können handelsspezifische mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks für die Serie hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
FEATURE_DEFINITION
In diesem Element werden variantenabhängige Informationen, die gegenüber dem Basiskatalog handelspezifisch verändert werden, hinterlegt. Diese Veränderungen dürfen sich nur für den Verkauf auswirken, nicht für die Bestellung.
Sequence
FEATURES

In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten angegeben, für die eine handelsspezifische Veränderung vorgenommen wird. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Datenbestandes erforderlich sind.

Weitere Erläuterungen zu den Variantenarten sind zu finden in der Einleitung im Abschnitt " Variantenarten"

Sequence
FEATURE 1..∞
In diesem Element wird eine Variantart aus dem Basiskatalog handelspezifisch aufbereitet.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. Die Nummer muss der des Basiskataloges entsprechen. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen handelspezifisch zu ändernden Ausprägungen einer Variantenart hinterlegt werden.
Sequence
OPTION 1..∞
In diesem Element wird eine Variante für die übergeordnete Variantenart abgelegt.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung aus dem Basiskatalog referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen, die dem Basiskatalog entsprechen muss. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein handelsspezifischer Variantentext definiert. Für Bestellungen muss der Originaltext genutzt werden.
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein handelsspezifischer allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.
DETAIL_INFOS optional
Dieses Element dient der Zuordnung von veränderten Medien. Es ist möglich einer Variante mehrere Detail-Informationen zuzuordnen, und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild nur in der entsprechenden Serie oder beim bestimmten Artikel angezeigt.
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
Dieses Element enthält handelsspezifische Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben. Sie muss dem Basiskatalog entsprechen.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten des Basiskataloges(HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ des Basiskataloges 		D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MAJOR Restriction of xs:positiveInteger required
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION. 		D positiveInteger
P
M [3:3]
MINOR Restriction of xs:nonNegativeInteger required
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:0]
REVISION Restriction of xs:nonNegativeInteger required
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt. D nonNegativeInteger
P
M [0:0]
FORMAT Restriction of xs:string required
In diesem Element wird das Kennzeichen für die Herstellerbranche angegeben. Derzeit sind folgende Branchenkennzeichen definiert:

A = Arbeitsplattenhersteller
B = Badmöbelhersteller
G = Gerätehersteller
K = Küchenmöbelhersteller
O = Büromöbelhersteller
P = Polstermöbelhersteller
S = Sanitärhersteller
W = Wohnmöbelhersteller
Z = Zubehörhersteller 		D string
P [ABGKOPSWZ]
M [1:1]
Quelle
<xs:element name="T_MODIFY_CONTENT_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version 2.3 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetext30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FILE_ID">
              <xs:annotation>
                <xs:documentation>100--14--Datei_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MARK">
              <xs:annotation>
                <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BKVF]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
                <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_DATA_VERSION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>110--3--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_ID">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Katalog_ID
                /Hermann Balke 9.06.2013
                neu in 2.3
                hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren
                </xs:documentation>
                <xs:documentation> minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="64" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_VERSION">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
                <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FALL_BACK_LANGUAGE">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
                <xs:documentation>K. Richter 15.08.2017</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
                <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW  </xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW </xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RECEIVER_ID" type="xs:string" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="REF_CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CATALOG_DATA_VERSION">
              <xs:annotation>
                <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_VERSION">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
                <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SUPPLIER_GLN_NO" use="required">
            <xs:annotation>
              <xs:documentation>GLN des Herstellers</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9]{13}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="CATALOG_ID" use="required">
            <xs:annotation>
              <xs:documentation>Katalogidentifikator</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="64" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="GLOBAL_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASSIFICATION">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INFO_TYPE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
12.02.2013/Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:maxInclusive value="14" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="URL">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT" type="xs:anyURI">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="HASH_VALUE">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="32" />
                                          <xs:maxLength value="32" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="LAYER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-6]0" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE" maxOccurs="1000000">
              <xs:annotation>
                <xs:documentation>200--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>maxOccours geändert, K.Richter 23.11.2015</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIES_NAME">
                    <xs:annotation>
                      <xs:documentation>200--3--Serienname</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>200--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>200--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRODUCT_GROUPS">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEMS">
                                <xs:annotation>
                                  <xs:documentation>400--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ITEM_TEXT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SHORT_TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT_LINE" maxOccurs="3">
                                                              <xs:annotation>
                                                                <xs:documentation>410--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="TEXT">
                                                                    <xs:annotation>
                                                                      <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[\S ]{1,30}" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                                <xs:attribute name="SEQUENCE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger" />
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:language">
                                                                <xs:pattern value="[A-Z]{2}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS">
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="ECLASS_NO">
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:totalDigits value="8" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="INDIVIDUAL">
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="CLASSIFICATION_KEY">
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string" />
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="DETAIL_INFOS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:maxInclusive value="999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="DECISION_NO" use="optional">
                                                      <xs:annotation>
                                                        <xs:documentation>291--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="9999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE_NO">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
                    <xs:documentation>K. Richter 26.02.2015</xs:documentation>
                    <xs:documentation>Datentyp auf positiveInteger gesetzt, K. Richter 12.06.2015</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_DEFINITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURES">
              <xs:annotation>
                <xs:documentation>250--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTION_TEXT" type="languagetext60">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                    <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="30" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                  <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_FREETEXT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                                        <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FEATURE_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>250--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="SEQUENCE_NO">
                          <xs:annotation>
                            <xs:documentation>250--4--Sortierung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MAJOR" use="required">
      <xs:annotation>
        <xs:documentation>100--3--Versionsnummer</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="3" />
          <xs:maxInclusive value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MINOR" use="required">
      <xs:annotation>
        <xs:documentation>100--4--Sub_Versions_Nr</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012, K. Richter 23.11.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="0" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REVISION" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="0" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FORMAT" use="required">
      <xs:annotation>
        <xs:documentation>100--8--Branchen_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[ABGKOPSWZ]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element : CATALOG Element
Beschreibung
In diesem Element werden administrative Informationen zum Datenbestand hinterlegt.
Namensraum (none)
Diagramm
RECEIVER_ID Element DETAIL_INFOS Element FALL_BACK_LANGUAGE Element CATALOG_VERSION Element CATALOG_ID Element LANGUAGE Element Sequence CATALOG_INFO Element CATALOG_DATA_VERSION Element CATALOG_MERGE_TYPE Element CATALOG_MARK Element FILE_ID Element LANGUAGE Element Sequence CATALOG_NAME Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element Sequence CATALOG Element
Overview
CATALOG
In diesem Element werden administrative Informationen zum Datenbestand hinterlegt.
Sequence
CATALOG_IDENTIFICATION
In diesem Element werden identifizierende Merkmale des Kataloges hinterlegt.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten müssen identisch sein.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
CATALOG_NAME languagetext30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
CATALOG_MERGE_TYPE optional xs:boolean

Dieses Element CATALOG_MERGE_TYPE ist optional und vom Datentyp boolean mit folgenden Werten:

0: entspricht dem Wert, wenn das Element nicht vorhanden ist und bedeutet, dieser Katalog muss nicht Bestandteil eines Multiherstellerkataloges sein.

1: Dieser Katalog ist immer Bestandteil eines Multiherstellerkataloges.

 D boolean
P
M
CATALOG_DATA_VERSION optional Restriction of xs:date
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
CATALOG_INFO optional languagetext Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
CATALOG_ID Restriction of xs:string

Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
CATALOG_VERSION Restriction of xs:positiveInteger
Hier kann der Hersteller des Datenbestandes eine Versions-Nr. für den Katalog vergeben. Wird zu einem Basiskatalog ein neuer Modifizierungsdatenbestand herausgegeben, muss der Wert von CATALOG_VERSION hoch gezählt werden. D positiveInteger
P
M [1:999999999]
FALL_BACK_LANGUAGE Restriction of xs:language
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO- Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
DETAIL_INFOS optional
Dieses Element dient der veränderten Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos bzw. eines speziellen Labels.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
RECEIVER_ID xs:string
Hier wird die ID des Empfängers eingetragen. D string
P
M
Quelle
<xs:element name="CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version 2.3 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetext30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FILE_ID">
        <xs:annotation>
          <xs:documentation>100--14--Datei_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MARK">
        <xs:annotation>
          <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BKVF]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
          <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_DATA_VERSION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>110--3--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_ID">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Katalog_ID
                /Hermann Balke 9.06.2013
                neu in 2.3
                hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren
                </xs:documentation>
          <xs:documentation> minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="64" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_VERSION">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
          <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FALL_BACK_LANGUAGE">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
          <xs:documentation>K. Richter 15.08.2017</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
          <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW </xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RECEIVER_ID" type="xs:string" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG_IDENTIFICATION Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_IDENTIFICATION Element
Beschreibung
In diesem Element werden identifizierende Merkmale des Kataloges hinterlegt.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten müssen identisch sein.
Namensraum (none)
Diagramm
CURRENCY_KEY Element ISO_LANGUAGE_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
In diesem Element werden identifizierende Merkmale des Kataloges hinterlegt.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten müssen identisch sein.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Quelle
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
ISO_LANGUAGE_ID Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Beschreibung
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:language
Diagramm
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CURRENCY_KEY Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Beschreibung
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Quelle
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG_NUMBER Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_NUMBER Element
Beschreibung
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Quelle
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG_NAME Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_NAME Element
Beschreibung
In diesem Element wird der Katalogname des Datenbestandes angegeben. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.
Namensraum (none)
Typ
languagetext30 Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetext30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="CATALOG_NAME" type="languagetext30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
FILE_ID Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : FILE_ID Element
Beschreibung
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
FILE_ID Element
Overview
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
Quelle
<xs:element name="FILE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--14--Datei_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG_MARK Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_MARK Element
Beschreibung
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_MARK Element
Overview
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
Quelle
<xs:element name="CATALOG_MARK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BKVF]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG_MERGE_TYPE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_MERGE_TYPE Element
Beschreibung

Dieses Element CATALOG_MERGE_TYPE ist optional und vom Datentyp boolean mit folgenden Werten:

0: entspricht dem Wert, wenn das Element nicht vorhanden ist und bedeutet, dieser Katalog muss nicht Bestandteil eines Multiherstellerkataloges sein.

1: Dieser Katalog ist immer Bestandteil eines Multiherstellerkataloges.

 D boolean
P
M
Namensraum (none)
Typ
xs:boolean
Diagramm
CATALOG_MERGE_TYPE Element
Overview
CATALOG_MERGE_TYPE optional xs:boolean

Dieses Element CATALOG_MERGE_TYPE ist optional und vom Datentyp boolean mit folgenden Werten:

0: entspricht dem Wert, wenn das Element nicht vorhanden ist und bedeutet, dieser Katalog muss nicht Bestandteil eines Multiherstellerkataloges sein.

1: Dieser Katalog ist immer Bestandteil eines Multiherstellerkataloges.

 D boolean
P
M
Quelle
<xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
    <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG_DATA_VERSION Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_DATA_VERSION Element
Beschreibung
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
CATALOG_DATA_VERSION Element
Overview
CATALOG_DATA_VERSION optional Restriction of xs:date
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
Quelle
<xs:element name="CATALOG_DATA_VERSION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG_INFO Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_INFO Element
Beschreibung
In diesem Element werden die Informationstexte abgelegt.
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_INFO Element
Overview
CATALOG_INFO optional languagetext Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>110--3--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG_ID Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_ID Element
Beschreibung

Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_ID Element
Overview
CATALOG_ID Restriction of xs:string

Hier muss der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren.
Diese ID ist notwendig unter Anderem zur Identifizierung bei Multiherstellerkatalogen.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Quelle
<xs:element name="CATALOG_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Katalog_ID
                /Hermann Balke 9.06.2013
                neu in 2.3
                hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren
                </xs:documentation>
    <xs:documentation> minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="64" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG_VERSION Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_VERSION Element
Beschreibung
Hier kann der Hersteller des Datenbestandes eine Versions-Nr. für den Katalog vergeben. Wird zu einem Basiskatalog ein neuer Modifizierungsdatenbestand herausgegeben, muss der Wert von CATALOG_VERSION hoch gezählt werden. D positiveInteger
P
M [1:999999999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CATALOG_VERSION Element
Overview
CATALOG_VERSION Restriction of xs:positiveInteger
Hier kann der Hersteller des Datenbestandes eine Versions-Nr. für den Katalog vergeben. Wird zu einem Basiskatalog ein neuer Modifizierungsdatenbestand herausgegeben, muss der Wert von CATALOG_VERSION hoch gezählt werden. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="CATALOG_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
    <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
FALL_BACK_LANGUAGE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : FALL_BACK_LANGUAGE Element
Beschreibung
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO- Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:language
Diagramm
FALL_BACK_LANGUAGE Element
Overview
FALL_BACK_LANGUAGE Restriction of xs:language
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO- Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="FALL_BACK_LANGUAGE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
DETAIL_INFOS Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : DETAIL_INFOS Element
Beschreibung
Dieses Element dient der veränderten Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos bzw. eines speziellen Labels.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
Dieses Element dient der veränderten Angabe von Bildern auf Katalogebene z. B. eines Hersteller- oder Kataloglogos bzw. eines speziellen Labels.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
    <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW </xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
DETAIL_INFO_REF Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
RECEIVER_ID Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : RECEIVER_ID Element
Beschreibung
Hier wird die ID des Empfängers eingetragen. D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
RECEIVER_ID Element
Overview
RECEIVER_ID xs:string
Hier wird die ID des Empfängers eingetragen. D string
P
M
Quelle
<xs:element name="RECEIVER_ID" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
REF_CATALOG Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element : REF_CATALOG Element
Beschreibung
Hier wird der Katalog, auf den sich die modifizierten Texte beziehen, über die GLN des Herstellers und die CATALOG_ID des Basiskataloges referenziert.
Namensraum (none)
Diagramm
CATALOG_VERSION Element CATALOG_DATA_VERSION Element Sequence REF_CATALOG Element
Overview
REF_CATALOG
Hier wird der Katalog, auf den sich die modifizierten Texte beziehen, über die GLN des Herstellers und die CATALOG_ID des Basiskataloges referenziert.
SUPPLIER_GLN_NO required Restriction of xs:string
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) des Herstellers des Basiskataloges eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch. D string
P [0-9]{13}
M
CATALOG_ID required Restriction of xs:string

Hier wird die eindeutige ID (z.B.GUID) des Herstellers eingeben, um den BasisKatalog eindeutig zu referenziern. Sie muss den gleichen Wert wie die CATALOG_ID unterhalb von CATALOG im Basiskatalog haben.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Sequence
CATALOG_DATA_VERSION Restriction of xs:date
In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf die sich die Zusatzpreise beziehen. D date
P
M
CATALOG_VERSION Restriction of xs:positiveInteger
Hier wird dieVersions-Nr. des Basiskataloges angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SUPPLIER_GLN_NO Restriction of xs:string required
In dieses Element wird die eindeutige Globale Lokationsnummer (GLN) des Herstellers des Basiskataloges eingetragen. Die GLN ermöglicht eine eindeutige Zuordnung von Unternehmen oder Unternehmenseinheiten für beispielsweise den automatisierten elektronischen Datenaustausch. D string
P [0-9]{13}
M
CATALOG_ID Restriction of xs:string required

Hier wird die eindeutige ID (z.B.GUID) des Herstellers eingeben, um den BasisKatalog eindeutig zu referenziern. Sie muss den gleichen Wert wie die CATALOG_ID unterhalb von CATALOG im Basiskatalog haben.

Ein Herstellerkatalog muss für einen bestimmten Händler immer dieselbe ID besitzen.

 D string
P
M [1:64]
Quelle
<xs:element name="REF_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG_DATA_VERSION">
        <xs:annotation>
          <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_VERSION">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
          <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SUPPLIER_GLN_NO" use="required">
      <xs:annotation>
        <xs:documentation>GLN des Herstellers</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[0-9]{13}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="CATALOG_ID" use="required">
      <xs:annotation>
        <xs:documentation>Katalogidentifikator</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="64" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG_DATA_VERSION Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > REF_CATALOG Element : CATALOG_DATA_VERSION Element
Beschreibung
In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf die sich die Zusatzpreise beziehen. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
CATALOG_DATA_VERSION Element
Overview
CATALOG_DATA_VERSION Restriction of xs:date
In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf die sich die Zusatzpreise beziehen. D date
P
M
Quelle
<xs:element name="CATALOG_DATA_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
REF_CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CATALOG_VERSION Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > REF_CATALOG Element : CATALOG_VERSION Element
Beschreibung
Hier wird dieVersions-Nr. des Basiskataloges angegeben. D positiveInteger
P
M [1:999999999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CATALOG_VERSION Element
Overview
CATALOG_VERSION Restriction of xs:positiveInteger
Hier wird dieVersions-Nr. des Basiskataloges angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="CATALOG_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
    <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
REF_CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
GLOBAL_DEFINITION Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element : GLOBAL_DEFINITION Element
Beschreibung
In diesem Element werden für den Datenbestand gültige Daten (globale Informationen) hinterlegt.
Namensraum (none)
Diagramm
DETAIL_INFOS Element Sequence GLOBAL_DEFINITION Element
Overview
GLOBAL_DEFINITION optional
In diesem Element werden für den Datenbestand gültige Daten (globale Informationen) hinterlegt.
Sequence
DETAIL_INFOS optional
In diesem Element werden für den Datenbestand als globale Informationen die Detail-Informationen (Medien) hinterlegt.
Sequence
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:14]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Quelle
<xs:element name="GLOBAL_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASSIFICATION">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INFO_TYPE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
12.02.2013/Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="14" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="URL">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT" type="xs:anyURI">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="HASH_VALUE">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="32" />
                                    <xs:maxLength value="32" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="LAYER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-6]0" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
DETAIL_INFOS Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element : DETAIL_INFOS Element
Beschreibung
In diesem Element werden für den Datenbestand als globale Informationen die Detail-Informationen (Medien) hinterlegt.
Namensraum (none)
Diagramm
DETAIL_INFO Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
In diesem Element werden für den Datenbestand als globale Informationen die Detail-Informationen (Medien) hinterlegt.
Sequence
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:14]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASSIFICATION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="INFO_TYPE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
12.02.2013/Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="14" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="URL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT" type="xs:anyURI">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="HASH_VALUE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="32" />
                              <xs:maxLength value="32" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="LAYER" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-6]0" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
DETAIL_INFO Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element : DETAIL_INFO Element
Beschreibung
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
Namensraum (none)
Diagramm
LAYER Element URL Element LANGUAGE Element Sequence TOOL_TIP Element LANGUAGE Element Sequence INTERNAL_NAME Element LANGUAGE Element Sequence EXTERNAL_NAME Element INFO_TYPE Element CLASSIFICATION Element Sequence DETAIL_INFO Element
Overview
DETAIL_INFO 1..∞
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:14]
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASSIFICATION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="INFO_TYPE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
12.02.2013/Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="14" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="URL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT" type="xs:anyURI">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="HASH_VALUE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="32" />
                        <xs:maxLength value="32" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="LAYER" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-6]0" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CLASSIFICATION Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : CLASSIFICATION Element
Beschreibung
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CLASSIFICATION Element
Overview
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.

 D string
P
M
Quelle
<xs:element name="CLASSIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
INFO_TYPE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INFO_TYPE Element
Beschreibung
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:14]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
INFO_TYPE Element
Overview
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

Die Werte der möglichen Info-Typen sind der entsprechenden Tabelle aus der Einleitung zu entnehmen. 		D positiveInteger
P
M [1:14]
Quelle
<xs:element name="INFO_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
12.02.2013/Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="14" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
EXTERNAL_NAME Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : EXTERNAL_NAME Element
Beschreibung
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence EXTERNAL_NAME Element
Overview
EXTERNAL_NAME optional languagetext Complex Type
Diese Element enthält den Anzeigename des Links (z.B. "Skizze 4711").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
INTERNAL_NAME Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INTERNAL_NAME Element
Beschreibung
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Namensraum (none)
Typ
languagetext40 Complex Type
Diagramm
LANGUAGE Element Sequence INTERNAL_NAME Element
Overview
INTERNAL_NAME optional languagetext40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner, sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
TOOL_TIP Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : TOOL_TIP Element
Beschreibung

Dieses Element enthält Text für einen Hinweis zum Link.

Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence TOOL_TIP Element
Overview
TOOL_TIP optional languagetext Complex Type

Dieses Element enthält Text für einen Hinweis zum Link.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="TOOL_TIP" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
URL Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : URL Element
Beschreibung
Dieses Element gibt die URL zur Detailinformation an.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence URL Element
Overview
URL
Dieses Element gibt die URL zur Detailinformation an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Quelle
<xs:element name="URL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT" type="xs:anyURI">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="HASH_VALUE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="32" />
                  <xs:maxLength value="32" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
LANGUAGE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
HASH_VALUE Element TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:anyURI">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="HASH_VALUE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="32" />
            <xs:maxLength value="32" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
Namensraum (none)
Typ
xs:anyURI
Diagramm
TEXT Element
Overview
TEXT xs:anyURI
In diesem Element wird die URI für die Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D anyURI
P
M [1:1024]
Quelle
<xs:element name="TEXT" type="xs:anyURI" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
HASH_VALUE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : HASH_VALUE Element
Beschreibung
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
HASH_VALUE Element
Overview
HASH_VALUE Restriction of xs:string
Hier wird das Bild verschlüsselt dargestellt. Der HASH_VALUE soll genau 32 Stellen beinhalten und ist MD5 zu verschlüsseln.
Somit kann jeder Dienstleister feststellen, ob das Bild schon einmal heruntergeladen wurde oder nicht. 		D string
P
M [32:32]
Quelle
<xs:element name="HASH_VALUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="32" />
      <xs:maxLength value="32" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
LAYER Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : LAYER Element
Beschreibung

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
LAYER Element
Overview
LAYER optional Restriction of xs:positiveInteger

Dieses Element dient der Platzierung von Anschlussartikeln, z. B. Kopfstützen.

Möglich ist dieses Element nur für SVG-Dateien.

Innerhalb des Outline-Typs (OLT) einer SVG gilt:

Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.

Für das Element gelten folgende Werte:

10 Teppich

20 Sofa/ Möbel/ Tisch (Default-Wert)

30 Kissen

40 Dekorkissen

50 Kopfstütze

60 Plate/ Überwurf

 D positiveInteger
P [1-6]0
M [10:60]
Quelle
<xs:element name="LAYER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-6]0" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
SERIES Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element : SERIES Element
Beschreibung

In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren zugeordneten Elementen wie beispielsweise Produktgruppen oder Artikeln hinterlegt, an denen veränderte Texte, Detailinformationen oder zusätzliche Klassifizierungen hinterlegt werden.

Eine Serie entspricht im Allgemeinen einem Modell.

Namensraum (none)
Diagramm
SERIE Element Sequence SERIES Element
Overview
SERIES

In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren zugeordneten Elementen wie beispielsweise Produktgruppen oder Artikeln hinterlegt, an denen veränderte Texte, Detailinformationen oder zusätzliche Klassifizierungen hinterlegt werden.

Eine Serie entspricht im Allgemeinen einem Modell.

Sequence
SERIE 1..1000000
In diesem Element wird eine Serie mit ihren entsprechenden Artikeln gespeichert. Einen Serie entspricht einem Modell. Die Angaben der Nummern und Bezeichnungen müssen denen des Basiskataloges entsprechen.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie des Basiskataloges angegeben. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
Dieses Attribut gibt die Möglichkeit, Serien mit einer selbstdefinierten Sortierreihenfolge anzulegen.
Wird für eine Serie eine SEQUENCE_NO angegeben, muss für alle Serien eine SEQUENCE_NO angegeben werden. Sie muss dem Basiskatalog entsprechen. 		D positiveInteger
P
M
Sequence
SERIES_NAME
Dieses Element gibt den Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PRODUCT_GROUPS
In diesem Element werden Produktgruppen gespeichert. Sie müssen denen des Basiskataloges entsprechen. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Polstermöbel mit Armlehne).
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind.
Sequence
ITEMS

In diesem Element werden alle Artikel einer Produktgruppe angegeben, für die die Texte, Detailinformationen oder Klassifizierungen handelspezifisch verändert werden.

Sequence
ITEM 1..∞

In diesem Element werden Artikel entsprechend des Basiskataloges gespeichert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 2).

Pfad 1: SERIES/SERIE/SERIE_NO
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden und muss dem Basiskatalog entsprechen. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Der Kurztext darf aus drei Zeilen bestehen.

Dieses Element ist nur anzugeben, wenn für den Artikel ein handelsspezifischer Text vorgesehen ist.

Die spätere Bestellung muss den Originaltext enthalten.

CLASSIFICATIONS optional
In diesem Element werden zum Basiskatalog ergänzende Klassifikationsnummern hinterlegt.
DETAIL_INFOS optional
In diesem Element können veränderte mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch Video Links hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
DETAIL_INFOS optional
In diesem Element können handelsspezifische mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks für die Serie hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="SERIES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE" maxOccurs="1000000">
        <xs:annotation>
          <xs:documentation>200--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>maxOccours geändert, K.Richter 23.11.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIES_NAME">
              <xs:annotation>
                <xs:documentation>200--3--Serienname</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>200--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRODUCT_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEMS">
                          <xs:annotation>
                            <xs:documentation>400--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM_TEXT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SHORT_TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT_LINE" maxOccurs="3">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT">
                                                              <xs:annotation>
                                                                <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[\S ]{1,30}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SEQUENCE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger" />
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:language">
                                                          <xs:pattern value="[A-Z]{2}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS">
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS_NO">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:totalDigits value="8" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="INDIVIDUAL">
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="CLASSIFICATION_KEY">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string" />
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="DECISION_NO" use="optional">
                                                <xs:annotation>
                                                  <xs:documentation>291--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="9999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
              <xs:documentation>K. Richter 26.02.2015</xs:documentation>
              <xs:documentation>Datentyp auf positiveInteger gesetzt, K. Richter 12.06.2015</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
SERIE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element : SERIE Element
Beschreibung
In diesem Element wird eine Serie mit ihren entsprechenden Artikeln gespeichert. Einen Serie entspricht einem Modell. Die Angaben der Nummern und Bezeichnungen müssen denen des Basiskataloges entsprechen.
Namensraum (none)
Diagramm
DETAIL_INFOS Element PRODUCT_GROUPS Element SERIES_NAME Element Sequence SERIE Element
Overview
SERIE 1..1000000
In diesem Element wird eine Serie mit ihren entsprechenden Artikeln gespeichert. Einen Serie entspricht einem Modell. Die Angaben der Nummern und Bezeichnungen müssen denen des Basiskataloges entsprechen.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie des Basiskataloges angegeben. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
Dieses Attribut gibt die Möglichkeit, Serien mit einer selbstdefinierten Sortierreihenfolge anzulegen.
Wird für eine Serie eine SEQUENCE_NO angegeben, muss für alle Serien eine SEQUENCE_NO angegeben werden. Sie muss dem Basiskatalog entsprechen. 		D positiveInteger
P
M
Sequence
SERIES_NAME
Dieses Element gibt den Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PRODUCT_GROUPS
In diesem Element werden Produktgruppen gespeichert. Sie müssen denen des Basiskataloges entsprechen. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Polstermöbel mit Armlehne).
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind.
Sequence
ITEMS

In diesem Element werden alle Artikel einer Produktgruppe angegeben, für die die Texte, Detailinformationen oder Klassifizierungen handelspezifisch verändert werden.

Sequence
ITEM 1..∞

In diesem Element werden Artikel entsprechend des Basiskataloges gespeichert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 2).

Pfad 1: SERIES/SERIE/SERIE_NO
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden und muss dem Basiskatalog entsprechen. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Der Kurztext darf aus drei Zeilen bestehen.

Dieses Element ist nur anzugeben, wenn für den Artikel ein handelsspezifischer Text vorgesehen ist.

Die spätere Bestellung muss den Originaltext enthalten.

Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
CLASSIFICATIONS optional
In diesem Element werden zum Basiskatalog ergänzende Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
INDIVIDUAL
Dieses Element dient der Angabe einer eigenen Klassifizierung.
DETAIL_INFOS optional
In diesem Element können veränderte mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch Video Links hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFOS optional
In diesem Element können handelsspezifische mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks für die Serie hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der Serie des Basiskataloges angegeben. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO xs:positiveInteger required
Dieses Attribut gibt die Möglichkeit, Serien mit einer selbstdefinierten Sortierreihenfolge anzulegen.
Wird für eine Serie eine SEQUENCE_NO angegeben, muss für alle Serien eine SEQUENCE_NO angegeben werden. Sie muss dem Basiskatalog entsprechen. 		D positiveInteger
P
M
Quelle
<xs:element name="SERIE" maxOccurs="1000000" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>maxOccours geändert, K.Richter 23.11.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIES_NAME">
        <xs:annotation>
          <xs:documentation>200--3--Serienname</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>200--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRODUCT_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEMS">
                    <xs:annotation>
                      <xs:documentation>400--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM_TEXT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SHORT_TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT_LINE" maxOccurs="3">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT">
                                                        <xs:annotation>
                                                          <xs:documentation>410--6--Textzeile</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[\S ]{1,30}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger" />
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:language">
                                                    <xs:pattern value="[A-Z]{2}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS">
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS_NO">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:totalDigits value="8" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="INDIVIDUAL">
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="CLASSIFICATION_KEY">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string" />
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="DECISION_NO" use="optional">
                                          <xs:annotation>
                                            <xs:documentation>291--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
        <xs:documentation>K. Richter 26.02.2015</xs:documentation>
        <xs:documentation>Datentyp auf positiveInteger gesetzt, K. Richter 12.06.2015</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
SERIES_NAME Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element : SERIES_NAME Element
Beschreibung
Dieses Element gibt den Seriennamen an.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence SERIES_NAME Element
Overview
SERIES_NAME
Dieses Element gibt den Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="SERIES_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--3--Serienname</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>200--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
LANGUAGE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>200--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
TEXT_LINE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element : TEXT_LINE Element
Beschreibung
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Namensraum (none)
Diagramm
FULL_TEXT Element TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.

Das Element TEXT beinhaltet einen Kurztext. Das Elemt FULL_TEXT beinhaltet einen beliebig langen Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="TEXT_LINE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Beschreibung
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Kuerztext in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
FULL_TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : FULL_TEXT Element
Beschreibung
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
FULL_TEXT Element
Overview
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="FULL_TEXT" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
PRODUCT_GROUPS Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element : PRODUCT_GROUPS Element
Beschreibung
In diesem Element werden Produktgruppen gespeichert. Sie müssen denen des Basiskataloges entsprechen. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Polstermöbel mit Armlehne).
Namensraum (none)
Diagramm
PRODUCT_GROUP Element Sequence PRODUCT_GROUPS Element
Overview
PRODUCT_GROUPS
In diesem Element werden Produktgruppen gespeichert. Sie müssen denen des Basiskataloges entsprechen. In Produktgruppen werden Artikel mit gleichen Variantenarten gruppiert (z. B. Polstermöbel mit Armlehne).
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind.
Sequence
ITEMS

In diesem Element werden alle Artikel einer Produktgruppe angegeben, für die die Texte, Detailinformationen oder Klassifizierungen handelspezifisch verändert werden.

Sequence
ITEM 1..∞

In diesem Element werden Artikel entsprechend des Basiskataloges gespeichert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 2).

Pfad 1: SERIES/SERIE/SERIE_NO
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden und muss dem Basiskatalog entsprechen. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Der Kurztext darf aus drei Zeilen bestehen.

Dieses Element ist nur anzugeben, wenn für den Artikel ein handelsspezifischer Text vorgesehen ist.

Die spätere Bestellung muss den Originaltext enthalten.

Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
CLASSIFICATIONS optional
In diesem Element werden zum Basiskatalog ergänzende Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
INDIVIDUAL
Dieses Element dient der Angabe einer eigenen Klassifizierung.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

Hier wird die zum Artikel passende eigene Klassifizierung zugeordnet.

 D string
P
M
DETAIL_INFOS optional
In diesem Element können veränderte mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch Video Links hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden. 		D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="PRODUCT_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEMS">
              <xs:annotation>
                <xs:documentation>400--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_TEXT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SHORT_TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT_LINE" maxOccurs="3">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--6--Textzeile</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[\S ]{1,30}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger" />
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:language">
                                              <xs:pattern value="[A-Z]{2}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CLASSIFICATIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS">
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS_NO">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:totalDigits value="8" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="INDIVIDUAL">
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLASSIFICATION_KEY">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string" />
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DECISION_NO" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
PRODUCT_GROUP Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element : PRODUCT_GROUP Element
Beschreibung
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind.
Namensraum (none)
Diagramm
ITEMS Element Sequence PRODUCT_GROUP Element
Overview
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind.
Sequence
ITEMS

In diesem Element werden alle Artikel einer Produktgruppe angegeben, für die die Texte, Detailinformationen oder Klassifizierungen handelspezifisch verändert werden.

Sequence
ITEM 1..∞

In diesem Element werden Artikel entsprechend des Basiskataloges gespeichert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 2).

Pfad 1: SERIES/SERIE/SERIE_NO
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden und muss dem Basiskatalog entsprechen. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Der Kurztext darf aus drei Zeilen bestehen.

Dieses Element ist nur anzugeben, wenn für den Artikel ein handelsspezifischer Text vorgesehen ist.

Die spätere Bestellung muss den Originaltext enthalten.

Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
CLASSIFICATIONS optional
In diesem Element werden zum Basiskatalog ergänzende Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
INDIVIDUAL
Dieses Element dient der Angabe einer eigenen Klassifizierung.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

Hier wird die zum Artikel passende eigene Klassifizierung zugeordnet.

 D string
P
M
DETAIL_INFOS optional
In diesem Element können veränderte mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch Video Links hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden. 		D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="PRODUCT_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEMS">
        <xs:annotation>
          <xs:documentation>400--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_TEXT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SHORT_TEXT">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT_LINE" maxOccurs="3">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--6--Textzeile</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[\S ]{1,30}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CLASSIFICATIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS_NO">
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:totalDigits value="8" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="INDIVIDUAL">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLASSIFICATION_KEY">
                                <xs:simpleType>
                                  <xs:restriction base="xs:string" />
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="DECISION_NO" use="optional">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
ITEMS Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : ITEMS Element
Beschreibung

In diesem Element werden alle Artikel einer Produktgruppe angegeben, für die die Texte, Detailinformationen oder Klassifizierungen handelspezifisch verändert werden.

Namensraum (none)
Diagramm
ITEM Element Sequence ITEMS Element
Overview
ITEMS

In diesem Element werden alle Artikel einer Produktgruppe angegeben, für die die Texte, Detailinformationen oder Klassifizierungen handelspezifisch verändert werden.

Sequence
ITEM 1..∞

In diesem Element werden Artikel entsprechend des Basiskataloges gespeichert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 2).

Pfad 1: SERIES/SERIE/SERIE_NO
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden und muss dem Basiskatalog entsprechen. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Der Kurztext darf aus drei Zeilen bestehen.

Dieses Element ist nur anzugeben, wenn für den Artikel ein handelsspezifischer Text vorgesehen ist.

Die spätere Bestellung muss den Originaltext enthalten.

Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
CLASSIFICATIONS optional
In diesem Element werden zum Basiskatalog ergänzende Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
INDIVIDUAL
Dieses Element dient der Angabe einer eigenen Klassifizierung.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

Hier wird die zum Artikel passende eigene Klassifizierung zugeordnet.

 D string
P
M
DETAIL_INFOS optional
In diesem Element können veränderte mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch Video Links hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden. 		D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="ITEMS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_TEXT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SHORT_TEXT">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--6--Textzeile</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CLASSIFICATIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS_NO">
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:totalDigits value="8" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="INDIVIDUAL">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASSIFICATION_KEY">
                          <xs:simpleType>
                            <xs:restriction base="xs:string" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="DECISION_NO" use="optional">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
ITEM Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element : ITEM Element
Beschreibung

In diesem Element werden Artikel entsprechend des Basiskataloges gespeichert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 2).

Pfad 1: SERIES/SERIE/SERIE_NO
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

Namensraum (none)
Diagramm
DETAIL_INFOS Element CLASSIFICATIONS Element ITEM_TEXT Element Sequence ITEM Element
Overview
ITEM 1..∞

In diesem Element werden Artikel entsprechend des Basiskataloges gespeichert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 2).

Pfad 1: SERIES/SERIE/SERIE_NO
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden und muss dem Basiskatalog entsprechen. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Der Kurztext darf aus drei Zeilen bestehen.

Dieses Element ist nur anzugeben, wenn für den Artikel ein handelsspezifischer Text vorgesehen ist.

Die spätere Bestellung muss den Originaltext enthalten.

Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
CLASSIFICATIONS optional
In diesem Element werden zum Basiskatalog ergänzende Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
INDIVIDUAL
Dieses Element dient der Angabe einer eigenen Klassifizierung.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

Hier wird die zum Artikel passende eigene Klassifizierung zugeordnet.

 D string
P
M
DETAIL_INFOS optional
In diesem Element können veränderte mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch Video Links hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden. 		D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode/die Artikeltype eingegeben. D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:positiveInteger optional

Dieses Attribut gibt die Möglichkeit, Artikel mit einer selbstdefinierten Sortierreihenfolge anzulegen.

Die Sortierung der Artikel bezieht sich immer auf die Serie, in der die Artikel gespeichert werden und muss dem Basiskatalog entsprechen. Wird für einen Artikel innerhalb der Serie eine SEQUENCE_NO angegeben, muss für alle Artikel dieser Serie eine SEQUENCE_NO angegeben werden.

 D positiveInteger
P
M
Quelle
<xs:element name="ITEM" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_TEXT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SHORT_TEXT">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--6--Textzeile</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CLASSIFICATIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS_NO">
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:totalDigits value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="INDIVIDUAL">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASSIFICATION_KEY">
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DECISION_NO" use="optional">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
ITEM_TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_TEXT Element
Beschreibung

In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Der Kurztext darf aus drei Zeilen bestehen.

Dieses Element ist nur anzugeben, wenn für den Artikel ein handelsspezifischer Text vorgesehen ist.

Die spätere Bestellung muss den Originaltext enthalten.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence PLANNING_ADVICE Element LANGUAGE Element Sequence FULL_TEXT Element SHORT_TEXT Element Sequence ITEM_TEXT Element
Overview
ITEM_TEXT optional

In diesem Element werden die artikelspezifischen Texte definiert. Dies können Lang-, Kurz-, sowie Planungshinweistexte sein. Der Kurztext darf aus drei Zeilen bestehen.

Dieses Element ist nur anzugeben, wenn für den Artikel ein handelsspezifischer Text vorgesehen ist.

Die spätere Bestellung muss den Originaltext enthalten.

Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="ITEM_TEXT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SHORT_TEXT">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>410--6--Textzeile</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
SHORT_TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : SHORT_TEXT Element
Beschreibung
Dieses Element enthält Kurztexte.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence SHORT_TEXT Element
Overview
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="SHORT_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>410--6--Textzeile</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
LANGUAGE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprachig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>410--6--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
TEXT_LINE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element : TEXT_LINE Element
Beschreibung
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
Namensraum (none)
Diagramm
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE_NO Restriction of xs:positiveInteger required
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Quelle
<xs:element name="TEXT_LINE" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>410--6--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--6--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
FULL_TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : FULL_TEXT Element
Beschreibung
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence FULL_TEXT Element
Overview
FULL_TEXT optional languagetext Complex Type
Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden.

Dieses Element enthält den Volltext in einem CDATA - Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="FULL_TEXT" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
LANGUAGE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > languagetext Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:string" />
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetext Complex Type | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > languagetext Complex Type > LANGUAGE Element : TEXT Element
Beschreibung

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
TEXT Element
Overview
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="TEXT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
LANGUAGE Element | languagetext Complex Type | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
PLANNING_ADVICE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : PLANNING_ADVICE Element
Beschreibung
Dieses Element enthält Planungshinweise.
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence PLANNING_ADVICE Element
Overview
PLANNING_ADVICE optional languagetext Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CLASSIFICATIONS Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CLASSIFICATIONS Element
Beschreibung
In diesem Element werden zum Basiskatalog ergänzende Klassifikationsnummern hinterlegt.
Namensraum (none)
Diagramm
INDIVIDUAL Element ECLASS Element Sequence CLASSIFICATIONS Element
Overview
CLASSIFICATIONS optional
In diesem Element werden zum Basiskatalog ergänzende Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
INDIVIDUAL
Dieses Element dient der Angabe einer eigenen Klassifizierung.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

Hier wird die zum Artikel passende eigene Klassifizierung zugeordnet.

 D string
P
M
Quelle
<xs:element name="CLASSIFICATIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS_NO">
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:totalDigits value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="INDIVIDUAL">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASSIFICATION_KEY">
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
ECLASS Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element : ECLASS Element
Beschreibung
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Namensraum (none)
Diagramm
ECLASS_NO Element Sequence ECLASS Element
Overview
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
Quelle
<xs:element name="ECLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS_NO">
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:totalDigits value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
ECLASS_NO Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element > ECLASS Element : ECLASS_NO Element
Beschreibung

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
ECLASS_NO Element
Overview
ECLASS_NO Restriction of xs:nonNegativeInteger

Hier wird die zum Artikel passende 8-stellige eCl@ss-Nummer, die der 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

 D nonNegativeInteger
P
M [10000000:99999999]
Quelle
<xs:element name="ECLASS_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:totalDigits value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ECLASS Element | CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
INDIVIDUAL Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element : INDIVIDUAL Element
Beschreibung
Dieses Element dient der Angabe einer eigenen Klassifizierung.
Namensraum (none)
Diagramm
CLASSIFICATION_KEY Element Sequence INDIVIDUAL Element
Overview
INDIVIDUAL
Dieses Element dient der Angabe einer eigenen Klassifizierung.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

Hier wird die zum Artikel passende eigene Klassifizierung zugeordnet.

 D string
P
M
Quelle
<xs:element name="INDIVIDUAL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASSIFICATION_KEY">
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
CLASSIFICATION_KEY Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element > INDIVIDUAL Element : CLASSIFICATION_KEY Element
Beschreibung

Hier wird die zum Artikel passende eigene Klassifizierung zugeordnet.

 D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CLASSIFICATION_KEY Element
Overview
CLASSIFICATION_KEY Restriction of xs:string

Hier wird die zum Artikel passende eigene Klassifizierung zugeordnet.

 D string
P
M
Quelle
<xs:element name="CLASSIFICATION_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
Siehe auch
INDIVIDUAL Element | CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
DETAIL_INFOS Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : DETAIL_INFOS Element
Beschreibung
In diesem Element können veränderte mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch Video Links hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
In diesem Element können veränderte mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch Video Links hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Sequence
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden. 		D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DECISION_NO" use="optional">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
DETAIL_INFO_REF Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞

Über dieses Element kann genau 1 Variante direkt dem Bild zugeordnet werden.

Die Zuordnung erfolgt über DETAIL_INFO_NO und entweder RESTRICTION_NO oder DECISION_NO, wobei für die Referenzierung auf eine Regel(DECISION) nur Vorbereitungsregeln zulässig sind.

Diese Zuordnung darf ausschließlich für Magnetplanerbilder (Zuordnungen) verwendet werden.

Beispiel:
Falls ein Hersteller Funktionsvarianten (z.B. Querschläfer)zu einem Artikel anbietet, kann er hier die unterschiedlichen Bilder in Abhängigkeit dieser Variante hinterlegen.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden. 		D positiveInteger
P
M [1:9999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
DECISION_NO Restriction of xs:positiveInteger optional
Mit diesem Attribut wird eine Regel referenziert.
Es darf nur der Identifikator (DECISION_NO) einer Vorbereitungsregel angegeben werden. 		D positiveInteger
P
M [1:9999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DECISION_NO" use="optional">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
DETAIL_INFO_REF Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
DETAIL_INFOS Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element : DETAIL_INFOS Element
Beschreibung
In diesem Element können handelsspezifische mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks für die Serie hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
In diesem Element können handelsspezifische mediale Detailinformationen wie z.B. Milieufotos, PDFs oder auch VideoLinks für die Serie hinterlegt werden. Wird dieses Element angegeben, müssen alle relevanten Detailinformationen, auch die, die aus dem Basiskatalog genutzt werden sollen, angegeben werden.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
FEATURE_DEFINITION Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element : FEATURE_DEFINITION Element
Beschreibung
In diesem Element werden variantenabhängige Informationen, die gegenüber dem Basiskatalog handelspezifisch verändert werden, hinterlegt. Diese Veränderungen dürfen sich nur für den Verkauf auswirken, nicht für die Bestellung.
Namensraum (none)
Diagramm
FEATURES Element Sequence FEATURE_DEFINITION Element
Overview
FEATURE_DEFINITION
In diesem Element werden variantenabhängige Informationen, die gegenüber dem Basiskatalog handelspezifisch verändert werden, hinterlegt. Diese Veränderungen dürfen sich nur für den Verkauf auswirken, nicht für die Bestellung.
Sequence
FEATURES

In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten angegeben, für die eine handelsspezifische Veränderung vorgenommen wird. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Datenbestandes erforderlich sind.

Weitere Erläuterungen zu den Variantenarten sind zu finden in der Einleitung im Abschnitt " Variantenarten"

Sequence
FEATURE 1..∞
In diesem Element wird eine Variantart aus dem Basiskatalog handelspezifisch aufbereitet.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. Die Nummer muss der des Basiskataloges entsprechen. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen handelspezifisch zu ändernden Ausprägungen einer Variantenart hinterlegt werden.
Sequence
OPTION 1..∞
In diesem Element wird eine Variante für die übergeordnete Variantenart abgelegt.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung aus dem Basiskatalog referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen, die dem Basiskatalog entsprechen muss. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein handelsspezifischer Variantentext definiert. Für Bestellungen muss der Originaltext genutzt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein handelsspezifischer allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.
DETAIL_INFOS optional
Dieses Element dient der Zuordnung von veränderten Medien. Es ist möglich einer Variante mehrere Detail-Informationen zuzuordnen, und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild nur in der entsprechenden Serie oder beim bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
Dieses Element enthält handelsspezifische Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben. Sie muss dem Basiskatalog entsprechen.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten des Basiskataloges(HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ des Basiskataloges 		D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURE_DEFINITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURES">
        <xs:annotation>
          <xs:documentation>250--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_TEXT" type="languagetext60">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                              <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_FREETEXT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                                  <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="SEQUENCE_NO">
                    <xs:annotation>
                      <xs:documentation>250--4--Sortierung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>250--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
FEATURES Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element : FEATURES Element
Beschreibung

In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten angegeben, für die eine handelsspezifische Veränderung vorgenommen wird. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Datenbestandes erforderlich sind.

Weitere Erläuterungen zu den Variantenarten sind zu finden in der Einleitung im Abschnitt " Variantenarten"

Namensraum (none)
Diagramm
FEATURE Element Sequence FEATURES Element
Overview
FEATURES

In diesem Element werden die Variantenarten (FEATURE) und die zughörigen Varianten angegeben, für die eine handelsspezifische Veränderung vorgenommen wird. Es werden nur die Variantenarten definiert, die zur korrekten Abbildung des Datenbestandes erforderlich sind.

Weitere Erläuterungen zu den Variantenarten sind zu finden in der Einleitung im Abschnitt " Variantenarten"

Sequence
FEATURE 1..∞
In diesem Element wird eine Variantart aus dem Basiskatalog handelspezifisch aufbereitet.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. Die Nummer muss der des Basiskataloges entsprechen. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen handelspezifisch zu ändernden Ausprägungen einer Variantenart hinterlegt werden.
Sequence
OPTION 1..∞
In diesem Element wird eine Variante für die übergeordnete Variantenart abgelegt.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung aus dem Basiskatalog referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen, die dem Basiskatalog entsprechen muss. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein handelsspezifischer Variantentext definiert. Für Bestellungen muss der Originaltext genutzt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein handelsspezifischer allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.
DETAIL_INFOS optional
Dieses Element dient der Zuordnung von veränderten Medien. Es ist möglich einer Variante mehrere Detail-Informationen zuzuordnen, und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild nur in der entsprechenden Serie oder beim bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
ITEM_REF 0..∞
Dieses Element dient der Referenzierung eines Artikels.
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
Dieses Element enthält handelsspezifische Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben. Sie muss dem Basiskatalog entsprechen.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten des Basiskataloges(HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ des Basiskataloges 		D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                        <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_FREETEXT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                            <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="SEQUENCE_NO">
              <xs:annotation>
                <xs:documentation>250--4--Sortierung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>250--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
FEATURE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element : FEATURE Element
Beschreibung
In diesem Element wird eine Variantart aus dem Basiskatalog handelspezifisch aufbereitet.
Namensraum (none)
Diagramm
SEQUENCE_NO Element LANGUAGE Element Sequence FEATURE_TEXT Element OPTIONS Element Sequence FEATURE Element
Overview
FEATURE 1..∞
In diesem Element wird eine Variantart aus dem Basiskatalog handelspezifisch aufbereitet.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. Die Nummer muss der des Basiskataloges entsprechen. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen handelspezifisch zu ändernden Ausprägungen einer Variantenart hinterlegt werden.
Sequence
OPTION 1..∞
In diesem Element wird eine Variante für die übergeordnete Variantenart abgelegt.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung aus dem Basiskatalog referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen, die dem Basiskatalog entsprechen muss. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein handelsspezifischer Variantentext definiert. Für Bestellungen muss der Originaltext genutzt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein handelsspezifischer allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.
DETAIL_INFOS optional
Dieses Element dient der Zuordnung von veränderten Medien. Es ist möglich einer Variante mehrere Detail-Informationen zuzuordnen, und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild nur in der entsprechenden Serie oder beim bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
Dieses Element dient der Referenzierung eines Artikels.
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
Dieses Element enthält handelsspezifische Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben. Sie muss dem Basiskatalog entsprechen.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten des Basiskataloges(HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ des Basiskataloges 		D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird die Variantenart identifiziert. Die Nummer muss der des Basiskataloges entsprechen. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                  <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_FREETEXT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                      <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="SEQUENCE_NO">
        <xs:annotation>
          <xs:documentation>250--4--Sortierung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>250--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
OPTIONS Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : OPTIONS Element
Beschreibung
Dies ist ein Container-Element, in dem die möglichen handelspezifisch zu ändernden Ausprägungen einer Variantenart hinterlegt werden.
Namensraum (none)
Diagramm
OPTION Element Sequence OPTIONS Element
Overview
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen handelspezifisch zu ändernden Ausprägungen einer Variantenart hinterlegt werden.
Sequence
OPTION 1..∞
In diesem Element wird eine Variante für die übergeordnete Variantenart abgelegt.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung aus dem Basiskatalog referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen, die dem Basiskatalog entsprechen muss. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein handelsspezifischer Variantentext definiert. Für Bestellungen muss der Originaltext genutzt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein handelsspezifischer allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.
DETAIL_INFOS optional
Dieses Element dient der Zuordnung von veränderten Medien. Es ist möglich einer Variante mehrere Detail-Informationen zuzuordnen, und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild nur in der entsprechenden Serie oder beim bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
Dieses Element dient der Referenzierung eines Artikels.
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
Quelle
<xs:element name="OPTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                            <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_FREETEXT" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
OPTION Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element : OPTION Element
Beschreibung
In diesem Element wird eine Variante für die übergeordnete Variantenart abgelegt.
Namensraum (none)
Diagramm
OPTION_FREETEXT Element DETAIL_INFOS Element VALID_UNTIL Element VALID_FROM Element LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element LANGUAGE Element Sequence OPTION_TEXT Element Sequence OPTION Element
Overview
OPTION 1..∞
In diesem Element wird eine Variante für die übergeordnete Variantenart abgelegt.
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung aus dem Basiskatalog referenziert. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen, die dem Basiskatalog entsprechen muss. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein handelsspezifischer Variantentext definiert. Für Bestellungen muss der Originaltext genutzt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein handelsspezifischer allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.
DETAIL_INFOS optional
Dieses Element dient der Zuordnung von veränderten Medien. Es ist möglich einer Variante mehrere Detail-Informationen zuzuordnen, und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild nur in der entsprechenden Serie oder beim bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
Dieses Element dient der Referenzierung eines Artikels.
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung aus dem Basiskatalog referenziert. D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional
Dieses Attribut gibt die Möglichkeit, Varianten mit einer selbstdefinierten Sortierreihenfolge anzulegen, die dem Basiskatalog entsprechen muss. D nonNegativeInteger
P
M
Quelle
<xs:element name="OPTION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_FREETEXT" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
          <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
OPTION_TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_TEXT Element
Beschreibung
In diesem Element wird ein handelsspezifischer Variantentext definiert. Für Bestellungen muss der Originaltext genutzt werden.
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence OPTION_TEXT Element
Overview
OPTION_TEXT languagetext60 Complex Type
In diesem Element wird ein handelsspezifischer Variantentext definiert. Für Bestellungen muss der Originaltext genutzt werden.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="OPTION_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
OPTION_COMMENT_TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_COMMENT_TEXT Element
Beschreibung
In diesem Element wird ein handelsspezifischer allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Namensraum (none)
Typ
languagetext Complex Type
Diagramm
LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element
Overview
OPTION_COMMENT_TEXT optional languagetext Complex Type
In diesem Element wird ein handelsspezifischer allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante referenziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
VALID_FROM Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_FROM Element
Beschreibung
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
VALID_UNTIL Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_UNTIL Element
Beschreibung
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Über die Elemente VALID_FROM und VALID_UNTIL werden die Zeiträume für Gültigkeiten von Veränderungen der Varianten definiert.
Für die Füllung der Elemente gelten folgende Bedingungen
Beide Elemente gefüllt: in dem resultierendem Zeitraum gültig.
Beide Elemente leer: uneingeschränkt gültig.
Nur das Element VALID_FROM gefüllt: ab diesem Datum gültig.
Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum gültig.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
DETAIL_INFOS Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : DETAIL_INFOS Element
Beschreibung
Dieses Element dient der Zuordnung von veränderten Medien. Es ist möglich einer Variante mehrere Detail-Informationen zuzuordnen, und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild nur in der entsprechenden Serie oder beim bestimmten Artikel angezeigt.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
Dieses Element dient der Zuordnung von veränderten Medien. Es ist möglich einer Variante mehrere Detail-Informationen zuzuordnen, und jedes Bild der Variante kann dann speziellen Serien oder Artikeln zugeordnet werden. Somit wird das jeweilige Bild nur in der entsprechenden Serie oder beim bestimmten Artikel angezeigt.
Sequence
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
Dieses Element dient der Referenzierung eines Artikels.
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
DETAIL_INFO_REF Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
In diesem Element werden die Detailinformationen referenziert.
Namensraum (none)
Diagramm
ITEM_REF Element SERIE_REF Element Sequence DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
In diesem Element werden die Detailinformationen referenziert.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
Dieses Element dient der Referenzierung eines Artikels.
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
SERIE_REF Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element > DETAIL_INFO_REF Element : SERIE_REF Element
Beschreibung
In diesem Element wird die Serie referenziert.
Namensraum (none)
Diagramm
SERIE_REF Element
Overview
SERIE_REF 0..∞
In diesem Element wird die Serie referenziert.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Identifikationsnummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFO_REF Element | DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
ITEM_REF Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element > DETAIL_INFO_REF Element : ITEM_REF Element
Beschreibung
Dieses Element dient der Referenzierung eines Artikels.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF 0..∞
Dieses Element dient der Referenzierung eines Artikels.
SERIE_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
Dieses Attribut gibt die Seriennummer des referenzierten Artikel an. D nonNegativInteger
P
M [0:999999]
TYPE_NO Restriction of xs:string required
Mit diesem Attribut wird ein Artikel per Artikelnummer referenziert. D string
P
M [1:30]
Quelle
<xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFO_REF Element | DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
OPTION_FREETEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_FREETEXT Element
Beschreibung
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
OPTION_FREETEXT Element
Overview
OPTION_FREETEXT optional Restriction of xs:boolean
Mit diesem Element wird ein Kennzeichen gesetzt, das beim Wahrheitswert true angibt, dass der Planer z. B. für RAL-Farben einen Text eingeben muss. D boolean
P
M
Quelle
<xs:element name="OPTION_FREETEXT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
    <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
FEATURE_TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : FEATURE_TEXT Element
Beschreibung
Dieses Element enthält handelsspezifische Texte für Variantenarten.
Namensraum (none)
Typ
languagetext60 Complex Type
Diagramm
LANGUAGE Element Sequence FEATURE_TEXT Element
Overview
FEATURE_TEXT languagetext60 Complex Type
Dieses Element enthält handelsspezifische Texte für Variantenarten.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="FEATURE_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
SEQUENCE_NO Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : SEQUENCE_NO Element
Beschreibung
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben. Sie muss dem Basiskatalog entsprechen.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten des Basiskataloges(HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ des Basiskataloges 		D nonNegativeInteger
P
M [0:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
SEQUENCE_NO Element
Overview
SEQUENCE_NO Restriction of xs:nonNegativeInteger
In diesem Element wird eine herstellerspezifische Sortierung für die Variantenarten angegeben. Sie muss dem Basiskatalog entsprechen.
Die Reihenfolge ist eine Empfehlung des Herstellers. Der Handel arbeitet im Bedarfsfall mit einer abweichenden Sortierung. Die Sortierung wird beispielsweise genutzt für: Anzeige in Bildschirmmasken, Reihenfolge der Varianten beim Bestellvorgang oder Formulare.
Die Sortierung muss für alle Datensätze eindeutig angegeben werden.
Bei unsichtbaren Kopfvarianten des Basiskataloges(HEADER_POS_VARIATION_TYPE = U (Pfad 1)), wird das Element nicht gefüllt.

Elementpfade
Pfad 1: FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ des Basiskataloges 		D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="SEQUENCE_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--4--Sortierung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.0 XML-Schema Dokumentation
Komplexe Datentypen
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > Komplexe Datentypen


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
languagetext Complex Type
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd : languagetext Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetext Complex Type
Overview
languagetext

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Verwendet von
CATALOG_INFO Element
EXTERNAL_NAME Element
TOOL_TIP Element
FULL_TEXT Element
PLANNING_ADVICE Element
OPTION_COMMENT_TEXT Element
Quelle
<xs:complexType name="languagetext" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT" type="xs:string" />
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
languagetext30 Complex Type
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd : languagetext30 Complex Type
Beschreibung
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetext30 Complex Type
Overview
languagetext30
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Verwendet von
CATALOG_NAME Element
Quelle
<xs:complexType name="languagetext30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 30stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,30}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
LANGUAGE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > languagetext30 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetext30 Complex Type | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > languagetext30 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetext30 Complex Type | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
languagetext40 Complex Type
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd : languagetext40 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetext40 Complex Type
Overview
languagetext40

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Verwendet von
INTERNAL_NAME Element
Quelle
<xs:complexType name="languagetext40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 40stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,40}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
LANGUAGE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > languagetext40 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,40}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetext40 Complex Type | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > languagetext40 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,40}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetext40 Complex Type | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
languagetext60 Complex Type
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd : languagetext60 Complex Type
Beschreibung
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetext60 Complex Type
Overview
languagetext60
Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Verwendet von
OPTION_TEXT Element
FEATURE_TEXT Element
Quelle
<xs:complexType name="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,60}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
LANGUAGE Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > languagetext60 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetext60 Complex Type | MODIFY_CONTENT_IDMP_3_0_0.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_0.xsd
TEXT Element
Ansicht mit Navigationswerkzeuge
MODIFY_CONTENT_IDMP_3_0_0.xsd > languagetext60 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetext60 Complex Type | MODIFY_CONTENT_IDMP_3_0_0.xsd