%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Einleitung
Ansicht mit Navigationswerkzeuge

Modifikation IDM 2.7.0 XML-Schema

Dokumentation

Stand 01 .05.2019

Dokumentiertes XML-Schema:

MODIFY_IDM_2_7_0.xsd

Kontakt

DCC e. V.
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org
Telefon 0 52 21/12 65-37


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Grundstruktur des IDM-Schemas
Ansicht mit Navigationswerkzeuge
Einleitung > Grundstruktur des IDM-Schemas

Die Grundstruktur des IDM-Schemas

Das Hauptelement T_MODIFY_CATALOG definiert, dass eine Modifikationsdatei auf einen vollständigen Katalogdatenbestand bereitgestellt wird.

Dabei sind die XML-Dateien UTF-8 zu kodieren.

Das IDM-Schema ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Child-Elemente (siehe Abbildung 1) von T_MODIFY_CATALOG abgebildet werden.

Abbildung 1 - Child-Elemente von T_NEW_CATALOG

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

REF_CATALOG

In REF_CATAG werden Informationen zum Hauptkataloghinterlegt.

SERIES

In SERIES werden die Daten für die Beschreibung der Artikel hinterlegt. Dabei werden die Artikel in Produktgruppen wie beispielsweise Unterschränke oder Regale gruppiert.

FEATURE_DEFINITION

In FEATURE_DEFINITION werden Varianteninformationen hinterlegt. Dabei sind die angegebenen Daten Veränderungen zum Hauptkatalog.

PRICE_DEFINITION

In PRICE_DEFINITION werden Preisinformationen hinterlegt. Die Angeben beziehen sich z. B. auf veränderte Preisfelder gegenüber dem Hauptkatalog.


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Katalogstruktur
Ansicht mit Navigationswerkzeuge
Einleitung > Katalogstruktur

Katalog- und Elementstruktur

Die grundlegende Katalogstruktur der Datenbestände baut sich wie folgt auf:

Abbildung 1 – Katalogstruktur der Datenbestände

Die Katalogstruktur wird im IDM-Schema durch die folgende Elementhierarchie abgebildet:

Abbildung 1 – Elementhierarchie im IDM-Schema

In dem Element SERIE werden die Eigenschaften einer Serie definiert. Über das Element RESTRICTION_REF werden einer Serie Varianten über Prüfverfahren zugeordnet. Innerhalb der Serie werden Produktgruppen (PRODUCT_GROUPS) definiert, in denen Artikel mit gleichartigen Variantenarten zusammengefasst sind. Die Artikel sind einer Serie automatisch zugeordnet, da sie Kind-Elemente des Elementes SERIE sind.


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Referenzierung
Ansicht mit Navigationswerkzeuge
Einleitung > Referenzierung

Referenzierung von Elementen

Im IDM-Schema werden Beziehungen zwischen Elementen aufgebaut und Informationen an zentraler Stelle definiert und an anderer Stelle mehrfach verwendet. Die Wiederverwendung der Informationen und der Aufbau von Elementbeziehungen erfolgt über Referenzierung. Die im IDM-Schema angewendete Art der Referenzierung wird nachfolgend beschrieben.

Begriffsdefinition

Im IDM-Schema werden für die Referenzierung von Elementen folgende Begriffe verwendet:

Key-Element | Ein XML-Element, welches von anderen Elementen referenziert wird.
Ref-Element | Ein XML-Element, welches andere Elemente referenziert.

Vorgang der Referenzierung

Das Key-Element besitzt Attribute, über die es eindeutig identifiziert wird. Das Ref-Element besitzt minimal die Key-Attribute des Key-Elementes. Zwischen den Elementen wird die Referenz aufgebaut, in dem die Attributwerte des Ref-Elementes denen des Key-Elementes entsprechen.

Beispiel: Referenzierung der Varianten

Im folgenden Beispiel wird eine Variante in einer Ausführungsgruppe neu referenziert.

Key-Element

T_MODIFY_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="400"> <!-- Sockelausführung -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="400"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="401"> <!-- Sockelfarbe -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="401"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

Die XML-Elemente definieren für die Variantenart 400 (FEATURE) drei Varianten (OPTION) mit den Nummern 1-3 sowie für die Variantenart 401 drei Varianten mit den Nummern 1-3. Eine Variante wird identifiziert über die Kombination FEATURE_NO und OPTION_KEY.

Ref-Element

/T_MODIFY_CATALOG/PRICE_DEFINITION/PICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FINISH/OPTION_REF


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Datentypen
Ansicht mit Navigationswerkzeuge
Einleitung > Datentypen

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

Es werden folgende Datentypen genutzt:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDM wird der Datentyp date XML-Schema konform in folgender Weise angewendet: YYYY-MM-DD YYYY = Jahr, MM = Monat, DD = Tag
dateTime | Im IDM wird der Datentyp dateTime XML-Schema konform in folgender Weise angewendet: YYYY-MM-DDThh:mm:ssZ YYYY = Jahr, MM = Monat, DD = Tag T = Beginn der Zeitangabe hh = Stunde, mm = Minute, ss = Sekunde Z = UTC-Zeit
gYear | Im IDM wird der Datentyp dateTime XML-Schema konform in folgender Weise angewendet: YYYY
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDM für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.
anyURI | Der Datentyp wird im IDM für die Darstellung einer URL verwendet. anyURI stellt einen Uniform Resource Identifier (URI) dar. Der lexikalische Bereich von anyURI ist eine endlich lange Zeichenkette, die einem legalen URI entspricht. Ein anyURI-Wert kann absolut oder relativ sein und darf Fragment-Bezeichner enthalten (z.B. könnte es eine URI-Refenz sein).
language | Der Datentyp wird im IDM für die Darstellung von gültigen Sprachschlüsseln verwendet. language repräsentiert Bezeichner für natürliche Sprachen, wie sie in Tags for the Identification of Languages definiert werden. Der Wertebereich von language ist die Menge aller Zeichenketten, die einen gültigen Bezeichner einer natürlichen Sprache darstellen. Für ISO-normierte Sprachen besteht das Format i. A. aus einer Zeichenfolge von 2-3 kleinen Buchstaben optional gefolgt von einem Bindestrich und einem Ländercode bestehend aus 2 großen Buchstaben z. B. en-US.

Die Wertebereiche der obigen Datentypen sind im allgemeinen für die Elemente im IDM eingeschränkt. Über "Restrictions" bei der Datentypdefinition sind Minimal- und Maximalwerte, zulässige Zeichen sowie Wertlisten eingeschränkt.

In der XML-Schema Dokumentation des IDM sind die Wertebereiche durch die Angabe hinter M und P spezifiziert.

Neben den hier genannten XML-Datentypen werden eigene Datentypen für die Texte definiert.

Sie sind am Ende der Dokumentation erklärt.

Siehe auch
languagetexte Complex Type
languagetexte30 Complex Type
languagetexte40 Complex Type
languagetexte60 Complex Type
languagetexte60999 Complex Type


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Erläuterungen zur Dokumentation
Ansicht mit Navigationswerkzeuge
Einleitung > Erläuterungen zur Dokumentation

Erläuterungen zur Dokumentation des IDM

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

TEXT Attribute

Description
" -->
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Variantenarten
Ansicht mit Navigationswerkzeuge
Einleitung > Variantenarten

Variantenart | Variantentext | Ausführungsart | Bemerkung
1 | Programm | A | Programm als VariantenartProgramm als VariantenartProgramm als Variantenart
2 | Seriennummer | A | Zuordnung einer fünfstelligen Seriennummer
100 | Frontausführung | A |
101 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
102 | Frontfarbe 2 | F | Rahmen
103 | Frontfarbe 3 | F | Lisenen
104 | Kantenfarbe Front | F |
105 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
106 | Frontgruppe | A | Überschreibt die FRONT_GROUP_NO in FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Frontausführung Absetzung 1 | A |
111 | Frontfarbe 1 Absetzung 1 | F | Füllung glatte Front = ganze Fläche
112 | Frontfarbe 2 Absetzung 1 | F | Rahmen
113 | Frontfarbe 3 Absetzung 1 | F | Lisenen
114 | Kantenfarbe Front Absetzung 1 | F |
115 | Front-Kombination Absetzung 1 | K | Darf die Varianten 111 bis 114 enthalten
120 | Frontausführung Absetzung 2 | A |
121 | Frontfarbe 1 Absetzung 2 | F | Füllung glatte Front = ganze Fläche
122 | Frontfarbe 2 Absetzung 2 | F | Rahmen
123 | Frontfarbe 3 Absetzung 2 | F | Lisenen
124 | Kantenfarbe Front Absetzung 2 | F |
125 | Front-Kombination Absetzung 2 | K | Darf die Varianten 121 bis 124 enthalten
150 | Glasausführung | A |
151 | Glasfarbe | F |
152 | Sprossenausführung | A |
153 | Sprossenfarbe | F |
154 | Ausführung Glastürrahmen | A |
155 | Farbe Glastürrahmen | F |
160 | Ausführung Jalousie | A |
161 | Farbe Jalousie | F |
170 | Ausführung Schütte | A |
171 | Farbe Schütte | F |
200 | Korpusausführung | A |
201 | Korpus-Kombination | K | Wenn für mehrere Korpusfarben - innen/außen - nur ein Schlüssel vorhanden ist.
202 | Korpusfarbe außen | F |
203 | Korpusfarbe innen | F |
204 | Kantenausführung Korpus | A |
205 | Kantenfarbe Korpus | F |
206 | Sichtseiten-Ausführung | A |
207 | Sichtseiten-Farbe | F |
208 | Korpusfarbe innen für Glas | F | Glasschränke und offene Schränke, die kein Regal sind.
209 | Korpusausf. innen für Glas | A | Glasschränke und offene Schränke, die kein Regal sind.
300 | Griffausführung | A |
301 | Griff-Farbe 1 | F | Griff-, Knopfsockel- bzw. Hauptfarbe
302 | Griff-Farbe 2 | F | Bügel-, Steg- und Knopfblendenfarbe
303 | Griff-Kombination | K | Wenn nur ein Schlüssel für mehrere Griffbedingungen vorgegeben ist.
304 | Grifflagen | NULL | Siehe Grifflagen S. 5-23
400 | Sockelausführung | A |
401 | Sockelfarbe | F |
402 | Sockelhöhe | A |
410 | Ausführung Sockelboden | A |
411 | Farbe Sockelboden | F |
500 | Ausführung Regale | A |
501 | Farbe Regale | F |
502 | Ausführung Kranzprofil | A | Beinhaltet Form und Material
503 | Farbe Kranzprofil | F |
504 | Ausführung Lichtleiste | A | Beinhaltet Form und Material
505 | Farbe Lichtleiste | F |
506 | Ausführung Deckenblende | A |
507 | Farbe Deckenblende | F |
508 | Ausf. u. Schr.-abschlussleiste | A | Untere Schrankabschlußleiste
509 | Farbe u. Schr.-abschlussleiste | F | Untere Schrankabschlußleiste
510 | Ausführung Oberboden | A |
511 | Farbe Oberboden | F |
512 | Ausführung Oberboden-Kante | A |
513 | Farbe Oberboden-Kante | F |
514 | Ausführung Bord | A |
515 | Farbe Bord | F |
516 | Ausführung Bordkante | A |
517 | Farbe Bordkante | F |
520 | Ausführung Wangen/Riegel | A |
521 | Farbe Wangen/Riegel | F |
522 | Ausführung Wangenkante | A |
523 | Farbe Wangenkante | F |
524 | Ausführung Unterboden | A |
525 | Farbe Unterboden | F |
526 | Ausführung Unterboden-Kante | A |
527 | Farbe Unterboden-Kante | F |
550 | Nischenausführung | A |
551 | Nischenfarbe | F |
560 | Ausführung Nischenzubehör | A |
561 | Farbe Nischenzubehör | F |
562 | Ausführung Pilaster | A |
563 | Farbe Pilaster | F |
564 | Ausführung Pilasterkante | A |
565 | Farbe Pilasterkante | F |
600 | Arbeitsplatten-Ausführung | A |
601 | Arbeitsplatten-Farbe | F |
602 | Arbeitsplattenkantenausführung | A |
603 | Arbeitsplatten-Kantenfarbe | F |
604 | Barplatten-Ausführung | A |
605 | Barplatten-Farbe | F |
606 | Barplatten-Kantenausführung | A |
607 | Barplatten-Kantenfarbe | F |
620 | Abdeckplatten-Ausführung | A |
621 | Abdeckplatten-Farbe | F |
622 | Abdeckplatten-Kantenausführung | A |
623 | Abdeckplatten-Kantenfarbe | F |
624 | Ansetztisch-Ausführung | A |
625 | Ansetztisch-Farbe | F |
626 | Ansetztisch-Kantenausführung | A |
627 | Ansetztisch-Kantenfarbe | F |
650 | WAP-Ausführung | A | Wandabschlussprofil
651 | WAP-Farbe | F | Wandabschlussprofil
700 | Schubkastenausführung | A | Innenausstattung
701 | Schubkastenfarbe | F | Innenausstattung
702 | Auszugsausführung | A | Innenausstattung
703 | Auszugsfarbe | F | Innenausstattung
750 | Arbeitsplattenform | S |
751 | Kranzleistenform | S |
752 | Lichtleistenform | S |
753 | Sockelform | S |
754 | Wandabschlussform | S |
755 | Abdeckplattenform | S |
756 | Barplattenform | S |
800 | Ausführung Elektrogeräte | A |
801 | Farbe Elektrogeräte | F |
802 | Farbe Elektrogeräte-Zubehör | F |
850 | Ausführung Spülen | A |
851 | Farbe Spülen | F |
852 | Farbe Spülenzubehör | F |
853 | Mischbatterien Farbe | F |
854 | Ausführung Mischbatterien | A |
900 | Ausführung Allgemeines Zubehör | A |
901 | Farbe Allgemeines Zubehör | F |
930 | zus. grafisch relevante Ausführung 1 | A | unbedingt den Softwarehäusern separat mitteilen
931 | zus. grafisch relevante Farbe 1 | F | unbedingt den Softwarehäusern separat mitteilen
932 | zus. grafisch relevante Ausführung 2 | A | unbedingt den Softwarehäusern separat mitteilen
933 | zus. grafisch relevante Farbe 2 | F | unbedingt den Softwarehäusern separat mitteilen
934 | zus. grafisch relevante Ausführung 3 | A | unbedingt den Softwarehäusern separat mitteilen
935 | zus. grafisch relevante Farbe 3 | F | unbedingt den Softwarehäusern separat mitteilen
936 | zus. grafisch relevante Ausführung 4 | A | unbedingt den Softwarehäusern separat mitteilen
937 | zus. grafisch relevante Farbe 4 | F | unbedingt den Softwarehäusern separat mitteilen
938 | zus. grafisch relevante Ausführung 5 | A | unbedingt den Softwarehäusern separat mitteilen
939 | zus. grafisch relevante Farbe 5 | F | unbedingt den Softwarehäusern separat mitteilen
950 | Ausführung Diverses 1 | A |
951 | Farbe Diverses 1 | F |
952 | Ausführung Diverses 2 | A |
953 | Farbe Diverses 2 | F |
954 | Ausführung Diverses 3 | A |
955 | Farbe Diverses 3 | F |
956 | Ausführung Diverses 4 | A |
957 | Farbe Diverses 4 | F |
958 | Ausführung Diverses 5 | A |
959 | Farbe Diverses 5 | F |
960 | Ausführung Diverses 6 | A |
961 | Farbe Diverses 6 | F |
962 | Ausführung Diverses 7 | A |
963 | Farbe Diverses 7 | F |
964 | Ausführung Diverses 8 | A |
965 | Farbe Diverses 8 | F |
966 | Ausführung Diverses 9 | A |
967 | Farbe Diverses 9 | F |
968 | Ausführung Diverses 10 | A |
969 | Farbe Diverses 10 | F |
970 | Ausführung Diverses 11 | A |
971 | Farbe Diverses 11 | F |
972 | Ausführung Diverses 12 | A |
973 | Farbe Diverses 12 | F |
974 | Ausführung Diverses 13 | A |
975 | Farbe Diverses 13 | F |
976 | Ausführung Diverses 14 | A |
977 | Farbe Diverses 14 | F |
978 | Ausführung Diverses 15 | A |
979 | Farbe Diverses 15 | F |
980 | Ausführung Diverses 16 | A |
981 | Farbe Diverses 16 | F |
982 | Ausführung Diverses 17 | A |
983 | Farbe Diverses 17 | F |
984 | Ausführung Diverses 18 | A |
985 | Farbe Diverses 18 | F |
986 | Ausführung Diverses 19 | A |
987 | Farbe Diverses 19 | F |
988 | Ausführung Diverses 20 | A |
989 | Farbe Diverses 20 | F |
999 | Fixe Materialzuordnung | F |

Typ: A = Ausführung

F = Farbe

K = Kombination

S = Form


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Sprachenschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprache
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AK | Akan
AM | Amharisch
AN | Aragonesisch
AR | Arabisch
AS | Assamesisch
AV | Avarisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Belorussisch
BG | Bulgarisch
BH | Bihari
BI | Bislama
BM | Bambara
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CR | Cree
CS | Tschechisch
CU | Alt-Slawisch
CV | Tschuwaschisch
CY | Walisisch
DA | Dänisch
DE | Deutsch
DV | Dhivehi
DZ | Dzongkha
EE | Ewe
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FF | Fulfulde
FI | Finnisch
FJ | Fidschianisch
FO | Färöisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
GV | Manx, Manx-Gälisch
HA | Hausa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HT | Haitianisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiaq
IN | Ehemalig Indonesisch
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut (Eskimosprache)
JA | Japanisch
JV | Javanisch
KA | Georgisch
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KR | Kanuri
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KW | Kornisch
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LG | Luganda
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LU | Kiluba
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Niederländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VE | Tshivenda
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Länderschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Länderschlüssel

Länderkennzeichen | Ländername(deutsch) | Ländername(englisch)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Einkaufsverbände
Ansicht mit Navigationswerkzeuge
Einleitung > Einkaufsverbände

Verbandskunde | Verbandsname | Strasse | PLZ | Ort | Telefon | Fax
AMBRA | AMBRA Vertriebsgesellschaft mbH & Co. KG | Pfälzer Straße 10 | 33332 | Gütersloh | +49(5241)9246-0 | +49(5241)9246-49
AMM | Alliance Möbel-Marketing GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
ANT | ANTARES Einkaufs- und Marketinggesellschaft GmbH & Co. KG | Ramlinger Str. 50 | 31303 | Burgdorf-Ehlershausen | +49(5085)955887 | +49(5085)-955885
ASSIMA | ASSIMA Verbund GmbH & Co. KG | Bussardweg 18 | 41468 | Neuss | +49(2131)310400 | +49(2131)310469
ATLAS | Atlas-Einrichtungs-Einkauf GmbH | Brunshofstr. 2 | 45470 | Mülheim a. d. Ruhr | +49(208)992400 | +49(208)9924099
AWD | AWD Einkaufs- und Marketinggesellschaft für Wohnkomfort mbH | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
BAUR | Baur Friedrich GmbH Zentraleinkauf | Bahnhofstr. 10 | 96224 | Burgkunstadt | +49(9572)912739 o. 912746 | +49(9572)912006
BEGROS | Begros GmbH | Graf-Zeppelin-Str. 5 | 46149 | Oberhausen | +49(208)99493-0 | +49(208)99493-911
BETTENKREIS | BETTENKREIS GmbH & Co. | Pascalstr. 4 | 47506 | Neukirchen-Vluyn | +49(2845)9134-0 | +49(2845)9134-34
BETTENRING | BETTENRING eG | Echterdinger Str. 115 | 70794 | Filderstadt | +49(711)70958-0 | +49(711)70958-66
BRANION | BRANION GmbH | Soennecken-Platz | 51491 | Overath | +49(2206)607-0 | +49(2206)607-199
BÜRORING | BÜRORING eG | Siemensstr. 7 | 42781 | Haan | +49(2129)5571-0 | +49(2129)5571-93
CI | Createive Inneneinrichter | Spreestr. 3 | 64295 | Darmstadt | +49(6151)39128-0 | +49(6151)39128-28
CON | Concorde Möbel-Einkaufs-GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | 0211-47236-0 | 0211-4180034
CP | CREATIVE PARTNEr Service- und Einkaufs-Kooperation GmbH | Otto-Hahn-Str. 6 d | 21509 | Glinde | +49(40)728161-0 | +49(40)728161-21
DKR | Der Küchenring GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
DMV | DEUTSCHER MÖBEL-VERBUND Handels GmbH | Ampertal 8 | 85777 | Fahrenzhausen-Unterbruck | +49(8133)89-0 | +49(8133)-89-199
DSM | Drosser & Schaffer Marketing GmbH | Würmstr. 13 A | 82166 | Gräfelfing | +49(89)89878434/-26 /-28 | +49(89)89878440
DU | DECOR UNION GmbH & Co. KG | Brüsseler Str. 3 | 30539 | Hannover | +49(511)8789-0 | +49(511)8789-299
EBUCH | ebuch eG | O'Brien-Str. 3 | 91126 | Schwabach | +49(9122)9386-0 | +49(9122)9386-68
EDE | Einkaufsbüro Deutscher Eisenhändler GmbH | Dieselstr. 33 | 42389 | Wuppertal | +49(202)6096-0 | +49(202)6096-331
EGEPACK | EGEPACK Einkaufs- und Vertriebsgesellschaft mbH | Bödekerstr. 7 | 30161 | Hannover | +49(511)38841-03 / -04 | +49(511)3884064
EIS | E.I. S. GmbH | Von-Hünefeld-Str. 41 | 50829 | Köln | +49(211)59797-44 / -45 | +49(211)59797-21
EK | Grosseinkauf eG | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-144
EKAFLOR | ekaflor GmbH & Co. KG | Watzmannstr. 3 | 90471 | Nürnberg | +49(911)981166-0 | +49(911)981166-5
ELTKONTOR | ELTKONTOR GmbH & Co. KG | Oldenburger Allee 21 | 30659 | Hannover | +49(511)61599-0 | +49(511)61599-77
EM | Europa Möbel | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EMV | Europa Möbel-Verbund (EMV) | Ampertal 8 | 85777 | Fahrenzhausen-Unterbrück | +49(8133)89-0 | +49(8133)89-199
ESG | ESG Einkaufs- und Service Gesellschaft mbH | Berliner Str. 26 | 33378 | Rheda-Wiedenbrück | +49(5242)9453-0 | +49(5242)9453-53
EUROKON | EUROPA-KONTOR GmbH & Co. KG | Amsterdamer Str 230 | 50735 | Köln | +49(221)971491-21 | +49(221)971491-60
EUROPA | GROSSEINKAUF EUROPA MÖBEL GmbH & Co. KG | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EVB | EVB BauPunkt Einkaufs- und Handelsgemeinschaft GmbH & Co. KG | Zillenhardtstr. 46 | 73037 | Göppingen | +49(7161)99931-70/ -71 | +49(7161)99931-72
EWEPA | E W E P A GmbH | Oberevinger Str. 5 | 44339 | Dortmund | +49(231)985127-0 | +49(231)-985127-17 / -18
FHG | FHG Fach-Handels-gesellschaft mbH & Co. KG | Brühler Str. 55/58 | 42657 | Solingen | +49(212)24809-0 | +49(212)24809-119
FHR | F H R Fachhandelsring GmbH | Am Pfaffensee 4 | 67376 | Harthausen | +49(6344)9533-0 | +49(6344)9533-90
FS | "FÜR SIE" Handelsgenossenschaft eg Food-Non Food | An der Münze 12-18 | 50668 | Köln | +49(221)16041-0 | +49(221)16041-821
GARANT | GARANT-MÖBEL-MARKETING LAUTEN GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
GEDK | Ge-dk Unternehmensbetreuungsgesellschaft mbH | Beinhaltet Form und Material | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
GFM | G f M Möbeleinkaufsverbund GmbH & Co. Betriebs KG | Donaustr. 15 | 93333 | Neustadt a. d. D. | +49(9445)204-0 | +49(9445)204-155
HBO | H.B.O. Einkauf + Marketing GmbH & Co. | Dietrichsweg 64 | 26127 | Oldenburg | +49(441)96182-0 | +49(441)96182-55
HIS | Home in style Raumgsestaltung GmbH & Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-370 | +49(7231)915-259
HLH | HolzLand Holzhandels GmbH | Friedrich-Engels-Allee 432 | 42283 | Wuppertal | +49(202)55138-0 | +49(202)55138-10
HOLZRING | DER HOLZRING Handelsgesellschaft mbH | Universitätsallee 5 | 28359 | Bremen | +49(421)22315-0 | +49(421)22315-11
INKU | INKU GmbH + Co. | Nikolaus-Otto-Str. 6 | 70771 | Leinfelden-Echterdingen | +49(711)9492-438 | +49(711)9192-436
K581018 | NULL |  |  |  |  |
KA | K + A Küchen Aktuell GmbH | Senefelder Str. 2 a | 38124 | Braunscheig | +49(531)26134-0 | +49(531)26134-39
KAK | Küchen-Aktiv-Kreis | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KAREAL | Küchen Areal GmbH & Co. KG | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-163 | +49(5242)409-202
KARST | Karstadt Warenhaus AG | Theresienhöhe 5 | 80339 | München | +49(89)5105-0 | +49(89)5105-300
KATAG | KATAG International Partners GmbH | Stralsunder Str. 5 | 33605 | Bielefeld | +49(521)292-0 | +49(521)292-101/299
KAUFRING | KAUFRING AG | Kieshecker Weg 100 | 40468 | Düsseldorf | +49(211)4242-0 | +49(211)4242-444
KC | Küche & Co |  |  |  |  |
KER | Küchen-Einkaufs-Ring | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KGA | Koop Garant/Areal: EK-Grosseinkauf | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-559
KIG | Küchen-Interessen-Gesellschaft mbH | Strauberger Platz 19 | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
KL | Küchenliga | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
KOA | Koop Alliance FUTURA einkaufs-Gesellschaft mbH & Co. KG | Rolshoverstr. 227 | 51072 | Köln-Poll | +49(221)9836666 | +49(221)9836667
KP | Küchen Partner AG | Rüdesheimer Str. 34 | 65239 | Hochheim am Main | +49(6146)8340-0 | +49(6146)8340-40
KREIS | "DER KREIS" Einkaufsgesellschaft für Küche & Wohnen mbH & Co. KG | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)606700 | +49(7152)73017
KTEM | KTEM | Heemstr. 4 | 27793 | Wildeshausen | +49(4431)92067 | +49(4431)92069
LGF | MeisterTeam LGF GmbH | Rotenhäuser Str. 12 | 21109 | Hamburg | +49(40)7534091 | +49(40)7522019
LUTZ | LUTZ |  |  |  |  |
MBV | MBV Marketing Gesellschat mbH & Co. Lichthauspartner KG | Zeiloch 13 | 76643 | Bruchsal | +49(7251)7240890 | +49(7251)72408979
MDM | Küchenmarketing MDM GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
MHKD | musterhaus küchen Deutschland GmbH & Co. KG | Im Gefierth 9a | 36603 | Dreieich | +49(6103)391-0 | +49(6103)391-109
MIG | MIG Möbel-Interessen-Gemeinschaft GmbH & Co. KG | Industriestr. 41 | 53359 | Rheinbach | +49(2226)9221-0 | +49(2226)9221-22
MKK | Fachhändler Gemeinschaft "meister.Küchen-Konzepte" | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
MM | Möbel Mann GmbH | Durlacher Allee 109 | 76137 | Karlsruhe | +49(721)6096-298 | +49(721)6096-557
MON | Mondial GmbH | Eichsfelder Str. 17 | 40595 | Düsseldorf (Garath) | +49(211)702621-13 | +49(211)702621-30
MP | www.mig-power.de GmbH & Co. KG | Aktienstr. 2 | 45359 | Essen | +49(201)811710 | +49(201)2699838
MSI | Musterring International Josef Höner GmbH & Co. KG | Hauptstr. 134-140 | 33378 | Rheda-Wiedenbrück | +49(5242)592-01 | +49(5242)592-149
MV | Mega Verbund AG | St- Alban-Vorstadt 94 | CH-4052 | Basel | +41(61)2069070 | +41(61)-2069079
MZE | M Z E - Möbel-Zentral-Einkauf GmbH | Loheg 31 | 85375 | Neufarn b. Freising | +49(8165)9526-0 | +49(8165)9526-50
NB | Nürnberger Bund Grosseinkauf eG | Theodor-Althoff-Str. 39 | 45133 | Essen | +49(201)8709-0 |
NECK | Neckermann Versand AG | Hanauer Landstr. 360-400 | 60386 | Frankfurt/Main | +49(69)404-8697 | +49(69)404-8508
NOWEDA | NOWEDA eG | Heinrich-Strunk-Str. 77 | 45143 | Essen | +49(201)802-0 | +49(201)802-1314
NREM | nrc Nordring Einkauf- und Marketing-Cooperation GmbH | Am Redder 1 | 24558 | Henstedt-Ulzburg | +49(4193)9585-0 | +49(4193)9585-25
NWH | NORDWEST Handel AG | Berliner Str. 26-36 | 58135 | Hagen | +49(2331)461-0 | +49(2331)461-389
ÖkoPlus | ÖkoPlus AG Fachhandelsverbund für Ökologisches Bauen + Wohnen | Kasseler Str. 1 A | 60486 | Frankfurt | +49(69)70793013 | +49(69)70793016
OTTO | Otto Versand | Wandsbecker Str. 3-7 | 22179 | Hamburg | +49(40)64610 | +49(40)64618571
PARMA | parma-Aurel GmbH & Co. KG | Grosse-Kurfürsten-Str. 75 | 33615 | Bielefeld | +49(521)52077-0 | +49(521)52077-77
PRISMA | PRISMA Einkaufs- und Marketinggesellschaft mbH | Amsterdamer Str. 230 | 50735 | Köln | +49(221)971410-9 | +49(221)971410-84
ProÖko | Pro Öko Servicegesellschaft ökologischer Einrichtungshäuser mbH | Subbelrather Str. 24 | 50823 | Köln | +49(221)56968-0 | +49(221)56968-21
QUE | Grossversandhaus Quelle, Gustav Schickedanz KG | Thomas-Mann-Str. 50 | 90329 | Nürnberg 50 | +49(911)8152150 | +49(911)8152036
RED | Reddy Küchen und Elektro Vertriebs GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
REGENT | REGENT MÖBEL Grosseinkauf GmbH & Co. KG | Benzstr. 4 | 45891 | Gelsenkirchen | +49(209)9705-0 | +49(209)9705-188
SHK | S H K Einkaufs- und Vertriebsgesellschaft mbH & Co. KG | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
SOFATEX | sofatex Leistungsgemeinschaft GmbH | E.-C.-Baumann-Str. 12 | 95326 | Kulmbach | +49(9221)80064 | +49(9221)80066
SÜDRING | Südring GmbH & Co. KG | Nordstr. 71 | 63450 | Hanau | +49(6181)9104-0 | +49(6181)9104-44
TEV | Textil-Einkaufsverband "NORDWEST" eG | Nordweststr. | 59387 | Ascheberg | +49(2593)818 | +49(2593)7085
TREND | TReND Möbel-Handels-GmbH & Co. Einrichtungs KG | Im Lipperfeld 42 | 46047 | Oberhausen | +49(208)8205-0 | +49(208)8205-210
UNION | UNION Einkaufs GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | +49(211)47236-0 | +49(211)4180034
UNITEX | u n i t e x Einkaufsverband GmbH | Albrecht-Berblinger-Str. 11 | 89231 | Neu Ulm-Schwaighofen | +49(731)707940 | +49(731)7079446 / 7079424
VAR | Varia KE Franchise Warenvertriebsgesellschaft mbH | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)6097-25 | +49(7152)73017
VE | Vesta Küchenhandels GmbH | Industriestr. 9 | 96114 | Hirschaid | +49(9543)842330 | +49(9543)842340
VKG | V K G Vereinigter Küchenfachhandel GmbH + Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-0 | +49(7231)915-160
VME | V M E Vereinigte Möbeleinkaufs-GmbH & Co. KG | An der Wesebreede 2 | 33699 | Bielefeld | +49(521)20885-0 | +49(521)20885-60
WGMEM | Wohngruppe Möbeleinkauf + Marketing GmbH | Schleifweg 10 | 74257 | Untereisesheim | +49(7132)9988-0 | +49(7132)9988-44
WK | WK - WOHNEN Einrichtungs-GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +496103)391-109
WOTEX | Wotex Intercolor | Pappelweg 11 | 66578 | Schiffweiler | +49(6821)9614-0 | +49(6821)9614-60


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Standardgrifflagen
Ansicht mit Navigationswerkzeuge

Standardgrifflage | Bezeichnung | Abbildung | Beschreibung
0 | Ohne Bohrung mit Griff |  | Gilt für alle Fronttypen
1 | Waagerecht mittig - Senkrecht außen |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
2 | Waagerecht mittig - Waagerecht außen |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
3 | Senkrecht mittig - Senkrecht außen |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
4 | Senkrecht mittig - Waagerecht außen |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
5 | Waagerecht mittig - Senkrecht mittig |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
6 | Waagerecht mittig - Waagerecht mittig |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
7 | Senkrecht mittig - Senkrecht mittig |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
8 | Senkrecht mittig - Waagerecht mittig |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
9 | Waagerecht Gesamtoben - Waagerecht Gesamtoben |  | Anordnung waagerecht oben über die gesamte Breite für: Schubkästen; Auszüge; Jalousien (horizontal). Anordnung waagerecht über die gesamte Breite für: Türen; Glastüren; Klappen; Rollfronten (vertikal).
10 | Waagerecht Gesamtunten - Waagerecht Gesamtoben |  | Anordnung waagerecht unten über die gesamte Breite für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Anordnung waagerecht über die gesamte Breite für: Türen; Glastüren; Rollfronten (vertikal).
11 | Waagerecht Gesamtoben - Senkrecht Gesamtaußen |  | Anordnung waagerecht oben über die gesamte Breite für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Anordnung senkrecht außen über die gesamte Höhe für: Türen; Glastüren; Rollfronten (vertikal).
12 | Waagerecht Gesamtunten - Senkrecht Gesamtaußen |  | Anordnung waagerecht unten über die gesamte Breite für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Anordnung senkrecht außen über die gesamte Höhe für: Türen; Glastüren; Rollfronten (vertikal).
90 | Keine Standardgrifflage passt |  |
91 | Keine Standardgrifflage passt |  |
92 | Keine Standardgrifflage passt |  |
93 | Keine Standardgrifflage passt |  |
94 | Keine Standardgrifflage passt |  |
95 | Keine Standardgrifflage passt |  |
96 | Keine Standardgrifflage passt |  |
97 | Keine Standardgrifflage passt |  |
98 | Keine Standardgrifflage passt |  |
99 | Ohne Bohrung ohne Griff |  |


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Geforderte Variantenarten
Ansicht mit Navigationswerkzeuge

Zur Sicherstellung, dass alle benötigten Variantenarten im Planungsprozess bereitstehen werden Muss-Variantenarten definiert, die in Abhängigkeit des Typschlüssels eines Artikels geliefert werden müssen.

Typschlüssel | geforderte Variantenarten
Typenschlüssel-Art 8 oder 27 | 520,521
Typenschlüssel-Art 26 | 562,563
Typenschlüssel-Art 2 | 500,501
Typenschlüssel-Art 29 | 514,515
Typenschlüssel 5 | 550,551
Typenschlüssel 20 oder 21 | 510,511
Typenschlüssel 12 | 504,505
Typenschlüssel 11 | 502,503
Typenschlüssel 14 oder 15 | 400,401,402
Typenschlüssel 18 | 650,651
Typenschlüssel 17 | 600,601
Frontauspraegungsschlüssel 4 | 151, 154, 208
Branch_ID=K | 101,202,203,205

Alle Typenschlüssel sind der Tabelle Typenschlüssel zu entnehmen.

Die Typenschlüssel-Art ist in der Tabelle Typenschlüssel-Arten eingetragen


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Dateibenennung
Ansicht mit Navigationswerkzeuge
Einleitung > Dateibenennung

Für den Dateinamen eines Datensatzes werden folgende Empfehlungen gegeben:

· Der Name des Datensatzes darf nicht auf 8 Zeichen begrenzt sein.

· Möglichst sollten alle Bestandteile aus dem Element CATALOG_IDENTIFICATION genutzt werden:

· Folgende Bestandteile wurden vorgeschlagen:

· Herstellernummer

· IDM-Version

· Kundennummer (Wert aus dem Element ASSOC_CTM_NO)

· Sämtliche Sprachen

· Jahreszahl

· Haupt-Nummer (MIN_MAJOR_NO)

· Zeitstempel der Dateifreigabe (FILE_RELEASE_DATE)


%%LocalItemTitle%%

Elemente
Element | Beschreibung
T_MODIFY_CATALOG | In diesem Element werden alle Informationen und Daten für die Modifikation eines vorhandenen Kataloges/Datenbestandes hinterlegt.
Komplexe Typen
Complex Type | Beschreibung
languagetexte | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.
languagetexte30 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
languagetexte40 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.
languagetexte60 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.
languagetexte60999 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten bstehend aus bis zu 999 Zeilen der Länge 60.

© 2020 All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Elementreferenz
Ansicht mit Navigationswerkzeuge


%%LocalItemTitle%%

T_MODIFY_CATALOG Element
Modifikation IDM 2.7.0 XML-Schema : T_MODIFY_CATALOG Element
Beschreibung
In diesem Element werden alle Informationen und Daten für die Modifikation eines vorhandenen Kataloges/Datenbestandes hinterlegt.
Namensraum (none)
Diagramm
PRICE_DEFINITION Element FEATURE_DEFINITION Element SERIES Element REF_CATALOG Element CATALOG Element Signature Element Sequence T_MODIFY_CATALOG Element
Overview
T_MODIFY_CATALOG
In diesem Element werden alle Informationen und Daten für die Modifikation eines vorhandenen Kataloges/Datenbestandes hinterlegt.
MAJOR required Restriction of xs:positiveInteger
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION. 		D nonNegativeInteger
P
M [2]
MINOR required Restriction of xs:nonNegativeInteger
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:99]
REVISION required Restriction of xs:nonNegativeInteger
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt. D nonNegativeInteger
P
M [0:99]
Sequence
Signature optional

Dieses Element dient der Angabe einer Veschlüsselung.

Das Wurzelelement einer digitalen Signatur mit XML wird durch das Element Signature dargestellt.

Signature besitzt zwei Kindelemente, wovon die beiden Elemente SignedInfo und SignatureValue Pflicht sind.

Sequence
SignedInfo

Das erste und auch komplexeste Element innerhalb von Signature ist SignedInfo und enthält die verwendeten Algorithmen zur Kanonisierung und Signierung, eine oder mehrere Referenzen auf die signierten Daten, eventuelle Transformationen und die Hashwerte dieser Daten. SignedInfo enthält also alle Informationen zu den zu signierenden Ressourcen und ist damit der Teil, über den die digitale Signatur erstellt wird.

Mit dem Signieren der verwendeten Algorithmen erhöht sich die Sicherheit. Ein sicherer Algorithmus kann so nicht gegen einen unsicheren ausgetauscht werden, ohne dass die Signatur ungültig wird.

Kindelemente von SignedInfo sind die Pflichtelemente CanonicalizationMethod und SignatureMethod sowie ein oder mehrere Reference Elemente.

Sequence
CanonicalizationMethod Extension of xs:string

Das leere Pflichtelement CanonicalizationMethod enthält ein Algorithm Attribut zur Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird.

Beim Kanonisieren eines XML-Dokuments finden die folgenden Aktionen statt:

  • Das Dokument wird in UTF-8 kodiert
  • Zeilenumbrüche werden vor dem Parsen normalisiert zu #xA
  • Attributwerte werden normalisiert (wie bei einem validierenden Parser)
  • Character- und parsed-entity Referenzen werden ersetzt
  • CDATA Abschnitte werden durch ihren Inhalt ersetzt
  • Die XML-Deklaration und eine möglicherweise vorhandene DTD werden entfernt
  • Leere Elemente werden zu Start-End-Tag Paaren umgewandelt
  • Whitespace außerhalb des Dokumentelements und innerhalb von Start- und End-Tags wird normalisiert
  • Whitespace in Textknoten wird beibehalten (gilt jedoch nicht für Zeichen die bei der Normalisierung der Zeilenumbrüche entfernt wurden)
  • Attributwerte werden in doppelten Anführungsstrichen eingeschlossen
  • Sonderzeichen in Attributwerten und Textknoten werden durch Zeichenreferenzen ersetzt
  • Überflüssige Namespace Deklarationen werden von jedem Element entfernt
  • Defaultattribute werden zu den jeweiligen Elementen hinzugefügt
  • Namespace Deklarationen und Attribute werden alphanumerisch sortiert
Algorithm optional xs:anyURI
Dieses Attribut dient der Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird. Die Angabe erfolgt durch einen URI. D anyURI
P
M
SignatureMethod Extension of xs:string
SignatureMethod ist ebenfalls ein leeres Pflichtelement mit einem Algorithm Attribut und gibt den zur Signaturgenerierung (und später zur Verifizierung) verwendeten Algorithmus an. Mit diesem Algorithmus wird das kanonische SignedInfo Element in den SignatureValue konvertiert.
Algorithm optional xs:anyURI

Mit diesem Attribut wird der Algorithmus zur Signaturgenerierung über einen URI angegeben.

 D anyURI
P
M
Reference

Das Reference Element gibt an, welche beliebigen, auch binären, Daten in die Signaturberechnung miteinbezogen werden sollen. Das Reference Elemente stellt somit den Kern einer Signatur dar.

XML-Signaturen signieren niemals direkt die Ressourcen, sondern legen zunächst eine Liste von Hashwerten dieser an. Diese Liste wird dann mit einem Signatur-Algorithmus signiert. Damit wird nicht nur die Signatur-Operation beschleunigt, sondern auch ein einfacher Weg angeboten, um mehrere Ressourcen gleichzeitig zu signieren.

Zum Reference Element gehört das optionale Attribute URI.

URI optional xs:string

Das Attribut URI ist ebenfalls vom Typ anyURI und enthält die Adresse, unter der die zu signierenden Daten verfügbar sind. Die Daten, auf die sich die digitale Signatur bezieht, müssen nicht im Signature Element selbst vorhanden sein, sondern können auch über das lokale Dateisystem oder eine Internet-Adresse referenziert werden.

Daneben gibt es noch URIs, die auf das aktuelle Dokument verweisen wie z.B. URI="". Dieser spezielle Uniform Resource Identifier steht für alle XML-Knoten des aktuellen XML-Dokuments, jedoch ohne die möglicherweise vorhandenen Kommentare. Die zur Signatur gehörenden Knoten sind in der Auswahl jedoch enthalten.

 D anyURI
P
M
Sequence
Transforms

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Sequence
Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.
Algorithm optional xs:anyURI

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M
DigestValue xs:string
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon). D string
P
M
SignatureValue xs:string

Das Element SignatureValue enthält in binärer Form (immer Base-64 encoding) den über das gesamte SignedInfo Element berechneten Hashwert der Signatur. Dieser Hashwert wird mit dem in der SignatureMethod angegebenen Algorithmus, den kanonisierten Daten und dem privaten Schlüssel berechnet. Damit wird nicht die Nachricht selbst, sondern deren - in der Regel viel kürzerer - Hashwert unterschrieben (Hash-Then-Sign Paradigma).

In den unterschriebenen Daten sind somit sämtliche Informationen über die signierten Referenzen und deren Hashwerte enthalten. Damit ist es nicht erforderlich, dass die Daten selbst im Dokument vorliegen. Die Angaben über die verwendeten Algorithmen fließen jedoch mit in die Signaturberechnung ein. Dadurch werden nachträgliche Manipulationen verhindert.

Da alle Referenzen vor dem Signieren zusammengefasst und gemeinsam signiert werden existiert für die gesamte Signatur immer genau ein SignatureValue Element.

 D string
P
M
CATALOG
In diesem Element werden administrative Informationen zum Datenbestand hinterlegt.
Sequence
FILE_RELEASE_DATE xs:dateTime
Das Element FILE_RELEASE_DATE sollte automatisch beim Export der Daten gesetzt werden und das aktuelle Datum und die UTC-Uhrzeit beinhalten. D dateTime
P
M
CATALOG_IDENTIFICATION
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger

Dieses Feld dient der Identifizierung der Verbandskataloge.
Folgende Werte sind möglich:
2 = Verbandskatalog
3 =kundenspezifischer Katalog

Da das Feld nur mit 2 oder 3 gefüllt sein darf, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden.

D positiveInteger
P
M [2:3]
ASSOC_CTM_NO Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände"). 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
CATALOG_YEAR xs:gYear
Dieses Element bezieht sich auf das Kalenderjahr der Katalogdaten des Hauptkataloges. D gYear
P
M
MIN_MAJOR_NO Restriction of xs:positiveInteger
Wird ein neuer Katalog heraus gegeben oder werden Löschungen in einem Katalog vorgenommen, ändert sich, die Hauptnummer (MAJOR_NO) des Hauptkataloges. Wird die Änderung in einem neuen Jahr vollzogen, wird dass Kalenderjahr (CATALOG_YEAR) angepasst und die Hauptnummer auf 1 gesetzt. Wird in einem Jahr kein neuer Katalog bereitgestellt und keine Löschungen durchgeführt, bleibt das Kalenderjahr und die Hauptnummer bestehen. Das Element MIN_MAJOR_NO enthält den Mindestwert von MAJOR_NO des Hauptkataloges. D positiveInteger
P
M 1:99
CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, dass es sich bei den bereitgestellten Daten um M = Modifzierungsdaten gegenüber dem Hauptkatalog handelt. D string
P [M]
M [1:1]
CATALOG_INFO languagetexte60999 Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
REF_CATALOG
In diesem Element wird angegeben, auf welchen Katalog sich die Modifikationsdatei bezieht.
Sequence
CATALOG_IDENTIFICATION
in diesem Element wird der Katalog identifiziert, auf den sich diese Modifikationsdatei bezieht. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
ASSOC_CTM_NO optional Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Kurzbezeichnung Einkaufsverbände"). 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
SERIES optional
In diesem Element werden alle Serien des Kataloges/Datenbestandes hinterlegt, an denen Modifikationen zum Basiskatalog vorgenommen werden einschließlich ihrer zugeordneten Elemente wie beipsielsweise Produktgruppen oder Artikeln .
Sequence
SERIE 1..100
In diesem Element werden die Serien definiert, bei denen Modifikationen zum Basiskatalog vorgenommen werden.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie referenziert. D nonNegativeInteger
P
M [0:99]
Sequence
SERIES_NAME optional
Dieses Element gibt den modifizierten Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D string
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.
Das Element TEXT beinhaltet den Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PRODUCT_GROUPS
In diesem Element werden auf die Produktgruppen referenziert, in denen Modifikationen gegenüber dem Basiskatalog vorgenommen werden. In Produktgruppen sind Artikel mit gleichen Variantenarten gruppiert (z. B. Regale).
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden zu modifizierende Artikel angelegt, die in dem Basiskatalog zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
ITEMS
In diesem Element werden alle zu modifiziernden Artikel einer Produktgruppe referenziert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel und Blöcke angegeben, deren Gültigkeit sich gegenüber dem Hauptkatalog ändert. Ein Artikel wird identifiziert über die Attribute SERIE_NO und TYPE_NO
FEATURE_DEFINITION optional
In diesem Element werden zu modifizierende variantenabhängige Informationen hinterlegt.
Sequence
FEATURES
In diesem Element werden die Variantenarten (FEATURE) und die zughörigen zu modifizieren Varianten definiert. Es werden nur die Variantenarten angegeben, die zur Modifizierung des Kataloges erforderlich sind.
Sequence
FEATURE 1..∞
In diesem Element wird eine Variantenart definiert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand zu modifizierenden Varianten abgelegt.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung definiert. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein modifizierter Variantentext definiert.
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante modifiziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
VALID_FROM optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefällt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwänscht, muss das Element leer bleiben.

 D date
P
M
PRICE_DEFINITION optional
In diesem Element werden Informationen für die Katalogmodfizierung hinterlegt, die für die Preisberechnung notwengig sind wie beispielsweise Preistabellen und Ausführungsgruppen.
Sequence
PRICE_FEATURE_GROUPS
In diesem Element werden Preisvariantengruppen referenziert, die gegenüber dem Basiskatalog modifiziert werden.
Sequence
PRICE_FEATURE_GROUP 1..∞
In diesem Element werden eine Preisvariantengruppe referenziert, die gegenüber dem Basiskatalog Modifikationsinformationen enthalten soll.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
Sequence
FINISH 0..∞
In diesem Element werden Variantenkombinationen zu modifizierten Preisfeldern (Preisfeld, Blockpreisfeld) und einer Herstellerpreisgruppe zugeordnet.
Sequence
OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2 im Basiskatalog) abgelegt.
Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem veränderten Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2 im Basiskatalog).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die veränderte Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MAJOR Restriction of xs:positiveInteger required
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION. 		D nonNegativeInteger
P
M [2]
MINOR Restriction of xs:nonNegativeInteger required
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:99]
REVISION Restriction of xs:nonNegativeInteger required
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="T_MODIFY_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Signature" minOccurs="0" maxOccurs="1">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SignedInfo">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CanonicalizationMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="SignatureMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="Reference">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="Transforms">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="Transform">
                                <xs:complexType>
                                  <xs:simpleContent>
                                    <xs:extension base="xs:string">
                                      <xs:attribute name="Algorithm" type="xs:anyURI" />
                                    </xs:extension>
                                  </xs:simpleContent>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DigestMethod">
                          <xs:complexType>
                            <xs:simpleContent>
                              <xs:extension base="xs:string">
                                <xs:attribute name="Algorithm" type="xs:anyURI" />
                              </xs:extension>
                            </xs:simpleContent>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DigestValue" type="xs:string" />
                      </xs:sequence>
                      <xs:attribute name="URI" type="xs:string" />
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SignatureValue" type="xs:string" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FILE_RELEASE_DATE" type="xs:dateTime">
              <xs:annotation>
                <xs:documentation>100--2--Dateifreigabe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_ID">
                    <xs:annotation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--13--Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CATALOG_KIND">
                    <xs:annotation>
                      <xs:documentation>Katalog-Art</xs:documentation>
                      <xs:documentation>2 für Verbandskatalog</xs:documentation>
                      <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
                      <xs:documentation>geändert 17.04.2019</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="3" />
                        <xs:minInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ASSOC_CTM_NO">
                    <xs:annotation>
                      <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRODUCT_BRANDNAME">
                    <xs:annotation>
                      <xs:documentation>100--40--Produktmarke</xs:documentation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_ID">
                    <xs:annotation>
                      <xs:documentation>100--49--Preis_ID</xs:documentation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT">
                    <xs:annotation>
                      <xs:documentation>200--4--MwSt</xs:documentation>
                      <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_YEAR" type="xs:gYear">
              <xs:annotation>
                <xs:documentation>Jahr der Neuerstellung</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="MIN_MAJOR_NO">
              <xs:annotation>
                <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DATA_VERSION">
              <xs:annotation>
                <xs:documentation>100--11--Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_ID">
              <xs:annotation>
                <xs:documentation>100--14--Datei_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MARK">
              <xs:annotation>
                <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
                <xs:documentation>M = Modifikation</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[M]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_INFO" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>110--3--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="REF_CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_ID">
                    <xs:annotation>
                      <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--13--Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ASSOC_CTM_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRODUCT_BRANDNAME">
                    <xs:annotation>
                      <xs:documentation>100--40--Produktmarke</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_ID">
                    <xs:annotation>
                      <xs:documentation>100--49--Preis_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT">
                    <xs:annotation>
                      <xs:documentation>200--4--MwSt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES" minOccurs="0">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE" maxOccurs="100">
              <xs:annotation>
                <xs:documentation>200--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIES_NAME" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>200--3--Serienname</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>200--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>200--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRODUCT_GROUPS">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEMS">
                                <xs:annotation>
                                  <xs:documentation>400--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="VALID_FROM" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALID_UNTIL" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURES">
              <xs:annotation>
                <xs:documentation>250--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>300--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                                <xs:annotation>
                                  <xs:documentation>311--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>311--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>311--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_FIELD">
                                <xs:annotation>
                                  <xs:documentation>311--5--Preisfeld</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="SUPPLIER_PRICE_GROUP">
                                <xs:annotation>
                                  <xs:documentation>311--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="10" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MAJOR" use="required">
      <xs:annotation>
        <xs:documentation>100--3--Versionsnummer</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="2" />
          <xs:maxInclusive value="2" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MINOR" use="required">
      <xs:annotation>
        <xs:documentation>100--4--Sub_Versions_Nr</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REVISION" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Signature Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : Signature Element
Beschreibung

Dieses Element dient der Angabe einer Veschlüsselung.

Das Wurzelelement einer digitalen Signatur mit XML wird durch das Element Signature dargestellt.

Signature besitzt zwei Kindelemente, wovon die beiden Elemente SignedInfo und SignatureValue Pflicht sind.

Namensraum (none)
Diagramm
SignatureValue Element SignedInfo Element Sequence Signature Element
Overview
Signature optional

Dieses Element dient der Angabe einer Veschlüsselung.

Das Wurzelelement einer digitalen Signatur mit XML wird durch das Element Signature dargestellt.

Signature besitzt zwei Kindelemente, wovon die beiden Elemente SignedInfo und SignatureValue Pflicht sind.

Sequence
SignedInfo

Das erste und auch komplexeste Element innerhalb von Signature ist SignedInfo und enthält die verwendeten Algorithmen zur Kanonisierung und Signierung, eine oder mehrere Referenzen auf die signierten Daten, eventuelle Transformationen und die Hashwerte dieser Daten. SignedInfo enthält also alle Informationen zu den zu signierenden Ressourcen und ist damit der Teil, über den die digitale Signatur erstellt wird.

Mit dem Signieren der verwendeten Algorithmen erhöht sich die Sicherheit. Ein sicherer Algorithmus kann so nicht gegen einen unsicheren ausgetauscht werden, ohne dass die Signatur ungültig wird.

Kindelemente von SignedInfo sind die Pflichtelemente CanonicalizationMethod und SignatureMethod sowie ein oder mehrere Reference Elemente.

Sequence
CanonicalizationMethod Extension of xs:string

Das leere Pflichtelement CanonicalizationMethod enthält ein Algorithm Attribut zur Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird.

Beim Kanonisieren eines XML-Dokuments finden die folgenden Aktionen statt:

  • Das Dokument wird in UTF-8 kodiert
  • Zeilenumbrüche werden vor dem Parsen normalisiert zu #xA
  • Attributwerte werden normalisiert (wie bei einem validierenden Parser)
  • Character- und parsed-entity Referenzen werden ersetzt
  • CDATA Abschnitte werden durch ihren Inhalt ersetzt
  • Die XML-Deklaration und eine möglicherweise vorhandene DTD werden entfernt
  • Leere Elemente werden zu Start-End-Tag Paaren umgewandelt
  • Whitespace außerhalb des Dokumentelements und innerhalb von Start- und End-Tags wird normalisiert
  • Whitespace in Textknoten wird beibehalten (gilt jedoch nicht für Zeichen die bei der Normalisierung der Zeilenumbrüche entfernt wurden)
  • Attributwerte werden in doppelten Anführungsstrichen eingeschlossen
  • Sonderzeichen in Attributwerten und Textknoten werden durch Zeichenreferenzen ersetzt
  • Überflüssige Namespace Deklarationen werden von jedem Element entfernt
  • Defaultattribute werden zu den jeweiligen Elementen hinzugefügt
  • Namespace Deklarationen und Attribute werden alphanumerisch sortiert
Algorithm optional xs:anyURI
Dieses Attribut dient der Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird. Die Angabe erfolgt durch einen URI. D anyURI
P
M
SignatureMethod Extension of xs:string
SignatureMethod ist ebenfalls ein leeres Pflichtelement mit einem Algorithm Attribut und gibt den zur Signaturgenerierung (und später zur Verifizierung) verwendeten Algorithmus an. Mit diesem Algorithmus wird das kanonische SignedInfo Element in den SignatureValue konvertiert.
Algorithm optional xs:anyURI

Mit diesem Attribut wird der Algorithmus zur Signaturgenerierung über einen URI angegeben.

 D anyURI
P
M
Reference

Das Reference Element gibt an, welche beliebigen, auch binären, Daten in die Signaturberechnung miteinbezogen werden sollen. Das Reference Elemente stellt somit den Kern einer Signatur dar.

XML-Signaturen signieren niemals direkt die Ressourcen, sondern legen zunächst eine Liste von Hashwerten dieser an. Diese Liste wird dann mit einem Signatur-Algorithmus signiert. Damit wird nicht nur die Signatur-Operation beschleunigt, sondern auch ein einfacher Weg angeboten, um mehrere Ressourcen gleichzeitig zu signieren.

Zum Reference Element gehört das optionale Attribute URI.

URI optional xs:string

Das Attribut URI ist ebenfalls vom Typ anyURI und enthält die Adresse, unter der die zu signierenden Daten verfügbar sind. Die Daten, auf die sich die digitale Signatur bezieht, müssen nicht im Signature Element selbst vorhanden sein, sondern können auch über das lokale Dateisystem oder eine Internet-Adresse referenziert werden.

Daneben gibt es noch URIs, die auf das aktuelle Dokument verweisen wie z.B. URI="". Dieser spezielle Uniform Resource Identifier steht für alle XML-Knoten des aktuellen XML-Dokuments, jedoch ohne die möglicherweise vorhandenen Kommentare. Die zur Signatur gehörenden Knoten sind in der Auswahl jedoch enthalten.

 D anyURI
P
M
Sequence
Transforms

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Sequence
Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.
Algorithm optional xs:anyURI

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M
DigestValue xs:string
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon). D string
P
M
SignatureValue xs:string

Das Element SignatureValue enthält in binärer Form (immer Base-64 encoding) den über das gesamte SignedInfo Element berechneten Hashwert der Signatur. Dieser Hashwert wird mit dem in der SignatureMethod angegebenen Algorithmus, den kanonisierten Daten und dem privaten Schlüssel berechnet. Damit wird nicht die Nachricht selbst, sondern deren - in der Regel viel kürzerer - Hashwert unterschrieben (Hash-Then-Sign Paradigma).

In den unterschriebenen Daten sind somit sämtliche Informationen über die signierten Referenzen und deren Hashwerte enthalten. Damit ist es nicht erforderlich, dass die Daten selbst im Dokument vorliegen. Die Angaben über die verwendeten Algorithmen fließen jedoch mit in die Signaturberechnung ein. Dadurch werden nachträgliche Manipulationen verhindert.

Da alle Referenzen vor dem Signieren zusammengefasst und gemeinsam signiert werden existiert für die gesamte Signatur immer genau ein SignatureValue Element.

 D string
P
M
Quelle
<xs:element name="Signature" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SignedInfo">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CanonicalizationMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="SignatureMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="Reference">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="Transforms">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="Transform">
                          <xs:complexType>
                            <xs:simpleContent>
                              <xs:extension base="xs:string">
                                <xs:attribute name="Algorithm" type="xs:anyURI" />
                              </xs:extension>
                            </xs:simpleContent>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DigestMethod">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DigestValue" type="xs:string" />
                </xs:sequence>
                <xs:attribute name="URI" type="xs:string" />
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SignatureValue" type="xs:string" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignedInfo Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element : SignedInfo Element
Beschreibung

Das erste und auch komplexeste Element innerhalb von Signature ist SignedInfo und enthält die verwendeten Algorithmen zur Kanonisierung und Signierung, eine oder mehrere Referenzen auf die signierten Daten, eventuelle Transformationen und die Hashwerte dieser Daten. SignedInfo enthält also alle Informationen zu den zu signierenden Ressourcen und ist damit der Teil, über den die digitale Signatur erstellt wird.

Mit dem Signieren der verwendeten Algorithmen erhöht sich die Sicherheit. Ein sicherer Algorithmus kann so nicht gegen einen unsicheren ausgetauscht werden, ohne dass die Signatur ungültig wird.

Kindelemente von SignedInfo sind die Pflichtelemente CanonicalizationMethod und SignatureMethod sowie ein oder mehrere Reference Elemente.

Namensraum (none)
Diagramm
Reference Element SignatureMethod Element CanonicalizationMethod Element Sequence SignedInfo Element
Overview
SignedInfo

Das erste und auch komplexeste Element innerhalb von Signature ist SignedInfo und enthält die verwendeten Algorithmen zur Kanonisierung und Signierung, eine oder mehrere Referenzen auf die signierten Daten, eventuelle Transformationen und die Hashwerte dieser Daten. SignedInfo enthält also alle Informationen zu den zu signierenden Ressourcen und ist damit der Teil, über den die digitale Signatur erstellt wird.

Mit dem Signieren der verwendeten Algorithmen erhöht sich die Sicherheit. Ein sicherer Algorithmus kann so nicht gegen einen unsicheren ausgetauscht werden, ohne dass die Signatur ungültig wird.

Kindelemente von SignedInfo sind die Pflichtelemente CanonicalizationMethod und SignatureMethod sowie ein oder mehrere Reference Elemente.

Sequence
CanonicalizationMethod Extension of xs:string

Das leere Pflichtelement CanonicalizationMethod enthält ein Algorithm Attribut zur Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird.

Beim Kanonisieren eines XML-Dokuments finden die folgenden Aktionen statt:

  • Das Dokument wird in UTF-8 kodiert
  • Zeilenumbrüche werden vor dem Parsen normalisiert zu #xA
  • Attributwerte werden normalisiert (wie bei einem validierenden Parser)
  • Character- und parsed-entity Referenzen werden ersetzt
  • CDATA Abschnitte werden durch ihren Inhalt ersetzt
  • Die XML-Deklaration und eine möglicherweise vorhandene DTD werden entfernt
  • Leere Elemente werden zu Start-End-Tag Paaren umgewandelt
  • Whitespace außerhalb des Dokumentelements und innerhalb von Start- und End-Tags wird normalisiert
  • Whitespace in Textknoten wird beibehalten (gilt jedoch nicht für Zeichen die bei der Normalisierung der Zeilenumbrüche entfernt wurden)
  • Attributwerte werden in doppelten Anführungsstrichen eingeschlossen
  • Sonderzeichen in Attributwerten und Textknoten werden durch Zeichenreferenzen ersetzt
  • Überflüssige Namespace Deklarationen werden von jedem Element entfernt
  • Defaultattribute werden zu den jeweiligen Elementen hinzugefügt
  • Namespace Deklarationen und Attribute werden alphanumerisch sortiert
Algorithm optional xs:anyURI
Dieses Attribut dient der Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird. Die Angabe erfolgt durch einen URI. D anyURI
P
M
SignatureMethod Extension of xs:string
SignatureMethod ist ebenfalls ein leeres Pflichtelement mit einem Algorithm Attribut und gibt den zur Signaturgenerierung (und später zur Verifizierung) verwendeten Algorithmus an. Mit diesem Algorithmus wird das kanonische SignedInfo Element in den SignatureValue konvertiert.
Algorithm optional xs:anyURI

Mit diesem Attribut wird der Algorithmus zur Signaturgenerierung über einen URI angegeben.

 D anyURI
P
M
Reference

Das Reference Element gibt an, welche beliebigen, auch binären, Daten in die Signaturberechnung miteinbezogen werden sollen. Das Reference Elemente stellt somit den Kern einer Signatur dar.

XML-Signaturen signieren niemals direkt die Ressourcen, sondern legen zunächst eine Liste von Hashwerten dieser an. Diese Liste wird dann mit einem Signatur-Algorithmus signiert. Damit wird nicht nur die Signatur-Operation beschleunigt, sondern auch ein einfacher Weg angeboten, um mehrere Ressourcen gleichzeitig zu signieren.

Zum Reference Element gehört das optionale Attribute URI.

URI optional xs:string

Das Attribut URI ist ebenfalls vom Typ anyURI und enthält die Adresse, unter der die zu signierenden Daten verfügbar sind. Die Daten, auf die sich die digitale Signatur bezieht, müssen nicht im Signature Element selbst vorhanden sein, sondern können auch über das lokale Dateisystem oder eine Internet-Adresse referenziert werden.

Daneben gibt es noch URIs, die auf das aktuelle Dokument verweisen wie z.B. URI="". Dieser spezielle Uniform Resource Identifier steht für alle XML-Knoten des aktuellen XML-Dokuments, jedoch ohne die möglicherweise vorhandenen Kommentare. Die zur Signatur gehörenden Knoten sind in der Auswahl jedoch enthalten.

 D anyURI
P
M
Sequence
Transforms

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Sequence
Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.
Algorithm optional xs:anyURI

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M
DigestValue xs:string
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon). D string
P
M
Quelle
<xs:element name="SignedInfo" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CanonicalizationMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="SignatureMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="Reference">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="Transforms">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="Transform">
                    <xs:complexType>
                      <xs:simpleContent>
                        <xs:extension base="xs:string">
                          <xs:attribute name="Algorithm" type="xs:anyURI" />
                        </xs:extension>
                      </xs:simpleContent>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DigestMethod">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
            <xs:element name="DigestValue" type="xs:string" />
          </xs:sequence>
          <xs:attribute name="URI" type="xs:string" />
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CanonicalizationMethod Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element : CanonicalizationMethod Element
Beschreibung

Das leere Pflichtelement CanonicalizationMethod enthält ein Algorithm Attribut zur Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird.

Beim Kanonisieren eines XML-Dokuments finden die folgenden Aktionen statt:

  • Das Dokument wird in UTF-8 kodiert
  • Zeilenumbrüche werden vor dem Parsen normalisiert zu #xA
  • Attributwerte werden normalisiert (wie bei einem validierenden Parser)
  • Character- und parsed-entity Referenzen werden ersetzt
  • CDATA Abschnitte werden durch ihren Inhalt ersetzt
  • Die XML-Deklaration und eine möglicherweise vorhandene DTD werden entfernt
  • Leere Elemente werden zu Start-End-Tag Paaren umgewandelt
  • Whitespace außerhalb des Dokumentelements und innerhalb von Start- und End-Tags wird normalisiert
  • Whitespace in Textknoten wird beibehalten (gilt jedoch nicht für Zeichen die bei der Normalisierung der Zeilenumbrüche entfernt wurden)
  • Attributwerte werden in doppelten Anführungsstrichen eingeschlossen
  • Sonderzeichen in Attributwerten und Textknoten werden durch Zeichenreferenzen ersetzt
  • Überflüssige Namespace Deklarationen werden von jedem Element entfernt
  • Defaultattribute werden zu den jeweiligen Elementen hinzugefügt
  • Namespace Deklarationen und Attribute werden alphanumerisch sortiert
Namensraum (none)
Typ
Extension of xs:string
Diagramm
CanonicalizationMethod Element
Overview
CanonicalizationMethod Extension of xs:string

Das leere Pflichtelement CanonicalizationMethod enthält ein Algorithm Attribut zur Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird.

Beim Kanonisieren eines XML-Dokuments finden die folgenden Aktionen statt:

  • Das Dokument wird in UTF-8 kodiert
  • Zeilenumbrüche werden vor dem Parsen normalisiert zu #xA
  • Attributwerte werden normalisiert (wie bei einem validierenden Parser)
  • Character- und parsed-entity Referenzen werden ersetzt
  • CDATA Abschnitte werden durch ihren Inhalt ersetzt
  • Die XML-Deklaration und eine möglicherweise vorhandene DTD werden entfernt
  • Leere Elemente werden zu Start-End-Tag Paaren umgewandelt
  • Whitespace außerhalb des Dokumentelements und innerhalb von Start- und End-Tags wird normalisiert
  • Whitespace in Textknoten wird beibehalten (gilt jedoch nicht für Zeichen die bei der Normalisierung der Zeilenumbrüche entfernt wurden)
  • Attributwerte werden in doppelten Anführungsstrichen eingeschlossen
  • Sonderzeichen in Attributwerten und Textknoten werden durch Zeichenreferenzen ersetzt
  • Überflüssige Namespace Deklarationen werden von jedem Element entfernt
  • Defaultattribute werden zu den jeweiligen Elementen hinzugefügt
  • Namespace Deklarationen und Attribute werden alphanumerisch sortiert
Algorithm optional xs:anyURI
Dieses Attribut dient der Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird. Die Angabe erfolgt durch einen URI. D anyURI
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
Algorithm xs:anyURI optional
Dieses Attribut dient der Identifikation des Kanonisierungs-Algorithmus, der vor der Signaturberechnung auf die Daten in SignedInfo angewendet wird. Die Angabe erfolgt durch einen URI. D anyURI
P
M
Quelle
<xs:element name="CanonicalizationMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
Siehe auch
SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignatureMethod Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element : SignatureMethod Element
Beschreibung
SignatureMethod ist ebenfalls ein leeres Pflichtelement mit einem Algorithm Attribut und gibt den zur Signaturgenerierung (und später zur Verifizierung) verwendeten Algorithmus an. Mit diesem Algorithmus wird das kanonische SignedInfo Element in den SignatureValue konvertiert.
Namensraum (none)
Typ
Extension of xs:string
Diagramm
SignatureMethod Element
Overview
SignatureMethod Extension of xs:string
SignatureMethod ist ebenfalls ein leeres Pflichtelement mit einem Algorithm Attribut und gibt den zur Signaturgenerierung (und später zur Verifizierung) verwendeten Algorithmus an. Mit diesem Algorithmus wird das kanonische SignedInfo Element in den SignatureValue konvertiert.
Algorithm optional xs:anyURI

Mit diesem Attribut wird der Algorithmus zur Signaturgenerierung über einen URI angegeben.

 D anyURI
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
Algorithm xs:anyURI optional

Mit diesem Attribut wird der Algorithmus zur Signaturgenerierung über einen URI angegeben.

 D anyURI
P
M
Quelle
<xs:element name="SignatureMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
Siehe auch
SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Reference Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element : Reference Element
Beschreibung

Das Reference Element gibt an, welche beliebigen, auch binären, Daten in die Signaturberechnung miteinbezogen werden sollen. Das Reference Elemente stellt somit den Kern einer Signatur dar.

XML-Signaturen signieren niemals direkt die Ressourcen, sondern legen zunächst eine Liste von Hashwerten dieser an. Diese Liste wird dann mit einem Signatur-Algorithmus signiert. Damit wird nicht nur die Signatur-Operation beschleunigt, sondern auch ein einfacher Weg angeboten, um mehrere Ressourcen gleichzeitig zu signieren.

Zum Reference Element gehört das optionale Attribute URI.

Namensraum (none)
Diagramm
DigestValue Element DigestMethod Element Transforms Element Sequence Reference Element
Overview
Reference

Das Reference Element gibt an, welche beliebigen, auch binären, Daten in die Signaturberechnung miteinbezogen werden sollen. Das Reference Elemente stellt somit den Kern einer Signatur dar.

XML-Signaturen signieren niemals direkt die Ressourcen, sondern legen zunächst eine Liste von Hashwerten dieser an. Diese Liste wird dann mit einem Signatur-Algorithmus signiert. Damit wird nicht nur die Signatur-Operation beschleunigt, sondern auch ein einfacher Weg angeboten, um mehrere Ressourcen gleichzeitig zu signieren.

Zum Reference Element gehört das optionale Attribute URI.

URI optional xs:string

Das Attribut URI ist ebenfalls vom Typ anyURI und enthält die Adresse, unter der die zu signierenden Daten verfügbar sind. Die Daten, auf die sich die digitale Signatur bezieht, müssen nicht im Signature Element selbst vorhanden sein, sondern können auch über das lokale Dateisystem oder eine Internet-Adresse referenziert werden.

Daneben gibt es noch URIs, die auf das aktuelle Dokument verweisen wie z.B. URI="". Dieser spezielle Uniform Resource Identifier steht für alle XML-Knoten des aktuellen XML-Dokuments, jedoch ohne die möglicherweise vorhandenen Kommentare. Die zur Signatur gehörenden Knoten sind in der Auswahl jedoch enthalten.

 D anyURI
P
M
Sequence
Transforms

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Sequence
Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
DigestMethod Extension of xs:string
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.
Algorithm optional xs:anyURI

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M
DigestValue xs:string
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon). D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
URI xs:string optional

Das Attribut URI ist ebenfalls vom Typ anyURI und enthält die Adresse, unter der die zu signierenden Daten verfügbar sind. Die Daten, auf die sich die digitale Signatur bezieht, müssen nicht im Signature Element selbst vorhanden sein, sondern können auch über das lokale Dateisystem oder eine Internet-Adresse referenziert werden.

Daneben gibt es noch URIs, die auf das aktuelle Dokument verweisen wie z.B. URI="". Dieser spezielle Uniform Resource Identifier steht für alle XML-Knoten des aktuellen XML-Dokuments, jedoch ohne die möglicherweise vorhandenen Kommentare. Die zur Signatur gehörenden Knoten sind in der Auswahl jedoch enthalten.

 D anyURI
P
M
Quelle
<xs:element name="Reference" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Transforms">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="Transform">
              <xs:complexType>
                <xs:simpleContent>
                  <xs:extension base="xs:string">
                    <xs:attribute name="Algorithm" type="xs:anyURI" />
                  </xs:extension>
                </xs:simpleContent>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DigestMethod">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
      <xs:element name="DigestValue" type="xs:string" />
    </xs:sequence>
    <xs:attribute name="URI" type="xs:string" />
  </xs:complexType>
</xs:element>
Siehe auch
SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Transforms Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : Transforms Element
Beschreibung

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Namensraum (none)
Diagramm
Transform Element Sequence Transforms Element
Overview
Transforms

Das Element Transforms gibt in dem Transform Kindelement die auzuführende Transformationen an. Der Hashwert wird vom Ergebnis der Transformation berechnet.

Ein Transforms Element besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

Sequence
Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
Quelle
<xs:element name="Transforms" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="Transform">
        <xs:complexType>
          <xs:simpleContent>
            <xs:extension base="xs:string">
              <xs:attribute name="Algorithm" type="xs:anyURI" />
            </xs:extension>
          </xs:simpleContent>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
Reference Element | SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

Transform Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element > Reference Element > Transforms Element : Transform Element
Beschreibung

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Namensraum (none)
Typ
Extension of xs:string
Diagramm
Transform Element
Overview
Transform Extension of xs:string

Das Element Transform gibt die auzuführende Transformationen an. Es besteht dazu aus einem Algorithm Attribut mit dem anzuwendenden Transformations-Algorithmus.

 D string
P
M
Algorithm optional xs:anyURI

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
Algorithm xs:anyURI optional

Dieses Attribut dient der Angabe eines Tranformations-Algorithmus mittels eines URI.

 D anyURI
P
M
Quelle
<xs:element name="Transform" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
Siehe auch
Transforms Element | Reference Element | SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DigestMethod Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : DigestMethod Element
Beschreibung
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.
Namensraum (none)
Typ
Extension of xs:string
Diagramm
DigestMethod Element
Overview
DigestMethod Extension of xs:string
Das leere Pflichtelement DigestMethod enthält im Algorithm Attribut ausschließlich einen URI zur Identifikation des Message Digest Algorithmus.
Algorithm optional xs:anyURI

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
Algorithm xs:anyURI optional

In diesem Attribut wird der URI zur Identifikation des Message Digest Algorithmus angegeben.

D anyURI
P
M
Quelle
<xs:element name="DigestMethod" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:simpleContent>
      <xs:extension base="xs:string">
        <xs:attribute name="Algorithm" type="xs:anyURI" />
      </xs:extension>
    </xs:simpleContent>
  </xs:complexType>
</xs:element>
Siehe auch
Reference Element | SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DigestValue Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element > SignedInfo Element > Reference Element : DigestValue Element
Beschreibung
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon). D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
DigestValue Element
Overview
DigestValue xs:string
Mit dem in DigestMethod angegebenen Algorithmus wird der DigestValue, ein eindeutiger Hashwert des signierten Objekts, berechnet und per Base-64 encoding in diesem Element gespeichert. Der Hashwert, der auch als digitaler Fingerabdruck bezeichnet werden kann, ist meist kürzer als die signierten Daten und kann somit im folgenden Schritt schneller signiert werden. Es ist praktisch unmöglich, aus einem gegebenen Hashwert die ursprüngliche Nachricht zu ermitteln. Außerdem sollte es unmöglich sein, dass zwei beliebige Nachrichten denselben Hashwert ergeben (Kollision und Geburtstagsparadoxon). D string
P
M
Quelle
<xs:element name="DigestValue" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
Reference Element | SignedInfo Element | Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SignatureValue Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > Signature Element : SignatureValue Element
Beschreibung

Das Element SignatureValue enthält in binärer Form (immer Base-64 encoding) den über das gesamte SignedInfo Element berechneten Hashwert der Signatur. Dieser Hashwert wird mit dem in der SignatureMethod angegebenen Algorithmus, den kanonisierten Daten und dem privaten Schlüssel berechnet. Damit wird nicht die Nachricht selbst, sondern deren - in der Regel viel kürzerer - Hashwert unterschrieben (Hash-Then-Sign Paradigma).

In den unterschriebenen Daten sind somit sämtliche Informationen über die signierten Referenzen und deren Hashwerte enthalten. Damit ist es nicht erforderlich, dass die Daten selbst im Dokument vorliegen. Die Angaben über die verwendeten Algorithmen fließen jedoch mit in die Signaturberechnung ein. Dadurch werden nachträgliche Manipulationen verhindert.

Da alle Referenzen vor dem Signieren zusammengefasst und gemeinsam signiert werden existiert für die gesamte Signatur immer genau ein SignatureValue Element.

 D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
SignatureValue Element
Overview
SignatureValue xs:string

Das Element SignatureValue enthält in binärer Form (immer Base-64 encoding) den über das gesamte SignedInfo Element berechneten Hashwert der Signatur. Dieser Hashwert wird mit dem in der SignatureMethod angegebenen Algorithmus, den kanonisierten Daten und dem privaten Schlüssel berechnet. Damit wird nicht die Nachricht selbst, sondern deren - in der Regel viel kürzerer - Hashwert unterschrieben (Hash-Then-Sign Paradigma).

In den unterschriebenen Daten sind somit sämtliche Informationen über die signierten Referenzen und deren Hashwerte enthalten. Damit ist es nicht erforderlich, dass die Daten selbst im Dokument vorliegen. Die Angaben über die verwendeten Algorithmen fließen jedoch mit in die Signaturberechnung ein. Dadurch werden nachträgliche Manipulationen verhindert.

Da alle Referenzen vor dem Signieren zusammengefasst und gemeinsam signiert werden existiert für die gesamte Signatur immer genau ein SignatureValue Element.

 D string
P
M
Quelle
<xs:element name="SignatureValue" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
Siehe auch
Signature Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : CATALOG Element
Beschreibung
In diesem Element werden administrative Informationen zum Datenbestand hinterlegt.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence CATALOG_INFO Element CATALOG_MARK Element FILE_ID Element DATA_VERSION Element LANGUAGE Element Sequence CATALOG_NAME Element MIN_MAJOR_NO Element CATALOG_YEAR Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element FILE_RELEASE_DATE Element Sequence CATALOG Element
Overview
CATALOG
In diesem Element werden administrative Informationen zum Datenbestand hinterlegt.
Sequence
FILE_RELEASE_DATE xs:dateTime
Das Element FILE_RELEASE_DATE sollte automatisch beim Export der Daten gesetzt werden und das aktuelle Datum und die UTC-Uhrzeit beinhalten. D dateTime
P
M
CATALOG_IDENTIFICATION
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger

Dieses Feld dient der Identifizierung der Verbandskataloge.
Folgende Werte sind möglich:
2 = Verbandskatalog
3 =kundenspezifischer Katalog

Da das Feld nur mit 2 oder 3 gefüllt sein darf, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden.

D positiveInteger
P
M [2:3]
ASSOC_CTM_NO Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände"). 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
CATALOG_YEAR xs:gYear
Dieses Element bezieht sich auf das Kalenderjahr der Katalogdaten des Hauptkataloges. D gYear
P
M
MIN_MAJOR_NO Restriction of xs:positiveInteger
Wird ein neuer Katalog heraus gegeben oder werden Löschungen in einem Katalog vorgenommen, ändert sich, die Hauptnummer (MAJOR_NO) des Hauptkataloges. Wird die Änderung in einem neuen Jahr vollzogen, wird dass Kalenderjahr (CATALOG_YEAR) angepasst und die Hauptnummer auf 1 gesetzt. Wird in einem Jahr kein neuer Katalog bereitgestellt und keine Löschungen durchgeführt, bleibt das Kalenderjahr und die Hauptnummer bestehen. Das Element MIN_MAJOR_NO enthält den Mindestwert von MAJOR_NO des Hauptkataloges. D positiveInteger
P
M 1:99
CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, dass es sich bei den bereitgestellten Daten um M = Modifzierungsdaten gegenüber dem Hauptkatalog handelt. D string
P [M]
M [1:1]
CATALOG_INFO languagetexte60999 Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FILE_RELEASE_DATE" type="xs:dateTime">
        <xs:annotation>
          <xs:documentation>100--2--Dateifreigabe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_ID">
              <xs:annotation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--13--Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_KIND">
              <xs:annotation>
                <xs:documentation>Katalog-Art</xs:documentation>
                <xs:documentation>2 für Verbandskatalog</xs:documentation>
                <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
                <xs:documentation>geändert 17.04.2019</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="3" />
                  <xs:minInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ASSOC_CTM_NO">
              <xs:annotation>
                <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRODUCT_BRANDNAME">
              <xs:annotation>
                <xs:documentation>100--40--Produktmarke</xs:documentation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_ID">
              <xs:annotation>
                <xs:documentation>100--49--Preis_ID</xs:documentation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT">
              <xs:annotation>
                <xs:documentation>200--4--MwSt</xs:documentation>
                <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_YEAR" type="xs:gYear">
        <xs:annotation>
          <xs:documentation>Jahr der Neuerstellung</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="MIN_MAJOR_NO">
        <xs:annotation>
          <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DATA_VERSION">
        <xs:annotation>
          <xs:documentation>100--11--Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_ID">
        <xs:annotation>
          <xs:documentation>100--14--Datei_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MARK">
        <xs:annotation>
          <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
          <xs:documentation>M = Modifikation</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[M]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_INFO" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>110--3--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_RELEASE_DATE Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : FILE_RELEASE_DATE Element
Beschreibung
Das Element FILE_RELEASE_DATE sollte automatisch beim Export der Daten gesetzt werden und das aktuelle Datum und die UTC-Uhrzeit beinhalten. D dateTime
P
M
Namensraum (none)
Typ
xs:dateTime
Diagramm
FILE_RELEASE_DATE Element
Overview
FILE_RELEASE_DATE xs:dateTime
Das Element FILE_RELEASE_DATE sollte automatisch beim Export der Daten gesetzt werden und das aktuelle Datum und die UTC-Uhrzeit beinhalten. D dateTime
P
M
Quelle
<xs:element name="FILE_RELEASE_DATE" type="xs:dateTime" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--2--Dateifreigabe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_IDENTIFICATION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_IDENTIFICATION Element
Beschreibung
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Namensraum (none)
Diagramm
VAT Element PRICE_ID Element PRODUCT_BRANDNAME Element ASSOC_CTM_NO Element CATALOG_KIND Element COUNTRY_ID Element CURRENCY_KEY Element ISO_LANGUAGE_ID Element MANUFACTURER_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger

Dieses Feld dient der Identifizierung der Verbandskataloge.
Folgende Werte sind möglich:
2 = Verbandskatalog
3 =kundenspezifischer Katalog

Da das Feld nur mit 2 oder 3 gefüllt sein darf, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden.

D positiveInteger
P
M [2:3]
ASSOC_CTM_NO Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände"). 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Quelle
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_ID">
        <xs:annotation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--13--Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_KIND">
        <xs:annotation>
          <xs:documentation>Katalog-Art</xs:documentation>
          <xs:documentation>2 für Verbandskatalog</xs:documentation>
          <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
          <xs:documentation>geändert 17.04.2019</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="3" />
            <xs:minInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ASSOC_CTM_NO">
        <xs:annotation>
          <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRODUCT_BRANDNAME">
        <xs:annotation>
          <xs:documentation>100--40--Produktmarke</xs:documentation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_ID">
        <xs:annotation>
          <xs:documentation>100--49--Preis_ID</xs:documentation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT">
        <xs:annotation>
          <xs:documentation>200--4--MwSt</xs:documentation>
          <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANUFACTURER_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : MANUFACTURER_ID Element
Beschreibung
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MANUFACTURER_ID Element
Overview
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="MANUFACTURER_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ISO_LANGUAGE_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Beschreibung
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:language
Diagramm
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CURRENCY_KEY Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Beschreibung
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Quelle
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COUNTRY_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : COUNTRY_ID Element
Beschreibung
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
COUNTRY_ID Element
Overview
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--13--Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_KIND Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CATALOG_KIND Element
Beschreibung

Dieses Feld dient der Identifizierung der Verbandskataloge.
Folgende Werte sind möglich:
2 = Verbandskatalog
3 =kundenspezifischer Katalog

Da das Feld nur mit 2 oder 3 gefüllt sein darf, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden.

D positiveInteger
P
M [2:3]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CATALOG_KIND Element
Overview
CATALOG_KIND Restriction of xs:positiveInteger

Dieses Feld dient der Identifizierung der Verbandskataloge.
Folgende Werte sind möglich:
2 = Verbandskatalog
3 =kundenspezifischer Katalog

Da das Feld nur mit 2 oder 3 gefüllt sein darf, muss in dem Feld ASSOC_CTM_NO eine Verbands- oder Kundenkennzeichnung eingetragen werden.

D positiveInteger
P
M [2:3]
Quelle
<xs:element name="CATALOG_KIND" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Katalog-Art</xs:documentation>
    <xs:documentation>2 für Verbandskatalog</xs:documentation>
    <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
    <xs:documentation>geändert 17.04.2019</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="3" />
      <xs:minInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ASSOC_CTM_NO Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ASSOC_CTM_NO Element
Beschreibung
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände"). 		D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ASSOC_CTM_NO Element
Overview
ASSOC_CTM_NO Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Einkaufsverbände"). 		D string
P
M [1:15]
Quelle
<xs:element name="ASSOC_CTM_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_BRANDNAME Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRODUCT_BRANDNAME Element
Beschreibung

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRODUCT_BRANDNAME Element
Overview
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
Quelle
<xs:element name="PRODUCT_BRANDNAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--40--Produktmarke</xs:documentation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRICE_ID Element
Beschreibung
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_ID Element
Overview
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
Quelle
<xs:element name="PRICE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--49--Preis_ID</xs:documentation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VAT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : VAT Element
Beschreibung
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
VAT Element
Overview
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Quelle
<xs:element name="VAT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--4--MwSt</xs:documentation>
    <xs:documentation>Identisch mit CATALOG_REF</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NUMBER Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_NUMBER Element
Beschreibung
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Quelle
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_YEAR Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_YEAR Element
Beschreibung
Dieses Element bezieht sich auf das Kalenderjahr der Katalogdaten des Hauptkataloges. D gYear
P
M
Namensraum (none)
Typ
xs:gYear
Diagramm
CATALOG_YEAR Element
Overview
CATALOG_YEAR xs:gYear
Dieses Element bezieht sich auf das Kalenderjahr der Katalogdaten des Hauptkataloges. D gYear
P
M
Quelle
<xs:element name="CATALOG_YEAR" type="xs:gYear" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Jahr der Neuerstellung</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MIN_MAJOR_NO Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : MIN_MAJOR_NO Element
Beschreibung
Wird ein neuer Katalog heraus gegeben oder werden Löschungen in einem Katalog vorgenommen, ändert sich, die Hauptnummer (MAJOR_NO) des Hauptkataloges. Wird die Änderung in einem neuen Jahr vollzogen, wird dass Kalenderjahr (CATALOG_YEAR) angepasst und die Hauptnummer auf 1 gesetzt. Wird in einem Jahr kein neuer Katalog bereitgestellt und keine Löschungen durchgeführt, bleibt das Kalenderjahr und die Hauptnummer bestehen. Das Element MIN_MAJOR_NO enthält den Mindestwert von MAJOR_NO des Hauptkataloges. D positiveInteger
P
M 1:99
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
MIN_MAJOR_NO Element
Overview
MIN_MAJOR_NO Restriction of xs:positiveInteger
Wird ein neuer Katalog heraus gegeben oder werden Löschungen in einem Katalog vorgenommen, ändert sich, die Hauptnummer (MAJOR_NO) des Hauptkataloges. Wird die Änderung in einem neuen Jahr vollzogen, wird dass Kalenderjahr (CATALOG_YEAR) angepasst und die Hauptnummer auf 1 gesetzt. Wird in einem Jahr kein neuer Katalog bereitgestellt und keine Löschungen durchgeführt, bleibt das Kalenderjahr und die Hauptnummer bestehen. Das Element MIN_MAJOR_NO enthält den Mindestwert von MAJOR_NO des Hauptkataloges. D positiveInteger
P
M 1:99
Quelle
<xs:element name="MIN_MAJOR_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NAME Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_NAME Element
Beschreibung
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Namensraum (none)
Typ
languagetexte30 Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="CATALOG_NAME" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte30 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
languagetexte30 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte30 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte30 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

DATA_VERSION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : DATA_VERSION Element
Beschreibung
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
DATA_VERSION Element
Overview
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
Quelle
<xs:element name="DATA_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--11--Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FILE_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : FILE_ID Element
Beschreibung
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
FILE_ID Element
Overview
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
Quelle
<xs:element name="FILE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--14--Datei_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_MARK Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_MARK Element
Beschreibung
Dieses Element dient zur Kennzeichnung, dass es sich bei den bereitgestellten Daten um M = Modifzierungsdaten gegenüber dem Hauptkatalog handelt. D string
P [M]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_MARK Element
Overview
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, dass es sich bei den bereitgestellten Daten um M = Modifzierungsdaten gegenüber dem Hauptkatalog handelt. D string
P [M]
M [1:1]
Quelle
<xs:element name="CATALOG_MARK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
    <xs:documentation>M = Modifikation</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[M]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_INFO Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > CATALOG Element : CATALOG_INFO Element
Beschreibung
In diesem Element werden die Informationstexte abgelegt.
Namensraum (none)
Typ
languagetexte60999 Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_INFO Element
Overview
CATALOG_INFO languagetexte60999 Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="CATALOG_INFO" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>110--3--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

REF_CATALOG Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : REF_CATALOG Element
Beschreibung
In diesem Element wird angegeben, auf welchen Katalog sich die Modifikationsdatei bezieht.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence CATALOG_NAME Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element Sequence REF_CATALOG Element
Overview
REF_CATALOG
In diesem Element wird angegeben, auf welchen Katalog sich die Modifikationsdatei bezieht.
Sequence
CATALOG_IDENTIFICATION
in diesem Element wird der Katalog identifiziert, auf den sich diese Modifikationsdatei bezieht. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
ASSOC_CTM_NO optional Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Kurzbezeichnung Einkaufsverbände"). 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="REF_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_ID">
              <xs:annotation>
                <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--13--Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ASSOC_CTM_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRODUCT_BRANDNAME">
              <xs:annotation>
                <xs:documentation>100--40--Produktmarke</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_ID">
              <xs:annotation>
                <xs:documentation>100--49--Preis_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT">
              <xs:annotation>
                <xs:documentation>200--4--MwSt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_IDENTIFICATION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element : CATALOG_IDENTIFICATION Element
Beschreibung
in diesem Element wird der Katalog identifiziert, auf den sich diese Modifikationsdatei bezieht. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Namensraum (none)
Diagramm
VAT Element PRICE_ID Element PRODUCT_BRANDNAME Element ASSOC_CTM_NO Element COUNTRY_ID Element CURRENCY_KEY Element ISO_LANGUAGE_ID Element MANUFACTURER_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
in diesem Element wird der Katalog identifiziert, auf den sich diese Modifikationsdatei bezieht. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
ASSOC_CTM_NO optional Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Kurzbezeichnung Einkaufsverbände"). 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Quelle
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_ID">
        <xs:annotation>
          <xs:documentation>100--5--Hersteller_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--13--Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ASSOC_CTM_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRODUCT_BRANDNAME">
        <xs:annotation>
          <xs:documentation>100--40--Produktmarke</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_ID">
        <xs:annotation>
          <xs:documentation>100--49--Preis_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT">
        <xs:annotation>
          <xs:documentation>200--4--MwSt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

MANUFACTURER_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : MANUFACTURER_ID Element
Beschreibung
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MANUFACTURER_ID Element
Overview
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="MANUFACTURER_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--5--Hersteller_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ISO_LANGUAGE_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Beschreibung
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:language
Diagramm
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CURRENCY_KEY Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Beschreibung
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Quelle
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

COUNTRY_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : COUNTRY_ID Element
Beschreibung
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
COUNTRY_ID Element
Overview
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--13--Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ASSOC_CTM_NO Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : ASSOC_CTM_NO Element
Beschreibung
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Kurzbezeichnung Einkaufsverbände"). 		D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ASSOC_CTM_NO Element
Overview
ASSOC_CTM_NO optional Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.
Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Kurzbezeichnung Einkaufsverbände"). 		D string
P
M [1:15]
Quelle
<xs:element name="ASSOC_CTM_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_BRANDNAME Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : PRODUCT_BRANDNAME Element
Beschreibung

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRODUCT_BRANDNAME Element
Overview
PRODUCT_BRANDNAME Restriction of xs:positiveInteger

Die Produktmarke trägt zur eindeutigen Definition eines Kataloges bei. Sie sollte in diesem Element entsprechend gepflegt werden.

Dafür wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird.

 D positiveInteger
P
M [1:999]
Quelle
<xs:element name="PRODUCT_BRANDNAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--40--Produktmarke</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_ID Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : PRICE_ID Element
Beschreibung
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_ID Element
Overview
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. Bei Verrechnungspunkten muss der entsprechende Verrechnungsfaktor angegeben werden. 		D positiveInteger
P
M [1:3]
Quelle
<xs:element name="PRICE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--49--Preis_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VAT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element > CATALOG_IDENTIFICATION Element : VAT Element
Beschreibung
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
VAT Element
Overview
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer
Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Quelle
<xs:element name="VAT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--4--MwSt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NUMBER Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element : CATALOG_NUMBER Element
Beschreibung
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Quelle
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

CATALOG_NAME Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > REF_CATALOG Element : CATALOG_NAME Element
Beschreibung
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Namensraum (none)
Typ
languagetexte30 Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="CATALOG_NAME" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
REF_CATALOG Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIES Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : SERIES Element
Beschreibung
In diesem Element werden alle Serien des Kataloges/Datenbestandes hinterlegt, an denen Modifikationen zum Basiskatalog vorgenommen werden einschließlich ihrer zugeordneten Elemente wie beipsielsweise Produktgruppen oder Artikeln .
Namensraum (none)
Diagramm
SERIE Element Sequence SERIES Element
Overview
SERIES optional
In diesem Element werden alle Serien des Kataloges/Datenbestandes hinterlegt, an denen Modifikationen zum Basiskatalog vorgenommen werden einschließlich ihrer zugeordneten Elemente wie beipsielsweise Produktgruppen oder Artikeln .
Sequence
SERIE 1..100
In diesem Element werden die Serien definiert, bei denen Modifikationen zum Basiskatalog vorgenommen werden.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie referenziert. D nonNegativeInteger
P
M [0:99]
Sequence
SERIES_NAME optional
Dieses Element gibt den modifizierten Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D string
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.
Das Element TEXT beinhaltet den Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PRODUCT_GROUPS
In diesem Element werden auf die Produktgruppen referenziert, in denen Modifikationen gegenüber dem Basiskatalog vorgenommen werden. In Produktgruppen sind Artikel mit gleichen Variantenarten gruppiert (z. B. Regale).
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden zu modifizierende Artikel angelegt, die in dem Basiskatalog zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
ITEMS
In diesem Element werden alle zu modifiziernden Artikel einer Produktgruppe referenziert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel und Blöcke angegeben, deren Gültigkeit sich gegenüber dem Hauptkatalog ändert. Ein Artikel wird identifiziert über die Attribute SERIE_NO und TYPE_NO
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="SERIES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE" maxOccurs="100">
        <xs:annotation>
          <xs:documentation>200--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIES_NAME" minOccurs="0">
              <xs:annotation>
                <xs:documentation>200--3--Serienname</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>200--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRODUCT_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEMS">
                          <xs:annotation>
                            <xs:documentation>400--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIE Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element : SERIE Element
Beschreibung
In diesem Element werden die Serien definiert, bei denen Modifikationen zum Basiskatalog vorgenommen werden.
Namensraum (none)
Diagramm
PRODUCT_GROUPS Element SERIES_NAME Element Sequence SERIE Element
Overview
SERIE 1..100
In diesem Element werden die Serien definiert, bei denen Modifikationen zum Basiskatalog vorgenommen werden.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie referenziert. D nonNegativeInteger
P
M [0:99]
Sequence
SERIES_NAME optional
Dieses Element gibt den modifizierten Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D string
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.
Das Element TEXT beinhaltet den Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PRODUCT_GROUPS
In diesem Element werden auf die Produktgruppen referenziert, in denen Modifikationen gegenüber dem Basiskatalog vorgenommen werden. In Produktgruppen sind Artikel mit gleichen Variantenarten gruppiert (z. B. Regale).
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden zu modifizierende Artikel angelegt, die in dem Basiskatalog zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
ITEMS
In diesem Element werden alle zu modifiziernden Artikel einer Produktgruppe referenziert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel und Blöcke angegeben, deren Gültigkeit sich gegenüber dem Hauptkatalog ändert. Ein Artikel wird identifiziert über die Attribute SERIE_NO und TYPE_NO
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der Serie referenziert. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="SERIE" maxOccurs="100" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIES_NAME" minOccurs="0">
        <xs:annotation>
          <xs:documentation>200--3--Serienname</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>200--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRODUCT_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEMS">
                    <xs:annotation>
                      <xs:documentation>400--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SERIES_NAME Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element : SERIES_NAME Element
Beschreibung
Dieses Element gibt den modifizierten Seriennamen an.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence SERIES_NAME Element
Overview
SERIES_NAME optional
Dieses Element gibt den modifizierten Seriennamen an.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D string
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.
Das Element TEXT beinhaltet den Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="SERIES_NAME" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--3--Serienname</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>200--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D string
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.
Das Element TEXT beinhaltet den Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D string
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>200--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element : TEXT_LINE Element
Beschreibung
In diesem Element wird eine Textzeile hinterlegt.
Das Element TEXT beinhaltet den Text.
Namensraum (none)
Diagramm
FULL_TEXT Element TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE
In diesem Element wird eine Textzeile hinterlegt.
Das Element TEXT beinhaltet den Text.
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="TEXT_LINE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FULL_TEXT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : FULL_TEXT Element
Beschreibung
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
FULL_TEXT Element
Overview
FULL_TEXT optional xs:string
In diesem Element wird der beliebig lange Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="FULL_TEXT" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUPS Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element : PRODUCT_GROUPS Element
Beschreibung
In diesem Element werden auf die Produktgruppen referenziert, in denen Modifikationen gegenüber dem Basiskatalog vorgenommen werden. In Produktgruppen sind Artikel mit gleichen Variantenarten gruppiert (z. B. Regale).
Namensraum (none)
Diagramm
PRODUCT_GROUP Element Sequence PRODUCT_GROUPS Element
Overview
PRODUCT_GROUPS
In diesem Element werden auf die Produktgruppen referenziert, in denen Modifikationen gegenüber dem Basiskatalog vorgenommen werden. In Produktgruppen sind Artikel mit gleichen Variantenarten gruppiert (z. B. Regale).
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden zu modifizierende Artikel angelegt, die in dem Basiskatalog zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
ITEMS
In diesem Element werden alle zu modifiziernden Artikel einer Produktgruppe referenziert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel und Blöcke angegeben, deren Gültigkeit sich gegenüber dem Hauptkatalog ändert. Ein Artikel wird identifiziert über die Attribute SERIE_NO und TYPE_NO
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="PRODUCT_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEMS">
              <xs:annotation>
                <xs:documentation>400--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUP Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element : PRODUCT_GROUP Element
Beschreibung
In diesem Element werden zu modifizierende Artikel angelegt, die in dem Basiskatalog zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Namensraum (none)
Diagramm
ITEMS Element Sequence PRODUCT_GROUP Element
Overview
PRODUCT_GROUP 1..∞
In diesem Element werden zu modifizierende Artikel angelegt, die in dem Basiskatalog zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
ITEMS
In diesem Element werden alle zu modifiziernden Artikel einer Produktgruppe referenziert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel und Blöcke angegeben, deren Gültigkeit sich gegenüber dem Hauptkatalog ändert. Ein Artikel wird identifiziert über die Attribute SERIE_NO und TYPE_NO
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="PRODUCT_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEMS">
        <xs:annotation>
          <xs:documentation>400--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEMS Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : ITEMS Element
Beschreibung
In diesem Element werden alle zu modifiziernden Artikel einer Produktgruppe referenziert.
Namensraum (none)
Diagramm
ITEM Element Sequence ITEMS Element
Overview
ITEMS
In diesem Element werden alle zu modifiziernden Artikel einer Produktgruppe referenziert.
Sequence
ITEM 1..∞
In diesem Element werden Artikel und Blöcke angegeben, deren Gültigkeit sich gegenüber dem Hauptkatalog ändert. Ein Artikel wird identifiziert über die Attribute SERIE_NO und TYPE_NO
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="ITEMS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

ITEM Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element : ITEM Element
Beschreibung
In diesem Element werden Artikel und Blöcke angegeben, deren Gültigkeit sich gegenüber dem Hauptkatalog ändert. Ein Artikel wird identifiziert über die Attribute SERIE_NO und TYPE_NO
Namensraum (none)
Diagramm
VALID_UNTIL Element VALID_FROM Element Sequence ITEM Element
Overview
ITEM 1..∞
In diesem Element werden Artikel und Blöcke angegeben, deren Gültigkeit sich gegenüber dem Hauptkatalog ändert. Ein Artikel wird identifiziert über die Attribute SERIE_NO und TYPE_NO
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Quelle
<xs:element name="ITEM" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_FROM Element
Beschreibung
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_UNTIL Element
Beschreibung
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE_DEFINITION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : FEATURE_DEFINITION Element
Beschreibung
In diesem Element werden zu modifizierende variantenabhängige Informationen hinterlegt.
Namensraum (none)
Diagramm
FEATURES Element Sequence FEATURE_DEFINITION Element
Overview
FEATURE_DEFINITION optional
In diesem Element werden zu modifizierende variantenabhängige Informationen hinterlegt.
Sequence
FEATURES
In diesem Element werden die Variantenarten (FEATURE) und die zughörigen zu modifizieren Varianten definiert. Es werden nur die Variantenarten angegeben, die zur Modifizierung des Kataloges erforderlich sind.
Sequence
FEATURE 1..∞
In diesem Element wird eine Variantenart definiert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand zu modifizierenden Varianten abgelegt.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung definiert. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein modifizierter Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante modifiziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
VALID_FROM optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefällt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwänscht, muss das Element leer bleiben.

 D date
P
M
Quelle
<xs:element name="FEATURE_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURES">
        <xs:annotation>
          <xs:documentation>250--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>250--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURES Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element : FEATURES Element
Beschreibung
In diesem Element werden die Variantenarten (FEATURE) und die zughörigen zu modifizieren Varianten definiert. Es werden nur die Variantenarten angegeben, die zur Modifizierung des Kataloges erforderlich sind.
Namensraum (none)
Diagramm
FEATURE Element Sequence FEATURES Element
Overview
FEATURES
In diesem Element werden die Variantenarten (FEATURE) und die zughörigen zu modifizieren Varianten definiert. Es werden nur die Variantenarten angegeben, die zur Modifizierung des Kataloges erforderlich sind.
Sequence
FEATURE 1..∞
In diesem Element wird eine Variantenart definiert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand zu modifizierenden Varianten abgelegt.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung definiert. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein modifizierter Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante modifiziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefällt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwänscht, muss das Element leer bleiben.

 D date
P
M
Quelle
<xs:element name="FEATURES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>250--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FEATURE Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element : FEATURE Element
Beschreibung
In diesem Element wird eine Variantenart definiert.
Namensraum (none)
Diagramm
OPTIONS Element Sequence FEATURE Element
Overview
FEATURE 1..∞
In diesem Element wird eine Variantenart definiert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand zu modifizierenden Varianten abgelegt.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung definiert. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein modifizierter Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante modifiziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefällt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwänscht, muss das Element leer bleiben.

 D date
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird die Variantenart identifiziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="FEATURE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>250--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTIONS Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : OPTIONS Element
Beschreibung
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Namensraum (none)
Diagramm
OPTION Element Sequence OPTIONS Element
Overview
OPTIONS optional
Dies ist ein Container-Element, in dem die möglichen Ausprägungen einer Variantenart hinterlegt werden.
Sequence
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand zu modifizierenden Varianten abgelegt.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung definiert. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein modifizierter Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante modifiziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefällt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwänscht, muss das Element leer bleiben.

 D date
P
M
Quelle
<xs:element name="OPTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element : OPTION Element
Beschreibung
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand zu modifizierenden Varianten abgelegt.
Namensraum (none)
Diagramm
VALID_UNTIL Element VALID_FROM Element LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element LANGUAGE Element Sequence OPTION_TEXT Element Sequence OPTION Element
Overview
OPTION 1..∞
In diesem Element werden die Varianten für Variantenart definiert. In diesem Element werden alle im Datenbestand zu modifizierenden Varianten abgelegt.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung definiert. D string
P
M [1:5]
Sequence
OPTION_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein modifizierter Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante modifiziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
VALID_FROM optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.

 D date
P
M
VALID_UNTIL optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefällt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwänscht, muss das Element leer bleiben.

 D date
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. Es dient dem einfacheren Zugriff auf die Variantenart und muss identisch mit dem Attribut FEATURE_NO aus dem übergeordneten Element FEATURE sein. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung definiert. D string
P
M [1:5]
Quelle
<xs:element name="OPTION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014, Attribut FEATURE_NO gelöscht</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_TEXT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_TEXT Element
Beschreibung
In diesem Element wird ein modifizierter Variantentext definiert.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence OPTION_TEXT Element
Overview
OPTION_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein modifizierter Variantentext definiert.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="OPTION_TEXT" type="languagetexte60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_COMMENT_TEXT Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_COMMENT_TEXT Element
Beschreibung
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante modifiziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element
Overview
OPTION_COMMENT_TEXT optional languagetexte60 Complex Type
In diesem Element wird ein allgemeiner Kommentar als Hinweis für Besonderheiten einer Variante modifiziert. Dieser Kommentar dient dem Bedienungskomfort und darf keine bestellrelevanten Informationen beinhalten. Diese Informationen werden nicht elektronisch ausgewertet.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="OPTION_COMMENT_TEXT" type="languagetexte60" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_FROM Element
Beschreibung

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.

 D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefüllt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben.

 D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_UNTIL Element
Beschreibung

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefällt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwänscht, muss das Element leer bleiben.

 D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date

Über diese Elemente werden die modifierten Zeiträume für Gültigkeiten von Varianten definiert.
Wenn die Gültigkeiten abgelaufen sind wird dies als Warnhinweis dem Anwender des Planungssystems mitgeteilt. Die Variante wird für die Planung weiter verwendet. Für die Füllung der Elemente gelten folgende Bedingungen:

  • Beide Elemente gefüllt: in dem resultierendem Zeitraum lieferbar.
    Beide Elemente leer: uneingeschränkt lieferbar.
  • Nur das Element VALID_FROM gefällt: ab diesem Datum lieferbar.
  • Nur das Element VALID_UNTIL gefüllt: nur bis zu diesem Datum lieferbar.

Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwänscht, muss das Element leer bleiben.

 D date
P
M
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_DEFINITION Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element : PRICE_DEFINITION Element
Beschreibung
In diesem Element werden Informationen für die Katalogmodfizierung hinterlegt, die für die Preisberechnung notwengig sind wie beispielsweise Preistabellen und Ausführungsgruppen.
Namensraum (none)
Diagramm
PRICE_FEATURE_GROUPS Element Sequence PRICE_DEFINITION Element
Overview
PRICE_DEFINITION optional
In diesem Element werden Informationen für die Katalogmodfizierung hinterlegt, die für die Preisberechnung notwengig sind wie beispielsweise Preistabellen und Ausführungsgruppen.
Sequence
PRICE_FEATURE_GROUPS
In diesem Element werden Preisvariantengruppen referenziert, die gegenüber dem Basiskatalog modifiziert werden.
Sequence
PRICE_FEATURE_GROUP 1..∞
In diesem Element werden eine Preisvariantengruppe referenziert, die gegenüber dem Basiskatalog Modifikationsinformationen enthalten soll.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
Sequence
FINISH 0..∞
In diesem Element werden Variantenkombinationen zu modifizierten Preisfeldern (Preisfeld, Blockpreisfeld) und einer Herstellerpreisgruppe zugeordnet.
Sequence
OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2 im Basiskatalog) abgelegt.
Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem veränderten Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2 im Basiskatalog).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die veränderte Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Quelle
<xs:element name="PRICE_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>300--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                          <xs:annotation>
                            <xs:documentation>311--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>311--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>311--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_FIELD">
                          <xs:annotation>
                            <xs:documentation>311--5--Preisfeld</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="SUPPLIER_PRICE_GROUP">
                          <xs:annotation>
                            <xs:documentation>311--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="10" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUPS Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element : PRICE_FEATURE_GROUPS Element
Beschreibung
In diesem Element werden Preisvariantengruppen referenziert, die gegenüber dem Basiskatalog modifiziert werden.
Namensraum (none)
Diagramm
PRICE_FEATURE_GROUP Element Sequence PRICE_FEATURE_GROUPS Element
Overview
PRICE_FEATURE_GROUPS
In diesem Element werden Preisvariantengruppen referenziert, die gegenüber dem Basiskatalog modifiziert werden.
Sequence
PRICE_FEATURE_GROUP 1..∞
In diesem Element werden eine Preisvariantengruppe referenziert, die gegenüber dem Basiskatalog Modifikationsinformationen enthalten soll.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
Sequence
FINISH 0..∞
In diesem Element werden Variantenkombinationen zu modifizierten Preisfeldern (Preisfeld, Blockpreisfeld) und einer Herstellerpreisgruppe zugeordnet.
Sequence
OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2 im Basiskatalog) abgelegt.
Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem veränderten Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2 im Basiskatalog).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die veränderte Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Quelle
<xs:element name="PRICE_FEATURE_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>300--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
                    <xs:annotation>
                      <xs:documentation>311--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>311--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>311--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>311--5--Preisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="SUPPLIER_PRICE_GROUP">
                    <xs:annotation>
                      <xs:documentation>311--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="10" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element : PRICE_FEATURE_GROUP Element
Beschreibung
In diesem Element werden eine Preisvariantengruppe referenziert, die gegenüber dem Basiskatalog Modifikationsinformationen enthalten soll.
Namensraum (none)
Diagramm
FINISH Element Sequence PRICE_FEATURE_GROUP Element
Overview
PRICE_FEATURE_GROUP 1..∞
In diesem Element werden eine Preisvariantengruppe referenziert, die gegenüber dem Basiskatalog Modifikationsinformationen enthalten soll.
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
Sequence
FINISH 0..∞
In diesem Element werden Variantenkombinationen zu modifizierten Preisfeldern (Preisfeld, Blockpreisfeld) und einer Herstellerpreisgruppe zugeordnet.
Sequence
OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2 im Basiskatalog) abgelegt.
Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem veränderten Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2 im Basiskatalog).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die veränderte Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine zu modifizierende PRICE_FEATURE_GROUP identifiziert. D positiveInteger
P
M [1:99999]
Quelle
<xs:element name="PRICE_FEATURE_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>300--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
              <xs:annotation>
                <xs:documentation>311--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>311--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>311--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>311--5--Preisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="SUPPLIER_PRICE_GROUP">
              <xs:annotation>
                <xs:documentation>311--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>300--2--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

FINISH Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element : FINISH Element
Beschreibung
In diesem Element werden Variantenkombinationen zu modifizierten Preisfeldern (Preisfeld, Blockpreisfeld) und einer Herstellerpreisgruppe zugeordnet.
Namensraum (none)
Diagramm
SUPPLIER_PRICE_GROUP Element BLOCK_PRICE_FIELD Element PRICE_FIELD Element OPTION_REF Element Sequence FINISH Element
Overview
FINISH 0..∞
In diesem Element werden Variantenkombinationen zu modifizierten Preisfeldern (Preisfeld, Blockpreisfeld) und einer Herstellerpreisgruppe zugeordnet.
Sequence
OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2 im Basiskatalog) abgelegt.
Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem veränderten Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2 im Basiskatalog).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

 D nonNegativeInteger
P
M [1:250]
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die veränderte Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Quelle
<xs:element name="FINISH" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>311--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>311--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>311--5--Preisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_PRICE_FIELD" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="SUPPLIER_PRICE_GROUP">
        <xs:annotation>
          <xs:documentation>311--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : OPTION_REF Element
Beschreibung
Mit diesem Element wird eine Variante referenziert.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF 0..2
Mit diesem Element wird eine Variante referenziert.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>311--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>311--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

PRICE_FIELD Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : PRICE_FIELD Element
Beschreibung

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2 im Basiskatalog) abgelegt.
Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element gibt an, in welchem veränderten Preisfeld der Preis eines Artikels in dieser Ausführung abgelegt ist. Das entsprechende Preisfeld mit zugehörigem Preis wird in den Elementen ITEM_PREIS (Pfad 1 oder Pfad 2 im Basiskatalog) abgelegt.
Elementpfade
Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/PRICE_FEATURE_GROUP_REF

 D positiveInteger
P
M [1:250]
Quelle
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--5--Preisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

BLOCK_PRICE_FIELD Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : BLOCK_PRICE_FIELD Element
Beschreibung

Dieses Feld gibt an, in welchem veränderten Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2 im Basiskatalog).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

 D nonNegativeInteger
P
M [1:250]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_PRICE_FIELD Element
Overview
BLOCK_PRICE_FIELD optional Restriction of xs:nonNegativeInteger

Dieses Feld gibt an, in welchem veränderten Preisfeld der Blockpreis für dieses Programm abgelegt ist. Das entsprechende Preisfeld wird bei Artikeln, die als Block gekennzeichnet sind, referenziert (Elemente SERIES/SERIE/ PRODUCT_GROUPS/ PRODUCT_GROUP/ ITEMS/ ITEM mit ITEM_IDENTIFICATION=2 im Basiskatalog).

Wenn die Blockpreise nicht für die Katalogpreisgruppen angegeben, sondern für die einzelnen Programme innerhalb der Katalogpreisgruppen unterschiedlich vergeben werden, muss dieses Element wie folgt gefüllt werden:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

* Das Element " BLOCK_PRICE_FIELD " darf nur dann leer bleiben, wenn ein Hersteller keine Blöcke anbietet. Dabei ist nicht maßgeblich, ob es in der normalen Katalogdatei keine Blöcke gibt, sondern ob der Hersteller auf irgendeinem Vertriebsweg Blöcke anbietet. Nur dann, wenn keinerlei Blockaktivitäten innerhalb der Kataloggültigkeit vorkommen werden, darf das Feld "BLOCK_PRICE_FIELD " leer bleiben.

 D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="BLOCK_PRICE_FIELD" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

SUPPLIER_PRICE_GROUP Element
Modifikation IDM 2.7.0 XML-Schema > T_MODIFY_CATALOG Element > PRICE_DEFINITION Element > PRICE_FEATURE_GROUPS Element > PRICE_FEATURE_GROUP Element > FINISH Element : SUPPLIER_PRICE_GROUP Element
Beschreibung
In diesem Element wird die veränderte Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
SUPPLIER_PRICE_GROUP Element
Overview
SUPPLIER_PRICE_GROUP Restriction of xs:string
In diesem Element wird die veränderte Preisgruppe des Herstellers hinterlegt.

Bei ausführungsabhängigen Preisen (PRICE_CALC_METHOD = 3) wird der Wert des Elementes PRICE_FIELD in das Feld SUPPLIER_PRICE_GROUP "kopiert".
Bei programmneutralen Preisen (PRICE_CALC_METHOD = 1) ist der Inhalt beliebig und wird nicht ausgewertet. 		D string
P
M [1:10]
Quelle
<xs:element name="SUPPLIER_PRICE_GROUP" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>311--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
FINISH Element | PRICE_FEATURE_GROUP Element | PRICE_FEATURE_GROUPS Element | PRICE_DEFINITION Element | T_MODIFY_CATALOG Element | Modifikation IDM 2.7.0 XML-Schema


%%ItemTitle%%

Modifikation IDM 2.7.0 XML-Schema Dokumentation
Datentypen
Ansicht mit Navigationswerkzeuge

Für die sprachabhängigen Texte wurden eigene Datentypen definiert.


%%LocalItemTitle%%

languagetexte Complex Type
Modifikation IDM 2.7.0 XML-Schema : languagetexte Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte Complex Type
Overview
languagetexte

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:complexType name="languagetexte" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT" type="xs:string">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:string">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
languagetexte Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte Complex Type > LANGUAGE Element : TEXT Element
Beschreibung

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
TEXT Element
Overview
TEXT xs:string

In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.

Dieses Element enthält den Text in einem CDATA – Knoten

Die Formatierung des Textes ist HTML konform anzugeben:
<b> Fettdruck
<br> Zeilenumbruch

 D string
P
M
Quelle
<xs:element name="TEXT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte30 Complex Type
Modifikation IDM 2.7.0 XML-Schema : languagetexte30 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte30 Complex Type
Overview
languagetexte30

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Verwendet von
CATALOG_NAME Element
CATALOG_NAME Element
Quelle
<xs:complexType name="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 30stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,30}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte40 Complex Type
Modifikation IDM 2.7.0 XML-Schema : languagetexte40 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte40 Complex Type
Overview
languagetexte40

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:complexType name="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 40stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,40}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte40 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,40}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
languagetexte40 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte40 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,40}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte40 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte60 Complex Type
Modifikation IDM 2.7.0 XML-Schema : languagetexte60 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte60 Complex Type
Overview
languagetexte60

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Verwendet von
OPTION_TEXT Element
OPTION_COMMENT_TEXT Element
Quelle
<xs:complexType name="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>265--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,60}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte60 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
languagetexte60 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte60 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte60 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

languagetexte60999 Complex Type
Modifikation IDM 2.7.0 XML-Schema : languagetexte60999 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten bstehend aus bis zu 999 Zeilen der Länge 60.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte60999 Complex Type
Overview
languagetexte60999

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten bstehend aus bis zu 999 Zeilen der Länge 60.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Verwendet von
CATALOG_INFO Element
Quelle
<xs:complexType name="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelligen Zeilen</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT_LINE" maxOccurs="999">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="TEXT">
                  <xs:annotation>
                    <xs:documentation>265--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[\S ]{1,60}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
              </xs:sequence>
              <xs:attribute name="SEQUENCE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>150--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger" />
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Za-z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>150--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>265--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,60}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
languagetexte60999 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element : TEXT_LINE Element
Beschreibung
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
Namensraum (none)
Diagramm
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE_NO Restriction of xs:positiveInteger required
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Quelle
<xs:element name="TEXT_LINE" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte60999 Complex Type | Modifikation IDM 2.7.0 XML-Schema


%%LocalItemTitle%%

TEXT Element
Modifikation IDM 2.7.0 XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | languagetexte60999 Complex Type | Modifikation IDM 2.7.0 XML-Schema