%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Einleitung
Ansicht mit Navigationswerkzeuge

IDM 2.6.0 Block XML-Schema

Dokumentation

Stand 01 .07.2018

Dokumentiertes XML-Schema:

IDM_2_6_0_Block.xsd

Kontakt

DCC e. V.
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org

Telefon 0 52 21/12 65-37


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Grundstruktur des IDM-Schemas
Ansicht mit Navigationswerkzeuge
Einleitung > Grundstruktur des IDM-Schemas

Die Grundstruktur des IDM-Schemas

Das Hauptelement T_NEW_BLOCK definiert, dass ein neuer, vollständiger Block-Katalogdatenbestand bereitgestellt wird.

Das IDM-Schema ist in Datenbereiche aufgeteilt, die durch die nachfolgenden Child-Elemente (siehe Abbildung 1) von T_NEW_BLOCK abgebildet werden.

Abbildung 1 - Child-Elemente von T_NEW_BLOCK

Die Datenbereiche werden nicht isoliert voneinander verwendet. In einigen Datenbereichen werden Daten initial angelegt und aus anderen Datenbereichen heraus über Referenzierung verwendet.

Beschreibung der Datenbereiche

CATALOG

In CATALOG werden administrative Informationen zu dem Datenbestand hinterlegt. Beispielsweise die Version des Datenformates, Freigabedatum oder die eindeutige Identifizierung des Datenbestandes.

SUPPLIER

In SUPPLIER werden administrative Informationen zu dem Hersteller hinterlegt. Beispielsweise werden Kontaktdaten, EDI-Kommunikationsparameter oder das Herkunftsland des Herstellers angegeben.

GLOBAL_DEFINITION

Der Datenbereich GLOBAL_DEFINITION ist eine Art Datenpool für Informationen, die in den anderen Datenbereichen verwendet werden. Beispielsweise werden hier Verrechnungsgruppen oder die Informationen über Medien angelegt.

SERIES

In SERIES werden die Daten für die Beschreibung der Blöcke hinterlegt. Dabei werden alle Artikel(Blöcke) einer Produktgruppe zugeordnet.

FEATURE_DEFINITION

In FEATURE_DEFINITION werden Prüfverfahren (RESTRICTIONS) angelegt.

BLOCK_VALUE_CALCULATION

In BLOCK_VALUE_CALCULATON werden Informationen für die Block- und Werteverrechnung hinterlegt. Beispielsweise werden Daten für Blockregelwerke (SET_OF_BLOCK_RULES), Blockbedingungen (BLOCK_CONDITIONS) oder Wertetabellen (GRADING_TABLE) hinterlegt.


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Elemente der Katalogstruktur
Ansicht mit Navigationswerkzeuge
Einleitung > Elemente der Katalogstruktur

Elemente der Katalogstruktur anlegen

Grundvoraussetzung für eine Block-XML-Datei sind die Katalogdaten mit Informationen zu Serien, Programmen, Variantenarten, Varianten, Preisfeldern und Artikeldaten in einer vorhandenen Datei.

Darauf aufbauend können dann nach den Katalogangaben die Daten zu den Blöcke einschließlich ihrer Bestandteile und Preise erfolgen.

Blockinformationen anlegen

Blockinformationen werden im folgenden Element angelegt:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Das Element ITEM besitzt eine Vielzahl von Elementen mit denen die Eigenschaften eines Blockes beschrieben werden können. Die Identifizierung eines Blockeserfolgt über das Attribut TYPE_NO.

Hierbei ist jedoch zu beachten, dass ein Artikel in Abhängigkeit der Serie unterschiedliche Eigenschaften haben kann. Demzufolge wird ein Artikel mit seinen Eigenschaften nur eindeutig in Verbindung mit der Serie identifiziert.

Innnerhalb des Elementes BLOCK_PARTS werden dann die Einzelartikel des Blockes erfasst.


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Aufbauen der Katalogstruktur
Ansicht mit Navigationswerkzeuge

Aufbauen der Katalogstruktur

Programme Serien zuordnen

Programme werden Serien in folgendem Element zugeordnet:

SERIES/SERIE/RESTRICTION_REF

Das Programm wird der Serie zugeordnet, in dem ein Prüfverfahren referenziert wird, welches das Programm als gültige Kombination definiert.

Das Element zur Beschreibung der Programmeigenschaften ist:

FEATURE_DEFINITION/OPTION_DEFINITION/STYLE

Artikel Serien und Programmen zuordnen

Artikel-Serien Zuordnung

Artikel werden Serien automatisch zugeordnet, da das Element ITEM ein Kind-Element des Elementes SERIES ist:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Artikel-Programm Zuordnung

Programmabhängige Artikel sind grundlegend in allen Programmen verfügbar, die der Serie zugeordnet sind, in welcher der Artikel definiert ist. Soll für einen Artikel Programme ausgeschlossen werden, so sind entsprechende Artikel-spezifische Prüfverfahren von dem Artikel zu referenzieren:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

Ein geeignetes Prüfverfahren, mit dem bei Referenzierung von einem Artikel ein Programm ausgeschlossen wird, ist in dem nachfolgenden Beispiel dargestellt.

Beispiel: Prüfverfahren zur Artikel-Programm-Zuordnung

Element: FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="A1">

<FEATURE_REF FEATURE_NO="1"/>

<OPTION_REF OPTION_NO="A1" FEATURE_NO="1"/>

<TEST_ID>0</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

Das obige Beispiel stellt ein Prüfverfahren dar, in dem die referenzierte Variante eine nicht zulässige Kombination definiert. Die zugehörige Variantendefinition sieht beispielsweise wie folgt aus:

Die referenzierte Programmvariante:

Element: FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_NO="A1" FEATURE_NO="1">

<STYLE_REF STYLE_NO="A1"/>

</OPTION>

</OPTIONS>

</FEATURE>

Die verwendete Programmeigenschaft

Element: FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

<STYLE STYLE_NO="A1">

<STYLE_NAME>Paris</STYLE_NAME>

</STYLE>

</OPTION_DEFINITION>


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Katalogstruktur
Ansicht mit Navigationswerkzeuge
Einleitung > Katalogstruktur

Katalog- und Elementstruktur

Die grundlegende Katalogstruktur der Datenbestände baut sich wie folgt auf:

Abbildung 1 – Katalogstruktur der Datenbestände

Die Katalogstruktur wird im IDM-Schema durch die folgende Elementhierarchie abgebildet:

Abbildung 1 – Elementhierarchie im IDM-Schema

In dem Element SERIE werden die Eigenschaften einer Serie definiert. Über das Element RESTRICTION_REF werden einer Serie Varianten über Prüfverfahren zugeordnet. Innerhalb der Serie werden Produktgruppen (PRODUCT_GROUPS) definiert, in denen Artikel mit gleichartigen Variantenarten zusammengefasst sind. Die Artikel sind einer Serie automatisch zugeordnet, da sie Kind-Elemente des Elementes SERIE sind.


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Referenzierung
Ansicht mit Navigationswerkzeuge
Einleitung > Referenzierung

Referenzierung von Elementen

Im IDM-Schema werden Beziehungen zwischen Elementen aufgebaut und Informationen an zentraler Stelle definiert und an anderer Stelle mehrfach verwendet. Die Wiederverwendung der Informationen und der Aufbau von Elementbeziehungen erfolgt über Referenzierung. Die im IDM-Schema angewendete Art der Referenzierung wird nachfolgend beschrieben.

Begriffsdefinition

im IDM-Schema werden für die Referenzierung von Elementen folgende Begriffe verwendet:

Key-Element | Ein XML-Element, welches von anderen Elementen referenziert wird.
Ref-Element | Ein XML-Element, welches andere Elemente referenziert.

Vorgang der Referenzierung

Das Key-Element besitzt Attribute, über die es eindeutig identifiziert wird. Das Ref-Element besitzt minimal die Key-Attribute des Key-Elementes. Zwischen den Elementen wird die Referenz aufgebaut, in dem die Attributwerte des Ref-Elementes denen des Key-Elementes entsprechen.

Beispiel: Referenzierung der Serie aus dem Artikel

Das nachfolgende Beispiel zeigt, wie aus von einem Artikel (ITEM) eine Serie (SERIE) referenziert wird. Die XML-Elemente sind nur auszugsweise dargestellt.

Key-Element

T_NEW_CATALOG/SERIES/SERIE

<SERIES>

<SERIE SERIE_NO="1"/> … </SERIE>

<SERIE SERIE_NO="2"/> … </SERIE>

<SERIE SERIE_NO="3"/> … </SERIE>

. . .

<SERIE SERIE_NO="99"/> … </SERIE>

</SERIES>

Ref-Element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS>

<ITEM SERIE_NO="1" . . . />

. . .

</ITEMS>

Beispiel: Referenzierung einer Varianten

Im folgenden Beispiel wird eine Variante aus einem Prüfverfahren heraus referenziert.

Key-Element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="400"> <!-- Sockelausführung -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="400"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="401"> <!-- Sockelfarbe -->

<OPTIONS>

<OPTION OPTION_KEY="1" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="2" FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="3" FEATURE_NO="401"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

Die XML-Elemente definieren für die Variantenart 400 (FEATURE) drei Varianten (OPTION) mit den Nummern 1-3 sowie für die Variantenart 401 drei Varianten mit den Nummern 1-3. Eine Variante wird identifiziert über die Kombination FEATURE_NO und OPTION_KEY.

Ref-Element

/T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_REF

<RESTRICTION RESTRICTION_NO="1">

<OPTION_COMBINATION>

<OPTION_REF OPTION_KEY="1" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="400"/>

<OPTION_REF OPTION_KEY="3" FEATURE_NO="401"/>

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

In den XML-Elementen wird ein Prüfverfahren für die zulässigen Kombinationen (TEST_ID=1) der Sockelausführungen (FEATURE_NO=400) und der Sockelfarben (FEATURE_NO=401) definiert. Das Ref-Element OPTION_REF mit den grau hinterlegten Attributen referenziert in diesem Beispiel das grau hinterlegte Key-Element OPTION.


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Prüfverfahren
Ansicht mit Navigationswerkzeuge
Einleitung > Prüfverfahren

Definition und Zuordnung von Prüfverfahren

Prüfverfahren können Serien-übergreifend, Serien-spezifisch, Programm-spezifisch oder Artikel-spezifisch gültig sein. Je tiefer in der Hierarchie Serie->Programm->Artikel ein Prüfverfahren zugeordnet wird, desto höher ist seine Priorität. Ein Prüfverfahren auf Artikelebene übersteuert beispielsweise ein Prüfverfahren, welches auf Programmebene zugeordnet wurde. Ein übersteuerndes Prüfverfahren kann jedoch nur weitere Einschränkungen definieren. Beispielsweise ist es nicht möglich, dass über ein Artikel-spezifisches Prüfverfahren Varianten wieder verfügbar gemacht werden, die bereits von einem Programm-spezifischen Prüfverfahren ausgeschlossen wurden.

Prüfverfahren werden zunächst unabhängig von ihrer späteren Zuordnung angelegt und dann Serien, Programmen oder Artikeln zugeordnet.

Anlage von Prüfverfahren

Prüfverfahren werden in folgendem Element angelegt:

FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

In dem Element RESTRICTION werden Variantenarten referenziert, für deren Kombinationen das Prüfverfahren angelegt werden soll. In dem Element OPTION_REF werden die Varianten referenziert, deren Kombinationen geprüft werden sollen. Es dürfen nur die Varianten referenziert werden, deren Variantenarten in dem Element RESTRICTION referenziert wurden. Das Element TEST_ID definiert, ob die angegebene Variantenkombination zulässig oder unzulässig ist.

Beispiel: Definition von Prüfverfahren

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="523" FEATURE_1_NO="100" FEATURE2_NO="101">

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA" FEATURE_NO="100"/> #lackiert

<OPTION_REF OPTION_NO="RO" FEATURE_NO="101"/> # rot

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA" FEATURE_NO="100"/> # lackiert

<OPTION_REF OPTION_NO="GR" FEATURE_NO="101"/> # grün

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="FU" FEATURE_NO="100"/> # furniert

<OPTION_REF OPTION_NO="BU" FEATURE_NO="101"/> # buche

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

Im obigen Beispiel ist ein Prüfverfahren definiert, welches die Kombinationen von Varianten der Variantenart „Frontausführung “ (Nr. 100) und der Variantenart „Frontfarbe“ (Nr. 101) definiert. Nach dem obigen Prüfverfahren sind die Kombinationen lackiert-rot, lackiert-grün und furniert-buche erlaubt (TEST_ID = 1). Beim Auflisten der Variantenkombinationen (OPTION_REF) muss die Reihenfolge eingehalten werden, wie diese durch die Attribute von RESTRICTION (FEATURE_1_NO, FEATURE_2_NO) gegeben wird.

Für die Identifizierung wird dem Prüfverfahren eine eindeutige Nummer (RESTRICTION_NO) zugewiesen.

Zuordnung von Prüfverfahren

Serien-übergreifende Zuordnung

Prüfverfahren werden Serien-übergreifend mit folgendem Element zugeordnet:

SERIES/RESTRICTIONS/RESTRICTION_REF

Das Element RESTRICTION_REF ist Kind-Element des Elementes SERIES/RESTRICTIONS, hierdurch werden die in RESTRICTION_REF referenzierten Prüfverfahren allen Serien zugeordnet, die in SERIES/SERIE definiert werden.

Beispiel: Serien-übergreifende Zuordnung von Prüfverfahren

<SERIES>

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="523"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="678"/>

</RESTRICTIONS>

</SERIES>

In dem obigen Beispiel werden die Prüfverfahren 523 und 678 referenziert und damit allen Serien zugeordnet.

Serien-spezifische Zuordnung

Die Serien-spezifische Zuordnung von Prüfverfahren erfolgt nach selbem Muster, wie die Serien-übergreifende Zuordnung. Für die Serien-spezifische Zuordnung wird das folgende Element verwendet:

SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF

Die in RESTRICTION_REF referenzierten Prüfverfahren werden der Serie zugeordnet, innerhalb derer die Referenzierung erfolgte.

Prüfverfahren, in denen Programme zugeordnet werden, sind 1-stufige Prüfungen, in denen nur die Variantenart 1 (Programm) enthalten ist. Diese Prüfverfahren sind Pflicht für Serien > 0 und wenn die Variantenart 1 im Datenbestand definiert ist.

Beispiel: Serien-spezifische Zuordnung von Prüfverfahren

<SERIES>

<SERIE SERIE_NO="2">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="67"/>

</RESTRICTIONS>

</SERIE>

<SERIE SERIE_NO="7">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1" RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2" RESTRICTION_NO="123"/>

</RESTRICTIONS>

</SERIE>

</SERIES>

Im obigen Beispiel wurden der Serie „2“ die Prüfverfahren 45 und 67 sowie der Serie „7“ die Prüfverfahren 45 und 123 zugeordnet.

Artikelspezifische Zuordnung

Die Artikel-spezifische Zuordnung von Prüfverfahren erfolgt in folgendem Element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

Die Zuordnung der Prüfverfahren erfolgt wie bei der Serien- oder Programm-spezifischen Zuordnung.

Sind einem Artikel keine Prüfverfahren zugeordnet, dann ist dieser ohne Einschränkungen hinsichtlich der Varianten lieferbar.

Produktgruppen-spezifische Zuordnung

Die Produktgruppen-spezifische Zuordnung von Prüfverfahren erfolgt in folgendem Element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF

Die Zuordnung der Prüfverfahren erfolgt wie bei der Serien-spezifischen Zuordnung.


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Notation der XML-Elemente
Ansicht mit Navigationswerkzeuge


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Datentypen
Ansicht mit Navigationswerkzeuge
Einleitung > Datentypen

Datentypen und Wertebereiche

In dem IDM-Schema werden die mit dem Standard XML-Schema 1.0 Second Edition (28. Oktober 2004) definierten Datentypen verwendet.

Es werden folgende Datentypen genutzt:

boolean | Der Datentyp bildet die Wahrheitswerte "true" oder "false" ab. Entsprechend der W3C-Empfehlung für XML-Schema können die Werte true/false oder 1/0 im IDM verwendet werden.
date | Im IDM wird der Datentyp date XML-Schema konform in folgender Weise angewendet: YYYY-MM-DD Y = Jahr, M = Monat, D = Tag
integer | Ganzzahlige negative und positive Zahlenwerte.
nonNegativeInteger | Ganzzahlige positive Werte, einschließlich der 0
positiveInteger | Ganzzahlige positive Werte, ohne die 0
decimal | Der Datentyp wird im IDM für die Darstellung von Gleitkommawerten verwendet. Gleitpunktwerte werden bei diesem Datentyp entsprechend der W3C-Empfehlung beispielsweise wie folgt dargestellt: 126.56 o. -45.98000 oder +27.0
string | Eine begrenzte Anzahl von alphanumerischen Zeichen und Sonderzeichen.

Die Wertebereiche der obigen Datentypen sind im allgemeinen für die Elemente im IDM eingeschränkt. Über "Restrictions" bei der Datentypdefinition sind Minimal- und Maximalwerte, zulässige Zeichen sowie Wertlisten eingeschränkt.

In der XML-Schema Dokumentation des IDM sind die Wertebereiche durch die Angabe hinter M und P spezifiziert.

Neben den hier genannten XML-Datentypen werden eigene Datentypen für die Texte definiert.

Sie sind am Ende der Dokumentation erklärt.

Siehe auch
languagetexte Complex Type
languagetexte30 Complex Type
languagetexte40 Complex Type
languagetexte60 Complex Type
languagetexte60999 Complex Type


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Erläuterungen zur Dokumentation
Ansicht mit Navigationswerkzeuge
Einleitung > Erläuterungen zur Dokumentation

Erläuterungen zur Dokumentation des IDM

In diesem Abschnitt werden Erläuterungen zur Dokumentation des IDM-Schema hinterlegt.

Bedeutung der Elementeigenschaften

Jedes Element ist durch eine Beschreibung und seine Eigenschaften dokumentiert. Nachfolgend ist ein Beispiel für eine Elementbeschreibung dargestellt:

EXCHANGE_ID_NO Attribute

Description
" -->
Beschreibung
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

Auf der rechten Seite sind die Elementeigenschaften dokumentiert. Diese haben folgende Bedeutung:

D | Hier ist der Datentyp des Elementes dokumentiert. Ist an dieser Stelle kein Eintrag, so handelt es sich um ein Element, welches keine Nutzdaten, sondern weitere Kind-Elemente enthält.
P | Über die Einträge in P und M wird der Wertebereich eines Elementes dokumentiert. In P ist ein regulärer Ausdruck angegeben, der die zulässigen Werte definiert.
M | Im M sind das Minimum und das Maximum der zulässigen Werte angegeben. Bei einem String-Datentyp wird über P die zulässigen Zeichen definiert und über M die minimale und maximale Zeichenlänge. Bei einem Zahlen-Datentyp wird der zulässige minimale und maximale Wert definiert.


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Variantenarten
Ansicht mit Navigationswerkzeuge
Einleitung > Variantenarten
Variantenart | Variantentext | Ausführungsart | Bemerkung
1 | Programm | A | Programm als VariantenartProgramm als VariantenartProgramm als Variantenart
2 | Seriennummer | A | Zuordnung einer fünfstelligen Seriennummer
100 | Frontausführung | A |
101 | Frontfarbe 1 | F | Füllung glatte Front = ganze Fläche
102 | Frontfarbe 2 | F | Rahmen
103 | Frontfarbe 3 | F | Lisenen
104 | Kantenfarbe Front | F |
105 | Front-Kombination | K | Wenn für mehrere Frontinformationen nur ein Schlüssel vorgegeben ist.
106 | Frontgruppe | A | Überschreibt die FRONT_GROUP_NO in FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Frontausführung Absetzung 1 | A |
111 | Frontfarbe 1 Absetzung 1 | F | Füllung glatte Front = ganze Fläche
112 | Frontfarbe 2 Absetzung 1 | F | Rahmen
113 | Frontfarbe 3 Absetzung 1 | F | Lisenen
114 | Kantenfarbe Front Absetzung 1 | F |
115 | Front-Kombination Absetzung 1 | K | Darf die Varianten 111 bis 114 enthalten
120 | Frontausführung Absetzung 2 | A |
121 | Frontfarbe 1 Absetzung 2 | F | Füllung glatte Front = ganze Fläche
122 | Frontfarbe 2 Absetzung 2 | F | Rahmen
123 | Frontfarbe 3 Absetzung 2 | F | Lisenen
124 | Kantenfarbe Front Absetzung 2 | F |
125 | Front-Kombination Absetzung 2 | K | Darf die Varianten 121 bis 124 enthalten
150 | Glasausführung | A |
151 | Glasfarbe | F |
152 | Sprossenausführung | A |
153 | Sprossenfarbe | F |
154 | Ausführung Glastürrahmen | A |
155 | Farbe Glastürrahmen | F |
160 | Ausführung Jalousie | A |
161 | Farbe Jalousie | F |
170 | Ausführung Schütte | A |
171 | Farbe Schütte | F |
200 | Korpusausführung | A |
201 | Korpus-Kombination | K | Wenn für mehrere Korpusfarben - innen/außen - nur ein Schlüssel vorhanden ist.
202 | Korpusfarbe außen | F |
203 | Korpusfarbe innen | F |
204 | Kantenausführung Korpus | A |
205 | Kantenfarbe Korpus | F |
206 | Sichtseiten-Ausführung | A |
207 | Sichtseiten-Farbe | F |
208 | Korpusfarbe innen für Glas | F | Glasschränke und offene Schränke, die kein Regal sind.
209 | Korpusausf. innen für Glas | A | Glasschränke und offene Schränke, die kein Regal sind.
300 | Griffausführung | A |
301 | Griff-Farbe 1 | F | Griff-, Knopfsockel- bzw. Hauptfarbe
302 | Griff-Farbe 2 | F | Bügel-, Steg- und Knopfblendenfarbe
303 | Griff-Kombination | K | Wenn nur ein Schlüssel für mehrere Griffbedingungen vorgegeben ist.
304 | Grifflagen | NULL | Siehe Grifflagen S. 5-23
400 | Sockelausführung | A |
401 | Sockelfarbe | F |
402 | Sockelhöhe | A |
410 | Ausführung Sockelboden | A |
411 | Farbe Sockelboden | F |
500 | Ausführung Regale | A |
501 | Farbe Regale | F |
502 | Ausführung Kranzprofil | A | Beinhaltet Form und Material
503 | Farbe Kranzprofil | F |
504 | Ausführung Lichtleiste | A | Beinhaltet Form und Material
505 | Farbe Lichtleiste | F |
506 | Ausführung Deckenblende | A |
507 | Farbe Deckenblende | F |
508 | Ausf. u. Schr.-abschlussleiste | A | Untere Schrankabschlußleiste
509 | Farbe u. Schr.-abschlussleiste | F | Untere Schrankabschlußleiste
510 | Ausführung Oberboden | A |
511 | Farbe Oberboden | F |
512 | Ausführung Oberboden-Kante | A |
513 | Farbe Oberboden-Kante | F |
514 | Ausführung Bord | A |
515 | Farbe Bord | F |
516 | Ausführung Bordkante | A |
517 | Farbe Bordkante | F |
520 | Ausführung Wangen/Riegel | A |
521 | Farbe Wangen/Riegel | F |
522 | Ausführung Wangenkante | A |
523 | Farbe Wangenkante | F |
524 | Ausführung Unterboden | A |
525 | Farbe Unterboden | F |
526 | Ausführung Unterboden-Kante | A |
527 | Farbe Unterboden-Kante | F |
550 | Nischenausführung | A |
551 | Nischenfarbe | F |
560 | Ausführung Nischenzubehör | A |
561 | Farbe Nischenzubehör | F |
562 | Ausführung Pilaster | A |
563 | Farbe Pilaster | F |
564 | Ausführung Pilasterkante | A |
565 | Farbe Pilasterkante | F |
600 | Arbeitsplatten-Ausführung | A |
601 | Arbeitsplatten-Farbe | F |
602 | Arbeitsplattenkantenausführung | A |
603 | Arbeitsplatten-Kantenfarbe | F |
604 | Barplatten-Ausführung | A |
605 | Barplatten-Farbe | F |
606 | Barplatten-Kantenausführung | A |
607 | Barplatten-Kantenfarbe | F |
620 | Abdeckplatten-Ausführung | A |
621 | Abdeckplatten-Farbe | F |
622 | Abdeckplatten-Kantenausführung | A |
623 | Abdeckplatten-Kantenfarbe | F |
624 | Ansetztisch-Ausführung | A |
625 | Ansetztisch-Farbe | F |
626 | Ansetztisch-Kantenausführung | A |
627 | Ansetztisch-Kantenfarbe | F |
650 | WAP-Ausführung | A | Wandabschlussprofil
651 | WAP-Farbe | F | Wandabschlussprofil
700 | Schubkastenausführung | A | Innenausstattung
701 | Schubkastenfarbe | F | Innenausstattung
702 | Auszugsausführung | A | Innenausstattung
703 | Auszugsfarbe | F | Innenausstattung
750 | Arbeitsplattenform | S |
751 | Kranzleistenform | S |
752 | Lichtleistenform | S |
753 | Sockelform | S |
754 | Wandabschlussform | S |
755 | Abdeckplattenform | S |
756 | Barplattenform | S |
800 | Ausführung Elektrogeräte | A |
801 | Farbe Elektrogeräte | F |
802 | Farbe Elektrogeräte-Zubehör | F |
850 | Ausführung Spülen | A |
851 | Farbe Spülen | F |
852 | Farbe Spülenzubehör | F |
853 | Mischbatterien Farbe | F |
854 | Ausführung Mischbatterien | A |
900 | Ausführung Allgemeines Zubehör | A |
901 | Farbe Allgemeines Zubehör | F |
930 | zus. grafisch relevante Ausführung 1 | A | unbedingt den Softwarehäusern separat mitteilen
931 | zus. grafisch relevante Farbe 1 | F | unbedingt den Softwarehäusern separat mitteilen
932 | zus. grafisch relevante Ausführung 2 | A | unbedingt den Softwarehäusern separat mitteilen
933 | zus. grafisch relevante Farbe 2 | F | unbedingt den Softwarehäusern separat mitteilen
934 | zus. grafisch relevante Ausführung 3 | A | unbedingt den Softwarehäusern separat mitteilen
935 | zus. grafisch relevante Farbe 3 | F | unbedingt den Softwarehäusern separat mitteilen
936 | zus. grafisch relevante Ausführung 4 | A | unbedingt den Softwarehäusern separat mitteilen
937 | zus. grafisch relevante Farbe 4 | F | unbedingt den Softwarehäusern separat mitteilen
938 | zus. grafisch relevante Ausführung 5 | A | unbedingt den Softwarehäusern separat mitteilen
939 | zus. grafisch relevante Farbe 5 | F | unbedingt den Softwarehäusern separat mitteilen
950 | Ausführung Diverses 1 | A |
951 | Farbe Diverses 1 | F |
952 | Ausführung Diverses 2 | A |
953 | Farbe Diverses 2 | F |
954 | Ausführung Diverses 3 | A |
955 | Farbe Diverses 3 | F |
956 | Ausführung Diverses 4 | A |
957 | Farbe Diverses 4 | F |
958 | Ausführung Diverses 5 | A |
959 | Farbe Diverses 5 | F |
960 | Ausführung Diverses 6 | A |
961 | Farbe Diverses 6 | F |
962 | Ausführung Diverses 7 | A |
963 | Farbe Diverses 7 | F |
964 | Ausführung Diverses 8 | A |
965 | Farbe Diverses 8 | F |
966 | Ausführung Diverses 9 | A |
967 | Farbe Diverses 9 | F |
968 | Ausführung Diverses 10 | A |
969 | Farbe Diverses 10 | F |
970 | Ausführung Diverses 11 | A |
971 | Farbe Diverses 11 | F |
972 | Ausführung Diverses 12 | A |
973 | Farbe Diverses 12 | F |
974 | Ausführung Diverses 13 | A |
975 | Farbe Diverses 13 | F |
976 | Ausführung Diverses 14 | A |
977 | Farbe Diverses 14 | F |
978 | Ausführung Diverses 15 | A |
979 | Farbe Diverses 15 | F |
980 | Ausführung Diverses 16 | A |
981 | Farbe Diverses 16 | F |
982 | Ausführung Diverses 17 | A |
983 | Farbe Diverses 17 | F |
984 | Ausführung Diverses 18 | A |
985 | Farbe Diverses 18 | F |
986 | Ausführung Diverses 19 | A |
987 | Farbe Diverses 19 | F |
988 | Ausführung Diverses 20 | A |
989 | Farbe Diverses 20 | F |
999 | Fixe Materialzuordnung | F |

Typ: A = Ausführung

F = Farbe

K = Kombination

S = Form


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Typenschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Typenschlüssel

Typ-Nr. | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Unterschrank | Floor cupboard
2 | Hochschrank | Tal cupboard
3 | Hänge-/Oberschrank | Hanging/wall cupboard
4 | APL-Aufsatz | Work-top mounted cupboard
5 | Nischengestaltung | Recess kit
6 | Highboard | Highboard
7 | Nischenschrank |
8 | Solitärmöbel |
9 | Frontelement | Front element
10 | Modul-Element |
11 | Kranzprofil | Cornice profile
12 | Lichtblende | Pelmet
13 | Deckenblende | Top facing
14 | Sockelblende | Plinth filler
15 | Sockelleiste | Plinth board
17 | Arbeitsplatte | Work-top
18 | WAP | Wall end moulding
19 | Abdeckplatte | Covering plate
20 | Baldachin | Canopy
21 | Überbauboden | Over shelf
22 | Konstruktionsboden | Construction shelf
24 | Kaminesse | Chimney
26 | Elektrogerät | Appliance
27 | Gasgerät | Gas appliance
28 | Kleingerät | Small appliance
29 | Spüle | Sink
30 | Armatur | Tab unit
35 | Beleuchtung | Lighting
37 | Allgem. Zubehör | General accessory
38 | Sonstiges | Other
41 | Block | Block
42 | Mehrausstattung | Additional equipment
43 | Werteverrechnung |
95 | Vorgez. Recyclinggeb. |
98 | Information als Unterp. |
99 | Allgem. Text/Auftrag |


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Ausstattungsschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Ausstattungsschlüssel

AusstattungID | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Allesschneider | Universal cutter
2 | Brot | Bread
3 | Drehboden | Rotating shelf
4 | Flaschen | Bottles
5 | Glas | Glass
6 | Handtuch | Hand towel
7 | Innenschub/-zug |
8 | Putzmittel/Besen |
9 | Reste/Abfallsystem |
10 | Schwenkmechanik |
11 | Ausziehtisch |
12 | Vorrat | Larder
13 | Wäsche | Linen
14 | Gewürz | Spice
16 | Trockner | Dryer
17 | Herd | Cooker
18 | Backofen | Oven
19 | Kochmulde | Hob
20 | Ceranfeld | Ceramic hob
21 | Dunsthaube | Cooker hood
22 | Abzug | Extractor
23 | Lüfterbaustein |
24 | Microwelle | Microwave
25 | Spülmaschine | Dishwasher
26 | Gefrierschrank | Freezer
27 | Kühlschrank | Fridge
28 | Waschmaschine | Washing machine
29 | Funktions-/Schaltkasten |
30 | Doppelbackofen | Double oven
31 | Spüle | Sink
32 | Dampfgarer |
33 | Warmhaltezone |
34 | Grill |
35 | Friteuse |
36 | Schneidbrett beheizt |
37 | Kaffeemaschine |
41 | Kühl-/Gefrierkombination |
42 | Back-Mikro-Kombination |
43 | Backen/Wärmen |
46 | Niederdruck | Low pressure
47 | Hochdruck | High pressure
48 | TV-Gerät |
49 | Wasserspender |
50 | Geschirrwärmer |
51 | Muldenlüfter (Dunstabzug/Lüfterbaustein) |
52 | Eiswürfelspender |
53 | Bierkühler |
54 | Schublade |


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Einbau Info- Schlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Einbau Info- Schlüssel
EinbauInfo-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Integrierbar |
2 | Einbau |
3 | Unterbau |
4 | Standgerät |
5 | Voll Integrierbar |
7 | Nische integriert |
8 | Nische offen |
11 | Frontbündig |
12 | Korpusbündig |
13 | Flächenbündig |
14 | Auflage | Lay-on
15 | Module |
17 | freistehend |
18 | freihängend |
19 | wandhängend |
21 | Sichtseite |
22 | Seitlicher Sockel |
23 | Formstück |
24 | Retoure |
25 | Übergang |
26 | Gehrungszuschlag |
28 | Breitenkürzung |
29 | Tiefenkürzung |
30 | Höhenkürzung |
32 | Ausschnitt | Cut-out
33 | Abschrägung |
34 | Abrundung |
35 | Verbindung |
36 | Ausklinkung | Release
37 | Bearbeitung |
46 | Zeile 60 cm |
47 | Ecke | Edge
48 | Zeile 60 cm + Ecke |
49 | Spezialschrank |


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Materialschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Materialschlüssel
Material-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Kunststoff | Plastic
2 | Corian | Corean
3 | Echtholz | Wood
4 | Naturstein | Natural stone
5 | Metall | Metal
6 | Fliesen | Tiles
7 | Glas | Glass
8 | Verbundwerkstoff | Composite material
9 | Edelstahl | Stainless Steel
10 | Aluminium | Aluminium
11 | Stahl emailliert | Enameled steel
12 | Keramik | Ceramic


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Formschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Formschlüssel
Form-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Rechteckig | Square
2 | Diagonal | Diagonal
3 | Innenrund | Insidecurve
4 | Rund | Round
5 | Halbrund/Rundung | Half-round/rounding
6 | Schräg | Angled
7 | Z-Form / 3-D | Z-Form / 3-D
8 | Wellenform | Wavy
9 | 45-Grad | 45-degree
10 | 90-Grad | 90-degree
11 | 135-Grad | 135-degree
12 | N-Grad | N-degree


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Frontausprägungsschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Frontausprägungsschlüssel
Frontausprägung-Nr. | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Tür | Door
2 | Schubkasten | Drawer
3 | Auszug | Pull-out
4 | Glastür | Glass door
5 | Klappe | Lid/flap
6 | Schaltkastenblende | Switch cabinet bezel
7 | Jalousie | Blind
8 | Schiebetür |
9 | Faltklappentür |
10 | Rollfront |
11 | Tür/Schubkasten | Door/drawer
12 | Auszug/Schubkasten | Pull-out/drawer
13 | Schubkasten/Jalousie | Drawer/blind
14 | Auszug/Tür | Pull-out/door
15 | Auszug/Schubk./Tür | Pull-out/drawer/door
16 | Tür/Klappe | Door/flap
17 | Auszug/Schubk./Klappe | Pull-out/drawer/flap
18 | Schubkasten/Rollfront |
20 | ohne Front |
21 | 1 Becken o. Abtropfb. | 1 bowl without strainer bowl
22 | 1,5 Becken o. Abtropfb. | 1,5 bowls without strainer bowl
23 | 2 Becken o. Abtropfb. | 2 bowls without strainer bowl
24 | 1 Becken m. Abtropfb. | 1 bowl with strainer bowl
25 | 1,5 Becken m. Abtropfb. | 1,5 bowls with strainer bowl
26 | 2 Becken m. Abtropfb. | 2 bowls with strainer bowl
27 | Abtropfbereich | Strainer bowl
28 | 1 Becken m. Abfalls. | 1 bowl with rubbish container
29 | 1,5 Becken m. Abfalls. | 1,5 bowls with rubbish container
30 | 2 Becken m. Abfalls. | 2 bowls with rubbish container
31 | 1 Becken m. Abt.+Abf. | 1 bowl with strainer bowl and rubbish
32 | 1,5 Becken m. Abt.+Abf. | 1,5 bowls with strainer bowl and rubbish
33 | Abfall | Rubbish
36 | m. Rohrauslauf |
37 | m. Rohrauslauf vers./ab. |
38 | m. Schlauchbrause |
39 | m. Schlauchbr. vers./ab. |
41 | 1 Kochfläche | 1 ring
42 | 2 Kochflächen | 2 rings
43 | 3 Kochflächen | 3 rings
44 | 4 Kochflächen | 4 rings
45 | 5 Kochflächen | 5 rings
46 | 6 Kochflächen | 6 rings
47 | 7 Kochflächen | 7 rings
48 | 8 Kochflächen | 8 rings
49 | 9 Kochflächen | 9 rings


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Typenschlüssel- Arten
Ansicht mit Navigationswerkzeuge
Einleitung > Typenschlüssel- Arten
Art-Nr | Bezeichnung (deutsch) | Bezeichnung (englisch)
1 | Normal | Normal
2 | Regal | Shelf
3 | Rahmen | Frame
4 | Seitenverkleidung | Side cladding
5 | Rückwandverkleidung | Rear cladding
6 | Frontblende | Front facing
7 | Dekorblende | Decorative facing
8 | Formwange | Shaped cheek
9 | Raumteiler | Room divider
10 | Unterbau | substructure
11 | Aufsatz | Cap
14 | Paßstück | Filler
15 | Blende | Baffle
16 | Umbau |
17 | Modul-Umbauschrank |
19 | Einlegeboden | Shelf
21 | Barplatte | Bar top
22 | Ansetztisch | Fixed table
26 | Pilaster | Pilaster
27 | Stollen |
28 | Paneel | Panel
29 | Bord/Konsole | Board/table
30 | Reling | Rail
32 | Einhebelmischer |
33 | Zweigriffarmatur |
34 | Sonstige Armaturen |
36 | Umluft |
37 | Abluft |
40 | Zubehör | Accessory


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Sprachenschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Sprachenschlüssel

Sprachenschlüssel | Sprachenname
AA | Afar
AB | Abchasisch
AE | Avestan
AF | Afrikaans
AM | Amharisch
AR | Arabisch
AS | Assamesisch
AY | Aymara
AZ | Aserbaidschanisch
BA | Baschkirisch
BE | Byelorussisch
BG | Bulgarisch
BH | Biharisch
BI | Bislamisch
BN | Bengalisch
BO | Tibetanisch
BR | Bretonisch
BS | Bosnisch
CA | Katalanisch
CE | Tscherkessisch
CH | Chamorro
CO | Korsisch
CS | Tschechisch
CU | Alt-Slavisch
CV | Chuvash
CY | Walisisch
DA | Dänisch
DE | Deutsch
DZ | Dzongkha
EE | Estnisch
EL | Griechisch
EN | Englisch
EO | Esperanto
ES | Spanisch
ET | Estnisch
EU | Baskisch
FA | Persisch
FI | Finnisch
FJ | Fiji
FO | Faröisch
FR | Französisch
FY | Friesisch
GA | Irisch
GD | Gälisch
GL | Galizisch
GN | Guarani
GU | Gujaratisch
HA | Haussa
HE | Hebräisch
HI | Hindi
HO | Hiri Motu
HR | Kroatisch
HU | Ungarisch
HY | Armenisch
HZ | Herero
IA | Interlingua
ID | Indonesisch
IE | Interlingue
IK | Inupiak
IO | Ido
IS | Isländisch
IT | Italienisch
IU | Inuktitut -Eskimo-
JA | Japanisch
JV | Javanisch
KA | Georgisch
KI | Kikuyu
KJ | Kuanyama
KK | Kasachisch
KL | Kalaallisut (Grönländ.)
KM | Kambodschanisch
KN | Kannada
KO | Koreanisch
KS | Kaschmirisch
KU | Kurdisch
KV | Komi
KY | Kirgisisch
LA | Lateinisch
LB | Luxemburgisch
LI | Limburgisch
LN | Lingala
LO | Laotisch
LT | Litauisch
LV | Lettisch
MG | Malagasisch
MH | Marshallese
MI | Maorisch
MK | Mazedonisch
ML | Malayisch
MN | Mongolisch
MO | Moldavisch
MR | Marathi
MS | Malaysisch
MT | Maltesisch
MY | Burmesisch
NA | Nauruisch
NB | Norwegisch Bokmål
ND | Nord-Ndebele
NE | Nepalisch
NG | Ndonga
NL | Holländisch
NN | Norwegisch Nynorsk
NO | Norwegisch
NR | Süd-Ndebele
NV | Navajo
NY | Chichewa
OC | Okzitanisch
OM | Oromo
OR | Orija
OS | Ossetian
PA | Pundjabisch
PI | Pali
PL | Polnisch
PS | Paschtu
PT | Portugisisch
QU | Quechua
RM | Rätoromanisch
RN | Kirundisch
RO | Rumänisch
RU | Russisch
RW | Kijarwanda
SA | Sanskrit
SC | Sardinisch
SD | Zinti
SE | Nord-Sami
SG | Sango
SI | Singhalesisch
SK | Slowakisch
SL | Slowenisch
SM | Samoanisch
SN | Schonisch
SO | Somalisch
SQ | Albanisch
SR | Serbisch
SS | Swasiländisch
ST | Sesothisch
SU | Sudanesisch
SV | Schwedisch
SW | Suaheli
TA | Tamilisch
TE | Tegulu
TG | Tadschikisch
TH | Thai
TI | Tigrinja
TK | Turkmenisch
TL | Tagalog
TN | Sezuan
TO | Tongaisch
TR | Türkisch
TS | Tsongaisch
TT | Tatarisch
TW | Twi
TY | Thai
UG | Uighur
UK | Ukrainisch
UR | Urdu
UZ | Usbekisch
VI | Vietnamesisch
VO | Volapük
WA | Walonisch
WO | Wolof
XH | Xhosa
YI | Jiddisch
YO | Joruba
ZA | Zhuang
ZH | Chinesisch
ZU | Zulu


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Länderschlüssel
Ansicht mit Navigationswerkzeuge
Einleitung > Länderschlüssel

Länderkennzeichen | Ländername(deutsch) | Ländername(englisch)
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AL | Albanien | Albania
AM | Armenien | Armenia
AT | Österreich | Austria
AU | Australien | Australia
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BE | Belgien | Belgium
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BO | Bolivien | Bolivia
BR | Brasilien | Brazil
BY | Belarus | Belarus
CA | Kanada | Canada
CH | Schweiz | Switzerland
CL | Chile | Chile
CN | China | China
CO | Kolumbien | Columbia
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DK | Dänemark | Denmark
DZ | Algerien | Algeria
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EN | England | England
ES | Spanien | Spain
FI | Finnland | Finland
FR | Frankreich | France
GB | England/Großbritannien | England/Great Britain
GE | Georgien | Georgia
GI | Gibraltar | Gibraltar
GR | Griechenland | Greece
GT | Guatemala | Guatemala
HK | Hong Kong | Hong Kong
HN | Honduras | Honduras
HR | Kroatien | Croatia
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IN | Indien | India
IS | Island | Iceland
IT | Italien | Italy
JP | Japan | Japan
KG | Kurdistan | Kurdistan
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KZ | Kasachstan | Kazakstan
LI | Liechtenstein | Liechtenstein
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LX | Luxemburg | Luxembourg
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
MK | Makedonien | Macedonia
MT | Malta | Malta
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NZ | Neuseeland | New Zealand
PA | Panama | Panama
PE | Peru | Peru
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PR | Puerto Rico | Puerto Rica
PT | Portugal | Portugal
PY | Paraguay | Paraguay
QA | Quatar | Qatar
RO | Rumänien | Romania
RU | Russland | Russia
SA | Saudi Arabien | Saudi Arabia
SE | Schweden | Sweden
SG | Singapur | Singapore
SI | Slowenien | Slovenia
SK | Slowakei (slowakische Republik) | Slovak Republic
SM | San Marino | San Marino
SV | El Salvador | El Salvador
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TR | Türkei | Turkey
UA | Ukraine | Ukraine
US | U.S.A. | U.S.A.
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VE | Venezuela | Venezuela
YU | Jugoslawien | Yugoslavia
ZA | Südafrika | South Africa


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Einkaufsverbände
Ansicht mit Navigationswerkzeuge
Einleitung > Einkaufsverbände

Verbandskunde | Verbandsname | Strasse | PLZ | Ort | Telefon | Fax
AMBRA | AMBRA Vertriebsgesellschaft mbH & Co. KG | Pfälzer Straße 10 | 33332 | Gütersloh | +49(5241)9246-0 | +49(5241)9246-49
AMM | Alliance Möbel-Marketing GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
ANT | ANTARES Einkaufs- und Marketinggesellschaft GmbH & Co. KG | Ramlinger Str. 50 | 31303 | Burgdorf-Ehlershausen | +49(5085)955887 | +49(5085)-955885
ASSIMA | ASSIMA Verbund GmbH & Co. KG | Bussardweg 18 | 41468 | Neuss | +49(2131)310400 | +49(2131)310469
ATLAS | Atlas-Einrichtungs-Einkauf GmbH | Brunshofstr. 2 | 45470 | Mülheim a. d. Ruhr | +49(208)992400 | +49(208)9924099
AWD | AWD Einkaufs- und Marketinggesellschaft für Wohnkomfort mbH | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
BAUR | Baur Friedrich GmbH Zentraleinkauf | Bahnhofstr. 10 | 96224 | Burgkunstadt | +49(9572)912739 o. 912746 | +49(9572)912006
BEGROS | Begros GmbH | Graf-Zeppelin-Str. 5 | 46149 | Oberhausen | +49(208)99493-0 | +49(208)99493-911
BETTENKREIS | BETTENKREIS GmbH & Co. | Pascalstr. 4 | 47506 | Neukirchen-Vluyn | +49(2845)9134-0 | +49(2845)9134-34
BETTENRING | BETTENRING eG | Echterdinger Str. 115 | 70794 | Filderstadt | +49(711)70958-0 | +49(711)70958-66
BRANION | BRANION GmbH | Soennecken-Platz | 51491 | Overath | +49(2206)607-0 | +49(2206)607-199
BÜRORING | BÜRORING eG | Siemensstr. 7 | 42781 | Haan | +49(2129)5571-0 | +49(2129)5571-93
CI | Createive Inneneinrichter | Spreestr. 3 | 64295 | Darmstadt | +49(6151)39128-0 | +49(6151)39128-28
CON | Concorde Möbel-Einkaufs-GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | 0211-47236-0 | 0211-4180034
CP | CREATIVE PARTNEr Service- und Einkaufs-Kooperation GmbH | Otto-Hahn-Str. 6 d | 21509 | Glinde | +49(40)728161-0 | +49(40)728161-21
DKR | Der Küchenring GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
DMV | DEUTSCHER MÖBEL-VERBUND Handels GmbH | Ampertal 8 | 85777 | Fahrenzhausen-Unterbruck | +49(8133)89-0 | +49(8133)-89-199
DSM | Drosser & Schaffer Marketing GmbH | Würmstr. 13 A | 82166 | Gräfelfing | +49(89)89878434/-26 /-28 | +49(89)89878440
DU | DECOR UNION GmbH & Co. KG | Brüsseler Str. 3 | 30539 | Hannover | +49(511)8789-0 | +49(511)8789-299
EBUCH | ebuch eG | O'Brien-Str. 3 | 91126 | Schwabach | +49(9122)9386-0 | +49(9122)9386-68
EDE | Einkaufsbüro Deutscher Eisenhändler GmbH | Dieselstr. 33 | 42389 | Wuppertal | +49(202)6096-0 | +49(202)6096-331
EGEPACK | EGEPACK Einkaufs- und Vertriebsgesellschaft mbH | Bödekerstr. 7 | 30161 | Hannover | +49(511)38841-03 / -04 | +49(511)3884064
EIS | E.I. S. GmbH | Von-Hünefeld-Str. 41 | 50829 | Köln | +49(211)59797-44 / -45 | +49(211)59797-21
EK | Grosseinkauf eG | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-144
EKAFLOR | ekaflor GmbH & Co. KG | Watzmannstr. 3 | 90471 | Nürnberg | +49(911)981166-0 | +49(911)981166-5
ELTKONTOR | ELTKONTOR GmbH & Co. KG | Oldenburger Allee 21 | 30659 | Hannover | +49(511)61599-0 | +49(511)61599-77
EM | Europa Möbel | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EMV | Europa Möbel-Verbund (EMV) | Ampertal 8 | 85777 | Fahrenzhausen-Unterbrück | +49(8133)89-0 | +49(8133)89-199
ESG | ESG Einkaufs- und Service Gesellschaft mbH | Berliner Str. 26 | 33378 | Rheda-Wiedenbrück | +49(5242)9453-0 | +49(5242)9453-53
EUROKON | EUROPA-KONTOR GmbH & Co. KG | Amsterdamer Str 230 | 50735 | Köln | +49(221)971491-21 | +49(221)971491-60
EUROPA | GROSSEINKAUF EUROPA MÖBEL GmbH & Co. KG | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EVB | EVB BauPunkt Einkaufs- und Handelsgemeinschaft GmbH & Co. KG | Zillenhardtstr. 46 | 73037 | Göppingen | +49(7161)99931-70/ -71 | +49(7161)99931-72
EWEPA | E W E P A GmbH | Oberevinger Str. 5 | 44339 | Dortmund | +49(231)985127-0 | +49(231)-985127-17 / -18
FHG | FHG Fach-Handels-gesellschaft mbH & Co. KG | Brühler Str. 55/58 | 42657 | Solingen | +49(212)24809-0 | +49(212)24809-119
FHR | F H R Fachhandelsring GmbH | Am Pfaffensee 4 | 67376 | Harthausen | +49(6344)9533-0 | +49(6344)9533-90
FS | "FÜR SIE" Handelsgenossenschaft eg Food-Non Food | An der Münze 12-18 | 50668 | Köln | +49(221)16041-0 | +49(221)16041-821
GARANT | GARANT-MÖBEL-MARKETING LAUTEN GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
GEDK | Ge-dk Unternehmensbetreuungsgesellschaft mbH | Beinhaltet Form und Material | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
GFM | G f M Möbeleinkaufsverbund GmbH & Co. Betriebs KG | Donaustr. 15 | 93333 | Neustadt a. d. D. | +49(9445)204-0 | +49(9445)204-155
HBO | H.B.O. Einkauf + Marketing GmbH & Co. | Dietrichsweg 64 | 26127 | Oldenburg | +49(441)96182-0 | +49(441)96182-55
HIS | Home in style Raumgsestaltung GmbH & Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-370 | +49(7231)915-259
HLH | HolzLand Holzhandels GmbH | Friedrich-Engels-Allee 432 | 42283 | Wuppertal | +49(202)55138-0 | +49(202)55138-10
HOLZRING | DER HOLZRING Handelsgesellschaft mbH | Universitätsallee 5 | 28359 | Bremen | +49(421)22315-0 | +49(421)22315-11
INKU | INKU GmbH + Co. | Nikolaus-Otto-Str. 6 | 70771 | Leinfelden-Echterdingen | +49(711)9492-438 | +49(711)9192-436
K581018 | NULL |  |  |  |  |
KA | K + A Küchen Aktuell GmbH | Senefelder Str. 2 a | 38124 | Braunscheig | +49(531)26134-0 | +49(531)26134-39
KAK | Küchen-Aktiv-Kreis | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KAREAL | Küchen Areal GmbH & Co. KG | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-163 | +49(5242)409-202
KARST | Karstadt Warenhaus AG | Theresienhöhe 5 | 80339 | München | +49(89)5105-0 | +49(89)5105-300
KATAG | KATAG International Partners GmbH | Stralsunder Str. 5 | 33605 | Bielefeld | +49(521)292-0 | +49(521)292-101/299
KAUFRING | KAUFRING AG | Kieshecker Weg 100 | 40468 | Düsseldorf | +49(211)4242-0 | +49(211)4242-444
KC | Küche & Co |  |  |  |  |
KER | Küchen-Einkaufs-Ring | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KGA | Koop Garant/Areal: EK-Grosseinkauf | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-559
KIG | Küchen-Interessen-Gesellschaft mbH | Strauberger Platz 19 | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
KL | Küchenliga | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
KOA | Koop Alliance FUTURA einkaufs-Gesellschaft mbH & Co. KG | Rolshoverstr. 227 | 51072 | Köln-Poll | +49(221)9836666 | +49(221)9836667
KP | Küchen Partner AG | Rüdesheimer Str. 34 | 65239 | Hochheim am Main | +49(6146)8340-0 | +49(6146)8340-40
KREIS | "DER KREIS" Einkaufsgesellschaft für Küche & Wohnen mbH & Co. KG | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)606700 | +49(7152)73017
KTEM | KTEM | Heemstr. 4 | 27793 | Wildeshausen | +49(4431)92067 | +49(4431)92069
LGF | MeisterTeam LGF GmbH | Rotenhäuser Str. 12 | 21109 | Hamburg | +49(40)7534091 | +49(40)7522019
LUTZ | LUTZ |  |  |  |  |
MBV | MBV Marketing Gesellschat mbH & Co. Lichthauspartner KG | Zeiloch 13 | 76643 | Bruchsal | +49(7251)7240890 | +49(7251)72408979
MDM | Küchenmarketing MDM GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
MHKD | musterhaus küchen Deutschland GmbH & Co. KG | Im Gefierth 9a | 36603 | Dreieich | +49(6103)391-0 | +49(6103)391-109
MIG | MIG Möbel-Interessen-Gemeinschaft GmbH & Co. KG | Industriestr. 41 | 53359 | Rheinbach | +49(2226)9221-0 | +49(2226)9221-22
MKK | Fachhändler Gemeinschaft "meister.Küchen-Konzepte" | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
MM | Möbel Mann GmbH | Durlacher Allee 109 | 76137 | Karlsruhe | +49(721)6096-298 | +49(721)6096-557
MON | Mondial GmbH | Eichsfelder Str. 17 | 40595 | Düsseldorf (Garath) | +49(211)702621-13 | +49(211)702621-30
MP | www.mig-power.de GmbH & Co. KG | Aktienstr. 2 | 45359 | Essen | +49(201)811710 | +49(201)2699838
MSI | Musterring International Josef Höner GmbH & Co. KG | Hauptstr. 134-140 | 33378 | Rheda-Wiedenbrück | +49(5242)592-01 | +49(5242)592-149
MV | Mega Verbund AG | St- Alban-Vorstadt 94 | CH-4052 | Basel | +41(61)2069070 | +41(61)-2069079
MZE | M Z E - Möbel-Zentral-Einkauf GmbH | Loheg 31 | 85375 | Neufarn b. Freising | +49(8165)9526-0 | +49(8165)9526-50
NB | Nürnberger Bund Grosseinkauf eG | Theodor-Althoff-Str. 39 | 45133 | Essen | +49(201)8709-0 |
NECK | Neckermann Versand AG | Hanauer Landstr. 360-400 | 60386 | Frankfurt/Main | +49(69)404-8697 | +49(69)404-8508
NOWEDA | NOWEDA eG | Heinrich-Strunk-Str. 77 | 45143 | Essen | +49(201)802-0 | +49(201)802-1314
NREM | nrc Nordring Einkauf- und Marketing-Cooperation GmbH | Am Redder 1 | 24558 | Henstedt-Ulzburg | +49(4193)9585-0 | +49(4193)9585-25
NWH | NORDWEST Handel AG | Berliner Str. 26-36 | 58135 | Hagen | +49(2331)461-0 | +49(2331)461-389
ÖkoPlus | ÖkoPlus AG Fachhandelsverbund für Ökologisches Bauen + Wohnen | Kasseler Str. 1 A | 60486 | Frankfurt | +49(69)70793013 | +49(69)70793016
OTTO | Otto Versand | Wandsbecker Str. 3-7 | 22179 | Hamburg | +49(40)64610 | +49(40)64618571
PARMA | parma-Aurel GmbH & Co. KG | Grosse-Kurfürsten-Str. 75 | 33615 | Bielefeld | +49(521)52077-0 | +49(521)52077-77
PRISMA | PRISMA Einkaufs- und Marketinggesellschaft mbH | Amsterdamer Str. 230 | 50735 | Köln | +49(221)971410-9 | +49(221)971410-84
ProÖko | Pro Öko Servicegesellschaft ökologischer Einrichtungshäuser mbH | Subbelrather Str. 24 | 50823 | Köln | +49(221)56968-0 | +49(221)56968-21
QUE | Grossversandhaus Quelle, Gustav Schickedanz KG | Thomas-Mann-Str. 50 | 90329 | Nürnberg 50 | +49(911)8152150 | +49(911)8152036
RED | Reddy Küchen und Elektro Vertriebs GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
REGENT | REGENT MÖBEL Grosseinkauf GmbH & Co. KG | Benzstr. 4 | 45891 | Gelsenkirchen | +49(209)9705-0 | +49(209)9705-188
SHK | S H K Einkaufs- und Vertriebsgesellschaft mbH & Co. KG | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
SOFATEX | sofatex Leistungsgemeinschaft GmbH | E.-C.-Baumann-Str. 12 | 95326 | Kulmbach | +49(9221)80064 | +49(9221)80066
SÜDRING | Südring GmbH & Co. KG | Nordstr. 71 | 63450 | Hanau | +49(6181)9104-0 | +49(6181)9104-44
TEV | Textil-Einkaufsverband "NORDWEST" eG | Nordweststr. | 59387 | Ascheberg | +49(2593)818 | +49(2593)7085
TREND | TReND Möbel-Handels-GmbH & Co. Einrichtungs KG | Im Lipperfeld 42 | 46047 | Oberhausen | +49(208)8205-0 | +49(208)8205-210
UNION | UNION Einkaufs GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | +49(211)47236-0 | +49(211)4180034
UNITEX | u n i t e x Einkaufsverband GmbH | Albrecht-Berblinger-Str. 11 | 89231 | Neu Ulm-Schwaighofen | +49(731)707940 | +49(731)7079446 / 7079424
VAR | Varia KE Franchise Warenvertriebsgesellschaft mbH | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)6097-25 | +49(7152)73017
VE | Vesta Küchenhandels GmbH | Industriestr. 9 | 96114 | Hirschaid | +49(9543)842330 | +49(9543)842340
VKG | V K G Vereinigter Küchenfachhandel GmbH + Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-0 | +49(7231)915-160
VME | V M E Vereinigte Möbeleinkaufs-GmbH & Co. KG | An der Wesebreede 2 | 33699 | Bielefeld | +49(521)20885-0 | +49(521)20885-60
WGMEM | Wohngruppe Möbeleinkauf + Marketing GmbH | Schleifweg 10 | 74257 | Untereisesheim | +49(7132)9988-0 | +49(7132)9988-44
WK | WK - WOHNEN Einrichtungs-GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +496103)391-109
WOTEX | Wotex Intercolor | Pappelweg 11 | 66578 | Schiffweiler | +49(6821)9614-0 | +49(6821)9614-60


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Standardgrifflagen
Ansicht mit Navigationswerkzeuge

Standard-grifflage | Bezeichnung | Abbildung | Beschreibung
0 | Ohne Bohrung mit Griff |  | Gilt für alle Fronttypen
1 | Waagerecht mittig - Senkrecht außen |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
2 | Waagerecht mittig - Waagerecht außen |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
3 | Senkrecht mittig - Senkrecht außen |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
4 | Senkrecht mittig - Waagerecht außen |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte außen Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
5 | Waagerecht mittig - Senkrecht mittig |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
6 | Waagerecht mittig - Waagerecht mittig |  | Waagerechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
7 | Senkrecht mittig - Senkrecht mittig |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Senkrechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
8 | Senkrecht mittig - Waagerecht mittig |  | Senkrechte mittige Anordnung für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Waagerechte mittige Anordnung für: Türen; Glastüren; Rollfronten (vertikal).
9 | Waagerecht Gesamtoben - Waagerecht Gesamtoben |  | Anordnung waagerecht oben über die gesamte Breite für: Schubkästen; Auszüge; Jalousien (horizontal). Anordnung waagerecht über die gesamte Breite für: Türen; Glastüren; Klappen; Rollfronten (vertikal).
10 | Waagerecht Gesamtunten - Waagerecht Gesamtoben |  | Anordnung waagerecht unten über die gesamte Breite für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Anordnung waagerecht über die gesamte Breite für: Türen; Glastüren; Rollfronten (vertikal).
11 | Waagerecht Gesamtoben - Senkrecht Gesamtaußen |  | Anordnung waagerecht oben über die gesamte Breite für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Anordnung senkrecht außen über die gesamte Höhe für: Türen; Glastüren; Rollfronten (vertikal).
12 | Waagerecht Gesamtunten - Senkrecht Gesamtaußen |  | Anordnung waagerecht unten über die gesamte Breite für: Schubkästen; Auszüge; Klappen; Jalousien (horizontal). Anordnung senkrecht außen über die gesamte Höhe für: Türen; Glastüren; Rollfronten (vertikal).
90 | Keine Standardgrifflage passt |  |
91 | Keine Standardgrifflage passt |  |
92 | Keine Standardgrifflage passt |  |
93 | Keine Standardgrifflage passt |  |
94 | Keine Standardgrifflage passt |  |
95 | Keine Standardgrifflage passt |  |
96 | Keine Standardgrifflage passt |  |
97 | Keine Standardgrifflage passt |  |
98 | Keine Standardgrifflage passt |  |
99 | Ohne Bohrung ohne Griff |  |


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Sprachcodes
Ansicht mit Navigationswerkzeuge

639-1 | 639-2/ 639-5 | 639-3 | Language Name | Scope | Type |
aa | aar | aar | Afar | Individual | Living | more ...
ab | abk | abk | Abkhazian | Individual | Living | more ...
ae | ave | ave | Avestan | Individual | Ancient | more ...
af | afr | afr | Afrikaans | Individual | Living | more ...
ak | aka | aka | Akan | Macrolanguage | Living | more ...
am | amh | amh | Amharic | Individual | Living | more ...
an | arg | arg | Aragonese | Individual | Living | more ...
ar | ara | ara | Arabic | Macrolanguage | Living | more ...
as | asm | asm | Assamese | Individual | Living | more ...
av | ava | ava | Avaric | Individual | Living | more ...
ay | aym | aym | Aymara | Macrolanguage | Living | more ...
az | aze | aze | Azerbaijani | Macrolanguage | Living | more ...
ba | bak | bak | Bashkir | Individual | Living | more ...
be | bel | bel | Belarusian | Individual | Living | more ...
bg | bul | bul | Bulgarian | Individual | Living | more ...
bh | bih |  | Bihari languages | Collective |  | more ...
bi | bis | bis | Bislama | Individual | Living | more ...
bm | bam | bam | Bambara | Individual | Living | more ...
bn | ben | ben | Bengali | Individual | Living | more ...
bo | bod / tib* | bod | Tibetan | Individual | Living | more ...
br | bre | bre | Breton | Individual | Living | more ...
bs | bos | bos | Bosnian | Individual | Living | more ...
ca | cat | cat | Catalan | Individual | Living | more ...
ce | che | che | Chechen | Individual | Living | more ...
ch | cha | cha | Chamorro | Individual | Living | more ...
co | cos | cos | Corsican | Individual | Living | more ...
cr | cre | cre | Cree | Macrolanguage | Living | more ...
cs | ces / cze* | ces | Czech | Individual | Living | more ...
cu | chu | chu | Church Slavic | Individual | Ancient | more ...
cv | chv | chv | Chuvash | Individual | Living | more ...
cy | cym / wel* | cym | Welsh | Individual | Living | more ...
da | dan | dan | Danish | Individual | Living | more ...
de | deu / ger* | deu | German | Individual | Living | more ...
dv | div | div | Dhivehi | Individual | Living | more ...
dz | dzo | dzo | Dzongkha | Individual | Living | more ...
ee | ewe | ewe | Ewe | Individual | Living | more ...
el | ell / gre* | ell | Modern Greek (1453-) | Individual | Living | more ...
en | eng | eng | English | Individual | Living | more ...
eo | epo | epo | Esperanto | Individual | Constructed | more ...
es | spa | spa | Spanish | Individual | Living | more ...
et | est | est | Estonian | Macrolanguage | Living | more ...
eu | eus / baq* | eus | Basque | Individual | Living | more ...
fa | fas / per* | fas | Persian | Macrolanguage | Living | more ...
ff | ful | ful | Fulah | Macrolanguage | Living | more ...
fi | fin | fin | Finnish | Individual | Living | more ...
fj | fij | fij | Fijian | Individual | Living | more ...
fo | fao | fao | Faroese | Individual | Living | more ...
fr | fra / fre* | fra | French | Individual | Living | more ...
fy | fry | fry | Western Frisian | Individual | Living | more ...
ga | gle | gle | Irish | Individual | Living | more ...
gd | gla | gla | Scottish Gaelic | Individual | Living | more ...
gl | glg | glg | Galician | Individual | Living | more ...
gn | grn | grn | Guarani | Macrolanguage | Living | more ...
gu | guj | guj | Gujarati | Individual | Living | more ...
gv | glv | glv | Manx | Individual | Living | more ...
ha | hau | hau | Hausa | Individual | Living | more ...
he | heb | heb | Hebrew | Individual | Living | more ...
hi | hin | hin | Hindi | Individual | Living | more ...
ho | hmo | hmo | Hiri Motu | Individual | Living | more ...
hr | hrv | hrv | Croatian | Individual | Living | more ...
ht | hat | hat | Haitian | Individual | Living | more ...
hu | hun | hun | Hungarian | Individual | Living | more ...
hy | hye / arm* | hye | Armenian | Individual | Living | more ...
hz | her | her | Herero | Individual | Living | more ...
ia | ina | ina | Interlingua (International Auxiliary Language Association) | Individual | Constructed | more ...
id | ind | ind | Indonesian | Individual | Living | more ...
ie | ile | ile | Interlingue | Individual | Constructed | more ...
ig | ibo | ibo | Igbo | Individual | Living | more ...
ii | iii | iii | Sichuan Yi | Individual | Living | more ...
ik | ipk | ipk | Inupiaq | Macrolanguage | Living | more ...
io | ido | ido | Ido | Individual | Constructed | more ...
is | isl / ice* | isl | Icelandic | Individual | Living | more ...
it | ita | ita | Italian | Individual | Living | more ...
iu | iku | iku | Inuktitut | Macrolanguage | Living | more ...
ja | jpn | jpn | Japanese | Individual | Living | more ...
jv | jav | jav | Javanese | Individual | Living | more ...
ka | kat / geo* | kat | Georgian | Individual | Living | more ...
kg | kon | kon | Kongo | Macrolanguage | Living | more ...
ki | kik | kik | Kikuyu | Individual | Living | more ...
kj | kua | kua | Kuanyama | Individual | Living | more ...
kk | kaz | kaz | Kazakh | Individual | Living | more ...
kl | kal | kal | Kalaallisut | Individual | Living | more ...
km | khm | khm | Central Khmer | Individual | Living | more ...
kn | kan | kan | Kannada | Individual | Living | more ...
ko | kor | kor | Korean | Individual | Living | more ...
kr | kau | kau | Kanuri | Macrolanguage | Living | more ...
ks | kas | kas | Kashmiri | Individual | Living | more ...
ku | kur | kur | Kurdish | Macrolanguage | Living | more ...
kv | kom | kom | Komi | Macrolanguage | Living | more ...
kw | cor | cor | Cornish | Individual | Living | more ...
ky | kir | kir | Kirghiz | Individual | Living | more ...
la | lat | lat | Latin | Individual | Ancient | more ...
lb | ltz | ltz | Luxembourgish | Individual | Living | more ...
lg | lug | lug | Ganda | Individual | Living | more ...
li | lim | lim | Limburgan | Individual | Living | more ...
ln | lin | lin | Lingala | Individual | Living | more ...
lo | lao | lao | Lao | Individual | Living | more ...
lt | lit | lit | Lithuanian | Individual | Living | more ...
lu | lub | lub | Luba-Katanga | Individual | Living | more ...
lv | lav | lav | Latvian | Macrolanguage | Living | more ...
mg | mlg | mlg | Malagasy | Macrolanguage | Living | more ...
mh | mah | mah | Marshallese | Individual | Living | more ...
mi | mri / mao* | mri | Maori | Individual | Living | more ...
mk | mkd / mac* | mkd | Macedonian | Individual | Living | more ...
ml | mal | mal | Malayalam | Individual | Living | more ...
mn | mon | mon | Mongolian | Macrolanguage | Living | more ...
mr | mar | mar | Marathi | Individual | Living | more ...
ms | msa / may* | msa | Malay (macrolanguage) | Macrolanguage | Living | more ...
mt | mlt | mlt | Maltese | Individual | Living | more ...
my | mya / bur* | mya | Burmese | Individual | Living | more ...
na | nau | nau | Nauru | Individual | Living | more ...
nb | nob | nob | Norwegian Bokm�l | Individual | Living | more ...
nd | nde | nde | North Ndebele | Individual | Living | more ...
ne | nep | nep | Nepali (macrolanguage) | Macrolanguage | Living | more ...
ng | ndo | ndo | Ndonga | Individual | Living | more ...
nl | nld / dut* | nld | Dutch | Individual | Living | more ...
nn | nno | nno | Norwegian Nynorsk | Individual | Living | more ...
no | nor | nor | Norwegian | Macrolanguage | Living | more ...
nr | nbl | nbl | South Ndebele | Individual | Living | more ...
nv | nav | nav | Navajo | Individual | Living | more ...
ny | nya | nya | Nyanja | Individual | Living | more ...
oc | oci | oci | Occitan (post 1500) | Individual | Living | more ...
oj | oji | oji | Ojibwa | Macrolanguage | Living | more ...
om | orm | orm | Oromo | Macrolanguage | Living | more ...
or | ori | ori | Oriya (macrolanguage) | Macrolanguage | Living | more ...
os | oss | oss | Ossetian | Individual | Living | more ...
pa | pan | pan | Panjabi | Individual | Living | more ...
pi | pli | pli | Pali | Individual | Ancient | more ...
pl | pol | pol | Polish | Individual | Living | more ...
ps | pus | pus | Pushto | Macrolanguage | Living | more ...
pt | por | por | Portuguese | Individual | Living | more ...
qu | que | que | Quechua | Macrolanguage | Living | more ...
rm | roh | roh | Romansh | Individual | Living | more ...
rn | run | run | Rundi | Individual | Living | more ...
ro | ron / rum* | ron | Romanian | Individual | Living | more ...
ru | rus | rus | Russian | Individual | Living | more ...
rw | kin | kin | Kinyarwanda | Individual | Living | more ...
sa | san | san | Sanskrit | Individual | Ancient | more ...
sc | srd | srd | Sardinian | Macrolanguage | Living | more ...
sd | snd | snd | Sindhi | Individual | Living | more ...
se | sme | sme | Northern Sami | Individual | Living | more ...
sg | sag | sag | Sango | Individual | Living | more ...
sh (deprecated) |  | hbs | Serbo-Croatian | Macrolanguage | Living | more ...
si | sin | sin | Sinhala | Individual | Living | more ...
sk | slk / slo* | slk | Slovak | Individual | Living | more ...
sl | slv | slv | Slovenian | Individual | Living | more ...
sm | smo | smo | Samoan | Individual | Living | more ...
sn | sna | sna | Shona | Individual | Living | more ...
so | som | som | Somali | Individual | Living | more ...
sq | sqi / alb* | sqi | Albanian | Macrolanguage | Living | more ...
sr | srp | srp | Serbian | Individual | Living | more ...
ss | ssw | ssw | Swati | Individual | Living | more ...
st | sot | sot | Southern Sotho | Individual | Living | more ...
su | sun | sun | Sundanese | Individual | Living | more ...
sv | swe | swe | Swedish | Individual | Living | more ...
sw | swa | swa | Swahili (macrolanguage) | Macrolanguage | Living | more ...
ta | tam | tam | Tamil | Individual | Living | more ...
te | tel | tel | Telugu | Individual | Living | more ...
tg | tgk | tgk | Tajik | Individual | Living | more ...
th | tha | tha | Thai | Individual | Living | more ...
ti | tir | tir | Tigrinya | Individual | Living | more ...
tk | tuk | tuk | Turkmen | Individual | Living | more ...
tl | tgl | tgl | Tagalog | Individual | Living | more ...
tn | tsn | tsn | Tswana | Individual | Living | more ...
to | ton | ton | Tonga (Tonga Islands) | Individual | Living | more ...
tr | tur | tur | Turkish | Individual | Living | more ...
ts | tso | tso | Tsonga | Individual | Living | more ...
tt | tat | tat | Tatar | Individual | Living | more ...
tw | twi | twi | Twi | Individual | Living | more ...
ty | tah | tah | Tahitian | Individual | Living | more ...
ug | uig | uig | Uighur | Individual | Living | more ...
uk | ukr | ukr | Ukrainian | Individual | Living | more ...
ur | urd | urd | Urdu | Individual | Living | more ...
uz | uzb | uzb | Uzbek | Macrolanguage | Living | more ...
ve | ven | ven | Venda | Individual | Living | more ...
vi | vie | vie | Vietnamese | Individual | Living | more ...
vo | vol | vol | Volap�k | Individual | Constructed | more ...
wa | wln | wln | Walloon | Individual | Living | more ...
wo | wol | wol | Wolof | Individual | Living | more ...
xh | xho | xho | Xhosa | Individual | Living | more ...
yi | yid | yid | Yiddish | Macrolanguage | Living | more ...
yo | yor | yor | Yoruba | Individual | Living | more ...
za | zha | zha | Zhuang | Macrolanguage | Living | more ...
zh | zho / chi* | zho | Chinese | Macrolanguage | Living | more ...
zu | zul | zul | Zulu | Individual | Living | more ...


%%LocalItemTitle%%

Elemente
Element | Beschreibung
T_NEW_BLOCK | In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Block-Kataloges/Datenbestandes hinterlegt.
Komplexe Typen
Complex Type | Beschreibung
languagetexte | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.
languagetexte30 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.
languagetexte40 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.
languagetexte60 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.
languagetexte60999 | Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten bstehend aus bis zu 999 Zeilen der Länge 60.

© 2018 All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Typen für Detailinformation
Ansicht mit Navigationswerkzeuge
Einleitung > Typen für Detailinformation

Für die Beschreibung der Art der Detailinformation gibt es folgende Info-Typen:

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = diverse


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Elementreferenz
Ansicht mit Navigationswerkzeuge


%%LocalItemTitle%%

T_NEW_BLOCK Element
IDM 2.6.0 Block XML-Schema : T_NEW_BLOCK Element
Beschreibung
In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Block-Kataloges/Datenbestandes hinterlegt.
Namensraum (none)
Diagramm
BLOCK_VALUE_CALCULATION Element FEATURE_DEFINITION Element SERIES Element GLOBAL_DEFINITION Element SUPPLIER Element CATALOG Element Sequence T_NEW_BLOCK Element
Overview
T_NEW_BLOCK
In diesem Element werden alle Informationen und Daten für die Bereitstellung eines vollständigen Block-Kataloges/Datenbestandes hinterlegt.
MAJOR required Restriction of xs:positiveInteger
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION. 		D nonNegativeInteger
P
M [2]
MINOR required Restriction of xs:nonNegativeInteger
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:99]
REVISION required Restriction of xs:nonNegativeInteger
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:99]
Sequence
CATALOG
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.
Sequence
FILE_RELEASE_DATE Restriction of xs:date
In dieses Element wird das letzte Änderungsdatum des vorliegenden Datenbestandes eingegeben. D date
P
M
CATALOG_IDENTIFICATION
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
ASSOC_CTM_NO optional Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.

Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Kurzbezeichnung Einkaufsverbände"). 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
In diesem Element wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird. D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im
Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [1:3]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
VALID_FROM_DATE Restriction of xs:date
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
FILLING_LEVEL Restriction of xs:string
Über die Füllstufe (FILLING_LEVEL) wird definiert, mit welchem Detaillierungsgrad die Katalogdaten beschrieben werden. Im Grundsatz steigt mit zunehmender Füllstufe die Datenqualität, da mit dem steigenden Detaillierungsgrad die Herstellerspezifik der Daten zunimmt.
Die Füllstufen werden bei der Datenzertifizierung ausgewertet: Anhand der Füllstufe wird überprüft, welche Informationen in den Daten vorhanden sein müssen, um die angegebene Füllstufe zu erreichen. Ist eine geforderte Information nicht vorhanden, so wird der Datenbestand nicht zertifiziert.
Die Füllstufen sind wie folgt definiert:
- Füllstufe 1: Es werden Basisinformationen mit Ausnahme der Elemente zur Beschreibung von Texturinformationen
- Füllstufe 2a: Die Füllstufe 1 wird ergänzt um Informationen über Texturen und Material (Farben RGB, Transparenz und Glanz)
- Füllstufe 2b: Die Füllstufe 1 wird ergänzt um Informationen über Frontaufteilungen und Frontausprägungen
- Füllstufe 2c: Die Füllstufe 1 wird ergänzt um Informationen über Griffe
- Füllstufe 2d: Die Füllstufe 1 wird ergänzt um Informationen über Artikeltexturen

Es sind auch Kombinationen der Füllstufen 2a-2d möglich. Folgende Aufschlüsselung der Kombinationen sind definiert:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Füllstufe 3. Um die Füllstufe 3 zu erreichen, müssen die Informationen aus den Füllstufen 1 und 2a - 2d enthalten sein und um Informationen über Echtgrafik ergänzt werden. Mit der Füllstufe 3 werden die Möglichkeiten des Datenformates zur herstellerspezifischen Abbildung gänzlich angewendet.
Die Definition, welche Informationen von welcher Füllstufe gefordert werden, erfolgt im Tabellenteil "Füllstufen". 		D string
P [123]|2[a-n]
M [1:2]
CATALOG_DATA_VERSION optional Restriction of xs:date
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
PRICING_TERMS optional Restriction of xs:string
Mit diesem Element wird definiert, welche Preise in den Daten angelegt werden.
Dieses Element wird zur Unterscheidung beim Datenimport herangezogen, um zu vermeiden, dass sich die Preise bei gleichen Katalogen überschreiben.

Folgende Werte sind möglich:
0 = die angegebenen Preise sind Einkaufspreise für den Handel
1 = die angegebenen Preise sind unverbindliche Preisempfehlungen (UPE)

Entsprechend dem angegebenem Wert müssen die richtigen Preise in den Daten angelegt werden. 		D string
P [01]
M [1:1]
CATALOG_INFO optional languagetexte60999 Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FALL_BACK_LANGUAGE optional Restriction of xs:language
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
SUPPLIER
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.
Sequence
CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt.
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Konatkraufnahme) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
GLOBAL_DEFINITION optional
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.
Sequence
CLEARING_GROUP 0..∞
Das Element dient zur Definition von Verrechnungsgruppen. Eine Verrechnungsgruppe wird durch das Zusammenfassen mehrere Tausch-ID gebildet.

Die Verrechnungsgruppen werden in Blockbedingungen (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) und den Wertestaffeln (BLOCK_VALUE_CALCULATION/GRADING_TABLE) zur Bestimmung von Mindestwerten bestimmter Typenbereiche verwendet. Die Typenbereiche werden durch die Tausch-ID identifiziert.

Die Beträge aller Auftragsposition, deren Tausch-ID in einer Verrechnungsgruppe enthalten sind, werden summiert. Je Verrechnungsgruppe resultiert eine Summe, die als Vergleichskriterium zum Einstieg in die Blockbedingungen und in die Wertestaffel verwendet wird.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut identifiziert eine Verechnungsgruppe. D nonNegativeInteger
P
M [0:999]
Sequence
EXCHANGE_ID_REF 1..∞
Dieses Element referenziert eine Tausch-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Hier werden Tausch-ID eingetragen, die zu einer Verrechnungsgruppe zusammengefasst werden sollen. Die Werte 0, 98 und 99 dürfen hier nicht verwendet werden. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
CLEARING_GROUP_NAME languagetexte60 Complex Type
Bezeichnung für eine Verrechnungsgruppe, die der vereinfachten Handhabung bei der Datenanlage dient.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS optional
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
Sequence
DETAIL_INFO 1..∞

In diesem Element wird eine Detailinformation definiert.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
Anzeigename des Links (z.B. "Magic Corner in Bewegung").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
Dieses Element enthält Text für einen Tooltip zum Link.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
URL
Dieses Element ist für die URL zur Detailinformation.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei . 		D positiveInteger
P
M [1:4]
SERIES
In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren zugeordneten Elementen wie beipsielsweise Blöcke und deren Artikeln hinterlegt.
Sequence
SERIE 1..100
In diesem Element werden die Serien definiert.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie definiert. D nonNegativeInteger
P
M [0:99]
Sequence
PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel gruppiert.
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Blöcke und deren Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1) des Hauptkataloges.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
FEATURE_DEFINITION optional
In diesem Element werden variantenabhängige Informationen(Prüfungen) hinterlegt.
Sequence
RESTRICTIONS
In diesem Element werden die Prüfverfahren angelegt.
Sequence
RESTRICTION 1..99999
In diesem Element wird ein Prüfverfahren definiert und beschrieben. Die Prüfverfahren definieren Regeln, die technisch machbare Konfigurationen abbilden. Es werden keine Planungsvorschläge hinterlegt, andernfalls würden nicht notwendige Prüfungen aufgebaut, die den Planer in seinen Möglichkeiten ungerechtfertigt einschränken.

Eine Zuordnung der Prüfverfahren zu Serien, Programmen oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien, Programmen oder Artikeln referenziert werden.

Prüfverfahren, die aus Serien oder Programmen referenziert werden, dürfen nicht von Artikeln referenziert werden. Prüfverfahren, die von Artikeln referenziert werden, haben Vorrang gegenüber den Prüfungen, die von Serien oder Programmen referenziert werden.

Das Elemente OPTION_REF kann unterschiedlich angelegt werden. Entsprechend den Füllmöglichkeiten der Elemente FEATURE_1_NO, FEATURE_2_NO und FEATURE_3_NO kann ein Prüfverfahren 0-stufig, 1-stufig oder 2-stufig oder 3-stufig definiert werden.

Resultierende Variantenmenge bei nicht angelegten Varianten:

Ist ein Prüfverfahren ein "erlaubendes" Prüfverfahren (TEST_ID = 1), so sind alle in dem Prüfverfahren nicht aufgeführten Varianten der im Prüfverfahren genannten Variantenarten nicht erlaubt. Handelt es sich um ein "nicht erlaubendes" Prüfverfahren (TEST_ID = 0), so sind diese Varianten erlaubt. Werden in einem Prüfverfahren Variantenarten kombiniert, so gilt diese Regel für die Kombination der resultierenden Varianten.

Resultierende Variantenmenge bei Programm-spezifischen Prüfverfahren:

Wird ein Prüfverfahren nicht von allen Programmen referenziert, gilt für die Programme, die das Prüfverfahren nicht referenzieren folgendes:

Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen ungültig, die in diesem Prüfverfahren nicht angelegt wurden.
Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen nicht erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen gültig, die in diesem Prüfverfahren nicht angelegt wurden.

Zyklische Prüfungen
Zyklische Prüfungen sind nicht erlaubt, diese können beispielsweise durch nachfolgende Konstellation hervorgerufen werden:
Nicht erlaubt!
1. Prüfung: Variante1 mit Variante2
2. Prüfung: Variante2 mit Variante3
3. Prüfung: Variante3 mit Variante1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Prüfverfahren eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE required Restriction of xs:int
Im Attribut VALIDATION_TYPE erfolgt die Definition, ob es sich bei dem Prüfverfahren um eine Farblängen-Prüfung, oder eine Variantenprüfung handelt. Wenn es sich um eine Farblängen-Prüfung handelt muss zu jeder Prüfung unter OPTION_COMBINATION eine MIN/MAX_DIMENSION gefällt werden.
0 = Varianten-Prüfung (ehemals Satzart 270)
1 = Farblängen-Prüfung (ehemals Satzart 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt 		D boolean
P
M
BLOCK_VALUE_CALCULATION optional
In diesem Element wird die Block- und Werteverrechnung defiert.
Sequence
BLOCK_CONDITIONS optional

In diesem Element werden Bedingungen formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.

Ein Block darf für einen Auftrag angewendet werden, wenn alle für diesen Block formulierten Bedingungen erfüllt sind. Die einem Block zugeordneten Bedingungen werden durch das Tupel ITEM_REF (Pfad 1) und OPERATION_ID (Pfad 1) gebildet.

Grundbedingung für die Anwendung der Blockbedingung ist, dass ein Block in einem der Programme existiert, die im Auftrag verplant wurden. Sind in einem Auftrag mehrer Programme ausgewählt, gilt das erste Programm im Auftrag auf Kopfebene.

Ein Block unterliegt der Programm- und Variantensteuerung wie "normale" Artikel. Wenn ein Verrechnungsblock in einer Preisgruppe existieren soll, so wird ein entsprechendes Element ITEM_PRICE (Pfad 2) mit dem Preis 0 angelegt.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein, damit der Block für die Werteverrechnung oder die Blockverrechnung angewendet werden darf.

Pfad 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
BLOCK_CONDITION 1..∞
In diesem Element eine Bedingung formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.
Sequence
ITEM_REF
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.
Sequence
CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.
Sequence
CLEARING_GROUP_REF 1..999
Referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder eine zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Werte bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
BLOCK_SALE_PRICES optional
In diesem Element werden Blockaktionspreise formuliert.
Sequence
BLOCK_SALE_PRICE 1..∞

Dieses Element dient dazu, Blockaktionen zu unterschiedlich begrenzten Zeiträumen zu definieren. Sie darf nur eingesetzt werden, wenn ein Block in mehreren begrenzten Zeiträumen innerhalb einer Katalogrunde lieferbar bzw. nicht lieferbar ist. Blöcke, die nur in einem zusammenhängenden Zeitraum lieferbar sind, werden hinsichtlich der Lieferfähigkeit mittels der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL (Pfad 1) definiert.

Der in diesem Element angegebene Preis hat Vorrang gegenüber dem Preis, der dem Block im entsprechenden Preisfeld zugeordnet ist.
Die in diesem Element definierte Varianten-Kombination hat Vorrang gegenüber den artikelspezifischen Prüfverfahren, die dem Block zugeordnet sind.

Die definierten Zeiträume der Aktionspreise dürfen sich für einen Block nicht überschneiden.
Durch die Elementdaten werden keine Informationen überschrieben, es werden Informationen zeitlich auser Kraft gesetzt.
Es wird genau die Informationen zeitlich auser Kraft gesetzt, die in dem Element angegebne sind. Alle anderen Kombinationen sind weiter gültig!

Die Datumswerte eines Blocks in diesem Element dürfen nicht mit denen des Blocks in denen der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL übereinstimmen.
Wir durch einen Datensatz beispielsweise ein Block in einem Programm für einen Zeitraum günstiger angeboten, so darf auf keinen Fall der "normale" Preis in der entsprechenden Preisgruppe des Programms dieses Blockes durch den in diesem Element angegebenen Preis überschrieben werden, da der Preis in dieser Preisgruppe auch von anderen Programmen verwendet werden kann.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Sequence
ITEM_REF
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.
Sequence
VALID_FROM Restriction of xs:date
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
VALID_UNTIL Restriction of xs:date
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
GRADING_TABLE optional

In diesem Element werden die Wertestaffeln zur Verrechnung der Gutschriften oder Aufschläge definiert.

Wenn ein Verrechnungsblock für einen Auftrag gültig ist, kann mit dem Block in die Wertestaffel eingestiegen werden. Je gültigem Block in der Wertstaffel wird eine Vergleichssumme für die in dem Element angegebene Verrechnungsgruppe (CLEARING_GROUP (Pfad 1)) bestimmt. Entspricht der Wert der Vergleichssumme dem angegebenen Wertebereich (Elemente VALUE_FROM (Pfad 2) und VALUE_TO (Pfad 2)), so wird das Element angewendet, d. h. die im Element TYPE_CREDIT (Pfad 2) und/oder TYPE_DEBIT (Pfad 2) hinterlegte Type wird verrechnet. Die Berechnung erfolgt auf die Summe der Kalkulationsgruppe, die für die Gutschrift- oder Belastungstype angegeben ist (Element ITEM (Pfad 3)).

Für einen Block können mehrere Staffelbereiche angelegt werden. Jeder Staffelbereich wird einem Element COMPARING_RULES (Pfad 4) zugeordnet. In einer Staffel eines Blocks müssen die Bedingungen aller Wertebereiche mit jeweiliger Verrechnungsgruppe erfüllt sein, bevor die Positionen verrechnet werden können. Die einzelnen Elemente (COMPARING_RULE) sind UND-verknüpft.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein.

Werden auf dem Element GRADING_TABLE mehrere Datensätze eines Verrechnungsblocks angewendet, so wird der Wert des Blocks (ITEM (Pfad 3)), ITEM_PRICE (Pfad 5)) jedoch nur einmal berechnet.

Pfad 1: GLOBAL_DEFINITION
Pfad 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
CREDIT_SURCHARGE_CLEARING 1..∞
In diesem Element wird ein Wertebereich der Wertestaffel definiert.
Sequence
ITEM_REF

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.
Sequence
COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.

Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.

Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
SET_OF_BLOCK_RULES
In diesem Element und den Kind-Elementen werden die herstellerspezifischen Regelwerke beschrieben.
Sequence
EXCHANGE_ID_GROUP 1..∞
In diesem Element werden die Tauschgruppen definiert. Wenn Tausch-ID 1 (EXCHANGE_ID_1_REF) gegen Tausch-ID 2 (EXCHANGE_ID_2_REF) wechselseitig getauscht werden dürfen, muss dies explizit angegeben werden.
Wenn Artikel mit gleicher Tausch-ID 1:1 untereinander getauscht werden dürfen, muss für diesen Tauschvorgang ein Datensatz angelegt werden.
Sequence
EXCHANGE_ID_1_REF
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RULE 1..99
In diesem Element wird ein herstellerspezifisches Regelwerk definiert.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird ein Zähler von 1-99 für die Regeln im Blockregelwerk angegeben. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
RULE_SET_TEXT languagetexte60999 Complex Type

In diesem Element werden Erläuterungen zu dem Regelwerk angelegt.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
MAJOR Restriction of xs:positiveInteger required
Die Versionsnummer "MAJOR" gibt an in welcher Formatversion der Datenbestand geliefert wird. Diese Haupt-Versionsnummer ändert sich nur bei einer grundsätzlichen Überarbeitung des gesamten Formates.
Die vollständige Angabe der Formatversion, in der ein Datenbestand geliefert wird, besteht aus MAJOR und MINOR und REVISION. 		D nonNegativeInteger
P
M [2]
MINOR Restriction of xs:nonNegativeInteger required
Die Sub-Versionsnummer "MINOR" ändert sich im Regelfall jährlich. Wird die Hauptversion MAJOR geändert, wird die Subversion auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:99]
REVISION Restriction of xs:nonNegativeInteger required
Die Revisionsnummer "REVISION" zeigt unterjährige Format-Änderungen als Ergebnis einzelner Arbeitskreissitzungen an. Falls es sich nicht um notwendige Korrekturen handelt, werden die Revisionen nicht veröffentlicht. Mit jeder neuen Sub-Versionsnummer "MINOR" wird die REVISION auf 0 zurückgesetzt.
 D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="T_NEW_BLOCK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FILE_RELEASE_DATE">
              <xs:annotation>
                <xs:documentation>100--2--Dateifreigabe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_ID">
                    <xs:annotation>
                      <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--13--Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ASSOC_CTM_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRODUCT_BRANDNAME">
                    <xs:annotation>
                      <xs:documentation>100--40--Produktmarke</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_ID">
                    <xs:annotation>
                      <xs:documentation>100--49--Preis_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT">
                    <xs:annotation>
                      <xs:documentation>200--4--MwSt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DATA_VERSION">
              <xs:annotation>
                <xs:documentation>100--11--Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_FROM_DATE">
              <xs:annotation>
                <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_ID">
              <xs:annotation>
                <xs:documentation>100--14--Datei_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MARK">
              <xs:annotation>
                <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BKVF]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILLING_LEVEL">
              <xs:annotation>
                <xs:documentation>100--44--Fuellstufe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[123]|2[a-n]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_DATA_VERSION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICING_TERMS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--48--Preisstellung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="1" />
                  <xs:pattern value="[01]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_INFO" type="languagetexte60999" minOccurs="0">
              <xs:annotation>
                <xs:documentation>110--3--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FALL_BACK_LANGUAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
                <xs:documentation>K. Richter 29.06.2017</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONTACT_PERSON" maxOccurs="2">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CONTACT_PERSON_NO">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_ROLE">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="60" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_NAME">
                    <xs:annotation>
                      <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FIRST_NAME">
                    <xs:annotation>
                      <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FORM_OF_ADDRESS">
                    <xs:annotation>
                      <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DEPARTMENT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE">
                    <xs:annotation>
                      <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONTACT_SUPPLIER">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_NAME_1">
                    <xs:annotation>
                      <xs:documentation>100--16--Herstellername_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--17--Herstellername_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INTERNET_ADDRESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET">
                    <xs:annotation>
                      <xs:documentation>100--20--Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET">
                    <xs:annotation>
                      <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY">
                    <xs:annotation>
                      <xs:documentation>100--22--Ort</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--24--Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GLOBAL_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>120--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="CLEARING_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASSIFICATION">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="8" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INFO_TYPE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                            <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                            <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[01]|99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="INTERNAL_NAME" type="languagetexte40">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="GUID">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="URL">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:anyURI">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="1024" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HASH_VALUE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="64" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESOLUTION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="4" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE" maxOccurs="100">
              <xs:annotation>
                <xs:documentation>200--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUPS">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="ITEMS">
                                <xs:annotation>
                                  <xs:documentation>400--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                            <xs:annotation>
                                              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence minOccurs="0">
                                                <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>450/470--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="PRICE_FIELD">
                                                        <xs:annotation>
                                                          <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="250" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PRICE">
                                                        <xs:annotation>
                                                          <xs:documentation>450--5--Preis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:integer">
                                                            <xs:minInclusive value="-99999999" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="99999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="PRICE_TYPE_REF">
                                            <xs:annotation>
                                              <xs:documentation>400/407--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>407--5--Preisart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CALC_GROUP_REF">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="CALC_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="10" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="RESTRICTIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>409--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>409--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="RESTRICTION_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>409--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SEQUENCE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>409--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:maxInclusive value="99999" />
                                                          <xs:minInclusive value="1" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="EDP_NUMBER" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="9" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_IDENTIFICATION">
                                            <xs:annotation>
                                              <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[BEKSMZVPNOG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CATALOG_PAGE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="40" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VAT_ID_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="VAT_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="VALID_FROM" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALID_UNTIL" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="RANGE_DEPENDENT">
                                            <xs:annotation>
                                              <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:boolean" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_PARTS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="BLOCK_SEQUENTIAL_NO">
                                                        <xs:annotation>
                                                          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF">
                                                        <xs:annotation>
                                                          <xs:documentation>401--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>401--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="FEATURE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="OPTION_KEY" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="5" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="HINGE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--6--Anschlag</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[BEJLMNR]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="EXCHANGE_CONDITION">
                                                        <xs:annotation>
                                                          <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="2" />
                                                            <xs:maxInclusive value="3" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="STATUS">
                                                        <xs:annotation>
                                                          <xs:documentation>401--8--Status</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[ABELSZ]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[JLNRAE]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SHORT_TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT_LINE" maxOccurs="3">
                                                              <xs:annotation>
                                                                <xs:documentation>410--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="TEXT">
                                                                    <xs:annotation>
                                                                      <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[\S ]{1,30}" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                                <xs:attribute name="SEQUENCE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger" />
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>150--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:language">
                                                                <xs:pattern value="[A-Z]{2}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="TYPE_KEY">
                                            <xs:annotation>
                                              <xs:documentation>445--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_TYPE">
                                                  <xs:annotation>
                                                    <xs:documentation>445--4--TS_Typ</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_CLASS">
                                                  <xs:annotation>
                                                    <xs:documentation>445--5--TS_Art</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                                  <xs:annotation>
                                                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                                <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="9999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger" />
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                                      <xs:annotation>
                                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="TK_MATERIAL" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--21--TS_Material</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-2]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_SHAPE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--22--TS_Form</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-2]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS">
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="ECLASS_NO">
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:negativeInteger">
                                                            <xs:totalDigits value="8" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="DETAIL_INFOS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTIONS">
              <xs:annotation>
                <xs:documentation>270/271--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION" maxOccurs="99999">
                    <xs:annotation>
                      <xs:documentation>270/271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>270--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:sequence minOccurs="0">
                                <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                                  <xs:annotation>
                                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="DIMENSION_TYPE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[WHD]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSION_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                                  <xs:annotation>
                                    <xs:documentation>405--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="DIMENSION_TYPE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[WHD]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSION_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TEST_ID">
                          <xs:annotation>
                            <xs:documentation>270--4--Pruef_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_1_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_2_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_3_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="VALIDATION_TYPE" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:int">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BLOCK_VALUE_CALCULATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_CONDITIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>420--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>420--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>420--3--Type_Block</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--3--Type_Block</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--3--Type_Block</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CONDITION_RULES">
                          <xs:annotation>
                            <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>420--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                                      <xs:annotation>
                                        <xs:documentation>420--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="CLEARING_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>420--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:choice>
                                      <xs:element name="MINIMUM_VALUE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                    </xs:choice>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="BLOCK_SALE_PRICES" minOccurs="0">
              <xs:annotation>
                <xs:documentation>480--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>480--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>480--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>480--100--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="VALID_FROM">
                                <xs:annotation>
                                  <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL">
                                <xs:annotation>
                                  <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                                <xs:annotation>
                                  <xs:documentation>480--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>480--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>480--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_OR_CALCULATION_POINT">
                                <xs:annotation>
                                  <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="GRADING_TABLE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>421--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>421--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>421--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>421--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLEARING_GROUP_ID">
                                      <xs:annotation>
                                        <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_FROM">
                                      <xs:annotation>
                                        <xs:documentation>421--6--Wert_von</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_TO">
                                      <xs:annotation>
                                        <xs:documentation>421--7--Wert_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TYPE_CREDIT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TYPE_DEBIT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>421--9--Type_Belastung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_OF_BLOCK_RULES">
              <xs:annotation>
                <xs:documentation>111--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="EXCHANGE_ID_1_REF">
                          <xs:annotation>
                            <xs:documentation>117--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>117--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EXCHANGE_ID_2_REF">
                          <xs:annotation>
                            <xs:documentation>117--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>117--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RULE" maxOccurs="99">
                    <xs:annotation>
                      <xs:documentation>111--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RULE_TEXT" type="languagetexte60999">
                          <xs:annotation>
                            <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="RULE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>113--3--Regel_Nr</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
                    <xs:annotation>
                      <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MAJOR" use="required">
      <xs:annotation>
        <xs:documentation>100--3--Versionsnummer</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="2" />
          <xs:maxInclusive value="2" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MINOR" use="required">
      <xs:annotation>
        <xs:documentation>100--4--Sub_Versions_Nr</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REVISION" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element : CATALOG Element
Beschreibung
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.
Namensraum (none)
Diagramm
FALL_BACK_LANGUAGE Element LANGUAGE Element Sequence CATALOG_INFO Element PRICING_TERMS Element CATALOG_DATA_VERSION Element FILLING_LEVEL Element CATALOG_MARK Element FILE_ID Element VALID_FROM_DATE Element DATA_VERSION Element LANGUAGE Element Sequence CATALOG_NAME Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element FILE_RELEASE_DATE Element Sequence CATALOG Element
Overview
CATALOG
In diesem Element werden administrative Informationen zum Katalog/Datenbestand hinterlegt.
Sequence
FILE_RELEASE_DATE Restriction of xs:date
In dieses Element wird das letzte Änderungsdatum des vorliegenden Datenbestandes eingegeben. D date
P
M
CATALOG_IDENTIFICATION
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
ASSOC_CTM_NO optional Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.

Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Kurzbezeichnung Einkaufsverbände"). 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
In diesem Element wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird. D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im
Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [1:3]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
VALID_FROM_DATE Restriction of xs:date
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
FILLING_LEVEL Restriction of xs:string
Über die Füllstufe (FILLING_LEVEL) wird definiert, mit welchem Detaillierungsgrad die Katalogdaten beschrieben werden. Im Grundsatz steigt mit zunehmender Füllstufe die Datenqualität, da mit dem steigenden Detaillierungsgrad die Herstellerspezifik der Daten zunimmt.
Die Füllstufen werden bei der Datenzertifizierung ausgewertet: Anhand der Füllstufe wird überprüft, welche Informationen in den Daten vorhanden sein müssen, um die angegebene Füllstufe zu erreichen. Ist eine geforderte Information nicht vorhanden, so wird der Datenbestand nicht zertifiziert.
Die Füllstufen sind wie folgt definiert:
- Füllstufe 1: Es werden Basisinformationen mit Ausnahme der Elemente zur Beschreibung von Texturinformationen
- Füllstufe 2a: Die Füllstufe 1 wird ergänzt um Informationen über Texturen und Material (Farben RGB, Transparenz und Glanz)
- Füllstufe 2b: Die Füllstufe 1 wird ergänzt um Informationen über Frontaufteilungen und Frontausprägungen
- Füllstufe 2c: Die Füllstufe 1 wird ergänzt um Informationen über Griffe
- Füllstufe 2d: Die Füllstufe 1 wird ergänzt um Informationen über Artikeltexturen

Es sind auch Kombinationen der Füllstufen 2a-2d möglich. Folgende Aufschlüsselung der Kombinationen sind definiert:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Füllstufe 3. Um die Füllstufe 3 zu erreichen, müssen die Informationen aus den Füllstufen 1 und 2a - 2d enthalten sein und um Informationen über Echtgrafik ergänzt werden. Mit der Füllstufe 3 werden die Möglichkeiten des Datenformates zur herstellerspezifischen Abbildung gänzlich angewendet.
Die Definition, welche Informationen von welcher Füllstufe gefordert werden, erfolgt im Tabellenteil "Füllstufen". 		D string
P [123]|2[a-n]
M [1:2]
CATALOG_DATA_VERSION optional Restriction of xs:date
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
PRICING_TERMS optional Restriction of xs:string
Mit diesem Element wird definiert, welche Preise in den Daten angelegt werden.
Dieses Element wird zur Unterscheidung beim Datenimport herangezogen, um zu vermeiden, dass sich die Preise bei gleichen Katalogen überschreiben.

Folgende Werte sind möglich:
0 = die angegebenen Preise sind Einkaufspreise für den Handel
1 = die angegebenen Preise sind unverbindliche Preisempfehlungen (UPE)

Entsprechend dem angegebenem Wert müssen die richtigen Preise in den Daten angelegt werden. 		D string
P [01]
M [1:1]
CATALOG_INFO optional languagetexte60999 Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
FALL_BACK_LANGUAGE optional Restriction of xs:language
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FILE_RELEASE_DATE">
        <xs:annotation>
          <xs:documentation>100--2--Dateifreigabe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_ID">
              <xs:annotation>
                <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--13--Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ASSOC_CTM_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRODUCT_BRANDNAME">
              <xs:annotation>
                <xs:documentation>100--40--Produktmarke</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_ID">
              <xs:annotation>
                <xs:documentation>100--49--Preis_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT">
              <xs:annotation>
                <xs:documentation>200--4--MwSt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DATA_VERSION">
        <xs:annotation>
          <xs:documentation>100--11--Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_FROM_DATE">
        <xs:annotation>
          <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_ID">
        <xs:annotation>
          <xs:documentation>100--14--Datei_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MARK">
        <xs:annotation>
          <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BKVF]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILLING_LEVEL">
        <xs:annotation>
          <xs:documentation>100--44--Fuellstufe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[123]|2[a-n]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_DATA_VERSION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICING_TERMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--48--Preisstellung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="1" />
            <xs:pattern value="[01]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_INFO" type="languagetexte60999" minOccurs="0">
        <xs:annotation>
          <xs:documentation>110--3--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FALL_BACK_LANGUAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
          <xs:documentation>K. Richter 29.06.2017</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

FILE_RELEASE_DATE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : FILE_RELEASE_DATE Element
Beschreibung
In dieses Element wird das letzte Änderungsdatum des vorliegenden Datenbestandes eingegeben. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
FILE_RELEASE_DATE Element
Overview
FILE_RELEASE_DATE Restriction of xs:date
In dieses Element wird das letzte Änderungsdatum des vorliegenden Datenbestandes eingegeben. D date
P
M
Quelle
<xs:element name="FILE_RELEASE_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--2--Dateifreigabe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_IDENTIFICATION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_IDENTIFICATION Element
Beschreibung
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Namensraum (none)
Diagramm
VAT Element PRICE_ID Element PRODUCT_BRANDNAME Element ASSOC_CTM_NO Element COUNTRY_ID Element CURRENCY_KEY Element ISO_LANGUAGE_ID Element MANUFACTURER_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
In diesem Element wird der Katalog identifiziert. Ein Katalog ist eindeutig über die Kombination der folgenden Elemente identifiziert:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

Weichen die Inhalte dieser Felder bei einem aktualisiertem Katalog von der Basisdatei ab, so ist die Aktualisierung eines vorhandenen Kataloges nicht ohne weiteres möglich.
Die Währungen in den Katalogdaten und den korrespondierenden Blockdaten oder der Werteverrechnung müssen identisch sein.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
ASSOC_CTM_NO optional Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.

Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Kurzbezeichnung Einkaufsverbände"). 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
In diesem Element wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird. D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im
Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Quelle
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_ID">
        <xs:annotation>
          <xs:documentation>100--5--Hersteller_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--13--Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ASSOC_CTM_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRODUCT_BRANDNAME">
        <xs:annotation>
          <xs:documentation>100--40--Produktmarke</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_ID">
        <xs:annotation>
          <xs:documentation>100--49--Preis_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT">
        <xs:annotation>
          <xs:documentation>200--4--MwSt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

MANUFACTURER_ID Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : MANUFACTURER_ID Element
Beschreibung
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MANUFACTURER_ID Element
Overview
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
In diesem Element wird die für den Hersteller gültige Hersteller-ID eingetragen. Die Hersteller-IDs sind in der Tabelle "Hersteller-ID" definiert. Die Hersteller-ID wird ohne führende Nullen angegeben. D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="MANUFACTURER_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--5--Hersteller_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ISO_LANGUAGE_ID Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Beschreibung
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:language
Diagramm
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
Durch den Sprachenschlüssel wird die Sprache definiert, in der die Texte des Datenbestandes erstellt wurden. Hierzu ist der ISO Sprachenschlüssel zu benutzen.
Werden mehrere Sprachkennzeichen verwendet, bedeutet es, dass der Katalog mehrsprachig angelegt wird. Für die Texte des Kataloges dürfen nur die Sprachschlüssel verwendet werden, die in diesen Elementen eingetragen sind. 		D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CURRENCY_KEY Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Beschreibung
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
In diesem Element wird der für die im Datenbestand angegebenen Preise gültige Währungsschlüssel hinterlegt. Für den Währungsschlüssel werden die ISO Währungs-ID verwendet.
Wechselnde Währungen innerhalb eines Datenbestandes sind nicht erlaubt. Unterjährige Updates (auch Blöcke) müssen in der gleichen Währung wie die Basisdatei geliefert werden. 		D string
P [A-Z]{1,3}
M [1:3]
Quelle
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

COUNTRY_ID Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : COUNTRY_ID Element
Beschreibung
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
COUNTRY_ID Element
Overview
COUNTRY_ID Restriction of xs:string
In diesem Element wird bei länderübergreifenden Sprachen und gleicher Währungsangabe die korrekte Länderzuordnung des Datenbestandes angegeben. Hierzu wird der ISO-Ländercode eingetragen. D string
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--13--Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ASSOC_CTM_NO Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ASSOC_CTM_NO Element
Beschreibung
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.

Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Kurzbezeichnung Einkaufsverbände"). 		D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ASSOC_CTM_NO Element
Overview
ASSOC_CTM_NO optional Restriction of xs:string
In diesem Element wird die Kundennummer des Verbandes bzw. des Kunden angegeben, für den der Datenbestand bereitgestellt wird.

Die Bedeutung des Inhaltes ist den Software-Häusern separat mitzuteilen.
Zur einheitlichen Darstellung sollten, wenn vorhanden die Kurzbezeichnungen für die Einkaufverbände verwendet werden (siehe Tabelle "Kurzbezeichnung Einkaufsverbände"). 		D string
P
M [1:15]
Quelle
<xs:element name="ASSOC_CTM_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PRODUCT_BRANDNAME Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRODUCT_BRANDNAME Element
Beschreibung
In diesem Element wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird. D positiveInteger
P
M [1:999]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRODUCT_BRANDNAME Element
Overview
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
In diesem Element wird ein frei definierbarer Zähler angegeben, der für die Gültigkeit einer Produktmarke über mehrere Katalogrunden identisch bleiben muss. Hiermit wird den Softwarehäusern eine Zuordnung eines Kataloges zum Vorjahreskatalog ermöglicht, demzufolge eine effizientere Katalogumsetzung möglich wird. D positiveInteger
P
M [1:999]
Quelle
<xs:element name="PRODUCT_BRANDNAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--40--Produktmarke</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PRICE_ID Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRICE_ID Element
Beschreibung
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im
Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. 		D positiveInteger
P
M [1:3]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_ID Element
Overview
PRICE_ID Restriction of xs:positiveInteger
In diesem Element wird über eine Preis-ID definiert, welcher Art die Preise in dem Datenbestand sind.

Folgende Preis-ID sind möglich:
1 = Preis;
2 = Identnummer;
3 = Verrechnungspunkt.

Wird in diesem Feld der Wert 1 (Preis) oder 2 (Identnummer) eingetragen, muss im
Element CURRENCY_KEY eine Währung angegeben werden. Wird in diesem Element der Wert 3 (Verechnungspunkt) eingetragen, so darf im Element CURRENCY_KEY kein Wert eingetragen werden. 		D positiveInteger
P
M [1:3]
Quelle
<xs:element name="PRICE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--49--Preis_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

VAT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : VAT Element
Beschreibung
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
VAT Element
Overview
VAT Restriction of xs:boolean
In diesem Element wird das Mehrwertsteuerkennzeichen angegeben, welches bei der Preisfindung im Datenbestand verwendet wird.
Folgende Werte sind möglich:
0/False = exklusive Mehrwertsteuer
1/True = inklusive Mehrwertsteuer

Dieses Element hat eine wesentliche Bedeutung bei der Preisfindung. 		D boolean
P
M
Quelle
<xs:element name="VAT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--4--MwSt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_NUMBER Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_NUMBER Element
Beschreibung
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
In diesem Element wird die Katalognummer des Kataloges angegeben, der durch den Datenbestand abgebildet ist. Die Katalognummer ist ein herstellerspezifisches Kennzeichen. D string
P
M [1:10]
Quelle
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_NAME Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_NAME Element
Beschreibung
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Namensraum (none)
Typ
languagetexte30 Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetexte30 Complex Type
In diesem Element wird der Katalogname des Datenbestandes angegeben werden. Dieses Element dient als Basis für die Darstellung des Katalognamens in den Softwareprodukten. Katalognamen in Verbindung mit Jahreszahlen sind erlaubt, da die eindeutige Identifizierung des Kataloges über das Element PRODUCT_BRANDNAME erfolgt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [1:3]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="CATALOG_NAME" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.6.0 Block XML-Schema > languagetexte30 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [1:3]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [1:3]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetexte30 Complex Type | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.6.0 Block XML-Schema > languagetexte30 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte30 Complex Type | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

DATA_VERSION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : DATA_VERSION Element
Beschreibung
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
DATA_VERSION Element
Overview
DATA_VERSION Restriction of xs:date
Die Datenversion (DATA_VERSION) definiert das Datum, bis zu dem vom Hersteller veröffentlichte Katalogdaten, Nachträge und Fehlerkorrekturen in dem Datenbestand berücksichtigt wurden. D date
P
M
Quelle
<xs:element name="DATA_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--11--Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

VALID_FROM_DATE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : VALID_FROM_DATE Element
Beschreibung
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM_DATE Element
Overview
VALID_FROM_DATE Restriction of xs:date
Mit dem Element wird der Zeitpunkt der Gültigkeit des Kataloges und damit des vorliegenden Datenbestandes angegeben. D date
P
M
Quelle
<xs:element name="VALID_FROM_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

FILE_ID Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : FILE_ID Element
Beschreibung
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
FILE_ID Element
Overview
FILE_ID Restriction of xs:boolean
Mit diesem Element wird angegeben, ob es sich bei dem Datenbestand um Testdaten oder freigegebene Daten handelt.

0/false = Testdaten
1/true = freigegebene Daten 		D boolean
P
M
Quelle
<xs:element name="FILE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--14--Datei_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_MARK Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_MARK Element
Beschreibung
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_MARK Element
Overview
CATALOG_MARK Restriction of xs:string
Dieses Element dient zur Kennzeichnung, ob es sich bei den bereitgestellten Daten um

B = Blockdaten mit Preisen
K = Katalogdaten
V = Blockdaten ohne Preise (es müssen fiktive Preise angegeben werden)
F = Korrekturupdate

handelt. 		D string
P [BKVF]
M [1:1]
Quelle
<xs:element name="CATALOG_MARK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BKVF]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

FILLING_LEVEL Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : FILLING_LEVEL Element
Beschreibung
Über die Füllstufe (FILLING_LEVEL) wird definiert, mit welchem Detaillierungsgrad die Katalogdaten beschrieben werden. Im Grundsatz steigt mit zunehmender Füllstufe die Datenqualität, da mit dem steigenden Detaillierungsgrad die Herstellerspezifik der Daten zunimmt.
Die Füllstufen werden bei der Datenzertifizierung ausgewertet: Anhand der Füllstufe wird überprüft, welche Informationen in den Daten vorhanden sein müssen, um die angegebene Füllstufe zu erreichen. Ist eine geforderte Information nicht vorhanden, so wird der Datenbestand nicht zertifiziert.
Die Füllstufen sind wie folgt definiert:
- Füllstufe 1: Es werden Basisinformationen mit Ausnahme der Elemente zur Beschreibung von Texturinformationen
- Füllstufe 2a: Die Füllstufe 1 wird ergänzt um Informationen über Texturen und Material (Farben RGB, Transparenz und Glanz)
- Füllstufe 2b: Die Füllstufe 1 wird ergänzt um Informationen über Frontaufteilungen und Frontausprägungen
- Füllstufe 2c: Die Füllstufe 1 wird ergänzt um Informationen über Griffe
- Füllstufe 2d: Die Füllstufe 1 wird ergänzt um Informationen über Artikeltexturen

Es sind auch Kombinationen der Füllstufen 2a-2d möglich. Folgende Aufschlüsselung der Kombinationen sind definiert:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Füllstufe 3. Um die Füllstufe 3 zu erreichen, müssen die Informationen aus den Füllstufen 1 und 2a - 2d enthalten sein und um Informationen über Echtgrafik ergänzt werden. Mit der Füllstufe 3 werden die Möglichkeiten des Datenformates zur herstellerspezifischen Abbildung gänzlich angewendet.
Die Definition, welche Informationen von welcher Füllstufe gefordert werden, erfolgt im Tabellenteil "Füllstufen". 		D string
P [123]|2[a-n]
M [1:2]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FILLING_LEVEL Element
Overview
FILLING_LEVEL Restriction of xs:string
Über die Füllstufe (FILLING_LEVEL) wird definiert, mit welchem Detaillierungsgrad die Katalogdaten beschrieben werden. Im Grundsatz steigt mit zunehmender Füllstufe die Datenqualität, da mit dem steigenden Detaillierungsgrad die Herstellerspezifik der Daten zunimmt.
Die Füllstufen werden bei der Datenzertifizierung ausgewertet: Anhand der Füllstufe wird überprüft, welche Informationen in den Daten vorhanden sein müssen, um die angegebene Füllstufe zu erreichen. Ist eine geforderte Information nicht vorhanden, so wird der Datenbestand nicht zertifiziert.
Die Füllstufen sind wie folgt definiert:
- Füllstufe 1: Es werden Basisinformationen mit Ausnahme der Elemente zur Beschreibung von Texturinformationen
- Füllstufe 2a: Die Füllstufe 1 wird ergänzt um Informationen über Texturen und Material (Farben RGB, Transparenz und Glanz)
- Füllstufe 2b: Die Füllstufe 1 wird ergänzt um Informationen über Frontaufteilungen und Frontausprägungen
- Füllstufe 2c: Die Füllstufe 1 wird ergänzt um Informationen über Griffe
- Füllstufe 2d: Die Füllstufe 1 wird ergänzt um Informationen über Artikeltexturen

Es sind auch Kombinationen der Füllstufen 2a-2d möglich. Folgende Aufschlüsselung der Kombinationen sind definiert:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Füllstufe 3. Um die Füllstufe 3 zu erreichen, müssen die Informationen aus den Füllstufen 1 und 2a - 2d enthalten sein und um Informationen über Echtgrafik ergänzt werden. Mit der Füllstufe 3 werden die Möglichkeiten des Datenformates zur herstellerspezifischen Abbildung gänzlich angewendet.
Die Definition, welche Informationen von welcher Füllstufe gefordert werden, erfolgt im Tabellenteil "Füllstufen". 		D string
P [123]|2[a-n]
M [1:2]
Quelle
<xs:element name="FILLING_LEVEL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--44--Fuellstufe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[123]|2[a-n]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_DATA_VERSION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_DATA_VERSION Element
Beschreibung
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
CATALOG_DATA_VERSION Element
Overview
CATALOG_DATA_VERSION optional Restriction of xs:date
Dieses Element muss gefüllt werden, wenn in dem Element CATALOG_MARK (Katalogkennzeichen) der Wert F für Korrekturupdate enthalten ist.

In diesem Element wird das Datum der Basisdatei (Element DATA_VERSION) eingetragen, auf welches sich das Korrekturupdate bezieht. 		D date
P
M
Quelle
<xs:element name="CATALOG_DATA_VERSION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PRICING_TERMS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : PRICING_TERMS Element
Beschreibung
Mit diesem Element wird definiert, welche Preise in den Daten angelegt werden.
Dieses Element wird zur Unterscheidung beim Datenimport herangezogen, um zu vermeiden, dass sich die Preise bei gleichen Katalogen überschreiben.

Folgende Werte sind möglich:
0 = die angegebenen Preise sind Einkaufspreise für den Handel
1 = die angegebenen Preise sind unverbindliche Preisempfehlungen (UPE)

Entsprechend dem angegebenem Wert müssen die richtigen Preise in den Daten angelegt werden. 		D string
P [01]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
PRICING_TERMS Element
Overview
PRICING_TERMS optional Restriction of xs:string
Mit diesem Element wird definiert, welche Preise in den Daten angelegt werden.
Dieses Element wird zur Unterscheidung beim Datenimport herangezogen, um zu vermeiden, dass sich die Preise bei gleichen Katalogen überschreiben.

Folgende Werte sind möglich:
0 = die angegebenen Preise sind Einkaufspreise für den Handel
1 = die angegebenen Preise sind unverbindliche Preisempfehlungen (UPE)

Entsprechend dem angegebenem Wert müssen die richtigen Preise in den Daten angelegt werden. 		D string
P [01]
M [1:1]
Quelle
<xs:element name="PRICING_TERMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--48--Preisstellung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="1" />
      <xs:pattern value="[01]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_INFO Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_INFO Element
Beschreibung
In diesem Element werden die Informationstexte abgelegt.
Namensraum (none)
Typ
languagetexte60999 Complex Type
Diagramm
LANGUAGE Element Sequence CATALOG_INFO Element
Overview
CATALOG_INFO optional languagetexte60999 Complex Type
In diesem Element werden die Informationstexte abgelegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="CATALOG_INFO" type="languagetexte60999" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>110--3--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.6.0 Block XML-Schema > languagetexte60999 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>150--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>265--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,60}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetexte60999 Complex Type | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
IDM 2.6.0 Block XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element : TEXT_LINE Element
Beschreibung
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
Namensraum (none)
Diagramm
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE_NO Restriction of xs:positiveInteger required
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Quelle
<xs:element name="TEXT_LINE" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte60999 Complex Type | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.6.0 Block XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | languagetexte60999 Complex Type | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

FALL_BACK_LANGUAGE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : FALL_BACK_LANGUAGE Element
Beschreibung
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
Namensraum (none)
Typ
Restriction of xs:language
Diagramm
FALL_BACK_LANGUAGE Element
Overview
FALL_BACK_LANGUAGE optional Restriction of xs:language
Dieses Element entspricht dem Sprachenschlüssel, der die Sprache definiert, in der die Texte des Datenbestandes erstellt werden, wenn ein Sprachkennzeichen für die mehrsprachigen Texte fehlt. Hierzu ist der zweistellige ISO-Sprachenschlüssel zu benutzen. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="FALL_BACK_LANGUAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
    <xs:documentation>K. Richter 29.06.2017</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CATALOG Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

SUPPLIER Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element : SUPPLIER Element
Beschreibung
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.
Namensraum (none)
Diagramm
CONTACT_SUPPLIER Element CONTACT_PERSON Element Sequence SUPPLIER Element
Overview
SUPPLIER
In diesem Element werden Daten des Herstellers hinterlegt, wie beispielsweise Kommunikations- und Kontaktinformationen.
Sequence
CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt.
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Konatkraufnahme) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Quelle
<xs:element name="SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONTACT_PERSON" maxOccurs="2">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONTACT_PERSON_NO">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_ROLE">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="60" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_NAME">
              <xs:annotation>
                <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FIRST_NAME">
              <xs:annotation>
                <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FORM_OF_ADDRESS">
              <xs:annotation>
                <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPARTMENT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE">
              <xs:annotation>
                <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONTACT_SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_NAME_1">
              <xs:annotation>
                <xs:documentation>100--16--Herstellername_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--17--Herstellername_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INTERNET_ADDRESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET">
              <xs:annotation>
                <xs:documentation>100--20--Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET">
              <xs:annotation>
                <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY">
              <xs:annotation>
                <xs:documentation>100--22--Ort</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--24--Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CONTACT_PERSON Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element : CONTACT_PERSON Element
Beschreibung
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt.
Namensraum (none)
Diagramm
CITY Element ZIPCODE_STREET Element STREET Element EMAIL Element FAX Element TELEPHONE Element DEPARTMENT Element FORM_OF_ADDRESS Element FIRST_NAME Element CONTACT_NAME Element CONTACT_ROLE Element CONTACT_PERSON_NO Element Sequence CONTACT_PERSON Element
Overview
CONTACT_PERSON 1..2
In diesem Element werden die Informationen eines Ansprechpartners hinterlegt.
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Konatkraufnahme) D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Quelle
<xs:element name="CONTACT_PERSON" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONTACT_PERSON_NO">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_ROLE">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="60" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_NAME">
        <xs:annotation>
          <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FIRST_NAME">
        <xs:annotation>
          <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FORM_OF_ADDRESS">
        <xs:annotation>
          <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPARTMENT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE">
        <xs:annotation>
          <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CONTACT_PERSON_NO Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_PERSON_NO Element
Beschreibung
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Konatkraufnahme) D positiveInteger
P
M [1:2]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
CONTACT_PERSON_NO Element
Overview
CONTACT_PERSON_NO Restriction of xs:positiveInteger
In diesem Element wird die Rangfolge der Kontaktaufnahme zum Ansprechpartner angegeben. (1=1. Kontaktaufnahme, 2=2. Konatkraufnahme) D positiveInteger
P
M [1:2]
Quelle
<xs:element name="CONTACT_PERSON_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CONTACT_ROLE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_ROLE Element
Beschreibung
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONTACT_ROLE Element
Overview
CONTACT_ROLE Restriction of xs:string
In diesem Element wird die Rolle des angelegten Kontaktes angegeben. Die Bezeichnungen der Rollen werden vom Hersteller definiert (z. B. Stellvertreter, EDI-Verantwortlicher). D string
P
M [1:60]
Quelle
<xs:element name="CONTACT_ROLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="60" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CONTACT_NAME Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_NAME Element
Beschreibung
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONTACT_NAME Element
Overview
CONTACT_NAME Restriction of xs:string
In diesem Element wird der Familienname des direkten Ansprechpartners für das Software-Haus angegeben. D string
P
M [1:20]
Quelle
<xs:element name="CONTACT_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

FIRST_NAME Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : FIRST_NAME Element
Beschreibung
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FIRST_NAME Element
Overview
FIRST_NAME Restriction of xs:string
In diesem Element wird der Vorname des direkten Ansprechpartners angegeben. D string
P
M [1:20]
Quelle
<xs:element name="FIRST_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

FORM_OF_ADDRESS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : FORM_OF_ADDRESS Element
Beschreibung
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
FORM_OF_ADDRESS Element
Overview
FORM_OF_ADDRESS Restriction of xs:positiveInteger
Hier wird die Anrede des direkten Ansprechpartners angegeben.
1 = Frau
2 = Herr. 		D positiveInteger
P
M [1:2]
Quelle
<xs:element name="FORM_OF_ADDRESS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

DEPARTMENT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : DEPARTMENT Element
Beschreibung
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
DEPARTMENT Element
Overview
DEPARTMENT optional Restriction of xs:string
Hier wird, soweit vorhanden, die Abteilung des direkten Ansprechpartners angegeben. D string
P
M [1:15]
Quelle
<xs:element name="DEPARTMENT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TELEPHONE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : TELEPHONE Element
Beschreibung
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TELEPHONE Element
Overview
TELEPHONE Restriction of xs:string
Hier wird die Telefonnummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Quelle
<xs:element name="TELEPHONE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

FAX Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : FAX Element
Beschreibung
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FAX Element
Overview
FAX optional Restriction of xs:string
Hier wird die Fax-Nummer des direkten Ansprechpartners angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(5251)60-3284. D string
P
M [1:18]
Quelle
<xs:element name="FAX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

EMAIL Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : EMAIL Element
Beschreibung
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
In diesem Element wird die E-Mail-Adresse angegeben. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
Quelle
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

STREET Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : STREET Element
Beschreibung
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
STREET Element
Overview
STREET optional Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Quelle
<xs:element name="STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : ZIPCODE_STREET Element
Beschreibung
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET optional Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Quelle
<xs:element name="ZIPCODE_STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CITY Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : CITY Element
Beschreibung
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CITY Element
Overview
CITY optional Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Quelle
<xs:element name="CITY" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CONTACT_SUPPLIER Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element : CONTACT_SUPPLIER Element
Beschreibung
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.
Namensraum (none)
Diagramm
FAX_SWITCHBOARD Element TELEPHONE_SWITCHBOARD Element POSTBOX Element ZIPCODE_POSTBOX Element CITY Element ZIPCODE_STREET Element STREET Element INTERNET_ADDRESS Element EMAIL Element MANUFACTURER_NAME_2 Element MANUFACTURER_NAME_1 Element Sequence CONTACT_SUPPLIER Element
Overview
CONTACT_SUPPLIER
In diesem Element werden die Kontaktdaten des Herstellers hinterlegt.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Quelle
<xs:element name="CONTACT_SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_NAME_1">
        <xs:annotation>
          <xs:documentation>100--16--Herstellername_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--17--Herstellername_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INTERNET_ADDRESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--19--Internet_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET">
        <xs:annotation>
          <xs:documentation>100--20--Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET">
        <xs:annotation>
          <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY">
        <xs:annotation>
          <xs:documentation>100--22--Ort</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--24--Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9a-zA-Z]{0,10}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

MANUFACTURER_NAME_1 Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_1 Element
Beschreibung
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MANUFACTURER_NAME_1 Element
Overview
MANUFACTURER_NAME_1 Restriction of xs:string
In diesem Element wird die 1. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Quelle
<xs:element name="MANUFACTURER_NAME_1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--16--Herstellername_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

MANUFACTURER_NAME_2 Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_2 Element
Beschreibung
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
MANUFACTURER_NAME_2 Element
Overview
MANUFACTURER_NAME_2 optional Restriction of xs:string
Wenn vohanden, wird in diesem Element die 2. Zeile des Firmennamens angegeben. D string
P
M [1:30]
Quelle
<xs:element name="MANUFACTURER_NAME_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--17--Herstellername_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

EMAIL Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : EMAIL Element
Beschreibung
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
In diesem Element wird die für den Händler bzw. Endkunden offizielle E-Mail-Adresse angegeben.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

Quelle
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

INTERNET_ADDRESS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : INTERNET_ADDRESS Element
Beschreibung
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
INTERNET_ADDRESS Element
Overview
INTERNET_ADDRESS optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die für den Händler bzw. Endkunden offizielle Internet-Adresse angegeben (z. B.: http://www.firma.de). D string
P
M
Quelle
<xs:element name="INTERNET_ADDRESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--19--Internet_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

STREET Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : STREET Element
Beschreibung
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
STREET Element
Overview
STREET Restriction of xs:string
In diesem Element wird die Straße der Hausanschrift des Herstellers angegeben. D string
P
M [1:30]
Quelle
<xs:element name="STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--20--Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_STREET Element
Beschreibung
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET Restriction of xs:string
In diesem Element wird die Postleitzahl der Hausanschrift des Herstellers angegeben. D string
P
M [1:8]
Quelle
<xs:element name="ZIPCODE_STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CITY Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : CITY Element
Beschreibung
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CITY Element
Overview
CITY Restriction of xs:string
In diesem Element wird der Sitz des Herstellers angegeben. D string
P
M [1:30]
Quelle
<xs:element name="CITY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--22--Ort</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ZIPCODE_POSTBOX Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_POSTBOX Element
Beschreibung
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ZIPCODE_POSTBOX Element
Overview
ZIPCODE_POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, die Postleitzahl des Postfaches angegeben. D string
P
M [1:8]
Quelle
<xs:element name="ZIPCODE_POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

POSTBOX Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : POSTBOX Element
Beschreibung
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
POSTBOX Element
Overview
POSTBOX optional Restriction of xs:string
In diesem Element wird, soweit vorhanden, das Postfach der Herstelleradresse angegeben. Das Wort "Postfach" darf nicht miterfasst werden. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Quelle
<xs:element name="POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--24--Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9a-zA-Z]{0,10}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TELEPHONE_SWITCHBOARD Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : TELEPHONE_SWITCHBOARD Element
Beschreibung
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TELEPHONE_SWITCHBOARD Element
Overview
TELEPHONE_SWITCHBOARD Restriction of xs:string
Hier wird die Telefonnummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Quelle
<xs:element name="TELEPHONE_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

FAX_SWITCHBOARD Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : FAX_SWITCHBOARD Element
Beschreibung
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
FAX_SWITCHBOARD Element
Overview
FAX_SWITCHBOARD Restriction of xs:string
Hier wird die Fax-Nummer der Zentrale des Herstellers angegeben. Diese beinhaltet auch alle (internationalen) Vorwahlen, z. B.: +49(1234)56-7890. D string
P
M [1:18]
Quelle
<xs:element name="FAX_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

GLOBAL_DEFINITION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element : GLOBAL_DEFINITION Element
Beschreibung
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.
Namensraum (none)
Diagramm
DETAIL_INFOS Element CLEARING_GROUP Element Sequence GLOBAL_DEFINITION Element
Overview
GLOBAL_DEFINITION optional
In diesem Element werden für den gesamten Katalog/Datenbestand gültige Daten (globale Informationen) hinterlegt.
Sequence
CLEARING_GROUP 0..∞
Das Element dient zur Definition von Verrechnungsgruppen. Eine Verrechnungsgruppe wird durch das Zusammenfassen mehrere Tausch-ID gebildet.

Die Verrechnungsgruppen werden in Blockbedingungen (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) und den Wertestaffeln (BLOCK_VALUE_CALCULATION/GRADING_TABLE) zur Bestimmung von Mindestwerten bestimmter Typenbereiche verwendet. Die Typenbereiche werden durch die Tausch-ID identifiziert.

Die Beträge aller Auftragsposition, deren Tausch-ID in einer Verrechnungsgruppe enthalten sind, werden summiert. Je Verrechnungsgruppe resultiert eine Summe, die als Vergleichskriterium zum Einstieg in die Blockbedingungen und in die Wertestaffel verwendet wird.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut identifiziert eine Verechnungsgruppe. D nonNegativeInteger
P
M [0:999]
Sequence
EXCHANGE_ID_REF 1..∞
Dieses Element referenziert eine Tausch-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Hier werden Tausch-ID eingetragen, die zu einer Verrechnungsgruppe zusammengefasst werden sollen. Die Werte 0, 98 und 99 dürfen hier nicht verwendet werden. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
CLEARING_GROUP_NAME languagetexte60 Complex Type
Bezeichnung für eine Verrechnungsgruppe, die der vereinfachten Handhabung bei der Datenanlage dient.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS optional
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
Sequence
DETAIL_INFO 1..∞

In diesem Element wird eine Detailinformation definiert.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
Anzeigename des Links (z.B. "Magic Corner in Bewegung").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
Dieses Element enthält Text für einen Tooltip zum Link.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
URL
Dieses Element ist für die URL zur Detailinformation.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei . 		D positiveInteger
P
M [1:4]
Quelle
<xs:element name="GLOBAL_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="CLEARING_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASSIFICATION">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INFO_TYPE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                      <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                      <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[01]|99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="INTERNAL_NAME" type="languagetexte40">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="GUID">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="URL">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:anyURI">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="1024" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HASH_VALUE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="64" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESOLUTION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="4" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element : CLEARING_GROUP Element
Beschreibung
Das Element dient zur Definition von Verrechnungsgruppen. Eine Verrechnungsgruppe wird durch das Zusammenfassen mehrere Tausch-ID gebildet.

Die Verrechnungsgruppen werden in Blockbedingungen (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) und den Wertestaffeln (BLOCK_VALUE_CALCULATION/GRADING_TABLE) zur Bestimmung von Mindestwerten bestimmter Typenbereiche verwendet. Die Typenbereiche werden durch die Tausch-ID identifiziert.

Die Beträge aller Auftragsposition, deren Tausch-ID in einer Verrechnungsgruppe enthalten sind, werden summiert. Je Verrechnungsgruppe resultiert eine Summe, die als Vergleichskriterium zum Einstieg in die Blockbedingungen und in die Wertestaffel verwendet wird.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence CLEARING_GROUP_NAME Element EXCHANGE_ID_REF Element Sequence CLEARING_GROUP Element
Overview
CLEARING_GROUP 0..∞
Das Element dient zur Definition von Verrechnungsgruppen. Eine Verrechnungsgruppe wird durch das Zusammenfassen mehrere Tausch-ID gebildet.

Die Verrechnungsgruppen werden in Blockbedingungen (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) und den Wertestaffeln (BLOCK_VALUE_CALCULATION/GRADING_TABLE) zur Bestimmung von Mindestwerten bestimmter Typenbereiche verwendet. Die Typenbereiche werden durch die Tausch-ID identifiziert.

Die Beträge aller Auftragsposition, deren Tausch-ID in einer Verrechnungsgruppe enthalten sind, werden summiert. Je Verrechnungsgruppe resultiert eine Summe, die als Vergleichskriterium zum Einstieg in die Blockbedingungen und in die Wertestaffel verwendet wird.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Dieses Attribut identifiziert eine Verechnungsgruppe. D nonNegativeInteger
P
M [0:999]
Sequence
EXCHANGE_ID_REF 1..∞
Dieses Element referenziert eine Tausch-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Hier werden Tausch-ID eingetragen, die zu einer Verrechnungsgruppe zusammengefasst werden sollen. Die Werte 0, 98 und 99 dürfen hier nicht verwendet werden. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
CLEARING_GROUP_NAME languagetexte60 Complex Type
Bezeichnung für eine Verrechnungsgruppe, die der vereinfachten Handhabung bei der Datenanlage dient.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
CLEARING_GROUP_NO Restriction of xs:nonNegativeInteger required
Dieses Attribut identifiziert eine Verechnungsgruppe. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="CLEARING_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > CLEARING_GROUP Element : EXCHANGE_ID_REF Element
Beschreibung
Dieses Element referenziert eine Tausch-ID.
Namensraum (none)
Diagramm
EXCHANGE_ID_REF Element
Overview
EXCHANGE_ID_REF 1..∞
Dieses Element referenziert eine Tausch-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Hier werden Tausch-ID eingetragen, die zu einer Verrechnungsgruppe zusammengefasst werden sollen. Die Werte 0, 98 und 99 dürfen hier nicht verwendet werden. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
Hier werden Tausch-ID eingetragen, die zu einer Verrechnungsgruppe zusammengefasst werden sollen. Die Werte 0, 98 und 99 dürfen hier nicht verwendet werden. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Quelle
<xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
CLEARING_GROUP Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_NAME Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > CLEARING_GROUP Element : CLEARING_GROUP_NAME Element
Beschreibung
Bezeichnung für eine Verrechnungsgruppe, die der vereinfachten Handhabung bei der Datenanlage dient.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence CLEARING_GROUP_NAME Element
Overview
CLEARING_GROUP_NAME languagetexte60 Complex Type
Bezeichnung für eine Verrechnungsgruppe, die der vereinfachten Handhabung bei der Datenanlage dient.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="CLEARING_GROUP_NAME" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
CLEARING_GROUP Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.6.0 Block XML-Schema > languagetexte60 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetexte60 Complex Type | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.6.0 Block XML-Schema > languagetexte60 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte60 Complex Type | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element : DETAIL_INFOS Element
Beschreibung
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
Namensraum (none)
Diagramm
DETAIL_INFO Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
Das Element dient zur Speicherung von Hyperlinks zu Detailinformationen.
Sequence
DETAIL_INFO 1..∞

In diesem Element wird eine Detailinformation definiert.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
Anzeigename des Links (z.B. "Magic Corner in Bewegung").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
Dieses Element enthält Text für einen Tooltip zum Link.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
URL
Dieses Element ist für die URL zur Detailinformation.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei . 		D positiveInteger
P
M [1:4]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASSIFICATION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INFO_TYPE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[01]|99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="INTERNAL_NAME" type="languagetexte40">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="GUID">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="URL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:anyURI">
                              <xs:minLength value="1" />
                              <xs:maxLength value="1024" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HASH_VALUE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="64" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESOLUTION" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="4" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

DETAIL_INFO Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element : DETAIL_INFO Element
Beschreibung

In diesem Element wird eine Detailinformation definiert.

Namensraum (none)
Diagramm
RESOLUTION Element URL Element LANGUAGE Element Sequence TOOL_TIP Element GUID Element LANGUAGE Element Sequence INTERNAL_NAME Element LANGUAGE Element Sequence EXTERNAL_NAME Element INFO_TYPE Element CLASSIFICATION Element Sequence DETAIL_INFO Element
Overview
DETAIL_INFO 1..∞

In diesem Element wird eine Detailinformation definiert.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
Anzeigename des Links (z.B. "Magic Corner in Bewegung").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
Dieses Element enthält Text für einen Tooltip zum Link.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
URL
Dieses Element ist für die URL zur Detailinformation.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei . 		D positiveInteger
P
M [1:4]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO Restriction of xs:positiveInteger required
Dieses Attribut identifiziert eine Detailinformation. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASSIFICATION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INFO_TYPE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
          <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
          <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[01]|99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="INTERNAL_NAME" type="languagetexte40">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="GUID">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="URL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:anyURI">
                        <xs:minLength value="1" />
                        <xs:maxLength value="1024" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HASH_VALUE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="64" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESOLUTION" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="4" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CLASSIFICATION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : CLASSIFICATION Element
Beschreibung
Dieses Element dient der Klassifizierung der Detailinformation.
 D string
P
M [1:8]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CLASSIFICATION Element
Overview
CLASSIFICATION Restriction of xs:string
Dieses Element dient der Klassifizierung der Detailinformation.
 D string
P
M [1:8]
Quelle
<xs:element name="CLASSIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

INFO_TYPE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INFO_TYPE Element
Beschreibung
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
INFO_TYPE Element
Overview
INFO_TYPE Restriction of xs:positiveInteger
Dieses Element beschreibt die Art der Detailinformation.

1 = Milieufoto
2 = Artikel Skizze
3 = Artikel Foto
4 = Variante Foto
5 = Variante Textur
6 = Logo Hersteller/Produktmarke
7 = Modellbeschreibungsblätter
8 = Montageanleitung
9 = Marketing
10 = Pictogrammskizze
11 = Video
99 = Sonstiges 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
Quelle
<xs:element name="INFO_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
    <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
    <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[01]|99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

EXTERNAL_NAME Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : EXTERNAL_NAME Element
Beschreibung
Anzeigename des Links (z.B. "Magic Corner in Bewegung").
Namensraum (none)
Typ
languagetexte Complex Type
Diagramm
LANGUAGE Element Sequence EXTERNAL_NAME Element
Overview
EXTERNAL_NAME optional languagetexte Complex Type
Anzeigename des Links (z.B. "Magic Corner in Bewegung").
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.6.0 Block XML-Schema > languagetexte Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:string">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetexte Complex Type | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.6.0 Block XML-Schema > languagetexte Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Namensraum (none)
Typ
xs:string
Diagramm
TEXT Element
Overview
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="TEXT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte Complex Type | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

INTERNAL_NAME Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INTERNAL_NAME Element
Beschreibung
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Namensraum (none)
Typ
languagetexte40 Complex Type
Diagramm
LANGUAGE Element Sequence INTERNAL_NAME Element
Overview
INTERNAL_NAME languagetexte40 Complex Type
Hier kann eine ausführlichere Beschreibung zum Link mitgegeben werden.

Diese Information ist nicht für die Weitergabe an den Handelspartner,
sondern für weitergehende Informationen für die Softwarehäuser gedacht.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="INTERNAL_NAME" type="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.6.0 Block XML-Schema > languagetexte40 Complex Type : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,40}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
languagetexte40 Complex Type | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.6.0 Block XML-Schema > languagetexte40 Complex Type > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,40}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | languagetexte40 Complex Type | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

GUID Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : GUID Element
Beschreibung
Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
GUID Element
Overview
GUID Restriction of xs:string
Dieses Element dient der Zuordnung einer global eindeutigen Zahl (Globally Unique Identifier (GUID))

Die GUID wird im Format XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX dargestellt, wobei jedes 'X' für ein Zeichen aus dem Hexadezimalsystem steht und damit eine Ziffer 0-9 oder ein Buchstabe A-F sein kann, zum Beispiel :
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-Zeichen). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
Quelle
<xs:element name="GUID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TOOL_TIP Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : TOOL_TIP Element
Beschreibung
Dieses Element enthält Text für einen Tooltip zum Link.
Namensraum (none)
Typ
languagetexte Complex Type
Diagramm
LANGUAGE Element Sequence TOOL_TIP Element
Overview
TOOL_TIP optional languagetexte Complex Type
Dieses Element enthält Text für einen Tooltip zum Link.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

URL Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : URL Element
Beschreibung
Dieses Element ist für die URL zur Detailinformation.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence URL Element
Overview
URL
Dieses Element ist für die URL zur Detailinformation.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
Quelle
<xs:element name="URL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:anyURI">
                  <xs:minLength value="1" />
                  <xs:maxLength value="1024" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HASH_VALUE" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="64" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
HASH_VALUE Element TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:anyURI">
            <xs:minLength value="1" />
            <xs:maxLength value="1024" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HASH_VALUE" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="64" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : TEXT Element
Beschreibung
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
Namensraum (none)
Typ
Restriction of xs:anyURI
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:anyURI
In diesem Element wird die URL der Detailinformation hinterlegt, deren Sprachzugehörigkeit durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist.. D anyURI
P
M [1:1024]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:anyURI">
      <xs:minLength value="1" />
      <xs:maxLength value="1024" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

HASH_VALUE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : HASH_VALUE Element
Beschreibung
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
HASH_VALUE Element
Overview
HASH_VALUE optional Restriction of xs:string
Hier kann ein für die Detailinformation erzeugter Hashwert abgespeichert werden.
Dieser dient der Überprüfung auf Korrektheit des Downloads. 		D string
P
M [1:64]
Quelle
<xs:element name="HASH_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="64" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

RESOLUTION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : RESOLUTION Element
Beschreibung
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei . 		D positiveInteger
P
M [1:4]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
RESOLUTION Element
Overview
RESOLUTION optional Restriction of xs:positiveInteger
Diese Element gibt an, in welcher Auflösung das Bild vorliegt. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei . 		D positiveInteger
P
M [1:4]
Quelle
<xs:element name="RESOLUTION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="4" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

SERIES Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element : SERIES Element
Beschreibung
In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren zugeordneten Elementen wie beipsielsweise Blöcke und deren Artikeln hinterlegt.
Namensraum (none)
Diagramm
SERIE Element Sequence SERIES Element
Overview
SERIES
In diesem Element werden alle Serien des Kataloges/Datenbestandes mit ihren zugeordneten Elementen wie beipsielsweise Blöcke und deren Artikeln hinterlegt.
Sequence
SERIE 1..100
In diesem Element werden die Serien definiert.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie definiert. D nonNegativeInteger
P
M [0:99]
Sequence
PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel gruppiert.
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Blöcke und deren Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1) des Hauptkataloges.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1) aus dem Hauptkatalog, in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE des Hauptkataloges definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen im Hauptkatalog definiert.
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID des Hauptkataloges definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
RESTRICTIONS optional

In diesem Element werden blockspezifische Prüfverfahren zugeordnet.

Wenn ein Block Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Blockspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.

EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1 des Hauptkataloges) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD des Hauptkataloges gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird. 		D boolean
P
M
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Quelle
<xs:element name="SERIES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE" maxOccurs="100">
        <xs:annotation>
          <xs:documentation>200--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="ITEMS">
                          <xs:annotation>
                            <xs:documentation>400--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                      <xs:annotation>
                                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence minOccurs="0">
                                          <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>450/470--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PRICE_FIELD">
                                                  <xs:annotation>
                                                    <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="250" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PRICE">
                                                  <xs:annotation>
                                                    <xs:documentation>450--5--Preis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:integer">
                                                      <xs:minInclusive value="-99999999" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="PRICE_TYPE_REF">
                                      <xs:annotation>
                                        <xs:documentation>400/407--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="PRICE_TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>407--5--Preisart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CALC_GROUP_REF">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="CALC_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="10" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="RESTRICTIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>409--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>409--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="RESTRICTION_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>409--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SEQUENCE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>409--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:maxInclusive value="99999" />
                                                    <xs:minInclusive value="1" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="EDP_NUMBER" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_IDENTIFICATION">
                                      <xs:annotation>
                                        <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[BEKSMZVPNOG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CATALOG_PAGE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="40" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VAT_ID_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="VAT_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="RANGE_DEPENDENT">
                                      <xs:annotation>
                                        <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_PARTS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BLOCK_SEQUENTIAL_NO">
                                                  <xs:annotation>
                                                    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="FEATURE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="OPTION_KEY" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="5" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="HINGE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--6--Anschlag</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[BEJLMNR]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="EXCHANGE_CONDITION">
                                                  <xs:annotation>
                                                    <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="2" />
                                                      <xs:maxInclusive value="3" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="STATUS">
                                                  <xs:annotation>
                                                    <xs:documentation>401--8--Status</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[ABELSZ]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[JLNRAE]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SHORT_TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT_LINE" maxOccurs="3">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT">
                                                              <xs:annotation>
                                                                <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[\S ]{1,30}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SEQUENCE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger" />
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>150--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:language">
                                                          <xs:pattern value="[A-Z]{2}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TYPE_KEY">
                                      <xs:annotation>
                                        <xs:documentation>445--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_TYPE">
                                            <xs:annotation>
                                              <xs:documentation>445--4--TS_Typ</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_CLASS">
                                            <xs:annotation>
                                              <xs:documentation>445--5--TS_Art</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                            <xs:annotation>
                                              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                          <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="9999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger" />
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                                <xs:annotation>
                                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="TK_MATERIAL" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--21--TS_Material</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-2]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_SHAPE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--22--TS_Form</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-2]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS">
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS_NO">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:negativeInteger">
                                                      <xs:totalDigits value="8" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                </xs:annotation>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

SERIE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element : SERIE Element
Beschreibung
In diesem Element werden die Serien definiert.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.
Namensraum (none)
Diagramm
PRODUCT_GROUPS Element Sequence SERIE Element
Overview
SERIE 1..100
In diesem Element werden die Serien definiert.
Artikel der Serie 0 sind in allen anderen Serien gültig, daraus folgt, dass Artikel der Serie 0 nicht mit gleicher Typenbezeichnung (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in anderen Serien existieren dürfen. Artikel anderer Serien (ungleich 0) dürfen hingegen in mehreren Serien mit identischer Typenbezeichnung vorkommen.
Bei der Verwendung des EK-Preises handelt es sich um den EK-Preis des Händlers und nicht um den EK-Preis des Herstellers.
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der Serie definiert. D nonNegativeInteger
P
M [0:99]
Sequence
PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel gruppiert.
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Blöcke und deren Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1) des Hauptkataloges.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1) aus dem Hauptkatalog, in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Blockpreis hinterlegt.
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE des Hauptkataloges definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen im Hauptkatalog definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID des Hauptkataloges definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RESTRICTIONS optional

In diesem Element werden blockspezifische Prüfverfahren zugeordnet.

Wenn ein Block Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Blockspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.

Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Block zugeordnetes Prüfverfahren.
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1 des Hauptkataloges) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.
 D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD des Hauptkataloges gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird. 		D boolean
P
M
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1 des Hauptkataloges) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn in den Elementen ITEM (Pfad 1) mindestens ein Element mit dem Element ITEM_IDENTFICATION = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
FULL_TEXT optional languagetexte Complex Type

Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch

PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der Serie definiert. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="SERIE" maxOccurs="100" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="ITEMS">
                    <xs:annotation>
                      <xs:documentation>400--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                <xs:annotation>
                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence minOccurs="0">
                                    <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>450/470--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PRICE_FIELD">
                                            <xs:annotation>
                                              <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="250" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE">
                                            <xs:annotation>
                                              <xs:documentation>450--5--Preis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:integer">
                                                <xs:minInclusive value="-99999999" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_TYPE_REF">
                                <xs:annotation>
                                  <xs:documentation>400/407--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="PRICE_TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>407--5--Preisart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CALC_GROUP_REF">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="CALC_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="10" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="RESTRICTIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>409--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>409--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="RESTRICTION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>409--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>409--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:maxInclusive value="99999" />
                                              <xs:minInclusive value="1" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="EDP_NUMBER" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_IDENTIFICATION">
                                <xs:annotation>
                                  <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[BEKSMZVPNOG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CATALOG_PAGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="40" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VAT_ID_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="VAT_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="RANGE_DEPENDENT">
                                <xs:annotation>
                                  <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_PARTS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BLOCK_SEQUENTIAL_NO">
                                            <xs:annotation>
                                              <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="5" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="HINGE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--6--Anschlag</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[BEJLMNR]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="EXCHANGE_CONDITION">
                                            <xs:annotation>
                                              <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="2" />
                                                <xs:maxInclusive value="3" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="STATUS">
                                            <xs:annotation>
                                              <xs:documentation>401--8--Status</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[ABELSZ]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[JLNRAE]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SHORT_TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT_LINE" maxOccurs="3">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT">
                                                        <xs:annotation>
                                                          <xs:documentation>410--6--Textzeile</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[\S ]{1,30}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger" />
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>150--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:language">
                                                    <xs:pattern value="[A-Z]{2}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TYPE_KEY">
                                <xs:annotation>
                                  <xs:documentation>445--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_TYPE">
                                      <xs:annotation>
                                        <xs:documentation>445--4--TS_Typ</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_CLASS">
                                      <xs:annotation>
                                        <xs:documentation>445--5--TS_Art</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                      <xs:annotation>
                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                    <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="9999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                          <xs:annotation>
                                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TK_MATERIAL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--21--TS_Material</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-2]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_SHAPE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--22--TS_Form</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-2]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS">
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS_NO">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:negativeInteger">
                                                <xs:totalDigits value="8" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                          </xs:annotation>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUPS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element : PRODUCT_GROUPS Element
Beschreibung
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel gruppiert.
Namensraum (none)
Diagramm
PRODUCT_GROUP Element Sequence PRODUCT_GROUPS Element
Overview
PRODUCT_GROUPS
In diesem Element werden Produktgruppen definiert. In Produktgruppen werden Artikel gruppiert.
Sequence
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Blöcke und deren Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1) des Hauptkataloges.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1) aus dem Hauptkatalog, in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Blockpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element refrenziert auf das Blockpreisfeld (BLOCK_PRICE_FIELD unterhalb von PRICE_DEFINITION im Hauptkatalog).

Die Werte von BLOCK_PRICE_FIELD können identisch mit den Werten von PRICE_FIELD sein. Sie können für die einzelnen Programme innerhalb der Katalogpreisgruppen aber auch unterschiedlich vergeben werden.

Dabei gilt folgendes:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Element für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE des Hauptkataloges definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen im Hauptkatalog definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID des Hauptkataloges definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RESTRICTIONS optional

In diesem Element werden blockspezifische Prüfverfahren zugeordnet.

Wenn ein Block Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Blockspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.

Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Block zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, ...). 		D nonNegativeInteger
P
M [1:99999]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1 des Hauptkataloges) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.
 D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD des Hauptkataloges gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird. 		D boolean
P
M
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1 des Hauptkataloges) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn in den Elementen ITEM (Pfad 1) mindestens ein Element mit dem Element ITEM_IDENTFICATION = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1 des Hauptkataloges) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1 des Hauptkataloges) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2 des Hauptkataloges) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1 des Hauptkataloges) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
FULL_TEXT optional languagetexte Complex Type

Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel" der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:negativeInteger

Hier wird die zum Artikel passende eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="PRODUCT_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="ITEMS">
              <xs:annotation>
                <xs:documentation>400--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                          <xs:annotation>
                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence minOccurs="0">
                              <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>450/470--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PRICE_FIELD">
                                      <xs:annotation>
                                        <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="250" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE">
                                      <xs:annotation>
                                        <xs:documentation>450--5--Preis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:integer">
                                          <xs:minInclusive value="-99999999" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_REF">
                          <xs:annotation>
                            <xs:documentation>400/407--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="PRICE_TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>407--5--Preisart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CALC_GROUP_REF">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="CALC_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="10" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESTRICTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>409--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>409--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="RESTRICTION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>409--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>409--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="99999" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EDP_NUMBER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_IDENTIFICATION">
                          <xs:annotation>
                            <xs:documentation>400--14--Artikelkennung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[BEKSMZVPNOG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CATALOG_PAGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="40" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VAT_ID_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="VAT_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="RANGE_DEPENDENT">
                          <xs:annotation>
                            <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_PARTS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BLOCK_SEQUENTIAL_NO">
                                      <xs:annotation>
                                        <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="5" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="HINGE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--6--Anschlag</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[BEJLMNR]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="EXCHANGE_CONDITION">
                                      <xs:annotation>
                                        <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="2" />
                                          <xs:maxInclusive value="3" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="STATUS">
                                      <xs:annotation>
                                        <xs:documentation>401--8--Status</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[ABELSZ]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[JLNRAE]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_TEXT">
                          <xs:annotation>
                            <xs:documentation>410--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SHORT_TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT_LINE" maxOccurs="3">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--6--Textzeile</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[\S ]{1,30}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger" />
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                          <xs:annotation>
                                            <xs:documentation>150--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:language">
                                              <xs:pattern value="[A-Z]{2}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TYPE_KEY">
                          <xs:annotation>
                            <xs:documentation>445--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_TYPE">
                                <xs:annotation>
                                  <xs:documentation>445--4--TS_Typ</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_CLASS">
                                <xs:annotation>
                                  <xs:documentation>445--5--TS_Art</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                <xs:annotation>
                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TK_MATERIAL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--21--TS_Material</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-2]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_SHAPE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--22--TS_Form</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-2]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CLASSIFICATIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS">
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS_NO">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:negativeInteger">
                                          <xs:totalDigits value="8" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                    </xs:annotation>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUP Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element : PRODUCT_GROUP Element
Beschreibung
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Namensraum (none)
Diagramm
ITEMS Element LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element Sequence PRODUCT_GROUP Element
Overview
PRODUCT_GROUP 1..∞
In diesem Element werden Artikel angelegt, die zu Produktgruppen zusammengefasst sind. Eine Erfassung "identischer" Produktgruppen muss unterbleiben.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Blöcke und deren Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1) des Hauptkataloges.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1) aus dem Hauptkatalog, in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Blockpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element refrenziert auf das Blockpreisfeld (BLOCK_PRICE_FIELD unterhalb von PRICE_DEFINITION im Hauptkatalog).

Die Werte von BLOCK_PRICE_FIELD können identisch mit den Werten von PRICE_FIELD sein. Sie können für die einzelnen Programme innerhalb der Katalogpreisgruppen aber auch unterschiedlich vergeben werden.

Dabei gilt folgendes:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Element für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE des Hauptkataloges definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen im Hauptkatalog definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID des Hauptkataloges definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RESTRICTIONS optional

In diesem Element werden blockspezifische Prüfverfahren zugeordnet.

Wenn ein Block Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Blockspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.

Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Block zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, ...). 		D nonNegativeInteger
P
M [1:99999]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1 des Hauptkataloges) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.
 D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD des Hauptkataloges gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird. 		D boolean
P
M
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1 des Hauptkataloges) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn in den Elementen ITEM (Pfad 1) mindestens ein Element mit dem Element ITEM_IDENTFICATION = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1 des Hauptkataloges) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1 des Hauptkataloges) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2 des Hauptkataloges) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1 des Hauptkataloges) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
FULL_TEXT optional languagetexte Complex Type

Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel" der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:negativeInteger

Hier wird die zum Artikel passende eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="PRODUCT_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="ITEMS">
        <xs:annotation>
          <xs:documentation>400--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                    <xs:annotation>
                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence minOccurs="0">
                        <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>450/470--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_FIELD">
                                <xs:annotation>
                                  <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE">
                                <xs:annotation>
                                  <xs:documentation>450--5--Preis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:integer">
                                    <xs:minInclusive value="-99999999" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_REF">
                    <xs:annotation>
                      <xs:documentation>400/407--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>407--5--Preisart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CALC_GROUP_REF">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="CALC_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="10" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESTRICTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>409--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>409--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="RESTRICTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>409--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>409--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="99999" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EDP_NUMBER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_IDENTIFICATION">
                    <xs:annotation>
                      <xs:documentation>400--14--Artikelkennung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[BEKSMZVPNOG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CATALOG_PAGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="40" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT_ID_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="VAT_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RANGE_DEPENDENT">
                    <xs:annotation>
                      <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_PARTS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BLOCK_SEQUENTIAL_NO">
                                <xs:annotation>
                                  <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_REF">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HINGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--6--Anschlag</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[BEJLMNR]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="EXCHANGE_CONDITION">
                                <xs:annotation>
                                  <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="2" />
                                    <xs:maxInclusive value="3" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="STATUS">
                                <xs:annotation>
                                  <xs:documentation>401--8--Status</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[ABELSZ]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[JLNRAE]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_TEXT">
                    <xs:annotation>
                      <xs:documentation>410--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SHORT_TEXT">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT_LINE" maxOccurs="3">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--6--Textzeile</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[\S ]{1,30}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>150--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TYPE_KEY">
                    <xs:annotation>
                      <xs:documentation>445--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_TYPE">
                          <xs:annotation>
                            <xs:documentation>445--4--TS_Typ</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_CLASS">
                          <xs:annotation>
                            <xs:documentation>445--5--TS_Art</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                          <xs:annotation>
                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                              <xs:annotation>
                                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TK_MATERIAL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--21--TS_Material</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-2]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_SHAPE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--22--TS_Form</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-2]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CLASSIFICATIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS_NO">
                                <xs:simpleType>
                                  <xs:restriction base="xs:negativeInteger">
                                    <xs:totalDigits value="8" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                              </xs:annotation>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUP_TEXT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : PRODUCT_GROUP_TEXT Element
Beschreibung
Dieses Element enthält die Bezeichung einer Produktgruppe.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element
Overview
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
Dieses Element enthält die Bezeichung einer Produktgruppe.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ITEMS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : ITEMS Element
Beschreibung
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Namensraum (none)
Diagramm
ITEM Element Sequence ITEMS Element
Overview
ITEMS
In diesem Element werden alle Artikel einer Produktgruppe definiert.
Sequence
ITEM 1..∞
In diesem Element werden Blöcke und deren Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1) des Hauptkataloges.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1) aus dem Hauptkatalog, in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Blockpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element refrenziert auf das Blockpreisfeld (BLOCK_PRICE_FIELD unterhalb von PRICE_DEFINITION im Hauptkatalog).

Die Werte von BLOCK_PRICE_FIELD können identisch mit den Werten von PRICE_FIELD sein. Sie können für die einzelnen Programme innerhalb der Katalogpreisgruppen aber auch unterschiedlich vergeben werden.

Dabei gilt folgendes:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Element für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE des Hauptkataloges definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen im Hauptkatalog definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID des Hauptkataloges definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RESTRICTIONS optional

In diesem Element werden blockspezifische Prüfverfahren zugeordnet.

Wenn ein Block Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Blockspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.

Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Block zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, ...). 		D nonNegativeInteger
P
M [1:99999]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1 des Hauptkataloges) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.
 D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD des Hauptkataloges gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird. 		D boolean
P
M
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1 des Hauptkataloges) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn in den Elementen ITEM (Pfad 1) mindestens ein Element mit dem Element ITEM_IDENTFICATION = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1 des Hauptkataloges) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1 des Hauptkataloges) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2 des Hauptkataloges) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1 des Hauptkataloges) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type

Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel" der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:negativeInteger

Hier wird die zum Artikel passende eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="ITEMS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
              <xs:annotation>
                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence minOccurs="0">
                  <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>450/470--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FIELD">
                          <xs:annotation>
                            <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE">
                          <xs:annotation>
                            <xs:documentation>450--5--Preis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="-99999999" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_TYPE_REF">
              <xs:annotation>
                <xs:documentation>400/407--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="PRICE_TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>407--5--Preisart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CALC_GROUP_REF">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="CALC_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="10" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>409--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>409--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>409--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>409--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="99999" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="EDP_NUMBER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>400--14--Artikelkennung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BEKSMZVPNOG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_PAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="40" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT_ID_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="VAT_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="RANGE_DEPENDENT">
              <xs:annotation>
                <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_PARTS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="BLOCK_SEQUENTIAL_NO">
                          <xs:annotation>
                            <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HINGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--6--Anschlag</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[BEJLMNR]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXCHANGE_CONDITION">
                          <xs:annotation>
                            <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="2" />
                              <xs:maxInclusive value="3" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="STATUS">
                          <xs:annotation>
                            <xs:documentation>401--8--Status</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[ABELSZ]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[JLNRAE]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_TEXT">
              <xs:annotation>
                <xs:documentation>410--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SHORT_TEXT">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--6--Textzeile</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>150--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="TYPE_KEY">
              <xs:annotation>
                <xs:documentation>445--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_TYPE">
                    <xs:annotation>
                      <xs:documentation>445--4--TS_Typ</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_CLASS">
                    <xs:annotation>
                      <xs:documentation>445--5--TS_Art</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                    <xs:annotation>
                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                        <xs:annotation>
                          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TK_MATERIAL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--21--TS_Material</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-2]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_SHAPE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--22--TS_Form</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-2]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CLASSIFICATIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS_NO">
                          <xs:simpleType>
                            <xs:restriction base="xs:negativeInteger">
                              <xs:totalDigits value="8" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ITEM Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element : ITEM Element
Beschreibung
In diesem Element werden Blöcke und deren Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1) des Hauptkataloges.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Namensraum (none)
Diagramm
DETAIL_INFOS Element CLASSIFICATIONS Element TYPE_KEY Element ITEM_TEXT Element BLOCK_PARTS Element RANGE_DEPENDENT Element VALID_UNTIL Element VALID_FROM Element VAT_ID_REF Element CATALOG_PAGE Element ITEM_IDENTIFICATION Element BLOCK_PRICE_STATUS Element EDP_NUMBER Element RESTRICTIONS Element EXCHANGE_ID_REF Element CALC_GROUP_REF Element PRICE_TYPE_REF Element PRICE_FEATURE_GROUP_BASE_PRICE_REF Element Sequence ITEM Element
Overview
ITEM 1..∞
In diesem Element werden Blöcke und deren Artikel definiert. Ein Artikel wird identifiziert über die Attribute SERIE_NO (Pfad 1) und TYPE_NO (Pfad 1) des Hauptkataloges.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1) aus dem Hauptkatalog, in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Blockpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element refrenziert auf das Blockpreisfeld (BLOCK_PRICE_FIELD unterhalb von PRICE_DEFINITION im Hauptkatalog).

Die Werte von BLOCK_PRICE_FIELD können identisch mit den Werten von PRICE_FIELD sein. Sie können für die einzelnen Programme innerhalb der Katalogpreisgruppen aber auch unterschiedlich vergeben werden.

Dabei gilt folgendes:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Element für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE des Hauptkataloges definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen im Hauptkatalog definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID des Hauptkataloges definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RESTRICTIONS optional

In diesem Element werden blockspezifische Prüfverfahren zugeordnet.

Wenn ein Block Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Blockspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.

Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Block zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, ...). 		D nonNegativeInteger
P
M [1:99999]
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1 des Hauptkataloges) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.
 D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD des Hauptkataloges gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird. 		D boolean
P
M
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1 des Hauptkataloges) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn in den Elementen ITEM (Pfad 1) mindestens ein Element mit dem Element ITEM_IDENTFICATION = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1 des Hauptkataloges) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1 des Hauptkataloges) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2 des Hauptkataloges) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1 des Hauptkataloges) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type

Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel" der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:negativeInteger

Hier wird die zum Artikel passende eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
Quelle
<xs:element name="ITEM" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
        <xs:annotation>
          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence minOccurs="0">
            <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>450/470--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE">
                    <xs:annotation>
                      <xs:documentation>450--5--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPE_REF">
        <xs:annotation>
          <xs:documentation>400/407--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--5--Preisart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CALC_GROUP_REF">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="CALC_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="10" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>409--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>409--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>409--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>409--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="99999" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="EDP_NUMBER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--10--EDV_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>400--14--Artikelkennung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BEKSMZVPNOG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_PAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--15--Katalog_Seite</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="40" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT_ID_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="VAT_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="RANGE_DEPENDENT">
        <xs:annotation>
          <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_PARTS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_PART" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_SEQUENTIAL_NO">
                    <xs:annotation>
                      <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HINGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--6--Anschlag</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[BEJLMNR]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXCHANGE_CONDITION">
                    <xs:annotation>
                      <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="2" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STATUS">
                    <xs:annotation>
                      <xs:documentation>401--8--Status</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[ABELSZ]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[JLNRAE]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_TEXT">
        <xs:annotation>
          <xs:documentation>410--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SHORT_TEXT">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--6--Textzeile</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>150--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="TYPE_KEY">
        <xs:annotation>
          <xs:documentation>445--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_TYPE">
              <xs:annotation>
                <xs:documentation>445--4--TS_Typ</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_CLASS">
              <xs:annotation>
                <xs:documentation>445--5--TS_Art</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
              <xs:annotation>
                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                  <xs:annotation>
                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="TK_MATERIAL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--21--TS_Material</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-2]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_SHAPE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--22--TS_Form</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-2]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CLASSIFICATIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS_NO">
                    <xs:simpleType>
                      <xs:restriction base="xs:negativeInteger">
                        <xs:totalDigits value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Beschreibung
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1) aus dem Hauptkatalog, in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
Namensraum (none)
Diagramm
ITEM_PRICE Element Sequence PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Overview
PRICE_FEATURE_GROUP_BASE_PRICE_REF
Dieses Element referenziert eine Basispreisvariantengruppe. Eine Basispreisvariantengruppe ist eine PRICE_FEATURE_GROUP (Pfad1) aus dem Hauptkatalog, in der das Element ADDITIONAL_PRICE den Wert 0 hat.

Elementpfade:
Pfad1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
In diesem Element wird der Blockpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element refrenziert auf das Blockpreisfeld (BLOCK_PRICE_FIELD unterhalb von PRICE_DEFINITION im Hauptkatalog).

Die Werte von BLOCK_PRICE_FIELD können identisch mit den Werten von PRICE_FIELD sein. Sie können für die einzelnen Programme innerhalb der Katalogpreisgruppen aber auch unterschiedlich vergeben werden.

Dabei gilt folgendes:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Element für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird eine PRICE_FEATURE_GROUP referenziert. D positiveInteger
P
M [1:99999]
Quelle
<xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence minOccurs="0">
      <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>450/470--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>450--5--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_PRICE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element : ITEM_PRICE Element
Beschreibung
In diesem Element wird der Blockpreis hinterlegt.
Namensraum (none)
Diagramm
PRICE Element PRICE_FIELD Element Sequence ITEM_PRICE Element
Overview
ITEM_PRICE 0..∞
In diesem Element wird der Blockpreis hinterlegt.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element refrenziert auf das Blockpreisfeld (BLOCK_PRICE_FIELD unterhalb von PRICE_DEFINITION im Hauptkatalog).

Die Werte von BLOCK_PRICE_FIELD können identisch mit den Werten von PRICE_FIELD sein. Sie können für die einzelnen Programme innerhalb der Katalogpreisgruppen aber auch unterschiedlich vergeben werden.

Dabei gilt folgendes:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Element für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
Quelle
<xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450/470--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>450--5--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PRICE_FIELD Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_FIELD Element
Beschreibung

Dieses Element refrenziert auf das Blockpreisfeld (BLOCK_PRICE_FIELD unterhalb von PRICE_DEFINITION im Hauptkatalog).

Die Werte von BLOCK_PRICE_FIELD können identisch mit den Werten von PRICE_FIELD sein. Sie können für die einzelnen Programme innerhalb der Katalogpreisgruppen aber auch unterschiedlich vergeben werden.

Dabei gilt folgendes:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

 D positiveInteger
P
M [1:250]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger

Dieses Element refrenziert auf das Blockpreisfeld (BLOCK_PRICE_FIELD unterhalb von PRICE_DEFINITION im Hauptkatalog).

Die Werte von BLOCK_PRICE_FIELD können identisch mit den Werten von PRICE_FIELD sein. Sie können für die einzelnen Programme innerhalb der Katalogpreisgruppen aber auch unterschiedlich vergeben werden.

Dabei gilt folgendes:

Entweder sind die Werte von BLOCK_PRICE_FIELD identisch mit den Werten von PRICE_FIELD oder innerhalb einer Serie sind die im Element BLOCK_PRICE_FIELD eingetragenen Preisfelder eindeutig.

 D positiveInteger
P
M [1:250]
Quelle
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PRICE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE Element
Beschreibung
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Element für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
Namensraum (none)
Typ
Restriction of xs:integer
Diagramm
PRICE Element
Overview
PRICE Restriction of xs:integer
In dieses Feld werden die Preise laut ihrer Preisgruppen (Preisfeld, Element PRICE_FIELD) eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (z. B. 300,00 € = 30000 Cent). In das Feld können auch negative Preise eingetragen werden. Negative Preise werden mit führendem Minuszeichen dargestellt. Die verfügbare Stellenanzahl für negative Preise ist um eine Stelle geringer als bei positiven Werten. Die erste Ziffer nach dem Minuszeichen muss ungleich 0 sein. Leerzeichen sind nicht zulässig.

(Beispiel: -9,00 € => -900)

Wird der Preis 0 eingegeben, ist der Artikel in dieser Preisgruppe kostenlos. Ist ein Artikel in einer Preisgruppe nicht lieferbar, wird in dem Element PRICE_FEATURE_GROUP_BASE_PRICE_REF des Artikels kein Element für die entsprechende Preisgruppe angelegt. 		D integer
P
M [-99999999:999999999]
Quelle
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--5--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PRICE_TYPE_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_TYPE_REF Element
Beschreibung
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE des Hauptkataloges definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
Namensraum (none)
Diagramm
PRICE_TYPE_REF Element
Overview
PRICE_TYPE_REF
Dieses Element referenziert eine Preisart. Preisarten werden mit dem Element Pfad1/PRICE_TYPE des Hauptkataloges definiert.

Elementpfade:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
PRICE_TYPE_NO Restriction of xs:positiveInteger required
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [1:999]
Quelle
<xs:element name="PRICE_TYPE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400/407--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--5--Preisart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CALC_GROUP_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CALC_GROUP_REF Element
Beschreibung
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen im Hauptkatalog definiert.
Namensraum (none)
Diagramm
CALC_GROUP_REF Element
Overview
CALC_GROUP_REF
Dieses Element referenziert Kalkulationsgruppen. Die Kalkulationsgruppen sind innerhalb der Warengruppen im Hauptkatalog definiert.
CALC_GROUP_NO required Restriction of xs:positiveInteger
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
CALC_GROUP_NO Restriction of xs:positiveInteger required
Über dieses Attribut wird eine Preisart identifiziert. D positiveInteger
P
M [10:99]
Quelle
<xs:element name="CALC_GROUP_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="CALC_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="10" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EXCHANGE_ID_REF Element
Beschreibung
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID des Hauptkataloges definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
Namensraum (none)
Diagramm
EXCHANGE_ID_REF Element
Overview
EXCHANGE_ID_REF optional
Dieses Element referenziert eine Tausch-ID, die in dem Element Pfad1/EXCHANGE_ID des Hauptkataloges definiert ist.

Elementpfade:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
Das Attribut identifiziert eine Tausch-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Quelle
<xs:element name="EXCHANGE_ID_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : RESTRICTIONS Element
Beschreibung

In diesem Element werden blockspezifische Prüfverfahren zugeordnet.

Wenn ein Block Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Blockspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.

Namensraum (none)
Diagramm
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional

In diesem Element werden blockspezifische Prüfverfahren zugeordnet.

Wenn ein Block Prüfverfahren referenziert, die Variantenarten der Ausführungsgruppe des Artikels enthalten, dürfen diese Prüfverfahren die Varianten nur einschränken.

Prüfverfahren, die einem Programmausschluss dienen, dürfen nur referenziert werden, wenn der Artikel Programm-abhängig ist.

Blockspezifische Prüfverfahren haben Vorrang gegenüber Prüfverfahren, die von Serien oder Programmen referenziert werden.

Von einem Artikel dürfen keine inhaltlich identischen Prüfverfahren referenziert werden. Ein Prüfverfahren ist unter folgender Bedingung identisch (Prüfverfahren 1 = P1, Prüfverfahren 2 = P2):
P1-Variante1 = P2-Variante1 und P1-Variante2 = P2-Variante2
oder
P1-Variante1 = P2-Variante2 und P1-Variante2 = P2-Variante1

Die Menge der im Planungssystem ausgewählten Varianten ist nur dann gültig, wenn es kein Prüfverfahren gibt, was eine Kombination dieser Varianten ausschließt.

Sequence
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Block zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, ...). 		D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>409--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>409--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>409--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>409--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99999" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > RESTRICTIONS Element : RESTRICTION_REF Element
Beschreibung
Dieses Element referenziert ein, dem Block zugeordnetes Prüfverfahren.
Namensraum (none)
Diagramm
RESTRICTION_REF Element
Overview
RESTRICTION_REF 1..∞
Dieses Element referenziert ein, dem Block zugeordnetes Prüfverfahren.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, ...). 		D nonNegativeInteger
P
M [1:99999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
Durch dieses Attribut werden Artikel-spezifische Prüfverfahren referenziert. D nonNegativeInteger
P
M [0:99999]
SEQUENCE Restriction of xs:nonNegativeInteger required
Mit diesem Element wird festgelegt, in welcher Reihenfolge die zugeordneten Prüfverfahren ausgeführt werden. Mehrere Prüfungen können gruppiert werden, d. h. es wird die Vereinigungsmenge über diese Prüfungen gebildet, wenn sie den selben Wert im Element Reihenfolge erhalten. Über Prüfungen, die unterschiedliche Reihenfolge haben, wird die Schnittmenge gebildet.
Innerhalb einer gleicher Reihenfolge dürfen nur erlaubende Prüfverfahren angegeben sein.
Innerhalb einer Reihenfolge müssen die Variantenarten der Prüfverfahren gleich sein.
Die Reihenfolge ist aufsteigend anzulegen, die Reihenfolge darf aber Lücken haben (z. B. 1,3,10, ...). 		D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="RESTRICTION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>409--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>409--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>409--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99999" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
RESTRICTIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

EDP_NUMBER Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EDP_NUMBER Element
Beschreibung
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
EDP_NUMBER Element
Overview
EDP_NUMBER optional Restriction of xs:string
In dieses Element wird die (interne) Artikel-EDV-Nummer des Herstellers eingetragen.
Wenn die EDP_NUMBER verwendet wird, muss diese innerhalb einer Serie eindeutig sein und für alle Artikel angelegt werden. 		D string
P
M [1:15]
Quelle
<xs:element name="EDP_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--10--EDV_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_PRICE_STATUS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BLOCK_PRICE_STATUS Element
Beschreibung
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_PRICE_STATUS Element
Overview
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
Wenn es sich bei dem Artikel um einen Block (ITEM_IDENTIFICATION = B) handelt, wird in diesem Element definiert, wie der Preis des Blockes bei Tausch zu behandeln ist. Dann ist dieses Element nicht optional.
1 = Additiver Blockpreis;
der Blockpreis entspricht der Addition der Typenpreise auf Basis normaler EK/VK-Preise.
2 = Fixer Blockpreis;
Tausch und Preisänderungen sind nicht möglich.
3 = Keine Preisreduzierung erlaubt;
beim Austausch von Typen werden keine Minderpreise zugelassen.
4 = Preisreduzierung bis Blockpreis;
beim Austausch von Typen werden Minderpreise bis zum Erreichen des Blockpreises zugelassen.
5 = Preisreduzierung unter Blockpreis;
beim Austausch von Typen werden Minderpreise bis unter den Blockpreis zugelassen.
6 = Mehrpreis;
dieser Status darf nur bei Mehrausstattungen verwendet werden. Bei den Preisen handelt es sich um Mehrpreise gegenüber den Standard-Blocktypen.
7 = Minderpreis
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
8 = Minderpreis trotz anders lautender Blockpreis-Vorgabe;
dieser Status darf nur bei Minderausstattungen verwendet werden. Bei den Preisen handelt es sich um Minderpreise gegenüber den Standard-Blocktypen.
9 = Preisreduzierung bis zum Wert der Tauschgruppe; beim Austausch von Typen werden Minderpreise bis zum Erreichen des Wertes der Tauschgruppe zugelassen.
Status 1-5 und 9 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "B"
Status 6-8 nur zulässig mit Artikelkennung (ITEM_IDENTIFICATION) "M" 		D nonNegativeInteger
P
M [1:9]
Quelle
<xs:element name="BLOCK_PRICE_STATUS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_IDENTIFICATION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_IDENTIFICATION Element
Beschreibung
In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral. 		D string
P [BEKSMZVPNOG]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
ITEM_IDENTIFICATION Element
Overview
ITEM_IDENTIFICATION Restriction of xs:string
In diesem Element wird dem Artikel eine Kennung zugewiesen:
B = Block
E = Ersatzteil
K = Katalogartikel
S = Sonderartikel
M = Mehrausstattungen
Z = Zusammenstellung
O = Gruppierung ohne Preis, Preis errechnet sich aus Einzelpreisen der Artikel
N = Nicht einzeln planbar, Artikel darf nur Bestandteil einer Gruppierung sein
V = Verrechnungsblock
P = Verrechnungsposition
G = Gruppierung mit Preis.
Die Werte V und P werden nur für die Werteverrechnung in verwendet.
Die Werte von TYPE_CREDIT (Gutschrifttype) und TYPE_DEBIT (Belastungstype) sind in einer Wertestaffel nicht preisgruppenabhängig. Die TYPE_CREDITX und TYPE_DEBIT sind programmneutral. 		D string
P [BEKSMZVPNOG]
M [1:1]
Quelle
<xs:element name="ITEM_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--14--Artikelkennung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BEKSMZVPNOG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_PAGE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CATALOG_PAGE Element
Beschreibung
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CATALOG_PAGE Element
Overview
CATALOG_PAGE optional Restriction of xs:string
In diesem Element sollte die äquivalente Katalogseite des Artikels angegeben werden. Diese Angabe dient dem schnelleren Auffinden eines Artikels innerhalb des gedruckten Katalogs.
Katalogseiten kommen pro Artikel öfter vor. In diesem Fall wird die erste Seitennummer auf der der Artikel/ die Type auftaucht verwendet. Bei Zubehör ist es sinnvoll die Seite zu verwenden auf der der Artikel vollständig beschrieben wird. Dieses geschieht häufig im Abschnitt/Register "Zubehör". 		D string
P
M [1:40]
Quelle
<xs:element name="CATALOG_PAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--15--Katalog_Seite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="40" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

VAT_ID_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VAT_ID_REF Element
Beschreibung
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1 des Hauptkataloges) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
Namensraum (none)
Diagramm
VAT_ID_REF Element
Overview
VAT_ID_REF optional
Dieses Element referenziert Mehrwertsteuersätze.

Die Mehrwertsteuersätze sind im Element VALUE_ADDED_TAX (Pfad 1 des Hauptkataloges) angelegt. Bei Artikel ohne Mehrwertsteuer wird hier der Wert 0 eingetragen.
Wird der Wert 0 (Artikel ohne Mehrwertsteuer) verwendet muss dieser im Element VALUE_ADDED_TAX (Pfad 1) angelegt sein.

Elementpfade
Pfad 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
Dieses Element referenziert Mehrwertsteuersätze.
 D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
VAT_NO Restriction of xs:nonNegativeInteger required
Dieses Element referenziert Mehrwertsteuersätze.
 D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="VAT_ID_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="VAT_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_FROM Element
Beschreibung
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
Dieses Element gibt das Datum an, ab dem der Artikel lieferbar ist.
Wird dieses Element nicht gefüllt, so gilt das Element CATALOG/VALID_FROM_DATE.
Die Elemente mit der Bezeichnung VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. 		D date
P
M
Quelle
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_UNTIL Element
Beschreibung
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
Dieses Element gibt das Datum an, bis zu welchem der Artikel lieferbar ist. Ist dieses DatumsElement nicht gefüllt, gibt es keine Beschränkung bezüglich der Dauer der Lieferbarkeit.
Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer bleiben. 		D date
P
M
Quelle
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

RANGE_DEPENDENT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : RANGE_DEPENDENT Element
Beschreibung
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD des Hauptkataloges gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird. 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
RANGE_DEPENDENT Element
Overview
RANGE_DEPENDENT Restriction of xs:boolean
Die Programmabhängigkeit muss hinsichtlich der Preisbildung und der grafischen Darstellung unterschieden werden.

0 = programmunabhängig
1 = programmabhängig

Das Element regelt die Grafik und Variantensteuerung.
Wenn das Element den Wert 0 hat, d. h. der Artikel ist als programmunabhängig definiert, darf für diesen Artikel keine programmabhängige Prüfung hinterlegt sein. Preisliche Abhängigkeit wird über PRICE_CALC_METHOD des Hauptkataloges gesteuert, die Variantenabhängigkeit wird über dieses Element geregelt. Das Element PRICE_CALC_METHOD definiert, das der Preis eines Artikel programmabhängig bestimmt wird. 		D boolean
P
M
Quelle
<xs:element name="RANGE_DEPENDENT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_PARTS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BLOCK_PARTS Element
Beschreibung
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Namensraum (none)
Diagramm
BLOCK_PART Element Sequence BLOCK_PARTS Element
Overview
BLOCK_PARTS optional
Dies ist das Container-Element für die Blockstücklisten im Katalog.
Sequence
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1 des Hauptkataloges) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn in den Elementen ITEM (Pfad 1) mindestens ein Element mit dem Element ITEM_IDENTFICATION = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1 des Hauptkataloges) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1 des Hauptkataloges) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2 des Hauptkataloges) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1 des Hauptkataloges) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Quelle
<xs:element name="BLOCK_PARTS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_PART" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_SEQUENTIAL_NO">
              <xs:annotation>
                <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="HINGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--6--Anschlag</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[BEJLMNR]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXCHANGE_CONDITION">
              <xs:annotation>
                <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="2" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STATUS">
              <xs:annotation>
                <xs:documentation>401--8--Status</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[ABELSZ]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONSTRUCTION_ID" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[JLNRAE]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_PART Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element : BLOCK_PART Element
Beschreibung

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1 des Hauptkataloges) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn in den Elementen ITEM (Pfad 1) mindestens ein Element mit dem Element ITEM_IDENTFICATION = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Namensraum (none)
Diagramm
CONSTRUCTION_ID Element BLOCK_ITEM_DIMENSION_DEPTH Element BLOCK_ITEM_DIMENSION_HEIGHT Element BLOCK_ITEM_DIMENSION_WIDTH Element STATUS Element EXCHANGE_CONDITION Element HINGE Element OPTION_REF Element ITEM_REF Element BLOCK_SEQUENTIAL_NO Element Sequence BLOCK_PART Element
Overview
BLOCK_PART 1..∞

In diesem Element werden die einzelnen Artikel (Blockpositionen) eines Blockes bzw. einer Mehrausstattung zusammengestellt. Es können programmneutrale, programmabhängige sowie ausführungsabhängige Artikel referenziert werden.

Für Artikel, die ausführungsabhängig sind, gilt folgendes:
Die Ausführungsgruppe der Blockposition ist über die Artikeldefinition im Element /ITEM (Pfad 1 des Hauptkataloges) bekannt. Die Ausführungsgruppe der Blockpositionen kann in den Blockdaten gegenüber den Katalogdaten nicht geändert werden. Daher können in den Elementen FEATURE_NO und OPTION_KEY nur die Variantenkombinationen der Ausführungsgruppe der Blockposition verwendet werden.

In Abhängigkeit der Preisberechnungsmethode (Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges)), die eine Blockposition über ihre Zuordnung im Element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 1) hat, ergeben sich für die Attirbute von, OPTION_REF folgende Regeln:

- Methode = 1: Das Element OPTION_REF darf nicht angelegt werden.
- Methode = 2: das Attribut FEATURE_NO muss den Wert 1 für Programm enthalten.
- Methode = 3 das Attribut FEATURE_NO darf nicht Wert 1 für Programm enthalten.

Alle Artikel, die in einer Blockdatei referenziert werden, müssen in der Katalogdatei enthalten sein (Hinweis: wenn diese Bedingung nicht erfüllt ist, wird die Software den zugehörigen Block nicht verarbeiten.)

Artikel der Serie 0 dürfen nicht mit gleicher Typenbezeichnung in anderen Serien existieren, Artikel anderer Serien (ungleich 0) dürfen hingegen gemischt werden. Die Blockposition gehört entweder der gleichen Serie an aus der der Block stammt oder der Serie 0.
Auf die Positionen in einer Blockstückliste dürfen Prüfverfahren nicht angewendet werden. Der Preis einer Blockposition wird immer gezogen, unabhängig von Einschränkungen wie beispielsweise Lieferzeiten etc..
Dieses Element muss angelegt werden, wenn in den Elementen ITEM (Pfad 1) mindestens ein Element mit dem Element ITEM_IDENTFICATION = B oder M oder Z angelegt wurde.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1 des Hauptkataloges) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1 des Hauptkataloges) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2 des Hauptkataloges) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1 des Hauptkataloges) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Quelle
<xs:element name="BLOCK_PART" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_SEQUENTIAL_NO">
        <xs:annotation>
          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="HINGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--6--Anschlag</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[BEJLMNR]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXCHANGE_CONDITION">
        <xs:annotation>
          <xs:documentation>401--7--Tauschbedingung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="2" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STATUS">
        <xs:annotation>
          <xs:documentation>401--8--Status</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[ABELSZ]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--13--Bauweise_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[JLNRAE]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_SEQUENTIAL_NO Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_SEQUENTIAL_NO Element
Beschreibung
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_SEQUENTIAL_NO Element
Overview
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
In diesem Element wird die Position des Artikels in der Blockaufstellung angegeben. D nonNegativeInteger
P
M [1:999]
Quelle
<xs:element name="BLOCK_SEQUENTIAL_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : ITEM_REF Element
Beschreibung

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1 des Hauptkataloges) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF

In diesem Element werden die Artikel referenziert, die in dem Block bzw. der Mehrausstattung enthalten sind.

In diesem Element dürfen keine Artikel referenziert werden, die im Element PRICE_CALC_METHOD (Pfad 2 des Hauptkataloges) den Wert 0 (Preis auf Anfrage). haben. Weiterhin dürfen nur Artikel referenziert werden, deren Wert im Element ITEM_IDENTIFICATION (Pfad 1 des Hauptkataloges) die Werte E, K oder S aufweisen.

Bei serienneutrale Artikeln werden über die Serie "0" referenziert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Pfad 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : OPTION_REF Element
Beschreibung

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1 des Hauptkataloges) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2 des Hauptkataloges) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF 0..∞

Dieses Element kann zur Zuordnung von Mehrpreisen an einzelnen Artikeln genutzt werden.

In diesem Element werden in Kombination mit dem Element FEATURE_NO Variantenkombinationen referenziert, die im Element PRICE_FEATURE_GROUP (Pfad 1 des Hauptkataloges) angelegt sind.

Die referenzierten Variantenkombinationen müssen mit denen der Ausführungsgruppe übereinstimmen, welche die Blockposition über ihre Definition im Element PRICE_FEATURE_GROUP_BASE_PRICE_REF (Pfad 2 des Hauptkataloges) zugewiesen bekommen hat.

Ist der Artikel ausführungsabhängig, so muss dieses Element gefüllt werden.

Pfad 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Weicht das Programm der Blockposition vom Programm des Blocks ab, so ist hier der Programmschlüssel als Variante einzutragen. Das Programm muss in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION definiert sein, die genutzten Varianten müssen unter T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS definiert sein.

FEATURE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Variantenart einer referenzierten Variante angegeben.
Eine FEATURE_NO darf nur ein Mal vorkommen. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variante referenziert. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

HINGE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : HINGE Element
Beschreibung
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1 des Hauptkataloges) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
HINGE Element
Overview
HINGE optional Restriction of xs:string
In diesem Element wird definiert, welchen Anschlag der Artikel in dieser Blockstückliste hat.
In diesem Element wird ein Anschlag nur angegeben, wenn dieser gegenüber der Angabe im Element HINGE (Pfad 1 des Hauptkataloges) in der Artikeldefinition abweicht.

Andernfalls gilt für alle dem Block/Mehrausstattung zugeordneten Artikel der Anschlag des Block/Mehrausstattung.
Um den Anschlag zu definieren sind folgende Codes möglich:
J = Anschlag erfragen;
L = Anschlag links;
M = Anschlag Mitte (Doppeltür);
N = ohne Anschlag bzw. Anschlag beidseitig ausen (Doppeltür);
R = Anschlag rechts;
B = entsprechend Bauweise: Bauweise links Anschlag links;
E = entgegen Bauweise: Bauweise links Anschlag rechts;

Bei Doppeltüren gilt L und R für beide Türen.
Die Werte B und E sind nur möglich, wenn im Element CONSTRUCTION_ID (Pfad 1) für diese Blockposition der Wert J enthalten ist.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
Quelle
<xs:element name="HINGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--6--Anschlag</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[BEJLMNR]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_CONDITION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : EXCHANGE_CONDITION Element
Beschreibung

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
EXCHANGE_CONDITION Element
Overview
EXCHANGE_CONDITION Restriction of xs:positiveInteger

In diesem Element wird die Tauschbedingung näher erläutert.

2 = kein Tausch möglich
3 = Tausch laut Regelwerk möglich.

 D positiveInteger
P
M [2:3]
Quelle
<xs:element name="EXCHANGE_CONDITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--7--Tauschbedingung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="2" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

STATUS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : STATUS Element
Beschreibung
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
STATUS Element
Overview
STATUS Restriction of xs:string
In diesem Element sind folgende Werte möglich:

A = Diese Type entfällt (Austausch);
B = Blocktype;
E = Diese Type ist der Ersatz für die vorstehend ausgetauschte Type;
L = Diese Type wurde ersatzlos storniert;
S = Settype;
Z = Zusatztype.

Bei einer Mehrausstattung ist die Reihenfolge "Austausch", "Ersatz", "Austausch", "Ersatz" genau einzuhalten.
Wird in diesem Element ein S = Settype verwendet, so muss der entsprechende Artikel als Mehrausstattung deklariert sein (Artikelkennung = M). Für jeden Artikel in dem Block muss dieses Element dann mit einem S gefüllt sein.
In Abhängigkeit der Artikelkennung, die eine Blockposition über ihre Definition im Element ITEM (Pfad 1) hat, ergeben sich für den Status folgende Wertebereiche:
- Artikelkennung = B, dann Status = B
- Artikelkennung = M, dann Status = A, E, L, Z oder nur S (alle Artikel in der Mehrausstattung müssen den Status S haben)
- Artikelkennung = Z, dann Status = B, S

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
Quelle
<xs:element name="STATUS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--8--Status</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[ABELSZ]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_WIDTH Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_WIDTH Element
Beschreibung
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_ITEM_DIMENSION_WIDTH Element
Overview
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_HEIGHT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_HEIGHT Element
Beschreibung
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_ITEM_DIMENSION_HEIGHT Element
Overview
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_DEPTH Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_DEPTH Element
Beschreibung
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
BLOCK_ITEM_DIMENSION_DEPTH Element
Overview
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
In diesem Element wird das konkrete Maße eines maßvariablen Artikels in der Blockstückliste angegeben. Wenn Maße angegeben werden, müssen immer Breite, Höhe und Tiefe definiert werden. D nonNegativeInteger
P
M [1:99999]
Quelle
<xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CONSTRUCTION_ID Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : CONSTRUCTION_ID Element
Beschreibung
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
CONSTRUCTION_ID Element
Overview
CONSTRUCTION_ID optional Restriction of xs:string
Dieses Element ist ein Kennzeichen für die auf die Korpus-Grundform (Teil 2) bezogene, Bauweise eines Artikels.
J = Bauweise muss abgefragt werden, da der Artikel nicht symmetrisch ist.
L = Bauweise des Artikels ist fest vorgegeben (linke Bauweise).
R = Bauweise des Artikels ist fest vorgegeben, jedoch gegenüber der Grundform gespiegelt.
N = Grundform ist eindeutig, da der Artikel symmetrisch ist.
A = entsprechend Anschlag: (z. B. Anschlag links ? Bauweise links)
E = entgegen Anschlag: (z. B. Anschlag links ? Bauweise rechts)
Für die Artikelkennung B (Block) gilt die Anordnung der Artikel im Block entsprechend der CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Quelle
<xs:element name="CONSTRUCTION_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--13--Bauweise_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[JLNRAE]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_TEXT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_TEXT Element
Beschreibung
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence PLANNING_ADVICE Element LANGUAGE Element Sequence FULL_TEXT Element SHORT_TEXT Element Sequence ITEM_TEXT Element
Overview
ITEM_TEXT
In diesem Element werden die artikelspezifischen Texte definiert. Dies können Kurz- sowie Volltexte sein. Für jeden Artikel muss mindestens ein Artikeltext angelegt werden.

Folgende Textkombinationen sind erlaubt:
- Kurztext;

- Kurztext + Volltext

Der Kurztext darf aus drei Zeilen bestehen.
Sequence
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type

Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="ITEM_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SHORT_TEXT">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>410--6--Textzeile</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>150--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

SHORT_TEXT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : SHORT_TEXT Element
Beschreibung
Dieses Element enthält Kurztexte.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence SHORT_TEXT Element
Overview
SHORT_TEXT
Dieses Element enthält Kurztexte.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="SHORT_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>410--6--Textzeile</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element : LANGUAGE Element
Beschreibung
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
Namensraum (none)
Diagramm
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
ISO_LANGUAGE_ID Restriction of xs:language required
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Quelle
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>410--6--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element : TEXT_LINE Element
Beschreibung
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
Namensraum (none)
Diagramm
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..3
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE_NO Restriction of xs:positiveInteger required
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Quelle
<xs:element name="TEXT_LINE" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>410--6--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Beschreibung
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TEXT Element
Overview
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Quelle
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--6--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TEXT_LINE Element | LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

FULL_TEXT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : FULL_TEXT Element
Beschreibung

Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch

Namensraum (none)
Typ
languagetexte Complex Type
Diagramm
LANGUAGE Element Sequence FULL_TEXT Element
Overview
FULL_TEXT optional languagetexte Complex Type

Volltext enthält die komplette Beschreibung inklusive Kurztext. Innerhalb des Volltextes kann mit den HTML Formatierungen bold und Zeilenumbruch gearbeitet werden

Dieses Element enthält den Volltext in einem Knoten.
Die Formatierung des Textes ist HTML konform anzugeben:

<b> | Fettdruck
<br> | Zeilenumbruch

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Quelle
<xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PLANNING_ADVICE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : PLANNING_ADVICE Element
Beschreibung
Dieses Element enthält Planungshinweise.
Namensraum (none)
Typ
languagetexte60999 Complex Type
Diagramm
LANGUAGE Element Sequence PLANNING_ADVICE Element
Overview
PLANNING_ADVICE optional languagetexte60999 Complex Type
Dieses Element enthält Planungshinweise.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TYPE_KEY Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : TYPE_KEY Element
Beschreibung
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Namensraum (none)
Diagramm
TK_FRONT_APPEARANCE Element TK_SHAPE Element TK_MATERIAL Element TK_EQUIPMENT Element TK_CLASS Element TK_TYPE Element Sequence TYPE_KEY Element
Overview
TYPE_KEY
In diesem Element wird der Typschlüssel eines Artikels definiert.

Die Informationen Einbauinfo (TK_INSTALLATION_INFORMATION), Nischenhöhe (TK_RECESS_HEIGHT) und Ausstattung (TK_EQUIPMENT) des Typschlüssel können mehrfach belegt werden.

Bei Mehrfachbelegungen gilt, dass die Belegungen von unten nach oben aufgebaut wird, beginnend entsprechend der Reihenfolge der Elemente (TK_INSTALLATION_INFORMATION).

Die Elemente für Nischehöhe sollten nur angelegt werden, wenn das korrespondierende Element für die Einbauinfo existiert.

Zwischen den Elementen

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

besteht eine inhaltliche Abhängigkeit.

Der Typschlüssel wird genau einmal pro Artikel angelegt.
Sequence
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel" der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Quelle
<xs:element name="TYPE_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_TYPE">
        <xs:annotation>
          <xs:documentation>445--4--TS_Typ</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_CLASS">
        <xs:annotation>
          <xs:documentation>445--5--TS_Art</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
        <xs:annotation>
          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
            <xs:annotation>
              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="TK_MATERIAL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--21--TS_Material</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-2]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_SHAPE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--22--TS_Form</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-2]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TK_TYPE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_TYPE Element
Beschreibung
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
TK_TYPE Element
Overview
TK_TYPE Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ-Nr der Tabelle "Typschlüssel" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
Quelle
<xs:element name="TK_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--4--TS_Typ</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TK_CLASS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_CLASS Element
Beschreibung
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
TK_CLASS Element
Overview
TK_CLASS Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Art-Nr der Tabelle "Typschlüssel-Arten" der Einleitung eingetragen. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
Quelle
<xs:element name="TK_CLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--5--TS_Art</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TK_EQUIPMENT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_EQUIPMENT Element
Beschreibung

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

Namensraum (none)
Diagramm
TK_INSTALLATION_RECESS Element Sequence TK_EQUIPMENT Element
Overview
TK_EQUIPMENT 0..5

Es dient der Zuordnung eines Austattungsschlüssels zur Einbau-Information und Nischenhöhe.

SEQUENCE_NO required Restriction of xs:positiveInteger
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel" der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
SEQUENCE_NO Restriction of xs:positiveInteger required
Mit diesem Attribut wird die Reihenfolge definiert, in der die Einbauelemente/Ausstattung zugeordnet werden. D positiveInteger
P
M
TK_EQUIPMENT_NO Restriction of xs:nonNegativeInteger optional

Das Element sollte nur gefüllt werden, wenn das Element TK_INSTALLATION_INFORMATION gefüllt ist.

Hier wird ein Wert aus der Spalte AusstattungID der Tabelle "Asstattungsschlüssel" der Einleitung eingetragen.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Quelle
<xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
      <xs:annotation>
        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TK_INSTALLATION_RECESS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element : TK_INSTALLATION_RECESS Element
Beschreibung
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Namensraum (none)
Diagramm
TK_RECESS_HEIGHT Element TK_INSTALLATION_INFORMATION Element Sequence TK_INSTALLATION_RECESS Element
Overview
TK_INSTALLATION_RECESS optional
In diesem Element wird die Kombination aus Einbauinformation (siehe Tabelle EinbauInfo-Schlüssel) und Nischenhöhe hinterlegt.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="TK_INSTALLATION_RECESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
          <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TK_INSTALLATION_INFORMATION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element > TK_INSTALLATION_RECESS Element : TK_INSTALLATION_INFORMATION Element
Beschreibung
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
TK_INSTALLATION_INFORMATION Element
Overview
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert aus der Spalte Einbauinfo der Tabelle "EinbauInfo-Schlüssel" eingetragen. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
Quelle
<xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TK_INSTALLATION_RECESS Element | TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TK_RECESS_HEIGHT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element > TK_INSTALLATION_RECESS Element : TK_RECESS_HEIGHT Element
Beschreibung
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
TK_RECESS_HEIGHT Element
Overview
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
Hier wird ein Wert für die Nischenhöhe in mm angegeben. D nonNegativeInteger
P
M [0:9999]
Quelle
<xs:element name="TK_RECESS_HEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
    <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TK_INSTALLATION_RECESS Element | TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TK_MATERIAL Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_MATERIAL Element
Beschreibung
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
TK_MATERIAL Element
Overview
TK_MATERIAL optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Typ der Tabelle "Materialschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Quelle
<xs:element name="TK_MATERIAL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--21--TS_Material</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-2]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TK_SHAPE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_SHAPE Element
Beschreibung
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
TK_SHAPE Element
Overview
TK_SHAPE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Form-Nr der Tabelle "Formschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Quelle
<xs:element name="TK_SHAPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--22--TS_Form</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-2]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TK_FRONT_APPEARANCE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_FRONT_APPEARANCE Element
Beschreibung
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Namensraum (none)
Typ
Restriction of xs:positiveInteger
Diagramm
TK_FRONT_APPEARANCE Element
Overview
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
Hier wird ein Wert aus der Spalte Frontausprägung-Nr. der Tabelle "Frontausprägungsschlüssel" eingetragen. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Quelle
<xs:element name="TK_FRONT_APPEARANCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CLASSIFICATIONS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CLASSIFICATIONS Element
Beschreibung
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Namensraum (none)
Diagramm
ECLASS Element Sequence CLASSIFICATIONS Element
Overview
CLASSIFICATIONS optional
In diesem Element werden standardisierte Klassifikationsnummern hinterlegt.
Sequence
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:negativeInteger

Hier wird die zum Artikel passende eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Quelle
<xs:element name="CLASSIFICATIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS_NO">
              <xs:simpleType>
                <xs:restriction base="xs:negativeInteger">
                  <xs:totalDigits value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ECLASS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element : ECLASS Element
Beschreibung
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Namensraum (none)
Diagramm
ECLASS_NO Element Sequence ECLASS Element
Overview
ECLASS
Dieses Element dient der Angabe zur eCl@ss-Klassifizierung
Sequence
ECLASS_NO Restriction of xs:negativeInteger

Hier wird die zum Artikel passende eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Quelle
<xs:element name="ECLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS_NO">
        <xs:simpleType>
          <xs:restriction base="xs:negativeInteger">
            <xs:totalDigits value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ECLASS_NO Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element > ECLASS Element : ECLASS_NO Element
Beschreibung

Hier wird die zum Artikel passende eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Namensraum (none)
Typ
Restriction of xs:negativeInteger
Diagramm
ECLASS_NO Element
Overview
ECLASS_NO Restriction of xs:negativeInteger

Hier wird die zum Artikel passende eCl@ss-Nummer, die der 3. bzw. 4. Stufe der Klassifizierung über eCl@ss entspricht, zugeordnet.

Dabei beginnt die Nummer für Küchenmöbel i. A. mit den Ziffern 5003, für Geräte dagegen mit 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Quelle
<xs:element name="ECLASS_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:negativeInteger">
      <xs:totalDigits value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
ECLASS Element | CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : DETAIL_INFOS Element
Beschreibung
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
In diesem Element werden die dem Artikel zugeordneten Hyperlinks zu Detailinformationen zusammengefasst.
Sequence
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Beschreibung
Dieses Element referenziert Hyperlinks zu Detailinformationen.
Namensraum (none)
Diagramm
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
Dieses Element referenziert Hyperlinks zu Detailinformationen.
DETAIL_INFO_NO required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DETAIL_INFO_NO required
In diesem Attribut wird die Identifikationsnummer der referenzierten Detailinformation angegeben. D positiveInteger
P
M [1:999999999]
Quelle
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
DETAIL_INFOS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

FEATURE_DEFINITION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element : FEATURE_DEFINITION Element
Beschreibung
In diesem Element werden variantenabhängige Informationen(Prüfungen) hinterlegt.
Namensraum (none)
Diagramm
RESTRICTIONS Element Sequence FEATURE_DEFINITION Element
Overview
FEATURE_DEFINITION optional
In diesem Element werden variantenabhängige Informationen(Prüfungen) hinterlegt.
Sequence
RESTRICTIONS
In diesem Element werden die Prüfverfahren angelegt.
Sequence
RESTRICTION 1..99999
In diesem Element wird ein Prüfverfahren definiert und beschrieben. Die Prüfverfahren definieren Regeln, die technisch machbare Konfigurationen abbilden. Es werden keine Planungsvorschläge hinterlegt, andernfalls würden nicht notwendige Prüfungen aufgebaut, die den Planer in seinen Möglichkeiten ungerechtfertigt einschränken.

Eine Zuordnung der Prüfverfahren zu Serien, Programmen oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien, Programmen oder Artikeln referenziert werden.

Prüfverfahren, die aus Serien oder Programmen referenziert werden, dürfen nicht von Artikeln referenziert werden. Prüfverfahren, die von Artikeln referenziert werden, haben Vorrang gegenüber den Prüfungen, die von Serien oder Programmen referenziert werden.

Das Elemente OPTION_REF kann unterschiedlich angelegt werden. Entsprechend den Füllmöglichkeiten der Elemente FEATURE_1_NO, FEATURE_2_NO und FEATURE_3_NO kann ein Prüfverfahren 0-stufig, 1-stufig oder 2-stufig oder 3-stufig definiert werden.

Resultierende Variantenmenge bei nicht angelegten Varianten:

Ist ein Prüfverfahren ein "erlaubendes" Prüfverfahren (TEST_ID = 1), so sind alle in dem Prüfverfahren nicht aufgeführten Varianten der im Prüfverfahren genannten Variantenarten nicht erlaubt. Handelt es sich um ein "nicht erlaubendes" Prüfverfahren (TEST_ID = 0), so sind diese Varianten erlaubt. Werden in einem Prüfverfahren Variantenarten kombiniert, so gilt diese Regel für die Kombination der resultierenden Varianten.

Resultierende Variantenmenge bei Programm-spezifischen Prüfverfahren:

Wird ein Prüfverfahren nicht von allen Programmen referenziert, gilt für die Programme, die das Prüfverfahren nicht referenzieren folgendes:

Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen ungültig, die in diesem Prüfverfahren nicht angelegt wurden.
Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen nicht erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen gültig, die in diesem Prüfverfahren nicht angelegt wurden.

Zyklische Prüfungen
Zyklische Prüfungen sind nicht erlaubt, diese können beispielsweise durch nachfolgende Konstellation hervorgerufen werden:
Nicht erlaubt!
1. Prüfung: Variante1 mit Variante2
2. Prüfung: Variante2 mit Variante3
3. Prüfung: Variante3 mit Variante1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Prüfverfahren eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE required Restriction of xs:int
Im Attribut VALIDATION_TYPE erfolgt die Definition, ob es sich bei dem Prüfverfahren um eine Farblängen-Prüfung, oder eine Variantenprüfung handelt. Wenn es sich um eine Farblängen-Prüfung handelt muss zu jeder Prüfung unter OPTION_COMBINATION eine MIN/MAX_DIMENSION gefällt werden.
0 = Varianten-Prüfung (ehemals Satzart 270)
1 = Farblängen-Prüfung (ehemals Satzart 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt 		D boolean
P
M
Quelle
<xs:element name="FEATURE_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTIONS">
        <xs:annotation>
          <xs:documentation>270/271--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION" maxOccurs="99999">
              <xs:annotation>
                <xs:documentation>270/271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>270--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:sequence minOccurs="0">
                          <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                            <xs:annotation>
                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="DIMENSION_TYPE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[WHD]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSION_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                            <xs:annotation>
                              <xs:documentation>405--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="DIMENSION_TYPE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[WHD]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSION_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TEST_ID">
                    <xs:annotation>
                      <xs:documentation>270--4--Pruef_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_1_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_2_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_3_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="VALIDATION_TYPE" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:int">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element : RESTRICTIONS Element
Beschreibung
In diesem Element werden die Prüfverfahren angelegt.
Namensraum (none)
Diagramm
RESTRICTION Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS
In diesem Element werden die Prüfverfahren angelegt.
Sequence
RESTRICTION 1..99999
In diesem Element wird ein Prüfverfahren definiert und beschrieben. Die Prüfverfahren definieren Regeln, die technisch machbare Konfigurationen abbilden. Es werden keine Planungsvorschläge hinterlegt, andernfalls würden nicht notwendige Prüfungen aufgebaut, die den Planer in seinen Möglichkeiten ungerechtfertigt einschränken.

Eine Zuordnung der Prüfverfahren zu Serien, Programmen oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien, Programmen oder Artikeln referenziert werden.

Prüfverfahren, die aus Serien oder Programmen referenziert werden, dürfen nicht von Artikeln referenziert werden. Prüfverfahren, die von Artikeln referenziert werden, haben Vorrang gegenüber den Prüfungen, die von Serien oder Programmen referenziert werden.

Das Elemente OPTION_REF kann unterschiedlich angelegt werden. Entsprechend den Füllmöglichkeiten der Elemente FEATURE_1_NO, FEATURE_2_NO und FEATURE_3_NO kann ein Prüfverfahren 0-stufig, 1-stufig oder 2-stufig oder 3-stufig definiert werden.

Resultierende Variantenmenge bei nicht angelegten Varianten:

Ist ein Prüfverfahren ein "erlaubendes" Prüfverfahren (TEST_ID = 1), so sind alle in dem Prüfverfahren nicht aufgeführten Varianten der im Prüfverfahren genannten Variantenarten nicht erlaubt. Handelt es sich um ein "nicht erlaubendes" Prüfverfahren (TEST_ID = 0), so sind diese Varianten erlaubt. Werden in einem Prüfverfahren Variantenarten kombiniert, so gilt diese Regel für die Kombination der resultierenden Varianten.

Resultierende Variantenmenge bei Programm-spezifischen Prüfverfahren:

Wird ein Prüfverfahren nicht von allen Programmen referenziert, gilt für die Programme, die das Prüfverfahren nicht referenzieren folgendes:

Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen ungültig, die in diesem Prüfverfahren nicht angelegt wurden.
Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen nicht erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen gültig, die in diesem Prüfverfahren nicht angelegt wurden.

Zyklische Prüfungen
Zyklische Prüfungen sind nicht erlaubt, diese können beispielsweise durch nachfolgende Konstellation hervorgerufen werden:
Nicht erlaubt!
1. Prüfung: Variante1 mit Variante2
2. Prüfung: Variante2 mit Variante3
3. Prüfung: Variante3 mit Variante1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Prüfverfahren eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE required Restriction of xs:int
Im Attribut VALIDATION_TYPE erfolgt die Definition, ob es sich bei dem Prüfverfahren um eine Farblängen-Prüfung, oder eine Variantenprüfung handelt. Wenn es sich um eine Farblängen-Prüfung handelt muss zu jeder Prüfung unter OPTION_COMBINATION eine MIN/MAX_DIMENSION gefällt werden.
0 = Varianten-Prüfung (ehemals Satzart 270)
1 = Farblängen-Prüfung (ehemals Satzart 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt 		D boolean
P
M
Quelle
<xs:element name="RESTRICTIONS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION" maxOccurs="99999">
        <xs:annotation>
          <xs:documentation>270/271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>270--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:sequence minOccurs="0">
                    <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                      <xs:annotation>
                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSION_TYPE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[WHD]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSION_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                      <xs:annotation>
                        <xs:documentation>405--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSION_TYPE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[WHD]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSION_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="TEST_ID">
              <xs:annotation>
                <xs:documentation>270--4--Pruef_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_1_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_2_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_3_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="VALIDATION_TYPE" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:int">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

RESTRICTION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element : RESTRICTION Element
Beschreibung
In diesem Element wird ein Prüfverfahren definiert und beschrieben. Die Prüfverfahren definieren Regeln, die technisch machbare Konfigurationen abbilden. Es werden keine Planungsvorschläge hinterlegt, andernfalls würden nicht notwendige Prüfungen aufgebaut, die den Planer in seinen Möglichkeiten ungerechtfertigt einschränken.

Eine Zuordnung der Prüfverfahren zu Serien, Programmen oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien, Programmen oder Artikeln referenziert werden.

Prüfverfahren, die aus Serien oder Programmen referenziert werden, dürfen nicht von Artikeln referenziert werden. Prüfverfahren, die von Artikeln referenziert werden, haben Vorrang gegenüber den Prüfungen, die von Serien oder Programmen referenziert werden.

Das Elemente OPTION_REF kann unterschiedlich angelegt werden. Entsprechend den Füllmöglichkeiten der Elemente FEATURE_1_NO, FEATURE_2_NO und FEATURE_3_NO kann ein Prüfverfahren 0-stufig, 1-stufig oder 2-stufig oder 3-stufig definiert werden.

Resultierende Variantenmenge bei nicht angelegten Varianten:

Ist ein Prüfverfahren ein "erlaubendes" Prüfverfahren (TEST_ID = 1), so sind alle in dem Prüfverfahren nicht aufgeführten Varianten der im Prüfverfahren genannten Variantenarten nicht erlaubt. Handelt es sich um ein "nicht erlaubendes" Prüfverfahren (TEST_ID = 0), so sind diese Varianten erlaubt. Werden in einem Prüfverfahren Variantenarten kombiniert, so gilt diese Regel für die Kombination der resultierenden Varianten.

Resultierende Variantenmenge bei Programm-spezifischen Prüfverfahren:

Wird ein Prüfverfahren nicht von allen Programmen referenziert, gilt für die Programme, die das Prüfverfahren nicht referenzieren folgendes:

Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen ungültig, die in diesem Prüfverfahren nicht angelegt wurden.
Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen nicht erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen gültig, die in diesem Prüfverfahren nicht angelegt wurden.

Zyklische Prüfungen
Zyklische Prüfungen sind nicht erlaubt, diese können beispielsweise durch nachfolgende Konstellation hervorgerufen werden:
Nicht erlaubt!
1. Prüfung: Variante1 mit Variante2
2. Prüfung: Variante2 mit Variante3
3. Prüfung: Variante3 mit Variante1
Namensraum (none)
Diagramm
TEST_ID Element OPTION_COMBINATION Element LANGUAGE Element Sequence RESTRICTION_NAME_TEXT Element Sequence RESTRICTION Element
Overview
RESTRICTION 1..99999
In diesem Element wird ein Prüfverfahren definiert und beschrieben. Die Prüfverfahren definieren Regeln, die technisch machbare Konfigurationen abbilden. Es werden keine Planungsvorschläge hinterlegt, andernfalls würden nicht notwendige Prüfungen aufgebaut, die den Planer in seinen Möglichkeiten ungerechtfertigt einschränken.

Eine Zuordnung der Prüfverfahren zu Serien, Programmen oder Artikeln erfolgt durch Referenzierung aus den entsprechenden Elementen. In Summe müssen alle in diesem Element definierten Prüfverfahren entweder aus Serien, Programmen oder Artikeln referenziert werden.

Prüfverfahren, die aus Serien oder Programmen referenziert werden, dürfen nicht von Artikeln referenziert werden. Prüfverfahren, die von Artikeln referenziert werden, haben Vorrang gegenüber den Prüfungen, die von Serien oder Programmen referenziert werden.

Das Elemente OPTION_REF kann unterschiedlich angelegt werden. Entsprechend den Füllmöglichkeiten der Elemente FEATURE_1_NO, FEATURE_2_NO und FEATURE_3_NO kann ein Prüfverfahren 0-stufig, 1-stufig oder 2-stufig oder 3-stufig definiert werden.

Resultierende Variantenmenge bei nicht angelegten Varianten:

Ist ein Prüfverfahren ein "erlaubendes" Prüfverfahren (TEST_ID = 1), so sind alle in dem Prüfverfahren nicht aufgeführten Varianten der im Prüfverfahren genannten Variantenarten nicht erlaubt. Handelt es sich um ein "nicht erlaubendes" Prüfverfahren (TEST_ID = 0), so sind diese Varianten erlaubt. Werden in einem Prüfverfahren Variantenarten kombiniert, so gilt diese Regel für die Kombination der resultierenden Varianten.

Resultierende Variantenmenge bei Programm-spezifischen Prüfverfahren:

Wird ein Prüfverfahren nicht von allen Programmen referenziert, gilt für die Programme, die das Prüfverfahren nicht referenzieren folgendes:

Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen ungültig, die in diesem Prüfverfahren nicht angelegt wurden.
Wenn in diesem Prüfverfahren Varianten oder Variantenkombinationen nicht erlaubt werden, so sind alle Varianten der im Prüfverfahren angegebenen Variantenarten in den Programmen gültig, die in diesem Prüfverfahren nicht angelegt wurden.

Zyklische Prüfungen
Zyklische Prüfungen sind nicht erlaubt, diese können beispielsweise durch nachfolgende Konstellation hervorgerufen werden:
Nicht erlaubt!
1. Prüfung: Variante1 mit Variante2
2. Prüfung: Variante2 mit Variante3
3. Prüfung: Variante3 mit Variante1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
Durch dieses Attribut werden Prüfverfahren eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE required Restriction of xs:int
Im Attribut VALIDATION_TYPE erfolgt die Definition, ob es sich bei dem Prüfverfahren um eine Farblängen-Prüfung, oder eine Variantenprüfung handelt. Wenn es sich um eine Farblängen-Prüfung handelt muss zu jeder Prüfung unter OPTION_COMBINATION eine MIN/MAX_DIMENSION gefällt werden.
0 = Varianten-Prüfung (ehemals Satzart 270)
1 = Farblängen-Prüfung (ehemals Satzart 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt 		D boolean
P
M
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
RESTRICTION_NO Restriction of xs:nonNegativeInteger required
Durch dieses Attribut werden Prüfverfahren eindeutig identifiziert. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO Restriction of xs:nonNegativeInteger required
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO Restriction of xs:nonNegativeInteger optional
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO Restriction of xs:nonNegativeInteger optional
In den Attributen FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO werden die Variantenarten angegeben, die in den Prüfverfahren verwendet werden. Die Attribute definieren zugleich die Reihenfolge der Variantenarten in den Prüfverfahren.
Zusätzlich besteht die Möglichkeit zur Überprüfung, das die Variantenarten innerhalb eines Prüfverfahrens nicht wechseln. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE Restriction of xs:int required
Im Attribut VALIDATION_TYPE erfolgt die Definition, ob es sich bei dem Prüfverfahren um eine Farblängen-Prüfung, oder eine Variantenprüfung handelt. Wenn es sich um eine Farblängen-Prüfung handelt muss zu jeder Prüfung unter OPTION_COMBINATION eine MIN/MAX_DIMENSION gefällt werden.
0 = Varianten-Prüfung (ehemals Satzart 270)
1 = Farblängen-Prüfung (ehemals Satzart 405) 		D nonNegativeInteger
P
M [0:1]
Quelle
<xs:element name="RESTRICTION" maxOccurs="99999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>270--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:sequence minOccurs="0">
              <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                <xs:annotation>
                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="DIMENSION_TYPE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[WHD]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                  <xs:attribute name="DIMENSION_VALUE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                <xs:annotation>
                  <xs:documentation>405--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="DIMENSION_TYPE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[WHD]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                  <xs:attribute name="DIMENSION_VALUE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="TEST_ID">
        <xs:annotation>
          <xs:documentation>270--4--Pruef_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_1_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_2_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_3_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="VALIDATION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:int">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

RESTRICTION_NAME_TEXT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : RESTRICTION_NAME_TEXT Element
Beschreibung
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.
Namensraum (none)
Typ
languagetexte60 Complex Type
Diagramm
LANGUAGE Element Sequence RESTRICTION_NAME_TEXT Element
Overview
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
In diesem Element wir die Bezeichnung eines Prüfverfahrens hinterlegt.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

OPTION_COMBINATION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : OPTION_COMBINATION Element
Beschreibung
In diesem Element wird eine Variantenkombination gebildet.
Namensraum (none)
Diagramm
MIN_DIMENSION Element MAX_DIMENSION Element Sequence OPTION_REF Element Sequence OPTION_COMBINATION Element
Overview
OPTION_COMBINATION 1..∞
In diesem Element wird eine Variantenkombination gebildet.
Sequence
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
Quelle
<xs:element name="OPTION_COMBINATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:sequence minOccurs="0">
        <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
          <xs:annotation>
            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="DIMENSION_TYPE" use="required">
              <xs:annotation>
                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[WHD]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
            <xs:attribute name="DIMENSION_VALUE" use="required">
              <xs:annotation>
                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
          <xs:annotation>
            <xs:documentation>405--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="DIMENSION_TYPE" use="required">
              <xs:annotation>
                <xs:documentation>405--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[WHD]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
            <xs:attribute name="DIMENSION_VALUE" use="required">
              <xs:annotation>
                <xs:documentation>405--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : OPTION_REF Element
Beschreibung
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF 1..3
In diesem Element werden Varianten referenziert, die in einem Prüfverfahren angewendet werden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_REF" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

MAX_DIMENSION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : MAX_DIMENSION Element
Beschreibung
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
Namensraum (none)
Diagramm
MAX_DIMENSION Element
Overview
MAX_DIMENSION 0..3
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DIMENSION_TYPE Restriction of xs:string required
In diesem Element wird angegeben, für welche Dimension das angegebene Maximalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE Restriction of xs:nonNegativeInteger required
In diesem Element wird die maximale Breite, Höhe und Tiefe angegeben, in der die Farbvariante bzw. Kombination Farb- und Ausführungsvariante verfügbar ist. Der Wert wird in mm angegeben. Die hier eingegebenen Werte müssen den Wertebereichen entsprechen, die für den Artikel im Element PARAMETERS (Pfad 1) angegeben sind.

Die im Element /PARAMETERS (Pfad 1) angegebene Maximalwerte dürfen nicht überschritten werden.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
Quelle
<xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[WHD]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSION_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

MIN_DIMENSION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : MIN_DIMENSION Element
Beschreibung
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
Namensraum (none)
Diagramm
MIN_DIMENSION Element
Overview
MIN_DIMENSION 0..3
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist.
DIMENSION_TYPE required Restriction of xs:string
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
DIMENSION_TYPE Restriction of xs:string required
In diesem Element wird angegeben, für welche Dimension das angegebene Minimalmaß gültig ist.

Es sind folgende Werte möglich:
W = Breite
H = Höhe
D = Tiefe . 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE Restriction of xs:nonNegativeInteger required
Dieses Element definiert das minimale Maß in der eine Ausprägung lieferbar ist. D nonNegativeInteger
P
M [1:9999]
Quelle
<xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>405--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>405--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[WHD]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSION_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>405--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TEST_ID Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : TEST_ID Element
Beschreibung
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt 		D boolean
P
M
Namensraum (none)
Typ
Restriction of xs:boolean
Diagramm
TEST_ID Element
Overview
TEST_ID Restriction of xs:boolean
Die TEST_ID definiert, ob die angelegten Variantenkombinationen eines Prüfverfahrens erlaubt oder nicht erlaubt sind.
0 = Kombinationen nicht erlaubt
1 = Kombinationen erlaubt 		D boolean
P
M
Quelle
<xs:element name="TEST_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--4--Pruef_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
Siehe auch
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_VALUE_CALCULATION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element : BLOCK_VALUE_CALCULATION Element
Beschreibung
In diesem Element wird die Block- und Werteverrechnung defiert.
Namensraum (none)
Diagramm
SET_OF_BLOCK_RULES Element GRADING_TABLE Element BLOCK_SALE_PRICES Element BLOCK_CONDITIONS Element Sequence BLOCK_VALUE_CALCULATION Element
Overview
BLOCK_VALUE_CALCULATION optional
In diesem Element wird die Block- und Werteverrechnung defiert.
Sequence
BLOCK_CONDITIONS optional

In diesem Element werden Bedingungen formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.

Ein Block darf für einen Auftrag angewendet werden, wenn alle für diesen Block formulierten Bedingungen erfüllt sind. Die einem Block zugeordneten Bedingungen werden durch das Tupel ITEM_REF (Pfad 1) und OPERATION_ID (Pfad 1) gebildet.

Grundbedingung für die Anwendung der Blockbedingung ist, dass ein Block in einem der Programme existiert, die im Auftrag verplant wurden. Sind in einem Auftrag mehrer Programme ausgewählt, gilt das erste Programm im Auftrag auf Kopfebene.

Ein Block unterliegt der Programm- und Variantensteuerung wie "normale" Artikel. Wenn ein Verrechnungsblock in einer Preisgruppe existieren soll, so wird ein entsprechendes Element ITEM_PRICE (Pfad 2) mit dem Preis 0 angelegt.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein, damit der Block für die Werteverrechnung oder die Blockverrechnung angewendet werden darf.

Pfad 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
BLOCK_CONDITION 1..∞
In diesem Element eine Bedingung formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.
Sequence
ITEM_REF
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.
Sequence
CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.
Sequence
CLEARING_GROUP_REF 1..999
Referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder eine zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Werte bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
BLOCK_SALE_PRICES optional
In diesem Element werden Blockaktionspreise formuliert.
Sequence
BLOCK_SALE_PRICE 1..∞

Dieses Element dient dazu, Blockaktionen zu unterschiedlich begrenzten Zeiträumen zu definieren. Sie darf nur eingesetzt werden, wenn ein Block in mehreren begrenzten Zeiträumen innerhalb einer Katalogrunde lieferbar bzw. nicht lieferbar ist. Blöcke, die nur in einem zusammenhängenden Zeitraum lieferbar sind, werden hinsichtlich der Lieferfähigkeit mittels der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL (Pfad 1) definiert.

Der in diesem Element angegebene Preis hat Vorrang gegenüber dem Preis, der dem Block im entsprechenden Preisfeld zugeordnet ist.
Die in diesem Element definierte Varianten-Kombination hat Vorrang gegenüber den artikelspezifischen Prüfverfahren, die dem Block zugeordnet sind.

Die definierten Zeiträume der Aktionspreise dürfen sich für einen Block nicht überschneiden.
Durch die Elementdaten werden keine Informationen überschrieben, es werden Informationen zeitlich auser Kraft gesetzt.
Es wird genau die Informationen zeitlich auser Kraft gesetzt, die in dem Element angegebne sind. Alle anderen Kombinationen sind weiter gültig!

Die Datumswerte eines Blocks in diesem Element dürfen nicht mit denen des Blocks in denen der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL übereinstimmen.
Wir durch einen Datensatz beispielsweise ein Block in einem Programm für einen Zeitraum günstiger angeboten, so darf auf keinen Fall der "normale" Preis in der entsprechenden Preisgruppe des Programms dieses Blockes durch den in diesem Element angegebenen Preis überschrieben werden, da der Preis in dieser Preisgruppe auch von anderen Programmen verwendet werden kann.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Sequence
ITEM_REF
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.
Sequence
VALID_FROM Restriction of xs:date
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
VALID_UNTIL Restriction of xs:date
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
GRADING_TABLE optional

In diesem Element werden die Wertestaffeln zur Verrechnung der Gutschriften oder Aufschläge definiert.

Wenn ein Verrechnungsblock für einen Auftrag gültig ist, kann mit dem Block in die Wertestaffel eingestiegen werden. Je gültigem Block in der Wertstaffel wird eine Vergleichssumme für die in dem Element angegebene Verrechnungsgruppe (CLEARING_GROUP (Pfad 1)) bestimmt. Entspricht der Wert der Vergleichssumme dem angegebenen Wertebereich (Elemente VALUE_FROM (Pfad 2) und VALUE_TO (Pfad 2)), so wird das Element angewendet, d. h. die im Element TYPE_CREDIT (Pfad 2) und/oder TYPE_DEBIT (Pfad 2) hinterlegte Type wird verrechnet. Die Berechnung erfolgt auf die Summe der Kalkulationsgruppe, die für die Gutschrift- oder Belastungstype angegeben ist (Element ITEM (Pfad 3)).

Für einen Block können mehrere Staffelbereiche angelegt werden. Jeder Staffelbereich wird einem Element COMPARING_RULES (Pfad 4) zugeordnet. In einer Staffel eines Blocks müssen die Bedingungen aller Wertebereiche mit jeweiliger Verrechnungsgruppe erfüllt sein, bevor die Positionen verrechnet werden können. Die einzelnen Elemente (COMPARING_RULE) sind UND-verknüpft.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein.

Werden auf dem Element GRADING_TABLE mehrere Datensätze eines Verrechnungsblocks angewendet, so wird der Wert des Blocks (ITEM (Pfad 3)), ITEM_PRICE (Pfad 5)) jedoch nur einmal berechnet.

Pfad 1: GLOBAL_DEFINITION
Pfad 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
CREDIT_SURCHARGE_CLEARING 1..∞
In diesem Element wird ein Wertebereich der Wertestaffel definiert.
Sequence
ITEM_REF

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.
Sequence
COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.

Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.

Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
SET_OF_BLOCK_RULES
In diesem Element und den Kind-Elementen werden die herstellerspezifischen Regelwerke beschrieben.
Sequence
EXCHANGE_ID_GROUP 1..∞
In diesem Element werden die Tauschgruppen definiert. Wenn Tausch-ID 1 (EXCHANGE_ID_1_REF) gegen Tausch-ID 2 (EXCHANGE_ID_2_REF) wechselseitig getauscht werden dürfen, muss dies explizit angegeben werden.
Wenn Artikel mit gleicher Tausch-ID 1:1 untereinander getauscht werden dürfen, muss für diesen Tauschvorgang ein Datensatz angelegt werden.
Sequence
EXCHANGE_ID_1_REF
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RULE 1..99
In diesem Element wird ein herstellerspezifisches Regelwerk definiert.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird ein Zähler von 1-99 für die Regeln im Blockregelwerk angegeben. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
RULE_SET_TEXT languagetexte60999 Complex Type

In diesem Element werden Erläuterungen zu dem Regelwerk angelegt.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="BLOCK_VALUE_CALCULATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_CONDITIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>420--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>420--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>420--3--Type_Block</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--3--Type_Block</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--3--Type_Block</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CONDITION_RULES">
                    <xs:annotation>
                      <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>420--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                                <xs:annotation>
                                  <xs:documentation>420--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="CLEARING_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>420--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:choice>
                                <xs:element name="MINIMUM_VALUE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:choice>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BLOCK_SALE_PRICES" minOccurs="0">
        <xs:annotation>
          <xs:documentation>480--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>480--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>480--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>480--100--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="VALID_FROM">
                          <xs:annotation>
                            <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL">
                          <xs:annotation>
                            <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                          <xs:annotation>
                            <xs:documentation>480--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_OR_CALCULATION_POINT">
                          <xs:annotation>
                            <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GRADING_TABLE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>421--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>421--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>421--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>421--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLEARING_GROUP_ID">
                                <xs:annotation>
                                  <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_FROM">
                                <xs:annotation>
                                  <xs:documentation>421--6--Wert_von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_TO">
                                <xs:annotation>
                                  <xs:documentation>421--7--Wert_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TYPE_CREDIT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TYPE_DEBIT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>421--9--Type_Belastung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_OF_BLOCK_RULES">
        <xs:annotation>
          <xs:documentation>111--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_1_REF">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>117--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EXCHANGE_ID_2_REF">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>117--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RULE" maxOccurs="99">
              <xs:annotation>
                <xs:documentation>111--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RULE_TEXT" type="languagetexte60999">
                    <xs:annotation>
                      <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="RULE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>113--3--Regel_Nr</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_CONDITIONS Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element : BLOCK_CONDITIONS Element
Beschreibung

In diesem Element werden Bedingungen formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.

Ein Block darf für einen Auftrag angewendet werden, wenn alle für diesen Block formulierten Bedingungen erfüllt sind. Die einem Block zugeordneten Bedingungen werden durch das Tupel ITEM_REF (Pfad 1) und OPERATION_ID (Pfad 1) gebildet.

Grundbedingung für die Anwendung der Blockbedingung ist, dass ein Block in einem der Programme existiert, die im Auftrag verplant wurden. Sind in einem Auftrag mehrer Programme ausgewählt, gilt das erste Programm im Auftrag auf Kopfebene.

Ein Block unterliegt der Programm- und Variantensteuerung wie "normale" Artikel. Wenn ein Verrechnungsblock in einer Preisgruppe existieren soll, so wird ein entsprechendes Element ITEM_PRICE (Pfad 2) mit dem Preis 0 angelegt.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein, damit der Block für die Werteverrechnung oder die Blockverrechnung angewendet werden darf.

Pfad 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Namensraum (none)
Diagramm
BLOCK_CONDITION Element Sequence BLOCK_CONDITIONS Element
Overview
BLOCK_CONDITIONS optional

In diesem Element werden Bedingungen formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.

Ein Block darf für einen Auftrag angewendet werden, wenn alle für diesen Block formulierten Bedingungen erfüllt sind. Die einem Block zugeordneten Bedingungen werden durch das Tupel ITEM_REF (Pfad 1) und OPERATION_ID (Pfad 1) gebildet.

Grundbedingung für die Anwendung der Blockbedingung ist, dass ein Block in einem der Programme existiert, die im Auftrag verplant wurden. Sind in einem Auftrag mehrer Programme ausgewählt, gilt das erste Programm im Auftrag auf Kopfebene.

Ein Block unterliegt der Programm- und Variantensteuerung wie "normale" Artikel. Wenn ein Verrechnungsblock in einer Preisgruppe existieren soll, so wird ein entsprechendes Element ITEM_PRICE (Pfad 2) mit dem Preis 0 angelegt.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein, damit der Block für die Werteverrechnung oder die Blockverrechnung angewendet werden darf.

Pfad 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
BLOCK_CONDITION 1..∞
In diesem Element eine Bedingung formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.
Sequence
ITEM_REF
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.
Sequence
CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.
Sequence
CLEARING_GROUP_REF 1..999
Referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder eine zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Werte bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="BLOCK_CONDITIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>420--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>420--3--Type_Block</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--3--Type_Block</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--3--Type_Block</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONDITION_RULES">
              <xs:annotation>
                <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>420--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                          <xs:annotation>
                            <xs:documentation>420--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="CLEARING_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:choice>
                          <xs:element name="MINIMUM_VALUE" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:choice>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_CONDITION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element : BLOCK_CONDITION Element
Beschreibung
In diesem Element eine Bedingung formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.
Namensraum (none)
Diagramm
CONDITION_RULES Element ITEM_REF Element Sequence BLOCK_CONDITION Element
Overview
BLOCK_CONDITION 1..∞
In diesem Element eine Bedingung formuliert, mittels derer die Gültigkeit eines Blocks für einen Auftrag geprüft wird. Dieses Element ist für die Werteverrechnung (Verrechnungsblock) und für die Blockverrechnung (Artikelblock) gültig.
Sequence
ITEM_REF
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.
Sequence
CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.
Sequence
CLEARING_GROUP_REF 1..999
Referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder eine zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Werte bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="BLOCK_CONDITION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>420--3--Type_Block</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--3--Type_Block</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--3--Type_Block</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONDITION_RULES">
        <xs:annotation>
          <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>420--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                    <xs:annotation>
                      <xs:documentation>420--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="CLEARING_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:choice>
                    <xs:element name="MINIMUM_VALUE" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:choice>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element : ITEM_REF Element
Beschreibung
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF
Dieses Element gibt die Type des Verrechnungsblocks an. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie. Der Verrechnungsblock wird mit der Artikelkennung V=Verrechnungsblock angelegt.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--3--Type_Block</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--3--Type_Block</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--3--Type_Block</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CONDITION_RULES Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element : CONDITION_RULES Element
Beschreibung
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.
Namensraum (none)
Diagramm
CONDITION_RULE Element Sequence CONDITION_RULES Element
Overview
CONDITION_RULES
Blockbedingungen, die innerhalb eines Elementes CONDITION_RULES definiert sind, sind UND-verknüpft. Die Elemente CONDITION_RULES untereinander sind ODER-verknüpft.
Sequence
CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.
Sequence
CLEARING_GROUP_REF 1..999
Referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder eine zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Werte bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="CONDITION_RULES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>420--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
              <xs:annotation>
                <xs:documentation>420--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="CLEARING_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:choice>
              <xs:element name="MINIMUM_VALUE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="999999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:choice>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CONDITION_RULE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element : CONDITION_RULE Element
Beschreibung
In diesem Element werden die Blockbedingungen formuliert.
Namensraum (none)
Diagramm
MINIMUM_WIDTH Element MINIMUM_VALUE Element Choice CLEARING_GROUP_REF Element Sequence CONDITION_RULE Element
Overview
CONDITION_RULE 1..∞
In diesem Element werden die Blockbedingungen formuliert.
Sequence
CLEARING_GROUP_REF 1..999
Referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder eine zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Werte bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="CONDITION_RULE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>420--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="CLEARING_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:choice>
        <xs:element name="MINIMUM_VALUE" minOccurs="0">
          <xs:annotation>
            <xs:documentation>420--6--Mindest_Wert</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:nonNegativeInteger">
              <xs:minInclusive value="0" />
              <xs:maxInclusive value="999999999" />
            </xs:restriction>
          </xs:simpleType>
        </xs:element>
        <xs:element name="MINIMUM_WIDTH" minOccurs="0">
          <xs:annotation>
            <xs:documentation>420--7--Mindest_Breite</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:nonNegativeInteger">
              <xs:minInclusive value="0" />
              <xs:maxInclusive value="999999" />
            </xs:restriction>
          </xs:simpleType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : CLEARING_GROUP_REF Element
Beschreibung
Referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder eine zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
Namensraum (none)
Diagramm
CLEARING_GROUP_REF Element
Overview
CLEARING_GROUP_REF 1..999
Referenziert eine Verrechnungsgruppe für die Bedingungen formuliert werden. Sofern alle anderen Bedingungen für den Verrechnungsblock (SERIE_NO, TYPE_NO) erfüllt sind, darf dieser für einen Auftrag angewendet werden.
Für die Verrechnungsgruppe kann entweder eine zu erreichender Mindestwert (MINIMUM_VALUE) oder eine zu erreichende Mindestlänge (MINIMUM_WIDTH) definiert werden.
Anhand der hier angegebenen Verrechnungsgruppe werden die Werte (Betrag oder Länge) aller Auftragspositionen, deren Tausch-ID der Verrechnungsgruppe zugeordnet ist, summiert. Die so errechnete Summe wird mit dem Inhalt der Elemente MINIMUM_VALUE oder MINIMUM_WIDTH verglichen. Ist die errechnete Summe größer als der in diesen Feldern angegebene Wert, ist das Blockkriterium in diesem Punkt erfüllt.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
CLEARING_GROUP_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Verrechnungsgruppe referenziert. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="CLEARING_GROUP_REF" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="CLEARING_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

MINIMUM_VALUE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : MINIMUM_VALUE Element
Beschreibung
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Werte bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MINIMUM_VALUE Element
Overview
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
Dieses Element stellt den Mindestwert dar, den die Summe der Beträge aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element Mindest_Werte bezieht sich auf die im Element Verrechnungsgruppe-ID referenzierte Verrechnungsgruppe.
Soll der MINIMUM_VALUE auf einen Artikel bezogen werden, so sind die Tausch-ID entsprechend fein detailliert anzulegen.
Der angegebene Mindetwert ist der Brutto-EK Preis, vor Abzug der EK-Bedingungen

Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="MINIMUM_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--6--Mindest_Wert</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

MINIMUM_WIDTH Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : MINIMUM_WIDTH Element
Beschreibung
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
MINIMUM_WIDTH Element
Overview
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
Mindestlänge, welche die Summe der Längen aller Auftragspositionen, deren Tausch-ID in der Verrechnungsgruppe zugeordnet ist, übersteigen muss, damit die Blockbedingung erfüllt ist.
Das Element MINIMUM_WIDTH bezieht sich auf die im Element CONDITION_RULES referenzierte Verrechnungsgruppe.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH (Mindestbreite) gefüllt.
Bei der Berechnung der Mindestbreite werden nur Artikel beachtet, die maßabhängig sind. Die Dimension anhand derer die Mindestbreite berechnet wird, ist die Breite der Artikel.
Die Mindestbreite ist definiert, als die Summe der Länge aller Artikel dieser Verrechnungsgruppe. Soll die Mindestbreite auf einen Artikel bezogen werden, so sind die Tausch-ID und die Verrechnungsgruppen entsprechend detailliert anzulegen.
Hierbei ist unbedingt zu beachten, dass ein detailliertes Anlegen von Tausch-ID die Handhabung in der Blockverrechnung aufwändiger gestaltet. Das Definieren der Tausch-ID und Verrechnungsgruppen ist sorgfältig zu planen.
Entweder ist das Element MINIMUM_VALUE oder das Element MINIMUM_WIDTH gefüllt. 		D nonNegativeInteger
P
M [0:999999]
Quelle
<xs:element name="MINIMUM_WIDTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--7--Mindest_Breite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_SALE_PRICES Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element : BLOCK_SALE_PRICES Element
Beschreibung
In diesem Element werden Blockaktionspreise formuliert.
Namensraum (none)
Diagramm
BLOCK_SALE_PRICE Element Sequence BLOCK_SALE_PRICES Element
Overview
BLOCK_SALE_PRICES optional
In diesem Element werden Blockaktionspreise formuliert.
Sequence
BLOCK_SALE_PRICE 1..∞

Dieses Element dient dazu, Blockaktionen zu unterschiedlich begrenzten Zeiträumen zu definieren. Sie darf nur eingesetzt werden, wenn ein Block in mehreren begrenzten Zeiträumen innerhalb einer Katalogrunde lieferbar bzw. nicht lieferbar ist. Blöcke, die nur in einem zusammenhängenden Zeitraum lieferbar sind, werden hinsichtlich der Lieferfähigkeit mittels der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL (Pfad 1) definiert.

Der in diesem Element angegebene Preis hat Vorrang gegenüber dem Preis, der dem Block im entsprechenden Preisfeld zugeordnet ist.
Die in diesem Element definierte Varianten-Kombination hat Vorrang gegenüber den artikelspezifischen Prüfverfahren, die dem Block zugeordnet sind.

Die definierten Zeiträume der Aktionspreise dürfen sich für einen Block nicht überschneiden.
Durch die Elementdaten werden keine Informationen überschrieben, es werden Informationen zeitlich auser Kraft gesetzt.
Es wird genau die Informationen zeitlich auser Kraft gesetzt, die in dem Element angegebne sind. Alle anderen Kombinationen sind weiter gültig!

Die Datumswerte eines Blocks in diesem Element dürfen nicht mit denen des Blocks in denen der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL übereinstimmen.
Wir durch einen Datensatz beispielsweise ein Block in einem Programm für einen Zeitraum günstiger angeboten, so darf auf keinen Fall der "normale" Preis in der entsprechenden Preisgruppe des Programms dieses Blockes durch den in diesem Element angegebenen Preis überschrieben werden, da der Preis in dieser Preisgruppe auch von anderen Programmen verwendet werden kann.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Sequence
ITEM_REF
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.
Sequence
VALID_FROM Restriction of xs:date
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
VALID_UNTIL Restriction of xs:date
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="BLOCK_SALE_PRICES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>480--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>480--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>480--100--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="VALID_FROM">
                    <xs:annotation>
                      <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL">
                    <xs:annotation>
                      <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                    <xs:annotation>
                      <xs:documentation>480--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_OR_CALCULATION_POINT">
                    <xs:annotation>
                      <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_SALE_PRICE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element : BLOCK_SALE_PRICE Element
Beschreibung

Dieses Element dient dazu, Blockaktionen zu unterschiedlich begrenzten Zeiträumen zu definieren. Sie darf nur eingesetzt werden, wenn ein Block in mehreren begrenzten Zeiträumen innerhalb einer Katalogrunde lieferbar bzw. nicht lieferbar ist. Blöcke, die nur in einem zusammenhängenden Zeitraum lieferbar sind, werden hinsichtlich der Lieferfähigkeit mittels der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL (Pfad 1) definiert.

Der in diesem Element angegebene Preis hat Vorrang gegenüber dem Preis, der dem Block im entsprechenden Preisfeld zugeordnet ist.
Die in diesem Element definierte Varianten-Kombination hat Vorrang gegenüber den artikelspezifischen Prüfverfahren, die dem Block zugeordnet sind.

Die definierten Zeiträume der Aktionspreise dürfen sich für einen Block nicht überschneiden.
Durch die Elementdaten werden keine Informationen überschrieben, es werden Informationen zeitlich auser Kraft gesetzt.
Es wird genau die Informationen zeitlich auser Kraft gesetzt, die in dem Element angegebne sind. Alle anderen Kombinationen sind weiter gültig!

Die Datumswerte eines Blocks in diesem Element dürfen nicht mit denen des Blocks in denen der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL übereinstimmen.
Wir durch einen Datensatz beispielsweise ein Block in einem Programm für einen Zeitraum günstiger angeboten, so darf auf keinen Fall der "normale" Preis in der entsprechenden Preisgruppe des Programms dieses Blockes durch den in diesem Element angegebenen Preis überschrieben werden, da der Preis in dieser Preisgruppe auch von anderen Programmen verwendet werden kann.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Namensraum (none)
Diagramm
VARIATION_PRICE_DEFINITION Element ITEM_REF Element Sequence BLOCK_SALE_PRICE Element
Overview
BLOCK_SALE_PRICE 1..∞

Dieses Element dient dazu, Blockaktionen zu unterschiedlich begrenzten Zeiträumen zu definieren. Sie darf nur eingesetzt werden, wenn ein Block in mehreren begrenzten Zeiträumen innerhalb einer Katalogrunde lieferbar bzw. nicht lieferbar ist. Blöcke, die nur in einem zusammenhängenden Zeitraum lieferbar sind, werden hinsichtlich der Lieferfähigkeit mittels der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL (Pfad 1) definiert.

Der in diesem Element angegebene Preis hat Vorrang gegenüber dem Preis, der dem Block im entsprechenden Preisfeld zugeordnet ist.
Die in diesem Element definierte Varianten-Kombination hat Vorrang gegenüber den artikelspezifischen Prüfverfahren, die dem Block zugeordnet sind.

Die definierten Zeiträume der Aktionspreise dürfen sich für einen Block nicht überschneiden.
Durch die Elementdaten werden keine Informationen überschrieben, es werden Informationen zeitlich auser Kraft gesetzt.
Es wird genau die Informationen zeitlich auser Kraft gesetzt, die in dem Element angegebne sind. Alle anderen Kombinationen sind weiter gültig!

Die Datumswerte eines Blocks in diesem Element dürfen nicht mit denen des Blocks in denen der Elemente VALID_FROM (Pfad 1) und /VALID_UNTIL übereinstimmen.
Wir durch einen Datensatz beispielsweise ein Block in einem Programm für einen Zeitraum günstiger angeboten, so darf auf keinen Fall der "normale" Preis in der entsprechenden Preisgruppe des Programms dieses Blockes durch den in diesem Element angegebenen Preis überschrieben werden, da der Preis in dieser Preisgruppe auch von anderen Programmen verwendet werden kann.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Sequence
ITEM_REF
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.
Sequence
VALID_FROM Restriction of xs:date
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
VALID_UNTIL Restriction of xs:date
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>480--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>480--100--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="VALID_FROM">
              <xs:annotation>
                <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL">
              <xs:annotation>
                <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
              <xs:annotation>
                <xs:documentation>480--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_OR_CALCULATION_POINT">
              <xs:annotation>
                <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element : ITEM_REF Element
Beschreibung
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.
Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF
Mit diesem Element wird ein Artikel referenziert, für den ein Blockaktionspreis definiert wird.
TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

VARIATION_PRICE_DEFINITION Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element : VARIATION_PRICE_DEFINITION Element
Beschreibung
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.
Namensraum (none)
Diagramm
PRICE_OR_CALCULATION_POINT Element OPTION_REF Element VALID_UNTIL Element VALID_FROM Element Sequence VARIATION_PRICE_DEFINITION Element
Overview
VARIATION_PRICE_DEFINITION 1..∞
In diesem Element werden die Bedingungen für Blockaktionspreise definiert.
Sequence
VALID_FROM Restriction of xs:date
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
VALID_UNTIL Restriction of xs:date
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--100--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="VALID_FROM">
        <xs:annotation>
          <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL">
        <xs:annotation>
          <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
        <xs:annotation>
          <xs:documentation>480--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_OR_CALCULATION_POINT">
        <xs:annotation>
          <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : VALID_FROM Element
Beschreibung
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_FROM Element
Overview
VALID_FROM Restriction of xs:date
Dieses Element gibt das Datum in der Form, ab dem der Block zum Aktionspreis lieferbar ist. Die Elemente VALID_FROM dürfen kein Datum enthalten, das vor dem Katalogbeginn liegt. Die Datumswerte eines Block aus VARIATION_PRICE_DEFINITION dürfen nicht mit denen des Blocks aus ITEM übereinstimmen. D date
P
M
Quelle
<xs:element name="VALID_FROM" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : VALID_UNTIL Element
Beschreibung
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
Namensraum (none)
Typ
Restriction of xs:date
Diagramm
VALID_UNTIL Element
Overview
VALID_UNTIL Restriction of xs:date
Dieses Element gibt das Datum in der Form, bis zu welchem der Block zum Aktionspreis lieferbar ist. Die Elemente mit der Bezeichnung VALID_UNTIL dürfen kein Datum enthalten, das größer dem Katalogdatum + 10 Jahre ist. Ist eine Einschränkung nicht erwünscht, muss das Element leer sein. Die Datumswerte eines Block aus dem Element BLOCK_SALE_PRICE dürfen nicht mit denen des Blocks in dem Element ITEM übereinstimmen. D date
P
M
Quelle
<xs:element name="VALID_UNTIL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
Siehe auch
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : OPTION_REF Element
Beschreibung
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
Namensraum (none)
Diagramm
OPTION_REF Element
Overview
OPTION_REF 0..4
Mit diesem Element werden Varianten referenziert, für deren Kombination ein Blockaktionspreis angeboten werden soll.

Wird ein Programm verwendet, so muss für dieses Programm die erste OPTION_REF verwendet werden. Bei Verwendung mehrerer Variantenarten dürfen keine Dubletten vorhanden sein, die sich nur in der Reihenfolge der verwendeteten Variantenarten unterschieden.
FEATURE_NO required Restriction of xs:nonNegativeInteger
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
FEATURE_NO Restriction of xs:nonNegativeInteger required
Mit diesem Attribut wird eine Variantenart referenziert. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required
Mit diesem Attribut wird eine Variantenausprägung referenziert. D string
P
M [1:5]
Quelle
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

PRICE_OR_CALCULATION_POINT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : PRICE_OR_CALCULATION_POINT Element
Beschreibung
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
PRICE_OR_CALCULATION_POINT Element
Overview
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
In dieses Element werden die Preise laut ihrer Preisgruppen eingetragen. Die Preise sind immer in der kleinsten Währungseinheit einzubringen (beispielsweise anstatt "300,00" [€] "30000" [Cent]). Identnummern werden ohne Nachkommastellen, Verrechnungspunkte werden mit genau zwei Nachkommastellen angegeben (ohne das Komma selbst). D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="PRICE_OR_CALCULATION_POINT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

GRADING_TABLE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element : GRADING_TABLE Element
Beschreibung

In diesem Element werden die Wertestaffeln zur Verrechnung der Gutschriften oder Aufschläge definiert.

Wenn ein Verrechnungsblock für einen Auftrag gültig ist, kann mit dem Block in die Wertestaffel eingestiegen werden. Je gültigem Block in der Wertstaffel wird eine Vergleichssumme für die in dem Element angegebene Verrechnungsgruppe (CLEARING_GROUP (Pfad 1)) bestimmt. Entspricht der Wert der Vergleichssumme dem angegebenen Wertebereich (Elemente VALUE_FROM (Pfad 2) und VALUE_TO (Pfad 2)), so wird das Element angewendet, d. h. die im Element TYPE_CREDIT (Pfad 2) und/oder TYPE_DEBIT (Pfad 2) hinterlegte Type wird verrechnet. Die Berechnung erfolgt auf die Summe der Kalkulationsgruppe, die für die Gutschrift- oder Belastungstype angegeben ist (Element ITEM (Pfad 3)).

Für einen Block können mehrere Staffelbereiche angelegt werden. Jeder Staffelbereich wird einem Element COMPARING_RULES (Pfad 4) zugeordnet. In einer Staffel eines Blocks müssen die Bedingungen aller Wertebereiche mit jeweiliger Verrechnungsgruppe erfüllt sein, bevor die Positionen verrechnet werden können. Die einzelnen Elemente (COMPARING_RULE) sind UND-verknüpft.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein.

Werden auf dem Element GRADING_TABLE mehrere Datensätze eines Verrechnungsblocks angewendet, so wird der Wert des Blocks (ITEM (Pfad 3)), ITEM_PRICE (Pfad 5)) jedoch nur einmal berechnet.

Pfad 1: GLOBAL_DEFINITION
Pfad 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Namensraum (none)
Diagramm
CREDIT_SURCHARGE_CLEARING Element Sequence GRADING_TABLE Element
Overview
GRADING_TABLE optional

In diesem Element werden die Wertestaffeln zur Verrechnung der Gutschriften oder Aufschläge definiert.

Wenn ein Verrechnungsblock für einen Auftrag gültig ist, kann mit dem Block in die Wertestaffel eingestiegen werden. Je gültigem Block in der Wertstaffel wird eine Vergleichssumme für die in dem Element angegebene Verrechnungsgruppe (CLEARING_GROUP (Pfad 1)) bestimmt. Entspricht der Wert der Vergleichssumme dem angegebenen Wertebereich (Elemente VALUE_FROM (Pfad 2) und VALUE_TO (Pfad 2)), so wird das Element angewendet, d. h. die im Element TYPE_CREDIT (Pfad 2) und/oder TYPE_DEBIT (Pfad 2) hinterlegte Type wird verrechnet. Die Berechnung erfolgt auf die Summe der Kalkulationsgruppe, die für die Gutschrift- oder Belastungstype angegeben ist (Element ITEM (Pfad 3)).

Für einen Block können mehrere Staffelbereiche angelegt werden. Jeder Staffelbereich wird einem Element COMPARING_RULES (Pfad 4) zugeordnet. In einer Staffel eines Blocks müssen die Bedingungen aller Wertebereiche mit jeweiliger Verrechnungsgruppe erfüllt sein, bevor die Positionen verrechnet werden können. Die einzelnen Elemente (COMPARING_RULE) sind UND-verknüpft.

Sind für einen Block mehrere Bedingungen formuliert, so sind diese ODER-verknüpft, d. h. mindestens eine dieser Bedingungen muss erfüllt sein.

Werden auf dem Element GRADING_TABLE mehrere Datensätze eines Verrechnungsblocks angewendet, so wird der Wert des Blocks (ITEM (Pfad 3)), ITEM_PRICE (Pfad 5)) jedoch nur einmal berechnet.

Pfad 1: GLOBAL_DEFINITION
Pfad 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
Pfad 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
Pfad 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
CREDIT_SURCHARGE_CLEARING 1..∞
In diesem Element wird ein Wertebereich der Wertestaffel definiert.
Sequence
ITEM_REF

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.
Sequence
COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.

Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.

Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="GRADING_TABLE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>421--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>421--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>421--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLEARING_GROUP_ID">
                          <xs:annotation>
                            <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_FROM">
                          <xs:annotation>
                            <xs:documentation>421--6--Wert_von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_TO">
                          <xs:annotation>
                            <xs:documentation>421--7--Wert_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TYPE_CREDIT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TYPE_DEBIT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>421--9--Type_Belastung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CREDIT_SURCHARGE_CLEARING Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element : CREDIT_SURCHARGE_CLEARING Element
Beschreibung
In diesem Element wird ein Wertebereich der Wertestaffel definiert.
Namensraum (none)
Diagramm
COMPARING_RULES Element ITEM_REF Element Sequence CREDIT_SURCHARGE_CLEARING Element
Overview
CREDIT_SURCHARGE_CLEARING 1..∞
In diesem Element wird ein Wertebereich der Wertestaffel definiert.
Sequence
ITEM_REF

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.
Sequence
COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.

Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.

Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>421--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>421--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>421--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLEARING_GROUP_ID">
                    <xs:annotation>
                      <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_FROM">
                    <xs:annotation>
                      <xs:documentation>421--6--Wert_von</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_TO">
                    <xs:annotation>
                      <xs:documentation>421--7--Wert_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TYPE_CREDIT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TYPE_DEBIT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>421--9--Type_Belastung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element : ITEM_REF Element
Beschreibung

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Namensraum (none)
Diagramm
ITEM_REF Element
Overview
ITEM_REF

Dieses Element entspricht einer Type des Verrechnungsblocks. Ein Verrechnungsblock ist eindeutig durch die Type und die Serie definiert. Der Verechnungsblock wird in ITEM (Pfad1) mit der Artikelkennung V=Verrechnungsblock angelegt.
Soll die Werteverrechnung zeitlich eingegrenzt werden, so sind in den Elementen VALID_FROM/VALID_UNTIL des Elementes ITEM (Pfad1) in dem Verrechnungsblock die entsprechenden Daten zu setzen. Dies bedeutet, dass für jeden Zeitraum ein entsprechender Verrechnungsblock anzulegen ist.
Die Daten der Verrechnungspositionen (TYPE_CREDIT und TYPE_DEBIT) werden ignoriert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
TYPE_NO Restriction of xs:string required
In diesem Element wird der Artikelkurzcode eingegeben. (z. B. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird die Seriennummer der referenzierten Serie angegeben. D nonNegativeInteger
P
M [0:99]
Quelle
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>421--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>421--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

COMPARING_RULES Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element : COMPARING_RULES Element
Beschreibung
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.
Namensraum (none)
Diagramm
COMPARING_RULE Element Sequence COMPARING_RULES Element
Overview
COMPARING_RULES 1..∞
Für einen Verrechnungsblock können mehrere Wertebereiche (VALUE_FROM bis VALUE_TO) angelegt werden. Wertebereiche, die innerhalb eines Elementes COMPARING_RULES definiert sind, sind UND-verknüpft. Die Elemente COMPARING_RULES untereinander sind ODER-verknüpft.
Soll für einen Wertebereich keine Gutschrift/Belastung gegeben werden,so sind die Felder TYPE_CREDIT und TYPE_DEBIT wegzulassen.
Sequence
COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.

Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.

Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="COMPARING_RULES" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP_ID">
              <xs:annotation>
                <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_FROM">
              <xs:annotation>
                <xs:documentation>421--6--Wert_von</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_TO">
              <xs:annotation>
                <xs:documentation>421--7--Wert_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TYPE_CREDIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TYPE_DEBIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--9--Type_Belastung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

COMPARING_RULE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element : COMPARING_RULE Element
Beschreibung
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Namensraum (none)
Diagramm
TYPE_DEBIT Element TYPE_CREDIT Element VALUE_TO Element VALUE_FROM Element CLEARING_GROUP_ID Element Sequence COMPARING_RULE Element
Overview
COMPARING_RULE 1..∞
In diesem Element werden die in einer COMPARING_RULES zusammengefassten Bedingungen formuliert, die erst angewendet werden können, wenn die alle erfüllt sind.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.

Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.

Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="COMPARING_RULE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP_ID">
        <xs:annotation>
          <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_FROM">
        <xs:annotation>
          <xs:documentation>421--6--Wert_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_TO">
        <xs:annotation>
          <xs:documentation>421--7--Wert_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TYPE_CREDIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TYPE_DEBIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--9--Type_Belastung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_ID Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : CLEARING_GROUP_ID Element
Beschreibung
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
CLEARING_GROUP_ID Element
Overview
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
Dieses Element identifiziert eine Verrechnungsgruppe, für die eine Summe der Beträge aller Auftragspositionen bestimmt wird. Liegt die errechnete Summe in dem angegebenen Wertebereich, der über die Elemente VALUE_FROM und VALUE_TO definiert ist, so kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden. D nonNegativeInteger
P
M [0:999]
Quelle
<xs:element name="CLEARING_GROUP_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

VALUE_FROM Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : VALUE_FROM Element
Beschreibung
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
VALUE_FROM Element
Overview
VALUE_FROM Restriction of xs:nonNegativeInteger
Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben. 		D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="VALUE_FROM" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--6--Wert_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

VALUE_TO Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : VALUE_TO Element
Beschreibung

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
Namensraum (none)
Typ
Restriction of xs:nonNegativeInteger
Diagramm
VALUE_TO Element
Overview
VALUE_TO Restriction of xs:nonNegativeInteger

Über die Elemente VALUE_FROM und VALUE_TO wird ein Wertebereich definiert. Liegt die für die angegebene Verrechnungsgruppe errechnete Summe in dem angegebenen Wertebereich, kann die Gutschrift (TYPE_CREDIT) oder die Belastung (TYPE_DEBIT) verrechnet werden.
Bei den Bereichsübergängen (VALUE_TO, dann VALUE_FROM) dürfen keine Lücken entstehen. Andernfalls kann für einen fehlenden Wertebereich keine Rabattierung angewendet werden.
Die Werte in den Feldern Wert_von/Wert_bis sind auf den Cent genau anzugeben.

Soll der bis-Wert als unbegrenzt definiert werden, so ist stellvertretend der m amximal mögliche Wert (999999999) einzutragen.

 D nonNegativeInteger
P
M [0:999999999]
Quelle
<xs:element name="VALUE_TO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--7--Wert_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TYPE_CREDIT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : TYPE_CREDIT Element
Beschreibung
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.

Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TYPE_CREDIT Element
Overview
TYPE_CREDIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Gutschrift angegeben. Die Type der Gutschrift wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Gutschriftposition ist identisch mit der Serie des Verrechnungsblocks.
Die Gutschriftstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Gutschrift wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Gutschrifttype sind.

Der Wert der Gutschrift wird im Element ITEM_PRICE (Pfad 2) als negativer Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
Quelle
<xs:element name="TYPE_CREDIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

TYPE_DEBIT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : TYPE_DEBIT Element
Beschreibung
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.

Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Namensraum (none)
Typ
Restriction of xs:string
Diagramm
TYPE_DEBIT Element
Overview
TYPE_DEBIT optional Restriction of xs:string
Hier wird eine Verrechnungsposition als Belastung angegeben. Die Type der Belastungt wird im Element ITEM (Pfad 1) als Verrechnungsposition (ITEM_IDENTIFICATION (Pfad1) = P) angelegt . Die Serie der Belastungsposition ist identisch mit der Serie des Verrechnungsblocks.
Die Belastungstype wird über das Element CALC_GROUP_REF (Pfad 1) einer Kalkulationsgruppe zugeordnet und unterliegt somit der regulären Auftragsberechnung entsprechend der zugeordneten Kalkulationsgruppe. Die Belastung wird dann auf die Betragssumme aller Auftragspositionen gegeben, die in der gleichen Kalkulationsgruppe wie die Belastungstype sind.

Der Wert der Belastung wird im Element ITEM_PRICE (Pfad 2) als positiver Zahlenwert eingetragen.

Die Gutschriftstype (TYPE_CREDIT) und die Belastungstype (TYPE_DEBIT) können beide angelegt werden, ihnen können unterschiedlichen Kalkulationsgruppen zugeordnet sein.

Die Gutschrifts- und die Belastungstype sind in einer Wertestaffel nicht preisgruppenabhängig, sie sind immer programmneutral (PRICE_CLASS (Pfad 1) = 1)

Die Gutschrifts- und die Belastungstype dürfen nur einen Preis in Preisgruppe 1 haben.

Das Planungssystem entscheidet, ob auf dem Auftrag die einzelnen Verrechnungspositionen oder aber nur der Verrechnungsblock als Auftragsposition gelistet wird.

Die Gutschrifts- und die Belastungstype sind nicht Bestandteil der Katalogdaten, diese werden ausschlieslich über die Blockdaten ausgeliefert.

Pfad 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Pfad 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Quelle
<xs:element name="TYPE_DEBIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--9--Type_Belastung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
Siehe auch
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

SET_OF_BLOCK_RULES Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element : SET_OF_BLOCK_RULES Element
Beschreibung
In diesem Element und den Kind-Elementen werden die herstellerspezifischen Regelwerke beschrieben.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence RULE_SET_TEXT Element RULE Element EXCHANGE_ID_GROUP Element Sequence SET_OF_BLOCK_RULES Element
Overview
SET_OF_BLOCK_RULES
In diesem Element und den Kind-Elementen werden die herstellerspezifischen Regelwerke beschrieben.
Sequence
EXCHANGE_ID_GROUP 1..∞
In diesem Element werden die Tauschgruppen definiert. Wenn Tausch-ID 1 (EXCHANGE_ID_1_REF) gegen Tausch-ID 2 (EXCHANGE_ID_2_REF) wechselseitig getauscht werden dürfen, muss dies explizit angegeben werden.
Wenn Artikel mit gleicher Tausch-ID 1:1 untereinander getauscht werden dürfen, muss für diesen Tauschvorgang ein Datensatz angelegt werden.
Sequence
EXCHANGE_ID_1_REF
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RULE 1..99
In diesem Element wird ein herstellerspezifisches Regelwerk definiert.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird ein Zähler von 1-99 für die Regeln im Blockregelwerk angegeben. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
RULE_SET_TEXT languagetexte60999 Complex Type

In diesem Element werden Erläuterungen zu dem Regelwerk angelegt.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="SET_OF_BLOCK_RULES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_1_REF">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>117--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="EXCHANGE_ID_2_REF">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>117--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RULE" maxOccurs="99">
        <xs:annotation>
          <xs:documentation>111--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RULE_TEXT" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="RULE_NO" use="required">
            <xs:annotation>
              <xs:documentation>113--3--Regel_Nr</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_GROUP Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : EXCHANGE_ID_GROUP Element
Beschreibung
In diesem Element werden die Tauschgruppen definiert. Wenn Tausch-ID 1 (EXCHANGE_ID_1_REF) gegen Tausch-ID 2 (EXCHANGE_ID_2_REF) wechselseitig getauscht werden dürfen, muss dies explizit angegeben werden.
Wenn Artikel mit gleicher Tausch-ID 1:1 untereinander getauscht werden dürfen, muss für diesen Tauschvorgang ein Datensatz angelegt werden.
Namensraum (none)
Diagramm
EXCHANGE_ID_2_REF Element EXCHANGE_ID_1_REF Element Sequence EXCHANGE_ID_GROUP Element
Overview
EXCHANGE_ID_GROUP 1..∞
In diesem Element werden die Tauschgruppen definiert. Wenn Tausch-ID 1 (EXCHANGE_ID_1_REF) gegen Tausch-ID 2 (EXCHANGE_ID_2_REF) wechselseitig getauscht werden dürfen, muss dies explizit angegeben werden.
Wenn Artikel mit gleicher Tausch-ID 1:1 untereinander getauscht werden dürfen, muss für diesen Tauschvorgang ein Datensatz angelegt werden.
Sequence
EXCHANGE_ID_1_REF
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Quelle
<xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_1_REF">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>117--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="EXCHANGE_ID_2_REF">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>117--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Siehe auch
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_1_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > EXCHANGE_ID_GROUP Element : EXCHANGE_ID_1_REF Element
Beschreibung
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
Namensraum (none)
Diagramm
EXCHANGE_ID_1_REF Element
Overview
EXCHANGE_ID_1_REF
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Quelle
<xs:element name="EXCHANGE_ID_1_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>117--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
EXCHANGE_ID_GROUP Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_2_REF Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > EXCHANGE_ID_GROUP Element : EXCHANGE_ID_2_REF Element
Beschreibung
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
Namensraum (none)
Diagramm
EXCHANGE_ID_2_REF Element
Overview
EXCHANGE_ID_2_REF
Die Tausch-ID verweist auf eine im Element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS des Hauptkataloges definierte Tauschgruppe. Die Tausch-ID referenziert Kommissions- bzw. Planungsartikel.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required
Das Element E_ID (Tausch-ID) dient als Schlüssel für die Tauschgruppen. Die Werte sind frei wählbar zwischen 1 und 89.
Folgende Sonder-Tausch-ID wurden definiert:
0 = dieses Teil darf nicht getauscht werden
98 = dieses Teil darf nur mit sich selbst getauscht werden.
99 = dieses Teil darf gegen alle anderen Tausch-ID getauscht werden.
Alle verwendeten Tausch-ID müssen angelegt werden. Auch die vordefinierten Tausch-ID müssen hier bei Verwendung angelegt werden.
Die Werte 0, 98 und 99 dürfen nur in den Elementen SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF und PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID verwendet werden. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Quelle
<xs:element name="EXCHANGE_ID_2_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>117--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
EXCHANGE_ID_GROUP Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

RULE Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : RULE Element
Beschreibung
In diesem Element wird ein herstellerspezifisches Regelwerk definiert.
Namensraum (none)
Diagramm
LANGUAGE Element Sequence RULE_TEXT Element Sequence RULE Element
Overview
RULE 1..99
In diesem Element wird ein herstellerspezifisches Regelwerk definiert.
RULE_NO required Restriction of xs:nonNegativeInteger
In diesem Attribut wird ein Zähler von 1-99 für die Regeln im Blockregelwerk angegeben. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Attribute
Name Typ Verwenden Standard Festgelegt Beschreibung
RULE_NO Restriction of xs:nonNegativeInteger required
In diesem Attribut wird ein Zähler von 1-99 für die Regeln im Blockregelwerk angegeben. D nonNegativeInteger
P
M [1:99]
Quelle
<xs:element name="RULE" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RULE_TEXT" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="RULE_NO" use="required">
      <xs:annotation>
        <xs:documentation>113--3--Regel_Nr</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
Siehe auch
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

RULE_TEXT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > RULE Element : RULE_TEXT Element
Beschreibung
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.
Namensraum (none)
Typ
languagetexte60999 Complex Type
Diagramm
LANGUAGE Element Sequence RULE_TEXT Element
Overview
RULE_TEXT languagetexte60999 Complex Type
Mit diesem Text wird erläutert, unter welchen Kriterien innerhalb der Blockabwicklung getauscht werden darf.
Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="RULE_TEXT" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
RULE Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

RULE_SET_TEXT Element
IDM 2.6.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : RULE_SET_TEXT Element
Beschreibung

In diesem Element werden Erläuterungen zu dem Regelwerk angelegt.

Namensraum (none)
Typ
languagetexte60999 Complex Type
Diagramm
LANGUAGE Element Sequence RULE_SET_TEXT Element
Overview
RULE_SET_TEXT languagetexte60999 Complex Type

In diesem Element werden Erläuterungen zu dem Regelwerk angelegt.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Quelle
<xs:element name="RULE_SET_TEXT" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
Siehe auch
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.6.0 Block XML-Schema


%%ItemTitle%%

IDM 2.6.0 Block XML-Schema Dokumentation
Datentypen
Ansicht mit Navigationswerkzeuge

Für die sprachabhängigen wurden eigene Datentypen definiert.


%%LocalItemTitle%%

languagetexte Complex Type
IDM 2.6.0 Block XML-Schema : languagetexte Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte Complex Type
Overview
languagetexte

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten beliebiger Länge.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P
M
Verwendet von
EXTERNAL_NAME Element
TOOL_TIP Element
FULL_TEXT Element
Quelle
<xs:complexType name="languagetexte" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT" type="xs:string">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

languagetexte30 Complex Type
IDM 2.6.0 Block XML-Schema : languagetexte30 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte30 Complex Type
Overview
languagetexte30

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 30.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [1:3]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,30}
M [1:30]
Verwendet von
CATALOG_NAME Element
Quelle
<xs:complexType name="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 30stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,30}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

languagetexte40 Complex Type
IDM 2.6.0 Block XML-Schema : languagetexte40 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte40 Complex Type
Overview
languagetexte40

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 40.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,40}
M [1:40]
Verwendet von
INTERNAL_NAME Element
Quelle
<xs:complexType name="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 40stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,40}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

languagetexte60 Complex Type
IDM 2.6.0 Block XML-Schema : languagetexte60 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte60 Complex Type
Overview
languagetexte60

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten der Länge 60.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Verwendet von
CLEARING_GROUP_NAME Element
PRODUCT_GROUP_TEXT Element
RESTRICTION_NAME_TEXT Element
Quelle
<xs:complexType name="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>265--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,60}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM 2.6.0 Block XML-Schema


%%LocalItemTitle%%

languagetexte60999 Complex Type
IDM 2.6.0 Block XML-Schema : languagetexte60999 Complex Type
Beschreibung

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten bstehend aus bis zu 999 Zeilen der Länge 60.

Namensraum (none)
Diagramm
LANGUAGE Element Sequence languagetexte60999 Complex Type
Overview
languagetexte60999

Dieser Datentyp dient dem Anlegen von mehrsprachigen Texten bstehend aus bis zu 999 Zeilen der Länge 60.

Sequence
LANGUAGE 1..∞
In diesem Element werden die Texte mehrsprächig hinterlegt. Für jede Sprache wird ein Element angelegt. Die Sprache wird mit dem Attribut ISO_LANGUAGE_ID angegeben. An jedem Element im Datenbestand müssen die gleichen Sprachen hinterlegt werden. Sie müssen mit den Elementen ISO_LANGUAGE_ID unterhalb von T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION übereinstimmen.
ISO_LANGUAGE_ID required Restriction of xs:language
In diesem Attribut wird der ISO-Code der Sprache angegeben, in der der Text hinterlegt wird. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
In diesem Element wird eine Textzeile hinterlegt.
In dem Attribut SEQUENCE_NO wird die Reihenfolge der Textzeile angegeben. Die Reihenfolge der Textzeile muss angegeben werden, da nicht sichergestellt werden kann, dass bei der Verarbeitung der XML-Daten die ursprünglich hinterlegte Reihenfolge der Elemente erhalten bleibt.

Das Element TEXT beinhaltet den Text.
SEQUENCE_NO required Restriction of xs:positiveInteger
Dieses Attribut definiert die Reihenfolge der Textzeile in einem mehrzeiligen Text. Bei einem einzeiligen Text wird der Wert 1 eingetragen. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
In diesem Element wird der Text in der Sprache hinterlegt, die durch das Attribut ISO_LANGUAGE_ID im Element LANGUAGE angegeben ist. D string
P [\S ]{1,60}
M [1:60]
Verwendet von
CATALOG_INFO Element
PLANNING_ADVICE Element
RULE_TEXT Element
RULE_SET_TEXT Element
Quelle
<xs:complexType name="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelligen Zeilen</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT_LINE" maxOccurs="999">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="TEXT">
                  <xs:annotation>
                    <xs:documentation>265--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[\S ]{1,60}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
              </xs:sequence>
              <xs:attribute name="SEQUENCE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>150--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger" />
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
IDM 2.6.0 Block XML-Schema