%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Introduction
View with Navigation Tools

IDM 2.7.0 Block XML-Schema

Documentation

last revised 01/05/2019

Documented XML schema:

IDM_2_7_0_Block.xsd

Contact

DCC e. V.
Dr.-Ing. Olaf Plümer
E-Mail pluemer@dcc-moebel.org

Telephone +49 (0) 52 21/12 65-37


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
The basic structure of the IDM schema
View with Navigation Tools
Introduction > The basic structure of the IDM schema

The basic structure of the IDM schema

The main element T_NEW_BLOCK defines that a new and complete multi-manufacturer catalogue data pool is made available.

XML files must be UTF-8 encrypted.

The IDM schema is subdivided in data ranges that are specified in the subsequent child-elements (see figure 1) in T_NEW_BLOCK.

Figure 1 - child elements in T_NEW_BLOCK

The data ranges are not used in isolation from each other. In some data ranges, data is initially created and used from other data ranges via referencing.

Description of the data ranges

CATALOG

CATALOG is used to store administrative information concerning the data pool. E.g. the version of the data format, release date or the unique identification of the data pool.

SUPPLIER

SUPPLIER is used to store administrative information about the manufacturer. Example: specification of contact data, EDI communication parameters or the manufacturer's country of origin.

GLOBAL_DEFINITION

The GLOBAL_DEFINITION data range is a kind of data pool for information used in the other data ranges. Example: It is used to create settlement groups or information about media.

SERIES

SERIES is used to store the data for the description of the blocks. All items (blocks) are assigned to a product group.

FEATURE_DEFINITION

FEATURE_DEFINITION serves the purpose of defining assessment procedures (RESTRICTIONS).

BLOCK_VALUE_CALCULATION

BLOCK_VALUE_CALCULATION is used to store information for the block and onward settlement. Example: Data for rules on block prices (SET_OF_BLOCK_RULES), block conditions(BLOCK_CONDITIONS), or value tables (GRADING_TABLE) can be stored.


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Elements of the catalogue structure
View with Navigation Tools
Introduction > Elements of the catalogue structure

Creating elements of the catalogue structure

The basic prerequisite for a block XML file are catalogue data with information on series, ranges, version types, versions, price fields and item data in an existing file.

Based on this, the data provisioning for the blocks including their components and prices can take place in accordance with the catalogue information.

Creating block information

Block information are created in the following element:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The element ITEM has a multitude of elements used to describe the properties of a block. A block is identified via the attribute TYPE_NO.

Please note that depending on the series, an item may have different properties. Consequently, an item and its properties can only be unequivocally identified in combination with the series.

The individual items of the block are then specified within the BLOCK_PARTS element.


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Arranging the catalogue structure
View with Navigation Tools

Arranging the catalogue structure

Assigning ranges to series

Ranges are assigned to series in the following element:

SERIES/SERIE/RESTRICTION_REF

The range is assigned to the series by referencing an assessment procedure that defines the range as a valid combination.

The element to describe the range properties is:

FEATURE_DEFINITION/OPTION_DEFINITION/STYLE

Assigning items to series and ranges

Item-series assignment

Items are automatically assigned to series because the ITEM element is a child element of the SERIES element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Item-range assignment

Range-specific items are principally available in all ranges assigned to the series in which the item is defined. If ranges are to be excluded for a certain item, corresponding item-specific assessment procedures for the item must be referenced:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

A suitable assessment procedure that excludes a range if referenced by an item is illustrated in the following example.

Example: Assessment procedure for item-range assignment

Element: FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="A1">

<FEATURE_REF FEATURE_NO="1"/>

<OPTION_REF OPTION_NO="A1"FEATURE_NO="1"/>

<TEST_ID>0</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

The above example shows an assessment procedure in which the referenced version defines a prohibited combination. The associated version definition can look like the following example:

The references range version:

Element: FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_NO="A1"FEATURE_NO="1">

<STYLE_REF STYLE_NO="A1"/>

</OPTION>

</OPTIONS>

</FEATURE>

The applied program property

Element: FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

<STYLE STYLE_NO="A1">

<STYLE_NAME>Paris</STYLE_NAME>

</STYLE>

</OPTION_DEFINITION>


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Catalogue structure
View with Navigation Tools
Introduction > Catalogue structure

Catalogue and element structure

The fundamental catalogue structure of the data pools is arranged as follows:

Figure 1 - Catalogue structure of the data pools

The catalogue structure in the IDM schema is mapped by the following element hierarchy:

Figure 1 - Element hierarchy in the IDM schema

The SERIE element is used to define the properties of a series. The element RESTRICTION_REF is used to assign versions to a series by assessment procedures. Product groups (PRODUCT_GROUPS) in which items with similar version types are combined are defined within the series. The items are automatically assigned to a series because they are child elements of the SERIE element.


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Referencing
View with Navigation Tools
Introduction > Referencing

Referencing of elements

The IDM schema establishes relationships between elements and defines information at a central point which are used on multiple occasions in another position. The reuse of the information and the structure of element relationships takes place via referencing. The type of referencing used in the IDM schema is described in the following.

Definition of terms

The IDM schema uses the following terms for the referencing of elements:

Key element | An XML element referenced by other elements.
Ref element | An XML element referencing other elements.

Referencing procedure

The key element has attributes that allow for its unequivocal identification. The ref element has at least the key attributes of the key element. The reference in which the attribute values of the ref element are identical to those of the key element is established between the elements.

Example: referencing the series from the item

The following example shows how a series (SERIE) is referenced from an item (ITEM). Only some of the XML elements are explained.

Key element

T_NEW_CATALOG/SERIES/SERIE

<SERIES>

<SERIE SERIE_NO="1"/> … </SERIE>

<SERIE SERIE_NO="2"/> … </SERIE>

<SERIE SERIE_NO="3"/> … </SERIE>

. . .

<SERIE SERIE_NO="99"/> … </SERIE>

</SERIES>

Ref element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS>

<ITEM SERIE_NO="1" . . . />

. . .

</ITEMS>

Example: referencing of a version

The following example shows how to reference a version from an assessment procedure.

Key element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="400"> <!-- Sockelausführung -->

<OPTIONS>

<OPTION OPTION_KEY="1"FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="2"FEATURE_NO="400"> … </OPTION>

<OPTION OPTION_KEY="3"FEATURE_NO="400"> … </OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="401"> <!-- Plinth colour-->

<OPTIONS>

<OPTION OPTION_KEY="1"FEATURE_NO="401"> … </OPTION>

<OPTION OPTION_KEY="2"FEATURE_NO="401"> … </OPTION>

<OPTIONOPTION_KEY="3" FEATURE_NO="401"> … </OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

For version type 400 (FEATURE) the XML elements define three versions (OPTION) numbered 1-3, as well as three versions numbered 1-3 for version type 401. A version is identified via the combination FEATURE_NO and OPTION_KEY.

Ref element

/T_NEW_CATALOG/FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION/OPTION_REF

<RESTRICTIONRESTRICTION_NO="1">

<OPTION_COMBINATION>

<OPTION_REFOPTION_KEY="1"FEATURE_NO="400"/>

<OPTION_REFOPTION_KEY="3" FEATURE_NO="401"/>

<OPTION_REFOPTION_KEY="3"FEATURE_NO="400"/>

<OPTION_REFOPTION_KEY="3"FEATURE_NO="401"/>

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

In the XML elements, an assessment procedure for the permitted combinations (TEST_ID=1) of the plinth finishes (FEATURE_NO=400) and the plinth colours (FEATURE_NO=401) is defined. The ref element OPTION_REF with the attributes highlighted in grey in this example references the key element highlighted in grey OPTION.


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Restrictions
View with Navigation Tools
Introduction > Restrictions

Definition and assignment of restrictions

The validity of restrictions may be series specific or comprehensive, programme specific or item specific. The priority of a restriction corresponds with the hierarchy level series -> programme -> item on which the restriction is defined. A restriction defined on item level overrides a restriction which is defined on programme level. Overriding restrictions may only define additional restrictions but not reverse previous restrictions. Example: the availability of an item in a programme is excluded by a restriction defined on item level. A restriction defined on item level may not reverse this exclusion.

First, the restrictions are defined and in a second step they are assigned to series, programmes and items. Definition

Definition of restrictions

Restrictions are defined in the following element:

FEATURE_DEFINITION/RESTRICTIONS/RESTRICTION

The element RESTRICTION references the feature combinations for which the restrictions have been defined. The element OPTION_REF references the feature combinations which are subject to control procedures. The element TEST_ID defines a feature combination as legal or illegal combination.

Example: definition of restrictions

<RESTRICTIONS>

<RESTRICTION RESTRICTION_NO="523" FEATURE_1_NO="100" FEATURE2_NO="101">

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA"FEATURE_NO="100"/>#lacquered

<OPTION_REF OPTION_NO="RO"FEATURE_NO="101"/># red

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="LA"FEATURE_NO="100"/># lacquered

<OPTION_REF OPTION_NO="GR"FEATURE_NO="101"/># green

</OPTION_COMBINATION>

<OPTION_COMBINATION>

<OPTION_REF OPTION_NO="FU"FEATURE_NO="100"/># veneered

<OPTION_REF OPTION_NO="BU"FEATURE_NO="101"/># beech

</OPTION_COMBINATION>

<TEST_ID>1</TEST_ID>

</RESTRICTION>

</RESTRICTIONS>

The above mentioned example shows a restriction which defines a legal feature combination of „front finish" (No. 100) and "front colour" (No. 101). According to the above mentioned restriction the combinations lacquer-red, lacquer-green and beech veneer are permitted (TEST_ID = 1). The listing of permitted combinations (OPTION_REF) has to be in accordance with the sequence defined by the attributes in the element RESTRICTION (FEATURE_1_NO, FEATURE_2_NO)

For the purpose of unique and unambiguous identification of a restrictrion a RESTRICTION_NO) is assigned.

Assignment of restrictions

Series independent restriction

Series independent restrictions are assigned by the following elements:

SERIES/RESTRICTIONS/RESTRICTION_REF

As the element RESTRICTION_REF is a child element of SERIES/RESTRICTIONS, all restrictions referenced in the element RESTRICTION_REF are assigned to all series which are defined in SERIES/SERIE.

Example: Series independent assignment of restrictions

<SERIES>

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1"RESTRICTION_NO="523"/>

<RESTRICTION_REF SEQUENCE="2"RESTRICTION_NO="678"/>

</RESTRICTIONS>

</SERIES>

In the above mentioned example the restrictions 523 and 678 are referenced and assigned to all series.

Series specific assignment

The rules for a series specific assignment of restrictions correspond to that of series independent assignment. the following element is used for the series-specific assignment:

SERIES/SERIE/RESTRICTIONS/RESTRICTION_REF

The restrictions referenced in the element RESTRICTION_REF are assigned to that series in which the reference was made.

Restrictions which are assigned to programmes are one-level restrictions, containing only the feature No. 1( programme). These restrictions are mandatory if series > 0 and feature No. 1 is defined in the database.

Example: Series-specific assignment of restrictions

<SERIES>

<SERIE SERIE_NO="2">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1"RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2"RESTRICTION_NO="67"/>

</RESTRICTIONS>

</SERIE>

<SERIE SERIE_NO="7">

<RESTRICTIONS>

<RESTRICTION_REF SEQUENCE="1"RESTRICTION_NO="45"/>

<RESTRICTION_REF SEQUENCE="2"RESTRICTION_NO="123"/>

</RESTRICTIONS>

</SERIE>

</SERIES>

In the above mentioned example restrictions 45 and 67 are assigned to series "2" and restrictions 45 and 123 are assigned to series "7".

Item specific assignment

A programme specific assignment of restrictions is defined in the following element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/RESTRICTIONS/RESTRICTION_REF

For item specific assignment the sames rules as for series or programme specific assignment apply.

If no restrictions are assigned to an item, this item is available without any restriction regarding series or programme.

Product group specific assignment

The product group specific assignment of restrictions is defined in the following element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/RESTRICTIONS/RESTRICTION_REF

The rules for a product group specific assignment of restrictions correspond with the rules for series and programme specific assignment.


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Data types
View with Navigation Tools
Introduction > Data types

Data types and value ranges

The IDM schema uses the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

The following data types are used:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDM, the data type date is used in conformity with the XML schemas as follows: YYYY-MM-DD YYYY = year, MM = month, DD = day
dateTime | In the IDM, the data type dateTime is used in conformity with the XML schemas as follows: YYYY-MM-DDThh:mm:ssZ YYYY = year, MM = month, DD = day T = Start of time information hh = hour, mm = minute, ss = second Z = UTC time
gYear | In the IDM, the data type gYear is used in conformity with the XML schema as follows: YYYY
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDM for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.56 or -45.98000 or +27.0
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDM for mapping URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used for the specification of valid language codes in the IDM.language represents codes for natural languages as Tags for the Identification of Languagesdefined in the Thevaluerangeof language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.

The value ranges of the above data types are usually restricted for the elements in the IDM. The "restrictions" in the data type definition contains restrictions for minimum and maximum values, permitted characters and value lists.

In the XML documentation of the IDM, the value ranges are specified by the information coming after M and P.

In addition to XML data types mentioned here, separate data types are defined for the texts.

They are explained at the end of the documentation.

See Also
languagetexte Complex Type
languagetexte30 Complex Type
languagetexte40 Complex Type
languagetexte60 Complex Type
languagetexte60999 Complex Type


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Notes to the documentation
View with Navigation Tools
Introduction > Notes to the documentation

Notes to the IDM documentation

Notes to the IDM documentation schema are stored in this section.

Explanation of the element properties

Each element is documented on the basis of a description and its properties. The following shows an example for an element description:

EXCHANGE_ID_NO Attribute

Description

This attribute identifies a swap-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]

The element properties are documented on the right side. They have the following meaning:

D | The data type of the element is documented here. If this position is left blank, the element does not contain any reference data but additional child-elements.
P | The entries made in P and M document the value range of an element. A regular expression that defines the permitted values must be entered in P.
M | The minimum and maximum permitted values must be entered in M. In the case of a string data type, P defines the permitted characters and M the minimum and maximum character length. In the case of a numeric data type, the permitted minimum and maximum value is defined.


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Variation types
View with Navigation Tools
Introduction > Variation types

Variation type | Variation text | Option type | Remark
1 | programm/ style | A | programm asvariation type
2 | serial number | A | assignment of a five-digit serial number
100 | Front finish | A |
101 | Front colour 1 | F | Front filling smooth = complete surface
102 | Front colour 2 | F | Frame
103 | Front colour 3 | F | Pilaster strips
104 | Edge colour front | F |
105 | Front combination | K | If only one key is used for different front information
106 | Front group | A | Overrides the FRONT_GROUP_NO in element FEATURE_DEFINITION/OPTION_DEFINITION/STYLE
110 | Front finish contrast colour 1 | A |
111 | Front colour 1 contrast colour 1 | F | Front filling smooth = complete surface
112 | Front colour 2 contrast colour 1 | F | Frame
113 | Front colour 3 contrast colour 1 | F | Pilaster strips
114 | Edge colour front, contrast colour 1 | F |
115 | Front combination, contrast colour 1 | K | The variations 111 - 114 are permitted.
120 | Front finish contrast colour 2 | A |
121 | Front colour 1 contrast colour 2 | F | Front filling smooth = complete surface
122 | Front colour 2 contrast colour 2 | F | Frame
123 | Front colour 3 contrast colour 2 | F | Pilaster strips
124 | Edge colour front, contrast colour 2 | F |
125 | Front combination, contrast colour 2 | K | The variations 121 - 124 are permitted.
150 | Glass finish | A |
151 | Glass colour | F |
152 | Mullion type | A |
153 | Mullion colour | F |
154 | Type glass door frame | A |
155 | Colour glass door frame | F |
160 | Type roller shutter | A |
161 | Colour roller shutter | F |
170 | Type container | A |
171 | Colour container | F |
200 | Type carcase | A |
201 | Carcase combination | K | If only one key is used for several – interior /exterior - carcase colours
202 | Exterior carcase colour | F |
203 | Interior carcase colour | F |
204 | Edge carcase | A |
205 | Edge colour carcase | F |
206 | Type visible side | A |
207 | Colour visible side | F |
208 | Interior carcase colour for glass door cabinets | F | Glass door cabinets and open cabinets, which are not a shelf .
209 | Interior carcase for glass door cabinets | A | Glass door cabinets and open cabinets, which are not a shelf .
300 | Type handle | A |
301 | Handle colour 1 | F | Colour handle, knob or main colour
302 | Handle colour 2 | F | Colour bow, railing, or knob handles
303 | Combination of handles | K | If only one key is defined for several handle conditions
304 | Handle positions | NULL | cf. handle positions p. 5-23
400 | Type plinth | A |
401 | Plinth colour | F |
402 | Plinth height | A |
410 | Type plinth bottom | A |
411 | Colour plinth bottom | F |
500 | Type shelves | A |
501 | Colour shelves | F |
502 | Type cornice | A | Includes shape and material
503 | Colour cornice | F |
504 | Type light pelment | A | Includes shape and material
505 | Colour light pelmet | F |
506 | Type ceiling filler | A |
507 | Colour ceiling filler | F |
508 | Type filler | A | Bottom ledge
509 | Colour bottopm ledge | F | Bottom ledge
510 | Type gallery shelf | A |
511 | Colour gallery shelf | F |
512 | Type gallery shelf edge | A |
513 | Colour gallery shelf edge | F |
514 | Type board | A |
515 | Colour board | F |
516 | Type board edge | A |
517 | Colour board edge | F |
520 | Type side panels/ bars | A |
521 | Colour side panels/ bars | F |
522 | Type bar panel edge | A |
523 | Colour bar panel edge | F |
524 | Type bottom shelf | A |
525 | Colour bottom shelf | F |
526 | Type bottom shelf edge | A |
527 | Colour bottom shelf edge | F |
550 | Type recess | A |
551 | Colour recess | F |
560 | Type recess accessories | A |
561 | Colour recess accessories | F |
562 | Type pilaster | A |
563 | Colour pilaster | F |
564 | Type pilaster edge | A |
565 | Colour pilaster edge | F |
600 | Type worktop | A |
601 | Colour worktop | F |
602 | Type worktop edge | A |
603 | Colour worktop edge | F |
604 | Type countertop | A |
605 | Colour countertop | F |
606 | Type countertop edge | A |
607 | Colour countertop edge | F |
620 | Type cover shelf | A |
621 | Colour cover shelf | F |
622 | Type cover shelf edge | A |
623 | Colour cover shelf | F |
624 | Type attachment table | A |
625 | Colour attachment table | F |
626 | Type attachment table edge | A |
627 | Colour attachment table edge | F |
650 | Type worktop upstand | A | Worktop upstand profile
651 | Colour worktop upstand | F | Worktop upstand profile
700 | Type drawer | A | Interior equipment
701 | Colour drawer | F | Interior equipment
702 | Type pull-out | A | Interior equipment
703 | Colour pull-out | F | Interior equipment
750 | Shape worktop | S |
751 | Shape cornice | S |
752 | Shape light pelmet | S |
753 | Shape plinth | S |
754 | Shape worktop upstand | S |
755 | Shape cover shelf | S |
756 | Shape countertop | S |
800 | Type electrical appliance | A |
801 | Colour electrical appliance | F |
802 | Colour electr. appliances accessories | F |
850 | Type sink | A |
851 | Colour sink | F |
852 | Colour sink accessories | F |
853 | Colour mixer taps | F |
854 | Type mixer taps | A |
900 | Type general accessories | A |
901 | Colour general accessories | F |
930 | additional, graphical relevant information about type 1. | A | The software suppliers have to be informed separately about the meaning.
931 | additional, graphical relevant information about colour 1. | F | The software suppliers have to be informed separately about the meaning.
932 | additional, graphical relevant information about type 2. | A | The software suppliers have to be informed separately about the meaning.
933 | additional, graphical relevant information about colour 2. | F | The software suppliers have to be informed separately about the meaning.
934 | additional, graphical relevant information about type 3. | A | The software suppliers have to be informed separately about the meaning.
935 | additional, graphical relevant information about colour 3. | F | The software suppliers have to be informed separately about the meaning.
936 | additional, graphical relevant information about type 4. | A | The software suppliers have to be informed separately about the meaning.
937 | additional, graphical relevant information about colour 4. | F | The software suppliers have to be informed separately about the meaning.
938 | additional, graphical relevant information about type 5. | A | The software suppliers have to be informed separately about the meaning.
939 | additional, graphical relevant information about colour 5. | F | The software suppliers have to be informed separately about the meaning.
950 | Type miscellaneous 1 | A |
951 | Colour miscellaneous 1 | F |
952 | Type miscellaneous 2 | A |
953 | Colour miscellaneous 2 | F |
954 | Type miscellaneous 3 | A |
955 | Colour miscellaneous 3 | F |
956 | Type miscellaneous 4 | A |
957 | Colour miscellaneous 4 | F |
958 | Type miscellaneous 5 | A |
959 | Colour miscellaneous 5 | F |
960 | Type miscellaneous 6 | A |
961 | Colour miscellaneous 6 | F |
962 | Type miscellaneous 7 | A |
963 | Colour miscellaneous 7 | F |
964 | Type miscellaneous 8 | A |
965 | Colour miscellaneous 8 | F |
966 | Type miscellaneous 9 | A |
967 | Colour miscellaneous 9 | F |
968 | Type miscellaneous 10 | A |
969 | Colour miscellaneous 10 | F |
970 | Type miscellaneous 11 | A |
971 | Colour miscellaneous 11 | F |
972 | Type miscellaneous 12 | A |
973 | Colour miscellaneous 12 | F |
974 | Type miscellaneous 13 | A |
975 | Colour miscellaneous 13 | F |
976 | Type miscellaneous 14 | A |
977 | Colour miscellaneous 14 | F |
978 | Type miscellaneous 15 | A |
979 | Colour miscellaneous 15 | F |
980 | Type miscellaneous 16 | A |
981 | Colour miscellaneous 16 | F |
982 | Type miscellaneous 17 | A |
983 | Colour miscellaneous 17 | F |
984 | Type miscellaneous 18 | A |
985 | Colour miscellaneous 18 | F |
986 | Type miscellaneous 19 | A |
987 | Colour miscellaneous 19 | F |
988 | Type miscellaneous 20 | A |
989 | Colour miscellaneous 20 | F |
999 | Fixed material assignment | F |

Type: A = type

F = colour

K = Combination

S = shape

</


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Type key
View with Navigation Tools
Introduction > Type key

Type-No. | Denotation
1 | Base cabinet
2 | Tall cabinet
3 | Wall cabinet
4 | Worktop top cabinet
5 | Recess elements
6 | Highboard
7 | Recess cabinet
8 | Solitaire furniture
9 | Front element
10 | Module element
11 | Cornice profile
12 | Light pelmet
13 | Ceiling filler
14 | Plinth blind
15 | Plinth board
17 | Worktop
18 | Worktop upstand profile
19 | Cover shelf
20 | Gallery shelf
21 | Gallery shelf
22 | Construction shelf
24 | Chimney
26 | Electrical appliance
27 | Gas appliance
28 | Small appliance
29 | Sink
30 | Fitting
35 | Lighting
37 | General Accesories
38 | Miscellaneous
41 | Block
42 | Additional equipment
43 | Value clearing
95 | Recycling fees.
98 | Information as subtext
99 | General text information/ order

Typenschlüssel


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
EquipmentID
View with Navigation Tools
Introduction > EquipmentID
EquipmentID | Denotation
1 | Universal cutter
2 | Bread
3 | Rotating shelf
4 | Bottles
5 | Glass
6 | Towel
7 | Interior drawer/ pull-out
8 | Detergents/broom
9 | Waste sorter system
10 | Swivel mechanism
11 | Extractable table
12 | Larder
13 | Linen
14 | Spice
16 | Dryer
17 | Cooker
18 | Oven
19 | Hob
20 | Ceramic hob
21 | Extractor hood
22 | Extractor
23 | Extractor element
24 | Microwave
25 | Dishwasher
26 | Freezer
27 | Fridge
28 | Washing machine
29 | Control panel
30 | Double oven
31 | Sink
32 | Steam cooker
33 | Warming zone
34 | Grill
35 | Fryer Fryer
36 | Chopping board
37 | Coffee machine
41 | Fridge/ freezer combination
42 | Oven-Microwave combination
43 | Oven/ Warming
46 | Low pressure
47 | High pressure


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Installation information key
View with Navigation Tools
Introduction > Installation information key


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Material key
View with Navigation Tools
Introduction > Material key


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Shape key
View with Navigation Tools
Introduction > Shape key


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Front appearance ID
View with Navigation Tools
Introduction > Front appearance ID


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Type key arts
View with Navigation Tools
Introduction > Type key arts


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Language key
View with Navigation Tools
Introduction > Language key


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Country code
View with Navigation Tools
Introduction > Country code

country code | country (German) | country (English)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Buying associations
View with Navigation Tools
Introduction > Buying associations

Buying association customer | Name buying association | Street | Postal Code | City | Phone | Fax
AMBRA | AMBRA Vertriebsgesellschaft mbH & Co. KG | Pfälzer Straße 10 | 33332 | Gütersloh | +49(5241)9246-0 | +49(5241)9246-49
AMM | Alliance Möbel-Marketing GmbH & Co.KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
ANT | ANTARES Einkaufs- und Marketinggesellschaft GmbH & Co. KG | Ramlinger Str. 50 | 31303 | Burgdorf-Ehlershausen | +49(5085)955887 | +49(5085)-955885
ASSIMA | ASSIMA Verbund GmbH & Co. KG | Bussardweg 18 | 41468 | Neuss | +49(2131)310400 | +49(2131)310469
ATLAS | Atlas-Einrichtungs-Einkauf GmbH | Brunshofstr. 2 | 45470 | Mülheim a. d. Ruhr | +49(208)992400 | +49(208)9924099
AWD | AWD Einkaufs- und Marketinggesellschaft für Wohnkomfort mbH | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
BAUR | Baur Friedrich GmbH Zentraleinkauf | Bahnhofstr. 10 | 96224 | Burgkunstadt | +49(9572)912739 o. 912746 | +49(9572)912006
BEGROS | Begros GmbH | Graf-Zeppelin-Str. 5 | 46149 | Oberhausen | +49(208)99493-0 | +49(208)99493-911
BETTENKREIS | BETTENKREIS GmbH & Co. | Pascalstr. 4 | 47506 | Neukirchen-Vluyn | +49(2845)9134-0 | +49(2845)9134-34
BETTENRING | BETTENRING eG | Echterdinger Str. 115 | 70794 | Filderstadt | +49(711)70958-0 | +49(711)70958-66
BRANION | BRANION GmbH | Soennecken-Platz | 51491 | Overath | +49(2206)607-0 | +49(2206)607-199
BÜRORING | BÜRORING eG | Siemensstr. 7 | 42781 | Haan | +49(2129)5571-0 | +49(2129)5571-93
CI | Createive Inneneinrichter | Spreestr. 3 | 64295 | Darmstadt | +49(6151)39128-0 | +49(6151)39128-28
CON | Concorde Möbel-Einkaufs-GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | 0211-47236-0 | 0211-4180034
CP | CREATIVE PARTNEr Service- und Einkaufs-Kooperation GmbH | Otto-Hahn-Str. 6 d | 21509 | Glinde | +49(40)728161-0 | +49(40)728161-21
DKR | Der Küchenring GmbH & Co. KG | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
DMV | DEUTSCHER MÖBEL-VERBUND Handels GmbH | Ampertal 8 | 85777 | Fahrenzhausen-Unterbruck | +49(8133)89-0 | +49(8133)-89-199
DSM | Drosser & Schaffer Marketing GmbH | Würmstr. 13A | 82166 | Gräfelfing | +49(89)89878434/-26 /-28 | +49(89)89878440
DU | DECOR UNION GmbH & Co. KG | Brüsseler Str. 3 | 30539 | Hannover | +49(511)8789-0 | +49(511)8789-299
EBUCH | ebuch eG | O'Brien-Str. 3 | 91126 | Schwabach | +49(9122)9386-0 | +49(9122)9386-68
EDE | Einkaufsbüro Deutscher Eisenhändler GmbH | Dieselstr. 33 | 42389 | Wuppertal | +49(202)6096-0 | +49(202)6096-331
EGEPACK | EGEPACK Einkaufs- und Vertriebsgesellschaft mbH | Bödekerstr. 7 | 30161 | Hannover | +49(511)38841-03 / -04 | +49(511)3884064
EIS | E.I. S. GmbH | Von-Hünefeld-Str. 41 | 50829 | Köln | +49(211)59797-44 / -45 | +49(211)59797-21
EK | Grosseinkauf eG | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-144
EKAFLOR | ekaflor GmbH & Co. KG | Watzmannstr. 3 | 90471 | Nürnberg | +49(911)981166-0 | +49(911)981166-5
ELTKONTOR | ELTKONTOR GmbH & Co. KG | Oldenburger Allee 21 | 30659 | Hannover | +49(511)61599-0 | +49(511)61599-77
EM | Europa Möbel | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EMV | Europa Möbel-Verbund (EMV) | Ampertal 8 | 85777 | Fahrenzhausen-Unterbrück | +49(8133)89-0 | +49(8133)89-199
ESG | ESG Einkaufs- und Service Gesellschaft mbH | Berliner Str. 26 | 33378 | Rheda-Wiedenbrück | +49(5242)9453-0 | +49(5242)9453-53
EUROKON | EUROPA-KONTOR GmbH & Co. KG | Amsterdamer Str 230 | 50735 | Köln | +49(221)971491-21 | +49(221)971491-60
EUROPA | GROSSEINKAUF EUROPA MÖBEL GmbH & Co. KG | Siegburger Str. 37 | 53757 | St. Augustin | +49(2241)164-0 | +49(2241)164-181
EVB | EVB BauPunkt Einkaufs- und Handelsgemeinschaft GmbH & Co. KG | Zillenhardtstr. 46 | 73037 | Göppingen | +49(7161)99931-70/ -71 | +49(7161)99931-72
EWEPA | E W E P A GmbH | Oberevinger Str. 5 | 44339 | Dortmund | +49(231)985127-0 | +49(231)-985127-17 / -18
FHG | FHG Fach-Handels-gesellschaft mbH & Co. KG | Brühler Str. 55/58 | 42657 | Solingen | +49(212)24809-0 | +49(212)24809-119
FHR | F H R Fachhandelsring GmbH | Am Pfaffensee 4 | 67376 | Harthausen | +49(6344)9533-0 | +49(6344)9533-90
FS | "FÜR SIE" Handelsgenossenschaft eg Food-Non Food | An der Münze 12-18 | 50668 | Köln | +49(221)16041-0 | +49(221)16041-821
GARANT | GARANT-MÖBEL-MARKETING LAUTEN GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
GEDK | Ge-dk Unternehmensbetreuungsgesellschaft mbH | Includes shape and material | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
GFM | G f M Möbeleinkaufsverbund GmbH & Co. Betriebs KG | Donaustr. 15 | 93333 | Neustadt a. d. D. | +49(9445)204-0 | +49(9445)204-155
HBO | H.B.O. Einkauf + Marketing GmbH & Co. | Dietrichsweg 64 | 26127 | Oldenburg | +49(441)96182-0 | +49(441)96182-55
HIS | Home in style Raumgsestaltung GmbH & Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-370 | +49(7231)915-259
HLH | HolzLand Holzhandels GmbH | Friedrich-Engels-Allee 432 | 42283 | Wuppertal | +49(202)55138-0 | +49(202)55138-10
HOLZRING | DER HOLZRING Handelsgesellschaft mbH | Universitätsallee 5 | 28359 | Bremen | +49(421)22315-0 | +49(421)22315-11
INKU | INKU GmbH + Co. | Nikolaus-Otto-Str. 6 | 70771 | Leinfelden-Echterdingen | +49(711)9492-438 | +49(711)9192-436
KA | K + A Küchen Aktuell GmbH | Senefelder Str. 2 a | 38124 | Braunschweig | +49(531)26134-0 | +49(531)26134-39
KAK | Küchen-Aktiv-Kreis | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KAREAL | Küchen Areal GmbH & Co. KG | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-163 | +49(5242)409-202
KARST | Karstadt Warenhaus AG | Theresienhöhe 5 | 80339 | München | +49(89)5105-0 | +49(89)5105-300
KATAG | KATAG International Partners GmbH | Stralsunder Str. 5 | 33605 | Bielefeld | +49(521)292-0 | +49(521)292-101/299
KAUFRING | KAUFRING AG | Kieshecker Weg 100 | 40468 | Düsseldorf | +49(211)4242-0 | +49(211)4242-444
KC | Küche & Co |  |  |  |  |
KER | Küchen-Einkaufs-Ring | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)409-202
KGA | Koop Garant/Areal: EK-Grosseinkauf | Elpke 109 | 33605 | Bielefeld | +49(521)2092-0 | +49(521)2092-559
KIG | Küchen-Interessen-Gesellschaft mbH | Strauberger Platz 19 | 10243 | Berlin | +49(30)2934709-0 | +49(30)2934709-13
KL | Küchenliga | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
KOA | Koop Alliance FUTURA einkaufs-Gesellschaft mbH & Co. KG | Rolshoverstr. 227 | 51072 | Köln-Poll | +49(221)9836666 | +49(221)9836667
KP | Küchen Partner AG | Rüdesheimer Str. 34 | 65239 | Hochheim am Main | +49(6146)8340-0 | +49(6146)8340-40
KREIS | "DER KREIS" Einkaufsgesellschaft für Küche & Wohnen mbH & Co. KG | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)606700 | +49(7152)73017
KTEM | KTEM | Heemstr. 4 | 27793 | Wildeshausen | +49(4431)92067 | +49(4431)92069
LGF | MeisterTeam LGF GmbH | Rotenhäuser Str. 12 | 21109 | Hamburg | +49(40)7534091 | +49(40)7522019
LUTZ | LUTZ |  |  |  |  |
MBV | MBV Marketing Gesellschat mbH & Co. Lichthauspartner KG | Zeiloch 13 | 76643 | Bruchsal | +49(7251)7240890 | +49(7251)72408979
MDM | Küchenmarketing MDM GmbH | Hauptstr. 143 | 33378 | Rheda-Wiedenbrück | +49(5242)409-0 | +49(5242)45640
MHKD | musterhaus küchen Deutschland GmbH & Co. KG | Im Gefierth 9a | 36603 | Dreieich | +49(6103)391-0 | +49(6103)391-109
MIG | MIG Möbel-Interessen-Gemeinschaft GmbH & Co. KG | Industriestr. 41 | 53359 | Rheinbach | +49(2226)9221-0 | +49(2226)9221-22
MKK | Fachhändler Gemeinschaft "meister.Küchen-Konzepte" | Marie-Curie-Str. 6 | 53359 | Rheinbach | +49(2226)904-0 | +49(2226)904-155
MM | Möbel Mann GmbH | Durlacher Allee 109 | 76137 | Karlsruhe | +49(721)6096-298 | +49(721)6096-557
MON | Mondial GmbH | Eichsfelder Str. 17 | 40595 | Düsseldorf (Garath) | +49(211)702621-13 | +49(211)702621-30
MP | www.mig-power.de GmbH & Co.KG | Aktienstr. 2 | 45359 | Essen | +49(201)811710 | +49(201)2699838
MSI | Musterring International Josef Höner GmbH & Co. KG | Hauptstr. 134-140 | 33378 | Rheda-Wiedenbrück | +49(5242)592-01 | +49(5242)592-149
MV | Mega Verbund AG | St- Alban-Vorstadt 94 | CH-4052 | Basel | +41(61)2069070 | +41(61)-2069079
MZE | M Z E - Möbel-Zentral-Einkauf GmbH | Loheg 31 | 85375 | Neufarn b. Freising | +49(8165)9526-0 | +49(8165)9526-50
NB | Nürnberger Bund Grosseinkauf eG | Theodor-Althoff-Str. 39 | 45133 | Essen | +49(201)8709-0 |
NECK | Neckermann Versand AG | Hanauer Landstr. 360-400 | 60386 | Frankfurt/Main | +49(69)404-8697 | +49(69)404-8508
NOWEDA | NOWEDA eG | Heinrich-Strunk-Str. 77 | 45143 | Essen | +49(201)802-0 | +49(201)802-1314
NREM | nrc Nordring Einkauf- und Marketing-Cooperation GmbH | Am Redder 1 | 24558 | Henstedt-Ulzburg | +49(4193)9585-0 | +49(4193)9585-25
NWH | NORDWEST Handel AG | Berliner Str. 26-36 | 58135 | Hagen | +49(2331)461-0 | +49(2331)461-389
ÖkoPlus | ÖkoPlus AG Fachhandelsverbund für Ökologisches Bauen + Wohnen | Kasseler Str. 1 A | 60486 | Frankfurt | +49(69)70793013 | +49(69)70793016
OTTO | Otto Versand | Wandsbecker Str. 3-7 | 22179 | Hamburg | +49(40)64610 | +49(40)64618571
PARMA | parma-Aurel GmbH & Co. KG | Grosse-Kurfürsten-Str. 75 | 33615 | Bielefeld | +49(521)52077-0 | +49(521)52077-77
PRISMA | PRISMA Einkaufs- und Marketinggesellschaft mbH | Amsterdamer Str. 230 | 50735 | Köln | +49(221)971410-9 | +49(221)971410-84
ProÖko | Pro Öko Servicegesellschaft ökologischer Einrichtungshäuser mbH | Subbelrather Str. 24 | 50823 | Köln | +49(221)56968-0 | +49(221)56968-21
QUE | Grossversandhaus Quelle, Gustav Schickedanz KG | Thomas-Mann-Str. 50 | 90329 | Nürnberg 50 | +49(911)8152150 | +49(911)8152036
RED | Reddy Küchen und Elektro Vertriebs GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +49(6103)391-119
REGENT | REGENT MÖBEL Grosseinkauf GmbH & Co. KG | Benzstr. 4 | 45891 | Gelsenkirchen | +49(209)9705-0 | +49(209)9705-188
SHK | S H K Einkaufs- und Vertriebsgesellschaft mbH & Co. KG | Im Zeiloch 13 | 76646 | Bruchsal | +49(7251)724088-0 | +49(7251)724088-89
SOFATEX | sofatex Leistungsgemeinschaft GmbH | E.-C.-Baumann-Str. 12 | 95326 | Kulmbach | +49(9221)80064 | +49(9221)80066
SÜDRING | Südring GmbH & Co. KG | Nordstr. 71 | 63450 | Hanau | +49(6181)9104-0 | +49(6181)9104-44
TEV | Textil-Einkaufsverband "NORDWEST" eG | Nordweststr. | 59387 | Ascheberg | +49(2593)818 | +49(2593)7085
TREND | TReND Möbel-Handels-GmbH & Co. Einrichtungs KG | Im Lipperfeld 42 | 46047 | Oberhausen | +49(208)8205-0 | +49(208)8205-210
UNION | UNION Einkaufs GmbH | Kieshecker Weg 148 | 40468 | Düsseldorf-Lohausen | +49(211)47236-0 | +49(211)4180034
UNITEX | u n i t e x Einkaufsverband GmbH | Albrecht-Berblinger-Str. 11 | 89231 | Neu Ulm-Schwaighofen | +49(731)707940 | +49(731)7079446 / 7079424
VAR | Varia KE Franchise Warenvertriebsgesellschaft mbH | Mollenbachstr. 2 | 71229 | Leonberg | +49(7152)6097-25 | +49(7152)73017
VE | Vesta Küchenhandels GmbH | Industriestr. 9 | 96114 | Hirschaid | +49(9543)842330 | +49(9543)842340
VKG | V K G Vereinigter Küchenfachhandel GmbH + Co. KG | Karlsruher Str. 91 | 75179 | Pforzheim | +49(7231)915-0 | +49(7231)915-160
VME | V M E Vereinigte Möbeleinkaufs-GmbH & Co. KG | An der Wesebreede 2 | 33699 | Bielefeld | +49(521)20885-0 | +49(521)20885-60
WGMEM | Wohngruppe Möbeleinkauf + Marketing GmbH | Schleifweg 10 | 74257 | Untereisesheim | +49(7132)9988-0 | +49(7132)9988-44
WK | WK - WOHNEN Einrichtungs-GmbH | Im Gefierth 9a | 63303 | Dreieich | +49(6103)391-0 | +496103)391-109
WOTEX | Wotex Intercolor | Pappelweg 11 | 66578 | Schiffweiler | +49(6821)9614-0 | +49(6821)9614-60

</


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Standard handle orientations
View with Navigation Tools

Standard handle orientation | Denotation | Picture | Description
0 | Without drilling, with handle |  | valid for all types of front
1 | horizontally centred - vertical at outer edge |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertical orientation at outer edge for: doors; glass doors; roller shutters (vertical).
2 | horizontally centred - horizontal at outer edge |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontal orientation at outer edge for: doors; glass doors; roller shutters (vertical).
3 | vertically centred - vertical at outer edge |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertical orientation at outer edge for: doors; glass doors; roller shutters (vertical).
4 | vertically centred - horizontal at outer edge |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontal orientation at outer edge for: doors; glass doors; roller shutters (vertical).
5 | horizontally centred - vertically centred |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertically centred orientation for: doors; glass doors; roller shutters (vertical).
6 | horizontally centred - horizontally centred |  | horizontally centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontally centred orientation for: doors; glass doors; roller shutters (vertical).
7 | vertically centred - vertically centred |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). vertically centred orientation for: doors; glass doors; roller shutters (vertical).
8 | vertically centred - horizontally centred |  | vertically centred orientation for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontally centred orientation for: doors; glass doors; roller shutters (vertical).
9 | Horizontal at the top, full width - horizontal at the top, full width |  | orientation horizontal, full width, for: Drawers; pull-outs; shutters (horizontal). horizontal orientation full width for: doors; glass doors; flap doors; roller shutters (vertical).
10 | horizontal at the bottom of the element, full width - horizontal at the top of the element, full width |  | orientation at the bottom, full width, for: Drawers; pull-outs; flap doors; shutters (horizontal). horizontal orientation full width for: doors; glass doors; roller shutters (vertical).
11 | horizontal at the top, full width - vertical at outer edge, full height |  | orientation horizontal, full width, for: Drawers; pull-outs; flap doors; shutters (horizontal). orientation at the outer edge, full height, for: doors; glass doors; roller shutters (vertical).
12 | horizontal at the bottom, full width - vertical at outer edge, full height |  | orientation at the bottom, full width, for: Drawers; pull-outs; flap doors; shutters (horizontal). orientation at the outer edge, full height, for: doors; glass doors; roller shutters (vertical).
90 | No standard handle orientation applicable. |  |
91 | No standard handle orientation applicable. |  |
92 | No standard handle orientation applicable. |  |
93 | No standard handle orientation applicable. |  |
94 | No standard handle orientation applicable. |  |
95 | No standard handle orientation applicable. |  |
96 | No standard handle orientation applicable. |  |
97 | No standard handle orientation applicable. |  |
98 | No standard handle orientation applicable. |  |
99 | Without drilling, without handle |  |


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Codes for detail information
View with Navigation Tools
Introduction > Codes for detail information

The following info codes can be used to describe the type of detail information:

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
File name
View with Navigation Tools
Introduction > File name

The following is recommended for the file name associated with a data record:

The name of the data record must not be limited to 8 characters.

If possible, all components from the CATALOG_IDENTIFICATION should be used:

The following components are suggested:

Manufacturer number

IDM version

Customer number (value from the ASSOC_CTM_NO element)

All languages

Year

Major number (MIN_MAJOR_NO)

File release timestamp (FILE_RELEASE_DATE)


%%LocalItemTitle%%

Elements
Element | Description
T_NEW_BLOCK | 1000--0--NEWThis element is used for storing and providing all information and data for the issuing of a complete block catalogue/ database.
Complex Types
Complex Type | Description
languagetexte | This data type is used for multilingual text information of any length.
languagetexte30 | Für Texte mit 30stelliger Zeile K. Richter 15.04.2014 This element is used for multilingual text information limited to 30 characters.
languagetexte40 | Für Texte mit 40stelliger Zeile K. Richter 15.04.2014 This element is used for multilingual text information limited to 40 characters.
languagetexte60 | Für Texte mit 60stelliger Zeile K. Richter 15.04.2014 This element is used for multilingual text information limited to 60 characters.
languagetexte60999 | Für Texte mit 60stelligen Zeilen K. Richter 15.04.2014 This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.

© 2020 All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Element reference
View with Navigation Tools


%%LocalItemTitle%%

T_NEW_BLOCK Element
IDM 2.7.0 Block XML-Schema : T_NEW_BLOCK Element
Description
1000--0--NEWThis element is used for storing and providing all information and data for the issuing of a complete block catalogue/ database.
Namespace (none)
Diagram
BLOCK_VALUE_CALCULATION Element FEATURE_DEFINITION Element SERIES Element GLOBAL_DEFINITION Element SUPPLIER Element CATALOG Element Sequence T_NEW_BLOCK Element
Overview
T_NEW_BLOCK
1000--0--NEWThis element is used for storing and providing all information and data for the issuing of a complete block catalogue/ database.
MAJOR required Restriction of xs:positiveInteger
100--3--Versionsnummer Verlegung der Versionierung AK 28.02.2012 K. Richter 25.03.2014
The version number "MAJOR" indicates the format version of the database. This main version number is only changed if the format is changed completely. The complete definition of a format version consists of the following elements: MAJOR, MINOR and REVISION. D nonNegativeInteger
P
M [2]
MINOR required Restriction of xs:nonNegativeInteger
100--4--Sub_Versions_Nr Verlegung der Versionierung AK 28.02.2012
In general the number of the sub-version "MINOR" changes every year. In case the main version number MAJOR is changed, the sub-version number is reset to 0.
 D nonNegativeInteger
P
M [0:99]
REVISION required Restriction of xs:nonNegativeInteger
1000--0--NEW Verlegung der Versionierung AK 28.02.2012
During the year the field revision number "REVISION" indicates changes of the format, as agreed upon in the regular sessions of the committee. The different revisions are not issued unless they are necessary corrections. The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. D nonNegativeInteger
P
M [0:99]
Sequence
CATALOG
100--0--NEW Version Beta 2.0 Build 0All administrative information about the catalogue/ database is stored in this element.
Sequence
FILE_RELEASE_DATE xs:dateTime
100--2--Dateifreigabe Version Beta 2.0 Build 0
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contain the current date and time (UTC). D dateTime
P
M
CATALOG_IDENTIFICATION
100--0--NEW Version Beta 2.0 Build 0This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
100--5--Hersteller_ID Version Beta 2.0 Build 0
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
100--6--Sprachenschluessel Version Beta 2.0 Build 4, K. Richter 21.03.2014
The language code defines the language in which the texts in the data pool were created. The ISO Language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
100--7--Waehrungsschluessel Version Beta 2.0 Build 0
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
100--13--Laender_ID Version Beta 2.0 Build 0
For transnational catalogues with an identical currency key this element is used for assigning a database to one country by the different ISO country codes. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger
Katalog-Art 1 für Basiskatalog 2 für Verbandskatalog 3 für kundenspezifischen Katalog geändert 17.04.2019

This field is used to identify association catalogues.

The following values can be used:
1 = base catalogue
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

 D positiveInteger
P
M [1:3]
ASSOC_CTM_NO optional Restriction of xs:string
100--15--Verband_KD_Nr Version Beta 2.0 Build 0
This element is used to specify the customer number of the Association or customer for which the data pool is available.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
100--40--Produktmarke Version Beta 2.0 Build 0K., K. Richter 25.03.2014
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
100--49--Preis_ID Version Beta 2.0 Build 0
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price
2 = identification number
3 = settlement point.

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
200--4--MwSt Version Beta 2.0 Build 0
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT

This element is very important for pricing. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
100--9--Katalog_Nummer Version Beta 2.0 Build 0
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
CATALOG_YEAR xs:gYear
Jahr der Neuerstellung
This element refers to the calendar year of the catalogue data in the main catalogue. D gYear
P
M
MIN_MAJOR_NO Restriction of xs:positiveInteger
Hauptnummer der Neuerstellung innerhalb eines Jahres
The main catalogue's major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. Element MIN_MAJOR_NO contains the minimum value of thee main catalogues's MAJOR_NO. D positiveInteger
P
M 1:99
CATALOG_NAME languagetexte30 Complex Type
100--10--Katalog_Name Version Beta 2.0 Build 0This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
100--11--Daten_Version Version Beta 2.0 Build 0
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database. D date
P
M
VALID_FROM_DATE Restriction of xs:date
100--12--Gueltig_ab_Datum Version Beta 2.0 Build 0
This element defines the period of validity for the catalogue and corresponding database. D date
P
M
FILE_ID Restriction of xs:boolean
100--14--Datei_ID Version Beta 2.0 Build 0
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
100--43--Katalogkennzeichen Version Beta 2.0 Build 0
This element is used to differ between the possible data types

B = block data with prices
K = catalogue data
V = block data without prices (notional prices are required) 		D string
P [BKV]
M [1:1]
FILLING_LEVEL Restriction of xs:string
100--44--Fuellstufe Version Beta 2.0 Build 0
The filling level (FILLING_LEVEL) defines the level of details which are provided in a database. In general, an increase in the filling level corresponds with an increase in data quality. The higher the degree of detail specification in the data, the more specific they are for a certain manufacturer.
The different filling levels are evaluated during the certification procedure: By checking the filling levels it is ascertained which information is required in the data, in order to achieve the filling level. In case the required information is missing in a filling level, the complete set of data is not certified.
The filling levels are defined as follows:
- Filling level 1: provides basic information except from elements for the description of texture information
- Filling level 2a: filling level 1 is supplemented with information regarding textures and material (colours RGB,transparency and brightness)
- Filling level 2b: filling level 1 is amended with information about front division and front finishes
- Filling level 2c: filling level 1 is supplemented with information about handles.
- Filling level 2d: filling level 1 is amended with information about item textures.

Combinations of filling levels 2a-2d are possible. Following itemized breakdowns of combinations are defined:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Filling level 3. To achieve filling level 3 information in the filling levels 1 and 2a - 2d supplemented by information about the modeling graphic is required. In filling level 3 all options of the data format for manufacturer specific illustrations are entirely applied.
A complete definition of the information required for the different filling levels is provided in the table "Filling levels". 		D string
P [123]|2[a-n]
M [1:2]
PRICING_TERMS optional Restriction of xs:string
100--48--Preisstellung Version Beta 2.0 Build 0, K. Richter 25.03.2014
This element defines the pricing terms for the catalog prices.
A complete definition of the information required for the dThis element defines the pricing terms for the catalog prices. The information in this field is used for a correct data import in order to avoid overwriting of price information.

The following values are used:
0 = prices in the catalogue are purchase prices for dealers
1 = prices in the catalogue are recommended retail prices (UPE)

All price information in the catalogue has to correspond to the information in this element. 		D string
P [01]
M [1:1]
CATALOG_INFO optional languagetexte60999 Complex Type
110--3--Textzeile Version Beta 2.0 Build 0Information texts are stored in this element.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
FALL_BACK_LANGUAGE optional Restriction of xs:language
100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind K. Richter 29.06.2017
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The two-digit ISO language code must be used. D language
P [A-Z]{2}
M [2:2]
SUPPLIER
100--1--Satzart Version Beta 2.0 Build 0All relevant supplier data, e.g. communication and contact details, are stored in this element.
Sequence
CONTACT_PERSON 1..2
100--0--NEW Version Beta 2.0 Build 0All information concerning the contact person is defined in this element.
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
100--0--NEW Version Beta 2.0 Build 2
Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact). D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
100--0--NEW Version Beta 2.0 Build 0
The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute. D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
100--26/33--Ansprechp_Name_1/2 Version Beta 2.0 Build 0
The family name of the direct contact person for the software suppliers is defined in this element. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
100--27/34--Vorname_1/2 Version Beta 2.0 Build 0
The first name of the direct contact person is entered here. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
100--28/35--Anrede_ID_1/2 Version Beta 2.0 Build 0
The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
100--29/36--Abteilung_1/2 Version Beta 2.0 Build 0
If applicable, the department of the contact person is defined in this field. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
100--30/37--Telefon_1/2 Version Beta 2.0 Build 0
This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
100--31/38--Fax_1/2 Version Beta 2.0 Build 0
This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
100--18--E_MAIL_Adresse Version Beta 2.0 Build 4, K. Richter 21.03.2014
This element contains the E-Mail address of the contact person. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
STREET optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
CITY optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
CONTACT_SUPPLIER
100--0--NEW Version Beta 2.0 Build 0All contact information for the specific manufacturer is defined in this element.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
100--16--Herstellername_1 Version Beta 2.0 Build 2
This element contains the first line of the manufacturer's name. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
100--17--Herstellername_2 Version Beta 2.0 Build 2
This element contains the second line of the manufacturer's name. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
100--18--E_MAIL_Adresse Version Beta 2.0 Build 4, K. Richter 21.03.2014
The official E-Mail address of the manufacturer is defined in this element.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string
100--19--Internet_Adresse Version Beta 2.0 Build 4
If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com). D string
P
M
STREET Restriction of xs:string
100--20--Strasse Version Beta 2.0 Build 0
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
100--21--PLZ_Strasse Version Beta 2.0 Build 4
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
CITY Restriction of xs:string
100--22--Ort Version Beta 2.0 Build 0
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
ZIPCODE_POSTBOX optional Restriction of xs:string
100--23--PLZ_Postfach Version Beta 2.0 Build 0
If applicable, the ZIP code of the manufacturer's postbox address is entered here. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
100--24--Postfach Version Beta 2.0 Build 0
If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
100--41--Telefon_Zentrale Version Beta 2.0 Build 0
This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
100--42--Fax_Zentrale Version Beta 2.0 Build 0
This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
GLOBAL_DEFINITION optional
1000--0--NEW Version Beta 2.0 Build 0 AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.This element is used for defining global data which apply to the complete catalogue/ database (global information).
Sequence
CLEARING_GROUP 0..∞
120--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of clearing groups. Different exchange_IDs are summarized and made up to a clearing group (element.

The clearing groups in the block conditions (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) and the grading tables (BLOCK_VALUE_CALCULATION/GRADING_TABLE) are used for the definition of a minimum value for a certain type range. The different type ranges can be identified by their corresponding exchange_ID.

The single amounts of all items which belong to a certain exchange_ID are summarized. A total amount is summed up for each clearing group. This amount is defined as reference value for further use in block calculation and for the value clearing grading table.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
120--1--Satzart Version Beta 2.0 Build 0
This attribute identifies a clearing group. D nonNegativeInteger
P
M [0:999]
Sequence
EXCHANGE_ID_REF 1..∞
120--0--NEW Version Beta 2.0 Build 0This element references an exchange-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
120--0--NEW Version Beta 2.0 Build 0
This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
CLEARING_GROUP_NAME languagetexte60 Complex Type
120--4--Verrechnungsgruppe_Bez Version Beta 2.0 Build 0Name for a clearing group. This is used in order to simplify data acquisition.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS optional
1000--0--NEW 13.06.2018/K.RichterThis element is used for saving hyperlinks with detail information
Sequence
DETAIL_INFO 1..∞
1000--0--NEW 30.05.2012/Bur

This element is used to define a detail information.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
1000--0--NEW 30.05.2012/Bur
This attribute identifies detail information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
1000--0--NEW 30.05.2012/Bur
This element is used for the classification of detail information.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
This element is here to describe the type of detailed information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
1000--0--NEW 30.05.2012/BurName of the link (e.g. "magic corner in motion").
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
1000--0--NEW 30.05.2012/BurElement for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
1000--0--NEW 18.11.2013 /FurniTec
This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
1000--0--NEW 30.05.2012/BurText information for a tool tip with reference to the link.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
URL
1000--0--NEW 30.05.2012/BurThis element contains the URL for the detail information.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW in Datentyp language geändert, 04.05 Kerstin Richter
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file . 		D positiveInteger
P
M [1:4]
SERIES
200--0--NEW Version Beta 2.0 Build 0This element is used to specify all series of the catalogue/data with the elements assigned to them, e.g. blocks and their items.
Sequence
SERIE 1..100
200--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of the series.
Items belonging to series 0 are valid for all series. Therefore items of series 0 must not occur with the same type number (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in other series. Items of other series (unequal 0) may be used with the same type name in different series.
Buying prices are always indicated as the dealer’s buying prices
SERIE_NO required Restriction of xs:nonNegativeInteger
200--1--Satzart Version Beta 2.0 Build 0
This attribute defines the serial number of the series. D nonNegativeInteger
P
M [0:99]
Sequence
PRODUCT_GROUPS
1000--0--NEW Version Beta 2.0 Build 0This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types.
Sequence
PRODUCT_GROUP 1..∞
1000--0--NEW Version Beta 2.0 Build 0This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
1000--0--NEW Version Beta 2.0 Build 0This element is used for defining a name for a product group.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ITEMS
400--1--Satzart Version Beta 2.0 Build 0This element defines all items belonging to one product group.
Sequence
ITEM 1..∞
400--0--NEW Version Beta 2.0 Build 0This element is used to define blocks and their items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes of the main catalogue.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
FEATURE_DEFINITION optional
1000--0--NEW Version Beta 2.0 Build 0All information which is depending on the different variations (restrictions) is defined in this element
Sequence
RESTRICTIONS
270/271--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of restrictions.
Sequence
RESTRICTION 1..99999
270/271--0--NEW Version Beta 2.0 Build 0This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
This attribute identifies restrictions unambiguously. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE required Restriction of xs:int
270/271--0--NEW
The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
270--0--NEW Version Beta 2.0 Build 0This element is used for the definition of a name for a control procedure.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
1000--0--NEW Version Beta 2.0 Build 6This element is used for the definition of a variation combination.
Sequence
OPTION_REF 1..3
271--0--NEW Version Beta 2.0 Build 4This element is used for referencing the variation types which are used in the control procedures.
FEATURE_NO required Restriction of xs:nonNegativeInteger
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
405--0--NEW Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the minimum dimension in which an option is available.
DIMENSION_TYPE required Restriction of xs:string
405--0--NEW Version Beta 2.0 Build 3
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--0--NEW Version Beta 2.0 Build 3
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
270--4--Pruef_ID Version Beta 2.0 Build 0
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted 		D boolean
P
M
BLOCK_VALUE_CALCULATION optional
1000--0--NEW Version Beta 2.0 Build 0This element is used for defining the rules which apply to block calculation and value clearing.
Sequence
BLOCK_CONDITIONS optional
420--1--Satzart Version Beta 2.0 Build 6This element contains special conditions for the block calculation. Only if a block corresponds with these conditions it can be applied to a certain commission. Rules defined here apply to the value clearing system (value clearing block) as well as to block calculation (item block).

A block may only be applied to a commission,if all conditions for this special block are fulfilled. A tuple, consisting of the fields ITEM_REF (path 1) and OPERATION_ID (path 2), defines the conditions which refer to a certain block.

Basic condition for the correct application of block conditions is, that a block exists in one of the ranges which have been planned in one commission. In case different ranges have been planned in one commission, the first range which appears in the header data is considered as reference.

The settings and definitions of range- and variation controls apply to blocks in the same way as to “ordinary” items. The price information 0 in the element ITEM_PRICE (path 2) indicates that the value clearing block exists in a certain price group.

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

path 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Sequence
BLOCK_CONDITION 1..∞
420--1--Satzart Version Beta 2.0 Build 6This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.
Sequence
ITEM_REF
420--3--Type_Block Version Beta 2.0 Build 6This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.
TYPE_NO required Restriction of xs:string
420--3--Type_Block Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
420--3--Type_Block Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
420--5--Verknuepfung_ID Version Beta 2.0 Build 6Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.
Sequence
CONDITION_RULE 1..∞
420--0--NEW Version Beta 2.0 Build 6This element is used for defining block conditions.
Sequence
CLEARING_GROUP_REF 1..999
420--0--NEW Version Beta 2.0 Build 6This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
420--6--Mindest_Wert Version Beta 2.0 Build 6
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
420--7--Mindest_Breite Version Beta 2.0 Build 6
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
BLOCK_SALE_PRICES optional
480--1--Satzart Version Beta 2.0 Build 6This element is used for defining block sale prices.
Sequence
BLOCK_SALE_PRICE 1..∞
480--1--Satzart Version Beta 2.0 Build 6Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Sequence
ITEM_REF
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing an item for which a block sale price has been defined.
TYPE_NO required Restriction of xs:string
480--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
480--100--NEW Version Beta 2.0 Build 6This element is used for defining block sale conditions.
Sequence
VALID_FROM Restriction of xs:date
480--12--Lieferbar_ab Version Beta 2.0 Build 6
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
VALID_UNTIL Restriction of xs:date
480--13--Lieferbar_bis Version Beta 2.0 Build 6
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
OPTION_REF 0..4
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
FEATURE_NO required Restriction of xs:nonNegativeInteger
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
480--14--Preis/Verrechnungspunkt Version Beta 2.0 Build 6
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
GRADING_TABLE optional
421--1--Satzart Version Beta 2.0 Build 6

This element is used for defining grading tables containing the surcharges or the credits which are used in the value clearing system.

A clearing block, which is valid for a certain commission, can be used as reference for the grading table. A reference amount is set up for each data record of this record type, to which the valid clearing block belongs CLEARING_GROUP (path 1). This amount is compared to the given amount of the clearing group. If the reference value corresponds with the given grading range (elements VALUE_FROM (path2) and VALUE_TO (path 2), the data record is applied. In this case the settings in the field TYPE_CREDIT (path 2) and/ or TYPE_DEBIT (path 2) are applied. The calculation is based on the amount of the calculation group, which is defined for type_credit or type_surcharge (element ITEM (path 3)).

Different grading ranges can be defined for one block. A freely defined operation_ID is assigned to each grading range COMPARING_RULES (path 4). Different grading ranges with the same operation_ID may appear within one grading range of a clearing block. In this case the conditions of all grading ranges with their corresponding clearing group have to be fulfilled, so that the value clearing system can be applied to the different items of the commission. Single data records are linked by an AND-operation (COMPARING_RULE).

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

In case several data records of a clearing block are applied in the GRADING_TABLE, the value of the block (ITEM (path 3)), ITEM_PRICE (path 5)) is calculated only one time.

path 1: GLOBAL_DEFINITION
path 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
path 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
CREDIT_SURCHARGE_CLEARING 1..∞
421--1--Satzart Version Beta 2.0 Build 6This element defines value range for a grading table.
Sequence
ITEM_REF
421--0--NEW Version Beta 2.0 Build 6

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
421--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
421--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
421--4--Verknuepfung_ID Version Beta 2.0 Build 6Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.
Sequence
COMPARING_RULE 1..∞
421--0--NEW Version Beta 2.0 Build 6This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
421--5--Verrechnungsgruppe_ID Version Beta 2.0 Build 6
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
421--6--Wert_von Version Beta 2.0 Build 6
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger
421--7--Wert_bis Version Beta 2.0 Build 6

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
421--8--Type_Gutschrift Version Beta 2.0 Build 6
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
421--9--Type_Belastung Version Beta 2.0 Build 6
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
SET_OF_BLOCK_RULES
111--1--Satzart Version Beta 2.0 Build 0The manufacturer specific rules are defined in this element and the in the child elements.
Sequence
EXCHANGE_ID_GROUP 1..∞
117--0--NEW Version Beta 2.0 Build 0This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.
Sequence
EXCHANGE_ID_1_REF
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RULE 1..99
111--0--NEW Version Beta 2.0 Build 0This element defines a manufacturer specific set of rules.
RULE_NO required Restriction of xs:nonNegativeInteger
113--3--Regel_Nr Version Beta 2.0 Build 0
This attribute defines a counter from 1-99 for the manufacturer specific block rules. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
113--5--Regel_Nr_Text Version Beta 2.0 Build 0This element defines the criteria for exchanges in the block processing.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
RULE_SET_TEXT languagetexte60999 Complex Type
111--5--Regelwerk_Text Version Beta 2.0 Build 0This element contains text information and explanations for the set of rules.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
MAJOR Restriction of xs:positiveInteger required 100--3--Versionsnummer Verlegung der Versionierung AK 28.02.2012 K. Richter 25.03.2014
The version number "MAJOR" indicates the format version of the database. This main version number is only changed if the format is changed completely. The complete definition of a format version consists of the following elements: MAJOR, MINOR and REVISION. D nonNegativeInteger
P
M [2]
MINOR Restriction of xs:nonNegativeInteger required 100--4--Sub_Versions_Nr Verlegung der Versionierung AK 28.02.2012
In general the number of the sub-version "MINOR" changes every year. In case the main version number MAJOR is changed, the sub-version number is reset to 0.
 D nonNegativeInteger
P
M [0:99]
REVISION Restriction of xs:nonNegativeInteger required 1000--0--NEW Verlegung der Versionierung AK 28.02.2012
During the year the field revision number "REVISION" indicates changes of the format, as agreed upon in the regular sessions of the committee. The different revisions are not issued unless they are necessary corrections. The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="T_NEW_BLOCK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FILE_RELEASE_DATE" type="xs:dateTime">
              <xs:annotation>
                <xs:documentation>100--2--Dateifreigabe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_ID">
                    <xs:annotation>
                      <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="COUNTRY_ID">
                    <xs:annotation>
                      <xs:documentation>100--13--Laender_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CATALOG_KIND">
                    <xs:annotation>
                      <xs:documentation>Katalog-Art</xs:documentation>
                      <xs:documentation>1 für Basiskatalog</xs:documentation>
                      <xs:documentation>2 für Verbandskatalog</xs:documentation>
                      <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
                      <xs:documentation>geändert 17.04.2019</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ASSOC_CTM_NO" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRODUCT_BRANDNAME">
                    <xs:annotation>
                      <xs:documentation>100--40--Produktmarke</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE_ID">
                    <xs:annotation>
                      <xs:documentation>100--49--Preis_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT">
                    <xs:annotation>
                      <xs:documentation>200--4--MwSt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_YEAR" type="xs:gYear">
              <xs:annotation>
                <xs:documentation>Jahr der Neuerstellung</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="MIN_MAJOR_NO">
              <xs:annotation>
                <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetexte30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="DATA_VERSION">
              <xs:annotation>
                <xs:documentation>100--11--Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_FROM_DATE">
              <xs:annotation>
                <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILE_ID">
              <xs:annotation>
                <xs:documentation>100--14--Datei_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MARK">
              <xs:annotation>
                <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BKV]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FILLING_LEVEL">
              <xs:annotation>
                <xs:documentation>100--44--Fuellstufe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[123]|2[a-n]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICING_TERMS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--48--Preisstellung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="1" />
                  <xs:pattern value="[01]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_INFO" type="languagetexte60999" minOccurs="0">
              <xs:annotation>
                <xs:documentation>110--3--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FALL_BACK_LANGUAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
                <xs:documentation>K. Richter 29.06.2017</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONTACT_PERSON" maxOccurs="2">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CONTACT_PERSON_NO">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_ROLE">
                    <xs:annotation>
                      <xs:documentation>100--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="60" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONTACT_NAME">
                    <xs:annotation>
                      <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FIRST_NAME">
                    <xs:annotation>
                      <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="20" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FORM_OF_ADDRESS">
                    <xs:annotation>
                      <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="2" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DEPARTMENT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE">
                    <xs:annotation>
                      <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONTACT_SUPPLIER">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="MANUFACTURER_NAME_1">
                    <xs:annotation>
                      <xs:documentation>100--16--Herstellername_1</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--17--Herstellername_2</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EMAIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INTERNET_ADDRESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STREET">
                    <xs:annotation>
                      <xs:documentation>100--20--Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_STREET">
                    <xs:annotation>
                      <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CITY">
                    <xs:annotation>
                      <xs:documentation>100--22--Ort</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="30" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="POSTBOX" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>100--24--Postfach</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TELEPHONE_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FAX_SWITCHBOARD">
                    <xs:annotation>
                      <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="18" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GLOBAL_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>120--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>120--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="CLEARING_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASSIFICATION">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="8" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INFO_TYPE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                            <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                            <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[01]|99" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="INTERNAL_NAME" type="languagetexte40">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="GUID">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                            <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="URL">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                        <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:anyURI">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="1024" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="HASH_VALUE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="64" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESOLUTION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="4" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE" maxOccurs="100">
              <xs:annotation>
                <xs:documentation>200--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUPS">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="ITEMS">
                                <xs:annotation>
                                  <xs:documentation>400--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                            <xs:annotation>
                                              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence minOccurs="0">
                                                <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>450/470--1--Satzart</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="PRICE_FIELD">
                                                        <xs:annotation>
                                                          <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="250" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="PRICE">
                                                        <xs:annotation>
                                                          <xs:documentation>450--5--Preis</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:integer">
                                                            <xs:minInclusive value="-99999999" />
                                                            <xs:maxInclusive value="999999999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="99999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="PRICE_TYPE_REF">
                                            <xs:annotation>
                                              <xs:documentation>400/407--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="PRICE_TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>407--5--Preisart</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CALC_GROUP_REF">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="CALC_GROUP_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="10" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="RESTRICTIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>409--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>409--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="RESTRICTION_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>409--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SEQUENCE" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>409--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:maxInclusive value="99999" />
                                                          <xs:minInclusive value="1" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="EDP_NUMBER" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="15" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="9" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_IDENTIFICATION">
                                            <xs:annotation>
                                              <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[BEKSMZVPNOG]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CATALOG_PAGE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                              <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:minLength value="1" />
                                                <xs:maxLength value="40" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VAT_ID_REF" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="VAT_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>400--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="VALID_FROM" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="VALID_UNTIL" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:date" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="RANGE_DEPENDENT">
                                            <xs:annotation>
                                              <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:boolean" />
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_PARTS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="BLOCK_SEQUENTIAL_NO">
                                                        <xs:annotation>
                                                          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="ITEM_REF">
                                                        <xs:annotation>
                                                          <xs:documentation>401--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="TYPE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="15" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="SERIE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="99" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>401--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:attribute name="FEATURE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:nonNegativeInteger">
                                                                <xs:minInclusive value="0" />
                                                                <xs:maxInclusive value="999" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                          <xs:attribute name="OPTION_KEY" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>401--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:string">
                                                                <xs:minLength value="1" />
                                                                <xs:maxLength value="5" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                      <xs:element name="HINGE" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--6--Anschlag</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[BEJLMNR]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="EXCHANGE_CONDITION">
                                                        <xs:annotation>
                                                          <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:positiveInteger">
                                                            <xs:minInclusive value="2" />
                                                            <xs:maxInclusive value="3" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="STATUS">
                                                        <xs:annotation>
                                                          <xs:documentation>401--8--Status</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[ABELSZ]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="1" />
                                                            <xs:maxInclusive value="99999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="|[JLNRAE]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SHORT_TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT_LINE" maxOccurs="3">
                                                              <xs:annotation>
                                                                <xs:documentation>410--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="TEXT">
                                                                    <xs:annotation>
                                                                      <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[\S ]{1,30}" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                                <xs:attribute name="SEQUENCE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger" />
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>150--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:language">
                                                                <xs:pattern value="[A-Z]{2}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="TYPE_KEY">
                                            <xs:annotation>
                                              <xs:documentation>445--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_TYPE">
                                                  <xs:annotation>
                                                    <xs:documentation>445--4--TS_Typ</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_CLASS">
                                                  <xs:annotation>
                                                    <xs:documentation>445--5--TS_Art</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                                  <xs:annotation>
                                                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                            <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                              <xs:annotation>
                                                                <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                                <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:nonNegativeInteger">
                                                                  <xs:minInclusive value="0" />
                                                                  <xs:maxInclusive value="9999" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger" />
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                                      <xs:annotation>
                                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="TK_MATERIAL" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--21--TS_Material</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-2]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_SHAPE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--22--TS_Form</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-2]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS">
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="ECLASS_NO">
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:negativeInteger">
                                                            <xs:totalDigits value="8" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="DETAIL_INFOS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                      </xs:annotation>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTIONS">
              <xs:annotation>
                <xs:documentation>270/271--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION" maxOccurs="99999">
                    <xs:annotation>
                      <xs:documentation>270/271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>270--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_REF" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>271--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>271--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:sequence minOccurs="0">
                                <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                                  <xs:annotation>
                                    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="DIMENSION_TYPE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[WHD]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSION_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                                <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                                  <xs:annotation>
                                    <xs:documentation>405--0--NEW</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                                  </xs:annotation>
                                  <xs:complexType>
                                    <xs:attribute name="DIMENSION_TYPE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[WHD]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                    <xs:attribute name="DIMENSION_VALUE" use="required">
                                      <xs:annotation>
                                        <xs:documentation>405--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:attribute>
                                  </xs:complexType>
                                </xs:element>
                              </xs:sequence>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TEST_ID">
                          <xs:annotation>
                            <xs:documentation>270--4--Pruef_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_1_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_2_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="FEATURE_3_NO">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="VALIDATION_TYPE" use="required">
                        <xs:annotation>
                          <xs:documentation>270/271--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:int">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BLOCK_VALUE_CALCULATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_CONDITIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>420--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>420--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>420--3--Type_Block</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--3--Type_Block</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--3--Type_Block</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CONDITION_RULES">
                          <xs:annotation>
                            <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>420--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                                      <xs:annotation>
                                        <xs:documentation>420--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="CLEARING_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>420--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:choice>
                                      <xs:element name="MINIMUM_VALUE" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                      <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                                        <xs:annotation>
                                          <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                        </xs:annotation>
                                        <xs:simpleType>
                                          <xs:restriction base="xs:nonNegativeInteger">
                                            <xs:minInclusive value="0" />
                                            <xs:maxInclusive value="999999" />
                                          </xs:restriction>
                                        </xs:simpleType>
                                      </xs:element>
                                    </xs:choice>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="BLOCK_SALE_PRICES" minOccurs="0">
              <xs:annotation>
                <xs:documentation>480--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>480--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>480--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>480--100--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="VALID_FROM">
                                <xs:annotation>
                                  <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL">
                                <xs:annotation>
                                  <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                                <xs:annotation>
                                  <xs:documentation>480--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>480--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>480--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_OR_CALCULATION_POINT">
                                <xs:annotation>
                                  <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="GRADING_TABLE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>421--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>421--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>421--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>421--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLEARING_GROUP_ID">
                                      <xs:annotation>
                                        <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_FROM">
                                      <xs:annotation>
                                        <xs:documentation>421--6--Wert_von</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALUE_TO">
                                      <xs:annotation>
                                        <xs:documentation>421--7--Wert_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TYPE_CREDIT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TYPE_DEBIT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>421--9--Type_Belastung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="SET_OF_BLOCK_RULES">
              <xs:annotation>
                <xs:documentation>111--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="EXCHANGE_ID_1_REF">
                          <xs:annotation>
                            <xs:documentation>117--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>117--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EXCHANGE_ID_2_REF">
                          <xs:annotation>
                            <xs:documentation>117--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>117--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RULE" maxOccurs="99">
                    <xs:annotation>
                      <xs:documentation>111--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RULE_TEXT" type="languagetexte60999">
                          <xs:annotation>
                            <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="RULE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>113--3--Regel_Nr</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
                    <xs:annotation>
                      <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MAJOR" use="required">
      <xs:annotation>
        <xs:documentation>100--3--Versionsnummer</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
        <xs:documentation>K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="2" />
          <xs:maxInclusive value="2" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MINOR" use="required">
      <xs:annotation>
        <xs:documentation>100--4--Sub_Versions_Nr</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REVISION" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element : CATALOG Element
Description
100--0--NEW Version Beta 2.0 Build 0All administrative information about the catalogue/ database is stored in this element.
Namespace (none)
Diagram
FALL_BACK_LANGUAGE Element LANGUAGE Element Sequence CATALOG_INFO Element PRICING_TERMS Element FILLING_LEVEL Element CATALOG_MARK Element FILE_ID Element VALID_FROM_DATE Element DATA_VERSION Element LANGUAGE Element Sequence CATALOG_NAME Element MIN_MAJOR_NO Element CATALOG_YEAR Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element FILE_RELEASE_DATE Element Sequence CATALOG Element
Overview
CATALOG
100--0--NEW Version Beta 2.0 Build 0All administrative information about the catalogue/ database is stored in this element.
Sequence
FILE_RELEASE_DATE xs:dateTime
100--2--Dateifreigabe Version Beta 2.0 Build 0
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contain the current date and time (UTC). D dateTime
P
M
CATALOG_IDENTIFICATION
100--0--NEW Version Beta 2.0 Build 0This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
100--5--Hersteller_ID Version Beta 2.0 Build 0
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
100--6--Sprachenschluessel Version Beta 2.0 Build 4, K. Richter 21.03.2014
The language code defines the language in which the texts in the data pool were created. The ISO Language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
100--7--Waehrungsschluessel Version Beta 2.0 Build 0
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
100--13--Laender_ID Version Beta 2.0 Build 0
For transnational catalogues with an identical currency key this element is used for assigning a database to one country by the different ISO country codes. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger
Katalog-Art 1 für Basiskatalog 2 für Verbandskatalog 3 für kundenspezifischen Katalog geändert 17.04.2019

This field is used to identify association catalogues.

The following values can be used:
1 = base catalogue
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

 D positiveInteger
P
M [1:3]
ASSOC_CTM_NO optional Restriction of xs:string
100--15--Verband_KD_Nr Version Beta 2.0 Build 0
This element is used to specify the customer number of the Association or customer for which the data pool is available.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
100--40--Produktmarke Version Beta 2.0 Build 0K., K. Richter 25.03.2014
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
100--49--Preis_ID Version Beta 2.0 Build 0
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price
2 = identification number
3 = settlement point.

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
200--4--MwSt Version Beta 2.0 Build 0
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT

This element is very important for pricing. 		D boolean
P
M
CATALOG_NUMBER Restriction of xs:string
100--9--Katalog_Nummer Version Beta 2.0 Build 0
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
CATALOG_YEAR xs:gYear
Jahr der Neuerstellung
This element refers to the calendar year of the catalogue data in the main catalogue. D gYear
P
M
MIN_MAJOR_NO Restriction of xs:positiveInteger
Hauptnummer der Neuerstellung innerhalb eines Jahres
The main catalogue's major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. Element MIN_MAJOR_NO contains the minimum value of thee main catalogues's MAJOR_NO. D positiveInteger
P
M 1:99
CATALOG_NAME languagetexte30 Complex Type
100--10--Katalog_Name Version Beta 2.0 Build 0This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
DATA_VERSION Restriction of xs:date
100--11--Daten_Version Version Beta 2.0 Build 0
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database. D date
P
M
VALID_FROM_DATE Restriction of xs:date
100--12--Gueltig_ab_Datum Version Beta 2.0 Build 0
This element defines the period of validity for the catalogue and corresponding database. D date
P
M
FILE_ID Restriction of xs:boolean
100--14--Datei_ID Version Beta 2.0 Build 0
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
100--43--Katalogkennzeichen Version Beta 2.0 Build 0
This element is used to differ between the possible data types

B = block data with prices
K = catalogue data
V = block data without prices (notional prices are required) 		D string
P [BKV]
M [1:1]
FILLING_LEVEL Restriction of xs:string
100--44--Fuellstufe Version Beta 2.0 Build 0
The filling level (FILLING_LEVEL) defines the level of details which are provided in a database. In general, an increase in the filling level corresponds with an increase in data quality. The higher the degree of detail specification in the data, the more specific they are for a certain manufacturer.
The different filling levels are evaluated during the certification procedure: By checking the filling levels it is ascertained which information is required in the data, in order to achieve the filling level. In case the required information is missing in a filling level, the complete set of data is not certified.
The filling levels are defined as follows:
- Filling level 1: provides basic information except from elements for the description of texture information
- Filling level 2a: filling level 1 is supplemented with information regarding textures and material (colours RGB,transparency and brightness)
- Filling level 2b: filling level 1 is amended with information about front division and front finishes
- Filling level 2c: filling level 1 is supplemented with information about handles.
- Filling level 2d: filling level 1 is amended with information about item textures.

Combinations of filling levels 2a-2d are possible. Following itemized breakdowns of combinations are defined:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Filling level 3. To achieve filling level 3 information in the filling levels 1 and 2a - 2d supplemented by information about the modeling graphic is required. In filling level 3 all options of the data format for manufacturer specific illustrations are entirely applied.
A complete definition of the information required for the different filling levels is provided in the table "Filling levels". 		D string
P [123]|2[a-n]
M [1:2]
PRICING_TERMS optional Restriction of xs:string
100--48--Preisstellung Version Beta 2.0 Build 0, K. Richter 25.03.2014
This element defines the pricing terms for the catalog prices.
A complete definition of the information required for the dThis element defines the pricing terms for the catalog prices. The information in this field is used for a correct data import in order to avoid overwriting of price information.

The following values are used:
0 = prices in the catalogue are purchase prices for dealers
1 = prices in the catalogue are recommended retail prices (UPE)

All price information in the catalogue has to correspond to the information in this element. 		D string
P [01]
M [1:1]
CATALOG_INFO optional languagetexte60999 Complex Type
110--3--Textzeile Version Beta 2.0 Build 0Information texts are stored in this element.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
FALL_BACK_LANGUAGE optional Restriction of xs:language
100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind K. Richter 29.06.2017
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The two-digit ISO language code must be used. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FILE_RELEASE_DATE" type="xs:dateTime">
        <xs:annotation>
          <xs:documentation>100--2--Dateifreigabe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_ID">
              <xs:annotation>
                <xs:documentation>100--5--Hersteller_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="COUNTRY_ID">
              <xs:annotation>
                <xs:documentation>100--13--Laender_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_KIND">
              <xs:annotation>
                <xs:documentation>Katalog-Art</xs:documentation>
                <xs:documentation>1 für Basiskatalog</xs:documentation>
                <xs:documentation>2 für Verbandskatalog</xs:documentation>
                <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
                <xs:documentation>geändert 17.04.2019</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ASSOC_CTM_NO" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRODUCT_BRANDNAME">
              <xs:annotation>
                <xs:documentation>100--40--Produktmarke</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE_ID">
              <xs:annotation>
                <xs:documentation>100--49--Preis_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT">
              <xs:annotation>
                <xs:documentation>200--4--MwSt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_YEAR" type="xs:gYear">
        <xs:annotation>
          <xs:documentation>Jahr der Neuerstellung</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="MIN_MAJOR_NO">
        <xs:annotation>
          <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetexte30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="DATA_VERSION">
        <xs:annotation>
          <xs:documentation>100--11--Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_FROM_DATE">
        <xs:annotation>
          <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILE_ID">
        <xs:annotation>
          <xs:documentation>100--14--Datei_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MARK">
        <xs:annotation>
          <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BKV]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FILLING_LEVEL">
        <xs:annotation>
          <xs:documentation>100--44--Fuellstufe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[123]|2[a-n]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICING_TERMS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--48--Preisstellung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="1" />
            <xs:pattern value="[01]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_INFO" type="languagetexte60999" minOccurs="0">
        <xs:annotation>
          <xs:documentation>110--3--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FALL_BACK_LANGUAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
          <xs:documentation>K. Richter 29.06.2017</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

FILE_RELEASE_DATE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : FILE_RELEASE_DATE Element
Description
100--2--Dateifreigabe Version Beta 2.0 Build 0
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contain the current date and time (UTC). D dateTime
P
M
Namespace (none)
Type
xs:dateTime
Diagram
FILE_RELEASE_DATE Element
Overview
FILE_RELEASE_DATE xs:dateTime
100--2--Dateifreigabe Version Beta 2.0 Build 0
The FILE_RELEASE_DATE element should be activated automatically when data is exported and contain the current date and time (UTC). D dateTime
P
M
Source
<xs:element name="FILE_RELEASE_DATE" type="xs:dateTime" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--2--Dateifreigabe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_IDENTIFICATION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_IDENTIFICATION Element
Description
100--0--NEW Version Beta 2.0 Build 0This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.
Namespace (none)
Diagram
VAT Element PRICE_ID Element PRODUCT_BRANDNAME Element ASSOC_CTM_NO Element CATALOG_KIND Element COUNTRY_ID Element CURRENCY_KEY Element ISO_LANGUAGE_ID Element MANUFACTURER_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
100--0--NEW Version Beta 2.0 Build 0This element identifies a catalogue. A catalogue is defined unambiguously by a distinct combination of the following elements:

- MANUFACTURER_ID
- ISO_LANGUAGE_ID
- CURRENCY_KEY
- COUNTRY_ID
- ASSOC_CTM_NO
- PRODUCT_BRANDNAME
- PRICE_ID

If the contents of these fields in an update file differs from the information given in the basic file the update is only possibble under certain conditions.
The currency units in the catalogue file and the corresponding block and value clearing files have to be identical.
Sequence
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
100--5--Hersteller_ID Version Beta 2.0 Build 0
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
100--6--Sprachenschluessel Version Beta 2.0 Build 4, K. Richter 21.03.2014
The language code defines the language in which the texts in the data pool were created. The ISO Language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
100--7--Waehrungsschluessel Version Beta 2.0 Build 0
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
COUNTRY_ID Restriction of xs:string
100--13--Laender_ID Version Beta 2.0 Build 0
For transnational catalogues with an identical currency key this element is used for assigning a database to one country by the different ISO country codes. D string
P [A-Z]{2}
M [2:2]
CATALOG_KIND Restriction of xs:positiveInteger
Katalog-Art 1 für Basiskatalog 2 für Verbandskatalog 3 für kundenspezifischen Katalog geändert 17.04.2019

This field is used to identify association catalogues.

The following values can be used:
1 = base catalogue
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

 D positiveInteger
P
M [1:3]
ASSOC_CTM_NO optional Restriction of xs:string
100--15--Verband_KD_Nr Version Beta 2.0 Build 0
This element is used to specify the customer number of the Association or customer for which the data pool is available.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
100--40--Produktmarke Version Beta 2.0 Build 0K., K. Richter 25.03.2014
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
PRICE_ID Restriction of xs:positiveInteger
100--49--Preis_ID Version Beta 2.0 Build 0
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price
2 = identification number
3 = settlement point.

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank. 		D positiveInteger
P
M [1:3]
VAT Restriction of xs:boolean
200--4--MwSt Version Beta 2.0 Build 0
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT

This element is very important for pricing. 		D boolean
P
M
Source
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_ID">
        <xs:annotation>
          <xs:documentation>100--5--Hersteller_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="COUNTRY_ID">
        <xs:annotation>
          <xs:documentation>100--13--Laender_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_KIND">
        <xs:annotation>
          <xs:documentation>Katalog-Art</xs:documentation>
          <xs:documentation>1 für Basiskatalog</xs:documentation>
          <xs:documentation>2 für Verbandskatalog</xs:documentation>
          <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
          <xs:documentation>geändert 17.04.2019</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ASSOC_CTM_NO" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRODUCT_BRANDNAME">
        <xs:annotation>
          <xs:documentation>100--40--Produktmarke</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE_ID">
        <xs:annotation>
          <xs:documentation>100--49--Preis_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT">
        <xs:annotation>
          <xs:documentation>200--4--MwSt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

MANUFACTURER_ID Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : MANUFACTURER_ID Element
Description
100--5--Hersteller_ID Version Beta 2.0 Build 0
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MANUFACTURER_ID Element
Overview
MANUFACTURER_ID Restriction of xs:nonNegativeInteger
100--5--Hersteller_ID Version Beta 2.0 Build 0
This field is used for the unambiguous manufacturer-ID as listed in the table "manufacturer-ID". This ID is given without leading zeros. This ID is given without leading zeros.The different revisions are not issued unless they are necessary corrections. With each new sub-version number "MINOR" the field REVISION is reset to 0. This ID is given without leading zeros. D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="MANUFACTURER_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--5--Hersteller_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ISO_LANGUAGE_ID Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Description
100--6--Sprachenschluessel Version Beta 2.0 Build 4, K. Richter 21.03.2014
The language code defines the language in which the texts in the data pool were created. The ISO Language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:language
Diagram
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
100--6--Sprachenschluessel Version Beta 2.0 Build 4, K. Richter 21.03.2014
The language code defines the language in which the texts in the data pool were created. The ISO Language code must be used.
Multiple language codes indicate that the catalogue is used in multiple languages. The catalogue texts must only use the language codes entered in these elements. 		D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CURRENCY_KEY Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Description
100--7--Waehrungsschluessel Version Beta 2.0 Build 0
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
Namespace (none)
Type
Restriction of xs:string
Diagram
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
100--7--Waehrungsschluessel Version Beta 2.0 Build 0
This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year (including blocks) must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
Source
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

COUNTRY_ID Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : COUNTRY_ID Element
Description
100--13--Laender_ID Version Beta 2.0 Build 0
For transnational catalogues with an identical currency key this element is used for assigning a database to one country by the different ISO country codes. D string
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:string
Diagram
COUNTRY_ID Element
Overview
COUNTRY_ID Restriction of xs:string
100--13--Laender_ID Version Beta 2.0 Build 0
For transnational catalogues with an identical currency key this element is used for assigning a database to one country by the different ISO country codes. D string
P [A-Z]{2}
M [2:2]
Source
<xs:element name="COUNTRY_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--13--Laender_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_KIND Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CATALOG_KIND Element
Description
Katalog-Art 1 für Basiskatalog 2 für Verbandskatalog 3 für kundenspezifischen Katalog geändert 17.04.2019

This field is used to identify association catalogues.

The following values can be used:
1 = base catalogue
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

 D positiveInteger
P
M [1:3]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
CATALOG_KIND Element
Overview
CATALOG_KIND Restriction of xs:positiveInteger
Katalog-Art 1 für Basiskatalog 2 für Verbandskatalog 3 für kundenspezifischen Katalog geändert 17.04.2019

This field is used to identify association catalogues.

The following values can be used:
1 = base catalogue
2 = association catalogue
3 = customer-specific catalogue

If 2 or 3 is entered in the field, an association or customer identifier to whom the data pool is made available must be entered in field ASSOC_CTM_NO.

 D positiveInteger
P
M [1:3]
Source
<xs:element name="CATALOG_KIND" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Katalog-Art</xs:documentation>
    <xs:documentation>1 für Basiskatalog</xs:documentation>
    <xs:documentation>2 für Verbandskatalog</xs:documentation>
    <xs:documentation>3 für kundenspezifischen Katalog</xs:documentation>
    <xs:documentation>geändert 17.04.2019</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ASSOC_CTM_NO Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ASSOC_CTM_NO Element
Description
100--15--Verband_KD_Nr Version Beta 2.0 Build 0
This element is used to specify the customer number of the Association or customer for which the data pool is available.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
ASSOC_CTM_NO Element
Overview
ASSOC_CTM_NO optional Restriction of xs:string
100--15--Verband_KD_Nr Version Beta 2.0 Build 0
This element is used to specify the customer number of the Association or customer for which the data pool is available.

The software houses must be informed of the meaning of the content separately.
For the sake of a uniform presentation, the abbreviations for the purchasing associations should be used wherever available (see table "purchasing associations") 		D string
P
M [1:15]
Source
<xs:element name="ASSOC_CTM_NO" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--15--Verband_KD_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PRODUCT_BRANDNAME Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRODUCT_BRANDNAME Element
Description
100--40--Produktmarke Version Beta 2.0 Build 0K., K. Richter 25.03.2014
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRODUCT_BRANDNAME Element
Overview
PRODUCT_BRANDNAME Restriction of xs:positiveInteger
100--40--Produktmarke Version Beta 2.0 Build 0K., K. Richter 25.03.2014
This element contains a freely defined counter which is valid for a single product brand and remains the same during the catalogue updates. In this way the efficiency of catalogue updates is increased as the software suppliers can assign catalogue updates distinctly to the catalogues of the preceding year. D positiveInteger
P
M [1:999]
Source
<xs:element name="PRODUCT_BRANDNAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--40--Produktmarke</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0K., K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PRICE_ID Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : PRICE_ID Element
Description
100--49--Preis_ID Version Beta 2.0 Build 0
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price
2 = identification number
3 = settlement point.

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank. 		D positiveInteger
P
M [1:3]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_ID Element
Overview
PRICE_ID Restriction of xs:positiveInteger
100--49--Preis_ID Version Beta 2.0 Build 0
This element is used to specify a price ID used to define the types of prices in the data pool.

The following price IDs can be used:
1 = price
2 = identification number
3 = settlement point.

If 1 (price) or 2 (identification number) is entered in this field, a currency must be specified in the CURRENCY_KEY element. If 3 is entered in this element (settlement point), the CURRENCY_KEY element must be left blank. 		D positiveInteger
P
M [1:3]
Source
<xs:element name="PRICE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--49--Preis_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

VAT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element > CATALOG_IDENTIFICATION Element : VAT Element
Description
200--4--MwSt Version Beta 2.0 Build 0
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT

This element is very important for pricing. 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
VAT Element
Overview
VAT Restriction of xs:boolean
200--4--MwSt Version Beta 2.0 Build 0
This element is used to specify the VAT ID used for pricing in the data pool.
The following values can be used:
0/False = exclusive of VAT
1/True = inclusive of VAT

This element is very important for pricing. 		D boolean
P
M
Source
<xs:element name="VAT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--4--MwSt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_NUMBER Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_NUMBER Element
Description
100--9--Katalog_Nummer Version Beta 2.0 Build 0
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
100--9--Katalog_Nummer Version Beta 2.0 Build 0
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
Source
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_YEAR Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_YEAR Element
Description
Jahr der Neuerstellung
This element refers to the calendar year of the catalogue data in the main catalogue. D gYear
P
M
Namespace (none)
Type
xs:gYear
Diagram
CATALOG_YEAR Element
Overview
CATALOG_YEAR xs:gYear
Jahr der Neuerstellung
This element refers to the calendar year of the catalogue data in the main catalogue. D gYear
P
M
Source
<xs:element name="CATALOG_YEAR" type="xs:gYear" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Jahr der Neuerstellung</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

MIN_MAJOR_NO Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : MIN_MAJOR_NO Element
Description
Hauptnummer der Neuerstellung innerhalb eines Jahres
The main catalogue's major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. Element MIN_MAJOR_NO contains the minimum value of thee main catalogues's MAJOR_NO. D positiveInteger
P
M 1:99
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
MIN_MAJOR_NO Element
Overview
MIN_MAJOR_NO Restriction of xs:positiveInteger
Hauptnummer der Neuerstellung innerhalb eines Jahres
The main catalogue's major number (MAJOR_NO) changes when a new catalogue is published or items are deleted from a catalogue. If the change takes place in a new year, the calendar year (CATALOG_YEAR) is adjusted accordingly and the major number is set to 1. If no new catalogue is published in a year and no items are deleted, the calendar year and major number remain unchanged. Element MIN_MAJOR_NO contains the minimum value of thee main catalogues's MAJOR_NO. D positiveInteger
P
M 1:99
Source
<xs:element name="MIN_MAJOR_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Hauptnummer der Neuerstellung innerhalb eines Jahres</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_NAME Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_NAME Element
Description
100--10--Katalog_Name Version Beta 2.0 Build 0This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.
Namespace (none)
Type
languagetexte30 Complex Type
Diagram
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetexte30 Complex Type
100--10--Katalog_Name Version Beta 2.0 Build 0This element defines the name of the catalogue which is represented in a database. This element is essential for the display of the catalogue name in the different software applications. A combination of catalogue name and year is permitted as the unambiguous identification of a catalogue is given in the element PRODUCT_BRANDNAME.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="CATALOG_NAME" type="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 Block XML-Schema > languagetexte30 Complex Type : LANGUAGE Element
Description
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required 150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte30 Complex Type | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 Block XML-Schema > languagetexte30 Complex Type > LANGUAGE Element : TEXT Element
Description
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetexte30 Complex Type | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

DATA_VERSION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : DATA_VERSION Element
Description
100--11--Daten_Version Version Beta 2.0 Build 0
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
DATA_VERSION Element
Overview
DATA_VERSION Restriction of xs:date
100--11--Daten_Version Version Beta 2.0 Build 0
The element data version (DATA_VERSION) defines the date up to which published catalogue data, supplements, and corrections are included in the database. D date
P
M
Source
<xs:element name="DATA_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--11--Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

VALID_FROM_DATE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : VALID_FROM_DATE Element
Description
100--12--Gueltig_ab_Datum Version Beta 2.0 Build 0
This element defines the period of validity for the catalogue and corresponding database. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM_DATE Element
Overview
VALID_FROM_DATE Restriction of xs:date
100--12--Gueltig_ab_Datum Version Beta 2.0 Build 0
This element defines the period of validity for the catalogue and corresponding database. D date
P
M
Source
<xs:element name="VALID_FROM_DATE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--12--Gueltig_ab_Datum</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

FILE_ID Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : FILE_ID Element
Description
100--14--Datei_ID Version Beta 2.0 Build 0
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
FILE_ID Element
Overview
FILE_ID Restriction of xs:boolean
100--14--Datei_ID Version Beta 2.0 Build 0
This element defines if the database is a test or a released version.

0/false = test data
1/true = released data 		D boolean
P
M
Source
<xs:element name="FILE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--14--Datei_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_MARK Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_MARK Element
Description
100--43--Katalogkennzeichen Version Beta 2.0 Build 0
This element is used to differ between the possible data types

B = block data with prices
K = catalogue data
V = block data without prices (notional prices are required) 		D string
P [BKV]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_MARK Element
Overview
CATALOG_MARK Restriction of xs:string
100--43--Katalogkennzeichen Version Beta 2.0 Build 0
This element is used to differ between the possible data types

B = block data with prices
K = catalogue data
V = block data without prices (notional prices are required) 		D string
P [BKV]
M [1:1]
Source
<xs:element name="CATALOG_MARK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BKV]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

FILLING_LEVEL Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : FILLING_LEVEL Element
Description
100--44--Fuellstufe Version Beta 2.0 Build 0
The filling level (FILLING_LEVEL) defines the level of details which are provided in a database. In general, an increase in the filling level corresponds with an increase in data quality. The higher the degree of detail specification in the data, the more specific they are for a certain manufacturer.
The different filling levels are evaluated during the certification procedure: By checking the filling levels it is ascertained which information is required in the data, in order to achieve the filling level. In case the required information is missing in a filling level, the complete set of data is not certified.
The filling levels are defined as follows:
- Filling level 1: provides basic information except from elements for the description of texture information
- Filling level 2a: filling level 1 is supplemented with information regarding textures and material (colours RGB,transparency and brightness)
- Filling level 2b: filling level 1 is amended with information about front division and front finishes
- Filling level 2c: filling level 1 is supplemented with information about handles.
- Filling level 2d: filling level 1 is amended with information about item textures.

Combinations of filling levels 2a-2d are possible. Following itemized breakdowns of combinations are defined:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Filling level 3. To achieve filling level 3 information in the filling levels 1 and 2a - 2d supplemented by information about the modeling graphic is required. In filling level 3 all options of the data format for manufacturer specific illustrations are entirely applied.
A complete definition of the information required for the different filling levels is provided in the table "Filling levels". 		D string
P [123]|2[a-n]
M [1:2]
Namespace (none)
Type
Restriction of xs:string
Diagram
FILLING_LEVEL Element
Overview
FILLING_LEVEL Restriction of xs:string
100--44--Fuellstufe Version Beta 2.0 Build 0
The filling level (FILLING_LEVEL) defines the level of details which are provided in a database. In general, an increase in the filling level corresponds with an increase in data quality. The higher the degree of detail specification in the data, the more specific they are for a certain manufacturer.
The different filling levels are evaluated during the certification procedure: By checking the filling levels it is ascertained which information is required in the data, in order to achieve the filling level. In case the required information is missing in a filling level, the complete set of data is not certified.
The filling levels are defined as follows:
- Filling level 1: provides basic information except from elements for the description of texture information
- Filling level 2a: filling level 1 is supplemented with information regarding textures and material (colours RGB,transparency and brightness)
- Filling level 2b: filling level 1 is amended with information about front division and front finishes
- Filling level 2c: filling level 1 is supplemented with information about handles.
- Filling level 2d: filling level 1 is amended with information about item textures.

Combinations of filling levels 2a-2d are possible. Following itemized breakdowns of combinations are defined:
2 2a+2b+2c+2d
2a 2a
2b 2b
2c 2c
2d 2d
2e 2a+2b
2f 2a+2c
2g 2a+2d
2h 2b+2c
2i 2b+2d
2j 2c+2d
2k 2a+2b+2c
2l 2a+2b+2d
2m 2a+2c+2d
2n 2b+2c+2d

Filling level 3. To achieve filling level 3 information in the filling levels 1 and 2a - 2d supplemented by information about the modeling graphic is required. In filling level 3 all options of the data format for manufacturer specific illustrations are entirely applied.
A complete definition of the information required for the different filling levels is provided in the table "Filling levels". 		D string
P [123]|2[a-n]
M [1:2]
Source
<xs:element name="FILLING_LEVEL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--44--Fuellstufe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[123]|2[a-n]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PRICING_TERMS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : PRICING_TERMS Element
Description
100--48--Preisstellung Version Beta 2.0 Build 0, K. Richter 25.03.2014
This element defines the pricing terms for the catalog prices.
A complete definition of the information required for the dThis element defines the pricing terms for the catalog prices. The information in this field is used for a correct data import in order to avoid overwriting of price information.

The following values are used:
0 = prices in the catalogue are purchase prices for dealers
1 = prices in the catalogue are recommended retail prices (UPE)

All price information in the catalogue has to correspond to the information in this element. 		D string
P [01]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
PRICING_TERMS Element
Overview
PRICING_TERMS optional Restriction of xs:string
100--48--Preisstellung Version Beta 2.0 Build 0, K. Richter 25.03.2014
This element defines the pricing terms for the catalog prices.
A complete definition of the information required for the dThis element defines the pricing terms for the catalog prices. The information in this field is used for a correct data import in order to avoid overwriting of price information.

The following values are used:
0 = prices in the catalogue are purchase prices for dealers
1 = prices in the catalogue are recommended retail prices (UPE)

All price information in the catalogue has to correspond to the information in this element. 		D string
P [01]
M [1:1]
Source
<xs:element name="PRICING_TERMS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--48--Preisstellung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="1" />
      <xs:pattern value="[01]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_INFO Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : CATALOG_INFO Element
Description
110--3--Textzeile Version Beta 2.0 Build 0Information texts are stored in this element.
Namespace (none)
Type
languagetexte60999 Complex Type
Diagram
LANGUAGE Element Sequence CATALOG_INFO Element
Overview
CATALOG_INFO optional languagetexte60999 Complex Type
110--3--Textzeile Version Beta 2.0 Build 0Information texts are stored in this element.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="CATALOG_INFO" type="languagetexte60999" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>110--3--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 Block XML-Schema > languagetexte60999 Complex Type : LANGUAGE Element
Description
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required 150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>150--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>265--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,60}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte60999 Complex Type | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
IDM 2.7.0 Block XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element : TEXT_LINE Element
Description
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
Namespace (none)
Diagram
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
SEQUENCE_NO Restriction of xs:positiveInteger required 150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Source
<xs:element name="TEXT_LINE" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
LANGUAGE Element | languagetexte60999 Complex Type | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 Block XML-Schema > languagetexte60999 Complex Type > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Description
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | languagetexte60999 Complex Type | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

FALL_BACK_LANGUAGE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > CATALOG Element : FALL_BACK_LANGUAGE Element
Description
100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind K. Richter 29.06.2017
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The two-digit ISO language code must be used. D language
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:language
Diagram
FALL_BACK_LANGUAGE Element
Overview
FALL_BACK_LANGUAGE optional Restriction of xs:language
100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind K. Richter 29.06.2017
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified.The two-digit ISO language code must be used. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="FALL_BACK_LANGUAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
    <xs:documentation>K. Richter 29.06.2017</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

SUPPLIER Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element : SUPPLIER Element
Description
100--1--Satzart Version Beta 2.0 Build 0All relevant supplier data, e.g. communication and contact details, are stored in this element.
Namespace (none)
Diagram
CONTACT_SUPPLIER Element CONTACT_PERSON Element Sequence SUPPLIER Element
Overview
SUPPLIER
100--1--Satzart Version Beta 2.0 Build 0All relevant supplier data, e.g. communication and contact details, are stored in this element.
Sequence
CONTACT_PERSON 1..2
100--0--NEW Version Beta 2.0 Build 0All information concerning the contact person is defined in this element.
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
100--0--NEW Version Beta 2.0 Build 2
Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact). D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
100--0--NEW Version Beta 2.0 Build 0
The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute. D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
100--26/33--Ansprechp_Name_1/2 Version Beta 2.0 Build 0
The family name of the direct contact person for the software suppliers is defined in this element. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
100--27/34--Vorname_1/2 Version Beta 2.0 Build 0
The first name of the direct contact person is entered here. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
100--28/35--Anrede_ID_1/2 Version Beta 2.0 Build 0
The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
100--29/36--Abteilung_1/2 Version Beta 2.0 Build 0
If applicable, the department of the contact person is defined in this field. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
100--30/37--Telefon_1/2 Version Beta 2.0 Build 0
This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
100--31/38--Fax_1/2 Version Beta 2.0 Build 0
This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
100--18--E_MAIL_Adresse Version Beta 2.0 Build 4, K. Richter 21.03.2014
This element contains the E-Mail address of the contact person. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
STREET optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
CITY optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
CONTACT_SUPPLIER
100--0--NEW Version Beta 2.0 Build 0All contact information for the specific manufacturer is defined in this element.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
100--16--Herstellername_1 Version Beta 2.0 Build 2
This element contains the first line of the manufacturer's name. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
100--17--Herstellername_2 Version Beta 2.0 Build 2
This element contains the second line of the manufacturer's name. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
100--18--E_MAIL_Adresse Version Beta 2.0 Build 4, K. Richter 21.03.2014
The official E-Mail address of the manufacturer is defined in this element.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string
100--19--Internet_Adresse Version Beta 2.0 Build 4
If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com). D string
P
M
STREET Restriction of xs:string
100--20--Strasse Version Beta 2.0 Build 0
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
100--21--PLZ_Strasse Version Beta 2.0 Build 4
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
CITY Restriction of xs:string
100--22--Ort Version Beta 2.0 Build 0
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
ZIPCODE_POSTBOX optional Restriction of xs:string
100--23--PLZ_Postfach Version Beta 2.0 Build 0
If applicable, the ZIP code of the manufacturer's postbox address is entered here. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
100--24--Postfach Version Beta 2.0 Build 0
If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
100--41--Telefon_Zentrale Version Beta 2.0 Build 0
This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
100--42--Fax_Zentrale Version Beta 2.0 Build 0
This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Source
<xs:element name="SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONTACT_PERSON" maxOccurs="2">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONTACT_PERSON_NO">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_ROLE">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="60" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONTACT_NAME">
              <xs:annotation>
                <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FIRST_NAME">
              <xs:annotation>
                <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="20" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FORM_OF_ADDRESS">
              <xs:annotation>
                <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="2" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DEPARTMENT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE">
              <xs:annotation>
                <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONTACT_SUPPLIER">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="MANUFACTURER_NAME_1">
              <xs:annotation>
                <xs:documentation>100--16--Herstellername_1</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--17--Herstellername_2</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EMAIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INTERNET_ADDRESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--19--Internet_Adresse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="STREET">
              <xs:annotation>
                <xs:documentation>100--20--Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_STREET">
              <xs:annotation>
                <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CITY">
              <xs:annotation>
                <xs:documentation>100--22--Ort</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="30" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="POSTBOX" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--24--Postfach</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[0-9a-zA-Z]{0,10}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TELEPHONE_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FAX_SWITCHBOARD">
              <xs:annotation>
                <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="18" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CONTACT_PERSON Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element : CONTACT_PERSON Element
Description
100--0--NEW Version Beta 2.0 Build 0All information concerning the contact person is defined in this element.
Namespace (none)
Diagram
CITY Element ZIPCODE_STREET Element STREET Element EMAIL Element FAX Element TELEPHONE Element DEPARTMENT Element FORM_OF_ADDRESS Element FIRST_NAME Element CONTACT_NAME Element CONTACT_ROLE Element CONTACT_PERSON_NO Element Sequence CONTACT_PERSON Element
Overview
CONTACT_PERSON 1..2
100--0--NEW Version Beta 2.0 Build 0All information concerning the contact person is defined in this element.
Sequence
CONTACT_PERSON_NO Restriction of xs:positiveInteger
100--0--NEW Version Beta 2.0 Build 2
Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact). D positiveInteger
P
M [1:2]
CONTACT_ROLE Restriction of xs:string
100--0--NEW Version Beta 2.0 Build 0
The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute. D string
P
M [1:60]
CONTACT_NAME Restriction of xs:string
100--26/33--Ansprechp_Name_1/2 Version Beta 2.0 Build 0
The family name of the direct contact person for the software suppliers is defined in this element. D string
P
M [1:20]
FIRST_NAME Restriction of xs:string
100--27/34--Vorname_1/2 Version Beta 2.0 Build 0
The first name of the direct contact person is entered here. D string
P
M [1:20]
FORM_OF_ADDRESS Restriction of xs:positiveInteger
100--28/35--Anrede_ID_1/2 Version Beta 2.0 Build 0
The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
DEPARTMENT optional Restriction of xs:string
100--29/36--Abteilung_1/2 Version Beta 2.0 Build 0
If applicable, the department of the contact person is defined in this field. D string
P
M [1:15]
TELEPHONE Restriction of xs:string
100--30/37--Telefon_1/2 Version Beta 2.0 Build 0
This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
FAX optional Restriction of xs:string
100--31/38--Fax_1/2 Version Beta 2.0 Build 0
This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284. D string
P
M [1:18]
EMAIL optional Restriction of xs:string
100--18--E_MAIL_Adresse Version Beta 2.0 Build 4, K. Richter 21.03.2014
This element contains the E-Mail address of the contact person. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
STREET optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
ZIPCODE_STREET optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
CITY optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
Source
<xs:element name="CONTACT_PERSON" maxOccurs="2" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONTACT_PERSON_NO">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_ROLE">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="60" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONTACT_NAME">
        <xs:annotation>
          <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FIRST_NAME">
        <xs:annotation>
          <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="20" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FORM_OF_ADDRESS">
        <xs:annotation>
          <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="2" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DEPARTMENT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE">
        <xs:annotation>
          <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CONTACT_PERSON_NO Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_PERSON_NO Element
Description
100--0--NEW Version Beta 2.0 Build 2
Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact). D positiveInteger
P
M [1:2]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
CONTACT_PERSON_NO Element
Overview
CONTACT_PERSON_NO Restriction of xs:positiveInteger
100--0--NEW Version Beta 2.0 Build 2
Priorities in contacting the manufacturer's contact persons are defined in this element (1=1. contact, 2=2. contact). D positiveInteger
P
M [1:2]
Source
<xs:element name="CONTACT_PERSON_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CONTACT_ROLE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_ROLE Element
Description
100--0--NEW Version Beta 2.0 Build 0
The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute. D string
P
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
CONTACT_ROLE Element
Overview
CONTACT_ROLE Restriction of xs:string
100--0--NEW Version Beta 2.0 Build 0
The different roles of the manufacturer's contact persons are defined in this element, e.g. EDI specialist, substitute. D string
P
M [1:60]
Source
<xs:element name="CONTACT_ROLE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="60" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CONTACT_NAME Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : CONTACT_NAME Element
Description
100--26/33--Ansprechp_Name_1/2 Version Beta 2.0 Build 0
The family name of the direct contact person for the software suppliers is defined in this element. D string
P
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
CONTACT_NAME Element
Overview
CONTACT_NAME Restriction of xs:string
100--26/33--Ansprechp_Name_1/2 Version Beta 2.0 Build 0
The family name of the direct contact person for the software suppliers is defined in this element. D string
P
M [1:20]
Source
<xs:element name="CONTACT_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--26/33--Ansprechp_Name_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

FIRST_NAME Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : FIRST_NAME Element
Description
100--27/34--Vorname_1/2 Version Beta 2.0 Build 0
The first name of the direct contact person is entered here. D string
P
M [1:20]
Namespace (none)
Type
Restriction of xs:string
Diagram
FIRST_NAME Element
Overview
FIRST_NAME Restriction of xs:string
100--27/34--Vorname_1/2 Version Beta 2.0 Build 0
The first name of the direct contact person is entered here. D string
P
M [1:20]
Source
<xs:element name="FIRST_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--27/34--Vorname_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="20" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

FORM_OF_ADDRESS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : FORM_OF_ADDRESS Element
Description
100--28/35--Anrede_ID_1/2 Version Beta 2.0 Build 0
The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
FORM_OF_ADDRESS Element
Overview
FORM_OF_ADDRESS Restriction of xs:positiveInteger
100--28/35--Anrede_ID_1/2 Version Beta 2.0 Build 0
The correct address of the contact person is defined by the following values.
1 = Mrs
2 = Mr 		D positiveInteger
P
M [1:2]
Source
<xs:element name="FORM_OF_ADDRESS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--28/35--Anrede_ID_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="2" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

DEPARTMENT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : DEPARTMENT Element
Description
100--29/36--Abteilung_1/2 Version Beta 2.0 Build 0
If applicable, the department of the contact person is defined in this field. D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
DEPARTMENT Element
Overview
DEPARTMENT optional Restriction of xs:string
100--29/36--Abteilung_1/2 Version Beta 2.0 Build 0
If applicable, the department of the contact person is defined in this field. D string
P
M [1:15]
Source
<xs:element name="DEPARTMENT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--29/36--Abteilung_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TELEPHONE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : TELEPHONE Element
Description
100--30/37--Telefon_1/2 Version Beta 2.0 Build 0
This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
TELEPHONE Element
Overview
TELEPHONE Restriction of xs:string
100--30/37--Telefon_1/2 Version Beta 2.0 Build 0
This element contains the phone number of the contact person including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Source
<xs:element name="TELEPHONE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--30/37--Telefon_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

FAX Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : FAX Element
Description
100--31/38--Fax_1/2 Version Beta 2.0 Build 0
This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
FAX Element
Overview
FAX optional Restriction of xs:string
100--31/38--Fax_1/2 Version Beta 2.0 Build 0
This element contains the fax number of the contact person including international dialing code and area code. e.g.: +49(5251)60-3284. D string
P
M [1:18]
Source
<xs:element name="FAX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--31/38--Fax_1/2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

EMAIL Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : EMAIL Element
Description
100--18--E_MAIL_Adresse Version Beta 2.0 Build 4, K. Richter 21.03.2014
This element contains the E-Mail address of the contact person. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
Namespace (none)
Type
Restriction of xs:string
Diagram
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
100--18--E_MAIL_Adresse Version Beta 2.0 Build 4, K. Richter 21.03.2014
This element contains the E-Mail address of the contact person. D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}"
M
Source
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

STREET Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : STREET Element
Description
1000--0--NEW Version Beta 2.0 Build 4
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
STREET Element
Overview
STREET optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
Source
<xs:element name="STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : ZIPCODE_STREET Element
Description
1000--0--NEW Version Beta 2.0 Build 4
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
Namespace (none)
Type
Restriction of xs:string
Diagram
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
Source
<xs:element name="ZIPCODE_STREET" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CITY Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_PERSON Element : CITY Element
Description
1000--0--NEW Version Beta 2.0 Build 4
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
CITY Element
Overview
CITY optional Restriction of xs:string
1000--0--NEW Version Beta 2.0 Build 4
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
Source
<xs:element name="CITY" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_PERSON Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CONTACT_SUPPLIER Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element : CONTACT_SUPPLIER Element
Description
100--0--NEW Version Beta 2.0 Build 0All contact information for the specific manufacturer is defined in this element.
Namespace (none)
Diagram
FAX_SWITCHBOARD Element TELEPHONE_SWITCHBOARD Element POSTBOX Element ZIPCODE_POSTBOX Element CITY Element ZIPCODE_STREET Element STREET Element INTERNET_ADDRESS Element EMAIL Element MANUFACTURER_NAME_2 Element MANUFACTURER_NAME_1 Element Sequence CONTACT_SUPPLIER Element
Overview
CONTACT_SUPPLIER
100--0--NEW Version Beta 2.0 Build 0All contact information for the specific manufacturer is defined in this element.
Sequence
MANUFACTURER_NAME_1 Restriction of xs:string
100--16--Herstellername_1 Version Beta 2.0 Build 2
This element contains the first line of the manufacturer's name. D string
P
M [1:30]
MANUFACTURER_NAME_2 optional Restriction of xs:string
100--17--Herstellername_2 Version Beta 2.0 Build 2
This element contains the second line of the manufacturer's name. D string
P
M [1:30]
EMAIL optional Restriction of xs:string
100--18--E_MAIL_Adresse Version Beta 2.0 Build 4, K. Richter 21.03.2014
The official E-Mail address of the manufacturer is defined in this element.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

INTERNET_ADDRESS optional Restriction of xs:string
100--19--Internet_Adresse Version Beta 2.0 Build 4
If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com). D string
P
M
STREET Restriction of xs:string
100--20--Strasse Version Beta 2.0 Build 0
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
ZIPCODE_STREET Restriction of xs:string
100--21--PLZ_Strasse Version Beta 2.0 Build 4
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
CITY Restriction of xs:string
100--22--Ort Version Beta 2.0 Build 0
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
ZIPCODE_POSTBOX optional Restriction of xs:string
100--23--PLZ_Postfach Version Beta 2.0 Build 0
If applicable, the ZIP code of the manufacturer's postbox address is entered here. D string
P
M [1:8]
POSTBOX optional Restriction of xs:string
100--24--Postfach Version Beta 2.0 Build 0
If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
TELEPHONE_SWITCHBOARD Restriction of xs:string
100--41--Telefon_Zentrale Version Beta 2.0 Build 0
This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890. D string
P
M [1:18]
FAX_SWITCHBOARD Restriction of xs:string
100--42--Fax_Zentrale Version Beta 2.0 Build 0
This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Source
<xs:element name="CONTACT_SUPPLIER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="MANUFACTURER_NAME_1">
        <xs:annotation>
          <xs:documentation>100--16--Herstellername_1</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="MANUFACTURER_NAME_2" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--17--Herstellername_2</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EMAIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INTERNET_ADDRESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--19--Internet_Adresse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="STREET">
        <xs:annotation>
          <xs:documentation>100--20--Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_STREET">
        <xs:annotation>
          <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CITY">
        <xs:annotation>
          <xs:documentation>100--22--Ort</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="30" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ZIPCODE_POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="POSTBOX" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--24--Postfach</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[0-9a-zA-Z]{0,10}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TELEPHONE_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FAX_SWITCHBOARD">
        <xs:annotation>
          <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="18" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

MANUFACTURER_NAME_1 Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_1 Element
Description
100--16--Herstellername_1 Version Beta 2.0 Build 2
This element contains the first line of the manufacturer's name. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
MANUFACTURER_NAME_1 Element
Overview
MANUFACTURER_NAME_1 Restriction of xs:string
100--16--Herstellername_1 Version Beta 2.0 Build 2
This element contains the first line of the manufacturer's name. D string
P
M [1:30]
Source
<xs:element name="MANUFACTURER_NAME_1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--16--Herstellername_1</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

MANUFACTURER_NAME_2 Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : MANUFACTURER_NAME_2 Element
Description
100--17--Herstellername_2 Version Beta 2.0 Build 2
This element contains the second line of the manufacturer's name. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
MANUFACTURER_NAME_2 Element
Overview
MANUFACTURER_NAME_2 optional Restriction of xs:string
100--17--Herstellername_2 Version Beta 2.0 Build 2
This element contains the second line of the manufacturer's name. D string
P
M [1:30]
Source
<xs:element name="MANUFACTURER_NAME_2" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--17--Herstellername_2</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

EMAIL Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : EMAIL Element
Description
100--18--E_MAIL_Adresse Version Beta 2.0 Build 4, K. Richter 21.03.2014
The official E-Mail address of the manufacturer is defined in this element.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

Namespace (none)
Type
Restriction of xs:string
Diagram
EMAIL Element
Overview
EMAIL optional Restriction of xs:string
100--18--E_MAIL_Adresse Version Beta 2.0 Build 4, K. Richter 21.03.2014
The official E-Mail address of the manufacturer is defined in this element.

D string
P [a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}

M

Source
<xs:element name="EMAIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--18--E_MAIL_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-zA-Z0-9._+\-!#$'*/=?^_`{|}~]+@[a-zA-Z0-9.\-]+\.[a-zA-Z]{2,}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

INTERNET_ADDRESS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : INTERNET_ADDRESS Element
Description
100--19--Internet_Adresse Version Beta 2.0 Build 4
If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com). D string
P
M
Namespace (none)
Type
Restriction of xs:string
Diagram
INTERNET_ADDRESS Element
Overview
INTERNET_ADDRESS optional Restriction of xs:string
100--19--Internet_Adresse Version Beta 2.0 Build 4
If applicable, the official homepage of the manufacturer is defined in this element (e.g.: http://www.company.com). D string
P
M
Source
<xs:element name="INTERNET_ADDRESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--19--Internet_Adresse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

STREET Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : STREET Element
Description
100--20--Strasse Version Beta 2.0 Build 0
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
STREET Element
Overview
STREET Restriction of xs:string
100--20--Strasse Version Beta 2.0 Build 0
The street address of the manufacturer is defined in this element. D string
P
M [1:30]
Source
<xs:element name="STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--20--Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ZIPCODE_STREET Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_STREET Element
Description
100--21--PLZ_Strasse Version Beta 2.0 Build 4
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
Namespace (none)
Type
Restriction of xs:string
Diagram
ZIPCODE_STREET Element
Overview
ZIPCODE_STREET Restriction of xs:string
100--21--PLZ_Strasse Version Beta 2.0 Build 4
The ZIP code for the street address of the manufacturer is defined in this element. D string
P
M [1:8]
Source
<xs:element name="ZIPCODE_STREET" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--21--PLZ_Strasse</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CITY Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : CITY Element
Description
100--22--Ort Version Beta 2.0 Build 0
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
CITY Element
Overview
CITY Restriction of xs:string
100--22--Ort Version Beta 2.0 Build 0
The city name of the manufacturer's address is entered here. D string
P
M [1:30]
Source
<xs:element name="CITY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--22--Ort</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="30" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ZIPCODE_POSTBOX Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : ZIPCODE_POSTBOX Element
Description
100--23--PLZ_Postfach Version Beta 2.0 Build 0
If applicable, the ZIP code of the manufacturer's postbox address is entered here. D string
P
M [1:8]
Namespace (none)
Type
Restriction of xs:string
Diagram
ZIPCODE_POSTBOX Element
Overview
ZIPCODE_POSTBOX optional Restriction of xs:string
100--23--PLZ_Postfach Version Beta 2.0 Build 0
If applicable, the ZIP code of the manufacturer's postbox address is entered here. D string
P
M [1:8]
Source
<xs:element name="ZIPCODE_POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--23--PLZ_Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

POSTBOX Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : POSTBOX Element
Description
100--24--Postfach Version Beta 2.0 Build 0
If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
POSTBOX Element
Overview
POSTBOX optional Restriction of xs:string
100--24--Postfach Version Beta 2.0 Build 0
If applicable, the postbox number of the manufacturer's address is defined in this element. The word "postbox" has to be omitted. D string
P [0-9a-zA-Z]{0,10}
M [0:10]
Source
<xs:element name="POSTBOX" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--24--Postfach</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[0-9a-zA-Z]{0,10}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TELEPHONE_SWITCHBOARD Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : TELEPHONE_SWITCHBOARD Element
Description
100--41--Telefon_Zentrale Version Beta 2.0 Build 0
This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
TELEPHONE_SWITCHBOARD Element
Overview
TELEPHONE_SWITCHBOARD Restriction of xs:string
100--41--Telefon_Zentrale Version Beta 2.0 Build 0
This element contains the manufacturer's switchboard telephone number including international dialing code and area code, e.g.: +49(1234)56-7890. D string
P
M [1:18]
Source
<xs:element name="TELEPHONE_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--41--Telefon_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

FAX_SWITCHBOARD Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SUPPLIER Element > CONTACT_SUPPLIER Element : FAX_SWITCHBOARD Element
Description
100--42--Fax_Zentrale Version Beta 2.0 Build 0
This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Namespace (none)
Type
Restriction of xs:string
Diagram
FAX_SWITCHBOARD Element
Overview
FAX_SWITCHBOARD Restriction of xs:string
100--42--Fax_Zentrale Version Beta 2.0 Build 0
This element contains the manufacturer's switchboard fax number including international dialing code and area code, e. g.: +49(1234)56-7890. D string
P
M [1:18]
Source
<xs:element name="FAX_SWITCHBOARD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--42--Fax_Zentrale</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="18" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONTACT_SUPPLIER Element | SUPPLIER Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

GLOBAL_DEFINITION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element : GLOBAL_DEFINITION Element
Description
1000--0--NEW Version Beta 2.0 Build 0 AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.This element is used for defining global data which apply to the complete catalogue/ database (global information).
Namespace (none)
Diagram
DETAIL_INFOS Element CLEARING_GROUP Element Sequence GLOBAL_DEFINITION Element
Overview
GLOBAL_DEFINITION optional
1000--0--NEW Version Beta 2.0 Build 0 AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.This element is used for defining global data which apply to the complete catalogue/ database (global information).
Sequence
CLEARING_GROUP 0..∞
120--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of clearing groups. Different exchange_IDs are summarized and made up to a clearing group (element.

The clearing groups in the block conditions (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) and the grading tables (BLOCK_VALUE_CALCULATION/GRADING_TABLE) are used for the definition of a minimum value for a certain type range. The different type ranges can be identified by their corresponding exchange_ID.

The single amounts of all items which belong to a certain exchange_ID are summarized. A total amount is summed up for each clearing group. This amount is defined as reference value for further use in block calculation and for the value clearing grading table.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
120--1--Satzart Version Beta 2.0 Build 0
This attribute identifies a clearing group. D nonNegativeInteger
P
M [0:999]
Sequence
EXCHANGE_ID_REF 1..∞
120--0--NEW Version Beta 2.0 Build 0This element references an exchange-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
120--0--NEW Version Beta 2.0 Build 0
This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
CLEARING_GROUP_NAME languagetexte60 Complex Type
120--4--Verrechnungsgruppe_Bez Version Beta 2.0 Build 0Name for a clearing group. This is used in order to simplify data acquisition.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
DETAIL_INFOS optional
1000--0--NEW 13.06.2018/K.RichterThis element is used for saving hyperlinks with detail information
Sequence
DETAIL_INFO 1..∞
1000--0--NEW 30.05.2012/Bur

This element is used to define a detail information.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
1000--0--NEW 30.05.2012/Bur
This attribute identifies detail information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
1000--0--NEW 30.05.2012/Bur
This element is used for the classification of detail information.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
This element is here to describe the type of detailed information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
1000--0--NEW 30.05.2012/BurName of the link (e.g. "magic corner in motion").
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
1000--0--NEW 30.05.2012/BurElement for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
1000--0--NEW 18.11.2013 /FurniTec
This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
1000--0--NEW 30.05.2012/BurText information for a tool tip with reference to the link.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
URL
1000--0--NEW 30.05.2012/BurThis element contains the URL for the detail information.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW in Datentyp language geändert, 04.05 Kerstin Richter
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file . 		D positiveInteger
P
M [1:4]
Source
<xs:element name="GLOBAL_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>120--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>120--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="CLEARING_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASSIFICATION">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INFO_TYPE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                      <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                      <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[01]|99" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="INTERNAL_NAME" type="languagetexte40">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="GUID">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                      <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="URL">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                  <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:anyURI">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="1024" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="HASH_VALUE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="64" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESOLUTION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="4" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element : CLEARING_GROUP Element
Description
120--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of clearing groups. Different exchange_IDs are summarized and made up to a clearing group (element.

The clearing groups in the block conditions (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) and the grading tables (BLOCK_VALUE_CALCULATION/GRADING_TABLE) are used for the definition of a minimum value for a certain type range. The different type ranges can be identified by their corresponding exchange_ID.

The single amounts of all items which belong to a certain exchange_ID are summarized. A total amount is summed up for each clearing group. This amount is defined as reference value for further use in block calculation and for the value clearing grading table.
Namespace (none)
Diagram
LANGUAGE Element Sequence CLEARING_GROUP_NAME Element EXCHANGE_ID_REF Element Sequence CLEARING_GROUP Element
Overview
CLEARING_GROUP 0..∞
120--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of clearing groups. Different exchange_IDs are summarized and made up to a clearing group (element.

The clearing groups in the block conditions (BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS) and the grading tables (BLOCK_VALUE_CALCULATION/GRADING_TABLE) are used for the definition of a minimum value for a certain type range. The different type ranges can be identified by their corresponding exchange_ID.

The single amounts of all items which belong to a certain exchange_ID are summarized. A total amount is summed up for each clearing group. This amount is defined as reference value for further use in block calculation and for the value clearing grading table.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
120--1--Satzart Version Beta 2.0 Build 0
This attribute identifies a clearing group. D nonNegativeInteger
P
M [0:999]
Sequence
EXCHANGE_ID_REF 1..∞
120--0--NEW Version Beta 2.0 Build 0This element references an exchange-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
120--0--NEW Version Beta 2.0 Build 0
This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
CLEARING_GROUP_NAME languagetexte60 Complex Type
120--4--Verrechnungsgruppe_Bez Version Beta 2.0 Build 0Name for a clearing group. This is used in order to simplify data acquisition.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
CLEARING_GROUP_NO Restriction of xs:nonNegativeInteger required 120--1--Satzart Version Beta 2.0 Build 0
This attribute identifies a clearing group. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="CLEARING_GROUP" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>120--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>120--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CLEARING_GROUP_NAME" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="CLEARING_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > CLEARING_GROUP Element : EXCHANGE_ID_REF Element
Description
120--0--NEW Version Beta 2.0 Build 0This element references an exchange-ID.
Namespace (none)
Diagram
EXCHANGE_ID_REF Element
Overview
EXCHANGE_ID_REF 1..∞
120--0--NEW Version Beta 2.0 Build 0This element references an exchange-ID.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
120--0--NEW Version Beta 2.0 Build 0
This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attributes
Name Type Use Default Fixed Description
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required 120--0--NEW Version Beta 2.0 Build 0
This element contains the exchange_IDs which are combined to a clearing group. Values 0, 98 and 99 are not permitted. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Source
<xs:element name="EXCHANGE_ID_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>120--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
CLEARING_GROUP Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_NAME Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > CLEARING_GROUP Element : CLEARING_GROUP_NAME Element
Description
120--4--Verrechnungsgruppe_Bez Version Beta 2.0 Build 0Name for a clearing group. This is used in order to simplify data acquisition.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence CLEARING_GROUP_NAME Element
Overview
CLEARING_GROUP_NAME languagetexte60 Complex Type
120--4--Verrechnungsgruppe_Bez Version Beta 2.0 Build 0Name for a clearing group. This is used in order to simplify data acquisition.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="CLEARING_GROUP_NAME" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>120--4--Verrechnungsgruppe_Bez</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CLEARING_GROUP Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 Block XML-Schema > languagetexte60 Complex Type : LANGUAGE Element
Description
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required 150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>150--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>265--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte60 Complex Type | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 Block XML-Schema > languagetexte60 Complex Type > LANGUAGE Element : TEXT Element
Description
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>265--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetexte60 Complex Type | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element : DETAIL_INFOS Element
Description
1000--0--NEW 13.06.2018/K.RichterThis element is used for saving hyperlinks with detail information
Namespace (none)
Diagram
DETAIL_INFO Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
1000--0--NEW 13.06.2018/K.RichterThis element is used for saving hyperlinks with detail information
Sequence
DETAIL_INFO 1..∞
1000--0--NEW 30.05.2012/Bur

This element is used to define a detail information.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
1000--0--NEW 30.05.2012/Bur
This attribute identifies detail information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
1000--0--NEW 30.05.2012/Bur
This element is used for the classification of detail information.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
This element is here to describe the type of detailed information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
1000--0--NEW 30.05.2012/BurName of the link (e.g. "magic corner in motion").
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
1000--0--NEW 30.05.2012/BurElement for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
1000--0--NEW 18.11.2013 /FurniTec
This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
1000--0--NEW 30.05.2012/BurText information for a tool tip with reference to the link.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
URL
1000--0--NEW 30.05.2012/BurThis element contains the URL for the detail information.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW in Datentyp language geändert, 04.05 Kerstin Richter
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file . 		D positiveInteger
P
M [1:4]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
13.06.2018/K.Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASSIFICATION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="INFO_TYPE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
                <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
                <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[01]|99" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="INTERNAL_NAME" type="languagetexte40">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="GUID">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="URL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:anyURI">
                              <xs:minLength value="1" />
                              <xs:maxLength value="1024" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="HASH_VALUE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="64" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESOLUTION" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="4" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

DETAIL_INFO Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element : DETAIL_INFO Element
Description
1000--0--NEW 30.05.2012/Bur

This element is used to define a detail information.

Namespace (none)
Diagram
RESOLUTION Element URL Element LANGUAGE Element Sequence TOOL_TIP Element GUID Element LANGUAGE Element Sequence INTERNAL_NAME Element LANGUAGE Element Sequence EXTERNAL_NAME Element INFO_TYPE Element CLASSIFICATION Element Sequence DETAIL_INFO Element
Overview
DETAIL_INFO 1..∞
1000--0--NEW 30.05.2012/Bur

This element is used to define a detail information.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
1000--0--NEW 30.05.2012/Bur
This attribute identifies detail information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
1000--0--NEW 30.05.2012/Bur
This element is used for the classification of detail information.
 D string
P
M [1:8]
INFO_TYPE Restriction of xs:positiveInteger
This element is here to describe the type of detailed information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
EXTERNAL_NAME optional languagetexte Complex Type
1000--0--NEW 30.05.2012/BurName of the link (e.g. "magic corner in motion").
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
INTERNAL_NAME languagetexte40 Complex Type
1000--0--NEW 30.05.2012/BurElement for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
GUID Restriction of xs:string
1000--0--NEW 18.11.2013 /FurniTec
This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
TOOL_TIP optional languagetexte Complex Type
1000--0--NEW 30.05.2012/BurText information for a tool tip with reference to the link.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
URL
1000--0--NEW 30.05.2012/BurThis element contains the URL for the detail information.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW in Datentyp language geändert, 04.05 Kerstin Richter
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
RESOLUTION optional Restriction of xs:positiveInteger
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file . 		D positiveInteger
P
M [1:4]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required 1000--0--NEW 30.05.2012/Bur
This attribute identifies detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASSIFICATION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="INFO_TYPE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
          <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
          <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[01]|99" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="INTERNAL_NAME" type="languagetexte40">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="GUID">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
          <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="URL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:anyURI">
                        <xs:minLength value="1" />
                        <xs:maxLength value="1024" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="HASH_VALUE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="64" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESOLUTION" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="4" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        <xs:documentation xml:lang="DE">Type von anyType in positiveInteger geändert
28.10.2013 /FurniTec</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CLASSIFICATION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : CLASSIFICATION Element
Description
1000--0--NEW 30.05.2012/Bur
This element is used for the classification of detail information.
 D string
P
M [1:8]
Namespace (none)
Type
Restriction of xs:string
Diagram
CLASSIFICATION Element
Overview
CLASSIFICATION Restriction of xs:string
1000--0--NEW 30.05.2012/Bur
This element is used for the classification of detail information.
 D string
P
M [1:8]
Source
<xs:element name="CLASSIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">ComplexType in SimpleType/string geändert, Längenbeschränkung 1-8 ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

INFO_TYPE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INFO_TYPE Element
Description
This element is here to describe the type of detailed information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
INFO_TYPE Element
Overview
INFO_TYPE Restriction of xs:positiveInteger
This element is here to describe the type of detailed information.

1 = milieu photo
2 = item sketch
3 = item photo
4 = version photo
5 = version texture
6 = manufacturer logo/product brand
7 = model description sheets
8 = installation instructions
9 = marketing
10 = pictogram sketch
11 = video
99 = miscellaneous 		D positiveInteger
P [1-9]|1[01]|99
M [1:11],99
Source
<xs:element name="INFO_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">SimpleType/positiveInteger und Wertebereich 1-10 ergänzt
12.02.2014 /FurniTec</xs:documentation>
    <xs:documentation xml:lang="DE">Kardinalität von 1-n in 1 geändert
12.02.2014 /FurniTec</xs:documentation>
    <xs:documentation xml:lang="DE">12.02.2014 /FurniTec
1   = Milieufoto
2   = Artikel Skizze
3   = Artikel Foto
4   = Variante Foto
5   = Variante Textur
6   = Logo Hersteller/Produktmarke
7   = Modellbeschreibungsblätter
8   = Montageanleitung
9   = Marketing
10  = Pictogrammskizze
11  = Video
99  = Sonstiges                                                </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[01]|99" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

EXTERNAL_NAME Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : EXTERNAL_NAME Element
Description
1000--0--NEW 30.05.2012/BurName of the link (e.g. "magic corner in motion").
Namespace (none)
Type
languagetexte Complex Type
Diagram
LANGUAGE Element Sequence EXTERNAL_NAME Element
Overview
EXTERNAL_NAME optional languagetexte Complex Type
1000--0--NEW 30.05.2012/BurName of the link (e.g. "magic corner in motion").
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
Source
<xs:element name="EXTERNAL_NAME" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 Block XML-Schema > languagetexte Complex Type : LANGUAGE Element
Description
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required 1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:string">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte Complex Type | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 Block XML-Schema > languagetexte Complex Type > LANGUAGE Element : TEXT Element
Description
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
Namespace (none)
Type
xs:string
Diagram
TEXT Element
Overview
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
Source
<xs:element name="TEXT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LANGUAGE Element | languagetexte Complex Type | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

INTERNAL_NAME Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INTERNAL_NAME Element
Description
1000--0--NEW 30.05.2012/BurElement for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.
Namespace (none)
Type
languagetexte40 Complex Type
Diagram
LANGUAGE Element Sequence INTERNAL_NAME Element
Overview
INTERNAL_NAME languagetexte40 Complex Type
1000--0--NEW 30.05.2012/BurElement for a more detailed description of the link.

The contents of this field is not supposed to be published or forwarded to sales partners,
but is only used for communication and information purposes between manufacturer and the software suppliers.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:element name="INTERNAL_NAME" type="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 Block XML-Schema > languagetexte40 Complex Type : LANGUAGE Element
Description
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required 150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,40}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetexte40 Complex Type | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 Block XML-Schema > languagetexte40 Complex Type > LANGUAGE Element : TEXT Element
Description
1000--0--NEW Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
1000--0--NEW Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,40}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetexte40 Complex Type | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

GUID Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : GUID Element
Description
1000--0--NEW 18.11.2013 /FurniTec
This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
Namespace (none)
Type
Restriction of xs:string
Diagram
GUID Element
Overview
GUID Restriction of xs:string
1000--0--NEW 18.11.2013 /FurniTec
This element assigns a globally unambiguous, and unique figure (Globally Unique Identifier (GUID))

The format of the GUID is defined as follows XXX-XXXX-XXXX-XXXX- XX. Each 'X' represents a character of the hexadecimal system, i.e. figures 0-9 or characters A-F. Example:
936DA01F-9ABD-4D9D-80C7-02AF85C822A8 (32-characters). 		D String
P [a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}
M [36:36]
Source
<xs:element name="GUID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
18.11.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[a-fA-F0-9]{8}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{4}-[a-fA-F0-9]{12}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TOOL_TIP Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : TOOL_TIP Element
Description
1000--0--NEW 30.05.2012/BurText information for a tool tip with reference to the link.
Namespace (none)
Type
languagetexte Complex Type
Diagram
LANGUAGE Element Sequence TOOL_TIP Element
Overview
TOOL_TIP optional languagetexte Complex Type
1000--0--NEW 30.05.2012/BurText information for a tool tip with reference to the link.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
Source
<xs:element name="TOOL_TIP" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
    <xs:documentation xml:lang="DE">minOccurs = "0" ergänzt
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

URL Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : URL Element
Description
1000--0--NEW 30.05.2012/BurThis element contains the URL for the detail information.
Namespace (none)
Diagram
LANGUAGE Element Sequence URL Element
Overview
URL
1000--0--NEW 30.05.2012/BurThis element contains the URL for the detail information.
Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW in Datentyp language geändert, 04.05 Kerstin Richter
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
Source
<xs:element name="URL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:anyURI">
                  <xs:minLength value="1" />
                  <xs:maxLength value="1024" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="HASH_VALUE" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="64" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element : LANGUAGE Element
Description
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
Namespace (none)
Diagram
HASH_VALUE Element TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW in Datentyp language geändert, 04.05 Kerstin Richter
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:anyURI
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required 1000--0--NEW in Datentyp language geändert, 04.05 Kerstin Richter
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:anyURI">
            <xs:minLength value="1" />
            <xs:maxLength value="1024" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="HASH_VALUE" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="64" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>in Datentyp language geändert, 04.05 Kerstin Richter</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : TEXT Element
Description
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
Namespace (none)
Type
Restriction of xs:anyURI
Diagram
TEXT Element
Overview
TEXT Restriction of xs:anyURI
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D anyURI
P
M [1:1024]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation xml:lang="DE">Type geändert in anyURI, maximale Länge mit 1024 definiert
28.10.2013 /FurniTec</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:anyURI">
      <xs:minLength value="1" />
      <xs:maxLength value="1024" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

HASH_VALUE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : HASH_VALUE Element
Description
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
Namespace (none)
Type
Restriction of xs:string
Diagram
HASH_VALUE Element
Overview
HASH_VALUE optional Restriction of xs:string
This element contains an encrypted representation of the image.

This enables each supplier to determine,
if the image had been downloaded or not. 		D string
P
M [1:64]
Source
<xs:element name="HASH_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
        Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
        14.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="64" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

RESOLUTION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : RESOLUTION Element
Description
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file . 		D positiveInteger
P
M [1:4]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
RESOLUTION Element
Overview
RESOLUTION optional Restriction of xs:positiveInteger
This element defines the resolution of an image. Possible values:
1=low, 2=medium, 3=large, 4=original file . 		D positiveInteger
P
M [1:4]
Source
<xs:element name="RESOLUTION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">In welcher Auflösung liegt das Bild vor. Mögliche Werte:
1=klein, 2=mittel, 3=groß, 4=Originaldatei
12.07.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="4" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

SERIES Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element : SERIES Element
Description
200--0--NEW Version Beta 2.0 Build 0This element is used to specify all series of the catalogue/data with the elements assigned to them, e.g. blocks and their items.
Namespace (none)
Diagram
SERIE Element Sequence SERIES Element
Overview
SERIES
200--0--NEW Version Beta 2.0 Build 0This element is used to specify all series of the catalogue/data with the elements assigned to them, e.g. blocks and their items.
Sequence
SERIE 1..100
200--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of the series.
Items belonging to series 0 are valid for all series. Therefore items of series 0 must not occur with the same type number (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in other series. Items of other series (unequal 0) may be used with the same type name in different series.
Buying prices are always indicated as the dealer’s buying prices
SERIE_NO required Restriction of xs:nonNegativeInteger
200--1--Satzart Version Beta 2.0 Build 0
This attribute defines the serial number of the series. D nonNegativeInteger
P
M [0:99]
Sequence
PRODUCT_GROUPS
1000--0--NEW Version Beta 2.0 Build 0This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types.
Sequence
PRODUCT_GROUP 1..∞
1000--0--NEW Version Beta 2.0 Build 0This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
1000--0--NEW Version Beta 2.0 Build 0This element is used for defining a name for a product group.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
ITEMS
400--1--Satzart Version Beta 2.0 Build 0This element defines all items belonging to one product group.
Sequence
ITEM 1..∞
400--0--NEW Version Beta 2.0 Build 0This element is used to define blocks and their items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes of the main catalogue.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
400--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) of the main catalogue with the value 0 in the element ADDITIONAL_PRICE.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_TYPE_REF
400/407--0--NEW Version Beta 2.0 Build 2This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPES
CALC_GROUP_REF
400--0--NEW Version Beta 2.0 Build 0This element references calculation groups. The calculation groups are defined within the product categories in the main catalogue.
EXCHANGE_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references a swap-ID, which is defined in the path1/EXCHANGE_ID element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
RESTRICTIONS optional
409--0--NEW Version Beta 2.0 Build 0This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
EDP_NUMBER optional Restriction of xs:string
400--10--EDV_Nummer Version Beta 2.0 Build 0
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
400--12--Block_Preisstatus Version Beta 2.0 Build 0
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
400--14--Artikelkennung Version Beta 2.0 Build 0
This element is used to assign an identifier to the article.
B = Block
E = Spare part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
400--15--Katalog_Seite Version Beta 2.0 Build 0 geändert K.Richter 25.02.2016
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
VAT_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references VAT tax rates.

The VAT tax rates are specified in the VALUE_ADDED_TAX element (path 1 of the main catalogue). A value of 0 is entered for items that are VAT-free.
If the value of 0 (VAT-free item) is used, the value must also be specified in the VALUE_ADDED_TAX element (path 1).

Element paths
Path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VALID_FROM optional Restriction of xs:date
400--18--Lieferbar_ab Version Beta 2.0 Build 0
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
400--19--Lieferbar_bis Version Beta 2.0 Build 0
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
400--34--Prog_abhaengig Version Beta 2.0 Build 0
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD of the main catalogue. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
BLOCK_PARTS optional
401--1--Satzart Version Beta 2.0 Build 0This element is used as a container element for the block parts lists in the catalogue.
ITEM_TEXT
410--1--Satzart Version Beta 2.0 Build 0This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
TYPE_KEY
445--1--Satzart Version Beta 2.0 Build 0This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item
CLASSIFICATIONS optional
Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. RichterThis element is used to store standardized classification numbers.
DETAIL_INFOS optional
1000--0--NEW 30.05.2012/BurThis element summarizes all hyperlinks providing detail information for an item.
Source
<xs:element name="SERIES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE" maxOccurs="100">
        <xs:annotation>
          <xs:documentation>200--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="ITEMS">
                          <xs:annotation>
                            <xs:documentation>400--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                      <xs:annotation>
                                        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence minOccurs="0">
                                          <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>450/470--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="PRICE_FIELD">
                                                  <xs:annotation>
                                                    <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="250" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="PRICE">
                                                  <xs:annotation>
                                                    <xs:documentation>450--5--Preis</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:integer">
                                                      <xs:minInclusive value="-99999999" />
                                                      <xs:maxInclusive value="999999999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="PRICE_TYPE_REF">
                                      <xs:annotation>
                                        <xs:documentation>400/407--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="PRICE_TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>407--5--Preisart</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CALC_GROUP_REF">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="CALC_GROUP_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="10" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="RESTRICTIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>409--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>409--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="RESTRICTION_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>409--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SEQUENCE" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>409--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:maxInclusive value="99999" />
                                                    <xs:minInclusive value="1" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="EDP_NUMBER" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="15" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="9" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_IDENTIFICATION">
                                      <xs:annotation>
                                        <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[BEKSMZVPNOG]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CATALOG_PAGE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                        <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="1" />
                                          <xs:maxLength value="40" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VAT_ID_REF" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="VAT_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="RANGE_DEPENDENT">
                                      <xs:annotation>
                                        <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_PARTS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="BLOCK_SEQUENTIAL_NO">
                                                  <xs:annotation>
                                                    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="15" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="99" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>401--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="FEATURE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="OPTION_KEY" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>401--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="5" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="HINGE" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--6--Anschlag</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[BEJLMNR]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="EXCHANGE_CONDITION">
                                                  <xs:annotation>
                                                    <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:positiveInteger">
                                                      <xs:minInclusive value="2" />
                                                      <xs:maxInclusive value="3" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="STATUS">
                                                  <xs:annotation>
                                                    <xs:documentation>401--8--Status</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[ABELSZ]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="1" />
                                                      <xs:maxInclusive value="99999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="|[JLNRAE]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SHORT_TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT_LINE" maxOccurs="3">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT">
                                                              <xs:annotation>
                                                                <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[\S ]{1,30}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SEQUENCE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger" />
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>150--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:language">
                                                          <xs:pattern value="[A-Z]{2}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TYPE_KEY">
                                      <xs:annotation>
                                        <xs:documentation>445--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_TYPE">
                                            <xs:annotation>
                                              <xs:documentation>445--4--TS_Typ</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_CLASS">
                                            <xs:annotation>
                                              <xs:documentation>445--5--TS_Art</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                            <xs:annotation>
                                              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                      <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                        <xs:annotation>
                                                          <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                          <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:minInclusive value="0" />
                                                            <xs:maxInclusive value="9999" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger" />
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                                <xs:annotation>
                                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="TK_MATERIAL" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--21--TS_Material</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-2]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_SHAPE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--22--TS_Form</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-2]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS">
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS_NO">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:negativeInteger">
                                                      <xs:totalDigits value="8" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                </xs:annotation>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

SERIE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element : SERIE Element
Description
200--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of the series.
Items belonging to series 0 are valid for all series. Therefore items of series 0 must not occur with the same type number (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in other series. Items of other series (unequal 0) may be used with the same type name in different series.
Buying prices are always indicated as the dealer’s buying prices
Namespace (none)
Diagram
PRODUCT_GROUPS Element Sequence SERIE Element
Overview
SERIE 1..100
200--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of the series.
Items belonging to series 0 are valid for all series. Therefore items of series 0 must not occur with the same type number (SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO) in other series. Items of other series (unequal 0) may be used with the same type name in different series.
Buying prices are always indicated as the dealer’s buying prices
SERIE_NO required Restriction of xs:nonNegativeInteger
200--1--Satzart Version Beta 2.0 Build 0
This attribute defines the serial number of the series. D nonNegativeInteger
P
M [0:99]
Sequence
PRODUCT_GROUPS
1000--0--NEW Version Beta 2.0 Build 0This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types.
Sequence
PRODUCT_GROUP 1..∞
1000--0--NEW Version Beta 2.0 Build 0This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
1000--0--NEW Version Beta 2.0 Build 0This element is used for defining a name for a product group.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
ITEMS
400--1--Satzart Version Beta 2.0 Build 0This element defines all items belonging to one product group.
Sequence
ITEM 1..∞
400--0--NEW Version Beta 2.0 Build 0This element is used to define blocks and their items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes of the main catalogue.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
400--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) of the main catalogue with the value 0 in the element ADDITIONAL_PRICE.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0, K. Richter 25.03.2014
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
450/470--1--Satzart Version Beta 2.0 Build 0This element is used to specify the block price.
PRICE_TYPE_REF
400/407--0--NEW Version Beta 2.0 Build 2This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
407--5--Preisart Version Beta 2.0 Build 2, K. Richter 25.03.2014
This attribute identifies a price type. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
400--0--NEW Version Beta 2.0 Build 0This element references calculation groups. The calculation groups are defined within the product categories in the main catalogue.
CALC_GROUP_NO required Restriction of xs:positiveInteger
407--6--Kalk_Gruppe Version Beta 2.0 Build 4, K. Richter 21.03.2014
This attribute identifies a price type. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references a swap-ID, which is defined in the path1/EXCHANGE_ID element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RESTRICTIONS optional
409--0--NEW Version Beta 2.0 Build 0This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
409--0--NEW Version Beta 2.0 Build 0This element references an item to an assigned restriction.
EDP_NUMBER optional Restriction of xs:string
400--10--EDV_Nummer Version Beta 2.0 Build 0
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
400--12--Block_Preisstatus Version Beta 2.0 Build 0
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
400--14--Artikelkennung Version Beta 2.0 Build 0
This element is used to assign an identifier to the article.
B = Block
E = Spare part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
400--15--Katalog_Seite Version Beta 2.0 Build 0 geändert K.Richter 25.02.2016
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
VAT_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references VAT tax rates.

The VAT tax rates are specified in the VALUE_ADDED_TAX element (path 1 of the main catalogue). A value of 0 is entered for items that are VAT-free.
If the value of 0 (VAT-free item) is used, the value must also be specified in the VALUE_ADDED_TAX element (path 1).

Element paths
Path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This element is used for referencing the different VAT rates.

 D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
400--18--Lieferbar_ab Version Beta 2.0 Build 0
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
400--19--Lieferbar_bis Version Beta 2.0 Build 0
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
400--34--Prog_abhaengig Version Beta 2.0 Build 0
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD of the main catalogue. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
BLOCK_PARTS optional
401--1--Satzart Version Beta 2.0 Build 0This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞
401--0--NEW Version Beta 2.0 Build 0

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2 of the main catalogue), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

ITEM_TEXT
410--1--Satzart Version Beta 2.0 Build 0This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
410--5--Texttype Version Beta 2.0 Build 0This element contains short text information.
FULL_TEXT optional languagetexte Complex Type
410--5--Texttype

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

PLANNING_ADVICE optional languagetexte60999 Complex Type
410--5--Texttype Version Beta 2.0 Build 0This element contains planning advices.
TYPE_KEY
445--1--Satzart Version Beta 2.0 Build 0This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item
Sequence
TK_TYPE Restriction of xs:positiveInteger
445--4--TS_Typ Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
445--5--TS_Art Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column item No., as listed in the Table "Type key arts", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is used for assigning a type key to the installation information and recess height.

TK_MATERIAL optional Restriction of xs:positiveInteger
445--21--TS_Material Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type, as listed in table " Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
445--22--TS_Form Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column shape No., as listed in the table " Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
445--23--TS_Front_Auspraegung Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column front appearance No., as listed in the table " Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. RichterThis element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
DETAIL_INFOS optional
1000--0--NEW 30.05.2012/BurThis element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
1000--0--NEW 30.05.2012/BurThis element references hyperlinks to detail information.
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required 200--1--Satzart Version Beta 2.0 Build 0
This attribute defines the serial number of the series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="SERIE" maxOccurs="100" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="ITEMS">
                    <xs:annotation>
                      <xs:documentation>400--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                                <xs:annotation>
                                  <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence minOccurs="0">
                                    <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>450/470--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="PRICE_FIELD">
                                            <xs:annotation>
                                              <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="250" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="PRICE">
                                            <xs:annotation>
                                              <xs:documentation>450--5--Preis</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:integer">
                                                <xs:minInclusive value="-99999999" />
                                                <xs:maxInclusive value="999999999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="PRICE_TYPE_REF">
                                <xs:annotation>
                                  <xs:documentation>400/407--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="PRICE_TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>407--5--Preisart</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CALC_GROUP_REF">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="CALC_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="10" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="EXCHANGE_ID_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="RESTRICTIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>409--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>409--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="RESTRICTION_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>409--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE" use="required">
                                          <xs:annotation>
                                            <xs:documentation>409--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:maxInclusive value="99999" />
                                              <xs:minInclusive value="1" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="EDP_NUMBER" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_IDENTIFICATION">
                                <xs:annotation>
                                  <xs:documentation>400--14--Artikelkennung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[BEKSMZVPNOG]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CATALOG_PAGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                  <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="40" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VAT_ID_REF" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="VAT_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="RANGE_DEPENDENT">
                                <xs:annotation>
                                  <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_PARTS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="BLOCK_SEQUENTIAL_NO">
                                            <xs:annotation>
                                              <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="15" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="99" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>401--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="FEATURE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="OPTION_KEY" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>401--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="5" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="HINGE" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--6--Anschlag</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[BEJLMNR]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="EXCHANGE_CONDITION">
                                            <xs:annotation>
                                              <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:positiveInteger">
                                                <xs:minInclusive value="2" />
                                                <xs:maxInclusive value="3" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="STATUS">
                                            <xs:annotation>
                                              <xs:documentation>401--8--Status</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[ABELSZ]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="1" />
                                                <xs:maxInclusive value="99999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="|[JLNRAE]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SHORT_TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT_LINE" maxOccurs="3">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT">
                                                        <xs:annotation>
                                                          <xs:documentation>410--6--Textzeile</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[\S ]{1,30}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger" />
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>150--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:language">
                                                    <xs:pattern value="[A-Z]{2}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TYPE_KEY">
                                <xs:annotation>
                                  <xs:documentation>445--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_TYPE">
                                      <xs:annotation>
                                        <xs:documentation>445--4--TS_Typ</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_CLASS">
                                      <xs:annotation>
                                        <xs:documentation>445--5--TS_Art</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                      <xs:annotation>
                                        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                                <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                                    <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:minInclusive value="0" />
                                                      <xs:maxInclusive value="9999" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                          <xs:annotation>
                                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="TK_MATERIAL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--21--TS_Material</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-2]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_SHAPE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--22--TS_Form</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-2]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS">
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS_NO">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:negativeInteger">
                                                <xs:totalDigits value="8" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                          </xs:annotation>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUPS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element : PRODUCT_GROUPS Element
Description
1000--0--NEW Version Beta 2.0 Build 0This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types.
Namespace (none)
Diagram
PRODUCT_GROUP Element Sequence PRODUCT_GROUPS Element
Overview
PRODUCT_GROUPS
1000--0--NEW Version Beta 2.0 Build 0This element is used for the definition of product groups. Product groups are used for grouping items which have the same variation types.
Sequence
PRODUCT_GROUP 1..∞
1000--0--NEW Version Beta 2.0 Build 0This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
1000--0--NEW Version Beta 2.0 Build 0This element is used for defining a name for a product group.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
ITEMS
400--1--Satzart Version Beta 2.0 Build 0This element defines all items belonging to one product group.
Sequence
ITEM 1..∞
400--0--NEW Version Beta 2.0 Build 0This element is used to define blocks and their items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes of the main catalogue.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
400--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) of the main catalogue with the value 0 in the element ADDITIONAL_PRICE.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0, K. Richter 25.03.2014
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
450/470--1--Satzart Version Beta 2.0 Build 0This element is used to specify the block price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
450--4--Preisfeld/Aufpreisfeld Version Beta 2.0 Build 0, K. Richter 25.03.2014

This element references to the block price field (BLOCK_PRICE_FIELD below PRICE_DEFINITION in the main catalogue).

The values in BLOCK_PRICE_FIELD can be identical to the values in PRICE_FIELD.They can also be assigned differently for individual ranges within the catalogue price groups.

The following applies:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
450--5--Preis Version Beta 2.0 Build 0
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
400/407--0--NEW Version Beta 2.0 Build 2This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
407--5--Preisart Version Beta 2.0 Build 2, K. Richter 25.03.2014
This attribute identifies a price type. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
400--0--NEW Version Beta 2.0 Build 0This element references calculation groups. The calculation groups are defined within the product categories in the main catalogue.
CALC_GROUP_NO required Restriction of xs:positiveInteger
407--6--Kalk_Gruppe Version Beta 2.0 Build 4, K. Richter 21.03.2014
This attribute identifies a price type. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references a swap-ID, which is defined in the path1/EXCHANGE_ID element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RESTRICTIONS optional
409--0--NEW Version Beta 2.0 Build 0This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
409--0--NEW Version Beta 2.0 Build 0This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
EDP_NUMBER optional Restriction of xs:string
400--10--EDV_Nummer Version Beta 2.0 Build 0
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
400--12--Block_Preisstatus Version Beta 2.0 Build 0
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
400--14--Artikelkennung Version Beta 2.0 Build 0
This element is used to assign an identifier to the article.
B = Block
E = Spare part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
400--15--Katalog_Seite Version Beta 2.0 Build 0 geändert K.Richter 25.02.2016
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
VAT_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references VAT tax rates.

The VAT tax rates are specified in the VALUE_ADDED_TAX element (path 1 of the main catalogue). A value of 0 is entered for items that are VAT-free.
If the value of 0 (VAT-free item) is used, the value must also be specified in the VALUE_ADDED_TAX element (path 1).

Element paths
Path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This element is used for referencing the different VAT rates.

 D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
400--18--Lieferbar_ab Version Beta 2.0 Build 0
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
400--19--Lieferbar_bis Version Beta 2.0 Build 0
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
400--34--Prog_abhaengig Version Beta 2.0 Build 0
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD of the main catalogue. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
BLOCK_PARTS optional
401--1--Satzart Version Beta 2.0 Build 0This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞
401--0--NEW Version Beta 2.0 Build 0

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2 of the main catalogue), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
401--4--Block_Lfd_Nr Version Beta 2.0 Build 0
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF
401--0--NEW Version Beta 2.0 Build 0

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2 of the main catalogue) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

OPTION_REF 0..∞
401--0--NEW Version Beta 2.0 Build 0This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2 of the main catalogue).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
HINGE optional Restriction of xs:string
401--6--Anschlag Version Beta 2.0 Build 0
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger
401--7--Tauschbedingung Version Beta 2.0 Build 0

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
401--8--Status Version Beta 2.0 Build 0
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
401--10--Blockartikelmass_Breite Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
401--11--Blockartikelmass_Hoehe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
401--12--Blockartikelmass_Tiefe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
401--13--Bauweise_ID Version Beta 2.0 Build 0
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
ITEM_TEXT
410--1--Satzart Version Beta 2.0 Build 0This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
410--5--Texttype Version Beta 2.0 Build 0This element contains short text information.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
FULL_TEXT optional languagetexte Complex Type
410--5--Texttype

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
PLANNING_ADVICE optional languagetexte60999 Complex Type
410--5--Texttype Version Beta 2.0 Build 0This element contains planning advices.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
TYPE_KEY
445--1--Satzart Version Beta 2.0 Build 0This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item
Sequence
TK_TYPE Restriction of xs:positiveInteger
445--4--TS_Typ Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
445--5--TS_Art Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column item No., as listed in the Table "Type key arts", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
445--0--NEW Version Beta 2.0 Build 4This element is used to specify the combination of installation information (see table Installinfo key) and recess height.
TK_MATERIAL optional Restriction of xs:positiveInteger
445--21--TS_Material Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type, as listed in table " Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
445--22--TS_Form Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column shape No., as listed in the table " Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
445--23--TS_Front_Auspraegung Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column front appearance No., as listed in the table " Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. RichterThis element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:negativeInteger

The eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.

The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
1000--0--NEW 30.05.2012/BurThis element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
1000--0--NEW 30.05.2012/BurThis element references hyperlinks to detail information.
DETAIL_INFO_NO required
1000--0--NEW 30.05.2012/Bur
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="PRODUCT_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="ITEMS">
              <xs:annotation>
                <xs:documentation>400--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                          <xs:annotation>
                            <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence minOccurs="0">
                              <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>450/470--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="PRICE_FIELD">
                                      <xs:annotation>
                                        <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="250" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="PRICE">
                                      <xs:annotation>
                                        <xs:documentation>450--5--Preis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:integer">
                                          <xs:minInclusive value="-99999999" />
                                          <xs:maxInclusive value="999999999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_TYPE_REF">
                          <xs:annotation>
                            <xs:documentation>400/407--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="PRICE_TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>407--5--Preisart</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CALC_GROUP_REF">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="CALC_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="10" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="EXCHANGE_ID_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="RESTRICTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>409--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>409--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="RESTRICTION_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>409--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE" use="required">
                                    <xs:annotation>
                                      <xs:documentation>409--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:maxInclusive value="99999" />
                                        <xs:minInclusive value="1" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="EDP_NUMBER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_IDENTIFICATION">
                          <xs:annotation>
                            <xs:documentation>400--14--Artikelkennung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[BEKSMZVPNOG]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CATALOG_PAGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                            <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="40" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VAT_ID_REF" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="VAT_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="RANGE_DEPENDENT">
                          <xs:annotation>
                            <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_PARTS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="BLOCK_SEQUENTIAL_NO">
                                      <xs:annotation>
                                        <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="15" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="99" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>401--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="FEATURE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="OPTION_KEY" use="required">
                                          <xs:annotation>
                                            <xs:documentation>401--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="5" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="HINGE" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--6--Anschlag</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[BEJLMNR]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="EXCHANGE_CONDITION">
                                      <xs:annotation>
                                        <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:positiveInteger">
                                          <xs:minInclusive value="2" />
                                          <xs:maxInclusive value="3" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="STATUS">
                                      <xs:annotation>
                                        <xs:documentation>401--8--Status</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[ABELSZ]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="1" />
                                          <xs:maxInclusive value="99999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="|[JLNRAE]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_TEXT">
                          <xs:annotation>
                            <xs:documentation>410--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SHORT_TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT_LINE" maxOccurs="3">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--6--Textzeile</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[\S ]{1,30}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger" />
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                          <xs:annotation>
                                            <xs:documentation>150--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:language">
                                              <xs:pattern value="[A-Z]{2}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TYPE_KEY">
                          <xs:annotation>
                            <xs:documentation>445--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_TYPE">
                                <xs:annotation>
                                  <xs:documentation>445--4--TS_Typ</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_CLASS">
                                <xs:annotation>
                                  <xs:documentation>445--5--TS_Art</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                                <xs:annotation>
                                  <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                          <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                              <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:minInclusive value="0" />
                                                <xs:maxInclusive value="9999" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="TK_MATERIAL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--21--TS_Material</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-2]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_SHAPE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--22--TS_Form</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-2]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CLASSIFICATIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS">
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS_NO">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:negativeInteger">
                                          <xs:totalDigits value="8" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                    </xs:annotation>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUP Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element : PRODUCT_GROUP Element
Description
1000--0--NEW Version Beta 2.0 Build 0This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.
Namespace (none)
Diagram
ITEMS Element LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element Sequence PRODUCT_GROUP Element
Overview
PRODUCT_GROUP 1..∞
1000--0--NEW Version Beta 2.0 Build 0This element contains items which are grouped together in product groups. A definition of "identical" product groups is not permitted.
Sequence
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
1000--0--NEW Version Beta 2.0 Build 0This element is used for defining a name for a product group.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
ITEMS
400--1--Satzart Version Beta 2.0 Build 0This element defines all items belonging to one product group.
Sequence
ITEM 1..∞
400--0--NEW Version Beta 2.0 Build 0This element is used to define blocks and their items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes of the main catalogue.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
400--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) of the main catalogue with the value 0 in the element ADDITIONAL_PRICE.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0, K. Richter 25.03.2014
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
450/470--1--Satzart Version Beta 2.0 Build 0This element is used to specify the block price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
450--4--Preisfeld/Aufpreisfeld Version Beta 2.0 Build 0, K. Richter 25.03.2014

This element references to the block price field (BLOCK_PRICE_FIELD below PRICE_DEFINITION in the main catalogue).

The values in BLOCK_PRICE_FIELD can be identical to the values in PRICE_FIELD.They can also be assigned differently for individual ranges within the catalogue price groups.

The following applies:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
450--5--Preis Version Beta 2.0 Build 0
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
400/407--0--NEW Version Beta 2.0 Build 2This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
407--5--Preisart Version Beta 2.0 Build 2, K. Richter 25.03.2014
This attribute identifies a price type. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
400--0--NEW Version Beta 2.0 Build 0This element references calculation groups. The calculation groups are defined within the product categories in the main catalogue.
CALC_GROUP_NO required Restriction of xs:positiveInteger
407--6--Kalk_Gruppe Version Beta 2.0 Build 4, K. Richter 21.03.2014
This attribute identifies a price type. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references a swap-ID, which is defined in the path1/EXCHANGE_ID element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RESTRICTIONS optional
409--0--NEW Version Beta 2.0 Build 0This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
409--0--NEW Version Beta 2.0 Build 0This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
EDP_NUMBER optional Restriction of xs:string
400--10--EDV_Nummer Version Beta 2.0 Build 0
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
400--12--Block_Preisstatus Version Beta 2.0 Build 0
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
400--14--Artikelkennung Version Beta 2.0 Build 0
This element is used to assign an identifier to the article.
B = Block
E = Spare part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
400--15--Katalog_Seite Version Beta 2.0 Build 0 geändert K.Richter 25.02.2016
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
VAT_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references VAT tax rates.

The VAT tax rates are specified in the VALUE_ADDED_TAX element (path 1 of the main catalogue). A value of 0 is entered for items that are VAT-free.
If the value of 0 (VAT-free item) is used, the value must also be specified in the VALUE_ADDED_TAX element (path 1).

Element paths
Path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This element is used for referencing the different VAT rates.

 D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
400--18--Lieferbar_ab Version Beta 2.0 Build 0
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
400--19--Lieferbar_bis Version Beta 2.0 Build 0
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
400--34--Prog_abhaengig Version Beta 2.0 Build 0
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD of the main catalogue. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
BLOCK_PARTS optional
401--1--Satzart Version Beta 2.0 Build 0This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞
401--0--NEW Version Beta 2.0 Build 0

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2 of the main catalogue), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
401--4--Block_Lfd_Nr Version Beta 2.0 Build 0
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF
401--0--NEW Version Beta 2.0 Build 0

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2 of the main catalogue) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞
401--0--NEW Version Beta 2.0 Build 0This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2 of the main catalogue).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to specify the version type of a referenced version.
A FEATURE_NO must only occur once. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to reference a version. D string
P
M [1:5]
HINGE optional Restriction of xs:string
401--6--Anschlag Version Beta 2.0 Build 0
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger
401--7--Tauschbedingung Version Beta 2.0 Build 0

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
401--8--Status Version Beta 2.0 Build 0
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
401--10--Blockartikelmass_Breite Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
401--11--Blockartikelmass_Hoehe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
401--12--Blockartikelmass_Tiefe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
401--13--Bauweise_ID Version Beta 2.0 Build 0
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
ITEM_TEXT
410--1--Satzart Version Beta 2.0 Build 0This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
410--5--Texttype Version Beta 2.0 Build 0This element contains short text information.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information.
FULL_TEXT optional languagetexte Complex Type
410--5--Texttype

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
410--5--Texttype Version Beta 2.0 Build 0This element contains planning advices.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
TYPE_KEY
445--1--Satzart Version Beta 2.0 Build 0This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item
Sequence
TK_TYPE Restriction of xs:positiveInteger
445--4--TS_Typ Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
445--5--TS_Art Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column item No., as listed in the Table "Type key arts", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
445--0--NEW Version Beta 2.0 Build 4This element is used to specify the combination of installation information (see table Installinfo key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5 Version Beta 2.0 Build 0
A value from the column InstallInfo in table "installinfo key" is entered here. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5 Version Beta 2.0 Build 4 Erweitert von 2 auf 4 Stellen 2011-12-14
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
445--21--TS_Material Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type, as listed in table " Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
445--22--TS_Form Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column shape No., as listed in the table " Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
445--23--TS_Front_Auspraegung Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column front appearance No., as listed in the table " Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. RichterThis element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:negativeInteger

The eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.

The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
1000--0--NEW 30.05.2012/BurThis element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
1000--0--NEW 30.05.2012/BurThis element references hyperlinks to detail information.
DETAIL_INFO_NO required
1000--0--NEW 30.05.2012/Bur
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="PRODUCT_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="ITEMS">
        <xs:annotation>
          <xs:documentation>400--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
                    <xs:annotation>
                      <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence minOccurs="0">
                        <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>450/470--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="PRICE_FIELD">
                                <xs:annotation>
                                  <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="250" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="PRICE">
                                <xs:annotation>
                                  <xs:documentation>450--5--Preis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:integer">
                                    <xs:minInclusive value="-99999999" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_TYPE_REF">
                    <xs:annotation>
                      <xs:documentation>400/407--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="PRICE_TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>407--5--Preisart</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CALC_GROUP_REF">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="CALC_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="10" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="RESTRICTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>409--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>409--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="RESTRICTION_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>409--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE" use="required">
                              <xs:annotation>
                                <xs:documentation>409--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:maxInclusive value="99999" />
                                  <xs:minInclusive value="1" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EDP_NUMBER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_IDENTIFICATION">
                    <xs:annotation>
                      <xs:documentation>400--14--Artikelkennung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[BEKSMZVPNOG]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CATALOG_PAGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                      <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="40" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VAT_ID_REF" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="VAT_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="RANGE_DEPENDENT">
                    <xs:annotation>
                      <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_PARTS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="BLOCK_SEQUENTIAL_NO">
                                <xs:annotation>
                                  <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="ITEM_REF">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="15" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="99" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>401--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="FEATURE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>401--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="5" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="HINGE" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--6--Anschlag</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[BEJLMNR]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="EXCHANGE_CONDITION">
                                <xs:annotation>
                                  <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:positiveInteger">
                                    <xs:minInclusive value="2" />
                                    <xs:maxInclusive value="3" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="STATUS">
                                <xs:annotation>
                                  <xs:documentation>401--8--Status</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[ABELSZ]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="99999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="|[JLNRAE]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_TEXT">
                    <xs:annotation>
                      <xs:documentation>410--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SHORT_TEXT">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT_LINE" maxOccurs="3">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--6--Textzeile</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[\S ]{1,30}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>150--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TYPE_KEY">
                    <xs:annotation>
                      <xs:documentation>445--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_TYPE">
                          <xs:annotation>
                            <xs:documentation>445--4--TS_Typ</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_CLASS">
                          <xs:annotation>
                            <xs:documentation>445--5--TS_Art</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                          <xs:annotation>
                            <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                        <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:minInclusive value="0" />
                                          <xs:maxInclusive value="9999" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                              <xs:annotation>
                                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="TK_MATERIAL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--21--TS_Material</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-2]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_SHAPE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--22--TS_Form</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-2]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CLASSIFICATIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS_NO">
                                <xs:simpleType>
                                  <xs:restriction base="xs:negativeInteger">
                                    <xs:totalDigits value="8" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                              </xs:annotation>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PRODUCT_GROUP_TEXT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : PRODUCT_GROUP_TEXT Element
Description
1000--0--NEW Version Beta 2.0 Build 0This element is used for defining a name for a product group.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence PRODUCT_GROUP_TEXT Element
Overview
PRODUCT_GROUP_TEXT languagetexte60 Complex Type
1000--0--NEW Version Beta 2.0 Build 0This element is used for defining a name for a product group.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="PRODUCT_GROUP_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ITEMS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : ITEMS Element
Description
400--1--Satzart Version Beta 2.0 Build 0This element defines all items belonging to one product group.
Namespace (none)
Diagram
ITEM Element Sequence ITEMS Element
Overview
ITEMS
400--1--Satzart Version Beta 2.0 Build 0This element defines all items belonging to one product group.
Sequence
ITEM 1..∞
400--0--NEW Version Beta 2.0 Build 0This element is used to define blocks and their items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes of the main catalogue.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
400--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) of the main catalogue with the value 0 in the element ADDITIONAL_PRICE.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0, K. Richter 25.03.2014
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
450/470--1--Satzart Version Beta 2.0 Build 0This element is used to specify the block price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
450--4--Preisfeld/Aufpreisfeld Version Beta 2.0 Build 0, K. Richter 25.03.2014

This element references to the block price field (BLOCK_PRICE_FIELD below PRICE_DEFINITION in the main catalogue).

The values in BLOCK_PRICE_FIELD can be identical to the values in PRICE_FIELD.They can also be assigned differently for individual ranges within the catalogue price groups.

The following applies:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
450--5--Preis Version Beta 2.0 Build 0
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
400/407--0--NEW Version Beta 2.0 Build 2This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
407--5--Preisart Version Beta 2.0 Build 2, K. Richter 25.03.2014
This attribute identifies a price type. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
400--0--NEW Version Beta 2.0 Build 0This element references calculation groups. The calculation groups are defined within the product categories in the main catalogue.
CALC_GROUP_NO required Restriction of xs:positiveInteger
407--6--Kalk_Gruppe Version Beta 2.0 Build 4, K. Richter 21.03.2014
This attribute identifies a price type. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references a swap-ID, which is defined in the path1/EXCHANGE_ID element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RESTRICTIONS optional
409--0--NEW Version Beta 2.0 Build 0This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
409--0--NEW Version Beta 2.0 Build 0This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
EDP_NUMBER optional Restriction of xs:string
400--10--EDV_Nummer Version Beta 2.0 Build 0
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
400--12--Block_Preisstatus Version Beta 2.0 Build 0
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
400--14--Artikelkennung Version Beta 2.0 Build 0
This element is used to assign an identifier to the article.
B = Block
E = Spare part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
400--15--Katalog_Seite Version Beta 2.0 Build 0 geändert K.Richter 25.02.2016
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
VAT_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references VAT tax rates.

The VAT tax rates are specified in the VALUE_ADDED_TAX element (path 1 of the main catalogue). A value of 0 is entered for items that are VAT-free.
If the value of 0 (VAT-free item) is used, the value must also be specified in the VALUE_ADDED_TAX element (path 1).

Element paths
Path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This element is used for referencing the different VAT rates.

 D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
400--18--Lieferbar_ab Version Beta 2.0 Build 0
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
400--19--Lieferbar_bis Version Beta 2.0 Build 0
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
400--34--Prog_abhaengig Version Beta 2.0 Build 0
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD of the main catalogue. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
BLOCK_PARTS optional
401--1--Satzart Version Beta 2.0 Build 0This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞
401--0--NEW Version Beta 2.0 Build 0

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2 of the main catalogue), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
401--4--Block_Lfd_Nr Version Beta 2.0 Build 0
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF
401--0--NEW Version Beta 2.0 Build 0

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2 of the main catalogue) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞
401--0--NEW Version Beta 2.0 Build 0This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2 of the main catalogue).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to specify the version type of a referenced version.
A FEATURE_NO must only occur once. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to reference a version. D string
P
M [1:5]
HINGE optional Restriction of xs:string
401--6--Anschlag Version Beta 2.0 Build 0
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger
401--7--Tauschbedingung Version Beta 2.0 Build 0

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
401--8--Status Version Beta 2.0 Build 0
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
401--10--Blockartikelmass_Breite Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
401--11--Blockartikelmass_Hoehe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
401--12--Blockartikelmass_Tiefe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
401--13--Bauweise_ID Version Beta 2.0 Build 0
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
ITEM_TEXT
410--1--Satzart Version Beta 2.0 Build 0This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
410--5--Texttype Version Beta 2.0 Build 0This element contains short text information.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information.
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type
410--5--Texttype

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
410--5--Texttype Version Beta 2.0 Build 0This element contains planning advices.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
445--1--Satzart Version Beta 2.0 Build 0This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item
Sequence
TK_TYPE Restriction of xs:positiveInteger
445--4--TS_Typ Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
445--5--TS_Art Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column item No., as listed in the Table "Type key arts", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
445--0--NEW Version Beta 2.0 Build 4This element is used to specify the combination of installation information (see table Installinfo key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5 Version Beta 2.0 Build 0
A value from the column InstallInfo in table "installinfo key" is entered here. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5 Version Beta 2.0 Build 4 Erweitert von 2 auf 4 Stellen 2011-12-14
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
445--21--TS_Material Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type, as listed in table " Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
445--22--TS_Form Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column shape No., as listed in the table " Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
445--23--TS_Front_Auspraegung Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column front appearance No., as listed in the table " Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. RichterThis element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:negativeInteger

The eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.

The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
1000--0--NEW 30.05.2012/BurThis element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
1000--0--NEW 30.05.2012/BurThis element references hyperlinks to detail information.
DETAIL_INFO_NO required
1000--0--NEW 30.05.2012/Bur
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="ITEMS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
              <xs:annotation>
                <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence minOccurs="0">
                  <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>450/470--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRICE_FIELD">
                          <xs:annotation>
                            <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="250" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="PRICE">
                          <xs:annotation>
                            <xs:documentation>450--5--Preis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:integer">
                              <xs:minInclusive value="-99999999" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_TYPE_REF">
              <xs:annotation>
                <xs:documentation>400/407--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="PRICE_TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>407--5--Preisart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CALC_GROUP_REF">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="CALC_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="10" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="RESTRICTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>409--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>409--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="RESTRICTION_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>409--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE" use="required">
                        <xs:annotation>
                          <xs:documentation>409--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:maxInclusive value="99999" />
                            <xs:minInclusive value="1" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="EDP_NUMBER" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--10--EDV_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>400--14--Artikelkennung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BEKSMZVPNOG]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_PAGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--15--Katalog_Seite</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="40" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VAT_ID_REF" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="VAT_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="RANGE_DEPENDENT">
              <xs:annotation>
                <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_PARTS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_PART" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="BLOCK_SEQUENTIAL_NO">
                          <xs:annotation>
                            <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="ITEM_REF">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="15" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="99" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>401--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>401--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="HINGE" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--6--Anschlag</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[BEJLMNR]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXCHANGE_CONDITION">
                          <xs:annotation>
                            <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:minInclusive value="2" />
                              <xs:maxInclusive value="3" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="STATUS">
                          <xs:annotation>
                            <xs:documentation>401--8--Status</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[ABELSZ]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="99999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="|[JLNRAE]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_TEXT">
              <xs:annotation>
                <xs:documentation>410--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SHORT_TEXT">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--6--Textzeile</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>150--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="TYPE_KEY">
              <xs:annotation>
                <xs:documentation>445--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_TYPE">
                    <xs:annotation>
                      <xs:documentation>445--4--TS_Typ</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_CLASS">
                    <xs:annotation>
                      <xs:documentation>445--5--TS_Art</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
                    <xs:annotation>
                      <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                                  <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                        <xs:annotation>
                          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TK_MATERIAL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--21--TS_Material</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-2]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_SHAPE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--22--TS_Form</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-2]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CLASSIFICATIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS_NO">
                          <xs:simpleType>
                            <xs:restriction base="xs:negativeInteger">
                              <xs:totalDigits value="8" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                        </xs:annotation>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ITEM Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element : ITEM Element
Description
400--0--NEW Version Beta 2.0 Build 0This element is used to define blocks and their items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes of the main catalogue.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Namespace (none)
Diagram
DETAIL_INFOS Element CLASSIFICATIONS Element TYPE_KEY Element ITEM_TEXT Element BLOCK_PARTS Element RANGE_DEPENDENT Element VALID_UNTIL Element VALID_FROM Element VAT_ID_REF Element CATALOG_PAGE Element ITEM_IDENTIFICATION Element BLOCK_PRICE_STATUS Element EDP_NUMBER Element RESTRICTIONS Element EXCHANGE_ID_REF Element CALC_GROUP_REF Element PRICE_TYPE_REF Element PRICE_FEATURE_GROUP_BASE_PRICE_REF Element Sequence ITEM Element
Overview
ITEM 1..∞
400--0--NEW Version Beta 2.0 Build 0This element is used to define blocks and their items. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 1) attributes of the main catalogue.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
SERIE_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO required Restriction of xs:string
400--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Sequence
PRICE_FEATURE_GROUP_BASE_PRICE_REF
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) of the main catalogue with the value 0 in the element ADDITIONAL_PRICE.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0, K. Richter 25.03.2014
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
450/470--1--Satzart Version Beta 2.0 Build 0This element is used to specify the block price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
450--4--Preisfeld/Aufpreisfeld Version Beta 2.0 Build 0, K. Richter 25.03.2014

This element references to the block price field (BLOCK_PRICE_FIELD below PRICE_DEFINITION in the main catalogue).

The values in BLOCK_PRICE_FIELD can be identical to the values in PRICE_FIELD.They can also be assigned differently for individual ranges within the catalogue price groups.

The following applies:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
450--5--Preis Version Beta 2.0 Build 0
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
PRICE_TYPE_REF
400/407--0--NEW Version Beta 2.0 Build 2This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
407--5--Preisart Version Beta 2.0 Build 2, K. Richter 25.03.2014
This attribute identifies a price type. D positiveInteger
P
M [1:999]
CALC_GROUP_REF
400--0--NEW Version Beta 2.0 Build 0This element references calculation groups. The calculation groups are defined within the product categories in the main catalogue.
CALC_GROUP_NO required Restriction of xs:positiveInteger
407--6--Kalk_Gruppe Version Beta 2.0 Build 4, K. Richter 21.03.2014
This attribute identifies a price type. D positiveInteger
P
M [10:99]
EXCHANGE_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references a swap-ID, which is defined in the path1/EXCHANGE_ID element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RESTRICTIONS optional
409--0--NEW Version Beta 2.0 Build 0This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
409--0--NEW Version Beta 2.0 Build 0This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
EDP_NUMBER optional Restriction of xs:string
400--10--EDV_Nummer Version Beta 2.0 Build 0
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
400--12--Block_Preisstatus Version Beta 2.0 Build 0
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
ITEM_IDENTIFICATION Restriction of xs:string
400--14--Artikelkennung Version Beta 2.0 Build 0
This element is used to assign an identifier to the article.
B = Block
E = Spare part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal. 		D string
P [BEKSMZVPNOG]
M [1:1]
CATALOG_PAGE optional Restriction of xs:string
400--15--Katalog_Seite Version Beta 2.0 Build 0 geändert K.Richter 25.02.2016
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
VAT_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references VAT tax rates.

The VAT tax rates are specified in the VALUE_ADDED_TAX element (path 1 of the main catalogue). A value of 0 is entered for items that are VAT-free.
If the value of 0 (VAT-free item) is used, the value must also be specified in the VALUE_ADDED_TAX element (path 1).

Element paths
Path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This element is used for referencing the different VAT rates.

 D nonNegativeInteger
P
M [0:99]
VALID_FROM optional Restriction of xs:date
400--18--Lieferbar_ab Version Beta 2.0 Build 0
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
400--19--Lieferbar_bis Version Beta 2.0 Build 0
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
RANGE_DEPENDENT Restriction of xs:boolean
400--34--Prog_abhaengig Version Beta 2.0 Build 0
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD of the main catalogue. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
BLOCK_PARTS optional
401--1--Satzart Version Beta 2.0 Build 0This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞
401--0--NEW Version Beta 2.0 Build 0

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2 of the main catalogue), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
401--4--Block_Lfd_Nr Version Beta 2.0 Build 0
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF
401--0--NEW Version Beta 2.0 Build 0

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2 of the main catalogue) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞
401--0--NEW Version Beta 2.0 Build 0This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2 of the main catalogue).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to specify the version type of a referenced version.
A FEATURE_NO must only occur once. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to reference a version. D string
P
M [1:5]
HINGE optional Restriction of xs:string
401--6--Anschlag Version Beta 2.0 Build 0
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger
401--7--Tauschbedingung Version Beta 2.0 Build 0

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
401--8--Status Version Beta 2.0 Build 0
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
401--10--Blockartikelmass_Breite Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
401--11--Blockartikelmass_Hoehe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
401--12--Blockartikelmass_Tiefe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
401--13--Bauweise_ID Version Beta 2.0 Build 0
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
ITEM_TEXT
410--1--Satzart Version Beta 2.0 Build 0This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
410--5--Texttype Version Beta 2.0 Build 0This element contains short text information.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information.
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type
410--5--Texttype

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
410--5--Texttype Version Beta 2.0 Build 0This element contains planning advices.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
TYPE_KEY
445--1--Satzart Version Beta 2.0 Build 0This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item
Sequence
TK_TYPE Restriction of xs:positiveInteger
445--4--TS_Typ Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
445--5--TS_Art Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column item No., as listed in the Table "Type key arts", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
445--0--NEW Version Beta 2.0 Build 4This element is used to specify the combination of installation information (see table Installinfo key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5 Version Beta 2.0 Build 0
A value from the column InstallInfo in table "installinfo key" is entered here. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5 Version Beta 2.0 Build 4 Erweitert von 2 auf 4 Stellen 2011-12-14
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
445--21--TS_Material Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type, as listed in table " Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
445--22--TS_Form Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column shape No., as listed in the table " Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
445--23--TS_Front_Auspraegung Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column front appearance No., as listed in the table " Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
CLASSIFICATIONS optional
Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. RichterThis element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:negativeInteger

The eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.

The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
DETAIL_INFOS optional
1000--0--NEW 30.05.2012/BurThis element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
1000--0--NEW 30.05.2012/BurThis element references hyperlinks to detail information.
DETAIL_INFO_NO required
1000--0--NEW 30.05.2012/Bur
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required 400--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
TYPE_NO Restriction of xs:string required 400--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
Source
<xs:element name="ITEM" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF">
        <xs:annotation>
          <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence minOccurs="0">
            <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>450/470--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRICE_FIELD">
                    <xs:annotation>
                      <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="250" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="PRICE">
                    <xs:annotation>
                      <xs:documentation>450--5--Preis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:integer">
                        <xs:minInclusive value="-99999999" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_TYPE_REF">
        <xs:annotation>
          <xs:documentation>400/407--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="PRICE_TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--5--Preisart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CALC_GROUP_REF">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="CALC_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="10" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="EXCHANGE_ID_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="RESTRICTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>409--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>409--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>409--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE" use="required">
                  <xs:annotation>
                    <xs:documentation>409--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:maxInclusive value="99999" />
                      <xs:minInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="EDP_NUMBER" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--10--EDV_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_PRICE_STATUS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="9" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>400--14--Artikelkennung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BEKSMZVPNOG]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_PAGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--15--Katalog_Seite</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="40" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VAT_ID_REF" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="VAT_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="RANGE_DEPENDENT">
        <xs:annotation>
          <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_PARTS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_PART" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="BLOCK_SEQUENTIAL_NO">
                    <xs:annotation>
                      <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>401--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>401--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="HINGE" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--6--Anschlag</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[BEJLMNR]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXCHANGE_CONDITION">
                    <xs:annotation>
                      <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:minInclusive value="2" />
                        <xs:maxInclusive value="3" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="STATUS">
                    <xs:annotation>
                      <xs:documentation>401--8--Status</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[ABELSZ]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="99999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CONSTRUCTION_ID" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="|[JLNRAE]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_TEXT">
        <xs:annotation>
          <xs:documentation>410--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SHORT_TEXT">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--6--Textzeile</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>150--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="TYPE_KEY">
        <xs:annotation>
          <xs:documentation>445--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_TYPE">
              <xs:annotation>
                <xs:documentation>445--4--TS_Typ</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_CLASS">
              <xs:annotation>
                <xs:documentation>445--5--TS_Art</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
              <xs:annotation>
                <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                            <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
                  <xs:annotation>
                    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="TK_MATERIAL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--21--TS_Material</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-2]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_SHAPE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--22--TS_Form</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-2]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CLASSIFICATIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS_NO">
                    <xs:simpleType>
                      <xs:restriction base="xs:negativeInteger">
                        <xs:totalDigits value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Description
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) of the main catalogue with the value 0 in the element ADDITIONAL_PRICE.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Namespace (none)
Diagram
ITEM_PRICE Element Sequence PRICE_FEATURE_GROUP_BASE_PRICE_REF Element
Overview
PRICE_FEATURE_GROUP_BASE_PRICE_REF
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0This element references a basic price feature group. A basic price feature group is a PRICE_FEATURE_GROUP (path1) of the main catalogue with the value 0 in the element ADDITIONAL_PRICE.

element paths:
path1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
PRICE_FEATURE_GROUP_NO required Restriction of xs:positiveInteger
400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0, K. Richter 25.03.2014
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Sequence optional
ITEM_PRICE 0..∞
450/470--1--Satzart Version Beta 2.0 Build 0This element is used to specify the block price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
450--4--Preisfeld/Aufpreisfeld Version Beta 2.0 Build 0, K. Richter 25.03.2014

This element references to the block price field (BLOCK_PRICE_FIELD below PRICE_DEFINITION in the main catalogue).

The values in BLOCK_PRICE_FIELD can be identical to the values in PRICE_FIELD.They can also be assigned differently for individual ranges within the catalogue price groups.

The following applies:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
450--5--Preis Version Beta 2.0 Build 0
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
Attributes
Name Type Use Default Fixed Description
PRICE_FEATURE_GROUP_NO Restriction of xs:positiveInteger required 400--8--Ausfuehrungs_Gruppe Version Beta 2.0 Build 0, K. Richter 25.03.2014
This attribute references a PRICE_FEATURE_GROUP. D positiveInteger
P
M [1:99999]
Source
<xs:element name="PRICE_FEATURE_GROUP_BASE_PRICE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence minOccurs="0">
      <xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>450/470--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRICE_FIELD">
              <xs:annotation>
                <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="250" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="PRICE">
              <xs:annotation>
                <xs:documentation>450--5--Preis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:integer">
                  <xs:minInclusive value="-99999999" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="PRICE_FEATURE_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--8--Ausfuehrungs_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_PRICE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element : ITEM_PRICE Element
Description
450/470--1--Satzart Version Beta 2.0 Build 0This element is used to specify the block price.
Namespace (none)
Diagram
PRICE Element PRICE_FIELD Element Sequence ITEM_PRICE Element
Overview
ITEM_PRICE 0..∞
450/470--1--Satzart Version Beta 2.0 Build 0This element is used to specify the block price.
Sequence
PRICE_FIELD Restriction of xs:positiveInteger
450--4--Preisfeld/Aufpreisfeld Version Beta 2.0 Build 0, K. Richter 25.03.2014

This element references to the block price field (BLOCK_PRICE_FIELD below PRICE_DEFINITION in the main catalogue).

The values in BLOCK_PRICE_FIELD can be identical to the values in PRICE_FIELD.They can also be assigned differently for individual ranges within the catalogue price groups.

The following applies:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

 D positiveInteger
P
M [1:250]
PRICE Restriction of xs:integer
450--5--Preis Version Beta 2.0 Build 0
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
Source
<xs:element name="ITEM_PRICE" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450/470--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRICE_FIELD">
        <xs:annotation>
          <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="250" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="PRICE">
        <xs:annotation>
          <xs:documentation>450--5--Preis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:integer">
            <xs:minInclusive value="-99999999" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PRICE_FIELD Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE_FIELD Element
Description
450--4--Preisfeld/Aufpreisfeld Version Beta 2.0 Build 0, K. Richter 25.03.2014

This element references to the block price field (BLOCK_PRICE_FIELD below PRICE_DEFINITION in the main catalogue).

The values in BLOCK_PRICE_FIELD can be identical to the values in PRICE_FIELD.They can also be assigned differently for individual ranges within the catalogue price groups.

The following applies:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

 D positiveInteger
P
M [1:250]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
PRICE_FIELD Element
Overview
PRICE_FIELD Restriction of xs:positiveInteger
450--4--Preisfeld/Aufpreisfeld Version Beta 2.0 Build 0, K. Richter 25.03.2014

This element references to the block price field (BLOCK_PRICE_FIELD below PRICE_DEFINITION in the main catalogue).

The values in BLOCK_PRICE_FIELD can be identical to the values in PRICE_FIELD.They can also be assigned differently for individual ranges within the catalogue price groups.

The following applies:

Either the values in BLOCK_PRICE_FIELD are identical to those in PRICE_FIELD, or the price fields entered in the BLOCK_PRICE_FIELD are unique within a series.

 D positiveInteger
P
M [1:250]
Source
<xs:element name="PRICE_FIELD" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--4--Preisfeld/Aufpreisfeld</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="250" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PRICE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > PRICE_FEATURE_GROUP_BASE_PRICE_REF Element > ITEM_PRICE Element : PRICE Element
Description
450--5--Preis Version Beta 2.0 Build 0
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
Namespace (none)
Type
Restriction of xs:integer
Diagram
PRICE Element
Overview
PRICE Restriction of xs:integer
450--5--Preis Version Beta 2.0 Build 0
This field is used for the prices of an item according to the price groups(price field, element PRICE_FIELD). Prices have to be defined in the smallest currency unit (e. g. 300,00 € = 30000 cent). Fields may also contain negative prices.These are entered with a minus sign, therefore the number of digits for negative prices is one less than for positive values. The first figure after the minus sign has to be > 0, blanks are not permitted.

(example: -9,00 € => -900)

If the value 0 is filled in, the item is free of charge within this price group. If an item is not available in one price group, no record is set up in the corresponding element PRICE_FEATURE_GROUP_BASE_PRICE_REF. 		D integer
P
M [-99999999:999999999]
Source
<xs:element name="PRICE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>450--5--Preis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:integer">
      <xs:minInclusive value="-99999999" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM_PRICE Element | PRICE_FEATURE_GROUP_BASE_PRICE_REF Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PRICE_TYPE_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : PRICE_TYPE_REF Element
Description
400/407--0--NEW Version Beta 2.0 Build 2This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPES
Namespace (none)
Diagram
PRICE_TYPE_REF Element
Overview
PRICE_TYPE_REF
400/407--0--NEW Version Beta 2.0 Build 2This element is used to reference a price type. Price types are defined in the path1/PRICE_TYPE element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/PRICE_TYPES
PRICE_TYPE_NO required Restriction of xs:positiveInteger
407--5--Preisart Version Beta 2.0 Build 2, K. Richter 25.03.2014
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Attributes
Name Type Use Default Fixed Description
PRICE_TYPE_NO Restriction of xs:positiveInteger required 407--5--Preisart Version Beta 2.0 Build 2, K. Richter 25.03.2014
This attribute identifies a price type. D positiveInteger
P
M [1:999]
Source
<xs:element name="PRICE_TYPE_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400/407--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="PRICE_TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--5--Preisart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 25.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CALC_GROUP_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CALC_GROUP_REF Element
Description
400--0--NEW Version Beta 2.0 Build 0This element references calculation groups. The calculation groups are defined within the product categories in the main catalogue.
Namespace (none)
Diagram
CALC_GROUP_REF Element
Overview
CALC_GROUP_REF
400--0--NEW Version Beta 2.0 Build 0This element references calculation groups. The calculation groups are defined within the product categories in the main catalogue.
CALC_GROUP_NO required Restriction of xs:positiveInteger
407--6--Kalk_Gruppe Version Beta 2.0 Build 4, K. Richter 21.03.2014
This attribute identifies a price type. D positiveInteger
P
M [10:99]
Attributes
Name Type Use Default Fixed Description
CALC_GROUP_NO Restriction of xs:positiveInteger required 407--6--Kalk_Gruppe Version Beta 2.0 Build 4, K. Richter 21.03.2014
This attribute identifies a price type. D positiveInteger
P
M [10:99]
Source
<xs:element name="CALC_GROUP_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="CALC_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>407--6--Kalk_Gruppe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 21.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="10" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EXCHANGE_ID_REF Element
Description
400--0--NEW Version Beta 2.0 Build 0This element references a swap-ID, which is defined in the path1/EXCHANGE_ID element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
Namespace (none)
Diagram
EXCHANGE_ID_REF Element
Overview
EXCHANGE_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references a swap-ID, which is defined in the path1/EXCHANGE_ID element of the main catalogue.

Element paths:
P1: PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attributes
Name Type Use Default Fixed Description
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required 400--0--NEW Version Beta 2.0 Build 0
This attribute identifies an exchange-ID. D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Source
<xs:element name="EXCHANGE_ID_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : RESTRICTIONS Element
Description
409--0--NEW Version Beta 2.0 Build 0This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Namespace (none)
Diagram
RESTRICTION_REF Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS optional
409--0--NEW Version Beta 2.0 Build 0This element defines the item specific restrictions.

Only those restrictions, which are part of the feature class of an item, are permitted.

Items may only reference those restrictions which reduce the number of feature types and options of an item.

Restrictions which result in an exclusion of styles may only be referenced by items which depend on different styles.

Item specific restrictions override those restrictions which are referenced from series or programmes.

An item must not reference identical restrictions. Identical restrictions are defined as follows (restriction 1 = P1, restriction 2 = P2):
P1-feature1 = P2-feature1 and P1-feature2 = P2-feature2
or
P1-option1 = P2-option2 and P1-option2 = P2-option1

The number of selected options within a planning is only valid, if there is no restriction which excludes a combination of these options.
Sequence
RESTRICTION_REF 1..∞
409--0--NEW Version Beta 2.0 Build 0This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
Source
<xs:element name="RESTRICTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>409--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>409--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>409--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE" use="required">
            <xs:annotation>
              <xs:documentation>409--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:maxInclusive value="99999" />
                <xs:minInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

RESTRICTION_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > RESTRICTIONS Element : RESTRICTION_REF Element
Description
409--0--NEW Version Beta 2.0 Build 0This element references an item to an assigned restriction.
Namespace (none)
Diagram
RESTRICTION_REF Element
Overview
RESTRICTION_REF 1..∞
409--0--NEW Version Beta 2.0 Build 0This element references an item to an assigned restriction.
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE required Restriction of xs:nonNegativeInteger
409--0--NEW Version Beta 2.0 Build 0
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
Attributes
Name Type Use Default Fixed Description
RESTRICTION_NO Restriction of xs:nonNegativeInteger required 409--0--NEW Version Beta 2.0 Build 0
This attribute references item specific restrictions. D nonNegativeInteger
P
M [0:99999]
SEQUENCE Restriction of xs:nonNegativeInteger required 409--0--NEW Version Beta 2.0 Build 0
This element defines the sequence in which the different test procedures are performed. Several restrictions can be grouped together, (set union), if the value in the field sequence is the same. If the value differs an intersection of the different restrictions is made up.
The following rules apply: One sequence may contain only permitting restrictions.
The feature types of the restrictions in one sequence have to be the same.
The sequence has to be defined in ascending order which may have gaps, e.g. 1,3,10,...). 		D nonNegativeInteger
P
M [0:99999]
Source
<xs:element name="RESTRICTION_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>409--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>409--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE" use="required">
      <xs:annotation>
        <xs:documentation>409--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:maxInclusive value="99999" />
          <xs:minInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
RESTRICTIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

EDP_NUMBER Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : EDP_NUMBER Element
Description
400--10--EDV_Nummer Version Beta 2.0 Build 0
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
EDP_NUMBER Element
Overview
EDP_NUMBER optional Restriction of xs:string
400--10--EDV_Nummer Version Beta 2.0 Build 0
This element contains the (internal) manufacturer specific EDP-number of an item.
If the EDP_NUMBER is used it has to be unique and unambiguous for all items and series. 		D string
P
M [1:15]
Source
<xs:element name="EDP_NUMBER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--10--EDV_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_PRICE_STATUS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BLOCK_PRICE_STATUS Element
Description
400--12--Block_Preisstatus Version Beta 2.0 Build 0
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_PRICE_STATUS Element
Overview
BLOCK_PRICE_STATUS optional Restriction of xs:nonNegativeInteger
400--12--Block_Preisstatus Version Beta 2.0 Build 0
If the item is a block (ITEM_IDENTIFICATION = B) this element is used for defining the rules which apply to the block pricing in case single items are exchanged. This field is only optional, if no settings were made.
1 = additive block price;
block price is equivalent to the addition of item prices based on the regular purchase/ sales price list.
2 = fixed block price;
exchange and price changes are not possible.
3 = no price reduction;
permitted in case of exchange of items.
4 = price reduction limited to block price;
in case of an exchange of items price reductions are permitted, but limited to the defined block price, i.e. the price cannot fall below the block price.
5 = unlimited price reduction;
if items are exchanged, price reductions are permitted and the total price can fall below the block price.
6 = surcharge;
this status may only be assigned to additional equipment. The prices given are the surcharge prices compared to the prices of the standard block items.
7 = price reduction
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
8 = price reduction despite of a different block price rule;
this status may only be assigned in case of reduced equipment. The prices given are the price reductions compared to the prices of the standard block items.
9 = price reduction limited to the value of the exchange group; If items are exchanged, price reductions are permitted but limited to the total value of the corresponding exchange group.
Status 1-5 and 9 are only permitted if the item identification (ITEM_IDENTIFICATION)is set to "B"
Status 6-8 are only permitted if the item identification (ITEM_IDENTIFICATION) is set to "M". 		D nonNegativeInteger
P
M [1:9]
Source
<xs:element name="BLOCK_PRICE_STATUS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--12--Block_Preisstatus</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="9" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_IDENTIFICATION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_IDENTIFICATION Element
Description
400--14--Artikelkennung Version Beta 2.0 Build 0
This element is used to assign an identifier to the article.
B = Block
E = Spare part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal. 		D string
P [BEKSMZVPNOG]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
ITEM_IDENTIFICATION Element
Overview
ITEM_IDENTIFICATION Restriction of xs:string
400--14--Artikelkennung Version Beta 2.0 Build 0
This element is used to assign an identifier to the article.
B = Block
E = Spare part
K = Catalogue item
S = Special item
M = Additional equipment
Z = Configuration
O = Grouping without price, the price is calculated as the total of all items' individual prices.
N = Cannot be planned individually, item must only be contained in a single grouping
V = Settlement block
P = Settlement position
G = Grouping with price.
The V and P values are only used for the value settlement.
The values in TYPE_CREDIT (credit type) and TYPE_DEBIT (debit type) are not price group-independent within a value scale. Both TYPE_CREDITX and TYPE_DEBIT are universal. 		D string
P [BEKSMZVPNOG]
M [1:1]
Source
<xs:element name="ITEM_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--14--Artikelkennung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BEKSMZVPNOG]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CATALOG_PAGE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CATALOG_PAGE Element
Description
400--15--Katalog_Seite Version Beta 2.0 Build 0 geändert K.Richter 25.02.2016
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_PAGE Element
Overview
CATALOG_PAGE optional Restriction of xs:string
400--15--Katalog_Seite Version Beta 2.0 Build 0 geändert K.Richter 25.02.2016
This element refers to the page on which the item is described in the printed sales manual. This information helps the user to find the item faster in the printed manual. Items may appear on different/ several pages in the printed manual.
In this case it is recommended to indicate the number of the page on which the item is described in detail. Often this is done in the part/ register "accessories". 		D string
P
M [1:40]
Source
<xs:element name="CATALOG_PAGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--15--Katalog_Seite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>geändert K.Richter 25.02.2016</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="40" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

VAT_ID_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VAT_ID_REF Element
Description
400--0--NEW Version Beta 2.0 Build 0This element references VAT tax rates.

The VAT tax rates are specified in the VALUE_ADDED_TAX element (path 1 of the main catalogue). A value of 0 is entered for items that are VAT-free.
If the value of 0 (VAT-free item) is used, the value must also be specified in the VALUE_ADDED_TAX element (path 1).

Element paths
Path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
Namespace (none)
Diagram
VAT_ID_REF Element
Overview
VAT_ID_REF optional
400--0--NEW Version Beta 2.0 Build 0This element references VAT tax rates.

The VAT tax rates are specified in the VALUE_ADDED_TAX element (path 1 of the main catalogue). A value of 0 is entered for items that are VAT-free.
If the value of 0 (VAT-free item) is used, the value must also be specified in the VALUE_ADDED_TAX element (path 1).

Element paths
Path 1: PRICE_DEFINITION/VALUE_ADDED_TAXES
VAT_NO required Restriction of xs:nonNegativeInteger
400--0--NEW Version Beta 2.0 Build 0
This element is used for referencing the different VAT rates.

 D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
VAT_NO Restriction of xs:nonNegativeInteger required 400--0--NEW Version Beta 2.0 Build 0
This element is used for referencing the different VAT rates.

 D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="VAT_ID_REF" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="VAT_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_FROM Element
Description
400--18--Lieferbar_ab Version Beta 2.0 Build 0
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
400--18--Lieferbar_ab Version Beta 2.0 Build 0
This element defines the first date of availability for an item.
If this field is left blank information from the element CATALOG/VALID_FROM_DATE applies.
Elements named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. 		D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--18--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : VALID_UNTIL Element
Description
400--19--Lieferbar_bis Version Beta 2.0 Build 0
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
400--19--Lieferbar_bis Version Beta 2.0 Build 0
This element indicates the date up to which an item is available. If this field is left blank the availability of an item is not restricted.
Fields named VALID_UNITL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. 		D date
P
M
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--19--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

RANGE_DEPENDENT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : RANGE_DEPENDENT Element
Description
400--34--Prog_abhaengig Version Beta 2.0 Build 0
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD of the main catalogue. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
RANGE_DEPENDENT Element
Overview
RANGE_DEPENDENT Restriction of xs:boolean
400--34--Prog_abhaengig Version Beta 2.0 Build 0
For range dependent items the pricing and the graphical depiction have to be distinguished.

0 = not depending on range
1 = range dependent

This element controls the graphic depiction and the restrictions.
If this element is marked with "0", i.e. the item is defined as not depending on range, a range depending restriction is not permitted. Price interconnections are defind by the element PRICE_CALC_METHOD of the main catalogue. This element controls the range dependency. The element PRICE_CALC_METHOD defines that the price of an item depends on the chosen programme or range.

T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/PRICE_CALC_METHOD 		D boolean
P
M
Source
<xs:element name="RANGE_DEPENDENT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--34--Prog_abhaengig</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_PARTS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : BLOCK_PARTS Element
Description
401--1--Satzart Version Beta 2.0 Build 0This element is used as a container element for the block parts lists in the catalogue.
Namespace (none)
Diagram
BLOCK_PART Element Sequence BLOCK_PARTS Element
Overview
BLOCK_PARTS optional
401--1--Satzart Version Beta 2.0 Build 0This element is used as a container element for the block parts lists in the catalogue.
Sequence
BLOCK_PART 1..∞
401--0--NEW Version Beta 2.0 Build 0

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2 of the main catalogue), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
401--4--Block_Lfd_Nr Version Beta 2.0 Build 0
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF
401--0--NEW Version Beta 2.0 Build 0

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2 of the main catalogue) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞
401--0--NEW Version Beta 2.0 Build 0This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2 of the main catalogue).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to specify the version type of a referenced version.
A FEATURE_NO must only occur once. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to reference a version. D string
P
M [1:5]
HINGE optional Restriction of xs:string
401--6--Anschlag Version Beta 2.0 Build 0
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger
401--7--Tauschbedingung Version Beta 2.0 Build 0

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
401--8--Status Version Beta 2.0 Build 0
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
401--10--Blockartikelmass_Breite Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
401--11--Blockartikelmass_Hoehe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
401--12--Blockartikelmass_Tiefe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
401--13--Bauweise_ID Version Beta 2.0 Build 0
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Source
<xs:element name="BLOCK_PARTS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_PART" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_SEQUENTIAL_NO">
              <xs:annotation>
                <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>401--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>401--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="HINGE" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--6--Anschlag</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[BEJLMNR]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXCHANGE_CONDITION">
              <xs:annotation>
                <xs:documentation>401--7--Tauschbedingung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="2" />
                  <xs:maxInclusive value="3" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="STATUS">
              <xs:annotation>
                <xs:documentation>401--8--Status</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[ABELSZ]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="99999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CONSTRUCTION_ID" minOccurs="0">
              <xs:annotation>
                <xs:documentation>401--13--Bauweise_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="|[JLNRAE]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_PART Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element : BLOCK_PART Element
Description
401--0--NEW Version Beta 2.0 Build 0

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2 of the main catalogue), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Namespace (none)
Diagram
CONSTRUCTION_ID Element BLOCK_ITEM_DIMENSION_DEPTH Element BLOCK_ITEM_DIMENSION_HEIGHT Element BLOCK_ITEM_DIMENSION_WIDTH Element STATUS Element EXCHANGE_CONDITION Element HINGE Element OPTION_REF Element ITEM_REF Element BLOCK_SEQUENTIAL_NO Element Sequence BLOCK_PART Element
Overview
BLOCK_PART 1..∞
401--0--NEW Version Beta 2.0 Build 0

In this element the single items of a block (block items) resp. additional equipment parts are defined. Neutral items as well as items depending on a programme and a finish can be referenced.

For items which are defined as depending on features the following rules apply:
The feature class is defined by the element ITEM (path 1). The feature class of the block elements cannot be changed in the block data.In the elements FEATURE_REF and OPTION_REF only those feature combinations may be used, which are defined for the block items..

Depending on the price type (element PRICE_CALC_METHOD (path 2 of the main catalogue), defined for the block item in the element ITEM/PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 1), the following combinations of the attributes OPTION_REF are permitted:

- Method = 1: the element OPTION_REF is not permitted.
- Method = 2: the attribute FEATURE_NO requires the value 1 for programme.
- Method = 3 the value 1 for programme is not permitted in the attribute FEATURE_NO.

All items which are referenced in a block file have to exist in the catalogue file (Note: if this condition is not fulfilled, the software will not process the block).

Items marked with series „0“ must not occur in other series with the same type name, items not marked with series „0“ can be mixed. The block item has to have the same series assignment as the block, or it has to be marked with series flag „0“.
Restrictions are not processed on single elements of a block parts list. The price information of a block item is always calculated, independent from further restrictions e. g. limitations in the availability etc..
If there is at least one record marked with one of the flags „B“, „M“ or „Z“ in the element ITEM (path 1) this element has to be defined.

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Sequence
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
401--4--Block_Lfd_Nr Version Beta 2.0 Build 0
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
ITEM_REF
401--0--NEW Version Beta 2.0 Build 0

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2 of the main catalogue) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
OPTION_REF 0..∞
401--0--NEW Version Beta 2.0 Build 0This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2 of the main catalogue).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to specify the version type of a referenced version.
A FEATURE_NO must only occur once. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to reference a version. D string
P
M [1:5]
HINGE optional Restriction of xs:string
401--6--Anschlag Version Beta 2.0 Build 0
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
EXCHANGE_CONDITION Restriction of xs:positiveInteger
401--7--Tauschbedingung Version Beta 2.0 Build 0

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
STATUS Restriction of xs:string
401--8--Status Version Beta 2.0 Build 0
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
401--10--Blockartikelmass_Breite Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
401--11--Blockartikelmass_Hoehe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
401--12--Blockartikelmass_Tiefe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
CONSTRUCTION_ID optional Restriction of xs:string
401--13--Bauweise_ID Version Beta 2.0 Build 0
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Source
<xs:element name="BLOCK_PART" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_SEQUENTIAL_NO">
        <xs:annotation>
          <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>401--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>401--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="HINGE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--6--Anschlag</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[BEJLMNR]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXCHANGE_CONDITION">
        <xs:annotation>
          <xs:documentation>401--7--Tauschbedingung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="2" />
            <xs:maxInclusive value="3" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="STATUS">
        <xs:annotation>
          <xs:documentation>401--8--Status</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[ABELSZ]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="99999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CONSTRUCTION_ID" minOccurs="0">
        <xs:annotation>
          <xs:documentation>401--13--Bauweise_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="|[JLNRAE]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_SEQUENTIAL_NO Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_SEQUENTIAL_NO Element
Description
401--4--Block_Lfd_Nr Version Beta 2.0 Build 0
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_SEQUENTIAL_NO Element
Overview
BLOCK_SEQUENTIAL_NO Restriction of xs:nonNegativeInteger
401--4--Block_Lfd_Nr Version Beta 2.0 Build 0
This element defines the position of an item in the block arrangement. D nonNegativeInteger
P
M [1:999]
Source
<xs:element name="BLOCK_SEQUENTIAL_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--4--Block_Lfd_Nr</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : ITEM_REF Element
Description
401--0--NEW Version Beta 2.0 Build 0

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2 of the main catalogue) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF
401--0--NEW Version Beta 2.0 Build 0

This element references the items which are part of the block or additional equipment.

A reference to elements with value 0 (price on request) in the element PRICE_CALC_METHOD (path 2 of the main catalogue) is not permitted. Only items with flags E, K, or S in the element ITEM_IDENTIFICATION (Path 1) are permitted.

Neutral items are referenced by series "0".

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Path 2: PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP

TYPE_NO required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required 401--0--NEW Version Beta 2.0 Build 0
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required 401--0--NEW Version Beta 2.0 Build 0
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : OPTION_REF Element
Description
401--0--NEW Version Beta 2.0 Build 0This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2 of the main catalogue).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF 0..∞
401--0--NEW Version Beta 2.0 Build 0This element references feature combinations according to the definitions in the elements FEATURE_NO and PRICE_FEATURE_GROUP (path 1).

The referenced feature combinations have to correspond with definitions in the element PRICE_FEATURE_GROUP_BASE_PRICE_REF (path 2 of the main catalogue).

This element has to be filled in for all items which are not neutral items.

Path 1: PRICE_DEFINITION/PRICE_FEATURE_GROUPS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The feature has to be defined in
T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION the options in T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS.
FEATURE_NO required Restriction of xs:nonNegativeInteger
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to specify the version type of a referenced version.
A FEATURE_NO must only occur once. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
401--0--NEW Version Beta 2.0 Build 0
This attribute is used to reference a version. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required 401--0--NEW Version Beta 2.0 Build 0
This attribute is used to specify the version type of a referenced version.
A FEATURE_NO must only occur once. 		D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required 401--0--NEW Version Beta 2.0 Build 0
This attribute is used to reference a version. D string
P
M [1:5]
Source
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>401--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

HINGE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : HINGE Element
Description
401--6--Anschlag Version Beta 2.0 Build 0
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
HINGE Element
Overview
HINGE optional Restriction of xs:string
401--6--Anschlag Version Beta 2.0 Build 0
This element defines the position of hinges for the items in the block parts list.
This element is only filled in if the orientation of the hinges differs from the settings given in the element HINGE (path 1) in the item definition.

In all other cases the hinge position is applied according to the definitions for the block and additional equipment items.
The following codes can be used to define the door closing:
J = request closing;
L = hinge left;
M = centre closing, hinges in the centre (double door);
N = without closing, or hinges on the exterior sides (double door);
R = hinge right;
B = corresponding with construction ID i.e. left: hinge left;
E = opposite to construction_ID, i.e. left: hinge right;

In case of double doors L and R apply to both doors.
Values B and E are illegal values, unless the element construction_ID (path 1) is set to J.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM 		D string
P [BEJLMNR]
M [1:1]
Source
<xs:element name="HINGE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--6--Anschlag</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[BEJLMNR]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_CONDITION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : EXCHANGE_CONDITION Element
Description
401--7--Tauschbedingung Version Beta 2.0 Build 0

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
EXCHANGE_CONDITION Element
Overview
EXCHANGE_CONDITION Restriction of xs:positiveInteger
401--7--Tauschbedingung Version Beta 2.0 Build 0

This element is used for more detailed explanations of the exchange conditions.

2 = exchange not permitted
3 = exchange is possible according to rule set.

 D positiveInteger
P
M [2:3]
Source
<xs:element name="EXCHANGE_CONDITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--7--Tauschbedingung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="2" />
      <xs:maxInclusive value="3" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

STATUS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : STATUS Element
Description
401--8--Status Version Beta 2.0 Build 0
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
STATUS Element
Overview
STATUS Restriction of xs:string
401--8--Status Version Beta 2.0 Build 0
Legal values in this element are defined as follows:

A = this item is canceled (replacement);
B = block item;
E = this item is a replacement for the above mentioned canceled item;
L = this item is canceled without replacement;
S = item belonging to a set;
Z = additional item.

For additional equipment the sequence "exchange", "replacement", "exchange","replacement" has to be strictly observed.
If an item is marked with "S" (= belonging to a set), the corresponding item has to be defined as additional equipment (item_identification = M). This field has to be marked with "S" for each block item.
The status of a block exchange type is depending on the definition in the element ITEM (path 1). The following rules apply:
- Item identification = B, status = B
- item identification = M, status = A, E, L, Z or S only (all items of the additional equipment have to be set to S)
- item identification = Z, status = B, S

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS 		D string
P [ABELSZ]
M [1:1]
Source
<xs:element name="STATUS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--8--Status</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[ABELSZ]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_WIDTH Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_WIDTH Element
Description
401--10--Blockartikelmass_Breite Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_ITEM_DIMENSION_WIDTH Element
Overview
BLOCK_ITEM_DIMENSION_WIDTH optional Restriction of xs:nonNegativeInteger
401--10--Blockartikelmass_Breite Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="BLOCK_ITEM_DIMENSION_WIDTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--10--Blockartikelmass_Breite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_HEIGHT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_HEIGHT Element
Description
401--11--Blockartikelmass_Hoehe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_ITEM_DIMENSION_HEIGHT Element
Overview
BLOCK_ITEM_DIMENSION_HEIGHT optional Restriction of xs:nonNegativeInteger
401--11--Blockartikelmass_Hoehe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="BLOCK_ITEM_DIMENSION_HEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--11--Blockartikelmass_Hoehe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_ITEM_DIMENSION_DEPTH Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : BLOCK_ITEM_DIMENSION_DEPTH Element
Description
401--12--Blockartikelmass_Tiefe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
BLOCK_ITEM_DIMENSION_DEPTH Element
Overview
BLOCK_ITEM_DIMENSION_DEPTH optional Restriction of xs:nonNegativeInteger
401--12--Blockartikelmass_Tiefe Version Beta 2.0 Build 0
For block part items with variable dimensions the exact measurements are defined in this element. If measurements are given all three dimensions, width, height, and depth have to be defined. D nonNegativeInteger
P
M [1:99999]
Source
<xs:element name="BLOCK_ITEM_DIMENSION_DEPTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--12--Blockartikelmass_Tiefe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="99999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CONSTRUCTION_ID Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > BLOCK_PARTS Element > BLOCK_PART Element : CONSTRUCTION_ID Element
Description
401--13--Bauweise_ID Version Beta 2.0 Build 0
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
CONSTRUCTION_ID Element
Overview
CONSTRUCTION_ID optional Restriction of xs:string
401--13--Bauweise_ID Version Beta 2.0 Build 0
This element defines the construction-ID of an item with reference to the basic carcase shape (part 2).
J = item is not symmetrical, request for construction_ID.
L = construction_ID is exactly defined (left-hand construction).
R = construction_ID is exactly defined, basic shape is mirrored.
N = basic shape is unambiguous, item is symmetrical.
A = corresponding with door closing (e.g. door closing left, construction_ID left)
E = contrary to door closing (e.g. door closing left, construction_ID right)
For the item identification B (block) the arrangement of items within the block corresponds with the CONSTRUCTION_ID. 		D string
P |[JLNRAE]
M [1:1]
Source
<xs:element name="CONSTRUCTION_ID" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>401--13--Bauweise_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="|[JLNRAE]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
BLOCK_PART Element | BLOCK_PARTS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_TEXT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_TEXT Element
Description
410--1--Satzart Version Beta 2.0 Build 0This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Namespace (none)
Diagram
LANGUAGE Element Sequence PLANNING_ADVICE Element LANGUAGE Element Sequence FULL_TEXT Element SHORT_TEXT Element Sequence ITEM_TEXT Element
Overview
ITEM_TEXT
410--1--Satzart Version Beta 2.0 Build 0This element provides additional text information for an item, e.g. long or short text or planning advices. For each item at least one item text has to be defined.

The following text combinations are permitted:
- Short text;

- Short text + long text

The short text element is limited to three lines
Sequence
SHORT_TEXT
410--5--Texttype Version Beta 2.0 Build 0This element contains short text information.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information.
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetexte Complex Type
410--5--Texttype

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
PLANNING_ADVICE optional languagetexte60999 Complex Type
410--5--Texttype Version Beta 2.0 Build 0This element contains planning advices.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="ITEM_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SHORT_TEXT">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>410--6--Textzeile</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>150--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

SHORT_TEXT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : SHORT_TEXT Element
Description
410--5--Texttype Version Beta 2.0 Build 0This element contains short text information.
Namespace (none)
Diagram
LANGUAGE Element Sequence SHORT_TEXT Element
Overview
SHORT_TEXT
410--5--Texttype Version Beta 2.0 Build 0This element contains short text information.
Sequence
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information.
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="SHORT_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>410--6--Textzeile</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

LANGUAGE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element : LANGUAGE Element
Description
410--0--NEW Version Beta 2.0 Build 2This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
Namespace (none)
Diagram
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
410--0--NEW Version Beta 2.0 Build 2This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION.
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information.
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required 150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>410--6--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TEXT_LINE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element : TEXT_LINE Element
Description
410--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information.
Namespace (none)
Diagram
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..3
410--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information.
SEQUENCE_NO required Restriction of xs:positiveInteger
410--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
SEQUENCE_NO Restriction of xs:positiveInteger required 410--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Source
<xs:element name="TEXT_LINE" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>410--6--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TEXT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Description
410--6--Textzeile Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
410--6--Textzeile Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--6--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

FULL_TEXT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : FULL_TEXT Element
Description
410--5--Texttype

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Namespace (none)
Type
languagetexte Complex Type
Diagram
LANGUAGE Element Sequence FULL_TEXT Element
Overview
FULL_TEXT optional languagetexte Complex Type
410--5--Texttype

The element full text provides the complete item information including the short text. HTML format options bold and softreturn are permitted.

This element contains the long text information in a knot.
Format options have to comply with the HTML standard

<b> | Bold
<br> | Soft return

Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
Source
<xs:element name="FULL_TEXT" type="languagetexte" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PLANNING_ADVICE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : PLANNING_ADVICE Element
Description
410--5--Texttype Version Beta 2.0 Build 0This element contains planning advices.
Namespace (none)
Type
languagetexte60999 Complex Type
Diagram
LANGUAGE Element Sequence PLANNING_ADVICE Element
Overview
PLANNING_ADVICE optional languagetexte60999 Complex Type
410--5--Texttype Version Beta 2.0 Build 0This element contains planning advices.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="PLANNING_ADVICE" type="languagetexte60999" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TYPE_KEY Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : TYPE_KEY Element
Description
445--1--Satzart Version Beta 2.0 Build 0This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item
Namespace (none)
Diagram
TK_FRONT_APPEARANCE Element TK_SHAPE Element TK_MATERIAL Element TK_EQUIPMENT Element TK_CLASS Element TK_TYPE Element Sequence TYPE_KEY Element
Overview
TYPE_KEY
445--1--Satzart Version Beta 2.0 Build 0This element defines the type key of an item.

Multiple allocations of the attribute installation information (TK_INSTALLATION_INFORMATION), recess height (TK_RECESS_HEIGHT) and equipment (TK_EQUIPMENT) are permitted.

Multiple allocations have to be defined in ascending order, starting with the element TK_INSTALLATION_INFORMATION).

Data in the element TK_recess_HEIGHT necessarily imply corresponding settings in the element TK_INSTALLATION_INFORMATION

There are interdependencies between the different elements

- TK_TYPE,
- TK_CLASS,
- TK_INSTALLATION_INFORMATION,
- TK_RECESS_HEIGHT,
- TK_EQUIPMENT,
- TK_MATERIAL und
- TK_SHAPE

Only one type key is permitted per item
Sequence
TK_TYPE Restriction of xs:positiveInteger
445--4--TS_Typ Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
TK_CLASS Restriction of xs:positiveInteger
445--5--TS_Art Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column item No., as listed in the Table "Type key arts", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
TK_EQUIPMENT 0..5
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
445--0--NEW Version Beta 2.0 Build 4This element is used to specify the combination of installation information (see table Installinfo key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5 Version Beta 2.0 Build 0
A value from the column InstallInfo in table "installinfo key" is entered here. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5 Version Beta 2.0 Build 4 Erweitert von 2 auf 4 Stellen 2011-12-14
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
TK_MATERIAL optional Restriction of xs:positiveInteger
445--21--TS_Material Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type, as listed in table " Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_SHAPE optional Restriction of xs:positiveInteger
445--22--TS_Form Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column shape No., as listed in the table " Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
445--23--TS_Front_Auspraegung Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column front appearance No., as listed in the table " Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Source
<xs:element name="TYPE_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_TYPE">
        <xs:annotation>
          <xs:documentation>445--4--TS_Typ</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_CLASS">
        <xs:annotation>
          <xs:documentation>445--5--TS_Art</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5">
        <xs:annotation>
          <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                      <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
            <xs:annotation>
              <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="TK_MATERIAL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--21--TS_Material</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-2]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_SHAPE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--22--TS_Form</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-2]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_FRONT_APPEARANCE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TK_TYPE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_TYPE Element
Description
445--4--TS_Typ Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
TK_TYPE Element
Overview
TK_TYPE Restriction of xs:positiveInteger
445--4--TS_Typ Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type No., as listed in the table "Type Keys", is required in this field. D positiveInteger
P [1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]
M [1:99]
Source
<xs:element name="TK_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--4--TS_Typ</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[012345789]|2[01246789]|3[0578]|4[123]|9[589]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TK_CLASS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_CLASS Element
Description
445--5--TS_Art Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column item No., as listed in the Table "Type key arts", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
TK_CLASS Element
Overview
TK_CLASS Restriction of xs:positiveInteger
445--5--TS_Art Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column item No., as listed in the Table "Type key arts", is required in this field. D positiveInteger
P [1-9]|1[0145679]|2[126789]|3[023467]|40
M [1:40]
Source
<xs:element name="TK_CLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--5--TS_Art</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0145679]|2[126789]|3[023467]|4[0]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TK_EQUIPMENT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_EQUIPMENT Element
Description
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is used for assigning a type key to the installation information and recess height.

Namespace (none)
Diagram
TK_INSTALLATION_RECESS Element Sequence TK_EQUIPMENT Element
Overview
TK_EQUIPMENT 0..5
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is used for assigning a type key to the installation information and recess height.

SEQUENCE_NO required Restriction of xs:positiveInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO optional Restriction of xs:nonNegativeInteger
445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Sequence
TK_INSTALLATION_RECESS optional
445--0--NEW Version Beta 2.0 Build 4This element is used to specify the combination of installation information (see table Installinfo key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5 Version Beta 2.0 Build 0
A value from the column InstallInfo in table "installinfo key" is entered here. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5 Version Beta 2.0 Build 4 Erweitert von 2 auf 4 Stellen 2011-12-14
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
Attributes
Name Type Use Default Fixed Description
SEQUENCE_NO Restriction of xs:positiveInteger required 445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4
This attribute defines the sequence in which installation information and equipment information is assigned to an item. D positiveInteger
P
M
TK_EQUIPMENT_NO Restriction of xs:nonNegativeInteger optional 445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5 Version Beta 2.0 Build 4

This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled.

A value from the column equipment-ID, as listed in table "Equipment key", is required in this field.

 D nonNegativeInteger
P [1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]
M 1:54
Source
<xs:element name="TK_EQUIPMENT" minOccurs="0" maxOccurs="5" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_INSTALLATION_RECESS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TK_EQUIPMENT_NO" use="optional">
      <xs:annotation>
        <xs:documentation>445--16/17/18/19/20--TS_Ausstattung_1/2/3/4/5</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[1-9]|1[012346789]|2[0-9]|3[0-7]|4[1-9]|5[0-4]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TK_INSTALLATION_RECESS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element : TK_INSTALLATION_RECESS Element
Description
445--0--NEW Version Beta 2.0 Build 4This element is used to specify the combination of installation information (see table Installinfo key) and recess height.
Namespace (none)
Diagram
TK_RECESS_HEIGHT Element TK_INSTALLATION_INFORMATION Element Sequence TK_INSTALLATION_RECESS Element
Overview
TK_INSTALLATION_RECESS optional
445--0--NEW Version Beta 2.0 Build 4This element is used to specify the combination of installation information (see table Installinfo key) and recess height.
Sequence
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5 Version Beta 2.0 Build 0
A value from the column InstallInfo in table "installinfo key" is entered here. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5 Version Beta 2.0 Build 4 Erweitert von 2 auf 4 Stellen 2011-12-14
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="TK_INSTALLATION_RECESS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TK_RECESS_HEIGHT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
          <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="9999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TK_INSTALLATION_INFORMATION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element > TK_INSTALLATION_RECESS Element : TK_INSTALLATION_INFORMATION Element
Description
445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5 Version Beta 2.0 Build 0
A value from the column InstallInfo in table "installinfo key" is entered here. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
TK_INSTALLATION_INFORMATION Element
Overview
TK_INSTALLATION_INFORMATION optional Restriction of xs:nonNegativeInteger
445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5 Version Beta 2.0 Build 0
A value from the column InstallInfo in table "installinfo key" is entered here. D nonNegativeInteger
P [1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]
M [1:49]
Source
<xs:element name="TK_INSTALLATION_INFORMATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--6/8/10/12/14--TS_Einbauinfo_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:pattern value="[1234578]|1[12345789]|2[12345689]|3[0234567]|4[6789]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TK_INSTALLATION_RECESS Element | TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TK_RECESS_HEIGHT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element > TK_EQUIPMENT Element > TK_INSTALLATION_RECESS Element : TK_RECESS_HEIGHT Element
Description
445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5 Version Beta 2.0 Build 4 Erweitert von 2 auf 4 Stellen 2011-12-14
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
TK_RECESS_HEIGHT Element
Overview
TK_RECESS_HEIGHT optional Restriction of xs:nonNegativeInteger
445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5 Version Beta 2.0 Build 4 Erweitert von 2 auf 4 Stellen 2011-12-14
This element defines the recess height in mm. This element is only filled in if the element TK_INSTALLATION_INFORMATION is filled. D nonNegativeInteger
P
M [0:9999]
Source
<xs:element name="TK_RECESS_HEIGHT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--7/9/11/13/15--TS_Nischenhöhe_1/2/3/4/5</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
    <xs:documentation>Erweitert von 2 auf 4 Stellen 2011-12-14</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="9999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TK_INSTALLATION_RECESS Element | TK_EQUIPMENT Element | TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TK_MATERIAL Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_MATERIAL Element
Description
445--21--TS_Material Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type, as listed in table " Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
TK_MATERIAL Element
Overview
TK_MATERIAL optional Restriction of xs:positiveInteger
445--21--TS_Material Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column type, as listed in table " Material keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Source
<xs:element name="TK_MATERIAL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--21--TS_Material</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-2]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TK_SHAPE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_SHAPE Element
Description
445--22--TS_Form Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column shape No., as listed in the table " Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
TK_SHAPE Element
Overview
TK_SHAPE optional Restriction of xs:positiveInteger
445--22--TS_Form Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column shape No., as listed in the table " Shape keys", is required in this field. D positiveInteger
P [1-9]|1[0-2]
M [1:12]
Source
<xs:element name="TK_SHAPE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--22--TS_Form</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-2]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TK_FRONT_APPEARANCE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > TYPE_KEY Element : TK_FRONT_APPEARANCE Element
Description
445--23--TS_Front_Auspraegung Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column front appearance No., as listed in the table " Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
TK_FRONT_APPEARANCE Element
Overview
TK_FRONT_APPEARANCE optional Restriction of xs:positiveInteger
445--23--TS_Front_Auspraegung Version Beta 2.0 Build 0, K. Richter 25.03.2014
A value from the column front appearance No., as listed in the table " Front appearance key", is required in this field. D positiveInteger
P [1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]
M
Source
<xs:element name="TK_FRONT_APPEARANCE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>445--23--TS_Front_Auspraegung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 25.03.2014</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-9]|1[0-8]|2[0-9]|3[01236789]|4[1-9]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TYPE_KEY Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CLASSIFICATIONS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CLASSIFICATIONS Element
Description
Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. RichterThis element is used to store standardized classification numbers.
Namespace (none)
Diagram
ECLASS Element Sequence CLASSIFICATIONS Element
Overview
CLASSIFICATIONS optional
Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. RichterThis element is used to store standardized classification numbers.
Sequence
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:negativeInteger

The eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.

The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Source
<xs:element name="CLASSIFICATIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS_NO">
              <xs:simpleType>
                <xs:restriction base="xs:negativeInteger">
                  <xs:totalDigits value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ECLASS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element : ECLASS Element
Description
This element is used to specify the eCl@ss classification.
Namespace (none)
Diagram
ECLASS_NO Element Sequence ECLASS Element
Overview
ECLASS
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:negativeInteger

The eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.

The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Source
<xs:element name="ECLASS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS_NO">
        <xs:simpleType>
          <xs:restriction base="xs:negativeInteger">
            <xs:totalDigits value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ECLASS_NO Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element > ECLASS Element : ECLASS_NO Element
Description

The eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.

The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Namespace (none)
Type
Restriction of xs:negativeInteger
Diagram
ECLASS_NO Element
Overview
ECLASS_NO Restriction of xs:negativeInteger

The eCl@ss number, which corresponds to the 3rd or 4th level of the eCl@ss classification, is assigned here.

The number for kitchen furniture starts with 5003, appliances with 291.

 D nonNegativeInteger
P
M [10000000:99999999]
Source
<xs:element name="ECLASS_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:negativeInteger">
      <xs:totalDigits value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ECLASS Element | CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

DETAIL_INFOS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : DETAIL_INFOS Element
Description
1000--0--NEW 30.05.2012/BurThis element summarizes all hyperlinks providing detail information for an item.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
1000--0--NEW 30.05.2012/BurThis element summarizes all hyperlinks providing detail information for an item.
Sequence
DETAIL_INFO_REF 1..∞
1000--0--NEW 30.05.2012/BurThis element references hyperlinks to detail information.
DETAIL_INFO_NO required
1000--0--NEW 30.05.2012/Bur
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

DETAIL_INFO_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
1000--0--NEW 30.05.2012/BurThis element references hyperlinks to detail information.
Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
1000--0--NEW 30.05.2012/BurThis element references hyperlinks to detail information.
DETAIL_INFO_NO required
1000--0--NEW 30.05.2012/Bur
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO required 1000--0--NEW 30.05.2012/Bur
This attribute is used for defining the identification number of the referenced detail information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

FEATURE_DEFINITION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element : FEATURE_DEFINITION Element
Description
1000--0--NEW Version Beta 2.0 Build 0All information which is depending on the different variations (restrictions) is defined in this element
Namespace (none)
Diagram
RESTRICTIONS Element Sequence FEATURE_DEFINITION Element
Overview
FEATURE_DEFINITION optional
1000--0--NEW Version Beta 2.0 Build 0All information which is depending on the different variations (restrictions) is defined in this element
Sequence
RESTRICTIONS
270/271--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of restrictions.
Sequence
RESTRICTION 1..99999
270/271--0--NEW Version Beta 2.0 Build 0This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
This attribute identifies restrictions unambiguously. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE required Restriction of xs:int
270/271--0--NEW
The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
270--0--NEW Version Beta 2.0 Build 0This element is used for the definition of a name for a control procedure.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
1000--0--NEW Version Beta 2.0 Build 6This element is used for the definition of a variation combination.
Sequence
OPTION_REF 1..3
271--0--NEW Version Beta 2.0 Build 4This element is used for referencing the variation types which are used in the control procedures.
FEATURE_NO required Restriction of xs:nonNegativeInteger
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
405--0--NEW Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the minimum dimension in which an option is available.
DIMENSION_TYPE required Restriction of xs:string
405--0--NEW Version Beta 2.0 Build 3
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--0--NEW Version Beta 2.0 Build 3
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
270--4--Pruef_ID Version Beta 2.0 Build 0
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted 		D boolean
P
M
Source
<xs:element name="FEATURE_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTIONS">
        <xs:annotation>
          <xs:documentation>270/271--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION" maxOccurs="99999">
              <xs:annotation>
                <xs:documentation>270/271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
                    <xs:annotation>
                      <xs:documentation>270--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_REF" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>271--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>271--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:sequence minOccurs="0">
                          <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                            <xs:annotation>
                              <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="DIMENSION_TYPE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[WHD]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSION_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                          <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                            <xs:annotation>
                              <xs:documentation>405--0--NEW</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                              <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                            </xs:annotation>
                            <xs:complexType>
                              <xs:attribute name="DIMENSION_TYPE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[WHD]" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                              <xs:attribute name="DIMENSION_VALUE" use="required">
                                <xs:annotation>
                                  <xs:documentation>405--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="1" />
                                    <xs:maxInclusive value="9999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:attribute>
                            </xs:complexType>
                          </xs:element>
                        </xs:sequence>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="TEST_ID">
                    <xs:annotation>
                      <xs:documentation>270--4--Pruef_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="RESTRICTION_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_1_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_2_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="FEATURE_3_NO">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="VALIDATION_TYPE" use="required">
                  <xs:annotation>
                    <xs:documentation>270/271--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:int">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="1" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

RESTRICTIONS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element : RESTRICTIONS Element
Description
270/271--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of restrictions.
Namespace (none)
Diagram
RESTRICTION Element Sequence RESTRICTIONS Element
Overview
RESTRICTIONS
270/271--1--Satzart Version Beta 2.0 Build 0This element is used for the definition of restrictions.
Sequence
RESTRICTION 1..99999
270/271--0--NEW Version Beta 2.0 Build 0This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
This attribute identifies restrictions unambiguously. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE required Restriction of xs:int
270/271--0--NEW
The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
270--0--NEW Version Beta 2.0 Build 0This element is used for the definition of a name for a control procedure.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
1000--0--NEW Version Beta 2.0 Build 6This element is used for the definition of a variation combination.
Sequence
OPTION_REF 1..3
271--0--NEW Version Beta 2.0 Build 4This element is used for referencing the variation types which are used in the control procedures.
FEATURE_NO required Restriction of xs:nonNegativeInteger
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
405--0--NEW Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the minimum dimension in which an option is available.
DIMENSION_TYPE required Restriction of xs:string
405--0--NEW Version Beta 2.0 Build 3
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--0--NEW Version Beta 2.0 Build 3
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
270--4--Pruef_ID Version Beta 2.0 Build 0
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted 		D boolean
P
M
Source
<xs:element name="RESTRICTIONS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION" maxOccurs="99999">
        <xs:annotation>
          <xs:documentation>270/271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
              <xs:annotation>
                <xs:documentation>270--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_REF" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>271--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>271--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:sequence minOccurs="0">
                    <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                      <xs:annotation>
                        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSION_TYPE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[WHD]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSION_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                    <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                      <xs:annotation>
                        <xs:documentation>405--0--NEW</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                        <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                      </xs:annotation>
                      <xs:complexType>
                        <xs:attribute name="DIMENSION_TYPE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[WHD]" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                        <xs:attribute name="DIMENSION_VALUE" use="required">
                          <xs:annotation>
                            <xs:documentation>405--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="1" />
                              <xs:maxInclusive value="9999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:attribute>
                      </xs:complexType>
                    </xs:element>
                  </xs:sequence>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="TEST_ID">
              <xs:annotation>
                <xs:documentation>270--4--Pruef_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="RESTRICTION_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_1_NO" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_2_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="FEATURE_3_NO">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="VALIDATION_TYPE" use="required">
            <xs:annotation>
              <xs:documentation>270/271--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:int">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="1" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

RESTRICTION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element : RESTRICTION Element
Description
270/271--0--NEW Version Beta 2.0 Build 0This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1
Namespace (none)
Diagram
TEST_ID Element OPTION_COMBINATION Element LANGUAGE Element Sequence RESTRICTION_NAME_TEXT Element Sequence RESTRICTION Element
Overview
RESTRICTION 1..99999
270/271--0--NEW Version Beta 2.0 Build 0This element is used for the definition and description of restrictions. These restrictions define rules for technically possible combinations but do not contain any planning advices. This is necessary to prevent the dealers from unnecessary restrictions in the course of kitchen planning.

Restrictions are assigned to series, styles or items by references. All test procedures defined in this element have to be referenced from series, styles or items.

Restrictions which are referenced from series or styles may not be referenced from items. Restrictions which are referenced from items have priority over restrictions referenced from series or styles

The element OPTION_REF can be set up in different ways. According to the filling levels in the elements FEATURE_1_NO, FEATURE_2_NO and FEATURE_3_NO test procedures can be defined as 0-level, 1-level or 2-level or 3-level.

Number of variations in case of undefined variations

On condition that the restriction is defined as a "permitting" test procedure (TEST_ID = 1), all features which are not listed in the test procedure are illegal feature combinations. If the restriction is defined as a "non-permitting" test procedure (TEST_ID = 0), all variations are legal feature combinations. If different feature combinations are combined this rule applies for the combination of the resulting features.

Number of variations for style specific restrictions:

In case a restriction is not referenced by all styles, the following rules apply:

If the restriction defines legal features and feature combinations, all variations of the feature combinations are illegal for those styles, which are not defined in the restriction.
If the restriction defines illegal features and feature combinations, all variations of the of the feature combinations are legal for those styles, which are not defined in the restriction.

Cyclical tests
Cyclical restrictions are not permitted. Such test procedures might result from the following constellations
Not permitted
1. restriction: feature 1 with feature 2
2. restriction: feature 2 with feature 3
3. restriction: feature 3 with feature 1
RESTRICTION_NO required Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
This attribute identifies restrictions unambiguously. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO required Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO optional Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO optional Restriction of xs:nonNegativeInteger
270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE required Restriction of xs:int
270/271--0--NEW
The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405) 		D nonNegativeInteger
P
M [0:1]
Sequence
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
270--0--NEW Version Beta 2.0 Build 0This element is used for the definition of a name for a control procedure.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMBINATION 1..∞
1000--0--NEW Version Beta 2.0 Build 6This element is used for the definition of a variation combination.
Sequence
OPTION_REF 1..3
271--0--NEW Version Beta 2.0 Build 4This element is used for referencing the variation types which are used in the control procedures.
FEATURE_NO required Restriction of xs:nonNegativeInteger
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
405--0--NEW Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the minimum dimension in which an option is available.
DIMENSION_TYPE required Restriction of xs:string
405--0--NEW Version Beta 2.0 Build 3
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--0--NEW Version Beta 2.0 Build 3
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
TEST_ID Restriction of xs:boolean
270--4--Pruef_ID Version Beta 2.0 Build 0
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted 		D boolean
P
M
Attributes
Name Type Use Default Fixed Description
RESTRICTION_NO Restriction of xs:nonNegativeInteger required 270/271--0--NEW Version Beta 2.0 Build 0
This attribute identifies restrictions unambiguously. D nonNegativeInteger
P
M [1:99999]
FEATURE_1_NO Restriction of xs:nonNegativeInteger required 270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_2_NO Restriction of xs:nonNegativeInteger optional 270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
FEATURE_3_NO Restriction of xs:nonNegativeInteger optional 270/271--0--NEW Version Beta 2.0 Build 0
The attributes FEATURE_1_NO, FEATURE_2_NO, FEATURE_3_NO define the different variation types which are used in the restrictions. At the same time the attributes define the sequence of the variation types in the restrictions.
In addition this attribute can be used to avoid an alternation of the variation types in one restriction. 		D nonNegativeInteger
P
M [0:999]
VALIDATION_TYPE Restriction of xs:int required 270/271--0--NEW
The attribute VALIDATION_TYPE defines a restriction as either colour-length or variation test procedure. In case of a colour-length test procedure the element MIN/MAX_DIMENSION under OPTION_COMBINATION has to be filled in.
0 = variation test procedure (formerly record type 270)
1 = colour-length test procedure (formerly record type 405) 		D nonNegativeInteger
P
M [0:1]
Source
<xs:element name="RESTRICTION" maxOccurs="99999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270/271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60">
        <xs:annotation>
          <xs:documentation>270--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMBINATION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_REF" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>271--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>271--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:sequence minOccurs="0">
              <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
                <xs:annotation>
                  <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="DIMENSION_TYPE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[WHD]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                  <xs:attribute name="DIMENSION_VALUE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
              <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
                <xs:annotation>
                  <xs:documentation>405--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                  <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
                </xs:annotation>
                <xs:complexType>
                  <xs:attribute name="DIMENSION_TYPE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[WHD]" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                  <xs:attribute name="DIMENSION_VALUE" use="required">
                    <xs:annotation>
                      <xs:documentation>405--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="1" />
                        <xs:maxInclusive value="9999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:attribute>
                </xs:complexType>
              </xs:element>
            </xs:sequence>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="TEST_ID">
        <xs:annotation>
          <xs:documentation>270--4--Pruef_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="RESTRICTION_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_1_NO" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_2_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FEATURE_3_NO">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="VALIDATION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>270/271--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:int">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="1" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

RESTRICTION_NAME_TEXT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : RESTRICTION_NAME_TEXT Element
Description
270--0--NEW Version Beta 2.0 Build 0This element is used for the definition of a name for a control procedure.
Namespace (none)
Type
languagetexte60 Complex Type
Diagram
LANGUAGE Element Sequence RESTRICTION_NAME_TEXT Element
Overview
RESTRICTION_NAME_TEXT languagetexte60 Complex Type
270--0--NEW Version Beta 2.0 Build 0This element is used for the definition of a name for a control procedure.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="RESTRICTION_NAME_TEXT" type="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

OPTION_COMBINATION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : OPTION_COMBINATION Element
Description
1000--0--NEW Version Beta 2.0 Build 6This element is used for the definition of a variation combination.
Namespace (none)
Diagram
MIN_DIMENSION Element MAX_DIMENSION Element Sequence OPTION_REF Element Sequence OPTION_COMBINATION Element
Overview
OPTION_COMBINATION 1..∞
1000--0--NEW Version Beta 2.0 Build 6This element is used for the definition of a variation combination.
Sequence
OPTION_REF 1..3
271--0--NEW Version Beta 2.0 Build 4This element is used for referencing the variation types which are used in the control procedures.
FEATURE_NO required Restriction of xs:nonNegativeInteger
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a option. D string
P
M [1:5]
Sequence optional
MAX_DIMENSION 0..3
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
MIN_DIMENSION 0..3
405--0--NEW Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the minimum dimension in which an option is available.
DIMENSION_TYPE required Restriction of xs:string
405--0--NEW Version Beta 2.0 Build 3
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--0--NEW Version Beta 2.0 Build 3
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
Source
<xs:element name="OPTION_COMBINATION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_REF" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>271--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>271--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:sequence minOccurs="0">
        <xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3">
          <xs:annotation>
            <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="DIMENSION_TYPE" use="required">
              <xs:annotation>
                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[WHD]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
            <xs:attribute name="DIMENSION_VALUE" use="required">
              <xs:annotation>
                <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
        <xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3">
          <xs:annotation>
            <xs:documentation>405--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
            <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
          </xs:annotation>
          <xs:complexType>
            <xs:attribute name="DIMENSION_TYPE" use="required">
              <xs:annotation>
                <xs:documentation>405--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[WHD]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
            <xs:attribute name="DIMENSION_VALUE" use="required">
              <xs:annotation>
                <xs:documentation>405--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="9999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:attribute>
          </xs:complexType>
        </xs:element>
      </xs:sequence>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : OPTION_REF Element
Description
271--0--NEW Version Beta 2.0 Build 4This element is used for referencing the variation types which are used in the control procedures.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF 1..3
271--0--NEW Version Beta 2.0 Build 4This element is used for referencing the variation types which are used in the control procedures.
FEATURE_NO required Restriction of xs:nonNegativeInteger
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a option. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required 271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required 271--0--NEW Version Beta 2.0 Build 4
This attribute is used for referencing a option. D string
P
M [1:5]
Source
<xs:element name="OPTION_REF" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>271--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>271--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

MAX_DIMENSION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : MAX_DIMENSION Element
Description
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
Namespace (none)
Diagram
MAX_DIMENSION Element
Overview
MAX_DIMENSION 0..3
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES
DIMENSION_TYPE required Restriction of xs:string
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
Attributes
Name Type Use Default Fixed Description
DIMENSION_TYPE Restriction of xs:string required 405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the dimension for which the given maximum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE Restriction of xs:nonNegativeInteger required 405--8/9/10--Max_Breite/Hoehe/Tiefe Version Beta 2.0 Build 3
This element defines the maximum width, height, depth in which the colour feature or the combination of colour feature and finish option is available. The values are given in mm. The values defined here have to correspond with the range of values defined in the element PARAMETERS (path 1).

The values must not exceed the maximum values defined in element /PARAMETERS (path 1).

path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/BASIC_PROFILES 		D nonNegativeInteger
P
M [1:9999]
Source
<xs:element name="MAX_DIMENSION" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[WHD]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSION_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>405--8/9/10--Max_Breite/Hoehe/Tiefe</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

MIN_DIMENSION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element > OPTION_COMBINATION Element : MIN_DIMENSION Element
Description
405--0--NEW Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the minimum dimension in which an option is available.
Namespace (none)
Diagram
MIN_DIMENSION Element
Overview
MIN_DIMENSION 0..3
405--0--NEW Version Beta 2.0 Build 3 von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können This element defines the minimum dimension in which an option is available.
DIMENSION_TYPE required Restriction of xs:string
405--0--NEW Version Beta 2.0 Build 3
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE required Restriction of xs:nonNegativeInteger
405--0--NEW Version Beta 2.0 Build 3
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
Attributes
Name Type Use Default Fixed Description
DIMENSION_TYPE Restriction of xs:string required 405--0--NEW Version Beta 2.0 Build 3
This element defines the dimension for which the given minimum value is valid.

The following values are defined:
W = width
H = height
D = depth 		D string
P [WHD]
M [1:1]
DIMENSION_VALUE Restriction of xs:nonNegativeInteger required 405--0--NEW Version Beta 2.0 Build 3
This element defines the minimum dimension in which an option is available. D nonNegativeInteger
P
M [1:9999]
Source
<xs:element name="MIN_DIMENSION" minOccurs="0" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>405--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
    <xs:documentation>von maxOcc 1 auf maxOcc 3 2011-12-14 damit Breite Höhe Tiefe angegeben werden können </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DIMENSION_TYPE" use="required">
      <xs:annotation>
        <xs:documentation>405--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[WHD]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DIMENSION_VALUE" use="required">
      <xs:annotation>
        <xs:documentation>405--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTION_COMBINATION Element | RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TEST_ID Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > FEATURE_DEFINITION Element > RESTRICTIONS Element > RESTRICTION Element : TEST_ID Element
Description
270--4--Pruef_ID Version Beta 2.0 Build 0
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
TEST_ID Element
Overview
TEST_ID Restriction of xs:boolean
270--4--Pruef_ID Version Beta 2.0 Build 0
The element TEST_ID defines if the feature combinations in a restriction are permitted or not permitted.
0 = combinations not permitted
1 = combinations permitted 		D boolean
P
M
Source
<xs:element name="TEST_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>270--4--Pruef_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
RESTRICTION Element | RESTRICTIONS Element | FEATURE_DEFINITION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_VALUE_CALCULATION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element : BLOCK_VALUE_CALCULATION Element
Description
1000--0--NEW Version Beta 2.0 Build 0This element is used for defining the rules which apply to block calculation and value clearing.
Namespace (none)
Diagram
SET_OF_BLOCK_RULES Element GRADING_TABLE Element BLOCK_SALE_PRICES Element BLOCK_CONDITIONS Element Sequence BLOCK_VALUE_CALCULATION Element
Overview
BLOCK_VALUE_CALCULATION optional
1000--0--NEW Version Beta 2.0 Build 0This element is used for defining the rules which apply to block calculation and value clearing.
Sequence
BLOCK_CONDITIONS optional
420--1--Satzart Version Beta 2.0 Build 6This element contains special conditions for the block calculation. Only if a block corresponds with these conditions it can be applied to a certain commission. Rules defined here apply to the value clearing system (value clearing block) as well as to block calculation (item block).

A block may only be applied to a commission,if all conditions for this special block are fulfilled. A tuple, consisting of the fields ITEM_REF (path 1) and OPERATION_ID (path 2), defines the conditions which refer to a certain block.

Basic condition for the correct application of block conditions is, that a block exists in one of the ranges which have been planned in one commission. In case different ranges have been planned in one commission, the first range which appears in the header data is considered as reference.

The settings and definitions of range- and variation controls apply to blocks in the same way as to “ordinary” items. The price information 0 in the element ITEM_PRICE (path 2) indicates that the value clearing block exists in a certain price group.

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

path 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Sequence
BLOCK_CONDITION 1..∞
420--1--Satzart Version Beta 2.0 Build 6This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.
Sequence
ITEM_REF
420--3--Type_Block Version Beta 2.0 Build 6This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.
TYPE_NO required Restriction of xs:string
420--3--Type_Block Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
420--3--Type_Block Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
420--5--Verknuepfung_ID Version Beta 2.0 Build 6Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.
Sequence
CONDITION_RULE 1..∞
420--0--NEW Version Beta 2.0 Build 6This element is used for defining block conditions.
Sequence
CLEARING_GROUP_REF 1..999
420--0--NEW Version Beta 2.0 Build 6This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
420--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
420--6--Mindest_Wert Version Beta 2.0 Build 6
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
420--7--Mindest_Breite Version Beta 2.0 Build 6
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
BLOCK_SALE_PRICES optional
480--1--Satzart Version Beta 2.0 Build 6This element is used for defining block sale prices.
Sequence
BLOCK_SALE_PRICE 1..∞
480--1--Satzart Version Beta 2.0 Build 6Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Sequence
ITEM_REF
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing an item for which a block sale price has been defined.
TYPE_NO required Restriction of xs:string
480--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
480--100--NEW Version Beta 2.0 Build 6This element is used for defining block sale conditions.
Sequence
VALID_FROM Restriction of xs:date
480--12--Lieferbar_ab Version Beta 2.0 Build 6
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
VALID_UNTIL Restriction of xs:date
480--13--Lieferbar_bis Version Beta 2.0 Build 6
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
OPTION_REF 0..4
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
FEATURE_NO required Restriction of xs:nonNegativeInteger
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
480--14--Preis/Verrechnungspunkt Version Beta 2.0 Build 6
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
GRADING_TABLE optional
421--1--Satzart Version Beta 2.0 Build 6

This element is used for defining grading tables containing the surcharges or the credits which are used in the value clearing system.

A clearing block, which is valid for a certain commission, can be used as reference for the grading table. A reference amount is set up for each data record of this record type, to which the valid clearing block belongs CLEARING_GROUP (path 1). This amount is compared to the given amount of the clearing group. If the reference value corresponds with the given grading range (elements VALUE_FROM (path2) and VALUE_TO (path 2), the data record is applied. In this case the settings in the field TYPE_CREDIT (path 2) and/ or TYPE_DEBIT (path 2) are applied. The calculation is based on the amount of the calculation group, which is defined for type_credit or type_surcharge (element ITEM (path 3)).

Different grading ranges can be defined for one block. A freely defined operation_ID is assigned to each grading range COMPARING_RULES (path 4). Different grading ranges with the same operation_ID may appear within one grading range of a clearing block. In this case the conditions of all grading ranges with their corresponding clearing group have to be fulfilled, so that the value clearing system can be applied to the different items of the commission. Single data records are linked by an AND-operation (COMPARING_RULE).

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

In case several data records of a clearing block are applied in the GRADING_TABLE, the value of the block (ITEM (path 3)), ITEM_PRICE (path 5)) is calculated only one time.

path 1: GLOBAL_DEFINITION
path 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
path 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
CREDIT_SURCHARGE_CLEARING 1..∞
421--1--Satzart Version Beta 2.0 Build 6This element defines value range for a grading table.
Sequence
ITEM_REF
421--0--NEW Version Beta 2.0 Build 6

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
421--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
421--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
421--4--Verknuepfung_ID Version Beta 2.0 Build 6Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.
Sequence
COMPARING_RULE 1..∞
421--0--NEW Version Beta 2.0 Build 6This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
421--5--Verrechnungsgruppe_ID Version Beta 2.0 Build 6
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
421--6--Wert_von Version Beta 2.0 Build 6
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger
421--7--Wert_bis Version Beta 2.0 Build 6

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
421--8--Type_Gutschrift Version Beta 2.0 Build 6
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
421--9--Type_Belastung Version Beta 2.0 Build 6
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
SET_OF_BLOCK_RULES
111--1--Satzart Version Beta 2.0 Build 0The manufacturer specific rules are defined in this element and the in the child elements.
Sequence
EXCHANGE_ID_GROUP 1..∞
117--0--NEW Version Beta 2.0 Build 0This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.
Sequence
EXCHANGE_ID_1_REF
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RULE 1..99
111--0--NEW Version Beta 2.0 Build 0This element defines a manufacturer specific set of rules.
RULE_NO required Restriction of xs:nonNegativeInteger
113--3--Regel_Nr Version Beta 2.0 Build 0
This attribute defines a counter from 1-99 for the manufacturer specific block rules. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
113--5--Regel_Nr_Text Version Beta 2.0 Build 0This element defines the criteria for exchanges in the block processing.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
RULE_SET_TEXT languagetexte60999 Complex Type
111--5--Regelwerk_Text Version Beta 2.0 Build 0This element contains text information and explanations for the set of rules.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="BLOCK_VALUE_CALCULATION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_CONDITIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>420--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>420--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>420--3--Type_Block</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--3--Type_Block</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--3--Type_Block</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CONDITION_RULES">
                    <xs:annotation>
                      <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>420--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                                <xs:annotation>
                                  <xs:documentation>420--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="CLEARING_GROUP_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>420--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:choice>
                                <xs:element name="MINIMUM_VALUE" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                                <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                                  <xs:annotation>
                                    <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                  </xs:annotation>
                                  <xs:simpleType>
                                    <xs:restriction base="xs:nonNegativeInteger">
                                      <xs:minInclusive value="0" />
                                      <xs:maxInclusive value="999999" />
                                    </xs:restriction>
                                  </xs:simpleType>
                                </xs:element>
                              </xs:choice>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="BLOCK_SALE_PRICES" minOccurs="0">
        <xs:annotation>
          <xs:documentation>480--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>480--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>480--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>480--100--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="VALID_FROM">
                          <xs:annotation>
                            <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL">
                          <xs:annotation>
                            <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                          <xs:annotation>
                            <xs:documentation>480--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="FEATURE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>480--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="5" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="PRICE_OR_CALCULATION_POINT">
                          <xs:annotation>
                            <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="GRADING_TABLE" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_REF">
                    <xs:annotation>
                      <xs:documentation>421--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>421--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="15" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>421--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="99" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>421--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLEARING_GROUP_ID">
                                <xs:annotation>
                                  <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_FROM">
                                <xs:annotation>
                                  <xs:documentation>421--6--Wert_von</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALUE_TO">
                                <xs:annotation>
                                  <xs:documentation>421--7--Wert_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:minInclusive value="0" />
                                    <xs:maxInclusive value="999999999" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TYPE_CREDIT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="TYPE_DEBIT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>421--9--Type_Belastung</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="1" />
                                    <xs:maxLength value="15" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SET_OF_BLOCK_RULES">
        <xs:annotation>
          <xs:documentation>111--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="EXCHANGE_ID_1_REF">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>117--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="EXCHANGE_ID_2_REF">
                    <xs:annotation>
                      <xs:documentation>117--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="EXCHANGE_ID_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>117--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RULE" maxOccurs="99">
              <xs:annotation>
                <xs:documentation>111--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="RULE_TEXT" type="languagetexte60999">
                    <xs:annotation>
                      <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="RULE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>113--3--Regel_Nr</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_CONDITIONS Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element : BLOCK_CONDITIONS Element
Description
420--1--Satzart Version Beta 2.0 Build 6This element contains special conditions for the block calculation. Only if a block corresponds with these conditions it can be applied to a certain commission. Rules defined here apply to the value clearing system (value clearing block) as well as to block calculation (item block).

A block may only be applied to a commission,if all conditions for this special block are fulfilled. A tuple, consisting of the fields ITEM_REF (path 1) and OPERATION_ID (path 2), defines the conditions which refer to a certain block.

Basic condition for the correct application of block conditions is, that a block exists in one of the ranges which have been planned in one commission. In case different ranges have been planned in one commission, the first range which appears in the header data is considered as reference.

The settings and definitions of range- and variation controls apply to blocks in the same way as to “ordinary” items. The price information 0 in the element ITEM_PRICE (path 2) indicates that the value clearing block exists in a certain price group.

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

path 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Namespace (none)
Diagram
BLOCK_CONDITION Element Sequence BLOCK_CONDITIONS Element
Overview
BLOCK_CONDITIONS optional
420--1--Satzart Version Beta 2.0 Build 6This element contains special conditions for the block calculation. Only if a block corresponds with these conditions it can be applied to a certain commission. Rules defined here apply to the value clearing system (value clearing block) as well as to block calculation (item block).

A block may only be applied to a commission,if all conditions for this special block are fulfilled. A tuple, consisting of the fields ITEM_REF (path 1) and OPERATION_ID (path 2), defines the conditions which refer to a certain block.

Basic condition for the correct application of block conditions is, that a block exists in one of the ranges which have been planned in one commission. In case different ranges have been planned in one commission, the first range which appears in the header data is considered as reference.

The settings and definitions of range- and variation controls apply to blocks in the same way as to “ordinary” items. The price information 0 in the element ITEM_PRICE (path 2) indicates that the value clearing block exists in a certain price group.

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

path 1: BLOCK_VALUE_CALCULATION/BLOCK_CONDITIONS/ITEM_REF
path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE
Sequence
BLOCK_CONDITION 1..∞
420--1--Satzart Version Beta 2.0 Build 6This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.
Sequence
ITEM_REF
420--3--Type_Block Version Beta 2.0 Build 6This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.
TYPE_NO required Restriction of xs:string
420--3--Type_Block Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
420--3--Type_Block Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
420--5--Verknuepfung_ID Version Beta 2.0 Build 6Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.
Sequence
CONDITION_RULE 1..∞
420--0--NEW Version Beta 2.0 Build 6This element is used for defining block conditions.
Sequence
CLEARING_GROUP_REF 1..999
420--0--NEW Version Beta 2.0 Build 6This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
420--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
420--6--Mindest_Wert Version Beta 2.0 Build 6
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
420--7--Mindest_Breite Version Beta 2.0 Build 6
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="BLOCK_CONDITIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_CONDITION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>420--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>420--3--Type_Block</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--3--Type_Block</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--3--Type_Block</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="CONDITION_RULES">
              <xs:annotation>
                <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>420--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                          <xs:annotation>
                            <xs:documentation>420--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="CLEARING_GROUP_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>420--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:choice>
                          <xs:element name="MINIMUM_VALUE" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                          <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                            <xs:annotation>
                              <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                            </xs:annotation>
                            <xs:simpleType>
                              <xs:restriction base="xs:nonNegativeInteger">
                                <xs:minInclusive value="0" />
                                <xs:maxInclusive value="999999" />
                              </xs:restriction>
                            </xs:simpleType>
                          </xs:element>
                        </xs:choice>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_CONDITION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element : BLOCK_CONDITION Element
Description
420--1--Satzart Version Beta 2.0 Build 6This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.
Namespace (none)
Diagram
CONDITION_RULES Element ITEM_REF Element Sequence BLOCK_CONDITION Element
Overview
BLOCK_CONDITION 1..∞
420--1--Satzart Version Beta 2.0 Build 6This element contains a condition which is used for validating a block, i.e. checking if a block price can be applied to a commission. This element is valid for clearing blocks and block calculation.
Sequence
ITEM_REF
420--3--Type_Block Version Beta 2.0 Build 6This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.
TYPE_NO required Restriction of xs:string
420--3--Type_Block Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
420--3--Type_Block Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
CONDITION_RULES
420--5--Verknuepfung_ID Version Beta 2.0 Build 6Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.
Sequence
CONDITION_RULE 1..∞
420--0--NEW Version Beta 2.0 Build 6This element is used for defining block conditions.
Sequence
CLEARING_GROUP_REF 1..999
420--0--NEW Version Beta 2.0 Build 6This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
420--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
420--6--Mindest_Wert Version Beta 2.0 Build 6
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
420--7--Mindest_Breite Version Beta 2.0 Build 6
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="BLOCK_CONDITION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>420--3--Type_Block</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--3--Type_Block</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--3--Type_Block</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="CONDITION_RULES">
        <xs:annotation>
          <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>420--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
                    <xs:annotation>
                      <xs:documentation>420--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="CLEARING_GROUP_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>420--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:choice>
                    <xs:element name="MINIMUM_VALUE" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                    <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                      <xs:annotation>
                        <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                      </xs:annotation>
                      <xs:simpleType>
                        <xs:restriction base="xs:nonNegativeInteger">
                          <xs:minInclusive value="0" />
                          <xs:maxInclusive value="999999" />
                        </xs:restriction>
                      </xs:simpleType>
                    </xs:element>
                  </xs:choice>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element : ITEM_REF Element
Description
420--3--Type_Block Version Beta 2.0 Build 6This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF
420--3--Type_Block Version Beta 2.0 Build 6This element defines the type of clearing block. A clearing block is unambiguously defined by type and series. A clearing block is defined by the flag V = value clearing block.
TYPE_NO required Restriction of xs:string
420--3--Type_Block Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
420--3--Type_Block Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required 420--3--Type_Block Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required 420--3--Type_Block Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--3--Type_Block</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--3--Type_Block</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--3--Type_Block</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CONDITION_RULES Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element : CONDITION_RULES Element
Description
420--5--Verknuepfung_ID Version Beta 2.0 Build 6Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.
Namespace (none)
Diagram
CONDITION_RULE Element Sequence CONDITION_RULES Element
Overview
CONDITION_RULES
420--5--Verknuepfung_ID Version Beta 2.0 Build 6Block conditions which are defined within the same set of CONDITION_RULES are linked with an AND argument. The different elements of CONDITION_RULES are linked with an OR argument.
Sequence
CONDITION_RULE 1..∞
420--0--NEW Version Beta 2.0 Build 6This element is used for defining block conditions.
Sequence
CLEARING_GROUP_REF 1..999
420--0--NEW Version Beta 2.0 Build 6This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
420--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
420--6--Mindest_Wert Version Beta 2.0 Build 6
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
420--7--Mindest_Breite Version Beta 2.0 Build 6
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="CONDITION_RULES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--5--Verknuepfung_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CONDITION_RULE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>420--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
              <xs:annotation>
                <xs:documentation>420--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="CLEARING_GROUP_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>420--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:choice>
              <xs:element name="MINIMUM_VALUE" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>420--6--Mindest_Wert</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="999999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
              <xs:element name="MINIMUM_WIDTH" minOccurs="0">
                <xs:annotation>
                  <xs:documentation>420--7--Mindest_Breite</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:nonNegativeInteger">
                    <xs:minInclusive value="0" />
                    <xs:maxInclusive value="999999" />
                  </xs:restriction>
                </xs:simpleType>
              </xs:element>
            </xs:choice>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CONDITION_RULE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element : CONDITION_RULE Element
Description
420--0--NEW Version Beta 2.0 Build 6This element is used for defining block conditions.
Namespace (none)
Diagram
MINIMUM_WIDTH Element MINIMUM_VALUE Element Choice CLEARING_GROUP_REF Element Sequence CONDITION_RULE Element
Overview
CONDITION_RULE 1..∞
420--0--NEW Version Beta 2.0 Build 6This element is used for defining block conditions.
Sequence
CLEARING_GROUP_REF 1..999
420--0--NEW Version Beta 2.0 Build 6This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
420--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Choice
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
420--6--Mindest_Wert Version Beta 2.0 Build 6
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
420--7--Mindest_Breite Version Beta 2.0 Build 6
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="CONDITION_RULE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP_REF" maxOccurs="999">
        <xs:annotation>
          <xs:documentation>420--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="CLEARING_GROUP_NO" use="required">
            <xs:annotation>
              <xs:documentation>420--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:choice>
        <xs:element name="MINIMUM_VALUE" minOccurs="0">
          <xs:annotation>
            <xs:documentation>420--6--Mindest_Wert</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:nonNegativeInteger">
              <xs:minInclusive value="0" />
              <xs:maxInclusive value="999999999" />
            </xs:restriction>
          </xs:simpleType>
        </xs:element>
        <xs:element name="MINIMUM_WIDTH" minOccurs="0">
          <xs:annotation>
            <xs:documentation>420--7--Mindest_Breite</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:nonNegativeInteger">
              <xs:minInclusive value="0" />
              <xs:maxInclusive value="999999" />
            </xs:restriction>
          </xs:simpleType>
        </xs:element>
      </xs:choice>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : CLEARING_GROUP_REF Element
Description
420--0--NEW Version Beta 2.0 Build 6This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
Namespace (none)
Diagram
CLEARING_GROUP_REF Element
Overview
CLEARING_GROUP_REF 1..999
420--0--NEW Version Beta 2.0 Build 6This element references that clearing group for which the conditions had been defined. In case all conditions are fulfilled for the clearing block (SERIES_NO, TYPE_NO) this can be applied to the commission.
It is permitted to define a minimum value (MINIMUM_VALUE) or a minimum width (MINIMUM_WIDTH).
The values (amount or measurement) of all commission items with the same exchange_ID in a clearing group are summarized and compared with values in the elements MINIMUM_VALUE or MINIMUM_WIDTH. If the sum of all commission items exceeds these given minimum values, that special criterion of block calculation is fulfilled.
CLEARING_GROUP_NO required Restriction of xs:nonNegativeInteger
420--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
CLEARING_GROUP_NO Restriction of xs:nonNegativeInteger required 420--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a clearing group. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="CLEARING_GROUP_REF" maxOccurs="999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="CLEARING_GROUP_NO" use="required">
      <xs:annotation>
        <xs:documentation>420--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

MINIMUM_VALUE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : MINIMUM_VALUE Element
Description
420--6--Mindest_Wert Version Beta 2.0 Build 6
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MINIMUM_VALUE Element
Overview
MINIMUM_VALUE optional Restriction of xs:nonNegativeInteger
420--6--Mindest_Wert Version Beta 2.0 Build 6
This element defines a minimum value. The amounts of the single items, which are assigned to one clearing group by their exchange_IDs, are summarized. The total amount has to exceed the defined minimum value, so that this block condition is fulfilled.
The element MINIMUM_VALUE refers to the clearing group, which is defined in the element CONDITION_RULE.
If the MINIMUM_VALUE shall apply to a single item only, the data acquisition of the exchange_IDs has to be very detailed and refined.
The given minimum price is total purchase_price before the application of purchase conditions/ discounts.

Either the element MINIMUM_VALUE or the element MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="MINIMUM_VALUE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--6--Mindest_Wert</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

MINIMUM_WIDTH Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_CONDITIONS Element > BLOCK_CONDITION Element > CONDITION_RULES Element > CONDITION_RULE Element : MINIMUM_WIDTH Element
Description
420--7--Mindest_Breite Version Beta 2.0 Build 6
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
MINIMUM_WIDTH Element
Overview
MINIMUM_WIDTH optional Restriction of xs:nonNegativeInteger
420--7--Mindest_Breite Version Beta 2.0 Build 6
This element defines a minimum width. The different widths of the single items, which are assigned to one clearing_group via their exchange_IDs, are summarized. The total width has to exceed the defined minimum_width, so that this block condition is fulfilled.
The element MINIMUM_WIDTH refers to the clearing group, which is defined in the element CONDITION_RULE.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in.
Only those items are considered here for which the price calculation is dependent on dimensions. The width of an item is the reference dimension for the element MINIMUM_WIDTH.
The MINIMUM_WIDTH is defined as the sum of the width of all single items, belonging to one clearing group. If the minimum_width shall apply to a single item only, the data acquisition of the exchange_IDs and clearing_groups has to be very detailed and refined.
The more detailed the data acquisition of exchange_IDs is set up, the more complicated the handling of block calculation will be. Therefore, the definition of exchange_IDs and clearing_groups requires careful planning.
Either the field MINIMUM_VALUE or the field MINIMUM_WIDTH has to be filled in. 		D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="MINIMUM_WIDTH" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>420--7--Mindest_Breite</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CONDITION_RULE Element | CONDITION_RULES Element | BLOCK_CONDITION Element | BLOCK_CONDITIONS Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_SALE_PRICES Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element : BLOCK_SALE_PRICES Element
Description
480--1--Satzart Version Beta 2.0 Build 6This element is used for defining block sale prices.
Namespace (none)
Diagram
BLOCK_SALE_PRICE Element Sequence BLOCK_SALE_PRICES Element
Overview
BLOCK_SALE_PRICES optional
480--1--Satzart Version Beta 2.0 Build 6This element is used for defining block sale prices.
Sequence
BLOCK_SALE_PRICE 1..∞
480--1--Satzart Version Beta 2.0 Build 6Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Sequence
ITEM_REF
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing an item for which a block sale price has been defined.
TYPE_NO required Restriction of xs:string
480--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
480--100--NEW Version Beta 2.0 Build 6This element is used for defining block sale conditions.
Sequence
VALID_FROM Restriction of xs:date
480--12--Lieferbar_ab Version Beta 2.0 Build 6
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
VALID_UNTIL Restriction of xs:date
480--13--Lieferbar_bis Version Beta 2.0 Build 6
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
OPTION_REF 0..4
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
FEATURE_NO required Restriction of xs:nonNegativeInteger
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
480--14--Preis/Verrechnungspunkt Version Beta 2.0 Build 6
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="BLOCK_SALE_PRICES" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>480--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>480--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>480--100--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="VALID_FROM">
                    <xs:annotation>
                      <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL">
                    <xs:annotation>
                      <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
                    <xs:annotation>
                      <xs:documentation>480--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>480--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="5" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRICE_OR_CALCULATION_POINT">
                    <xs:annotation>
                      <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

BLOCK_SALE_PRICE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element : BLOCK_SALE_PRICE Element
Description
480--1--Satzart Version Beta 2.0 Build 6Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Namespace (none)
Diagram
VARIATION_PRICE_DEFINITION Element ITEM_REF Element Sequence BLOCK_SALE_PRICE Element
Overview
BLOCK_SALE_PRICE 1..∞
480--1--Satzart Version Beta 2.0 Build 6Block sale prices, which are only valid for various limited periods, are defined in this element. This element may be used only, if certain block prices are valid for more than one limited period within one catalogue period. Blocks, which are only available within one coherent period, are defined by the elements VALID_FROM (path 1) and /VALID_UNTIL (path 1).

A price defined in this element has precedence over the price defined in the general price field.
The variation combinations defined in this element have priority over the item specific control procedures.

Overlapping dates in the defined periods of block sale prices are not permitted.
Information provided in this element does not override information from other elements but abrogates it temporarily.
The combination of those pieces of information which are concerned, is defined in this element. All other combinations are still valid!

The validity dates of a block defined in this element have to differ from those defined in the elements VALID_FROM (path 1) and /VALID_UNTIL.
A block sale price is defined for a certain range within a certain period of time. The block sale price entered in this element must not override the “normal” block price in this pricegroup because other ranges may refer to that price, too.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM
Sequence
ITEM_REF
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing an item for which a block sale price has been defined.
TYPE_NO required Restriction of xs:string
480--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
VARIATION_PRICE_DEFINITION 1..∞
480--100--NEW Version Beta 2.0 Build 6This element is used for defining block sale conditions.
Sequence
VALID_FROM Restriction of xs:date
480--12--Lieferbar_ab Version Beta 2.0 Build 6
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
VALID_UNTIL Restriction of xs:date
480--13--Lieferbar_bis Version Beta 2.0 Build 6
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
OPTION_REF 0..4
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
FEATURE_NO required Restriction of xs:nonNegativeInteger
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
480--14--Preis/Verrechnungspunkt Version Beta 2.0 Build 6
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="BLOCK_SALE_PRICE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>480--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>480--100--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="VALID_FROM">
              <xs:annotation>
                <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL">
              <xs:annotation>
                <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
              <xs:annotation>
                <xs:documentation>480--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>480--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="5" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRICE_OR_CALCULATION_POINT">
              <xs:annotation>
                <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element : ITEM_REF Element
Description
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing an item for which a block sale price has been defined.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing an item for which a block sale price has been defined.
TYPE_NO required Restriction of xs:string
480--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required 480--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required 480--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

VARIATION_PRICE_DEFINITION Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element : VARIATION_PRICE_DEFINITION Element
Description
480--100--NEW Version Beta 2.0 Build 6This element is used for defining block sale conditions.
Namespace (none)
Diagram
PRICE_OR_CALCULATION_POINT Element OPTION_REF Element VALID_UNTIL Element VALID_FROM Element Sequence VARIATION_PRICE_DEFINITION Element
Overview
VARIATION_PRICE_DEFINITION 1..∞
480--100--NEW Version Beta 2.0 Build 6This element is used for defining block sale conditions.
Sequence
VALID_FROM Restriction of xs:date
480--12--Lieferbar_ab Version Beta 2.0 Build 6
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
VALID_UNTIL Restriction of xs:date
480--13--Lieferbar_bis Version Beta 2.0 Build 6
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
OPTION_REF 0..4
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
FEATURE_NO required Restriction of xs:nonNegativeInteger
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a option. D string
P
M [1:5]
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
480--14--Preis/Verrechnungspunkt Version Beta 2.0 Build 6
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="VARIATION_PRICE_DEFINITION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--100--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="VALID_FROM">
        <xs:annotation>
          <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL">
        <xs:annotation>
          <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4">
        <xs:annotation>
          <xs:documentation>480--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>480--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="5" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRICE_OR_CALCULATION_POINT">
        <xs:annotation>
          <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

VALID_FROM Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : VALID_FROM Element
Description
480--12--Lieferbar_ab Version Beta 2.0 Build 6
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM Restriction of xs:date
480--12--Lieferbar_ab Version Beta 2.0 Build 6
This element defines the date from which the block sale price is valid. Fields named VALID_FROM must not contain a date earlier than the date of the catalogue's validity. Dates defined in the element VARIATION_PRICE_DEFINITION must be different from the dates entered in the element ITEM. D date
P
M
Source
<xs:element name="VALID_FROM" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--12--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

VALID_UNTIL Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : VALID_UNTIL Element
Description
480--13--Lieferbar_bis Version Beta 2.0 Build 6
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL Restriction of xs:date
480--13--Lieferbar_bis Version Beta 2.0 Build 6
This element indicates the latest date of validity for the given block sale price. Fields named VALID_UNTIL must not contain a date that is later than the actual catalogue date + 10 years. If there is no restriction of availability this field has to be left blank. Dates defined in the element BLOCK_SALE_PRICE must be different from the dates entered in the element ITEM. D date
P
M
Source
<xs:element name="VALID_UNTIL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--13--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

OPTION_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : OPTION_REF Element
Description
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
Namespace (none)
Diagram
OPTION_REF Element
Overview
OPTION_REF 0..4
480--0--NEW Version Beta 2.0 Build 6This element is used for referencing the options to which the block sale price applies.

Only the first OPTION_REF is applicable for programmes. If different feature types are used, duplicate elements which only differ in the sequence order of the features are not permitted.
FEATURE_NO required Restriction of xs:nonNegativeInteger
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY required Restriction of xs:string
480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a option. D string
P
M [1:5]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required 480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a feature. D nonNegativeInteger
P
M [0:999]
OPTION_KEY Restriction of xs:string required 480--0--NEW Version Beta 2.0 Build 6
This attribute is used for referencing a option. D string
P
M [1:5]
Source
<xs:element name="OPTION_REF" minOccurs="0" maxOccurs="4" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>480--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="5" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

PRICE_OR_CALCULATION_POINT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > BLOCK_SALE_PRICES Element > BLOCK_SALE_PRICE Element > VARIATION_PRICE_DEFINITION Element : PRICE_OR_CALCULATION_POINT Element
Description
480--14--Preis/Verrechnungspunkt Version Beta 2.0 Build 6
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
PRICE_OR_CALCULATION_POINT Element
Overview
PRICE_OR_CALCULATION_POINT Restriction of xs:nonNegativeInteger
480--14--Preis/Verrechnungspunkt Version Beta 2.0 Build 6
This element is used for price information. According to the price groups (price fields), prices are filled in into this field. Prices have to be defined in the smallest unit of a currency (e.g. instead of 300,00 [€], 30000 [Cent]).Ident numbers are filled in without decimal places, calculation points have to be filled in with two decimal places (without the decimal point itself). D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="PRICE_OR_CALCULATION_POINT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>480--14--Preis/Verrechnungspunkt</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
VARIATION_PRICE_DEFINITION Element | BLOCK_SALE_PRICE Element | BLOCK_SALE_PRICES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

GRADING_TABLE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element : GRADING_TABLE Element
Description
421--1--Satzart Version Beta 2.0 Build 6

This element is used for defining grading tables containing the surcharges or the credits which are used in the value clearing system.

A clearing block, which is valid for a certain commission, can be used as reference for the grading table. A reference amount is set up for each data record of this record type, to which the valid clearing block belongs CLEARING_GROUP (path 1). This amount is compared to the given amount of the clearing group. If the reference value corresponds with the given grading range (elements VALUE_FROM (path2) and VALUE_TO (path 2), the data record is applied. In this case the settings in the field TYPE_CREDIT (path 2) and/ or TYPE_DEBIT (path 2) are applied. The calculation is based on the amount of the calculation group, which is defined for type_credit or type_surcharge (element ITEM (path 3)).

Different grading ranges can be defined for one block. A freely defined operation_ID is assigned to each grading range COMPARING_RULES (path 4). Different grading ranges with the same operation_ID may appear within one grading range of a clearing block. In this case the conditions of all grading ranges with their corresponding clearing group have to be fulfilled, so that the value clearing system can be applied to the different items of the commission. Single data records are linked by an AND-operation (COMPARING_RULE).

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

In case several data records of a clearing block are applied in the GRADING_TABLE, the value of the block (ITEM (path 3)), ITEM_PRICE (path 5)) is calculated only one time.

path 1: GLOBAL_DEFINITION
path 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
path 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Namespace (none)
Diagram
CREDIT_SURCHARGE_CLEARING Element Sequence GRADING_TABLE Element
Overview
GRADING_TABLE optional
421--1--Satzart Version Beta 2.0 Build 6

This element is used for defining grading tables containing the surcharges or the credits which are used in the value clearing system.

A clearing block, which is valid for a certain commission, can be used as reference for the grading table. A reference amount is set up for each data record of this record type, to which the valid clearing block belongs CLEARING_GROUP (path 1). This amount is compared to the given amount of the clearing group. If the reference value corresponds with the given grading range (elements VALUE_FROM (path2) and VALUE_TO (path 2), the data record is applied. In this case the settings in the field TYPE_CREDIT (path 2) and/ or TYPE_DEBIT (path 2) are applied. The calculation is based on the amount of the calculation group, which is defined for type_credit or type_surcharge (element ITEM (path 3)).

Different grading ranges can be defined for one block. A freely defined operation_ID is assigned to each grading range COMPARING_RULES (path 4). Different grading ranges with the same operation_ID may appear within one grading range of a clearing block. In this case the conditions of all grading ranges with their corresponding clearing group have to be fulfilled, so that the value clearing system can be applied to the different items of the commission. Single data records are linked by an AND-operation (COMPARING_RULE).

In case several conditions are defined for one block, they are defined as OR-operations, i.e. at least one of the conditions has to be fulfilled, so that the block can be applied to value clearing or block calculation.

In case several data records of a clearing block are applied in the GRADING_TABLE, the value of the block (ITEM (path 3)), ITEM_PRICE (path 5)) is calculated only one time.

path 1: GLOBAL_DEFINITION
path 2: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES/COMPARING_RULE
path 3: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
path 4: BLOCK_VALUE_CALCULATION/GRADING_TABLE/CREDIT_SURCHARGE_CLEARING/COMPARING_RULES
path 5: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE

Sequence
CREDIT_SURCHARGE_CLEARING 1..∞
421--1--Satzart Version Beta 2.0 Build 6This element defines value range for a grading table.
Sequence
ITEM_REF
421--0--NEW Version Beta 2.0 Build 6

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
421--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
421--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
421--4--Verknuepfung_ID Version Beta 2.0 Build 6Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.
Sequence
COMPARING_RULE 1..∞
421--0--NEW Version Beta 2.0 Build 6This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
421--5--Verrechnungsgruppe_ID Version Beta 2.0 Build 6
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
421--6--Wert_von Version Beta 2.0 Build 6
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger
421--7--Wert_bis Version Beta 2.0 Build 6

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
421--8--Type_Gutschrift Version Beta 2.0 Build 6
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
421--9--Type_Belastung Version Beta 2.0 Build 6
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="GRADING_TABLE" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_REF">
              <xs:annotation>
                <xs:documentation>421--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>421--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="15" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>421--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="99" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>421--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLEARING_GROUP_ID">
                          <xs:annotation>
                            <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_FROM">
                          <xs:annotation>
                            <xs:documentation>421--6--Wert_von</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALUE_TO">
                          <xs:annotation>
                            <xs:documentation>421--7--Wert_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999999999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TYPE_CREDIT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="TYPE_DEBIT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>421--9--Type_Belastung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="1" />
                              <xs:maxLength value="15" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CREDIT_SURCHARGE_CLEARING Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element : CREDIT_SURCHARGE_CLEARING Element
Description
421--1--Satzart Version Beta 2.0 Build 6This element defines value range for a grading table.
Namespace (none)
Diagram
COMPARING_RULES Element ITEM_REF Element Sequence CREDIT_SURCHARGE_CLEARING Element
Overview
CREDIT_SURCHARGE_CLEARING 1..∞
421--1--Satzart Version Beta 2.0 Build 6This element defines value range for a grading table.
Sequence
ITEM_REF
421--0--NEW Version Beta 2.0 Build 6

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
421--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
421--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
COMPARING_RULES 1..∞
421--4--Verknuepfung_ID Version Beta 2.0 Build 6Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.
Sequence
COMPARING_RULE 1..∞
421--0--NEW Version Beta 2.0 Build 6This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
421--5--Verrechnungsgruppe_ID Version Beta 2.0 Build 6
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
421--6--Wert_von Version Beta 2.0 Build 6
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger
421--7--Wert_bis Version Beta 2.0 Build 6

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
421--8--Type_Gutschrift Version Beta 2.0 Build 6
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
421--9--Type_Belastung Version Beta 2.0 Build 6
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="CREDIT_SURCHARGE_CLEARING" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_REF">
        <xs:annotation>
          <xs:documentation>421--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>421--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="15" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>421--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="COMPARING_RULES" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>421--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLEARING_GROUP_ID">
                    <xs:annotation>
                      <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_FROM">
                    <xs:annotation>
                      <xs:documentation>421--6--Wert_von</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALUE_TO">
                    <xs:annotation>
                      <xs:documentation>421--7--Wert_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999999999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TYPE_CREDIT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="TYPE_DEBIT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>421--9--Type_Belastung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="1" />
                        <xs:maxLength value="15" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

ITEM_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element : ITEM_REF Element
Description
421--0--NEW Version Beta 2.0 Build 6

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF
421--0--NEW Version Beta 2.0 Build 6

This element is a single item of a clearing block. A clearing block is unambiguously defined by type and series. A clearing block is marked with the flag „V“ = clearing block in ITEM (path 1).
The validity of a clearing block can be limited for a certain period of time. In this case the corresponding dates have to be entered into the fields VALID_FROM/VALID_UNTIL of the element ITEM (path 1). If time limitations are applied, separate clearing blocks have to be defined for each different period.
Data from the clearing positions (TYPE_CREDIT and TYPE_DEBIT) are not taken into consideration.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS

TYPE_NO required Restriction of xs:string
421--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO required Restriction of xs:nonNegativeInteger
421--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required 421--0--NEW Version Beta 2.0 Build 6
This element is used for defining an item short code. (e.g. U60). D string
P
M [1:15]
SERIE_NO Restriction of xs:nonNegativeInteger required 421--0--NEW Version Beta 2.0 Build 6
This attribute is used for defining a serial No. of the referenced series. D nonNegativeInteger
P
M [0:99]
Source
<xs:element name="ITEM_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>421--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="15" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>421--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

COMPARING_RULES Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element : COMPARING_RULES Element
Description
421--4--Verknuepfung_ID Version Beta 2.0 Build 6Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.
Namespace (none)
Diagram
COMPARING_RULE Element Sequence COMPARING_RULES Element
Overview
COMPARING_RULES 1..∞
421--4--Verknuepfung_ID Version Beta 2.0 Build 6Different grading ranges (VALUE_FROM - VALUE_TO) can be defined for one clearing block. Different ranges of values with the same elements in COMPARING_RULE are linked with an AND-argument. The different elements COMPARING_RULES are linked with an OR-argument.
In case no credit/ surcharge shall be applied to one range the fields TYPE_CREDIT and TYPE_DEBIT have to be omitted.
Sequence
COMPARING_RULE 1..∞
421--0--NEW Version Beta 2.0 Build 6This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
421--5--Verrechnungsgruppe_ID Version Beta 2.0 Build 6
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
421--6--Wert_von Version Beta 2.0 Build 6
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger
421--7--Wert_bis Version Beta 2.0 Build 6

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
421--8--Type_Gutschrift Version Beta 2.0 Build 6
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
421--9--Type_Belastung Version Beta 2.0 Build 6
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="COMPARING_RULES" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--4--Verknuepfung_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="COMPARING_RULE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>421--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLEARING_GROUP_ID">
              <xs:annotation>
                <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_FROM">
              <xs:annotation>
                <xs:documentation>421--6--Wert_von</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALUE_TO">
              <xs:annotation>
                <xs:documentation>421--7--Wert_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TYPE_CREDIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="TYPE_DEBIT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>421--9--Type_Belastung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="15" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

COMPARING_RULE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element : COMPARING_RULE Element
Description
421--0--NEW Version Beta 2.0 Build 6This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Namespace (none)
Diagram
TYPE_DEBIT Element TYPE_CREDIT Element VALUE_TO Element VALUE_FROM Element CLEARING_GROUP_ID Element Sequence COMPARING_RULE Element
Overview
COMPARING_RULE 1..∞
421--0--NEW Version Beta 2.0 Build 6This element contains the total number of conditions defined for a COMPARING_RULE, which can only be applied when all of them are fulfilled.
Sequence
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
421--5--Verrechnungsgruppe_ID Version Beta 2.0 Build 6
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
VALUE_FROM Restriction of xs:nonNegativeInteger
421--6--Wert_von Version Beta 2.0 Build 6
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
VALUE_TO Restriction of xs:nonNegativeInteger
421--7--Wert_bis Version Beta 2.0 Build 6

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
TYPE_CREDIT optional Restriction of xs:string
421--8--Type_Gutschrift Version Beta 2.0 Build 6
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
TYPE_DEBIT optional Restriction of xs:string
421--9--Type_Belastung Version Beta 2.0 Build 6
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="COMPARING_RULE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLEARING_GROUP_ID">
        <xs:annotation>
          <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_FROM">
        <xs:annotation>
          <xs:documentation>421--6--Wert_von</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALUE_TO">
        <xs:annotation>
          <xs:documentation>421--7--Wert_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TYPE_CREDIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="TYPE_DEBIT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>421--9--Type_Belastung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="15" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

CLEARING_GROUP_ID Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : CLEARING_GROUP_ID Element
Description
421--5--Verrechnungsgruppe_ID Version Beta 2.0 Build 6
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
CLEARING_GROUP_ID Element
Overview
CLEARING_GROUP_ID Restriction of xs:nonNegativeInteger
421--5--Verrechnungsgruppe_ID Version Beta 2.0 Build 6
This element identifies a clearing group. The sum of all items in one commission is assigned to this clearing group. If the defined reference value of the clearing group is within this range of values, which is defined be the elements VALUE_FROM and VALUE_TO, the clearing of credits (TYPE_CREDIT) or surcharge (TYPE_DEBIT) can be applied. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="CLEARING_GROUP_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--5--Verrechnungsgruppe_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

VALUE_FROM Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : VALUE_FROM Element
Description
421--6--Wert_von Version Beta 2.0 Build 6
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
VALUE_FROM Element
Overview
VALUE_FROM Restriction of xs:nonNegativeInteger
421--6--Wert_von Version Beta 2.0 Build 6
A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent. 		D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="VALUE_FROM" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--6--Wert_von</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

VALUE_TO Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : VALUE_TO Element
Description
421--7--Wert_bis Version Beta 2.0 Build 6

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
VALUE_TO Element
Overview
VALUE_TO Restriction of xs:nonNegativeInteger
421--7--Wert_bis Version Beta 2.0 Build 6

A range of values within one grading table is defined by the elements VALUE_FROM and VALUE_TO. If the defined reference value of the clearing_group is within this range of values, the clearing of credits (TYPE_CREDIT) or surcharges (TYPE_DEBIT ) can be applied.
Omissions are not permitted in the transition of the fields VALUE_FROM and VALUE_TO. Otherwise discounts are not applied to the omitted values.
Values in the fields VALUE_FROM/ VALUE_TO have to be given as exact figures in Euro Cent.

In case the value in the field VALUE_TO shall be unlimited the highest possible numerical value (999999999) has to be filled in as substitute.

 D nonNegativeInteger
P
M [0:999999999]
Source
<xs:element name="VALUE_TO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--7--Wert_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TYPE_CREDIT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : TYPE_CREDIT Element
Description
421--8--Type_Gutschrift Version Beta 2.0 Build 6
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
Namespace (none)
Type
Restriction of xs:string
Diagram
TYPE_CREDIT Element
Overview
TYPE_CREDIT optional Restriction of xs:string
421--8--Type_Gutschrift Version Beta 2.0 Build 6
This element identifies a clearing position as credit. The type of credit is defined in the element ITEM (path 1)as clearing position (ITEM_IDENTIFICATION (path1) = P). The series of credit positions is equal to the series of clearing positions in the corresponding data record.
In the element CALC_GROUP_REF (path 1) the credit is assigned to a certain calculation group. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The credit is applied to the total amount of those commission items which belong to the same calculation group as the credit type.
The credit value is defined as a negative numerical value in the element ITEM_PRICE (path 2).
Both elements, the credit type (TYPE_CREDIT) and the debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D string
P
M [1:15]
Source
<xs:element name="TYPE_CREDIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--8--Type_Gutschrift</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

TYPE_DEBIT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > GRADING_TABLE Element > CREDIT_SURCHARGE_CLEARING Element > COMPARING_RULES Element > COMPARING_RULE Element : TYPE_DEBIT Element
Description
421--9--Type_Belastung Version Beta 2.0 Build 6
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Namespace (none)
Type
Restriction of xs:string
Diagram
TYPE_DEBIT Element
Overview
TYPE_DEBIT optional Restriction of xs:string
421--9--Type_Belastung Version Beta 2.0 Build 6
The type of debit is defined in the element ITEM (path 1) as clearing position (ITEM_IDENTIFICATION (path 1) = P). The series of debit positions is equal to the series of clearing positions in the corresponding clearing block.
In the element CALC_GROUP_REF (path 1) the debit type is assigned to a certain calculation group. The debit is applied to the total amount of those commission items, which belong to the same calculation group as the credit type. In this way, the credit is subject to the general rules of calculation which are applied to this calculation group. The debit is applied to the total amount of those commission items which belong to the same calculation group as the debit type
The debit value is defined as a positive numerical value in the element ITEM_PRICE (path 2).
Both elements, credit type (TYPE_CREDIT) and debit type (TYPE_DEBIT) are permitted, and may be assigned to different calculation groups.
Within one grading range credit and debit type are always neutral (PRICE_CLASS (path 1) = 1)
Credit and debit type may have only one price in price group 1.
Different adaptations of the value clearing system are used in the different planning software applications. Therefore, either differentiated clearing positions or the clearing block as one position may appear in the order.
Debit and credit types are not part of the general catalogue data. They are only delivered with special block data files.

Path 1: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/PRICE_FEATURE_GROUP_BASE_PRICE 		D nonNegativeInteger
P
M [1:250]
Source
<xs:element name="TYPE_DEBIT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>421--9--Type_Belastung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 6</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="15" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
COMPARING_RULE Element | COMPARING_RULES Element | CREDIT_SURCHARGE_CLEARING Element | GRADING_TABLE Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

SET_OF_BLOCK_RULES Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element : SET_OF_BLOCK_RULES Element
Description
111--1--Satzart Version Beta 2.0 Build 0The manufacturer specific rules are defined in this element and the in the child elements.
Namespace (none)
Diagram
LANGUAGE Element Sequence RULE_SET_TEXT Element RULE Element EXCHANGE_ID_GROUP Element Sequence SET_OF_BLOCK_RULES Element
Overview
SET_OF_BLOCK_RULES
111--1--Satzart Version Beta 2.0 Build 0The manufacturer specific rules are defined in this element and the in the child elements.
Sequence
EXCHANGE_ID_GROUP 1..∞
117--0--NEW Version Beta 2.0 Build 0This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.
Sequence
EXCHANGE_ID_1_REF
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
RULE 1..99
111--0--NEW Version Beta 2.0 Build 0This element defines a manufacturer specific set of rules.
RULE_NO required Restriction of xs:nonNegativeInteger
113--3--Regel_Nr Version Beta 2.0 Build 0
This attribute defines a counter from 1-99 for the manufacturer specific block rules. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
113--5--Regel_Nr_Text Version Beta 2.0 Build 0This element defines the criteria for exchanges in the block processing.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
RULE_SET_TEXT languagetexte60999 Complex Type
111--5--Regelwerk_Text Version Beta 2.0 Build 0This element contains text information and explanations for the set of rules.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="SET_OF_BLOCK_RULES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="EXCHANGE_ID_1_REF">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>117--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="EXCHANGE_ID_2_REF">
              <xs:annotation>
                <xs:documentation>117--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="EXCHANGE_ID_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>117--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RULE" maxOccurs="99">
        <xs:annotation>
          <xs:documentation>111--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="RULE_TEXT" type="languagetexte60999">
              <xs:annotation>
                <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="RULE_NO" use="required">
            <xs:annotation>
              <xs:documentation>113--3--Regel_Nr</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="99" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="RULE_SET_TEXT" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_GROUP Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : EXCHANGE_ID_GROUP Element
Description
117--0--NEW Version Beta 2.0 Build 0This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.
Namespace (none)
Diagram
EXCHANGE_ID_2_REF Element EXCHANGE_ID_1_REF Element Sequence EXCHANGE_ID_GROUP Element
Overview
EXCHANGE_ID_GROUP 1..∞
117--0--NEW Version Beta 2.0 Build 0This element is used for defining the exchange groups. If exchange-ID 1 (EXCHANGE_ID_1_REF) may be exchanged with exchange-ID 2 (EXCHANGE_ID_2_REF) and vice versa this has to be defined explicitly.
If items with the same exchange_ID can be exchanged 1 by 1 a special data record for this exchange has to be defined.
Sequence
EXCHANGE_ID_1_REF
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
EXCHANGE_ID_2_REF
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Source
<xs:element name="EXCHANGE_ID_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="EXCHANGE_ID_1_REF">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>117--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="EXCHANGE_ID_2_REF">
        <xs:annotation>
          <xs:documentation>117--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="EXCHANGE_ID_NO" use="required">
            <xs:annotation>
              <xs:documentation>117--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_1_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > EXCHANGE_ID_GROUP Element : EXCHANGE_ID_1_REF Element
Description
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
Namespace (none)
Diagram
EXCHANGE_ID_1_REF Element
Overview
EXCHANGE_ID_1_REF
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group which is defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attributes
Name Type Use Default Fixed Description
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required 117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Source
<xs:element name="EXCHANGE_ID_1_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>117--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
EXCHANGE_ID_GROUP Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

EXCHANGE_ID_2_REF Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > EXCHANGE_ID_GROUP Element : EXCHANGE_ID_2_REF Element
Description
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
Namespace (none)
Diagram
EXCHANGE_ID_2_REF Element
Overview
EXCHANGE_ID_2_REF
117--0--NEW Version Beta 2.0 Build 0The exchange-ID refers to an exchange group defined in the element PRICE_DEFINITION/SET_OF_EXCHANGE_IDS of the main catalogue. The exchange-ID references the items of a commission or planning.
EXCHANGE_ID_NO required Restriction of xs:nonNegativeInteger
117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Attributes
Name Type Use Default Fixed Description
EXCHANGE_ID_NO Restriction of xs:nonNegativeInteger required 117--0--NEW Version Beta 2.0 Build 0
The element E_ID (Exchange-ID) is defined as a key for the exchange groups. The values for the keys can be freely chosen from the range of figures 1-89.
The following special exchange-IDs are predefined:
0 = this item must not be exchanged
98 = this item may only be exchanged with itself.
99 = this item may be exchanged with all other exchange_IDs.
All utilized exchange_IDs have to be defined. If one of the special exchange-IDs is used it has to be defined, too.
The use of the values 0, 98 and 99 is only permitted in the elements SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EXCHANGE_ID_REF and PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID. 		D nonNegativeInteger
P [0-9]|[1-8][0-9]|9[89]
M [0:99]
Source
<xs:element name="EXCHANGE_ID_2_REF" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>117--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="EXCHANGE_ID_NO" use="required">
      <xs:annotation>
        <xs:documentation>117--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:pattern value="[0-9]|[1-8][0-9]|9[89]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
EXCHANGE_ID_GROUP Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

RULE Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : RULE Element
Description
111--0--NEW Version Beta 2.0 Build 0This element defines a manufacturer specific set of rules.
Namespace (none)
Diagram
LANGUAGE Element Sequence RULE_TEXT Element Sequence RULE Element
Overview
RULE 1..99
111--0--NEW Version Beta 2.0 Build 0This element defines a manufacturer specific set of rules.
RULE_NO required Restriction of xs:nonNegativeInteger
113--3--Regel_Nr Version Beta 2.0 Build 0
This attribute defines a counter from 1-99 for the manufacturer specific block rules. D nonNegativeInteger
P
M [1:99]
Sequence
RULE_TEXT languagetexte60999 Complex Type
113--5--Regel_Nr_Text Version Beta 2.0 Build 0This element defines the criteria for exchanges in the block processing.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
RULE_NO Restriction of xs:nonNegativeInteger required 113--3--Regel_Nr Version Beta 2.0 Build 0
This attribute defines a counter from 1-99 for the manufacturer specific block rules. D nonNegativeInteger
P
M [1:99]
Source
<xs:element name="RULE" maxOccurs="99" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="RULE_TEXT" type="languagetexte60999">
        <xs:annotation>
          <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="RULE_NO" use="required">
      <xs:annotation>
        <xs:documentation>113--3--Regel_Nr</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="99" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

RULE_TEXT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element > RULE Element : RULE_TEXT Element
Description
113--5--Regel_Nr_Text Version Beta 2.0 Build 0This element defines the criteria for exchanges in the block processing.
Namespace (none)
Type
languagetexte60999 Complex Type
Diagram
LANGUAGE Element Sequence RULE_TEXT Element
Overview
RULE_TEXT languagetexte60999 Complex Type
113--5--Regel_Nr_Text Version Beta 2.0 Build 0This element defines the criteria for exchanges in the block processing.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="RULE_TEXT" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>113--5--Regel_Nr_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
RULE Element | SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

RULE_SET_TEXT Element
IDM 2.7.0 Block XML-Schema > T_NEW_BLOCK Element > BLOCK_VALUE_CALCULATION Element > SET_OF_BLOCK_RULES Element : RULE_SET_TEXT Element
Description
111--5--Regelwerk_Text Version Beta 2.0 Build 0This element contains text information and explanations for the set of rules.
Namespace (none)
Type
languagetexte60999 Complex Type
Diagram
LANGUAGE Element Sequence RULE_SET_TEXT Element
Overview
RULE_SET_TEXT languagetexte60999 Complex Type
111--5--Regelwerk_Text Version Beta 2.0 Build 0This element contains text information and explanations for the set of rules.
Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="RULE_SET_TEXT" type="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>111--5--Regelwerk_Text</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
SET_OF_BLOCK_RULES Element | BLOCK_VALUE_CALCULATION Element | T_NEW_BLOCK Element | IDM 2.7.0 Block XML-Schema


%%ItemTitle%%

IDM 2.7.0 Block XML schema documentation
Type of data
View with Navigation Tools

Special types of data have been defined for element references depending on language.


%%LocalItemTitle%%

languagetexte Complex Type
IDM 2.7.0 Block XML-Schema : languagetexte Complex Type
Description

This data type is used for multilingual text information of any length.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte Complex Type
Overview
languagetexte

This data type is used for multilingual text information of any length.

Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used for multilingual text information. For each language the definition of one element is required. The chosen language is defined by the attribute ISO_LANGUAGE_ID. If different languages are defined, they apply to each single item in the database.
ISO_LANGUAGE_ID required Restriction of xs:language
1000--0--NEW
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string
1000--0--NEW

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> Line break

 D string
P
M
Used By
EXTERNAL_NAME Element
TOOL_TIP Element
FULL_TEXT Element
Source
<xs:complexType name="languagetexte" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT" type="xs:string">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>1000--0--NEW</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

languagetexte30 Complex Type
IDM 2.7.0 Block XML-Schema : languagetexte30 Complex Type
Description
Für Texte mit 30stelliger Zeile K. Richter 15.04.2014

This element is used for multilingual text information limited to 30 characters.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte30 Complex Type
Overview
languagetexte30
Für Texte mit 30stelliger Zeile K. Richter 15.04.2014

This element is used for multilingual text information limited to 30 characters.

Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,30}
M [1:30]
Used By
CATALOG_NAME Element
Source
<xs:complexType name="languagetexte30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 30stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,30}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

languagetexte40 Complex Type
IDM 2.7.0 Block XML-Schema : languagetexte40 Complex Type
Description
Für Texte mit 40stelliger Zeile K. Richter 15.04.2014

This element is used for multilingual text information limited to 40 characters.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte40 Complex Type
Overview
languagetexte40
Für Texte mit 40stelliger Zeile K. Richter 15.04.2014

This element is used for multilingual text information limited to 40 characters.

Sequence
LANGUAGE 1..∞
1000--0--NEWThis element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
1000--0--NEW Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,40}
M [1:40]
Used By
INTERNAL_NAME Element
Source
<xs:complexType name="languagetexte40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 40stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>Längenbeschränkung 1-40 ergänzt 28.10.2013 /FurniTec</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,40}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014</xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

languagetexte60 Complex Type
IDM 2.7.0 Block XML-Schema : languagetexte60 Complex Type
Description
Für Texte mit 60stelliger Zeile K. Richter 15.04.2014

This element is used for multilingual text information limited to 60 characters.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte60 Complex Type
Overview
languagetexte60
Für Texte mit 60stelliger Zeile K. Richter 15.04.2014

This element is used for multilingual text information limited to 60 characters.

Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Used By
CLEARING_GROUP_NAME Element
PRODUCT_GROUP_TEXT Element
RESTRICTION_NAME_TEXT Element
Source
<xs:complexType name="languagetexte60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:annotation>
              <xs:documentation>265--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,60}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDM 2.7.0 Block XML-Schema


%%LocalItemTitle%%

languagetexte60999 Complex Type
IDM 2.7.0 Block XML-Schema : languagetexte60999 Complex Type
Description
Für Texte mit 60stelligen Zeilen K. Richter 15.04.2014

This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetexte60999 Complex Type
Overview
languagetexte60999
Für Texte mit 60stelligen Zeilen K. Richter 15.04.2014

This element is used for multilingual text information limited to 60 characters per line. The maximum length of the complete element is limited to 999 lines.

Sequence
LANGUAGE 1..∞
150--0--NEW Version Beta 2.0 Build 4This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_BLOCK/CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
150--0--NEW Version Beta 2.0 Build 4, K. Richter 26.03.2014
This attribute define sthe ISO-Code for the chosen language in the text information. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..999
150--0--NEW Version Beta 2.0 Build 5This element defines a text line.
The attribute SEQUENCE_NO defines the order of text elements within the text line. This definition is necessary because the basic order of the text elements may be changed in the cause of XML data processing.

The element TEXT contains text information
SEQUENCE_NO required Restriction of xs:positiveInteger
150--0--NEW Version Beta 2.0 Build 5
This attribute defines the order of text lines in multi-line texts. In case of single-line texts the value 1 is filled in. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
265--0--NEW Version Beta 2.0 Build 5
This element contains text information in the language defined by the attribute ISO_LANGUAGE_ID in the element LANGUAGE. D string
P [\S ]{1,60}
M [1:60]
Used By
CATALOG_INFO Element
PLANNING_ADVICE Element
RULE_TEXT Element
RULE_SET_TEXT Element
Source
<xs:complexType name="languagetexte60999" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelligen Zeilen</xs:documentation>
    <xs:documentation>K. Richter 15.04.2014</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:annotation>
        <xs:documentation>150--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
      </xs:annotation>
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT_LINE" maxOccurs="999">
            <xs:annotation>
              <xs:documentation>150--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:complexType>
              <xs:sequence>
                <xs:element name="TEXT">
                  <xs:annotation>
                    <xs:documentation>265--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:pattern value="[\S ]{1,60}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:element>
              </xs:sequence>
              <xs:attribute name="SEQUENCE_NO" use="required">
                <xs:annotation>
                  <xs:documentation>150--0--NEW</xs:documentation>
                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                </xs:annotation>
                <xs:simpleType>
                  <xs:restriction base="xs:positiveInteger" />
                </xs:simpleType>
              </xs:attribute>
            </xs:complexType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:annotation>
            <xs:documentation>150--0--NEW</xs:documentation>
            <xs:documentation>Version Beta 2.0 Build 4, K. Richter 26.03.2014
              </xs:documentation>
          </xs:annotation>
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
IDM 2.7.0 Block XML-Schema