%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Introduction
View with Navigation Tools

MODIFY_CONTENT_IDMP_3.0.1 XML schema

Documentation

Last revised 01 May 2020

Documented XML schema:

MODIFY_CONTENT_IDMP_3_0_1.xsd

Contact

DCC e. V.
Dr.-Ing. Olaf Plümer
E-Mail pluemer@vhk-herford.de
Telephone +49 (0) 52 21/12 65-37


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
The basic structure of the IDM schema
View with Navigation Tools
Introduction > The basic structure of the IDM schema

The basic structure of the IDMP schema

The main element T_MODIFY_CONTENT_CATALOG defines that a new and complete catalogue data pool is made available.

The IDM schema is subdivided in data ranges that are specified in the subsequent child-elements (see figure 1) in T_MODIFY_CONTENT_CATALOG.

Figure 1 - child elements in T_MODIFY_CONTENT_CATALOG

The data ranges are not used in isolation from each other. In some data ranges, data is initially created and used from other data ranges via referencing.
Additionally, many data ranges contain references to the associated base catalogue.

Description of the data ranges

CATALOG

CATALOG is used to store administrative information concerning the data pool. E.g. the version of the data format, release date or the unique identification of the data pool.

REF_CATALOG

Information on the base catalogue is specified in REF_CATALOG.

GLOBAL_DEFINITION

The GLOBAL_DEFINITION data range is a kind of data pool for information used in the other data ranges. In this case, the detail information for this data pool is stored.

SERIES

The modified trade-specific texts, detail information and classifications for the items of the base catalogue are specified in SERIES. Items are combined into product groups, such as armchairs or intermediate elements.

FEATURE_DEFINITION

Trade-specific texts and detail information for feature information are stored in FEATURE_DEFINITION.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Elements of the catalogue structure
View with Navigation Tools

Creating elements of the catalogue structure

Creating series information

Series are defined in the following element:

T_NEW_CATALOG/SERIES/SERIE

All child elements are used to describe the properties of the series.Versions are assigned to series via assessment procedures (RESTRICTION_REF).

Creating versions

Example: creating versions

1. Definition of the version properties/version variations

The version properties are defined in the following element:

FEATURE_DEFINITION/OPTION_DEFINITION

<OPTION_DEFINITION>

</OPTION_DEFINITION>

This element is used to define the properties of colours, materials, shape versions and dimensions.

2. Creating the versions

The versions are created in the following element:

FEATURE_DEFINITION/FEATURES/FEATURE

<FEATURE FEATURE_NO="1">

<OPTIONS>

<OPTION OPTION_KEY="L"

</OPTION>

<OPTION OPTION_KEY="S"

</OPTION>

</OPTIONS>

</FEATURE>

Version types are defined via version type numbers, e.g. 1. The version is unequivocally identified by the combination of FEATURE_NO in FEATURE_DEFINITION/FEATURES/FEATURE and OPTION_KEY in FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

Creating item information

Item information is specified in the following element:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

The element ITEM has a multitude of elements used to describe the properties of items. An item is identified via the attribute TYPE_NO.

Please note that depending on the series, an item may have different properties. Consequently, an item and its properties can only be unequivocally identified in combination with the series.

Series-specific item information

Depending on the series, items may have different properties. Items are automatically assigned to a series because the element ITEM is a child element of the SERIE element.

Creating version information

Version information is created in the IDM schema as described in the following:

- Creation of variations for the versions

- Assignment of variation and version type

Creating variations

The variations for the versions are defined as a data pool in the element T_NEW_CATALOG/FEATURE_DEFINITION/OPTION_DEFINITION.

Figure 2 - The element OPTION_DEFINITION

The OPTION_DEFINITION element contains elements in which the respective variations are specified:

MATERIAL | This element is used to define the properties of materials using colours and textures. These elements are referenced from variation version types.
OPTION_MEASURE | This element is used to specify the values of versions that are expressed in a dimension (e.g. sitting height (variation type 35)).

Example: variations for colours

<OPTION_DEFINITION>

<MATERIAL>

<COLOR COLOR_NO="1">

<RGB_RED>255</RGB_RED>

<RGB_GREEN>0</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="2">

<RGB_RED>133</RGB_RED>

<RGB_GREEN>273</RGB_GREEN>

<RGB_BLUE>0</RGB_BLUE>

</COLOR>

<COLOR COLOR_NO="3">

<RGB_RED>0</RGB_RED>

<RGB_GREEN>89</RGB_GREEN>

<RGB_BLUE>89</RGB_BLUE>

</COLOR>

</MATERIAL>

</OPTION_DEFINITION>

The above elements define three colours that are identified by numbers (COLOR_NO) 1-3.

Assignment of variation and version type

To use the colours defined in the example above, version types must be assigned, which results in versions.

The assignment of version types (FEATURE) and variations (OPTION) to versions is done in the element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE. A variation is formed and identified by the combination of FEATURE and OPTION. The following XML elements define 2 feed heights (version type 15).

Example: assembly of versions from version type and variations

<FEATURE FEATURE_NO="15">

<OPTIONS>

<OPTION OPTION_KEY="10">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

<OPTION OPTION_KEY="30">

<OPTION_TEXT>

</OPTION_TEXT>

</OPTION>

</OPTIONS>

<FEATURE_TEXT>

</FEATURE_TEXT>

<HEADER_POS_VARIATION_TYPE>K</HEADER_POS_VARIATION_TYPE>

</FEATURE>

The child elements of FEATURE describe the properties of the version type, the child elements of OPTION describe the properties of the version. Analogous to this principle, which applies for essentially all elements in the IDM schema, the OPTION_TEXT defines a text that designates the version. The element FEATURE_TEXT defines a text that designates the version type.

If the data is supposed to reference a version, the combination of FEATURE_NO and OPTION_KEY must always be specified as a reference key.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Data types
View with Navigation Tools
Introduction > Data types

Data types and value ranges

The IDM schema uses the data types defined in the standard XML schema 1.0 second edition (28 October 2004).

It uses the following data types:

boolean | This data type maps the logical values "true" or "false". In accordance with the W3C recommendation for XML schemas, the values that can be used in the IDM are true/false or 1/0.
date | In the IDMP, the data type date is used in conformity with the XML schemas as follows: YYYY-MM-DD Y = year, M = month, D = day
integer | Numbers can be positive and negative integers.
nonNegativeInteger | Value is a positive integer, including 0
positiveInteger | Value is a positive integer, excluding 0
decimal | The data type is used in the IDMP for floating-point values. Floating-point values for this data type are, as recommended by the W3C, stored as 126.56 or -45.98000 or +27.0.
string | A limited number of alphanumeric characters and special characters.
anyURI | The data type is used in the IDMP for URLs.anyURI represents a Uniform Resource Identifier (URI). The lexical part of anyURI is an indefinite sequence of characters that correspond to a legal URI. An anyURI value can be absolute or relative and may contain fragment codes (e.g. an URI reference).
language | The data type is used in the IDMP for the mapping of valid language keys.language represents codes for natural languages Tags for the Identification of Languagesas defined in the Thevaluerangeof language is the quantum of all character sequences that represent a valid code of a natural language. For ISO languages, the format consists of a sequence of 2-3 lower case letters optionally followed by a hyphen and a country code consisting of 2 upper case letters, e.g. en-US.

Additionally, there is also a user-defined data type:

operator

Thy data type is used for rules in the IDMP. This simple, self-defined data type defines an operator for comparisons. The comparison operator is a string of 1 to 4 characters length and may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

The value ranges of the above data types are usually restricted for the elements in the IDMP. The "restrictions" in the data type definition contains restrictions for minimum and maximum values, permitted characters (pattern) and value lists.

In the documentation of the XML schema of the IDM, the value ranges are specified by the information coming after M and P.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Notes to the documentation
View with Navigation Tools
Introduction > Notes to the documentation

Notes to the IDMP documentation

Notes to the IDM documentation schema are stored in this section.

Explanation of the element properties

Each element is documented on the basis of a description and its properties. The following shows an example for an element description:

Description:

This element is used to specify the currency key for the prices stated in the data pool. The ISO currency ID must be used for the currency key.
Changing currencies within the same data pool are not permitted. Updates during the year must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]

The element properties are documented on the right side. They have the following meaning:

D | The data type of the element is documented here. If this position is left blank, the element does not contain any reference data but additional child-elements.
P | The entries made in P and M document the value range of an element. A regular expression that defines the permitted values must be entered in P.
M | The minimum and maximum permitted values must be entered in M. In the case of a string data type, P defines the permitted characters and M the minimum and maximum character length. In the case of a numeric data type, the permitted minimum and maximum value is defined.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Version types
View with Navigation Tools
Introduction > Version types

Version types

The following version types have been defined:

Version_type | Version_type_text | Type | Remark/possible variations
1 | Reference type | A |
2 | Main reference type | A |
3 | Main reference colour | F |
4 | base cover material | A |
5 | base cover colour | F |
6 | back cover type | A |
7 | back cover colour | F |
8 | seam pattern | A | UNKNOWN TERM
9 | Seat cushion type | A |
10 | Seat cushion colour | F |
11 | Decorative cushion type | A | soft, firm, round, rectangular, ...
12 | Decorative cushion colour | F |
13 | Contrast stitching type / variation | A |
14 | Contrast stitching colour | F |
15 | Foot height | A |
16 | Foot material | A | Metal, timber, plastic, beech,. ..
17 | Foot shape | A | metal runner, wooden runner, metal leg, wooden leg, castor, plastic glider
18 | Foot colour | F |
19 | chatose type | A |
20 | chatose colour | F |
21 | UNKNOWN TERM | A |
22 | UNKNOWN TERM | F |
23 | UNKNOWN TERM | A |
24 | UNKNOWN TERM | F |
25 | Side pocket type | A |
26 | Side pocket colour | F |
27 | material of piping | A |
28 | colour of piping | F |
29 | kind of bottom linen | A |
30 | colour of bottom linen | F |
31 | Zipper type | A |
32 | Zipper colour | F |
33 | Seat hardness, quality | A | with/without spring core, ...
34 | Drive type | A | Nozzle, manual, gas pressure spring, motor plug-in, motor battery, do
35 | Seat height | A |
36 | Seat depth | A |
37 | Seat width | A |
38 | Back height | A |
39 | Back cushion height | A |
40 | Back cushion type | A |
41 | Armrests/side element configuration | A | without, left, right, both sides, ...
42 | Armrests/side element type | A |
43 | Side element adjustment | A |
44 | Headrest type | A | movable, fixed, neck rest, ...
45 | Headrest colour | F |
46 | lower front part | A | floor level, floor-free
47 | Fabric combination | K |
48 | Fire / flame retardant | A |
49 | Resting area type | A |
50 | Resting area colour | F |
51 | Country version | A |
52 | Crossways sleepers | A |
53 | Seat angle adjustment | A |
54 | Seat depth adjustment | A | Mechanical, electrical, gas spring, ...
55 | Backrest adjustment | A | Mechanical, electrical, gas spring, ...
56 | Footrest adjustment | A | Mechanical, electrical, gas spring, ...
57 | Massage function | A |
58 | Seat heating | A |
59 | Lumbar support | A |
60 | Swivel base | A |
61 | Stand-up aid | A | Mechanical, electrical, gas spring, ...
62 | Folding table | A |
63 | plug-in table | A |
64 | Pull-out table | A |
65 | Cupholder | A |
66 | Headboard | A | Shape 1, shape 2 etc., headboard shortening at a surcharge, without K
67 | Headboard fabric | A |
68 | Throw-over | A | short, half-length, full length, shroud
69 | Day cover fabric | A |
70 | Lying surface | A | 160x200, 180x200, 200x200 at a surcharge, other lengths at a surcharge
71 | Bedding box | A | standard, inserting mechanism, highline etc.
72 | Bedding box upholstery | A |
73 | Slatted base | A | Standard or alternatives at a surcharge, separate slats if appropriate
74 | Mattress | A | Standard or alternatives at a surcharge >> firmness level H2
75 | Handles (for bedside tables) | F |
76 | Bedside tables | A | Drawer with plastic or metal rails
77 | Lamp colour and finish | A |
78 | Knob cover | F |
79 | Slatted base adjustment | A | Mechanical, electrical, gas spring, multiple, ...
80 | Function/adjustment in general | A |
81 | freely defined version type | F |
82 | freely defined version type | F |
83 | freely defined version type | F |
84 | freely defined version type | F |
85 | freely defined version type | F |
86 | freely defined version type | F |
87 | freely defined version type | F |
88 | freely defined version type | F |
89 | Connection type L | P | ID of the connection vector in the SVG: AVL
90 | Connection type R | P | ID of the connection vector in the SVG: AVR
91 | Connection type custom 1 | P | ID of the connection vector in the SVG: AVC01
92 | Connection type custom 2 | P | ID of the connection vector in the SVG: AVC02
93 | Connection type custom 3 | P | ID of the connection vector in the SVG: AVC03
94 | Connection type custom 4 | P | ID of the connection vector in the SVG: AVC04
95 | Planning width | P | Item width
96 | Planning depth | P | Item depth
97 | Planning height | P | Item height
98 | Drive position | A |
99 | Table colour | F |
100 | Head-section adjustment | A |
101 | Relax function | A |
102 | Vitalising function | A |
103 | Power source/motor | A |
104 | Accessories | A |
105 | Top table | A |
106 | Back holder | A |
107 | Slot-in back | A |
108 | Intermediate table | A |
109 | Newspaper rack | A |
110 | Swivel function | A |
111 | Reading lamp | A |
112 | Decorative item | A |
150 | Connection type custom 5 | P | ID of the connection vector in the SVG: AVC05
151 | Connection type custom 6 | P | ID of the connection vector in the SVG: AVC06
152 | Connection type custom 7 | P | ID of the connection vector in the SVG: AVC07
153 | Connection type custom 8 | P | ID of the connection vector in the SVG: AVC08
154 | Connection type custom 9 | P | ID of the connection vector in the SVG: AVC09
155 | Connection type custom 10 | P | ID of the connection vector in the SVG: AVC10
160 | Connection type top 1 | P | ID of the connection vector in the SVG: AVO1
161 | Connection type top 2 | P | ID of the connection vector in the SVG: AVO2
162 | Connection type top 3 | P | ID of the connection vector in the SVG: AVO3
163 | Connection type top 4 | P | ID of the connection vector in the SVG: AVO4
164 | Connection type top 5 | P | ID of the connection vector in the SVG: AVO5
165 | Connection type bottom 1 | P | ID of the connection vector in the SVG: AVU1
166 | Connection type bottom 2 | P | ID of the connection vector in the SVG: AVU2
167 | Connection type bottom 3 | P | ID of the connection vector in the SVG: AVU3
168 | Connection type bottom 4 | P | ID of the connection vector in the SVG: AVU4
169 | Connection type bottom 5 | P | ID of the connection vector in the SVG: AVU5
170 | Connection type top 6 | P | ID of the connection vector in the SVG: AVO6
171 | Connection type top 7 | P | ID of the connection vector in the SVG: AVO7
172 | Connection type top 8 | P | ID of the connection vector in the SVG: AVO8
173 | Connection type top 9 | P | ID of the connection vector in the SVG: AVO9
174 | Connection type top 10 | P | ID of the connection vector in the SVG: AVO10
175 | Connection type bottom 6 | P | ID of the connection vector in the SVG: AVU6
176 | Connection type bottom 7 | P | ID of the connection vector in the SVG: AVU7
177 | Connection type bottom 8 | P | ID of the connection vector in the SVG: AVU8
178 | Connection type bottom 9 | P | ID of the connection vector in the SVG: AVU9
179 | Connection type bottom 10 | P | ID of the connection vector in the SVG: AVU10
180 | Connection type custom 1N | P | ID of the connection vector in the SVG: AVC01N
181 | Connection type custom 2N | P | ID of the connection vector in the SVG: AVC02N
182 | Connection type custom 3N | P | ID of the connection vector in the SVG: AVC03N
183 | Connection type custom 4N | P | ID of the connection vector in the SVG: AVC04N
184 | Connection type custom 5N | P | ID of the connection vector in the SVG: AVC05N
185 | Connection type custom 6N | P | ID of the connection vector in the SVG: AVC06N
186 | Connection type custom 7N | P | ID of the connection vector in the SVG: AVC07N
187 | Connection type custom 8N | P | ID of the connection vector in the SVG: AVC08N
188 | Connection type custom 9N | P | ID of the connection vector in the SVG: AVC09N
189 | Connection type custom 10N | P | ID of the connection vector in the SVG: AVC10N
190 | Connection type custom 1S | P | ID of the connection vector in the SVG: AVC01S
191 | Connection type custom 2S | P | ID of the connection vector in the SVG: AVC02S
192 | Connection type custom 3S | P | ID of the connection vector in the SVG: AVC03S
193 | Connection type custom 4S | P | ID of the connection vector in the SVG: AVC04S
194 | Connection type custom 5S | P | ID of the connection vector in the SVG: AVC05S
195 | Connection type custom 6S | P | ID of the connection vector in the SVG: AVC06S
196 | Connection type custom 7S | P | ID of the connection vector in the SVG: AVC07S
197 | Connection type custom 8S | P | ID of the connection vector in the SVG: AVC08S
198 | Connection type custom 9S | P | ID of the connection vector in the SVG: AVC09S
199 | Connection type custom 10S | P | ID of the connection vector in the SVG: AVC10S
200 | freely defined version type | F |
201 | freely defined version type | F |
202 | freely defined version type | F |
203 | freely defined version type | F |
204 | freely defined version type | F |
205 | freely defined version type | F |
206 | freely defined version type | F |
207 | freely defined version type | F |
208 | freely defined version type | F |
209 | freely defined version type | F |
210 | freely defined version type | F |

Freely defined version types are available from 200 to 999.

Type: A = finish

F = colour

P = planning


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Model code
View with Navigation Tools

Model code

This element is used to specify the model code:

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_KEY/TK_TYPE

The following model codes have been defined:

Type no.: | Designation (German) | Designation (English)
1 | Sessel / Hochlehnsessel | Floor cupboard
2 | Clubchair | Tal cupboard
3 | TV-Sessel / Ruhe- / Liege- / Relaxsessel | Hanging/wall cupboard
4 | Longchair | Work-top mounted cupboard
5 | Sofa / Canapé | Recess kit
6 | Zwischenelement | Highboard/ Intermediate element
7 | Ecke / Trapezteil | Corner / trapezoidal element
8 | Einzelliege / Recamiere / Ottomane / Cheselon / Chaiselongue | Single daybed / recamiere / otoman / cheselon / chaiselounge
9 | Hocker | Stool/ Front element
10 | Kissen | Cushions
11 | Coffee table / table attachment / UNKNOWN TERM | Cornice profile
12 | Dining table | Pelmet
13 | Combinations | Top facing
14 | Abschlusselement | Plinth filler
15 | Bed sofa / bed couch / sofa with bed function / sleeping element / divans | End unit/Plinth board
16 | Sitzbank, Essplatzbank, Dinnersofa, ... | Bench, dining table bench, dining sofa, ...
17 | Chairs | Work-top
18 | Footrest bench | Wall end moulding
19 | Headrest | Covering plate
20 | Lights | Canopy
21 | Carpets | Over shelf
22 | Accessories / small parts | Construction shelf
23 | Polsterbetten / Polsterbett-Systeme | Sofa beds / sofa bed systems/Chimney
24 | Polsterbettgestelle | Sofa bed frames/Chimney
25 | Metrage | Metrage
26 | Sonstiges | Miscellaneous/Appliance


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Catalogue structure
View with Navigation Tools

Catalogue and element structure

The catalogue structure in the IDM schema is mapped by the following element hierarchy:

Figure 1 - Element hierarchy in the IDM schema

The SERIE element is used to define the properties of a series.Product groups (PRODUCT_GROUPS) in which items (ITEMS) with similar version types are combined are defined within the series. The items are automatically assigned to a series because they are child elements of the SERIE element. The DECISIONS elements are used to cross-series assign versions to a series, product group or item via rules. It is also possible to assign actions (ACTIONS) to the rules defined in DECISIONS.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Arranging the catalogue structure
View with Navigation Tools

Arranging the catalogue structure

Assigning series to options

Options are assigned to all series in the following element:

SERIES/DECISIONS/DECISION_REF

The option is assigned to the series by referencing a rule that defines the option as a valid combination in the SERIES/SERIE/DECISIONS/DECISION_REF element.

Assigning items, series and options

Item-series assignment

Items are automatically assigned to series because the ITEM element is a child element of the SERIES element:

SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

Item-specific rules can be defined via SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/DECISIONS/DECISIONS_REF.

Example: Rule for options assignment

Element: FEATURE_DEFINITION/DECISIONS/DECISION

<DECISIONS>
<DECISIONVALIDATION_TYPE="0"DECISION_NO="1">
<DECISION_NAME_TEXT>
<LANGUAGEISO_LANGUAGE_ID="EN">
<TEXT_LINESEQUENCE_NO="1">
<TEXT>item numbers</TEXT>
</TEXT_LINE>
</LANGUAGE>
</DECISION_NAME_TEXT>
<OPTION_COMBINATIONSEQUENCE="1">
<FEATURE_REFFEATURE_NO="1">
<OPTION_REF_OPOPTION_KEY="1"OPERATOR="eq"/>
</FEATURE_REF>
<FEATURE_REFFEATURE_NO="201">
<OPTION_REF_OPOPTION_KEY="0"OPERATOR="eq"/>
</FEATURE_REF>
<FEATURE_REFFEATURE_NO="202">
<OPTION_REF_OPOPTION_KEY="00"OPERATOR="eq"/>
</FEATURE_REF>
<ACTIONS>
<SET_FEATURE_FIXEDFEATURE_NO="204">
<OPTION_REFOPTION_KEY="1000"/>
</SET_FEATURE_FIXED>
</ACTIONS>
</OPTION_COMBINATION>
</DECISION>
</DECISIONS>


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Referencing
View with Navigation Tools

Referencing of elements

The IDM schema establishes relationships between elements and defines information at a central point which are used on multiple occasions in another position. The reuse of the information and the structure of element relationships takes place via referencing. The type of referencing used in the IDM schema is described in the following.

Definition of terms

The IDM schema uses the following terms for the referencing of elements:

Key element | An XML element referenced by other elements.
Ref element | An XML element referencing other elements.

Referencing procedure

The key element has attributes that allow for its unequivocal identification. The ref element has at least the key attributes of the key element. The reference in which the attribute values of the ref element are identical to those of the key element is established between the elements.

Example: Referencing the rule across multiple series, from the series, the product group and the item

The following example shows how a rule (DECISION) is referenced from an item (ITEM). Only some of the XML elements are explained.

Key element

T_NEW_CATALOG/FEATURE_DEFINITION/DECISIONS

<DECISIONS>

<DECISION DECISION_NO="1"/> … </DECISION>

<DECISION DECISION_NO="2"/> … </DECISION>

<DECISION DECISION_NO="3"/> … </DECISION>

. . .

</DECISIONS>

Ref element

T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM

<ITEMS>

<ITEM TYPE_NO="1111">

<DECISIONS>

<DECISION_REF DECISION_NO="1"> …</DECISION_REF>

. . .

</ITEMS>

Example: referencing of a version

The following example shows how to reference a version from an assessment procedure.

Key element

T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION

<FEATURES>

<FEATURE FEATURE_NO="15"> <!-- foot height-->

<OPTIONS>

<OPTION OPTION_KEY="100"> …</OPTION>

<OPTION OPTION_KEY="120"> …</OPTION>

<OPTION OPTION_KEY="30"> …</OPTION>

</OPTIONS>

</FEATURE>

<FEATURE FEATURE_NO="17"> <!-- Footshape-->

<OPTIONS>

<OPTION OPTION_KEY="F00"> …</OPTION>

<OPTION OPTION_KEY="F3Z"> …</OPTION>

<OPTIONOPTION_KEY="F70"> …</OPTION>

</OPTIONS>

</FEATURE>

</FEATURES>

For version type 15, the XML elements define three versions (OPTION) with codes 100,120,30. For version type 17, three versions with codes F00, F3Z, F70 are defined. A version is identified via the combination of FEATURE_NO and OPTION_KEY.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Assessment procedure
View with Navigation Tools

Definition and assignment of rules

The earlier assessments (RESTRICTIONS) are now fully replaced by rules (DECISIONS).

The rules/assessment procedures are assigned to serious or items by references from the corresponding elements. In total, all assessment procedures defined in this element must be referenced from either series or items.

Rules that are referenced by items take priority over rules referenced by series.

DECISIONS have 3 types of rules (identified by TEST_ID).

Depending on the TEST_ID element, different rules can be specified.

If the value in TEST_ID is 1, the rule is a "preparation rule".

This allows for the definition of valid versions in OPTION_COMBINATION. These are used to determine the valid versions of a version type. These rules do not have an action part ("ACTIONS") and they define a quantity of version combinations that are either true or false. This is a table with the version types (FEATURES) as column headings; the cell contents of this table are values, lists, intervals, version groups that are linked by quantity operators.

The conditions are supplemented with operators. The special data type operator was defined for this purpose. It may contain the following values:

eq (equal)

ne (not equal)

in (is contained in a quantity)

nin (is not contained in a quantity)

gt (greater)

lt (less)

ge (greater than or equal)

le (less than or equal)

The individual OPTION_COMBINATIONs must be considered as ELSE branches. This means that as soon as a condition line (OPTION_COMBINATIONS) receives a hit, the others will not be executed anymore.

If the value in TEST_ID is 2, the rule is a an action rule. It allows for the definition of actions in addition to the conditions.

If all conditions within an „OPTION_COMBINATION“ are satisfied, all signed actions (ACTIONS) then can set values or make version types (FEATURES) invisible depending on conditions. If an OPTION_COMBINATION is satisfied, the other conditions are not processed.

Actions (ACTIONS) are instructions that are executed if a condition is met. The following actions can be executed:

  • The setting of versions (SET_FEATURE_FIXED) with the following options:

§Direct, e.g. main fabric = "blue" (OPTION)

§the setting of version values from another version type (FEATURE), e.g. ledge fabric = main fabric

§the calculation of versions (e.g. sitting height + 5 cm).
This function is only available for dimension versions and takes place via a formula string that may contain parameters and values.
This requires the version type (e.g. sitting height) to be assigned with a parameter (e.g. "sh").
The measure parameter (MEASURE_PARAMETER) can be supplemented with a unit (MEASURE_UNIT). The formula (FORMULA_STRING) therefore only contains the parameters (e.g. planning width = 2 * st + sb, which means that the planning width results from the sitting width + 2 times the side element width.

  • Setting default versions (SET_FEATURE_DEFAULT):
    These can be filled if no value has been entered yet. The same options as above apply.
  • The visibility of version types (SET_FEATURE_VISIBLE, SET_FEATURE_INVISIBLE) and disabling of rules (DISABLE_DECISION, ENABLE_DECISION):
    Example: for wooden feet, a potentially existing version type for a shade can be displayed and made invisible if a metal foot is selected.

Action rules are usually used in the configurator if an option value (a version) changes. If, for example, the foot version is changed from stainless steel to wood, a version type for the shade can be displayed.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Language key
View with Navigation Tools
Introduction > Language key
Language key | Language name
AA | Afar
AB | Abkhasian
AE | Avestan
AF | Afrikaans
AM | Amharic
AN | Aragonese
AR | Arabic
AS | Assam
AY | Aymara
AZ | Azerbaijanian
BA | Baschkirian
BE | Byelorussian
BG | Bulgarian
BH | Biharic
BI | Bislamic
BM | Bambara
BN | Bengal
BO | Tibetan
BR | Breton
BS | Bosnian
CA | Catalan
CE | Circassian
CH | Chamorro
CO | Corsican
CS | Czech
CU | Old slavish
CV | Chuvash
CY | Welsh
DA | Danish
DE | German
DV | Dhivehi
DZ | Dzongkha
DV | Dhivehi
EE | Estonian
EL | Greek
EN | English
EO | Esperanto
ES | Spanish
ET | Estonian
EU | Basque
FA | Persian
FF | Fulfulde
FI | Finno-Ugric
FJ | Fiji
FO | Faroese
FR | French
FY | Frisian
GA | Irish
GD | Gaelic
GL | Galician
GN | Guarani
GU | Gujaratic
GV | Manx, Manx-Gaelic
HA | Hausa
HE | Hebrew
HI | Hindi
HO | Hiri Motu
HR | Croatian
HT | Haitian
HU | Hungarian
HY | Armenian
HZ | Herero
IA | Interlingua
ID | Indonesian
IE | Interlingue
IG | Igbo
II | Yi
IK | Inupiak
IN | former Indonesian
IO | Ido
IS | Icelandic
IT | Italian
IU | Inuit
JA | Japanese
JV | Javanese
KA | Georgian
KG | Kikongo
KI | Kikuyu
KJ | Kuanyama
KK | Kazakh
KL | Kalaallisut (Greenland)
KM | Cambodian
KN | Canadian
KO | Korean
KR | Kanuri
KS | Kashmirian
KU | Kurdish
KV | Komi
KW | Cornish
KY | Kirghiz
LA | Latin
LB | Luxembourgish
LG | Luganda
LI | Limburg
LN | Lingala
LO | Laotian
LT | Lithuanian
LU | Kiluba
LV | Lett
MG | Malagasy
MH | Marshallese
MI | Maori
MK | Macedonian
ML | Malay
MN | Mongolian
MO | Moldovan
MR | Marathi
MS | Malayan
MT | Maltese
MY | Burmese
NA | Nauruan
NB | Norwegian Bokmål
ND | North Ndebele
NE | Nepalese
NG | Ndonga
NL | Dutch
NN | Norwegian Nynorsk
NO | Norwegian
NR | South Ndebele
NV | Navajo
NY | Chichewa
OC | Occitan
OJ | Ojibwe
OM | Oromo
OR | Orija
OS | Ossetian
PA | Punjab
PI | Pali
PL | Polish
PS | Paschtu
PT | Portugese
QU | Quechua
RM | Rhaeto-Romanic
RN | Kirundisch
RO | Romanian
RU | Russian
RW | Kijarwanda
SA | Sanskrit
SC | Sardinian
SD | Sinto
SE | North Sami
SG | Sango
SI | Sinhalese
SK | Slovakian
SL | Slovenian
SM | Samoan
SN | Shonian
SO | Somali
SQ | Albanian
SR | Serbian
SS | Swazi
ST | Sesothisch
SU | Sudanese
SV | Swedish
SW | Swahili
TA | Tamil
TE | Tegulu
TG | Tajik
TH | Thai
TI | Tigrinja
TK | Turkmenian
TL | Tagalog
TN | Sezuan
TO | Tongan
TR | Turkish
TS | Tongan
TT | Tartary
TW | Twi
TY | Thai
UG | Uighur
UK | Ukranian
UR | Urdu
UZ | Uzbek
VI | Vietnamese
VO | Volapük
WA | Walloon
WO | Wolof
XH | Xhosa
YI | Yiddish
YO | Joruba
ZA | Zhuang
ZH | Chinese
ZU | Zulu


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Country code
View with Navigation Tools
Introduction > Country code

country code | country (German) | country (English)
AC | Ascension | Ascension
AD | Andorra | Andorra
AE | Vereinigte Arabische Emirate | United Arab Emirates
AF | Afghanistan | Afghanistan
AG | Antigua und Barbuda | Antigua and Barbuda
AI | Anguilla | Anguilla
AL | Albanien | Albania
AM | Armenien | Armenia
AN | Niederländische Antillen | Dutch Antilles
AO | Angola | Angola
AQ | Antarktika | Antarctica
AR | Argentinien | Argentina
AS | Amerikanisch-Samoa | American Samoa
AT | Österreich | Austria
AU | Australien | Australia
AW | Aruba | Aruba
AX | Aland | Aland
AZ | Aserbaidschan | Azerbaijan
BA | Bosnien und Herzegowina | Bosnia and Herzegovina
BB | Barbados | Barbados
BD | Bangladesch | Bangladesh
BE | Belgien | Belgium
BF | Burkina Faso | Burkina Faso
BG | Bulgarien | Bulgaria
BH | Bahrain | Bahrain
BI | Burundi | Burundi
BJ | Benin | Benin
BL | Saint-Barthélemy | Saint-Barthélemy
BM | Bermuda | Bermuda
BN | Brunei Darussalam | Brunei Darussalam
BO | Bolivien | Bolivia
BQ | Bonaire, Sint Eustatius und Saba (Niederlande) | Bonaire, Sint Eustatius and Saba
BR | Brasilien | Brazil
BS | Bahamas | Bahamas
BT | Bhutan | Bhutan
BU | Burma (jetzt Myanmar) | Burma
BV | Bouvetinsel | Bouvet Island
BW | Botswana | Botswana
BY | Belarus | Belarus
BZ | Belize | Belize
CA | Kanada | Canada
CC | Kokosinseln | Cocos) Islands
CD | Kongo, Demokratische Republik (ehem. Zaire) | Democratic Republic of the Congo
CF | Zentralafrikanische Republik | Central African Republic
CG | Kongo, Republik (ehem. K.-Brazzaville) | Republic of the Congo
CH | Schweiz | Switzerland
CI | Côte d’Ivoire (Elfenbeinküste) | Ivory Coast
CK | Cookinseln | Cook Islands
CL | Chile | Chile
CM | Kamerun | Cameroon
CN | China | China
CO | Kolumbien | Columbia
CP | Clipperton | Clipperton
CR | Costa Rica | Costa Rica
CU | Kuba | Cuba
CV | Kap Verde | Cape Verde
CW | Curaçao | Curaçao
CX | Weihnachtsinsel | Christmas Island
CY | Zypern | Cyprus
CZ | Tschechische Republik | Czech Republic
DE | Deutschland | Germany
DG | Diego Garcia | Diego Garcia
DJ | Dschibuti | Djibouti
DK | Dänemark | Denmark
DM | Dominica | Dominica
DO | Dominikanische Republik | Dominican Republic
DZ | Algerien | Algeria
EA | Ceuta, Melilla | Ceuta, Melilla
EC | Ecuador | Ecuador
EE | Estland | Estonia
EG | Ägypten | Egypt
EH | Westsahara | Westsahara
EN | England | England
ER | Eritrea | Eritrea
ES | Spanien | Spain
ET | Äthiopien | Ethiopia
FI | Finnland | Finland
FJ | Fidschi | Fiji
FK | Falklandinseln | Falklands
FM | Mikronesien | Micronesia
FO | Färöer | Faeroe Islands
FR | Frankreich | France
GA | Gabun | Gabon
GB | England/Großbritannien | England/Great Britain
GD | Grenada | Grenada
GE | Georgien | Georgia
GF | Französisch-Guayana | French Guiana
GG | Guernsey (Kanalinsel) | Guernsey (Channel Island)
GH | Ghana | Ghana
GI | Gibraltar | Gibraltar
GL | Grönland | Greenland
GM | Gambia | Gambia
GN | Guinea | Guinea
GP | Guadeloupe | Guadeloupe
GQ | Äquatorialguinea | Equatorial Guinea
GR | Griechenland | Greece
GS | Südgeorgien und die Südlichen Sandwichinseln | South Georgia and the South Sandwich Islands
GT | Guatemala | Guatemala
GU | Guam | Guam
GW | Guinea-Bissau | Guinea-Bissau
GY | Guyana | Guyana
HK | Hong Kong | Hong Kong
HM | Heard und McDonaldinseln | Heard and McDonald Islands
HN | Honduras | Honduras
HR | Kroatien | Croatia
HT | Haiti | Haiti
HU | Ungarn | Hungary
ID | Indonesien | Indonesian
IE | Irland | Ireland
IL | Israel | Israel
IM | Insel Man | Isle of Man
IN | Indien | India
IO | Britisches Territorium im Indischen Ozean | British Indian Ocean Territory
IQ | Irak | Iraq
IR | Iran, Islamische Republik | Islamic Republic of Iran
IS | Island | Iceland
IT | Italien | Italy
JE | Jersey (Kanalinsel) | Channel Island of Jersey
JM | Jamaika | Jamaica
JO | Jordanien | Jordan
JP | Japan | Japan
KE | Kenia | Kenya
KG | Kirgisistan | Kyrgyzstan
KH | Kambodscha | Cambodia
KI | Kiribati | Kiribati
KM | Komoren | Comoros
KN | St. Kitts und Nevis | Saint Kitts and Nevis
KP | Korea, demokratische Volksrepublik | Democratic People's Republic of Korea
KR | Korea, Republik | Republic of Korea
KW | Kuwait | Kuwait
KY | Kaimaninseln | Cayman Islands
KZ | Kasachstan | Kazakstan
LA | Laos, Demokratische Volksrepublik | Laos
LB | Libanon | Lebanon
LC | St. Lucia | Saint Lucia
LI | Liechtenstein | Liechtenstein
LK | Sri Lanka | Sri Lanka
LR | Liberia | Liberia
LS | Lesotho | Lesotho
LT | Litauen | Lithuania
LU | Luxemburg | Luxembourg
LV | Lettland | Latvia
LY | Libyen | Libya
MA | Marokko | Morocco
MC | Monaco | Monaco
MD | Moldavien | Moldavia
ME | Montenegro | Montenegro
MF | Saint-Martin (franz. Teil) | Saint Martin
MG | Madagaskar | Madagascar
MH | Marshallinseln | Marshall Islands
MK | Nordmazedonien | North Macedonia
ML | Mali | Mali
MM | Myanmar (Burma) | Myanmar (Burma)
MN | Mongolei | Mongolia
MO | Macau | Macau
MP | Nördliche Marianen | Northern Mariana Islands
MQ | Martinique | Martinique
MR | Mauretanien | Mauritania
MS | Montserrat | Montserrat
MT | Malta | Malta
MU | Mauritius | Mauritius
MV | Malediven | Maldives
MW | Malawi | Malawi
MX | Mexiko | Mexico
MY | Malaysia | Malaysia
MZ | Mosambik | Mozambique
NA | Namibia | Namibia
NC | Neukaledonien | New Caledonia
NE | Niger | Niger
NF | Norfolkinsel | Norfolk Island
NG | Nigeria | Nigeria
NI | Nicaragua | Nicaragua
NL | Niederlande | Netherlands
NO | Norwegen | Norway
NP | Nepal | Nepal
NR | Nauru | Nauru
NU | Niue | Niue
NZ | Neuseeland | New Zealand
OM | Oman | Oman
PA | Panama | Panama
PE | Peru | Peru
PF | Französisch-Polynesien | French Polynesia
PG | Papua-Neuguinea | Papuan New Guinea
PH | Philippinen | Philippine
PK | Pakistan | Pakistan
PL | Polen | Poland
PM | Saint-Pierre und Miquelon | St. Pierre and Miquelon
PN | Pitcairninseln | Pitcairn Islands
PR | Puerto Rico | Puerto Rica
PS | Staat Palästina[ | Palestine
PT | Portugal | Portugal
PW | Palau | Palau
PY | Paraguay | Paraguay
QA | Katar | Qatar
RE | Réunion | Reunion
RO | Rumänien | Romania
RS | Serbien | Serbia
RU | Russland | Russia
RW | Ruanda | Ruanda
SA | Saudi Arabien | Saudi Arabia
SB | Salomonen | Solomon Islands
SC | Seychellen | Seychelles
SD | Sudan | Sudan
SE | Schweden | Sweden
SG | Singapur | Singapore
SH | St. Helena | St. Helena
SI | Slowenien | Slovenia
SJ | Svalbard und Jan Mayen | Svalbard and Jan Mayen Islands
SK | Slowakei (slowakische Republik) | Slovak Republic
SL | Sierra Leone | Sierra Leone
SM | San Marino | San Marino
SN | Senegal | Senegal
SO | Somalia | Somalia
SR | Suriname | Suriname
SS | Südsudan | South Sudan
ST | São Tomé und Príncipe | Democratic Republic of São Tomé and Príncipe
SV | El Salvador | El Salvador
SX | Sint Maarten (niederl. Teil) | Sint Maarten
SY | Syrien, Arabische Republik | Syrian Arab Republic
SZ | Swasiland | Swaziland
TC | Turks- und Caicosinseln | Turks and Caicos Islands
TD | Tschad | Chad
TF | Französische Süd- und Antarktisgebiete | French Southern and Antarctic Territories
TG | Togo | Togo
TH | Thailand | Thailand
TJ | Tadschikistan | Tadschikistan
TK | Tokelau | Tokelau
TL | Osttimor (Timor-Leste) | East Timor
TM | Turkmenistan | Turkmenistan
TN | Tunesien | Tunisia
TO | Tonga | Tonga
TR | Türkei | Turkey
TT | Trinidad und Tobago | Trinidad and Tobago
TV | Tuvalu | Tuvalu
TW | Taiwan | Taiwan
TZ | Tansania, Vereinigte Republik | Tanzania
UA | Ukraine | Ukraine
UG | Uganda | Uganda
UM | kleinere amerikanische Überseeinseln | United States Minor Outlying Islands
US | Vereinigte Staaten von Amerika | United States of America
UY | Uruguay | Uruguay
UZ | Usbekistan | Uzbekistan
VA | Vatikanstadt | Vatican City
VC | St. Vincent und die Grenadinen | Saint Vincent and the Grenadines
VE | Venezuela | Venezuela
VG | Britische Jungferninseln | British Virgin Islands
VI | Amerikanische Jungferninseln | American Virgin Islands
VN | Vietnam | Vietnam
VU | Vanuatu | Vanuatu
WF | Wallis und Futuna Inseln | Wallis and Futuna Islands
WS | Samoa | Samoa
YE | Jemen | Yemen
YT | Mayotte | Mayotte
ZA | Südafrika | South Africa
ZM | Sambia | Sambia
ZW | Simbabwe | Zimbabwe


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Types of detailed information
View with Navigation Tools
Introduction > Types of detailed information

The following info types can be used to describe the type of detail information:

1 = Milieu photo
2 = Item pictogram (type/item overview)
3 = Magnetic planner drawing (SVGs in top view)
4 = Version photo
5 = Version texture (leather type, ...)
6 = Manufacturer logo/product brand
7 = Colour consultancy (the versions are defined in an assessment procedure)
8 = Fabric sample book (PDF for fabric groups)
9 = Model description sheets (PDF below series)
10 = Installation instructions
11 = Marketing
12 = Miscellaneous
13 = Colour consultancy wall
14 = Colour consultancy floor


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Notes to the documentation
View with Navigation Tools


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
MODIFY_CONTENT_IDMP_3_0_1.xsd
View with Navigation Tools
Description

The purpose of this documentation is to describe the extension file with respect to trade-specific texts, detailed information and classifications for upholstery catalogues

Elements
Element | Description
T_MODIFY_CONTENT_CATALOG | This element offers an entry point for modified texts and designations, trade-specific media or additional classifications with respect to a catalogue in IDMP format. This data can be created by the trade as well as associations and similar, who would like to transfer texts, media and/or classifications that were adjusted for items and versions. These texts and media are only relevant for sales. For orders, the texts and designations of the original format must be used in IDMP format.If an element in the data pool references media, the reference must specify all relevant media, including those to be used by the base catalogue. This in particular applies to magnet planner information.
Complex Types
Complex Type | Description
languagetext | This data type is used to create multiple-language texts of any length.
languagetext30 | This data type is used to create multiple-language texts with a maximum length of 30 characters.
languagetext40 | This data type is used to create multiple-language texts with a maximum length of 40 characters.
languagetext60 | This data type is used to create multiple-language texts with a maximum length of 60 characters.

© 2020 All Rights Reserved.

Send comments on this topic.


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Element reference
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > Element reference


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Simple data types
View with Navigation Tools

A separate data type operator was created for the definition of specific conditions


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
T_MODIFY_CONTENT_CATALOG Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd : T_MODIFY_CONTENT_CATALOG Element
Description
This element offers an entry point for modified texts and designations, trade-specific media or additional classifications with respect to a catalogue in IDMP format. This data can be created by the trade as well as associations and similar, who would like to transfer texts, media and/or classifications that were adjusted for items and versions. These texts and media are only relevant for sales. For orders, the texts and designations of the original format must be used in IDMP format.If an element in the data pool references media, the reference must specify all relevant media, including those to be used by the base catalogue. This in particular applies to magnet planner information.
Namespace (none)
Diagram
FEATURE_DEFINITION Element SERIES Element GLOBAL_DEFINITION Element REF_CATALOG Element CATALOG Element Sequence T_MODIFY_CONTENT_CATALOG Element
Overview
T_MODIFY_CONTENT_CATALOG
This element offers an entry point for modified texts and designations, trade-specific media or additional classifications with respect to a catalogue in IDMP format. This data can be created by the trade as well as associations and similar, who would like to transfer texts, media and/or classifications that were adjusted for items and versions. These texts and media are only relevant for sales. For orders, the texts and designations of the original format must be used in IDMP format.If an element in the data pool references media, the reference must specify all relevant media, including those to be used by the base catalogue. This in particular applies to magnet planner information.
MAJOR required Restriction of xs:positiveInteger
The version number "MAJOR" specifies the format version the data pool is delivered. This major version number will only change in the case of a fundamental revision of the entire format.
The complete information about the format version in which a data pool is delivered consists of MAJOR, MINOR and REVISION. 		D positiveInteger
P
M [3:3]
MINOR required Restriction of xs:nonNegativeInteger
The sub-version number "MINOR" usually changes every year. If the main version MAJOR is modified, the subversion is reset to 0.
 D nonNegativeInteger
P
M [0:0]
REVISION required Restriction of xs:nonNegativeInteger
The revision number "REVISION" highlights changes during the year resultant from individual working groups. The revisions are not published if they are not concerned with necessary corrections. Revision is reset to 0 with each new MINOR sub-version number. D nonNegativeInteger
P
M [0:0]
FORMAT required Restriction of xs:string
This element is used to specify the manufacturer's industry code. The following industry codes are currently defined:

A = worktop manufacturers
B = bathroom furniture manufacturers
G = appliance manufacturers
K = kitchen furniture manufacturers
O = office furniture manufacturers
P = upholstered furniture manufacturers
S = sanitary products manufacturers
W = living room furniture manufacturers
Z = accessories manufacturers 		D string
P [ABGKOPSWZ]
M [1:1]
Sequence
CATALOG
This element is used to store administrative information concerning the data pool.
Sequence
CATALOG_IDENTIFICATION
This element is used to specify the catalogue's identifying characteristics.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data must be identical.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language key must be used. D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. For the currency key ISO currency ID is used.
Changing currencies within the same data pool are not permitted. Updates during the year must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
CATALOG_NUMBER Restriction of xs:string
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
CATALOG_NAME languagetext30 Complex Type
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FILE_ID Restriction of xs:boolean
This element is used to specify whether the data pool contains test data or released data.

0/false = test data
1/true = released data 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
This element is used to specify whether the provisions data are

B = block data with prices
K = catalogue data
V = block data without prices (fictional prices must be specified)
F = correction update.

 D string
P [BKVF]
M [1:1]
CATALOG_MERGE_TYPE optional xs:boolean

This element CATALOG_MERGE_TYPE is optional and contains boolean data with the following values:

0: The value if the element is not present; it means that this catalogue does not have to be part of a multi-manufacturer catalogue.

1: This catalogue is always part of a multi-manufacturer catalogue.

 D boolean
P
M
CATALOG_DATA_VERSION optional Restriction of xs:date
This element must be filled if the CATALOG_MARK (catalogue identifier) element contains the value F for correction update.

This element is used to enter the date of the base file (element DATA_VERSION) to which the correction update relates. 		D date
P
M
CATALOG_INFO optional languagetext Complex Type
This element is used to store the information texts.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
CATALOG_ID Restriction of xs:string

The manufacturer must enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.
This ID is required for identification in the case of multi-manufacturer catalogues.

A manufacturer catalogue must always have the same ID for the same dealership.

 D string
P
M [1:64]
CATALOG_VERSION Restriction of xs:positiveInteger
The manufacturer of the data records can assign a version number for the catalogue in this field. If a new modification data pool is released for a base catalogue, the value in CATALOG_VERSION must be increased. D positiveInteger
P
M [1:999999999]
FALL_BACK_LANGUAGE Restriction of xs:language
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified. The 2-digit ISO Language code must be used. D language
P [A-Z]{2}
M [2:2]
DETAIL_INFOS optional
This element serves to specify modified images on catalogue level, e.g. a manufacturer or catalogue logo or special label.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
RECEIVER_ID optional xs:string
The recipient ID is entered here. D string
P
M
REF_CATALOG
This references the catalogue to which the modified prices relate via the manufacturer's GLN and the CATALOG_ID of the base catalogue.
SUPPLIER_GLN_NO required Restriction of xs:string
This element is used to enter a unique global location number (GLN) of the manufacturer of the base catalogue. The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data. D string
P [0-9]{13}
M
CATALOG_ID required Restriction of xs:string

The unique ID (e.g. GUID) of a manufacturer is entered here in order to provide a unique identification of the base catalogue. The value must be identical to the value of CATALOG_ID under CATALOG in the base catalogue.

A manufacturer catalogue must always have the same ID for the same dealership.

 D string
P
M [1:64]
Sequence
CATALOG_DATA_VERSION Restriction of xs:date
This element is used to enter the date of the base file (element DATA_VERSION) to which the additional prices relate. D date
P
M
CATALOG_VERSION Restriction of xs:positiveInteger
The version no. of the base catalogue is specified here. D positiveInteger
P
M [1:999999999]
GLOBAL_DEFINITION optional
This element is used to specify data that is valid for the data pool (global information).
Sequence
DETAIL_INFOS optional
This element is used to specify the detail information (media) that is valid for the data pool (global information).
Sequence
DETAIL_INFO 1..∞
This element is used to specify URLs to detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute identifies a detailed information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
This element is used to classify detailed information.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
This element describes the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:14]
EXTERNAL_NAME optional languagetext Complex Type
This element contains the display name of the link (e.g. "sketch 4711").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

This element contains the text for a link note.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
URL
This element specifies the URL to the detailed information.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
SERIES

This element is used to specify all series of the catalogue/data pool with the elements assigned to them, e.g. product groups or items, for which modified texts, detail information or additional classifications are specified.

A series usually corresponds to a model.

Sequence
SERIE 1..1000000
This element is used to store a series together with the corresponding items. A series corresponds to a model. The numbers and designations stated here must correspond to those in the base catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the base catalogue. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
This attribute allows for the specification of series with a freely-defined sorting order.
If a SEQUENCE_NO is specified for one series, a SEQUENCE_NO must be specified for all series. It must reconcile with the base catalogue. 		D positiveInteger
P
M
Sequence
SERIES_NAME
This element is used to specify the series name.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
PRODUCT_GROUPS
This element is used to specify the product groups. They must correspond to those in the base catalogue.Product groups are used to combine articles with identical version types (e.g. upholstered furniture with armrests).
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups.
Sequence
ITEMS

This element is used to specify all items of a product group for which the texts, detail information or classifications are modified for the specific trade.

Sequence
ITEM 1..∞

This element is used to specify items in accordance with the base catalogue. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 2) attributes.

Path 1: SERIES/SERIE/SERIE_NO
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

DETAIL_INFOS optional
This element is used to specify trade-specific detailed media information, such as milieu photos, PDFs or video links for the series. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
FEATURE_DEFINITION
This element is used to specify option-specific information that are modified from the base catalogue for the specific trade. These modifications must only affect sales, not the order.
Sequence
FEATURES

This element is used to define the features (FEATURE) and the associated options for which a trade-specific modification is applied. Only the features needed for correctly mapping the data pool are defined.

Further information about features can be found in the Introduction in section "features"

Sequence
FEATURE 1..∞
This element is used to modify an option type from the base catalogue for the specific trade.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a feature. The number must correspond to those in the base catalogue. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
It is a container element in which the possible variations of a feature to be modified for the specific trade are stored.
Sequence
OPTION 1..∞
This element is used to define a version for the superordinate version type.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option from the base catalogue. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order that must correspond to the base catalogue. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
This element is used to define a trade-specific option text. The original text must be used for orders.
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a trade-specific general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.
DETAIL_INFOS optional
This element is used to assign modified media. It is possible to assign a number of detail information to one version, and each image of the version can then be assigned to specific series or items. The respective image will then only be displayed for the corresponding series or item.
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
This element contains trade-specific texts for features.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element is used to specify a manufacturer-specific sorting for the features. It must reconcile with the base catalogue.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options of the base catalogue (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1:FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ of the base catalogue 		D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
MAJOR Restriction of xs:positiveInteger required
The version number "MAJOR" specifies the format version the data pool is delivered. This major version number will only change in the case of a fundamental revision of the entire format.
The complete information about the format version in which a data pool is delivered consists of MAJOR, MINOR and REVISION. 		D positiveInteger
P
M [3:3]
MINOR Restriction of xs:nonNegativeInteger required
The sub-version number "MINOR" usually changes every year. If the main version MAJOR is modified, the subversion is reset to 0.
 D nonNegativeInteger
P
M [0:0]
REVISION Restriction of xs:nonNegativeInteger required
The revision number "REVISION" highlights changes during the year resultant from individual working groups. The revisions are not published if they are not concerned with necessary corrections. Revision is reset to 0 with each new MINOR sub-version number. D nonNegativeInteger
P
M [0:0]
FORMAT Restriction of xs:string required
This element is used to specify the manufacturer's industry code. The following industry codes are currently defined:

A = worktop manufacturers
B = bathroom furniture manufacturers
G = appliance manufacturers
K = kitchen furniture manufacturers
O = office furniture manufacturers
P = upholstered furniture manufacturers
S = sanitary products manufacturers
W = living room furniture manufacturers
Z = accessories manufacturers 		D string
P [ABGKOPSWZ]
M [1:1]
Source
<xs:element name="T_MODIFY_CONTENT_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version 2.3 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CATALOG_IDENTIFICATION">
              <xs:annotation>
                <xs:documentation>100--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:language">
                        <xs:pattern value="[A-Z]{2}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="CURRENCY_KEY">
                    <xs:annotation>
                      <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[A-Z]{1,3}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CATALOG_NUMBER">
              <xs:annotation>
                <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="10" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_NAME" type="languagetext30">
              <xs:annotation>
                <xs:documentation>100--10--Katalog_Name</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="FILE_ID">
              <xs:annotation>
                <xs:documentation>100--14--Datei_ID</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MARK">
              <xs:annotation>
                <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[BKVF]" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
                <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_DATA_VERSION" minOccurs="0">
              <xs:annotation>
                <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>110--3--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="CATALOG_ID">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Katalog_ID
                /Hermann Balke 9.06.2013
                neu in 2.3
                hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren
                </xs:documentation>
                <xs:documentation> minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="1" />
                  <xs:maxLength value="64" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_VERSION">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
                <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FALL_BACK_LANGUAGE">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
                <xs:documentation>K. Richter 15.08.2017</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
                <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW  </xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW </xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="RECEIVER_ID" type="xs:string" minOccurs="0" />
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="REF_CATALOG">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CATALOG_DATA_VERSION">
              <xs:annotation>
                <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="CATALOG_VERSION">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
                <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:minInclusive value="1" />
                  <xs:maxInclusive value="999999999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SUPPLIER_GLN_NO" use="required">
            <xs:annotation>
              <xs:documentation>GLN des Herstellers</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[0-9]{13}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="CATALOG_ID" use="required">
            <xs:annotation>
              <xs:documentation>Katalogidentifikator</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="64" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="GLOBAL_DEFINITION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASSIFICATION">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="INFO_TYPE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
12.02.2013/Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:maxInclusive value="14" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="URL">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT" type="xs:anyURI">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="HASH_VALUE">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:minLength value="32" />
                                          <xs:maxLength value="32" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="LAYER" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:positiveInteger">
                              <xs:pattern value="[1-6]0" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="SERIES">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE" maxOccurs="1000000">
              <xs:annotation>
                <xs:documentation>200--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                <xs:documentation>maxOccours geändert, K.Richter 23.11.2015</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIES_NAME">
                    <xs:annotation>
                      <xs:documentation>200--3--Serienname</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>200--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>200--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="PRODUCT_GROUPS">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEMS">
                                <xs:annotation>
                                  <xs:documentation>400--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>400--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ITEM_TEXT" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--1--Satzart</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SHORT_TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT_LINE" maxOccurs="3">
                                                              <xs:annotation>
                                                                <xs:documentation>410--0--NEW</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:complexType>
                                                                <xs:sequence>
                                                                  <xs:element name="TEXT">
                                                                    <xs:annotation>
                                                                      <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                    </xs:annotation>
                                                                    <xs:simpleType>
                                                                      <xs:restriction base="xs:string">
                                                                        <xs:pattern value="[\S ]{1,30}" />
                                                                      </xs:restriction>
                                                                    </xs:simpleType>
                                                                  </xs:element>
                                                                </xs:sequence>
                                                                <xs:attribute name="SEQUENCE_NO" use="required">
                                                                  <xs:annotation>
                                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                                  </xs:annotation>
                                                                  <xs:simpleType>
                                                                    <xs:restriction base="xs:positiveInteger" />
                                                                  </xs:simpleType>
                                                                </xs:attribute>
                                                              </xs:complexType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:language">
                                                                <xs:pattern value="[A-Z]{2}" />
                                                              </xs:restriction>
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                                <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                                  <xs:annotation>
                                                    <xs:documentation>410--5--Texttype</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  </xs:annotation>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS" minOccurs="0">
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="ECLASS_NO">
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:nonNegativeInteger">
                                                            <xs:totalDigits value="8" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="INDIVIDUAL" minOccurs="0">
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="CLASSIFICATION_KEY">
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string" />
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="DETAIL_INFOS" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:maxInclusive value="999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="DECISION_NO" use="optional">
                                                      <xs:annotation>
                                                        <xs:documentation>291--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger">
                                                          <xs:minInclusive value="1" />
                                                          <xs:maxInclusive value="9999999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>400--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="SEQUENCE_NO">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>200--1--Satzart</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
                  <xs:annotation>
                    <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
                    <xs:documentation>K. Richter 26.02.2015</xs:documentation>
                    <xs:documentation>Datentyp auf positiveInteger gesetzt, K. Richter 12.06.2015</xs:documentation>
                  </xs:annotation>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_DEFINITION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURES">
              <xs:annotation>
                <xs:documentation>250--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="FEATURE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="OPTION_TEXT" type="languagetext60">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="VALID_FROM" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="VALID_UNTIL" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:date" />
                                      </xs:simpleType>
                                    </xs:element>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                                <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>406--0--NEW</xs:documentation>
                                                    <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:attribute name="SERIE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:nonNegativeInteger">
                                                          <xs:minInclusive value="0" />
                                                          <xs:maxInclusive value="999999" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                    <xs:attribute name="TYPE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>406--0--NEW</xs:documentation>
                                                        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:string">
                                                          <xs:minLength value="1" />
                                                          <xs:maxLength value="30" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                                  <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="OPTION_FREETEXT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                                        <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:boolean" />
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="OPTION_KEY" use="required">
                                    <xs:annotation>
                                      <xs:documentation>260--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FEATURE_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>250--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="SEQUENCE_NO">
                          <xs:annotation>
                            <xs:documentation>250--4--Sortierung</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:minInclusive value="0" />
                              <xs:maxInclusive value="999" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="FEATURE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>250--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="MAJOR" use="required">
      <xs:annotation>
        <xs:documentation>100--3--Versionsnummer</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="3" />
          <xs:maxInclusive value="3" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="MINOR" use="required">
      <xs:annotation>
        <xs:documentation>100--4--Sub_Versions_Nr</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012, K. Richter 23.11.2015</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="0" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="REVISION" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>Verlegung der Versionierung AK 28.02.2012</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="0" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="FORMAT" use="required">
      <xs:annotation>
        <xs:documentation>100--8--Branchen_ID</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[ABGKOPSWZ]" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element : CATALOG Element
Description
This element is used to store administrative information concerning the data pool.
Namespace (none)
Diagram
RECEIVER_ID Element DETAIL_INFOS Element FALL_BACK_LANGUAGE Element CATALOG_VERSION Element CATALOG_ID Element LANGUAGE Element Sequence CATALOG_INFO Element CATALOG_DATA_VERSION Element CATALOG_MERGE_TYPE Element CATALOG_MARK Element FILE_ID Element LANGUAGE Element Sequence CATALOG_NAME Element CATALOG_NUMBER Element CATALOG_IDENTIFICATION Element Sequence CATALOG Element
Overview
CATALOG
This element is used to store administrative information concerning the data pool.
Sequence
CATALOG_IDENTIFICATION
This element is used to specify the catalogue's identifying characteristics.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data must be identical.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language key must be used. D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. For the currency key ISO currency ID is used.
Changing currencies within the same data pool are not permitted. Updates during the year must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
CATALOG_NUMBER Restriction of xs:string
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
CATALOG_NAME languagetext30 Complex Type
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FILE_ID Restriction of xs:boolean
This element is used to specify whether the data pool contains test data or released data.

0/false = test data
1/true = released data 		D boolean
P
M
CATALOG_MARK Restriction of xs:string
This element is used to specify whether the provisions data are

B = block data with prices
K = catalogue data
V = block data without prices (fictional prices must be specified)
F = correction update.

 D string
P [BKVF]
M [1:1]
CATALOG_MERGE_TYPE optional xs:boolean

This element CATALOG_MERGE_TYPE is optional and contains boolean data with the following values:

0: The value if the element is not present; it means that this catalogue does not have to be part of a multi-manufacturer catalogue.

1: This catalogue is always part of a multi-manufacturer catalogue.

 D boolean
P
M
CATALOG_DATA_VERSION optional Restriction of xs:date
This element must be filled if the CATALOG_MARK (catalogue identifier) element contains the value F for correction update.

This element is used to enter the date of the base file (element DATA_VERSION) to which the correction update relates. 		D date
P
M
CATALOG_INFO optional languagetext Complex Type
This element is used to store the information texts.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
CATALOG_ID Restriction of xs:string

The manufacturer must enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.
This ID is required for identification in the case of multi-manufacturer catalogues.

A manufacturer catalogue must always have the same ID for the same dealership.

 D string
P
M [1:64]
CATALOG_VERSION Restriction of xs:positiveInteger
The manufacturer of the data records can assign a version number for the catalogue in this field. If a new modification data pool is released for a base catalogue, the value in CATALOG_VERSION must be increased. D positiveInteger
P
M [1:999999999]
FALL_BACK_LANGUAGE Restriction of xs:language
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified. The 2-digit ISO Language code must be used. D language
P [A-Z]{2}
M [2:2]
DETAIL_INFOS optional
This element serves to specify modified images on catalogue level, e.g. a manufacturer or catalogue logo or special label.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
RECEIVER_ID optional xs:string
The recipient ID is entered here. D string
P
M
Source
<xs:element name="CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version 2.3 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG_IDENTIFICATION">
        <xs:annotation>
          <xs:documentation>100--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:language">
                  <xs:pattern value="[A-Z]{2}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="CURRENCY_KEY">
              <xs:annotation>
                <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[A-Z]{1,3}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CATALOG_NUMBER">
        <xs:annotation>
          <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="10" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_NAME" type="languagetext30">
        <xs:annotation>
          <xs:documentation>100--10--Katalog_Name</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="FILE_ID">
        <xs:annotation>
          <xs:documentation>100--14--Datei_ID</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MARK">
        <xs:annotation>
          <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[BKVF]" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
          <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_DATA_VERSION" minOccurs="0">
        <xs:annotation>
          <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>110--3--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="CATALOG_ID">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Katalog_ID
                /Hermann Balke 9.06.2013
                neu in 2.3
                hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren
                </xs:documentation>
          <xs:documentation> minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="1" />
            <xs:maxLength value="64" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_VERSION">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
          <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FALL_BACK_LANGUAGE">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
          <xs:documentation>K. Richter 15.08.2017</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
          <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW  </xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW </xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="RECEIVER_ID" type="xs:string" minOccurs="0" />
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG_IDENTIFICATION Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_IDENTIFICATION Element
Description
This element is used to specify the catalogue's identifying characteristics.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data must be identical.
Namespace (none)
Diagram
CURRENCY_KEY Element ISO_LANGUAGE_ID Element Sequence CATALOG_IDENTIFICATION Element
Overview
CATALOG_IDENTIFICATION
This element is used to specify the catalogue's identifying characteristics.
- ISO_LANGUAGE_ID
- CURRENCY_KEY

If the contents of these fields in an updated catalogue are different from the base file, it is not easily possible to update an existing catalogue.
The currencies used in the catalogue data must be identical.
Sequence
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language key must be used. D language
P [A-Z]{2}
M [2:2]
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. For the currency key ISO currency ID is used.
Changing currencies within the same data pool are not permitted. Updates during the year must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
Source
<xs:element name="CATALOG_IDENTIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:language">
            <xs:pattern value="[A-Z]{2}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="CURRENCY_KEY">
        <xs:annotation>
          <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[A-Z]{1,3}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
ISO_LANGUAGE_ID Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : ISO_LANGUAGE_ID Element
Description
The language code defines the language in which the texts in the data pool were created. The ISO language key must be used. D language
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:language
Diagram
ISO_LANGUAGE_ID Element
Overview
ISO_LANGUAGE_ID 1..∞ Restriction of xs:language
The language code defines the language in which the texts in the data pool were created. The ISO language key must be used. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="ISO_LANGUAGE_ID" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CURRENCY_KEY Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element > CATALOG_IDENTIFICATION Element : CURRENCY_KEY Element
Description
This element is used to specify the currency key for the prices stated in the data pool. For the currency key ISO currency ID is used.
Changing currencies within the same data pool are not permitted. Updates during the year must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
Namespace (none)
Type
Restriction of xs:string
Diagram
CURRENCY_KEY Element
Overview
CURRENCY_KEY Restriction of xs:string
This element is used to specify the currency key for the prices stated in the data pool. For the currency key ISO currency ID is used.
Changing currencies within the same data pool are not permitted. Updates during the year must be delivered in the same currency as the base file. 		D string
P [A-Z]{1,3}
M [1:3]
Source
<xs:element name="CURRENCY_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--7--Waehrungsschluessel</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[A-Z]{1,3}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG_IDENTIFICATION Element | CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG_NUMBER Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_NUMBER Element
Description
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_NUMBER Element
Overview
CATALOG_NUMBER Restriction of xs:string
This element is used to specify the catalogue number of the catalogue that is mapped by the data pool. The catalogue number is a manufacturer-specific identifier. D string
P
M [1:10]
Source
<xs:element name="CATALOG_NUMBER" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--9--Katalog_Nummer</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="10" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG_NAME Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_NAME Element
Description
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.
Namespace (none)
Type
languagetext30 Complex Type
Diagram
LANGUAGE Element Sequence CATALOG_NAME Element
Overview
CATALOG_NAME languagetext30 Complex Type
This element is used to specify the catalogue name of the data pool. This element serves as the basis for displaying the catalogue name in the software products. Catalogue names that include the year are permitted.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="CATALOG_NAME" type="languagetext30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--10--Katalog_Name</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
FILE_ID Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : FILE_ID Element
Description
This element is used to specify whether the data pool contains test data or released data.

0/false = test data
1/true = released data 		D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
FILE_ID Element
Overview
FILE_ID Restriction of xs:boolean
This element is used to specify whether the data pool contains test data or released data.

0/false = test data
1/true = released data 		D boolean
P
M
Source
<xs:element name="FILE_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--14--Datei_ID</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG_MARK Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_MARK Element
Description
This element is used to specify whether the provisions data are

B = block data with prices
K = catalogue data
V = block data without prices (fictional prices must be specified)
F = correction update.

 D string
P [BKVF]
M [1:1]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_MARK Element
Overview
CATALOG_MARK Restriction of xs:string
This element is used to specify whether the provisions data are

B = block data with prices
K = catalogue data
V = block data without prices (fictional prices must be specified)
F = correction update.

 D string
P [BKVF]
M [1:1]
Source
<xs:element name="CATALOG_MARK" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--43--Katalogkennzeichen</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[BKVF]" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG_MERGE_TYPE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_MERGE_TYPE Element
Description

This element CATALOG_MERGE_TYPE is optional and contains boolean data with the following values:

0: The value if the element is not present; it means that this catalogue does not have to be part of a multi-manufacturer catalogue.

1: This catalogue is always part of a multi-manufacturer catalogue.

 D boolean
P
M
Namespace (none)
Type
xs:boolean
Diagram
CATALOG_MERGE_TYPE Element
Overview
CATALOG_MERGE_TYPE optional xs:boolean

This element CATALOG_MERGE_TYPE is optional and contains boolean data with the following values:

0: The value if the element is not present; it means that this catalogue does not have to be part of a multi-manufacturer catalogue.

1: This catalogue is always part of a multi-manufacturer catalogue.

 D boolean
P
M
Source
<xs:element name="CATALOG_MERGE_TYPE" type="xs:boolean" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Kennzeichen, ob Teil eines Multiherstellerkataloges</xs:documentation>
    <xs:documentation>1: immer Teil eines Multiherstellerkataloges</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG_DATA_VERSION Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_DATA_VERSION Element
Description
This element must be filled if the CATALOG_MARK (catalogue identifier) element contains the value F for correction update.

This element is used to enter the date of the base file (element DATA_VERSION) to which the correction update relates. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
CATALOG_DATA_VERSION Element
Overview
CATALOG_DATA_VERSION optional Restriction of xs:date
This element must be filled if the CATALOG_MARK (catalogue identifier) element contains the value F for correction update.

This element is used to enter the date of the base file (element DATA_VERSION) to which the correction update relates. 		D date
P
M
Source
<xs:element name="CATALOG_DATA_VERSION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG_INFO Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_INFO Element
Description
This element is used to store the information texts.
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence CATALOG_INFO Element
Overview
CATALOG_INFO optional languagetext Complex Type
This element is used to store the information texts.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="CATALOG_INFO" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>110--3--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG_ID Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_ID Element
Description

The manufacturer must enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.
This ID is required for identification in the case of multi-manufacturer catalogues.

A manufacturer catalogue must always have the same ID for the same dealership.

 D string
P
M [1:64]
Namespace (none)
Type
Restriction of xs:string
Diagram
CATALOG_ID Element
Overview
CATALOG_ID Restriction of xs:string

The manufacturer must enter a unique ID (e.g. GUID) that unequivocally identifies the catalogue here.
This ID is required for identification in the case of multi-manufacturer catalogues.

A manufacturer catalogue must always have the same ID for the same dealership.

 D string
P
M [1:64]
Source
<xs:element name="CATALOG_ID" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Katalog_ID
                /Hermann Balke 9.06.2013
                neu in 2.3
                hier kann der Hersteller eine eindeutige ID (z.B.GUID)eingeben, um den Katalog eindeutig zu identifizieren
                </xs:documentation>
    <xs:documentation> minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="1" />
      <xs:maxLength value="64" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG_VERSION Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : CATALOG_VERSION Element
Description
The manufacturer of the data records can assign a version number for the catalogue in this field. If a new modification data pool is released for a base catalogue, the value in CATALOG_VERSION must be increased. D positiveInteger
P
M [1:999999999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
CATALOG_VERSION Element
Overview
CATALOG_VERSION Restriction of xs:positiveInteger
The manufacturer of the data records can assign a version number for the catalogue in this field. If a new modification data pool is released for a base catalogue, the value in CATALOG_VERSION must be increased. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="CATALOG_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
    <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
FALL_BACK_LANGUAGE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : FALL_BACK_LANGUAGE Element
Description
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified. The 2-digit ISO Language code must be used. D language
P [A-Z]{2}
M [2:2]
Namespace (none)
Type
Restriction of xs:language
Diagram
FALL_BACK_LANGUAGE Element
Overview
FALL_BACK_LANGUAGE Restriction of xs:language
This element corresponds to the language code that defines the language in which the data pool texts were created if no language identifier for multi-language texts is specified. The 2-digit ISO Language code must be used. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="FALL_BACK_LANGUAGE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--6--Sprachenschluessel für Sprachen, die nicht angegeben sind</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:language">
      <xs:pattern value="[A-Z]{2}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
DETAIL_INFOS Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : DETAIL_INFOS Element
Description
This element serves to specify modified images on catalogue level, e.g. a manufacturer or catalogue logo or special label.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element serves to specify modified images on catalogue level, e.g. a manufacturer or catalogue logo or special label.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 07.05.2014, K. Richter</xs:documentation>
    <xs:documentation xml:lang="DE">kann z. B. für Logos genutzt werden</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW  </xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW </xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
DETAIL_INFO_REF Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element is used to reference the detailed information.
Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW  </xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW </xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
RECEIVER_ID Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > CATALOG Element : RECEIVER_ID Element
Description
The recipient ID is entered here. D string
P
M
Namespace (none)
Type
xs:string
Diagram
RECEIVER_ID Element
Overview
RECEIVER_ID optional xs:string
The recipient ID is entered here. D string
P
M
Source
<xs:element name="RECEIVER_ID" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
REF_CATALOG Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element : REF_CATALOG Element
Description
This references the catalogue to which the modified prices relate via the manufacturer's GLN and the CATALOG_ID of the base catalogue.
Namespace (none)
Diagram
CATALOG_VERSION Element CATALOG_DATA_VERSION Element Sequence REF_CATALOG Element
Overview
REF_CATALOG
This references the catalogue to which the modified prices relate via the manufacturer's GLN and the CATALOG_ID of the base catalogue.
SUPPLIER_GLN_NO required Restriction of xs:string
This element is used to enter a unique global location number (GLN) of the manufacturer of the base catalogue. The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data. D string
P [0-9]{13}
M
CATALOG_ID required Restriction of xs:string

The unique ID (e.g. GUID) of a manufacturer is entered here in order to provide a unique identification of the base catalogue. The value must be identical to the value of CATALOG_ID under CATALOG in the base catalogue.

A manufacturer catalogue must always have the same ID for the same dealership.

 D string
P
M [1:64]
Sequence
CATALOG_DATA_VERSION Restriction of xs:date
This element is used to enter the date of the base file (element DATA_VERSION) to which the additional prices relate. D date
P
M
CATALOG_VERSION Restriction of xs:positiveInteger
The version no. of the base catalogue is specified here. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
SUPPLIER_GLN_NO Restriction of xs:string required
This element is used to enter a unique global location number (GLN) of the manufacturer of the base catalogue. The GLN allows for an unequivocal assignment of companies or business units, e.g. for the automated electronic exchange of data. D string
P [0-9]{13}
M
CATALOG_ID Restriction of xs:string required

The unique ID (e.g. GUID) of a manufacturer is entered here in order to provide a unique identification of the base catalogue. The value must be identical to the value of CATALOG_ID under CATALOG in the base catalogue.

A manufacturer catalogue must always have the same ID for the same dealership.

 D string
P
M [1:64]
Source
<xs:element name="REF_CATALOG" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CATALOG_DATA_VERSION">
        <xs:annotation>
          <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="CATALOG_VERSION">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
          <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:minInclusive value="1" />
            <xs:maxInclusive value="999999999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SUPPLIER_GLN_NO" use="required">
      <xs:annotation>
        <xs:documentation>GLN des Herstellers</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:pattern value="[0-9]{13}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="CATALOG_ID" use="required">
      <xs:annotation>
        <xs:documentation>Katalogidentifikator</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="64" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG_DATA_VERSION Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > REF_CATALOG Element : CATALOG_DATA_VERSION Element
Description
This element is used to enter the date of the base file (element DATA_VERSION) to which the additional prices relate. D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
CATALOG_DATA_VERSION Element
Overview
CATALOG_DATA_VERSION Restriction of xs:date
This element is used to enter the date of the base file (element DATA_VERSION) to which the additional prices relate. D date
P
M
Source
<xs:element name="CATALOG_DATA_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>100--46--Katalog_Daten_Version</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
REF_CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CATALOG_VERSION Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > REF_CATALOG Element : CATALOG_VERSION Element
Description
The version no. of the base catalogue is specified here. D positiveInteger
P
M [1:999999999]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
CATALOG_VERSION Element
Overview
CATALOG_VERSION Restriction of xs:positiveInteger
The version no. of the base catalogue is specified here. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="CATALOG_VERSION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Katalog_Version
                /Hermann Balke 16.07.2013
                neu in 2.3
                hier kann der Hersteller eine Versions-Nr. für den Katalog vergeben
                </xs:documentation>
    <xs:documentation>  minOccurs  0 entfernt, K. Richter 08.06..2015 </xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:minInclusive value="1" />
      <xs:maxInclusive value="999999999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
REF_CATALOG Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
GLOBAL_DEFINITION Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element : GLOBAL_DEFINITION Element
Description
This element is used to specify data that is valid for the data pool (global information).
Namespace (none)
Diagram
DETAIL_INFOS Element Sequence GLOBAL_DEFINITION Element
Overview
GLOBAL_DEFINITION optional
This element is used to specify data that is valid for the data pool (global information).
Sequence
DETAIL_INFOS optional
This element is used to specify the detail information (media) that is valid for the data pool (global information).
Sequence
DETAIL_INFO 1..∞
This element is used to specify URLs to detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute identifies a detailed information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
This element is used to classify detailed information.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
This element describes the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:14]
EXTERNAL_NAME optional languagetext Complex Type
This element contains the display name of the link (e.g. "sketch 4711").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

This element contains the text for a link note.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
URL
This element specifies the URL to the detailed information.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
Source
<xs:element name="GLOBAL_DEFINITION" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>AK 28.02.2012 Optional gemacht da alle Unterknoten ebenfalls optional. Bei Geraetedateien kein Inhalt.</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASSIFICATION">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="INFO_TYPE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
12.02.2013/Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:maxInclusive value="14" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="URL">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT" type="xs:anyURI">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="HASH_VALUE">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:minLength value="32" />
                                    <xs:maxLength value="32" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="LAYER" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:positiveInteger">
                        <xs:pattern value="[1-6]0" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
DETAIL_INFOS Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element : DETAIL_INFOS Element
Description
This element is used to specify the detail information (media) that is valid for the data pool (global information).
Namespace (none)
Diagram
DETAIL_INFO Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element is used to specify the detail information (media) that is valid for the data pool (global information).
Sequence
DETAIL_INFO 1..∞
This element is used to specify URLs to detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute identifies a detailed information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
This element is used to classify detailed information.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
This element describes the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:14]
EXTERNAL_NAME optional languagetext Complex Type
This element contains the display name of the link (e.g. "sketch 4711").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

This element contains the text for a link note.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
URL
This element specifies the URL to the detailed information.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" maxOccurs="1" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASSIFICATION">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="INFO_TYPE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
12.02.2013/Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:maxInclusive value="14" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="URL">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT" type="xs:anyURI">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="HASH_VALUE">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:minLength value="32" />
                              <xs:maxLength value="32" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="LAYER" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:positiveInteger">
                  <xs:pattern value="[1-6]0" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
DETAIL_INFO Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element : DETAIL_INFO Element
Description
This element is used to specify URLs to detailed information.
Namespace (none)
Diagram
LAYER Element URL Element LANGUAGE Element Sequence TOOL_TIP Element LANGUAGE Element Sequence INTERNAL_NAME Element LANGUAGE Element Sequence EXTERNAL_NAME Element INFO_TYPE Element CLASSIFICATION Element Sequence DETAIL_INFO Element
Overview
DETAIL_INFO 1..∞
This element is used to specify URLs to detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute identifies a detailed information. D positiveInteger
P
M [1:999999999]
Sequence
CLASSIFICATION Restriction of xs:string
This element is used to classify detailed information.

 D string
P
M
INFO_TYPE Restriction of xs:positiveInteger
This element describes the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:14]
EXTERNAL_NAME optional languagetext Complex Type
This element contains the display name of the link (e.g. "sketch 4711").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
INTERNAL_NAME optional languagetext40 Complex Type
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
TOOL_TIP optional languagetext Complex Type

This element contains the text for a link note.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
URL
This element specifies the URL to the detailed information.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
LAYER optional Restriction of xs:positiveInteger

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute identifies a detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO" minOccurs="1" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASSIFICATION">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="INFO_TYPE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
12.02.2013/Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:maxInclusive value="14" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="TOOL_TIP" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="URL">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT" type="xs:anyURI">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="HASH_VALUE">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:minLength value="32" />
                        <xs:maxLength value="32" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="LAYER" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:positiveInteger">
            <xs:pattern value="[1-6]0" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                        30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CLASSIFICATION Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : CLASSIFICATION Element
Description
This element is used to classify detailed information.

 D string
P
M
Namespace (none)
Type
Restriction of xs:string
Diagram
CLASSIFICATION Element
Overview
CLASSIFICATION Restriction of xs:string
This element is used to classify detailed information.

 D string
P
M
Source
<xs:element name="CLASSIFICATION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
INFO_TYPE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INFO_TYPE Element
Description
This element describes the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:14]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
INFO_TYPE Element
Overview
INFO_TYPE Restriction of xs:positiveInteger
This element describes the type of detailed information.

The values that can be assigned to the information types can be found in the corresponding table in the introduction. 		D positiveInteger
P
M [1:14]
Source
<xs:element name="INFO_TYPE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Version 2.3
01.07.2013 Hermann Balke
1 = Milieufoto
2 = Artikelpictogramm (Type/Artikelübersicht)
3 = Magnetplanerzeichnung (SVGs in Draufsicht)
4 = Variante Foto
5 = Variante Textur(Ledersorte, ....)
6 = Logo Hersteller/Produktmarke
7 = Farbberatung (über ein Prüfverfahren werden die Varianten definiert)
8 = Stoffpass (PDF an den Stoffgruppen)
9 = Modellbeschreibungsblätter (PDF unterhalb der Serie)
10 = Montageanleitung
11 = Marketing
12 = diverse
13 = Farbberatung Wand
14 = Farbberatung Boden
12.02.2013/Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:maxInclusive value="14" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
EXTERNAL_NAME Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : EXTERNAL_NAME Element
Description
This element contains the display name of the link (e.g. "sketch 4711").
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence EXTERNAL_NAME Element
Overview
EXTERNAL_NAME optional languagetext Complex Type
This element contains the display name of the link (e.g. "sketch 4711").
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="EXTERNAL_NAME" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
INTERNAL_NAME Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : INTERNAL_NAME Element
Description
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Namespace (none)
Type
languagetext40 Complex Type
Diagram
LANGUAGE Element Sequence INTERNAL_NAME Element
Overview
INTERNAL_NAME optional languagetext40 Complex Type
A more detailed description of the link can be included here.

This information is not intended for disclosure to the dealership, but to provide further information to the software houses.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:element name="INTERNAL_NAME" type="languagetext40" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
TOOL_TIP Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : TOOL_TIP Element
Description

This element contains the text for a link note.

Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence TOOL_TIP Element
Overview
TOOL_TIP optional languagetext Complex Type

This element contains the text for a link note.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="TOOL_TIP" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
URL Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : URL Element
Description
This element specifies the URL to the detailed information.
Namespace (none)
Diagram
LANGUAGE Element Sequence URL Element
Overview
URL
This element specifies the URL to the detailed information.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
Source
<xs:element name="URL" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT" type="xs:anyURI">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="HASH_VALUE">
              <xs:annotation>
                <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:minLength value="32" />
                  <xs:maxLength value="32" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
LANGUAGE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element : LANGUAGE Element
Description
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
Namespace (none)
Diagram
HASH_VALUE Element TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute is used to specify the ISO code of the language in which the text is stored. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:anyURI">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="HASH_VALUE">
        <xs:annotation>
          <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:minLength value="32" />
            <xs:maxLength value="32" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : TEXT Element
Description
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
Namespace (none)
Type
xs:anyURI
Diagram
TEXT Element
Overview
TEXT xs:anyURI
This element is used to store the URI for the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D anyURI
P
M [1:1024]
Source
<xs:element name="TEXT" type="xs:anyURI" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
HASH_VALUE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element > URL Element > LANGUAGE Element : HASH_VALUE Element
Description
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
Namespace (none)
Type
Restriction of xs:string
Diagram
HASH_VALUE Element
Overview
HASH_VALUE Restriction of xs:string
The image is displayed in encrypted form here.The HASH_VALUE must have exactly 32 characters and must be MD5-encrypted.
This will enable any service provider to determine whether the image has already been downloaded or not. 		D string
P
M [32:32]
Source
<xs:element name="HASH_VALUE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Hier wird das Bild verschlüsselt dargestellt.
Somit kann jeder Dienstleister feststellen, ob das Bild schonmal heruntergeladen wurde oder nicht.
14.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:minLength value="32" />
      <xs:maxLength value="32" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | URL Element | DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
LAYER Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > GLOBAL_DEFINITION Element > DETAIL_INFOS Element > DETAIL_INFO Element : LAYER Element
Description

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
Namespace (none)
Type
Restriction of xs:positiveInteger
Diagram
LAYER Element
Overview
LAYER optional Restriction of xs:positiveInteger

This element is used to place add-on items, e.g. headrests.

This element is only allowed for SVG files.

Within the outline type of a SVG, the following applies:

There is no overlapping of any areas designated by our clients within the same layer.

The following values apply to the element:

10 Carpet

20 Sofa/furniture/table (default value)

30 Cushion

40 Decorative cushion

50 Headrest

60 Plate/ throw

 D positiveInteger
P [1-6]0
M [10:60]
Source
<xs:element name="LAYER" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">Layer gibt es nur für SVG's:
                                                -innerhalb der Outline einer SVG gilt:
                                                Es gibt keine Überlappungen der durch Outlines gekennzeichneten Flächen innerhalb des selben Layers.
                          10=Teppich, 20=Sofa, Möbel,Tisch(Default-Wert),30 Kissen,40 Dekorkissen, 50 Kopfstützen, 60 Plate/Überwurf
                          24.06.2015 /Balke, K. Richter 23.11.2015</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:positiveInteger">
      <xs:pattern value="[1-6]0" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
DETAIL_INFO Element | DETAIL_INFOS Element | GLOBAL_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
SERIES Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element : SERIES Element
Description

This element is used to specify all series of the catalogue/data pool with the elements assigned to them, e.g. product groups or items, for which modified texts, detail information or additional classifications are specified.

A series usually corresponds to a model.

Namespace (none)
Diagram
SERIE Element Sequence SERIES Element
Overview
SERIES

This element is used to specify all series of the catalogue/data pool with the elements assigned to them, e.g. product groups or items, for which modified texts, detail information or additional classifications are specified.

A series usually corresponds to a model.

Sequence
SERIE 1..1000000
This element is used to store a series together with the corresponding items. A series corresponds to a model. The numbers and designations stated here must correspond to those in the base catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the base catalogue. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
This attribute allows for the specification of series with a freely-defined sorting order.
If a SEQUENCE_NO is specified for one series, a SEQUENCE_NO must be specified for all series. It must reconcile with the base catalogue. 		D positiveInteger
P
M
Sequence
SERIES_NAME
This element is used to specify the series name.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
PRODUCT_GROUPS
This element is used to specify the product groups. They must correspond to those in the base catalogue.Product groups are used to combine articles with identical version types (e.g. upholstered furniture with armrests).
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups.
Sequence
ITEMS

This element is used to specify all items of a product group for which the texts, detail information or classifications are modified for the specific trade.

Sequence
ITEM 1..∞

This element is used to specify items in accordance with the base catalogue. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 2) attributes.

Path 1: SERIES/SERIE/SERIE_NO
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored and must align with the base catalogue. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. The short text may consist of three lines.

This element is only specified if a trade-specific text should be used for the item.

The later order must contain the original text.

CLASSIFICATIONS optional
This element is used to specify standardized classification numbers that supplement the base catalogue.
DETAIL_INFOS optional
This element is used to specify modified detailed media information, such as milieu photos, PDFs or video links. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
DETAIL_INFOS optional
This element is used to specify trade-specific detailed media information, such as milieu photos, PDFs or video links for the series. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="SERIES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE" maxOccurs="1000000">
        <xs:annotation>
          <xs:documentation>200--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
          <xs:documentation>maxOccours geändert, K.Richter 23.11.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIES_NAME">
              <xs:annotation>
                <xs:documentation>200--3--Serienname</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>200--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>200--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="PRODUCT_GROUPS">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEMS">
                          <xs:annotation>
                            <xs:documentation>400--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>400--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ITEM_TEXT" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--1--Satzart</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SHORT_TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT_LINE" maxOccurs="3">
                                                        <xs:annotation>
                                                          <xs:documentation>410--0--NEW</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:complexType>
                                                          <xs:sequence>
                                                            <xs:element name="TEXT">
                                                              <xs:annotation>
                                                                <xs:documentation>410--6--Textzeile</xs:documentation>
                                                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                              </xs:annotation>
                                                              <xs:simpleType>
                                                                <xs:restriction base="xs:string">
                                                                  <xs:pattern value="[\S ]{1,30}" />
                                                                </xs:restriction>
                                                              </xs:simpleType>
                                                            </xs:element>
                                                          </xs:sequence>
                                                          <xs:attribute name="SEQUENCE_NO" use="required">
                                                            <xs:annotation>
                                                              <xs:documentation>410--0--NEW</xs:documentation>
                                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                            </xs:annotation>
                                                            <xs:simpleType>
                                                              <xs:restriction base="xs:positiveInteger" />
                                                            </xs:simpleType>
                                                          </xs:attribute>
                                                        </xs:complexType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:language">
                                                          <xs:pattern value="[A-Z]{2}" />
                                                        </xs:restriction>
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                          <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                            <xs:annotation>
                                              <xs:documentation>410--5--Texttype</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            </xs:annotation>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS" minOccurs="0">
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="ECLASS_NO">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:nonNegativeInteger">
                                                      <xs:totalDigits value="8" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="INDIVIDUAL" minOccurs="0">
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="CLASSIFICATION_KEY">
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string" />
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="DETAIL_INFOS" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="DETAIL_INFO_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:maxInclusive value="999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="DECISION_NO" use="optional">
                                                <xs:annotation>
                                                  <xs:documentation>291--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                                  <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger">
                                                    <xs:minInclusive value="1" />
                                                    <xs:maxInclusive value="9999999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>400--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="SEQUENCE_NO">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>200--1--Satzart</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
            <xs:annotation>
              <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
              <xs:documentation>K. Richter 26.02.2015</xs:documentation>
              <xs:documentation>Datentyp auf positiveInteger gesetzt, K. Richter 12.06.2015</xs:documentation>
            </xs:annotation>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
SERIE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element : SERIE Element
Description
This element is used to store a series together with the corresponding items. A series corresponds to a model. The numbers and designations stated here must correspond to those in the base catalogue.
Namespace (none)
Diagram
DETAIL_INFOS Element PRODUCT_GROUPS Element SERIES_NAME Element Sequence SERIE Element
Overview
SERIE 1..1000000
This element is used to store a series together with the corresponding items. A series corresponds to a model. The numbers and designations stated here must correspond to those in the base catalogue.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the base catalogue. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO required xs:positiveInteger
This attribute allows for the specification of series with a freely-defined sorting order.
If a SEQUENCE_NO is specified for one series, a SEQUENCE_NO must be specified for all series. It must reconcile with the base catalogue. 		D positiveInteger
P
M
Sequence
SERIES_NAME
This element is used to specify the series name.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
PRODUCT_GROUPS
This element is used to specify the product groups. They must correspond to those in the base catalogue.Product groups are used to combine articles with identical version types (e.g. upholstered furniture with armrests).
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups.
Sequence
ITEMS

This element is used to specify all items of a product group for which the texts, detail information or classifications are modified for the specific trade.

Sequence
ITEM 1..∞

This element is used to specify items in accordance with the base catalogue. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 2) attributes.

Path 1: SERIES/SERIE/SERIE_NO
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored and must align with the base catalogue. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. The short text may consist of three lines.

This element is only specified if a trade-specific text should be used for the item.

The later order must contain the original text.

Sequence
SHORT_TEXT
This element contains short texts.
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
CLASSIFICATIONS optional
This element is used to specify standardized classification numbers that supplement the base catalogue.
Sequence
ECLASS optional
This element is used to specify the eCl@ss classification.
INDIVIDUAL optional
This element is used to specify a discretionary classification.
DETAIL_INFOS optional
This element is used to specify modified detailed media information, such as milieu photos, PDFs or video links. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFOS optional
This element is used to specify trade-specific detailed media information, such as milieu photos, PDFs or video links for the series. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the serial number of the base catalogue. D nonNegativeInteger
P
M [0:999999]
SEQUENCE_NO xs:positiveInteger required
This attribute allows for the specification of series with a freely-defined sorting order.
If a SEQUENCE_NO is specified for one series, a SEQUENCE_NO must be specified for all series. It must reconcile with the base catalogue. 		D positiveInteger
P
M
Source
<xs:element name="SERIE" maxOccurs="1000000" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
    <xs:documentation>maxOccours geändert, K.Richter 23.11.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIES_NAME">
        <xs:annotation>
          <xs:documentation>200--3--Serienname</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>200--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>200--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="PRODUCT_GROUPS">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEMS">
                    <xs:annotation>
                      <xs:documentation>400--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>400--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ITEM_TEXT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--1--Satzart</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SHORT_TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT_LINE" maxOccurs="3">
                                                  <xs:annotation>
                                                    <xs:documentation>410--0--NEW</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:complexType>
                                                    <xs:sequence>
                                                      <xs:element name="TEXT">
                                                        <xs:annotation>
                                                          <xs:documentation>410--6--Textzeile</xs:documentation>
                                                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                        </xs:annotation>
                                                        <xs:simpleType>
                                                          <xs:restriction base="xs:string">
                                                            <xs:pattern value="[\S ]{1,30}" />
                                                          </xs:restriction>
                                                        </xs:simpleType>
                                                      </xs:element>
                                                    </xs:sequence>
                                                    <xs:attribute name="SEQUENCE_NO" use="required">
                                                      <xs:annotation>
                                                        <xs:documentation>410--0--NEW</xs:documentation>
                                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                      </xs:annotation>
                                                      <xs:simpleType>
                                                        <xs:restriction base="xs:positiveInteger" />
                                                      </xs:simpleType>
                                                    </xs:attribute>
                                                  </xs:complexType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:language">
                                                    <xs:pattern value="[A-Z]{2}" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                    <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                      <xs:annotation>
                                        <xs:documentation>410--5--Texttype</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      </xs:annotation>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="CLASSIFICATIONS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS" minOccurs="0">
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="ECLASS_NO">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:nonNegativeInteger">
                                                <xs:totalDigits value="8" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="INDIVIDUAL" minOccurs="0">
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="CLASSIFICATION_KEY">
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string" />
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="DECISION_NO" use="optional">
                                          <xs:annotation>
                                            <xs:documentation>291--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                            <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:minInclusive value="1" />
                                              <xs:maxInclusive value="9999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>400--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>200--1--Satzart</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO" type="xs:positiveInteger" use="required">
      <xs:annotation>
        <xs:documentation xml:lang="DE">IDM 2.5 Sortierung der Modelle</xs:documentation>
        <xs:documentation>K. Richter 26.02.2015</xs:documentation>
        <xs:documentation>Datentyp auf positiveInteger gesetzt, K. Richter 12.06.2015</xs:documentation>
      </xs:annotation>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
SERIES_NAME Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element : SERIES_NAME Element
Description
This element is used to specify the series name.
Namespace (none)
Diagram
LANGUAGE Element Sequence SERIES_NAME Element
Overview
SERIES_NAME
This element is used to specify the series name.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Source
<xs:element name="SERIES_NAME" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--3--Serienname</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>200--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>200--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
LANGUAGE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element : LANGUAGE Element
Description
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
Namespace (none)
Diagram
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 3</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>200--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>200--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 3, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
TEXT_LINE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element : TEXT_LINE Element
Description
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Namespace (none)
Diagram
FULL_TEXT Element TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE
This element is used to specify a line of text.

The TEXT element contains a short text. The FULL_TEXT element contains a text of any length.
Sequence
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Source
<xs:element name="TEXT_LINE" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>200--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="xs:string" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Description
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element is used to store the short text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>200--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
FULL_TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > SERIES_NAME Element > LANGUAGE Element > TEXT_LINE Element : FULL_TEXT Element
Description
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Namespace (none)
Type
xs:string
Diagram
FULL_TEXT Element
Overview
FULL_TEXT optional xs:string
This element is used to store the text (any length) in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P
M
Source
<xs:element name="FULL_TEXT" type="xs:string" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SERIES_NAME Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
PRODUCT_GROUPS Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element : PRODUCT_GROUPS Element
Description
This element is used to specify the product groups. They must correspond to those in the base catalogue.Product groups are used to combine articles with identical version types (e.g. upholstered furniture with armrests).
Namespace (none)
Diagram
PRODUCT_GROUP Element Sequence PRODUCT_GROUPS Element
Overview
PRODUCT_GROUPS
This element is used to specify the product groups. They must correspond to those in the base catalogue.Product groups are used to combine articles with identical version types (e.g. upholstered furniture with armrests).
Sequence
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups.
Sequence
ITEMS

This element is used to specify all items of a product group for which the texts, detail information or classifications are modified for the specific trade.

Sequence
ITEM 1..∞

This element is used to specify items in accordance with the base catalogue. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 2) attributes.

Path 1: SERIES/SERIE/SERIE_NO
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored and must align with the base catalogue. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. The short text may consist of three lines.

This element is only specified if a trade-specific text should be used for the item.

The later order must contain the original text.

Sequence
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
CLASSIFICATIONS optional
This element is used to specify standardized classification numbers that supplement the base catalogue.
Sequence
ECLASS optional
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
INDIVIDUAL optional
This element is used to specify a discretionary classification.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

The discretionary classification matching the item is specified here.

 D string
P
M
DETAIL_INFOS optional
This element is used to specify modified detailed media information, such as milieu photos, PDFs or video links. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) of a preparation rule must be specified. 		D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="PRODUCT_GROUPS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="PRODUCT_GROUP" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEMS">
              <xs:annotation>
                <xs:documentation>400--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>400--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ITEM_TEXT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--1--Satzart</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SHORT_TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT_LINE" maxOccurs="3">
                                            <xs:annotation>
                                              <xs:documentation>410--0--NEW</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:sequence>
                                                <xs:element name="TEXT">
                                                  <xs:annotation>
                                                    <xs:documentation>410--6--Textzeile</xs:documentation>
                                                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                  </xs:annotation>
                                                  <xs:simpleType>
                                                    <xs:restriction base="xs:string">
                                                      <xs:pattern value="[\S ]{1,30}" />
                                                    </xs:restriction>
                                                  </xs:simpleType>
                                                </xs:element>
                                              </xs:sequence>
                                              <xs:attribute name="SEQUENCE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>410--0--NEW</xs:documentation>
                                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:positiveInteger" />
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:language">
                                              <xs:pattern value="[A-Z]{2}" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>410--5--Texttype</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="CLASSIFICATIONS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS" minOccurs="0">
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="ECLASS_NO">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:nonNegativeInteger">
                                          <xs:totalDigits value="8" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="INDIVIDUAL" minOccurs="0">
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="CLASSIFICATION_KEY">
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string" />
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="DECISION_NO" use="optional">
                                    <xs:annotation>
                                      <xs:documentation>291--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                      <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:minInclusive value="1" />
                                        <xs:maxInclusive value="9999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>400--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
PRODUCT_GROUP Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element : PRODUCT_GROUP Element
Description
This element is used to create modified items that are combined in product groups.
Namespace (none)
Diagram
ITEMS Element Sequence PRODUCT_GROUP Element
Overview
PRODUCT_GROUP 1..∞
This element is used to create modified items that are combined in product groups.
Sequence
ITEMS

This element is used to specify all items of a product group for which the texts, detail information or classifications are modified for the specific trade.

Sequence
ITEM 1..∞

This element is used to specify items in accordance with the base catalogue. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 2) attributes.

Path 1: SERIES/SERIE/SERIE_NO
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored and must align with the base catalogue. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. The short text may consist of three lines.

This element is only specified if a trade-specific text should be used for the item.

The later order must contain the original text.

Sequence
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element is used to specify a line of text.
The SEQUENCE_NO attribute is used to specify the order of the text line. The order of the text line must be specified because it cannot be assured that the originally specified order of elements is retained during processing of the XML data.

The TEXT element contains the text.
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
CLASSIFICATIONS optional
This element is used to specify standardized classification numbers that supplement the base catalogue.
Sequence
ECLASS optional
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
INDIVIDUAL optional
This element is used to specify a discretionary classification.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

The discretionary classification matching the item is specified here.

 D string
P
M
DETAIL_INFOS optional
This element is used to specify modified detailed media information, such as milieu photos, PDFs or video links. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) of a preparation rule must be specified. 		D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="PRODUCT_GROUP" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEMS">
        <xs:annotation>
          <xs:documentation>400--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>400--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ITEM_TEXT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SHORT_TEXT">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="LANGUAGE" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT_LINE" maxOccurs="3">
                                      <xs:annotation>
                                        <xs:documentation>410--0--NEW</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="TEXT">
                                            <xs:annotation>
                                              <xs:documentation>410--6--Textzeile</xs:documentation>
                                              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                            </xs:annotation>
                                            <xs:simpleType>
                                              <xs:restriction base="xs:string">
                                                <xs:pattern value="[\S ]{1,30}" />
                                              </xs:restriction>
                                            </xs:simpleType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="SEQUENCE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>410--0--NEW</xs:documentation>
                                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger" />
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:language">
                                        <xs:pattern value="[A-Z]{2}" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>410--5--Texttype</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="CLASSIFICATIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS" minOccurs="0">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="ECLASS_NO">
                                <xs:simpleType>
                                  <xs:restriction base="xs:nonNegativeInteger">
                                    <xs:totalDigits value="8" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="INDIVIDUAL" minOccurs="0">
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="CLASSIFICATION_KEY">
                                <xs:simpleType>
                                  <xs:restriction base="xs:string" />
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="DECISION_NO" use="optional">
                              <xs:annotation>
                                <xs:documentation>291--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:minInclusive value="1" />
                                  <xs:maxInclusive value="9999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>400--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
ITEMS Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element : ITEMS Element
Description

This element is used to specify all items of a product group for which the texts, detail information or classifications are modified for the specific trade.

Namespace (none)
Diagram
ITEM Element Sequence ITEMS Element
Overview
ITEMS

This element is used to specify all items of a product group for which the texts, detail information or classifications are modified for the specific trade.

Sequence
ITEM 1..∞

This element is used to specify items in accordance with the base catalogue. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 2) attributes.

Path 1: SERIES/SERIE/SERIE_NO
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored and must align with the base catalogue. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. The short text may consist of three lines.

This element is only specified if a trade-specific text should be used for the item.

The later order must contain the original text.

Sequence
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element is used to specify a line of text.
The SEQUENCE_NO attribute is used to specify the order of the text line. The order of the text line must be specified because it cannot be assured that the originally specified order of elements is retained during processing of the XML data.

The TEXT element contains the text.
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the text line in a text of multiple lines. The value 1 is entered for a text with a single line. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
CLASSIFICATIONS optional
This element is used to specify standardized classification numbers that supplement the base catalogue.
Sequence
ECLASS optional
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
INDIVIDUAL optional
This element is used to specify a discretionary classification.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

The discretionary classification matching the item is specified here.

 D string
P
M
DETAIL_INFOS optional
This element is used to specify modified detailed media information, such as milieu photos, PDFs or video links. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) of a preparation rule must be specified. 		D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="ITEMS" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>400--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ITEM_TEXT" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SHORT_TEXT">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="LANGUAGE" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT_LINE" maxOccurs="3">
                                <xs:annotation>
                                  <xs:documentation>410--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="TEXT">
                                      <xs:annotation>
                                        <xs:documentation>410--6--Textzeile</xs:documentation>
                                        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                      </xs:annotation>
                                      <xs:simpleType>
                                        <xs:restriction base="xs:string">
                                          <xs:pattern value="[\S ]{1,30}" />
                                        </xs:restriction>
                                      </xs:simpleType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="SEQUENCE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>410--0--NEW</xs:documentation>
                                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger" />
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:language">
                                  <xs:pattern value="[A-Z]{2}" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>410--5--Texttype</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="CLASSIFICATIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS" minOccurs="0">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="ECLASS_NO">
                          <xs:simpleType>
                            <xs:restriction base="xs:nonNegativeInteger">
                              <xs:totalDigits value="8" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="INDIVIDUAL" minOccurs="0">
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="CLASSIFICATION_KEY">
                          <xs:simpleType>
                            <xs:restriction base="xs:string" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="DECISION_NO" use="optional">
                        <xs:annotation>
                          <xs:documentation>291--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:minInclusive value="1" />
                            <xs:maxInclusive value="9999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>400--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
ITEM Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element : ITEM Element
Description

This element is used to specify items in accordance with the base catalogue. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 2) attributes.

Path 1: SERIES/SERIE/SERIE_NO
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

Namespace (none)
Diagram
DETAIL_INFOS Element CLASSIFICATIONS Element ITEM_TEXT Element Sequence ITEM Element
Overview
ITEM 1..∞

This element is used to specify items in accordance with the base catalogue. An item is identified via the SERIE_NO (path 1) and TYPE_NO (path 2) attributes.

Path 1: SERIES/SERIE/SERIE_NO
Path 2: SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO

TYPE_NO required Restriction of xs:string
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:positiveInteger

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored and must align with the base catalogue. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Sequence
ITEM_TEXT optional

This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. The short text may consist of three lines.

This element is only specified if a trade-specific text should be used for the item.

The later order must contain the original text.

Sequence
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element is used to specify a line of text.
The SEQUENCE_NO attribute is used to specify the order of the text line. The order of the text line must be specified because it cannot be assured that the originally specified order of elements is retained during processing of the XML data.

The TEXT element contains the text.
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the text line in a text of multiple lines. The value 1 is entered for a text with a single line. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
CLASSIFICATIONS optional
This element is used to specify standardized classification numbers that supplement the base catalogue.
Sequence
ECLASS optional
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
INDIVIDUAL optional
This element is used to specify a discretionary classification.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

The discretionary classification matching the item is specified here.

 D string
P
M
DETAIL_INFOS optional
This element is used to specify modified detailed media information, such as milieu photos, PDFs or video links. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) of a preparation rule must be specified. 		D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
TYPE_NO Restriction of xs:string required
This element is used to enter the item code/item type. D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:positiveInteger optional

This attribute allows for the specification of items with a freely-defined sorting order.

The sorting of the items always relates to the series in which the items are stored and must align with the base catalogue. If a SEQUENCE_NO is specified for one item within the series, a SEQUENCE_NO must be specified for all items within this series.

 D positiveInteger
P
M
Source
<xs:element name="ITEM" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>400--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ITEM_TEXT" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SHORT_TEXT">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="LANGUAGE" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT_LINE" maxOccurs="3">
                          <xs:annotation>
                            <xs:documentation>410--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="TEXT">
                                <xs:annotation>
                                  <xs:documentation>410--6--Textzeile</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:string">
                                    <xs:pattern value="[\S ]{1,30}" />
                                  </xs:restriction>
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="SEQUENCE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>410--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:language">
                            <xs:pattern value="[A-Z]{2}" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>410--5--Texttype</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="CLASSIFICATIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS" minOccurs="0">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="ECLASS_NO">
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:totalDigits value="8" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="INDIVIDUAL" minOccurs="0">
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="CLASSIFICATION_KEY">
                    <xs:simpleType>
                      <xs:restriction base="xs:string" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="DECISION_NO" use="optional">
                  <xs:annotation>
                    <xs:documentation>291--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:minInclusive value="1" />
                      <xs:maxInclusive value="9999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>400--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
ITEM_TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : ITEM_TEXT Element
Description

This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. The short text may consist of three lines.

This element is only specified if a trade-specific text should be used for the item.

The later order must contain the original text.

Namespace (none)
Diagram
LANGUAGE Element Sequence PLANNING_ADVICE Element LANGUAGE Element Sequence FULL_TEXT Element SHORT_TEXT Element Sequence ITEM_TEXT Element
Overview
ITEM_TEXT optional

This element is used to define the item-specific texts. These may be long texts, short texts, as well as planning notes. The short text may consist of three lines.

This element is only specified if a trade-specific text should be used for the item.

The later order must contain the original text.

Sequence
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element is used to specify a line of text.
The SEQUENCE_NO attribute is used to specify the order of the text line. The order of the text line must be specified because it cannot be assured that the originally specified order of elements is retained during processing of the XML data.

The TEXT element contains the text.
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the text line in a text of multiple lines. The value 1 is entered for a text with a single line. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="ITEM_TEXT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SHORT_TEXT">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="LANGUAGE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT_LINE" maxOccurs="3">
                    <xs:annotation>
                      <xs:documentation>410--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="TEXT">
                          <xs:annotation>
                            <xs:documentation>410--6--Textzeile</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:string">
                              <xs:pattern value="[\S ]{1,30}" />
                            </xs:restriction>
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="SEQUENCE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>410--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="ISO_LANGUAGE_ID" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:language">
                      <xs:pattern value="[A-Z]{2}" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FULL_TEXT" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>410--5--Texttype</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
SHORT_TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : SHORT_TEXT Element
Description
This element contains short texts.
Namespace (none)
Diagram
LANGUAGE Element Sequence SHORT_TEXT Element
Overview
SHORT_TEXT
This element contains short texts.
Sequence
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element is used to specify a line of text.
The SEQUENCE_NO attribute is used to specify the order of the text line. The order of the text line must be specified because it cannot be assured that the originally specified order of elements is retained during processing of the XML data.

The TEXT element contains the text.
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the text line in a text of multiple lines. The value 1 is entered for a text with a single line. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="SHORT_TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="LANGUAGE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT_LINE" maxOccurs="3">
              <xs:annotation>
                <xs:documentation>410--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="TEXT">
                    <xs:annotation>
                      <xs:documentation>410--6--Textzeile</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:string">
                        <xs:pattern value="[\S ]{1,30}" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="SEQUENCE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>410--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="ISO_LANGUAGE_ID" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:language">
                <xs:pattern value="[A-Z]{2}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
LANGUAGE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element : LANGUAGE Element
Description
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
Namespace (none)
Diagram
TEXT_LINE Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element allows for the specification of texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT_LINE 1..3
This element is used to specify a line of text.
The SEQUENCE_NO attribute is used to specify the order of the text line. The order of the text line must be specified because it cannot be assured that the originally specified order of elements is retained during processing of the XML data.

The TEXT element contains the text.
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the text line in a text of multiple lines. The value 1 is entered for a text with a single line. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 2</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT_LINE" maxOccurs="3">
        <xs:annotation>
          <xs:documentation>410--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="TEXT">
              <xs:annotation>
                <xs:documentation>410--6--Textzeile</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:string">
                  <xs:pattern value="[\S ]{1,30}" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="SEQUENCE_NO" use="required">
            <xs:annotation>
              <xs:documentation>410--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 2, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
TEXT_LINE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element : TEXT_LINE Element
Description
This element is used to specify a line of text.
The SEQUENCE_NO attribute is used to specify the order of the text line. The order of the text line must be specified because it cannot be assured that the originally specified order of elements is retained during processing of the XML data.

The TEXT element contains the text.
Namespace (none)
Diagram
TEXT Element Sequence TEXT_LINE Element
Overview
TEXT_LINE 1..3
This element is used to specify a line of text.
The SEQUENCE_NO attribute is used to specify the order of the text line. The order of the text line must be specified because it cannot be assured that the originally specified order of elements is retained during processing of the XML data.

The TEXT element contains the text.
SEQUENCE_NO required Restriction of xs:positiveInteger
This attribute defines the order of the text line in a text of multiple lines. The value 1 is entered for a text with a single line. D positiveInteger
P
M
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
SEQUENCE_NO Restriction of xs:positiveInteger required
This attribute defines the order of the text line in a text of multiple lines. The value 1 is entered for a text with a single line. D positiveInteger
P
M
Source
<xs:element name="TEXT_LINE" maxOccurs="3" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:annotation>
          <xs:documentation>410--6--Textzeile</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="SEQUENCE_NO" use="required">
      <xs:annotation>
        <xs:documentation>410--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element > SHORT_TEXT Element > LANGUAGE Element > TEXT_LINE Element : TEXT Element
Description
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--6--Textzeile</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 5</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
TEXT_LINE Element | LANGUAGE Element | SHORT_TEXT Element | ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
FULL_TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : FULL_TEXT Element
Description
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence FULL_TEXT Element
Overview
FULL_TEXT optional languagetext Complex Type
Full text contains the complete description including the short text. The HTML tags bold and line break can be used within the full text.

This element contains the full text in a CDATA node.
The text must be specified in HTML format:

<b> | bold font
<br> | line break
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="FULL_TEXT" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
LANGUAGE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > languagetext Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT" type="xs:string" />
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetext Complex Type | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > languagetext Complex Type > LANGUAGE Element : TEXT Element
Description

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Namespace (none)
Type
xs:string
Diagram
TEXT Element
Overview
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="TEXT" type="xs:string" xmlns:xs="http://www.w3.org/2001/XMLSchema" />
See Also
LANGUAGE Element | languagetext Complex Type | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
PLANNING_ADVICE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > ITEM_TEXT Element : PLANNING_ADVICE Element
Description
This element contains planning advice.
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence PLANNING_ADVICE Element
Overview
PLANNING_ADVICE optional languagetext Complex Type
This element contains planning advice.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="PLANNING_ADVICE" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>410--5--Texttype</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
ITEM_TEXT Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CLASSIFICATIONS Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : CLASSIFICATIONS Element
Description
This element is used to specify standardized classification numbers that supplement the base catalogue.
Namespace (none)
Diagram
INDIVIDUAL Element ECLASS Element Sequence CLASSIFICATIONS Element
Overview
CLASSIFICATIONS optional
This element is used to specify standardized classification numbers that supplement the base catalogue.
Sequence
ECLASS optional
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
INDIVIDUAL optional
This element is used to specify a discretionary classification.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

The discretionary classification matching the item is specified here.

 D string
P
M
Source
<xs:element name="CLASSIFICATIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Klassifizierung für eCl@ss, GSP,.... 20.03.2018/K. Richter</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS" minOccurs="0">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ECLASS_NO">
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:totalDigits value="8" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="INDIVIDUAL" minOccurs="0">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="CLASSIFICATION_KEY">
              <xs:simpleType>
                <xs:restriction base="xs:string" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
ECLASS Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element : ECLASS Element
Description
This element is used to specify the eCl@ss classification.
Namespace (none)
Diagram
ECLASS_NO Element Sequence ECLASS Element
Overview
ECLASS optional
This element is used to specify the eCl@ss classification.
Sequence
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
Source
<xs:element name="ECLASS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="ECLASS_NO">
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:totalDigits value="8" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
ECLASS_NO Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element > ECLASS Element : ECLASS_NO Element
Description

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
ECLASS_NO Element
Overview
ECLASS_NO Restriction of xs:nonNegativeInteger

The 8-digit eCl@ss number, which corresponds to the 4th level of the eCl@ss classification, is assigned here.

 D nonNegativeInteger
P
M [10000000:99999999]
Source
<xs:element name="ECLASS_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:totalDigits value="8" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
ECLASS Element | CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
INDIVIDUAL Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element : INDIVIDUAL Element
Description
This element is used to specify a discretionary classification.
Namespace (none)
Diagram
CLASSIFICATION_KEY Element Sequence INDIVIDUAL Element
Overview
INDIVIDUAL optional
This element is used to specify a discretionary classification.
Sequence
CLASSIFICATION_KEY Restriction of xs:string

The discretionary classification matching the item is specified here.

 D string
P
M
Source
<xs:element name="INDIVIDUAL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CLASSIFICATION_KEY">
        <xs:simpleType>
          <xs:restriction base="xs:string" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
CLASSIFICATION_KEY Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > CLASSIFICATIONS Element > INDIVIDUAL Element : CLASSIFICATION_KEY Element
Description

The discretionary classification matching the item is specified here.

 D string
P
M
Namespace (none)
Type
Restriction of xs:string
Diagram
CLASSIFICATION_KEY Element
Overview
CLASSIFICATION_KEY Restriction of xs:string

The discretionary classification matching the item is specified here.

 D string
P
M
Source
<xs:element name="CLASSIFICATION_KEY" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string" />
  </xs:simpleType>
</xs:element>
See Also
INDIVIDUAL Element | CLASSIFICATIONS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
DETAIL_INFOS Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element : DETAIL_INFOS Element
Description
This element is used to specify modified detailed media information, such as milieu photos, PDFs or video links. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element is used to specify modified detailed media information, such as milieu photos, PDFs or video links. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Sequence
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) of a preparation rule must be specified. 		D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW 30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="DECISION_NO" use="optional">
            <xs:annotation>
              <xs:documentation>291--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:minInclusive value="1" />
                <xs:maxInclusive value="9999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
DETAIL_INFO_REF Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > PRODUCT_GROUPS Element > PRODUCT_GROUP Element > ITEMS Element > ITEM Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞

This element is used to directly assign precisely 1 option to the figure.

The assignment is done via DETAIL_INFO_NO and either RESTRICTION_NO or DECISION_NO, with only repertory rules permitted for the reference to a rule (DECISION).

This assignment must only be used for magnet planner figures (assignments).

Example:
If a manufacturer offers functional versions (e.g. cross-sleepers) for an item, the manufacturer may store the different figures for this option here.

DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO optional Restriction of xs:positiveInteger
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) of a preparation rule must be specified. 		D positiveInteger
P
M [1:9999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
DECISION_NO Restriction of xs:positiveInteger optional
This attribute is used to reference a rule.
Only the identifier (DECISION_NO) of a preparation rule must be specified. 		D positiveInteger
P
M [1:9999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                                              30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="DECISION_NO" use="optional">
      <xs:annotation>
        <xs:documentation>291--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>einheitlich auf 1 bis 99999 gesetzt, K. Richter 23.05.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:minInclusive value="1" />
          <xs:maxInclusive value="9999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | ITEM Element | ITEMS Element | PRODUCT_GROUP Element | PRODUCT_GROUPS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
DETAIL_INFO_REF Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element is used to reference the detailed information.
Namespace (none)
Diagram
DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
DETAIL_INFOS Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > SERIES Element > SERIE Element : DETAIL_INFOS Element
Description
This element is used to specify trade-specific detailed media information, such as milieu photos, PDFs or video links for the series. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element is used to specify trade-specific detailed media information, such as milieu photos, PDFs or video links for the series. If this element is specified, all relevant detail information, including those to be used from the base catalogue, must be provided.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">1000--0--NEW 15.02.2013 /Balke</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW
                                  30.05.2012/Bur</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW
                                      30.05.2012/Bur, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
SERIE Element | SERIES Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
FEATURE_DEFINITION Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element : FEATURE_DEFINITION Element
Description
This element is used to specify option-specific information that are modified from the base catalogue for the specific trade. These modifications must only affect sales, not the order.
Namespace (none)
Diagram
FEATURES Element Sequence FEATURE_DEFINITION Element
Overview
FEATURE_DEFINITION
This element is used to specify option-specific information that are modified from the base catalogue for the specific trade. These modifications must only affect sales, not the order.
Sequence
FEATURES

This element is used to define the features (FEATURE) and the associated options for which a trade-specific modification is applied. Only the features needed for correctly mapping the data pool are defined.

Further information about features can be found in the Introduction in section "features"

Sequence
FEATURE 1..∞
This element is used to modify an option type from the base catalogue for the specific trade.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a feature. The number must correspond to those in the base catalogue. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
It is a container element in which the possible variations of a feature to be modified for the specific trade are stored.
Sequence
OPTION 1..∞
This element is used to define a version for the superordinate version type.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option from the base catalogue. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order that must correspond to the base catalogue. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
This element is used to define a trade-specific option text. The original text must be used for orders.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a trade-specific general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.
DETAIL_INFOS optional
This element is used to assign modified media. It is possible to assign a number of detail information to one version, and each image of the version can then be assigned to specific series or items. The respective image will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
This element contains trade-specific texts for features.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element is used to specify a manufacturer-specific sorting for the features. It must reconcile with the base catalogue.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options of the base catalogue (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1:FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ of the base catalogue 		D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURE_DEFINITION" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURES">
        <xs:annotation>
          <xs:documentation>250--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="FEATURE" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTIONS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--1--Satzart</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="OPTION_TEXT" type="languagetext60">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--0--NEW</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                              </xs:element>
                              <xs:element name="VALID_FROM" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="VALID_UNTIL" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                                  <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:date" />
                                </xs:simpleType>
                              </xs:element>
                              <xs:element name="DETAIL_INFOS" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>1000--0--NEW</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:sequence>
                                          <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                          <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                            <xs:annotation>
                                              <xs:documentation>406--0--NEW</xs:documentation>
                                              <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                                            </xs:annotation>
                                            <xs:complexType>
                                              <xs:attribute name="SERIE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:nonNegativeInteger">
                                                    <xs:minInclusive value="0" />
                                                    <xs:maxInclusive value="999999" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                              <xs:attribute name="TYPE_NO" use="required">
                                                <xs:annotation>
                                                  <xs:documentation>406--0--NEW</xs:documentation>
                                                  <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                                </xs:annotation>
                                                <xs:simpleType>
                                                  <xs:restriction base="xs:string">
                                                    <xs:minLength value="1" />
                                                    <xs:maxLength value="30" />
                                                  </xs:restriction>
                                                </xs:simpleType>
                                              </xs:attribute>
                                            </xs:complexType>
                                          </xs:element>
                                        </xs:sequence>
                                        <xs:attribute name="DETAIL_INFO_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>1000--0--NEW</xs:documentation>
                                            <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:positiveInteger">
                                              <xs:maxInclusive value="999999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="OPTION_FREETEXT" minOccurs="0">
                                <xs:annotation>
                                  <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                                  <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
                                </xs:annotation>
                                <xs:simpleType>
                                  <xs:restriction base="xs:boolean" />
                                </xs:simpleType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="OPTION_KEY" use="required">
                              <xs:annotation>
                                <xs:documentation>260--0--NEW</xs:documentation>
                                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                                <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="SEQUENCE_NO">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger" />
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="FEATURE_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>250--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="SEQUENCE_NO">
                    <xs:annotation>
                      <xs:documentation>250--4--Sortierung</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:nonNegativeInteger">
                        <xs:minInclusive value="0" />
                        <xs:maxInclusive value="999" />
                      </xs:restriction>
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="FEATURE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>250--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
FEATURES Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element : FEATURES Element
Description

This element is used to define the features (FEATURE) and the associated options for which a trade-specific modification is applied. Only the features needed for correctly mapping the data pool are defined.

Further information about features can be found in the Introduction in section "features"

Namespace (none)
Diagram
FEATURE Element Sequence FEATURES Element
Overview
FEATURES

This element is used to define the features (FEATURE) and the associated options for which a trade-specific modification is applied. Only the features needed for correctly mapping the data pool are defined.

Further information about features can be found in the Introduction in section "features"

Sequence
FEATURE 1..∞
This element is used to modify an option type from the base catalogue for the specific trade.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a feature. The number must correspond to those in the base catalogue. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
It is a container element in which the possible variations of a feature to be modified for the specific trade are stored.
Sequence
OPTION 1..∞
This element is used to define a version for the superordinate version type.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option from the base catalogue. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order that must correspond to the base catalogue. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
This element is used to define a trade-specific option text. The original text must be used for orders.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a trade-specific general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.
DETAIL_INFOS optional
This element is used to assign modified media. It is possible to assign a number of detail information to one version, and each image of the version can then be assigned to specific series or items. The respective image will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
ITEM_REF 0..∞
This element is used to reference an item.
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
This element contains trade-specific texts for features.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element is used to specify a manufacturer-specific sorting for the features. It must reconcile with the base catalogue.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options of the base catalogue (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1:FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ of the base catalogue 		D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURES" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="FEATURE" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTIONS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--1--Satzart</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="OPTION_TEXT" type="languagetext60">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--0--NEW</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                        </xs:element>
                        <xs:element name="VALID_FROM" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="VALID_UNTIL" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                            <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:date" />
                          </xs:simpleType>
                        </xs:element>
                        <xs:element name="DETAIL_INFOS" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>1000--0--NEW</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:sequence>
                                    <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                    <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                      <xs:annotation>
                                        <xs:documentation>406--0--NEW</xs:documentation>
                                        <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                                      </xs:annotation>
                                      <xs:complexType>
                                        <xs:attribute name="SERIE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:nonNegativeInteger">
                                              <xs:minInclusive value="0" />
                                              <xs:maxInclusive value="999999" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                        <xs:attribute name="TYPE_NO" use="required">
                                          <xs:annotation>
                                            <xs:documentation>406--0--NEW</xs:documentation>
                                            <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                          </xs:annotation>
                                          <xs:simpleType>
                                            <xs:restriction base="xs:string">
                                              <xs:minLength value="1" />
                                              <xs:maxLength value="30" />
                                            </xs:restriction>
                                          </xs:simpleType>
                                        </xs:attribute>
                                      </xs:complexType>
                                    </xs:element>
                                  </xs:sequence>
                                  <xs:attribute name="DETAIL_INFO_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>1000--0--NEW</xs:documentation>
                                      <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:positiveInteger">
                                        <xs:maxInclusive value="999999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="OPTION_FREETEXT" minOccurs="0">
                          <xs:annotation>
                            <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                            <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
                          </xs:annotation>
                          <xs:simpleType>
                            <xs:restriction base="xs:boolean" />
                          </xs:simpleType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="OPTION_KEY" use="required">
                        <xs:annotation>
                          <xs:documentation>260--0--NEW</xs:documentation>
                          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                          <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="SEQUENCE_NO">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger" />
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="FEATURE_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>250--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="SEQUENCE_NO">
              <xs:annotation>
                <xs:documentation>250--4--Sortierung</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:nonNegativeInteger">
                  <xs:minInclusive value="0" />
                  <xs:maxInclusive value="999" />
                </xs:restriction>
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="FEATURE_NO" use="required">
            <xs:annotation>
              <xs:documentation>250--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
FEATURE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element : FEATURE Element
Description
This element is used to modify an option type from the base catalogue for the specific trade.
Namespace (none)
Diagram
SEQUENCE_NO Element LANGUAGE Element Sequence FEATURE_TEXT Element OPTIONS Element Sequence FEATURE Element
Overview
FEATURE 1..∞
This element is used to modify an option type from the base catalogue for the specific trade.
FEATURE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to identify a feature. The number must correspond to those in the base catalogue. D nonNegativeInteger
P
M [0:999]
Sequence
OPTIONS optional
It is a container element in which the possible variations of a feature to be modified for the specific trade are stored.
Sequence
OPTION 1..∞
This element is used to define a version for the superordinate version type.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option from the base catalogue. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order that must correspond to the base catalogue. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
This element is used to define a trade-specific option text. The original text must be used for orders.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a trade-specific general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.
DETAIL_INFOS optional
This element is used to assign modified media. It is possible to assign a number of detail information to one version, and each image of the version can then be assigned to specific series or items. The respective image will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
FEATURE_TEXT languagetext60 Complex Type
This element contains trade-specific texts for features.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element is used to specify a manufacturer-specific sorting for the features. It must reconcile with the base catalogue.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options of the base catalogue (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1:FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ of the base catalogue 		D nonNegativeInteger
P
M [0:999]
Attributes
Name Type Use Default Fixed Description
FEATURE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to identify a feature. The number must correspond to those in the base catalogue. D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="FEATURE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTIONS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--1--Satzart</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="OPTION_TEXT" type="languagetext60">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--0--NEW</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                  </xs:element>
                  <xs:element name="VALID_FROM" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="VALID_UNTIL" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                      <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:date" />
                    </xs:simpleType>
                  </xs:element>
                  <xs:element name="DETAIL_INFOS" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>1000--0--NEW</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:sequence>
                              <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                              <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                                <xs:annotation>
                                  <xs:documentation>406--0--NEW</xs:documentation>
                                  <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                                </xs:annotation>
                                <xs:complexType>
                                  <xs:attribute name="SERIE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:nonNegativeInteger">
                                        <xs:minInclusive value="0" />
                                        <xs:maxInclusive value="999999" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                  <xs:attribute name="TYPE_NO" use="required">
                                    <xs:annotation>
                                      <xs:documentation>406--0--NEW</xs:documentation>
                                      <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                                    </xs:annotation>
                                    <xs:simpleType>
                                      <xs:restriction base="xs:string">
                                        <xs:minLength value="1" />
                                        <xs:maxLength value="30" />
                                      </xs:restriction>
                                    </xs:simpleType>
                                  </xs:attribute>
                                </xs:complexType>
                              </xs:element>
                            </xs:sequence>
                            <xs:attribute name="DETAIL_INFO_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>1000--0--NEW</xs:documentation>
                                <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:positiveInteger">
                                  <xs:maxInclusive value="999999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="OPTION_FREETEXT" minOccurs="0">
                    <xs:annotation>
                      <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                      <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
                    </xs:annotation>
                    <xs:simpleType>
                      <xs:restriction base="xs:boolean" />
                    </xs:simpleType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="OPTION_KEY" use="required">
                  <xs:annotation>
                    <xs:documentation>260--0--NEW</xs:documentation>
                    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
                    <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="SEQUENCE_NO">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger" />
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="FEATURE_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>250--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="SEQUENCE_NO">
        <xs:annotation>
          <xs:documentation>250--4--Sortierung</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:nonNegativeInteger">
            <xs:minInclusive value="0" />
            <xs:maxInclusive value="999" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="FEATURE_NO" use="required">
      <xs:annotation>
        <xs:documentation>250--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
OPTIONS Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : OPTIONS Element
Description
It is a container element in which the possible variations of a feature to be modified for the specific trade are stored.
Namespace (none)
Diagram
OPTION Element Sequence OPTIONS Element
Overview
OPTIONS optional
It is a container element in which the possible variations of a feature to be modified for the specific trade are stored.
Sequence
OPTION 1..∞
This element is used to define a version for the superordinate version type.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option from the base catalogue. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order that must correspond to the base catalogue. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
This element is used to define a trade-specific option text. The original text must be used for orders.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a trade-specific general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.
DETAIL_INFOS optional
This element is used to assign modified media. It is possible to assign a number of detail information to one version, and each image of the version can then be assigned to specific series or items. The respective image will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
Source
<xs:element name="OPTIONS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--1--Satzart</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 7</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="OPTION_TEXT" type="languagetext60">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--0--NEW</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
            </xs:element>
            <xs:element name="VALID_FROM" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="VALID_UNTIL" minOccurs="0">
              <xs:annotation>
                <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
                <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:date" />
              </xs:simpleType>
            </xs:element>
            <xs:element name="DETAIL_INFOS" minOccurs="0">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>1000--0--NEW</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:sequence>
                        <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                        <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                          <xs:annotation>
                            <xs:documentation>406--0--NEW</xs:documentation>
                            <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                          </xs:annotation>
                          <xs:complexType>
                            <xs:attribute name="SERIE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:nonNegativeInteger">
                                  <xs:minInclusive value="0" />
                                  <xs:maxInclusive value="999999" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                            <xs:attribute name="TYPE_NO" use="required">
                              <xs:annotation>
                                <xs:documentation>406--0--NEW</xs:documentation>
                                <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                              </xs:annotation>
                              <xs:simpleType>
                                <xs:restriction base="xs:string">
                                  <xs:minLength value="1" />
                                  <xs:maxLength value="30" />
                                </xs:restriction>
                              </xs:simpleType>
                            </xs:attribute>
                          </xs:complexType>
                        </xs:element>
                      </xs:sequence>
                      <xs:attribute name="DETAIL_INFO_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>1000--0--NEW</xs:documentation>
                          <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:positiveInteger">
                            <xs:maxInclusive value="999999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
              </xs:complexType>
            </xs:element>
            <xs:element name="OPTION_FREETEXT" minOccurs="0">
              <xs:annotation>
                <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
                <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
              </xs:annotation>
              <xs:simpleType>
                <xs:restriction base="xs:boolean" />
              </xs:simpleType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="OPTION_KEY" use="required">
            <xs:annotation>
              <xs:documentation>260--0--NEW</xs:documentation>
              <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
              <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="SEQUENCE_NO">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger" />
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
OPTION Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element : OPTION Element
Description
This element is used to define a version for the superordinate version type.
Namespace (none)
Diagram
OPTION_FREETEXT Element DETAIL_INFOS Element VALID_UNTIL Element VALID_FROM Element LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element LANGUAGE Element Sequence OPTION_TEXT Element Sequence OPTION Element
Overview
OPTION 1..∞
This element is used to define a version for the superordinate version type.
OPTION_KEY required Restriction of xs:string
This attribute is used to reference an option from the base catalogue. D string
P
M [1:30]
SEQUENCE_NO optional Restriction of xs:nonNegativeInteger
This attribute allows for the specification of a freely-defined sorting order that must correspond to the base catalogue. D nonNegativeInteger
P
M
Sequence
OPTION_TEXT languagetext60 Complex Type
This element is used to define a trade-specific option text. The original text must be used for orders.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a trade-specific general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.
DETAIL_INFOS optional
This element is used to assign modified media. It is possible to assign a number of detail information to one version, and each image of the version can then be assigned to specific series or items. The respective image will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
Attributes
Name Type Use Default Fixed Description
OPTION_KEY Restriction of xs:string required
This attribute is used to reference an option from the base catalogue. D string
P
M [1:30]
SEQUENCE_NO Restriction of xs:nonNegativeInteger optional
This attribute allows for the specification of a freely-defined sorting order that must correspond to the base catalogue. D nonNegativeInteger
P
M
Source
<xs:element name="OPTION" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0, K. Richter 26.03.2014</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="OPTION_TEXT" type="languagetext60">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--0--NEW</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
      </xs:element>
      <xs:element name="VALID_FROM" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="VALID_UNTIL" minOccurs="0">
        <xs:annotation>
          <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
          <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:date" />
        </xs:simpleType>
      </xs:element>
      <xs:element name="DETAIL_INFOS" minOccurs="0">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>1000--0--NEW</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:sequence>
                  <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                  <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
                    <xs:annotation>
                      <xs:documentation>406--0--NEW</xs:documentation>
                      <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
                    </xs:annotation>
                    <xs:complexType>
                      <xs:attribute name="SERIE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:nonNegativeInteger">
                            <xs:minInclusive value="0" />
                            <xs:maxInclusive value="999999" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                      <xs:attribute name="TYPE_NO" use="required">
                        <xs:annotation>
                          <xs:documentation>406--0--NEW</xs:documentation>
                          <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                        </xs:annotation>
                        <xs:simpleType>
                          <xs:restriction base="xs:string">
                            <xs:minLength value="1" />
                            <xs:maxLength value="30" />
                          </xs:restriction>
                        </xs:simpleType>
                      </xs:attribute>
                    </xs:complexType>
                  </xs:element>
                </xs:sequence>
                <xs:attribute name="DETAIL_INFO_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>1000--0--NEW</xs:documentation>
                    <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:positiveInteger">
                      <xs:maxInclusive value="999999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="OPTION_FREETEXT" minOccurs="0">
        <xs:annotation>
          <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
          <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
        </xs:annotation>
        <xs:simpleType>
          <xs:restriction base="xs:boolean" />
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="OPTION_KEY" use="required">
      <xs:annotation>
        <xs:documentation>260--0--NEW</xs:documentation>
        <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
        <xs:documentation>17.01.2013 - Version 2.2.5 Polsterbranche - von 5 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="SEQUENCE_NO">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger" />
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
OPTION_TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_TEXT Element
Description
This element is used to define a trade-specific option text. The original text must be used for orders.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence OPTION_TEXT Element
Overview
OPTION_TEXT languagetext60 Complex Type
This element is used to define a trade-specific option text. The original text must be used for orders.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="OPTION_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
OPTION_COMMENT_TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_COMMENT_TEXT Element
Description
This element is used to reference a trade-specific general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Namespace (none)
Type
languagetext Complex Type
Diagram
LANGUAGE Element Sequence OPTION_COMMENT_TEXT Element
Overview
OPTION_COMMENT_TEXT optional languagetext Complex Type
This element is used to reference a trade-specific general comment as a notice of special properties of an option. This comment serves user-friendliness purposes and must not contain any order-relevant information. The information specified here will not be analysed electronically.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Source
<xs:element name="OPTION_COMMENT_TEXT" type="languagetext" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
VALID_FROM Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_FROM Element
Description
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_FROM Element
Overview
VALID_FROM optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period. 		D date
P
M
Source
<xs:element name="VALID_FROM" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--7--Lieferbar_ab</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
VALID_UNTIL Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : VALID_UNTIL Element
Description
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.
Namespace (none)
Type
Restriction of xs:date
Diagram
VALID_UNTIL Element
Overview
VALID_UNTIL optional Restriction of xs:date
These elements VALID_FROM and VALID_UNTIL are used to define the validity periods of modified options.
The following conditions apply for filling the elements
Both elements filled: valid within the resulting period.
Both elements left blank: valid indefinitely.
Only the VALID_FROM element is filled: valid from this date onwards.
Only the VALID_UNTIL element is filled: valid until this date.
Elements with the designation VALID_FROM must not contain a date prior to the catalogue start date. Elements with the designation VALID_UNTIL must not contain a date that is more than 10 years in the future from the catalogue date. The element must be left blank for an indefinite period.
Source
<xs:element name="VALID_UNTIL" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>260--8--Lieferbar_bis</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:date" />
  </xs:simpleType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
DETAIL_INFOS Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : DETAIL_INFOS Element
Description
This element is used to assign modified media. It is possible to assign a number of detail information to one version, and each image of the version can then be assigned to specific series or items. The respective image will then only be displayed for the corresponding series or item.
Namespace (none)
Diagram
DETAIL_INFO_REF Element Sequence DETAIL_INFOS Element
Overview
DETAIL_INFOS optional
This element is used to assign modified media. It is possible to assign a number of detail information to one version, and each image of the version can then be assigned to specific series or items. The respective image will then only be displayed for the corresponding series or item.
Sequence
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
Source
<xs:element name="DETAIL_INFOS" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>1000--0--NEW</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:sequence>
            <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
            <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
              <xs:annotation>
                <xs:documentation>406--0--NEW</xs:documentation>
                <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
              </xs:annotation>
              <xs:complexType>
                <xs:attribute name="SERIE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:nonNegativeInteger">
                      <xs:minInclusive value="0" />
                      <xs:maxInclusive value="999999" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
                <xs:attribute name="TYPE_NO" use="required">
                  <xs:annotation>
                    <xs:documentation>406--0--NEW</xs:documentation>
                    <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
                  </xs:annotation>
                  <xs:simpleType>
                    <xs:restriction base="xs:string">
                      <xs:minLength value="1" />
                      <xs:maxLength value="30" />
                    </xs:restriction>
                  </xs:simpleType>
                </xs:attribute>
              </xs:complexType>
            </xs:element>
          </xs:sequence>
          <xs:attribute name="DETAIL_INFO_NO" use="required">
            <xs:annotation>
              <xs:documentation>1000--0--NEW</xs:documentation>
              <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:positiveInteger">
                <xs:maxInclusive value="999999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
  </xs:complexType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
DETAIL_INFO_REF Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element : DETAIL_INFO_REF Element
Description
This element is used to reference the detailed information.
Namespace (none)
Diagram
ITEM_REF Element SERIE_REF Element Sequence DETAIL_INFO_REF Element
Overview
DETAIL_INFO_REF 1..∞
This element is used to reference the detailed information.
DETAIL_INFO_NO required Restriction of xs:positiveInteger
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Sequence
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
DETAIL_INFO_NO Restriction of xs:positiveInteger required
This attribute is used to specify the identification number of the referenced detailed information. D positiveInteger
P
M [1:999999999]
Source
<xs:element name="DETAIL_INFO_REF" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>1000--0--NEW</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:sequence>
      <xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
      <xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded">
        <xs:annotation>
          <xs:documentation>406--0--NEW</xs:documentation>
          <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
        </xs:annotation>
        <xs:complexType>
          <xs:attribute name="SERIE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:nonNegativeInteger">
                <xs:minInclusive value="0" />
                <xs:maxInclusive value="999999" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
          <xs:attribute name="TYPE_NO" use="required">
            <xs:annotation>
              <xs:documentation>406--0--NEW</xs:documentation>
              <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
            </xs:annotation>
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:minLength value="1" />
                <xs:maxLength value="30" />
              </xs:restriction>
            </xs:simpleType>
          </xs:attribute>
        </xs:complexType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="DETAIL_INFO_NO" use="required">
      <xs:annotation>
        <xs:documentation>1000--0--NEW</xs:documentation>
        <xs:documentation>, K. Richter 26.03.2014</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:positiveInteger">
          <xs:maxInclusive value="999999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
SERIE_REF Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element > DETAIL_INFO_REF Element : SERIE_REF Element
Description
This element is used to reference the series.
Namespace (none)
Diagram
SERIE_REF Element
Overview
SERIE_REF 0..∞
This element is used to reference the series.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the identification number of the referenced series. D nonNegativeInteger
P
M [0:999999]
Source
<xs:element name="SERIE_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="de">Version 2.3
01.07.2013 Hermann Balke
zusätzliche Referenzen auf die Serie für serienabhängige Bilder der gleichen Variante</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFO_REF Element | DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
ITEM_REF Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element > DETAIL_INFOS Element > DETAIL_INFO_REF Element : ITEM_REF Element
Description
This element is used to reference an item.
Namespace (none)
Diagram
ITEM_REF Element
Overview
ITEM_REF 0..∞
This element is used to reference an item.
SERIE_NO required Restriction of xs:nonNegativeInteger
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:999999]
TYPE_NO required Restriction of xs:string
This attribute is used to reference an item with an item number. D string
P
M [1:30]
Attributes
Name Type Use Default Fixed Description
SERIE_NO Restriction of xs:nonNegativeInteger required
This attribute is used to specify the serial number of the referenced item. D nonNegativInteger
P
M [0:999999]
TYPE_NO Restriction of xs:string required
This attribute is used to reference an item with an item number. D string
P
M [1:30]
Source
<xs:element name="ITEM_REF" minOccurs="0" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>406--0--NEW</xs:documentation>
    <xs:documentation>maxOccurs auf unbounded gesetzt, K. Richter 12.06.2015</xs:documentation>
  </xs:annotation>
  <xs:complexType>
    <xs:attribute name="SERIE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation xml:lang="de">Version 2.1 Build 7 für Polster erweitert auf 6 Stellen /28.11.2011 /ba</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:nonNegativeInteger">
          <xs:minInclusive value="0" />
          <xs:maxInclusive value="999999" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
    <xs:attribute name="TYPE_NO" use="required">
      <xs:annotation>
        <xs:documentation>406--0--NEW</xs:documentation>
        <xs:documentation>23.01.2013 - Version 2.2.5 Polsterbranche - von 18 auf 30stellig geändert</xs:documentation>
      </xs:annotation>
      <xs:simpleType>
        <xs:restriction base="xs:string">
          <xs:minLength value="1" />
          <xs:maxLength value="30" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
DETAIL_INFO_REF Element | DETAIL_INFOS Element | OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
OPTION_FREETEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element > OPTIONS Element > OPTION Element : OPTION_FREETEXT Element
Description
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
Namespace (none)
Type
Restriction of xs:boolean
Diagram
OPTION_FREETEXT Element
Overview
OPTION_FREETEXT optional Restriction of xs:boolean
This element is used to set an identifier that states that the planner must, for example, enter a text for RAL colours if the boolean value is set to true. D boolean
P
M
Source
<xs:element name="OPTION_FREETEXT" minOccurs="0" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation xml:lang="DE">IDM 2.5
wenn true, dann muss der Planer einen Text eingeben.</xs:documentation>
    <xs:documentation>Längenangabe entfernt, K. Richter, 12.03.2015</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:boolean" />
  </xs:simpleType>
</xs:element>
See Also
OPTION Element | OPTIONS Element | FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
FEATURE_TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : FEATURE_TEXT Element
Description
This element contains trade-specific texts for features.
Namespace (none)
Type
languagetext60 Complex Type
Diagram
LANGUAGE Element Sequence FEATURE_TEXT Element
Overview
FEATURE_TEXT languagetext60 Complex Type
This element contains trade-specific texts for features.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="FEATURE_TEXT" type="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--0--NEW</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 0</xs:documentation>
  </xs:annotation>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
SEQUENCE_NO Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > T_MODIFY_CONTENT_CATALOG Element > FEATURE_DEFINITION Element > FEATURES Element > FEATURE Element : SEQUENCE_NO Element
Description
This element is used to specify a manufacturer-specific sorting for the features. It must reconcile with the base catalogue.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options of the base catalogue (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1:FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ of the base catalogue 		D nonNegativeInteger
P
M [0:999]
Namespace (none)
Type
Restriction of xs:nonNegativeInteger
Diagram
SEQUENCE_NO Element
Overview
SEQUENCE_NO Restriction of xs:nonNegativeInteger
This element is used to specify a manufacturer-specific sorting for the features. It must reconcile with the base catalogue.
The order is a recommendation by the manufacturer. The dealership will, if necessary, work with a different sorting. The sorting is, for example, used for: display in on-screen forms, order of the options during the ordering process, or forms.
The sorting must be specified unequivocally for all data records.
The element is left blank for invisible head options of the base catalogue (HEADER_POS_VARIATION_TYPE = U (path 1)).

Element paths
Path 1:FEATURE_DEFINITION/FEATURES/FEATURE/HEADER_POS_VARIATION_TYPE/ of the base catalogue 		D nonNegativeInteger
P
M [0:999]
Source
<xs:element name="SEQUENCE_NO" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>250--4--Sortierung</xs:documentation>
    <xs:documentation>Version Beta 2.0 Build 4</xs:documentation>
  </xs:annotation>
  <xs:simpleType>
    <xs:restriction base="xs:nonNegativeInteger">
      <xs:minInclusive value="0" />
      <xs:maxInclusive value="999" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
FEATURE Element | FEATURES Element | FEATURE_DEFINITION Element | T_MODIFY_CONTENT_CATALOG Element | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%ItemTitle%%

MODIFY_CONTENT_IDMP 3.0.1 XML schema documentation
Complex data types
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > Complex data types


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
languagetext Complex Type
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd : languagetext Complex Type
Description

This data type is used to create multiple-language texts of any length.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetext Complex Type
Overview
languagetext

This data type is used to create multiple-language texts of any length.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool.
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT xs:string

This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute.

This element contains the text for a CDATA node.

The text must be specified in HTML format:
<b> Bold font
<br> line break

 D string
P
M
Used By
CATALOG_INFO Element
EXTERNAL_NAME Element
TOOL_TIP Element
FULL_TEXT Element
PLANNING_ADVICE Element
OPTION_COMMENT_TEXT Element
Source
<xs:complexType name="languagetext" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT" type="xs:string" />
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
languagetext30 Complex Type
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd : languagetext30 Complex Type
Description
This data type is used to create multiple-language texts with a maximum length of 30 characters.
Namespace (none)
Diagram
LANGUAGE Element Sequence languagetext30 Complex Type
Overview
languagetext30
This data type is used to create multiple-language texts with a maximum length of 30 characters.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Used By
CATALOG_NAME Element
Source
<xs:complexType name="languagetext30" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 30stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,30}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
LANGUAGE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > languagetext30 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,30}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetext30 Complex Type | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > languagetext30 Complex Type > LANGUAGE Element : TEXT Element
Description
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,30}
M [1:30]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,30}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetext30 Complex Type | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
languagetext40 Complex Type
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd : languagetext40 Complex Type
Description

This data type is used to create multiple-language texts with a maximum length of 40 characters.

Namespace (none)
Diagram
LANGUAGE Element Sequence languagetext40 Complex Type
Overview
languagetext40

This data type is used to create multiple-language texts with a maximum length of 40 characters.

Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
Used By
INTERNAL_NAME Element
Source
<xs:complexType name="languagetext40" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 40stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,40}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
LANGUAGE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > languagetext40 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,40}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetext40 Complex Type | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > languagetext40 Complex Type > LANGUAGE Element : TEXT Element
Description
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,40}
M [1:40]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,40}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetext40 Complex Type | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
languagetext60 Complex Type
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd : languagetext60 Complex Type
Description
This data type is used to create multiple-language texts with a maximum length of 60 characters.
Namespace (none)
Diagram
LANGUAGE Element Sequence languagetext60 Complex Type
Overview
languagetext60
This data type is used to create multiple-language texts with a maximum length of 60 characters.
Sequence
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Used By
OPTION_TEXT Element
FEATURE_TEXT Element
Source
<xs:complexType name="languagetext60" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:annotation>
    <xs:documentation>Für Texte mit 60stelliger Zeile</xs:documentation>
    <xs:documentation>K. Richter 15.08.2017</xs:documentation>
  </xs:annotation>
  <xs:sequence>
    <xs:element name="LANGUAGE" maxOccurs="unbounded">
      <xs:complexType>
        <xs:sequence>
          <xs:element name="TEXT">
            <xs:simpleType>
              <xs:restriction base="xs:string">
                <xs:pattern value="[\S ]{1,60}" />
              </xs:restriction>
            </xs:simpleType>
          </xs:element>
        </xs:sequence>
        <xs:attribute name="ISO_LANGUAGE_ID" use="required">
          <xs:simpleType>
            <xs:restriction base="xs:language">
              <xs:pattern value="[A-Z]{2}" />
            </xs:restriction>
          </xs:simpleType>
        </xs:attribute>
      </xs:complexType>
    </xs:element>
  </xs:sequence>
</xs:complexType>
See Also
MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
LANGUAGE Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > languagetext60 Complex Type : LANGUAGE Element
Description
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
Namespace (none)
Diagram
TEXT Element Sequence LANGUAGE Element
Overview
LANGUAGE 1..∞
This element is used to store texts in multiple languages. One element is created for each language. Language is specified in the attribute ISO_LANGUAGE_ID. The same languages must be specified for each element in the data pool. They must be identical to the ISO_LANGUAGE_ID elements under T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION
ISO_LANGUAGE_ID required Restriction of xs:language
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Sequence
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Attributes
Name Type Use Default Fixed Description
ISO_LANGUAGE_ID Restriction of xs:language required
This attribute specifies the ISO code of the stored text's language. D language
P [A-Z]{2}
M [2:2]
Source
<xs:element name="LANGUAGE" maxOccurs="unbounded" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TEXT">
        <xs:simpleType>
          <xs:restriction base="xs:string">
            <xs:pattern value="[\S ]{1,60}" />
          </xs:restriction>
        </xs:simpleType>
      </xs:element>
    </xs:sequence>
    <xs:attribute name="ISO_LANGUAGE_ID" use="required">
      <xs:simpleType>
        <xs:restriction base="xs:language">
          <xs:pattern value="[A-Z]{2}" />
        </xs:restriction>
      </xs:simpleType>
    </xs:attribute>
  </xs:complexType>
</xs:element>
See Also
languagetext60 Complex Type | MODIFY_CONTENT_IDMP_3_0_1.xsd


%%LocalItemTitle%%

MODIFY_CONTENT_IDMP_3_0_1.xsd
TEXT Element
View with Navigation Tools
MODIFY_CONTENT_IDMP_3_0_1.xsd > languagetext60 Complex Type > LANGUAGE Element : TEXT Element
Description
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Namespace (none)
Type
Restriction of xs:string
Diagram
TEXT Element
Overview
TEXT Restriction of xs:string
This element is used to store the text in the language specified in the LANGUAGE element of the ISO_LANGUAGE_ID attribute. D string
P [\S ]{1,60}
M [1:60]
Source
<xs:element name="TEXT" xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:simpleType>
    <xs:restriction base="xs:string">
      <xs:pattern value="[\S ]{1,60}" />
    </xs:restriction>
  </xs:simpleType>
</xs:element>
See Also
LANGUAGE Element | languagetext60 Complex Type | MODIFY_CONTENT_IDMP_3_0_1.xsd