%%ItemTitle%%

EANCOM_V2.03
Home page

Electronic interchange of orders for planning-intensive furniture

Documentation

Effective 01.07.2017

Conventions on the basis of

EANCOM 97A

EANCOM-ORDERS (V2.03)
EANCOM-OSTRPT (V2.03)
EANCOM-ORDRSP (V2.03)
EANCOM-ORDCHG(V2.03)

Contact:

Daten Competence Center e. V. Dr.-Ing. Olaf Plümer, Managing Director

Goebenstrasse 4-10

D - 32052 Herford

Tel.: + 49 5221 12 65 37

Fax.: + 49 5221 12 65 537
E-mail: pluemer@dcc-moebel.org

Info: www.dcc-moebel.org


Introduction

This document contains conventions on using the international EANCOM format for handling orders and order responses for planning-intensive furniture (in particular kitchen furniture).

The conventions were developed in a working group facilitated by Daten Competence Center e. V. (DCC) and including representatives of kitchen furniture manufacturers and system providers.

The basis for the electronic interchange of data between retailers and industry is the internationally standardised EANCOM format. Its syntax is documented on a CD-ROM which may be obtained from GS1 Germany (www.gs1-germany.de) in Cologne. This CD-ROM defines so-called message types for the various business processes of which EANCOM-ORDERS is of particular interest for orders, OSTRPT for confirmation of receipt, EANCOM-ORDRSP for order response as well as EANCOM-ORDCHG for changing orders.

The following document describes how the various data elements are filled in EANCOM-ORDERS, EANCOM-OSTRPT, EANCOM-ORDRSP and EANCOM-ORDCHG.

In this context, reference is made to EANCOM 97A. Anything not explicitly defined in the document follows the description of Standard EANCOM 97A.

The commercial contents of an order are transmitted in an EANCOM file, graphic contents (coordinates, etc.) in an additional EDIGRAPH file.

The commercial contents of an order are relevant to the order, the graphic contents are relevant to planning.

Under the conventions, only the order and order confirmation for a commission are transmitted in an EANCOM and EDIGRAPH file.


General structure

The EANCOM files are pure ASCII files without line breaks. The standard ASCII characters shown in the following table are used as separator symbols.

Symbol | ASCII code | Meaning
′ | 39 | End of EDI line
+ | 43 | Separator between segment code and data groups or data elements
: | 58 | Separator between the data elements of a group
. | 46 | Decimal point

In the explanations below, the following notation is used for describing the data elements and data-element groups.

Appearing first is name of the EDI segment, the exact syntax of which (field type, max. field length etc.) is provided on the above-mentioned CD-ROM.

This is followed by the data groups and data elements used. Here, a single four-character string (xxxx) references the data element xxxx, whereas the use of two four-character strings (yyyy,xxxx) references the data element xxxx within the data-element group yyyy. This is then followed by the value of the data element, with variable values in the documentation being shown in the form of <...>. Constant values are specified in the form of "...".

The FTX segments are limited in comparison to EANCOM 97A. It it not possible to transmit more than 99 FTX segments, each with a text line of up to 70 characters. This limitation of FTX segments applies to all message types agreed.

Sequence of segments:

The segments for all EDI documents must always be delivered in the order of sequence defined in EANCOM 97A.


ORDERS

Order

EANCOM-ORDERS

Structure of an EDI order in the EANCOM-ORDERS format

UNA { Separator character definition }

UNB { Header of EDI files }

UNH { Header of a message }

BGM { Beginning of message. Definition of order number etc. }

DTM { Date field - transaction dates }

FTX { Additional information at commission level }

RFF { Additional information at commission level }

NAD { Identification of parties involved (name/address) }

CTA { Specification of this party's contact person }

COM { Specification of how to reach the contact person, e.g. fax / phone }

LIN (Header data) { Beginning of a product range/option }

PIA { More detailed specification of an option }

LIN (Article data) { Beginning of a new item }

PIA { More detailed specification of the article: specification of options etc. }

IMD { Article description }

MEA { Article dimensions for dimension-specific articles }

QTY { Specification of order quantity }

FTX { Additional information at item level }

RFF { Reference numbers }

UNS { Separator between item and end section }

UNT { End of message }

UNZ { End of EDI file }

The following segments in the header of an EDI message contain basic standardisation conventions and must always be present.


UNA
ORDERS > UNA

This element defines the separators:

":+.? '"

In EANCOM, four special characters have a particular meaning and serve as default separators (default) for EANCOM:

Apostrophe | ' | = | End-of-segment character
Plus sign | + | = | Segment identifier and data-element separator
Colon | : | = | Group-data element separator
Question mark | ? | = | Release character; if the question mark immediately precedes a service character, it restores its normal meaning. E.g. 10?+10=20 means 10+10=20. A question mark is represented by ??


UNB
ORDERS > UNB

This segment is the user data header segment.

It is used for opening, identifying and describing an interchange file.

UNB

S001,0001 "UNOC"

S001,0002 "3"

S002,0004 <Sender identification, e.g. trading company>

S003,0010 <Recipient identification (IDM manufacturer ID or ILN)>

S004,0017 <Message creation date (format YYMMDD)>

S004,0019 <Message creation time (format SSMM)>

0020 <Unique reference number of EDI file>

0026 <Name and version number of transmitting system>

0032 <Version of order data format: "EANCOM_ORDER_V2.03">

0035 <Indication of whether this is a test message (1=test)>

Note: The name of the sending system is not sufficient, the system's current version number must also be transmitted.

Important: The name and version number of last sending system must always be communicated.


UNH
ORDERS > UNB > UNH

The message header segment is used for opening, identifying and specifying a message.

UNH

0062 <Unique reference number of EDI message>

S009,0065 "ORDERS"

S009,0052 "D"

S009,0054 "97A"

S009,0051 "UN"

S009,0057 "EAN007"

The content section of the EDI message starts here:

The next two segments are mandatory:

BGM

DTM


BGM
ORDERS > UNB > BGM

This segment is the beginning of the message.

It is used for indicating the type and function of a message and for communicating the identification number.

BGM

C002,1001 "220" (Document type = order)

or C002,1001 "226" (Document type = call order)

or C002,1001 "224" (Document type = rush order)

1004 <Order number>

1225 "9" (Original)


DTM
ORDERS > UNB > DTM

This segment contains date/time/period.

It is used for indicating the order date and -if necessary- dates requested for goods delivery.

DTM

C507,2005 "137" (Document date)

C507,2380 <Date>

C507,2379 "102" (Date format = YYYYMMDD)

The document date indicated in this segment is identical to the date shown in the UNB segment.

For an order (see BGM segment), this is now followed by up to two additional DTM segments with the requested delivery date. For a call order, the following DTM segments are optional:

DTM

C507,2005 "2" (Date type = delivery date, exact)

or C5072,005 "63" (Date type = delivery date, latest)

or C507,2005 "64" (Date type = delivery date, earliest)

C507,2380 <Delivery date>

C507,2379 "102" (Date format = YYYYMMDD)

or C507,2379 "616" (Date format = YYYYWW, calendar week)

Date type "2" specifies that the delivery is to take place exactly on the requested delivery date or within the specified delivery week.

Date type "63", on the other hand, requests delivery by no later than the specified date although delivery may also be made before this date. Date type "64" denotes that delivery is not to be made before the given date.

This means that date types "63" and "64" allow you to specify a delivery period either by stating a delivery week ("616") or a delivery day ("102").

Option: in addition to the delivery date, a date can be communicated on which the supplier is requested to assembly/install the kitchen. This information must be provided if the manufacturer is directly involved in assembly/installation, e.g. in the case of show kitchens.

DTM

C507,2005 "18" (Date type = installation date)

C507,2380 <Assembly/installation date>

C507,2379 "102" (Date format = YYYYMMDD)

or C507,2379 "616" (Date format = YYYYWW, calendar week)


FTX
ORDERS > UNB > FTX

If, in addition to the EANCOM file, further files are to be sent to the manufacturer, these must be described in the following segment:

FTX

4451 "ZZZ"
C108,4440 <File information>
3453 <Language according to ISO code, e.g. DE>

The <File information> field consists of the following components, each separated by a semicolon:

<File information>=<File type>;<File format>;<File name>;<File description>

File type

1 EDIGRAPH

11 Floor plan

21 Wall/front view

22 Tile plan

23 Installation plan

31 Perspective

41 Plinth sketch

42 Worktop sketch

43 Wall sealing profile sketch

44 Light-pelmet sketch

45 Cornice sketch

46 Flooring sketch

99 Other

File format

1 EDIGRAPH

11 JPEG

50 PDF

99 Others (only after bilateral agreement between sender and recipient)

Generally speaking, electronic orders made with an EDIGRAPH file must also include a floor plan in the above formats (11,50,99). It is also recommended to include relevant wall views of the kitchen being planned.

File name

The file name, including extension, must be no longer than 30 characters.

The following characters must never be used within file names: ;$%&[]{} plus the characters not permitted by the Windows operating system |<>?*:/\" . Spaces are permitted, tabs and carriage returns are not. If the file name contains a single quotation mark ('), this must be masked with the character specified in the UNA segment so that it complies with the normal rules. Example: " ?' ".

File description

No more than 30 characters to describe the file in plaintext.

Example: "Front view, wall 1", "Bird's-eye view"

Optionally, freely worded text may be sent for the entire commission (no more than 99 lines and 70 characters per line). However, the use of freely worded text means that the order cannot be processed without the interaction of a member of internal sales staff.

Freely worded texts must not, however, be misused to send information that can be communicated in structured form in other EDI segments.

FTX

4451 "AAI" C108,4440 <Text>
3453 <Language according to ISO code, e.g. DE>

The commission details are then provided in the REF segment.


RFF
ORDERS > UNB > RFF

Freely worded texts are followed by the commission details:

RFF

C506,1153 "CR"

C506,1154 <Commission number, e.g. "4711/01">

RFF
 C506.1153 "UC"

C506,1154 <Commission name, e.g. "Miller">

A commission number (C506,1153="CR") must always be stated whereas the customer name (C506,1153="UC") is optional.

The structure of the commission number is not subject to any rules and may be defined in any way by the sending system. If the sending system only uses the segment for sending the commission number, this may also contain the commission name, e.g. "4711/01, Miller".

A unique reference number must also be provided that identifies an order transaction from start to finish. Normally, this is commission number "CR".

On receiving an order response (EANCOM-ORDRSP), the manufacturer's system expects the commission number (C506,1153="CR") to be communicated back unchanged so that the order and order response are unequivocally matched up.

If a supplier's order number has already been communicated to the retailer by means of the EANCOM-OSTRPT or EANCOM-ORDRSP messages, this is transmitted back for secure communication.

RFF
 C506,1153 "VN"

C506,1154 <Order number, e.g. "12345/67">

If this is a follow-up order, the commission number of the original order must also be comminicated as reference.

RFF

C506,1153 "ON"

C506.1154 <Commission number of the original order, e.g. "4711/00" >

Optionally, a purchase contract number can be stated

RFF

C506,1153 "CT"

C506,1154 <Purchase contract number>

To define orders that differ from a standard order, e.g. object/project-related orders, show kitchens or pick-up orders, the <order type> must always bestated:

RFF

C506,1153 "ZZZ"

C506,1154 <Order type, e.g.: object/project-related order/show kitchen>

Value | Meaning
001 | Object/project order
002 | Show kitchen order
003 | Pick-up order

For special orders (objects/projects/show kitchens), further optional information, such as the <framework agreement number> etc., can be communicated.

Only orders of order type 001 and 002 are regarded as special orders.

RFF

C506,1153 "BO"

C506,1154 <Framework order number, e.g.: "object no./show-kitchen no.">

This information must only be sent if values 001 or 002 were communicated as the order type (RFF+ZZZ). If this order is a sub-order within a larger-type business transaction, the number of the overall order can be communicated here. For a framework agreement, for example, this would be the framework contract/framework order number. In show-kitchen planning involving several show kitchens, this is where the main planning number (or appropriate identification) is communicated. If this segment is provided, segment RFF+AAO described below must also be provided:

RFF

C506,1153 "AAO"

C506,1154 <Project/object no./show-kitchen no.>

The number of the project/object or show kitchen is communicated with (AAO).

This information refers to the above-mentioned RFF+BO segment and denotes a clear subdivision.

This segment may only be provided if the RFF+BO segment was also provided.

With project/object orders, this is where the project/object number is communicated.

In show-kitchen planning involving several kitchens, this is where the show-kitchen number is communicated.

The identification of the building/flat or the number of the booth of a show kitchen is communicated with (ACD).

RFF

C506,1153 "ACD"

C506,1154 <Building/flat/booth no.>

This is an additional reference to RFF+AAO. This segment may be provided only if the RFF+AAO segment was also provided.

With object orders, for example, the flat number or building number can be communicated.

In show-kitchen planning involving several kitchens, this segment is used for communicating the booth number.

In show-kitchen planning, it may be necessary to assign the order to a specific dealership branch. This is done in the segment described below:

RFF

C506,1153 "SD"

C506,1154 <Branch no.>

(SD) communicates the identification of the branch at which the show kitchen is to be installed.

This segment may only be communicated for a show-kitchen order.

This segment may only be provided if the RFF+AAO segment was also provided.

Example of show kitchens:

Framework order number (BO) = "RAN-LU-2007-286"

Show-kitchen number (AAO) = "MK-LU-012007-22"

Booth number (ACD) = "MK-LU-012007-22-8"

Branch number (SD) = "LU-WI076"

Example of object/project order:

Framework order number (BO) = "APO4711"

Object/project number (AAO) = "South Residential Park"

Building number (ACD) = "A26"

﻿


NAD
ORDERS > UNB > NAD

There are two ways of communicating the supplier, depending on whether or not the supplier has a GLN (Global Location Number). The GLN is assigned by GS1, is unique world-wide and therefore explicitly identifies the addressee. If the supplier does not have a GLN, the IDM manufacturer's ID is used instead.

With all possible NAD segments of existing message types, the Name/Name1, Street address, Town/city and Postcode fields are mandatory fields and must always be completed.

Specification of supplier's address

Option 1:

NAD

3035 "SU" Meaning of address (SU = supplier)
C082,3039 <Supplier's GLN>
C082,3055 "9"
C080,3036 <Name 1>
C080,3036 <Name 2>
C059,3042 <Street address>
3164 <Town/city>
3251 <Postcode>
3207 <Country according to ISO code, e.g. GB for the United Kingdom>

Option 2:

NAD

3035 "SU" Meaning of address (SU = supplier)
C082,3039 <Supplier's IDM-manufacturer ID>
C082,3055 "91"
C080,3036 <Name 1>
C080,3036 <Name 2>
C059,3042 <Street address>
3164 <Town/city>
3251 <Postcode>
3207 <Country according to ISO code, e.g. GB for the United Kingdom>

Specification of the retailer's address

This must always be followed by the retailer's address, with it also being possible here to state the GLN (preferably) or the customer no. :

NAD

3035 "BY" Meaning of address (BY = buyer)
C082,3039 <Retailer's GLN>
C082,3055 "9"
C080,3036 <Name>
C059,3042 <Street address>
3164 <Town/city>
3251 <Postcode>
3207 <Country according to ISO code, e.g. GB for the United Kingdom>

or

NAD

3035 "BY" Meaning of address (BY = buyer)
C082,3039 <Retailer's customer number at supplier >
C082,3055 "91"
C080,3036 <Name>
C059,3042 <Street address>
3164 <Town/city>
3251 <Postcode>
3207 <Country according to ISO code, e.g. GB for the United Kingdom>

Note:

The retailer's customer number at the supplier or the GLN is mandatory :

A further sender contact address is possible so that the order response can be sent to the sender of the Order.edi or to a central contact.

In turn, further contact data should be provided for the Order Status Report because in the retail trade this information often goes to other members of staff.

Specification of the delivery address

The other optional NAD segments correspond to the above (BY) with the following exceptions:

If the delivery address differs from the buyer's address (BY), a further NAD segment (DP) is always necessary:

NAD

3035 "DP" Meaning of address (DP = delivery address)

If consignment goes to a retailer's warehouse address, this warehouse address will normally have a customer no. or GLN. In this case, group C082 must also be provided either with qualifier 9 (GLN) or 91 (customer no.).

If the GLN is used for the retailer's address (3035 "BY"), it must also be used here, otherwise the customer number:

NAD

3035 "DP" Meaning of address (DP = delivery address)
C082,3039 <Retailer's GLN>
C082,3055 "9"
C080,3036 <Name>
C059,3042 <Street address>
3164 <Town/city>
3251 <Postcode>
3207 <Country according to ISO code, e.g. GB for the United Kingdom>

NAD

3035 "DP" Meaning of address (DP = delivery address)
C082,3039 <Retailer's customer no.>
C082,3055 "91"
C080,3036 <Name>
C059,3042 <Street address>
3164 <Town/city>
3251 <Postcode>
3207 <Country according to ISO code, e.g. GB for the United Kingdom>

Is the delivery address is the address of a consumer, there will be no group C082 because the customer neither has a number at the manufacturer nor a GLN.

Agent's address

The following address under code "AB" identifies the sender (UNB segment) as the buyer’s (BY) agent/authorised representative:

NAD

3035 "AB" Meaning of address: AB = agent (order on behalf the the buyer (BY))

This segment is mandatory if the sender (UNB segment) and the buyer (NAD+BY) are not identical.

This address has no effect on the regulations governing the delivery address and can never be used as the delivery address.

Specification of installation address

The following address under der code "MA" is only communicated if assembly/installation is carried out by the manufacturer:

NAD

3035 "MA" Meaning of address: (MA = installation address)

This is an additional address and replaces none of the above addresses.

This address has no effect on the regulations governing the delivery address and can never be used as the delivery address.

For each of the NAD segments mentioned above, it is possible to provide details of contact persons and how to reach them (immediately after the particular NAD segment).

This is done via the CTA segments.


CTA
ORDERS > UNB > NAD > CTA

For each of the NAD segments mentioned above, it is possible to provide details of contact persons and how to reach them (immediately after the particular NAD segment).

3 CTA segments with codes (3139) OC, IC and ODP are permitted per NAD segment.

For these three data elements it is now possible to provide a 17-character and a 35-character group data element.

A general contact for all questions relating to the order is named in the CTA+OC segment.

For code OC, the 17-character field is used for identifying the salesperson (log-in name in the planning system), the 35-character field for the salesperson's name in the form of: "Last name;First name;Form of address"

CTA

3139 "OC"

C056,3413 <Salesperson identification>

C056,3412 <Last name;First name;Form of address>

To ensure that this information is provided, the CTA segment with "OC" is mandatory for NAD segment "BY".

By way of option, 2 further CTA segments with the same "IC" and "ODP" ID are permitted for identifying additional contacts.

CTA+IC (IC=information contact) is for confirmation of receipt.

CTA+ODP is for the ORDRSP, i.e. this segment only occurs once.

IC and ODP are optional. If this information is provided, it should also be used.

A maximum of 3 CTA segments are permitted per NAD segment.

CTA

3139 "IC"

C056,3413 <Identification of information contact>

C056,3412 <Last name;First name;Form of address>

CTA

3139 "ODP" (once only (optional))

C056,3413 <Identification>

C056,3412 <Last name;First name;Form of address>

The following communication contact details for the contact persons are specified in the COM segment.


COM
ORDERS > UNB > NAD > CTA > COM

The following communication contact details are provided for the contact persons.

COM

C076,3148 <Telephone number of contact person>

C076,3155 "TE"

COM

C076,3148 <Fax number of contact person>

C076,3155 "FX"

COM

C076,3148 <E-mail address of contact person>

C076,3155 "EM"

If the contact person has several telephone numbers, it is possible to supply several COM segments with the same qualifier "TE". However, there must be no more than five COM segments.


LIN (Header data)
ORDERS > UNB > LIN (Header data)

The data segments at item level begin here:

Header data (options)

If the recipient of the EANCOM message is a wood supplier, the commission header data are now specified (product range or options). Here, a standard header is defined first. This contains details that apply to all supplier articles subsequently communicated. Any articles deviating from this standard header are communicated at item level and overwrite the information given in the standard header.

Note: features must only occur and be communicated once .

If combined options are created in the IDM data and if these are relevant to orders, they must always be communicated

LIN

1082 <Consecutive numbering beginning with 1>

C212,7140 "SPECIFICATION"

C212,7143 "MF"

1222 "0"

The actual information specified in the standard header is communicated in PIA segments. As the number of PIA segments in EANCOM format is currently limited to 25, it has been agreed that the ordering format and the formats based on it (e.g. order response) will also be able to transmit more than 25 PIA segments. It has also been agreed that only the first "C212" data-element group will be used in the PIA segments.


PIA
ORDERS > UNB > LIN (Header data) > PIA

The actual information specified in the standard header is communicated in PIA segments. As the number of PIA segments in EANCOM format is currently limited to 25, it has been agreed that the ordering format and the formats based on it (e.g. order response) will also be able to transmit more than 25 PIA segments.Only the first data-element group, "C212", is used for stating the manufacturer ID, the serial number and the catalogue ID, up to 5 data-element groups can be used for the product range and options. This is subject to the following rule:

The first two groups are used for the option designation, the fourth and fifth group for the designation of the feature. The third group is available in reserve for future usages.

PIA

4347 "5"

C212,7140 <Supplier's IDM-manufacturer ID from T_NEW_CATALOG/CATALOG/CATALOG_IDENTIFICATION/MANUFACTURER_ID>

C212,7143 "36"

C212,3055 "91"

PIA

4347 "5"

C212,7140 <Serial no. from T_NEW_CATALOG/SERIES/SERIE/SERIE_NO>

C212,7143 "18"

C212,3055 "91"

PIA

4347 "5"

C212,7140 <Catalogue ID>

C212,7143 "AA"

C212,3055 "91"

The catalogue ID consists of several fields of element T_NEW_CATALOG/CATALOG and the data version of the planning system, in each case separated by a semicolon:

<Catalogue ID>=<Product brand>;<Catalogue number>;<Data version>;<Data version in the planning system>

Note:

The <Data version in the planning system> field may be filled with a maximum of 11 characters.

The information in the <Data version> must originally come from the IDM data (without dots) .

Example: Product brand "4", catalogue number "02/2006", data version "13.01.2006" data version in the planning system "13.01.2006"

Catalogue ID = "4;02/2006;13012006;2006.1A"

The product range is communicated in a PIA segment:

PIA

4347 "5"

C212,7140 <Product-range key(5-character) + product-range name(30-character, 1st-30th character)>

C212,7143 "1"

C212,3055 "91"

C212,7140 <Product-range key(5-character) + product-range name(30-character, 31st-60th character)>

C212,7143 "1"

C212,3055 "91"

The product-range key corresponds to attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/STYLE_REF/STYLE_NO and must be given in 5-character form.

The product-range name corresponds to element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT/TEXT_LINE/TEXT and must be no longer than 30 characters.

If it is longer than 30 characters in a particular element, two data-element groups are selected, with the first one containing the first 30 characters, the second one the following 30 characters.

The selected options are also communicated in PIA segments:

PIA

4347 "5"

C212,7140 <Feature number (5-character) + feature text (30-character, 1st-30th character)>

C212,7143 <Feature>

C212,3055 "91"

C212,7140 <Feature number (5-character) + feature text (30-character, 31st-60th character)>

C212,7143 <Feature>

C212,3055 "91"

The feature number corresponds to attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_KEY and must be given in 5-character form.

The option name corresponds to element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT/TEXT_LINE/TEXT and must be no longer than 30 characters.

If it is longer than 30 characters in a particular element, two data-element groups are selected, with the first one containing the first 30 characters, the second one the following 30 characters.

The feature corresponds to attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_NO.

The fourth and fifth "C212" data-element groups are used for transmitting the feature:

C212,7140 <Feature number (5-character) + description of feature (30-character, 1st-30th character)>

C212,7143 <Feature>

C212,3055 "91"

C212,7140 <Feature number (5-character) + description of feature (30-character, 31st-60th character)>

C212,7143 <Feature>

C212,3055 "91"

The description of the feature corresponds to element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TEXT and must be no longer than 30 characters.

If it is longer than 30 characters in a particular element, two data-element groups are selected, with the first one containing the first 30 characters, the second one the following 30 characters.

One exception is feature 402 (plinth height) which, in field C212,7140, does not communicate the option from attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_KEY but the actual plinth height in mm:

PIA

4347 "5"

C212,7140 <Plinth height in mm, without decimal places>

C212,7143 <402 >

C212,3055 "92"


LIN (article data)
ORDERS > UNB > LIN (article data)

Following the header data, the articles are transmitted in individual LIN segments:

LIN

1082 <Consecutive number>

C212,7140 "EAN number of article, if available, otherwise empty"

C212,7143 "EN" if EAN number available, otherwise empty

1222 <Main/sub-item level>

In field 1222 all main items are given the value 1, sub-items the value 2, sub-sub-items the value 3 etc. If the order contains a block, it is recommended to transmit this as the first article.

Collective items can be created for long parts:

LIN

1082 <Consecutive number>

C212,7140 "EAN number of article, if available, otherwise empty"

C212,7143 "SG"

1222 1

One LIN segment is created for each long-part type.

Further article details, such as series deviating from the standard header, external articles, . . are provided in the PIA segments


PIA
ORDERS > UNB > LIN (article data) > PIA

Details of manufacturer/series

If the article is from a series that deviates from the standard header, this deviation must also be transmitted for a unique description of the article.

If the article is an external article, i.e. an article from another supplier and not ordered from this supplier but important for correct completion (e.g. fitted stove), it is necessary to state the supplier and series from which the article comes.

Manufacturer/series

PIA

4347 "5"

C212,7140 <External Supplier's IDM Manufacturer ID>

C212,7143 <36>

C212,3055 "91"

PIA

4347 "5"

C212,7140 <Serial number of the external article supplier or of the supplier in the event of any deviation from the standard header>

C212,7143 <18>

C212,3055 "91"

In addition to any EAN number that may have been communicated in the LIN segment, it is now essential to specify the order type for all articles:

PIA

4347 "5"

C212,7140 <T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO>

C212,7143 "SA"

C212,3055 "91"

Value "SA" must be entered into field C212,7143 for supplier articles not relevant to the order. In general, all articles in an order are relevant to that order. Exceptions, for example, include articles that are already available at the consumer, therefore not ordered but communicated for correctly generating length-dependent articles.

By definition, external articles (see above) are never order-relevant, regardless of the value in field C212,7143.

Further additional information

If an IT number for the article has been issued in the manufacturer IDM data, it is now shown in an additional PIA segment:

PIA

4347 "5"

C212,7140 <T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EDP_NUMBER>

C212,7143 "MF"

C212,3055 "91"

The hinge side is now indicated for articles hinged to a particular side:

PIA

4347 "1"

C212,7140 <L/R/M>

C212,7143 <6>

C212,3055 "91"

The type of construction is now indicated for articles governed by a particular construction type:

PIA

4347 "1"

C212,7140 <L/R>

C212,7143 <67>

C212,3055 "91"

For articles with visible sides, details relating to them must now be provided: (L(eft)/R(ight)/O(Top)/U(Bottom)/H(Rear)) in the same way as the PIA segments for hinge mounting and construction type:

PIA

4347 "1"

C212,7140 <L/R/O/U/H>

C212,7143 <68>

C212,3055 "91"

Feature "68" may only occur once.

C212,7140 unit details provide information on visible sides.

C212,7140 may contain several details, e.g. LR, LRU, LU, ... . This information can be given in any order of sequence.

The article visible side then comes in the form of a separate PIA segment and sub-item for the kitchen unit.

This means that a new LIN segment must be provided for each visible side of a unit.

Information on variations from the standard header

Any variation from the standard header (regardless of whether such relates to finishes or surcharges) are shown in the same way as in the standard header's PIA segments:

PIA

4347 "5"

C212,7140 <Feature number (5-character) + feature text (30-character, 1st-30th character)>

C212,7143 <Feature>

C212,3055 "91"

C212,7140 <Feature number (5-character) + feature text (30-character, 31st-60th character)>

C212,7143 <Feature>

C212,3055 "91"

The feature number corresponds to attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_KEY and must be given in 5-character form.

The feature text corresponds to element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_TEXT/TEXT_LINE/TEXT and must be no longer than 30 characters.

If it is longer than 30 characters in a particular element, two data-element groups are selected, with the first one containing the first 30 characters, the second one the following 30 characters.

The feature corresponds to attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_NO.

The fourth and fifth "C212" data-element groups are used for transmitting the feature:

C212,7140 <Feature number (5-character) + description of feature (30-character, 1st-30th character)>

C212,7143 <Feature>

C212,3055 "91"

C212,7140 <Feature number (5-character) + description of feature (30-character, 31st-60th character)>

C212,7143 <Feature>

C212,3055 "91"

The description of the feature corresponds to element T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/FEATURE_TEXT and must be no longer than 30 characters.

If it is longer than 30 characters in a particular element, two data-element groups are selected, with the first one containing the first 30 characters, the second one the following 30 characters.

The feature number corresponds to attribute T_NEW_CATALOG/FEATURE_DEFINITION/FEATURES/FEATURE/OPTIONS/OPTION/OPTION_KEY and must be given in 5-character form.

If there is no option key for requested changes, the relevant field is left empty.

The option key remains empty + a 92 for change by the salesperson.

C212,3055 "92"

Variations in terms of catalogue ID, product range as well as plinth height can also be specified at item level in the relevant PIA segments that are also used in defining the standard header.

Specification of article type for long parts

As long-part article types in the sales manual often differ from the article types in order responses, the "article type" for these articles is communicated in an additional PIA segment in line with the table below:

PIA

4347 "1"

C212,7140 <ID according to table>

C212,7143 "BK"

C212,3055 "91"

Table: values 1 to 99 are congruent with EDIGRAPH

1 Plinth

2 Worktop

3 Wall seal profile

4 Light pelmet

5 Cornice

6 Projecting cornice panel

7 Railing

8 Ceiling infill panel

99 Obstacle

100 Block

101 Block credit note

102 Surcharge at item level

103 Surcharge added up for entire kitchen plan

As in the past, all long-part items will be ordered with coordinates and RFF segments. Mouldings and extended side panels are also designated with the relevant article type. In the order, article type, such as plinth, wall seal profile, light pelmet, cornice, ceiling infill panel etc., is shown in the PIA segment. In the planning system, this information is used for grouping together all articles of identical type and, later on in checking the order response, for comparing the total quantities for the particular article type.

Surcharges for which an article number exists are transmitted by specifying the article type.

By way of option, short article texts from the IDM master data are then transmitted in segment IMD:


IMD
ORDERS > UNB > LIN (article data) > IMD

Segment IMD must be used for the option of transmitting short article texts from the IDM master data.

Short article texts must always be transmitted in the IMD segment for the order response. The texts transmitted are the texts from the IDM data or if the texts from the PPS system provide more information on the situation being described, they can also be communicated.

IMD

7077 "F"

C273,7008 <1st line of short text from IDM data>

C273,7008 <2nd line of short text from IDM data>

The short texts must be taken from TEXT element of the first two TEXT_LINE element for element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE.

It only makes sense to communicate article texts for external articles; not for articles of the manufacturer that receives the order.

Texts relating to orders or special texts must be transmitted in the FTX segment - explained below - since there is no absolute need for the retailer or retailer system to process the IMD segments.

Standard article texts are not transmitted. Changes to article texts are of no relevance and are not electronically communicated.

Clear instructions must be provided for such instances.

By way of option, article dimensions are transmitted in the MEA segment:


MEA
ORDERS > UNB > LIN (article data) > MEA

By way of option, the article dimensions are transmitted after the PIA segment and any subsequent IMD segment:

MEA

6311 "AAE" (Measurement type = dimensions)

C502,6313 <Code in line with following table>

C174,6411 "MMT" (Unit of measurement = millimetre)

C174,6314 <Measurement>

Measurement code

WD Width

DP Depth

HT Height

All changes to the measurements of an article are transmitted. The measurements communicated are the measurements ordered for the article.


QTY
ORDERS > UNB > LIN (article data) > QTY

The article quantity must always be transmitted:

QTY

C186,6063 "21" (Type of quantity specification = delivery quantity)

C186,6060 <Quantity> (without decimal places)

C186,6411 "PCE" (Unit of quantity = piece)

The <quantity> must always be provided without decimal places, e.g. QTY+21:1:PCE'

For graphically relevant articles (i.e. articles that are also specified in the EDIGRAPH file), the quantity must always be set to 1 piece. A quantity other than 1 piece may only be transmitted for articles that are not of graphic relevance.

It must be noted that identical articles in the order must not be grouped together in the order response. If, for example, 3 cutlery trays are ordered as 3 individual items in a quantity of 1 each, these must not be confirmed as one item comprising 3 pieces. Instead, each item must be confirmed individually by stating the following reference numbers.

Articles for which lengths, areas or volumes are calculated are also ordered in the "piece" unit of measurement, with the relevant measurements being communicated in the above-mentioned MEA segments.


FTX
ORDERS > UNB > LIN (article data) > FTX

Optionally, freely worded texts may be sent for an item (no more than 99 lines and 70 characters per line).

However, the use of freely worded texts means that the order/confirmation cannot be processed without the interaction of a member of internal sales staff.

Freely worded texts must not, however, be misused to send information that can be communicated in structured form in other EDI segments.

FTX

4451 "LIN"

C108,4440 <Text>

3453 <ISO code of language used, e.g. "GB">

Additional text must generated for custom-made articles, both for front layouts as well as for dimensional changes outside the width, depth and height specified in the master data.


RFF
ORDERS > UNB > LIN (article data) > RFF

A number must always be provided that is used for explicitly referencing an article:

RFF

C506,1153 "LI"

C506,1154 <Reference number>

The reference number is issued by the retailer software. It is a unique number that remains the same throughout the entire duration of the order. Once issued, a number is never re-issued, even after the article has been deleted. It explicitly identifies each article throughout the order cycle (order, order change, order response). This number also provides a unique reference to the items in the EDIGRAPH file.

By way of option, further reference numbers can be provided:

RFF

C506,1153 "ON"

C506,1154 <Planning-system item number>

This number corresponds to the item numbering in the retailer's planning system. Example: "1.0", "5.1" or "9.1.2".•

RFF

C506,1153 "ACD"

C506,1154 <Merchandise management item number>

This number corresponds to the item numbers in the retailer's merchandise management system. Example: "1.0", "5.1" or "9.1.2".•

To ensure that an order item is explicitly referenced, each of the above reference numbers - provided a number is specified for an article in the order - must be returned with the corresponding order item by the manufacturer when communicating the order response via EANCOM-ORDRSP.

This ends the item section of the EDI message. It must always be followed by concluding segments: UNS UNT UNZ


UNS
ORDERS > UNB > UNS

The item section of the EDI message must always be followed by the concluding segments:

UNS

0081 "S"


UNT
ORDERS > UNB > UNT

The UNS segment must always be followed by segment:

UNT

0074 <Number of segments between UNH and UNT, including this one.>

0062 <identical to UNH 0062>


UNZ
ORDERS > UNZ

The UNT segment must always be followed by segment:

UNZ

0036 <Number of messages within the EDI file, currently always 1>

0020 <identical to UNB 0020>


Medium for transmitting order
ORDERS > Medium for transmitting order

The e-mail medium has been defined as the medium used for transmitting an order from the retailer to industry as it represents the most widespread and also most cost-effective solution.

The structure of the e-mail must comply with the following conventions so that sent e-mails can be processed automatically on both sides:

  • An e-mail always contains exactly one order for a commission for exactly one supplier.
  • The necessary files (EANCOM, optionally EDIGRAPH as well as sketches) are compressed into a ZIP file named "ORDER.ZIP". This ZIP file is the only attachment to the e-mail.
  • The EANCOM file within this ZIP file is always named "ORDER.EDI". The file names of optional files can be taken from the relevant EDI segments within the EANCOM file.
  • The subject line of the e-mail is structured as follows, with the elements listed in the pointed brackets being optional:
    EDI ORDER <Customer no.> <Commission no.> <Retailer software system name>.
  • The e-mail text is optional and merely serves to provide a clear overall picture, e.g. for archiving.
    For practical reasons, the text should contain the retailer's address, including customer number, the commission details as well as a list of file attachments.

Under no circumstances must the text contain additional, order-relevant information that is not also contained in the EANCOM file as the text is not evaluated by the recipient during automatic e-mail processing.


OSTRPT

Confirmation of order receipt

ETOCOM-OSTRPT

It is important for retailers to receive fast confirmation of receipt for an EDI order sent by e-mail, particularly if the order response is not sent immediately.

The confirmation of receipt assures the retailer that the e-mail has been received by the manufacturer and is being processed there.

For practical reasons, the confirmation of receipt to the retailer contains an order or transaction number for the retailer to refer to in the further business process.

Structure of an EDI confirmation of receipt in the EANCOM-OSTRPT format

UNA { Separator definition }

UNB { EDI file header }

UNH { Header of a message }

BGM { Beginning of message. Definition of order number etc. }

DTM { Date field - transaction dates }

FTX { Additional information at commission level }

RFF { Commission details (number or name }

NAD { Identification of parties involved (name/address) }

CTA { Specification of this party's contact person }

COM { Specification of how to reach the contact person, e.g. fax / phone }

UNS { Separator between item and end section }

UNT { End of message }

UNZ { End of EDI file }

The following segments in the header of an EDI message contain basic standardisation conventions and must always be provided.


UNB
OSTRPT > UNB

This segment is the user data header segment.

It is used for opening, identifying and describing an interchange file.

UNB

S001,0001 "UNOC"

S001,0002 "3"

S002,0004 <Sender identification (IDM manufacturer ID or ILN)>

S003,0010 <Recipient identification>

S004,0017 <Message creation date (format YYMMDD)>

S004,0019 <Message creation time (format SSMM)>

0020 <Unique reference number of EDI file>

0026 <Version number of sending system>

0032 <Version of order data format: "EANCOM_OSTRPT_V2.03">

0035 <Indication of whether this is a test message (1=test)>

Note:The name of the sending system is not sufficient, the system's current version number must also be transmitted.

Important: The name and version number of last sending system must always be communicated.


UNH
OSTRPT > UNB > UNH

The message header segment is used for opening, identifying and specifying a message.

UNH

0062 <Unique reference number of EDI message>

S009,0065 "OSTRPT"

S009,0052 "D"

S009,0054 "97A"

S009,0051 "UN"

Now the content section of the EDI message starts:

The next two segment must always be provided:

BGM

DTM


BGM
OSTRPT > UNB > BGM

This segment is the beginning of the message.

It is used for indicating the type and function of a message and for communicating the identification number.

BGM

C002,1001 "348" (Document type = order status report)

1004 <Order number>

1225 "6" (Confirmation)


DTM
OSTRPT > UNB > DTM

This segment contains date/time/period.

It is used for indicating the order date and -if necessary- dates requested for goods delivery.

DTM

C507,2005 "137" (Document date)

C507,2380 <Date>

C507,2379 "102" (Date format = YYYYMMDD)

The document date indicated in this segment is identical to the date shown in the UNB segment.

Optionally, the delivery dates can be specified by the supplier in the confirmation of order receipt. The DTM segments described for orders are used here in the same way.

By way of option, a date can also be communicated by which the order can still be changed. This, however, is a non-binding information.

DTM

C507,2005 "334" (Date type = status change)

C507,2380 <Date by which changes can be made>

C507,2379 "102" (Date format = YYYYMMDD)


FTX
OSTRPT > UNB > FTX

In the form of freely worded text (maximum of 99 lines, 70 characters per line) the retailer can be provided with information on the status of its order.

FTX

4451 "AAI"
C108,4440 <Text>
3453 <Language according to ISO code, e.g. DE>

The commission details are then provided in the REF segment.


RFF
OSTRPT > UNB > RFF

This is where the commission details are provided:

RFF

C506,1153 "CR"

C506,1154 <Commission number, e.g. "4711/01">

For further RFF segments, refer to EANCOM-ORDERS.

In addition to RFF segment "CR", as mandatory information, all other commission details contained in the order (EANCOM-ORDERS) must also be passed on.

Important:

When sending confirmation of receipt (EANCOM-OSTRPT), the manufacturer's system expects ALL commission details from the order to be sent back. This is the only way of making sure that the order and order response can be unequivocally matched up! Here, the commission details used must be exactly the same as those specified by the retailer in the corresponding RFF segments when ordering (EANCOM-ORDERS). No additions or changes to the commission details from the order are permitted!

By way of option, the order number issued by the manufacturer is specified in a further RFF segment. However, the number transmitted must be the supplier’s final order number that will also be used in the subsequent order response.

RFF

C506,1153 "VN"

C506,1154 <Order number, "12345/67">


NAD
OSTRPT > UNB > NAD

The commission details must always be followed by the supplier's address and the retailer's address as well as the address of any agent specified in the order:

NAD segments "NAD+SU", "NAD+BY" and "NAD+AB" are structured in exactly the same way as the segments in EANCOM-ORDERS. However, the "NAD+DP" segment for the supplier's address is not used.

In turn, further contact data should be provided for the Order Status Report because in the retail trade this information often goes to other members of staff.

For each of the NAD segments mentioned above, it is possible to provide details of contact persons (in the CTA segment) and how to reach them (in the COM segments). Here as well, the relevant segments are identical to those in EANCOM-ORDERS.


Medium for transmitting confirmation of receipt
OSTRPT > Medium for transmitting confirmation of receipt

E-mail is also defined as the medium for transmitting confirmation of receipt from industry to retailer.

The structure of the e-mail must comply with the following conventions so that sent e-mails can be processed automatically on both sides:

  • An e-mail always contains exactly one confirmation of receipt of an order for exactly one supplier.
  • The necessary EANCOM file is compressed into a ZIP file named "OSTRPT.ZIP". This ZIP file is the only attachment to the e-mail.
  • The EANCOM file within this ZIP file is always named "OSTRPT.EDI".
  • The subject line of the e-mail is structured as follows, with the elements listed in the pointed brackets being optional:
    EDI-OSTRPT <Supplier> <Commission no.>
  • The e-mail text is optional and merely serves to provide a clear overall picture, e.g. for archiving.

For practical reasons, the text should contain the supplier's address as well as the commission details.

Under no circumstances must the text contain additional information that is not also contained in the EANCOM file as the text is not evaluated by the recipient during automatic e-mail processing.


ORDRSP

Order response

EANCOM-ORDRSP

The order response is a response from the manufacturer to an order from the retailer. This is done using the EANCOM-ORDRSP format which is basically the same as the order format with prices added.

Within the kitchen furniture industry, however, the "block clearing" and "discounts" aspects must also be taken into account.

As many of the EDI segments used in the order response are identical to those of the order, the relevant segment descriptions are not repeated in this section. Reference is made to the documentation on EANCOM-ORDERS.

In general, the retailer's software system automatically compares the order response it receives with the underlying order as a means of drawing attention to any discrepancies.

This makes handling more efficient both for retailer and industry because everything is checked prior to delivery, possibly avoiding or at least reducing costly complaints.

Just as with orders, all relevant information (product range, options, article types etc.) must be consistent with the manufacturer's IDM master data in the order response as well.

Structure of an EDI order in EANCOM-ORDRSP format

UNA { Separator definition }

UNB { EDI file header}

UNH { Header of a message }

BGM { Beginning of message. Definition of order number etc. }

DTM { Date field - transaction dates }

FTX { Additional information at commission level }

RFF { Specification of commission data (number or name) }

NAD { Identification of parties involved (name/address) }

RFF { Specification of WEEE Reg. No.}

CTA { Specification of this party's contact person }

COM { Specification of how to reach the contact person, e.g. fax / phone }

CUX { Currency details }

PAT { Cash discount (days) }

PCD { Cash discount (per cent) }

LIN (Header data) { Beginning of a product range/option }

PIA { More detailed specification of an option }

LIN (Article data) { Beginning of a new item }

PIA { More detailed specification of the article: specification of options etc. }

IMD { Article description }

MEA { Article dimensions for dimension-specific articles }

QTY { Specification of order quantity }

MOA { Amount }

FTX { Additional information at item level }

PRI { Price specifications }

RFF { Reference numbers }

TAX { Tax information }

UNS { Separator between item and end section }

MOA { Totals }

UNT { End of message }

UNZ { End of EDI file }


UNB
ORDRSP > UNB

This segment is the user data header segment.

It is used for opening, identifying and describing an interchange file.

UNB

S001,0001 "UNOC"

S001,0002 "3"

S002,0004 <Sender identification (IDM manufacturer ID or ILN)>

S003,0010 <Recipient identification>

S004,0017 <Date message was generated (format YYMMDD)>

S004,0019 <Time message was generated (format SSMM)>

0020 <Unique reference number of EDI file>

0026 <Version number of sending system>

0032 <Version of order data format: "EANCOM_ORDRSP_V2.03">

0035 <Indication of whether this a test message (1=test)>


UNH
ORDRSP > UNB > UNH

The message header segment is used for opening, identifying and specifying a message.

UNH

0062 <Unique reference number of EDI message>

S009,0065 "ORDRSP"

S009,0052 "D"

S009,0054 "97A"

S009,0051 "UN"

S009,0057 "EAN005"

Now the content section of the EDI message starts:

The next two segment must always be provided:

BGM

DTM


BGM
ORDRSP > UNB > BGM

This segment is the beginning of the EDI message.

It is used for indicating the type and function of a message and for communicating the identification number.

BGM

C002,1001 "231" (Document type = order response)

1004 <Supplier's order number>

1225 "9" (Original)


DTM
ORDRSP > UNB > DTM

This segment contains date/time/period.

It is used for indicating the order date and -if necessary- dates requested for goods delivery.

DTM

C507,2005 "137" (Document date)

C507,2380 <Date>

C507,2379 "102" (Date format = YYYYMMDD)

The document date indicated in this segment is identical to the date shown in the UNB segment.

The confirmed delivery date is shown in a further DTM segment:

DTM

C507,2005 "2" (Date type = delivery date, exact)

or C5072,005 "63" (Date type = delivery date, latest)

or C507,2005 "64" (Date type = delivery date, earliest)

C507,2380 <Delivery date>

C507,2379 "102" (Date format = YYYYMMDD)

or C507,2379 "616" (Date format = YYYYWW, calendar week)

Date type "2" specifies that the delivery is to take place exactly on the requested delivery date or within the specified delivery week.

Date type "63"on the other hand, requests delivery by no later than the specified date although delivery may also made before this date. Date type "64" denotes that delivery is not to be made before the given date.

This means that date types "63" and "64" allow you to specify a delivery period either by stating a delivery week ("616") or a delivery day ("102").

The dates indicated are not the dates on which loading takes place at the supplier but the dates of delivery to the supplier.

If the order is a call order, the DTM segments with the delivery date are optional as no delivery date is requested by the retailer in such instances.

By way of option, a date can be communicated by which the order can still be changed. This, however, is a non-binding information.

DTM

C507,2005 "334" (Date type = status change)

C507,2380 <Date by which changes can be made>

C507,2379 "102" (Date format = YYYYMMDD)


FTX
ORDRSP > UNB > FTX

If, in addition to the EANCOM file, further files are to be sent to the manufacturer, these must be shown in the following segment:

FTX

4451 "ZZZ"
C108,4440 <File information>
3453 <Language according to ISO code, e.g. GB>

The <File information> field consists of the following components, each separated by a semicolon:

<File information>=<File type>;<File format>;<File name>;<File description>

File type

90 Order response

File format

50 PDF

File name

The file name, including extension, must be no longer than 30 characters.

The following characters must never be used within file names: ;$%&[]{} plus the characters not permitted by the Windows operating system |<>?*:/\" . Spaces are permitted, tabs and carriage returns are not. If the file name contains a single quotation mark ('), this must be masked with the character specified in the UNA segment so that it complies with the normal rules. Example: " ?' ".

File description

No more than 30 characters to describe the file in plaintext.

Example: "Order response"

Optionally, any chosen wording may be sent for the entire commission (no more than 99 lines and 70 characters per line). However, the use of freely worded text means that the order cannot be processed without the interaction of a member of internal sales staff.

Freely worded texts must not, however, be misused to send information that can be communicated in structured form in other EDI segments.

The FTX segments must only be used for communicating relevant information, platitudes (such as "thank you for your order") should always be avoided.

FTX

4451 "AAI"
C108,4440 <Text>
3453 <Language according to ISO code, e.g. GB>

The commission details are then provided in the REF segment.


RFF
ORDRSP > UNB > RFF

This is where the commission details are provided:

RFF

C506,1153 "CR"

C506,1154 <Commission number, e.g. "4711/01">

For further RFF segments, refer to EANCOM-ORDERS.

In addition to RFF segment "CR", as mandatory information, all other commission details contained in the order (EANCOM-ORDERS) must also be passed on.

Important:

When sending the order response (EANCOM-ORDRSP), the manufacturer's system expects ALL commission details from the order to be sent back. This is the only way of making sure that the order and order response can be unequivocally matched up!

Here, the commission details used must be exactly the same as those specified by the retailer in the corresponding RFF segments when ordering (EANCOM-ORDERS). No additions or changes to the commission details from the order are permitted!

This must now be followed by a further segment containing the supplier's order number.

If a final order number has already been communicated to the retailer with the EANCOM-OSTRPT message, it must be used here.

RFF
 C506,1153 "VN"

C506,1154 <Supplier's order number >

Order changes (ORDCHG) may result in more than one order response being sent for an order. This makes it necessary to specify which order or order change the order response refers to.

In a response to an order change, the value from the RFF+PP segment of the order change (these being numbered through from 1) is returned.

If the order response is a response to the initial order, the value 0 is returned.

This is also the default assumption if the following segment is missing.

RFF
 C506,1153 "PP"

C506,1154 <Order-change number or 0 for order>


NAD
ORDRSP > UNB > NAD

The commission details must always be followed by the address of the supplier, of the retailer, the delivery address and, if the manufacturer is obliged by law, the good disposal registration number (WEEE Reg. No.).

The relevant NAD segments are used for this, in a similar manner to EANCOM-ORDERS.

Note:

With an order response for a pickup order, the supplier's address is shown in the delivery address ("NAD+DP").

The WEEE Reg. No. unequivocally identifies the supplier for taking back and disposing of equipment.

From March 2006, the registration number must always be transmitted by suppliers required to do so by law.

The registration number identifying a manufacturer under the German Electrical and Electronic Equipment Act can be transmitted in the RFF segment following the NAD segment. The number is only entered in the message header if it applies to all articles.

For each of the NAD segments mentioned above, it is possible to provide details of contact persons (in the CTA segment) and how to reach them (in COM segments) - immediately after the particular NAD segment. The relevant segments are structured in the same way as those from EANCOM-ORDERS.


RFF
ORDRSP > UNB > NAD > RFF

The registration number identifying a manufacturer under the German Electrical and Electronic Equipment Act can be transmitted in the RFF segment following the NAD segment. The number is only entered in the message header if it applies to all articles.

RFF
 C506,1153 "XA"

C506,1154 <Goods disposal registration no. WEEE Reg. No.: DE 39896667


CUX
ORDRSP > UNB > CUX

The currency in which the order is confirmed must always be indicated.

CUX

C504,6347 "2"

C504,6345 <ISO code for currency, e.g. "EUR">

C504,6343 "10"


PAT
ORDRSP > UNB > PAT

If cash discounts are granted, they must be specified as follows:

PAT

4279 "22" Deduction

C112,2475 "5" Invoice date

C112,2009 "3" after date from C112,2475

C112,2151 "D" days

C112,2152 <Number of days>

Cash discounts are then specified as a percentage in the PCD segment.


PCD
ORDRSP > UNB > PAT > PCD

This is where cash discount is specified in per cent.

PCD

C501,5245 "12" Deduction in per cent

C501,5482 <Cash discount percentage>

C501,5249 "13" in relation to the invoice value


LIN (header data)
ORDRSP > UNB > LIN (header data)

The data segments at item level begin here:

Header data (options)

If the sender of the EANCOM message is a wood supplier, the commission header data are now specified (product range or options).

Here, a standard header is defined first. This contains details that apply to all supplier articles subsequently communicated. Any articles varying from this standard header are communicated at item level and overwrite the information given in the standard header.

The procedure corresponds to that of EANCOM-ORDERS.

The conventions for the order format also apply to the number and usage of PIA segments.

The details communicated (product range, options/features) must be consistent with the supplier's IDM master data.


LIN (article data)
ORDRSP > UNB > LIN (article data)

Following the header data, the articles are transmitted in individual LIN segments:

It is important only to confirm sales types. However, if a different manufacturing type is required on account of the way an appliance is fitted, this can be communicated in an additional PIA segment.

LIN

1082 <Consecutive number>

C212,7140 "EAN number of article, if available, otherwise empty"

C212,7143 "EN" if EAN number available, otherwise empty

1222 <Main/sub-item level>

In field 1222 all main items are given the value 1, sub-items the value 2, sub-sub-items the value 3 etc.


PIA
ORDRSP > UNB > LIN (article data) > PIA

Details of further product numbers

In addition to any EAN number that may have been communicated in the LIN segment, the sales type must now be specified for all articles:

PIA

4347 "5"

C212,7140 <T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO>

C212,7143 "SA"

C212,3055 "91"

By way of option, a different manufacturing type can be specified:

PIA

4347 "5"

C212,7140 <Manufacturing type>

C212,7143 "VP"

C212,3055 "91"

If an IT number has been issued for the article in the manufacturer's IDM data, it is shown in an additional PIA segment:

PIA

4347 "5"

C212,7140 <T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/EDP_NUMBER>

C212,7143 "MF"

C212,3055 "91"

Further additional information

In a similar way to the order format, this is now followed by further PIA segments for

  • Hinging
  • Construction type
  • Visible sides
  • Deviations from standard header data

Usage of the "Hinge" and "Construction Type" fields follow the conventions for the IDM format.

As a new aspect in the order response, it is now necessary to specify the article's merchandise group which must correspond to a value in element T_NEW_CATALOG/PRICE_DEFINITION/MERCHANDISE_GROUP/MERCHANDISE_GROUP_NO.

PIA

4347 "5"

C212,7140 <T_NEW_CATALOG/PRICE_DEFINITION/MERCHANDISE_GROUP/MERCHANDISE_GROUP_NO>

C212,7143 "CG"

C212,3055 "91

Specification of the article type for long parts, articles not ordered and option-related surcharges

The "article type" given in the table below must also be provided for all long part articles (plinths, light pelmets, cornices, wall seal profiles etc.) as well as the associated accessory articles (corner connectors, bag of wall seal profile accessories etc.). This also applies if items are communicated in ORDRSP for which no reference to an order item is given (RFF+LI missing).

An additional PIA segment is provided to communicate the article type for the items concerned.

PIA

4347 "1"

C212,7140 <ID according to table>

C212,7143 "BK"

C212,3055 "91"

Table: values 1 to 99 are congruent with EDIGRAPH

1 Plinth

2 Worktop

3 Wall seal profile

4 Light pelmet

5 Cornice

6 Projecting cornice panel

7 Railing

8 Ceiling infill panel

99 Obstacle

100 Block

101 Block credit note

102 Surcharge at item level

103 Surcharge added up for entire kitchen plan

In the PIA segments, parts are specified with article type in the logic of the system provider (refer to ORDERS "Specification of article type for long parts"). In comparing the order response with the order, all parts are added up and compared with the total quantity of the article type ordered.

If a divergent type is confirmed in the order response for an ordered article, the ref. number of the ordered article must still be communicated, e.g. appliance surrounds, blocks.

If a block is confirmed in the order response, the article's exchange ID - T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ADDITIONAL_PRICE_GROUP/EXCHANGE_ID_REF/EXCHANGE_ID_NO - must also be specified for each article.

PIA

4347 "5"

C212,7140 <Article's exchange ID>

C212,7143 "GU"

C212,3055 "91"

If surcharges are confirmed in the order response, the prices shown must be taken from the section on communicating surcharges within "Communicating prices".

It is now always necessary to transmit the article short texts in IMD segments.

The texts transmitted are the texts from the IDM data or if the texts from the PPS system provide more information on the situation being described, they can also be communicated.

Special texts must be transmitted in the FTX segment - explained later on - as there is no absolute need for the retailer's system to process the IMD segments.

By way of option, article dimensions are transmitted in the relevant MEA segments. Deciding which dimensions to transmit follows the same rule as for the EANCOM-ORDERS order.

The article quantity must always be transmitted in the QTY segment.

It must be noted here that identical articles in the order must not be grouped together in the order response. If, for example, 3 cutlery trays are ordered as 3 individual items in a quantity of 1 each, these must not be confirmed as one item comprising 3 pieces. Instead, each item must be confirmed individually by stating the following reference numbers.


IMD
ORDRSP > UNB > LIN (article data) > IMD

Short article texts must always be transmitted in the IMD segment for the order response. The texts transmitted are the texts from the IDM data or if the texts from the PPS system provide more information on the situation being described, they can also be communicated.

IMD

7077 "F"

C273,7008 <1st line of short text from IDM data>

C273,7008 <2nd line of short text from IDM data>

The short texts must be taken from TEXT element of the first two TEXT_LINE element for element T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/ITEM_TEXT/SHORT_TEXT/LANGUAGE.

Texts relating to orders or special texts must be transmitted in the FTX segment - explained later on - as there is no absolute need for the retailer or retailer system to process the IMD segments.


MOA
ORDRSP > UNB > LIN (article data) > MOA

The total price per item is communicated in the following MOA segment.

The number and measurements of all measurement-dependent price-calculation types are already included in the total price and list price.

MOA

C516,5025 "203"

C516,5004 <Total price of item, excluding VAT>


PRI
ORDRSP > UNB > LIN (article data) > PRI

The IDM-format list price is also transmitted:

PRI

C509,5125 "CAL"

C509,5118 <List price according to IDM format>

C509,5375 "CA"


RFF
ORDRSP > UNB > LIN (article data) > RFF

A number must always be provided that is used for explicitly referencing an article.

All reference information given in the order ("RFF+LI", "RFF+ON" as well as "RFF+ACD") must be specified when confirming an order item.

In the ORDRSP, the RFF+LI segment may occur several times per article if the retailer's system lists individual profiles in spite of the manufacturer confirming a package.

However, RFF+LI may only occur several times in the ORDRSP for articles that are grouped together. If 10 of the same article are ordered, confirmation will only be given for one item comprising 10 articles.

This procedure does not apply to long parts, these are to be collated via the new "containers".

If additional articles are confirmed in the order response that were not contained in the order, no RFF details are returned for these articles.

The supplier can specify its own reference numbers for an order-response item:

RFF

C506,1153 "VN"

C506,1154 <Supplier reference number>


TAX
ORDRSP > UNB > LIN (article data) > TAX

The underlying rate of value-added tax must always be communicated for each item:

TAX

5283 "7"

C241,5153 "VAT"

C243,5278 <Value-added tax in per cent>


Communicating prices
ORDRSP > UNB > Communicating prices

Described below, there are several procedures for communicating prices. However, the same principle always applies:

The sum total of all money amounts (whether positive or negative) from the MOA segments (with "C526,5025" = "203") corresponds to the order value of the order response, excluding VAT.

Article prices

  • Article prices can be communicated as net prices. In this case, any discounts (terms and conditions) have already been deducted.
  • Alternatively, article prices can be communicated as list prices. With this procedure, discounts are calculated and deducted as a sum total for each merchandise group.
  • In conjunction with block clearing, the prices of the planned articles can also be communicated as zero. In this case, only the block would have a price; instead, the extra charges would be specified for each exchange group. Alternatively, however, it is also possible to communicate the respective article prices "without/before block clearing" and instead show the reduced block prices for each exchange group.

Discounts

The discounts for each merchandise group can be calculated and deducted as a sum total. Using only the following segment, this is done by communicating an individual "discount article" for each merchandise group:

LIN

1082 <Consecutive number>

1222 <"1">

PIA

4347 "5"

C212,7140 <Merchandise group from IDM data record type 350>

C212,7143 "CG"

C212,3055 "91"

IMD

7077 "F"

C273,7008 <e.g. "Discount for merchandise group XYZ" >

MOA

C516,5025 "203"

C516,5004 <Total discount for merchandise group, normally a negative value!>

Block clearing

In a similar way to discounts, the surcharges or reduced prices for each exchange group are also communicated as "block articles", with only the following segments being used.

LIN

1082 <Consecutive number>

1222 <"1">

PIA

4347 "5"

C212,7140 <T_NEW_CATALOG/PRICE_DEFINITION/SET_OF_EXCHANGE_IDS/EXCHANGE_ID/EXC HANGE_ID_NO>

C212,7143 "GU"

C212,3055 "91"

IMD

7077 "F"

C273,7008 <e.g. "Surcharge/reduced price for exchange group XYZ" >

MOA

C516,5025 "203"

C516,5004 <Surcharge/reduced price for exchange group>

Surcharges are shown by a positive value, reduced prices by a negative value.

To document exchange procedures carried out within block clearing, an additional "exchange procedure article" can be communicated, with only the following segments being used. The exchange procedures are described in readable form in the IDM segment.

LIN

1082 <Consecutive number>

1222 <"1">

PIA

4347 "5"

C212,7140 <"BLOCKTAUSCH" >

C212,7143 "BT"

C212,3055 "ZZZ"

IMD

7077 "F"

C273,7008 <1st – 99th line>

Communicating surcharges

Here, surcharges are regarded as additional option-related charges that were defined in the IDM data under T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/ADDITIONAL_PRICE with a value of 1 = surcharge.

There are several ways of communicating surcharges depending on whether or not the manufacturer has additional article types of its own for which surcharges are made. If the manufacturer does have article types, these can be communicated individually for each article (cabinet) within the respective article item or in cumulative form at the end of planning. Each option combination within the surcharge group must be communicated separately. Various procedures can be selected for different surcharges (e.g. handle, glazing etc.). However, the procedure must remain consistent within a surcharge.

Surcharge without explicit article type

If the manufacturer has no explicit article type for the surcharge, the procedure is as follows:

  • No separate article is created for the surcharge, instead the relevant surcharge data are communicated on the basis of the article concerned.
  • The surcharge is added to the normal article price and communicated as the article's total price in the MOA or PRI segment.
  • The option(s) on the basis of which the surcharge was calculated must be communicated as PIA segment(s). This is the same as the procedure for the order (ORDERS).
  • Article type 102 is not specified in the PIA segment under qualifier "BK".

Surcharge with article type at item level

If the manufacturer does have an article type for the surcharge and wishes to indicate such for each item, the procedure is as follows:

  • The surcharge is created as a separate article.
  • In the associated LIN segment, the surcharge must be defined as a sub-item belonging to the article concerned.
  • If a reference to the order item has been made for the higher-level article (RFF+LI), this reference must also be specified for the surcharge item.
  • 102 is specified as the article type for the surcharge (see PIA segment for "article type").
  • The option(s) on the basis of which the surcharge was calculated must be communicated as PIA segment(s).
  • The surcharge for individual items is specified in the MOA or PRI segment.

LIN

1082 <Consecutive number>

1222 <"2">

PIA

4347 "5"

C212,7140 <T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO>

C212,7143 "SA"

C212,3055 "91"

PIA

4347 "1"

C212,7140 <Feature number (5-character) + feature text (30-character)>

C212,7143 <Feature according to T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FEATURE_NO_1 as well as any FEATURE_NO_2>

C212,3055 "91"

PIA

4347 "1"

C212,7140 "102" = surcharge from item level

C212,7143 "BK"

C212,3055 "91"

IMD

7077 "F"

C273,7008 <e.g. Surcharge group 123" >

QTY

C186,6063 "21" (Type of quantity specification = delivery quantity)

C186,6060 <Quantity> (without decimal places)

C186,6411 "PCE" (unit of quantity = piece)

MOA

C516,5025 "203"

C516,5004 <Surcharge from surcharge group>

PRI

C509,5125 "CAL"

C509,5118 <List price according to IDM format>

C509,5375 "CA"

RFF

C506,1153 "LI"

C506,1154 <Reference number of main item generating the surcharge>

Surcharge added up with article type for entire kitchen plan.

If the manufacturer does have an article type for the surcharge and wishes to add this up for all items in the kitchen being planned, the procedure is as follows:

  • The surcharge is created as a separate article at the end of the parts list.
  • In the associated LIN segment, the surcharge must be defined as a main item.
  • As the surcharge is added up and specified for several articles, there is no need to make any reference (RFF+LI) to the order item.
  • Article type 103 is specified as the surcharge (see PIA segment for "article type").
  • The option(s) on the basis of which the surcharge was calculated must be communicated as PIA segment(s).
  • The surcharge for all items is specified in the MOA or PRI segment.

LIN

1082 <Consecutive number>

1222 <"1">

PIA

4347 "5"

C212,7140 <T_NEW_CATALOG/SERIES/SERIE/PRODUCT_GROUPS/PRODUCT_GROUP/ITEMS/ITEM/TYPE_NO>

C212,7143 "SA"

C212,3055 "91"

PIA

4347 "1"

C212,7140 <Feature number (5-character) + feature text (30-character)>

C212,7143 <Feature according to T_NEW_CATALOG/PRICE_DEFINITION/PRICE_FEATURE_GROUPS/PRICE_FEATURE_GROUP/FEATURE_NO_1 as well as any FEATURE_NO_2>

C212,3055 "91"

PIA

4347 "1"

C212,7140 "103" = surcharge added up for entire kitchen plan

C212,7143 "BK"

C212,3055 "91"

IMD

7077 "F"

C273,7008 <e.g. Surcharge group 123" >

QTY

C186,6063 "21" (Type of quantity specification = delivery quantity)

C186,6060 <Quantity> (without decimal places)

C186,6411 "PCE" (unit of quantity = piece)

MOA

C516,5025 "203"

C516,5004 <Surcharge for options within a surcharge group for overall planning>

PRI

C509,5125 "CAL"

C509,5118 <List price according to IDM format>

C509,5375 "CA"


UNS
ORDRSP > UNB > UNS

The item section is now followed by the sum-total section of the EDI message.

UNS

0081 "S"

Here, various amounts can or must be transmitted in MOA segments. The codes for this are shown in the table below.


MOA
ORDRSP > UNB > MOA

Various amounts can or must be transmitted in MOA segments, with the codes for this being shown in the table below.

MOA

C516,5025 <Codes according to table>

C516,5004 <Amount>

Code | Meaning |
79 | Sum total of all items, excluding VAT | Mandatory
124 | Sales tax amount | Mandatory
106 | Packaging costs | Optional
64 | Freight costs | Optional
86 | Order total, including VAT | Mandatory
200 | Amount of advance payment | Optional

This completes the sum-total section of the EDI message. It must always be followed by the following concluding segments:

UNT

UNZ


Medium for transmitting the order response
ORDRSP > Medium for transmitting the order response

E-mail is also defined as the medium for transmitting an order response from industry to retailer.

The structure of the e-mail must comply with the following conventions so that sent e-mails can be processed automatically on both sides:

  • An e-mail always contains exactly one order response for a commission for exactly one supplier.
  • The necessary files (EANCOM, optional attachments) are compressed into a ZIP file named "ORDRSP.ZIP". This ZIP file is the only attachment to the e-mail.
  • The EANCOM file within this ZIP file is always named "ORDRSP.EDI". The file names of optional files can be taken from the relevant EDI segments within the EANCOM file.
  • The subject line of the e-mail is structured as follows, with the elements listed in the pointed brackets being optional:

    EDI-ORDRSP <Supplier> <Commission no.>
  • The e-mail text is optional and merely serves to provide a clear overall picture, e.g. for archiving.

For practical reasons, the text should contain the supplier's address, the commission details as well as a list of attached files.

Under no circumstances must the text contain additional information that is not also contained in the EANCOM file as the text is not evaluated by the recipient during automatic e-mail processing.


ORDCHG

Order change

EANCOM-ORDCHG

Order change enables the retailer to make subsequent changes to an order already submitted. This is done using the EANCOM-ORDCH format which is basically the same as the order format (EANCOM-ORDERS).

As most of the EDI segments used for the order change are identical to those of the order, the relevant segment descriptions are not repeated in this section. Reference is made to the documentation on EANCOM-ORDERS. Deviations or additionally used segments are documented in the following.

Fundamental procedure:

In an order change, the complete Order (including all address information, header data, article items, file attachments etc.) is always transmitted in the same way as the initial order.

An additional ID is introduced for the article items indicating whether and the extent to which the individual article has changed.

It is left to the supplier's discretion to decide whether to cancel the existing order and create a new order with the order change, or whether to correct the existing order on the basis of the changes specified.

Structure of anEDI order in EANCOM-ORDCHG format

UNA { Separator definition }

UNB { EDI file header}

UNH { Header of a message }

BGM { Beginning of message. Definition of order number etc. }

DTM { Date field - transaction dates }

FTX { Additional information at commission level }

RFF { Additional information at commission level }

NAD { Identification of parties involved (name/address)

CTA { Specification of this party's contact person }

COM { Specification of how to reach the contact person, e.g. fax / phone }

LIN (Header data) { Beginning of a product range/option }

PIA { More detailed specification of an option }

LIN (Article data) { Beginning of a new item }

PIA { More detailed specification of the article: specification of options etc. }

IMD { Article description }

MEA { Article dimensions for dimension-specific articles }

QTY { Specification of order quantity }

FTX { Additional information at item level }

RFF { Reference numbers }

UNS { Separator between item and end section }

UNT { End of message }

UNZ { End of EDI file }

The following segments in the header of an EDI message contain basic standardisation conventions and must always be provided.


UNB
ORDCHG > UNB

This segment is the user data header segment.

It is used for opening, identifying and describing an interchange file.

UNB

S001,0001 "UNOC"

S001,0002 "3"

S002,0004 <Sender identification, e.g. trading company>

S003,0010 <Recipient identification (IDM manufacturer ID or ILN)> >

S004,0017 <Message creation date (format YYMMDD)>

S004,0019 <Message creation time (format SSMM)>

0020 <Unique reference number of EDI file>

0026 <Version number of sending system>

0032 <Version of order data format: "EANCOM_ORDCHG_V2.03">

0035 <Indication of whether this is a test message (1=test)>


UNH
ORDCHG > UNB > UNH

The message header segment is used for opening, identifying and specifying a message.

UNH

0062 <Unique reference number of EDI message>

S009,0065 "ORDCHG"

S009,0052 "D"

S009,0054 "97A"

S009,0051 "UN"

S009,0057 "EAN007"

Now the content section of the EDI message starts:

The next two segment must always be provided:

BGM

DTM


BGM
ORDCHG > UNB > BGM

This is where the content section of the EDI message starts:

The BGM segment here differs from the one used in the order:

BGM

C002,1001 "231" (Document type = order change)

1004 <Order or order number>

1225 "4" (Change)


RFF
ORDCHG > UNB > RFF

The references (commission number / name, purchase contract number) are provided in the same way as for the (ORDERS) order.

However, if the manufacturer has already issued an order number for the original order and sent the number to the retailer (e.g. via ORDRSP), it must also be transmitted with the order change:

RFF

C506,1153 "VN"

C506,1154 <Order number, "12345/67">

As an order may involve sending more than one order change, it is imperative that each order change can be provided with unique identification. To do this, each change to every order is numbered through from 1.

The supplier refers to this number in the order response (ORDRSP).

RFF

C506,1153 "PP"

C506,1154 <Order-change number, e.g. "1">


FTX
ORDCHG > UNB > LIN (article data) > FTX

For article items, all segments can be used that are also permissible in an order.

By way of option, it is possible to indicate whether and the extent to which the item has changed.

FTX

4451 "ZZZ" (Agreed bilaterally)

4453 "3" (For immediate use)

C107,4441 <Change indicator>

C107,3055 "ZZZ" (Agreed bilaterally)

Possible change indicators are:

Value | Meaning
0 | No change
1 | The change was commercially and/or graphically relevant.
2 | The article itself is unchanged, but the article coordinates have changed, e.g. because another article has been added.


Medium for transmitting an order change
ORDCHG > Medium for transmitting an order change

E-mail is also defined as the medium for transmitting an order change from retailer to industry.

The structure of the e-mail must comply with the following conventions so that sent e-mails can be processed automatically on both sides:

  • An e-mail always contains exactly one order change for a commission for exactly one supplier.
  • The necessary files (EANCOM, optional attachments) are compressed into a ZIP file named "ORDCHG.ZIP". This ZIP file is the e-mail's only attachment.
  • The EANCOM file within this ZIP file is always named "ORDCHG.EDI". The file names of optional files can be taken from the relevant EDI segments within the EANCOM file.
  • The subject line of the e-mail is structured as follows, with the elements listed in the pointed brackets being optional:

    EDI-ORDCHG <Supplier> <Commission no.>
  • The e-mail text is optional and merely serves to provide a clear overall picture, e.g. for archiving.

For practical reasons, the text should contain the supplier's address, the commission details as well as a list of attached files.

Under no circumstances must the text contain additional information that is not also contained in the EANCOM file as the text is not evaluated by the recipient during automatic e-mail processing.


EANCOM

Electronic interchange of orders for planning-intensive furniture

Documentation

Effective 01.07.2017

Conventions on the basis of

EANCOM 97A

Contact:

Daten Competence Center e. V. Dr.-Ing. Olaf Plümer, Managing Director

Goebenstrasse 4-10

D - 32052 Herford

Tel.: + 49 5221 12 65 37

Fax.: + 49 5221 12 65 537
E-mail: DCC.Herford@web.de

Info: www.vhk-herford.de